10 cách khôi phục tập tin Excel bị lỗi

Chia sẻ: Vu Trung | Ngày: | Loại File: DOC | Số trang:6

1
814
lượt xem
306
download

10 cách khôi phục tập tin Excel bị lỗi

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Các tập tin bảng tính Excel, cũng như Word, một khi bị lỗi sẽ gây ra hàng loạt rắc rối cho người dùng văn phòng. Bạn có thể tham khảo 10 cách khôi phục tập tin bảng tính dưới đây trước khi tính tới chuyện... ngồi khóc hay làm lại từ đầu.

Chủ đề:
Lưu

Nội dung Text: 10 cách khôi phục tập tin Excel bị lỗi

  1. 10 cách khôi phục tập tin Excel bị lỗi Các tập tin bảng tính Excel, cũng như Word, một khi bị lỗi sẽ gây ra hàng loạt rắc rối cho người dùng văn phòng. Bạn có thể tham khảo 10 cách khôi phục tập tin bảng tính dưới đây trước khi tính tới chuyện... ngồi khóc hay làm lại từ đầu. 1. Thử khôi phục bằng phương án thủ công Nếu tính năng tự động khôi phục lỗi của Excel tậm tịt, bạn có thể thực hiện công việc này bằng tay: 1. Mở tập tin từ menu File. Đối với Excel 2007, hãy click vào nút Office và chọn Open. 2. Sử dụng bảng điều khiển Look In, tìm và xác định workbook bị lỗi. 3. Từ danh sách sổ xuống của nút Open, chọn Open And Repair.
  2. 5. Thử chuyển tập tin sang nơi khác Đôi khi một tập tin bảng tính bị lỗi không hẳn do những nguyên nhân từ phần mềm hay sai lầm khi sử dụng của người dùng. Rất có thể nó đang tạm không truy cập được nữa, các hệ thống mạng và máy chủ thường vẫn đánh dấu chúng là những tập tin lỗi. Trong trường hợp gặp phải lỗi được xác định có nguyên nhân tương tự và Excel không thể sửa được, bạn hãy chuyển tập tin sang một thư mục, ổ đĩa hoặc máy chủ khác. 6. Hãy để OpenOffice “ra tay” Một số người khẳng định cảm thấy hoàn toàn bất ngờ với kết quả mỹ mãn khi sử dụng bộ ứng dụng OpenOffice để sửa chữa tập tin lỗi của Excel. Đây là công cụ mã nguồn mở miễn phí lừng danh. Nếu không thể xử lý được tập tin bảng tính bị lỗi trên Excel, hãy dùng tới Calc của OpenOffice. Tất nhiên, việc này thường kỳ công và phức tạp hơn bạn tưởng. 7. Mở tập tin lỗi trên WordPad hoặc Word Nếu bạn không thể sửa được tập tin bảng tính bị lỗi, hãy thử mở bằng WordPad. Nếu thành công, WordPad sẽ chuyển đổi tất cả mọi thứ sang dạng văn bản. Tất nhiên, điều này không hẳn đã làm bạn hoàn toàn hài lòng ngoài niềm vui có thể lấy lại được dữ liệu. Phương án này sẽ không thể khôi phục được các định dạng font, bảng... Tuy nhiên, không giống như một số phương án khôi phục dữ liệu khác, WordPad sẽ giúp bạn phục hồi các macro. Hãy sử dụng lệnh tìm kiếm Sub và Function trên khối dữ liệu đã khôi phục được để tìm chúng. Bạn cũng có thể mở tập tin .xls bị lỗi trên Word, nhưng kết quả thường khá giới hạn. Với phương án này, bạn phải cài đặt công cụ chuyển đổi Microsoft Office Excel. Không như WordPad, Word không khôi phục được các macro. 8. Xử lý các cell bị lỗi để khôi phục dữ liệu Đôi khi bạn có thể khôi phục dữ liệu bằng cách xử lý các cell trên tập tin lỗi. Bạn sẽ không thể lấy lại được định dạng, biểu đồ, macro... nhưng khôi phục được dữ liệu cũng đã là quá may rồi. Quy trình thực hiện như sau:
  3. 1. Mở một workbook mới, nhập vào cell A1 công thức sau đây để dẫn tới cell A1 trong tập tin lỗi: tên của tập tin lỗi!A1. (Bạn không cần phải thêm .xls). 2. Nhấp Enter. 3. Nếu tập tin lỗi không ở cùng thư mục, Excel sẽ hiển thị hộp thoại Update Values: tên của tập tin bị lỗi. Bạn hãy sử dụng bảng điều khiển Look In để xác định tập tin bị lỗi. Chọn tập tin này và click OK. 4. Nếu hộp thoại Select Sheet xuất hiện, bạn hãy chọn sheet phù hợp và click OK. Excel sẽ hiển thị giá trị cell A1 của tập tin lỗi. 5. Chọn cell A1 và kéo ngang qua các cột mà bạn cảm thấy cần để có thể khôi phục dữ liệu. Nếu Excel hiển thị hộp thoại Update Values - tên tập tin bị lỗi, bạn hãy chọn tập tin lỗi và click OK. 6. Lặp lại bước 5, nhân bản hàng A theo số lượng hàng bạn cảm thấy đủ để khôi phục tập tin lỗi. 7. Chọn dữ liệu và nhấp Copy từ menu Edit. 8. Chọn Paste Special từ menu Edit, chọn Values. 9. Click OK. 9. Thử định dạng SYLK để khôi phục dữ liệu
  4. Chuyển sang định dạng khác là phương án xử lý khá hiệu quả khi Excel bị lỗ i Microsoft khuyến cáo sử đụng định dạng SYLK để tránh khỏi bị lỗi khi dùng Excel, nhất là các lỗi liên quan đến máy in. Bạn có thể mở tập tin Excel bị lỗi bằng cách này: 1. Từ menu File, chọn Save As. Trên Excel 2007, click vào nút Office. 2. Từ bảng điều khiển Save As Type, chọn SYLK(Symbolic Link) (*.slk). 3. Đặt tên. Nếu tập tin lỗi có một sheet, việc này là không cần thiết. 4. Click vào Save. 5. Nếu tập tin workbook có nhiều sheet, Excel sẽ hỏi bạn có tiếp tục sử dụng định dạng không hỗ trợ nhiều sheet cùng lúc hay không. Click vào O K.
  5. 6. Nếu Excel cảnh báo bạn có thể workbook gồm một số định dạng không tương thích với SYLK, bạn hãy chọn Yes. Lưu ý là định dạng SYLK chỉ lưu lại những sheet đang sử dụng. Để khôi phục dữ liệu, bạn cần mở lại tập tin Excel và lưu lại từng sheet một. Đó là lý do vì sao ở bước 3 bạn cần đặt tên cho từng sheet trên workbook để tránh nhầm lẫn sau này. Sau khi đã lưu lại tất cả các sheet theo dạng mới, bạn hãy mở tập tin .slk và sửa thành .xls. Cẩn thận, không sử dụng tên của tập tin workbook bị lỗi. Nếu thành công, bạn có thể lưu lại được các giá trị từ công thức đã nhập nhưng các công thức thì không. 10. Khôi phục các macro Nếu có thể khôi phục dữ liệu nhưng vẫn bó tay trước các macro, bạn có thể lưu lại được chúng theo cách sau đây: 1. Mở Excel, đừng mở những workbook lỗi. 2. Đặt chế độ tính toán sang dạng thủ công (thủ thuật 3 ở trên). 3. Chọn Macro từ menu Tools, chọn Security và sau đó chọn High. Trên Excel 2007, hãy nhấp vào nút Office --> Excel Options, và chọn Trust Center phía trái bảng. Sau đó, click vào nút Trust Center Settings, chọn Macro Settings, sau đó chọn Disable All Macros Without Notification trên vùng cài đặt Macro Settings. Cuối cùng nhấp OK hai lần.
  6. 4. Mở tập tin bị lỗi. Nếu Excel mở được, bạn sẽ thấy một thông báo cho biết hiện macro đang được tắt. Nếu Excel tắt đi, phương pháp này coi như thất bại. 5. Nhấp tổ hợp [Alt]+[F11] để mở Visual Basic Editor (VBE). 6. Sử dụng Project Explorer (nhấp [Ctrl]+R), click chuột phải vào module và chọn Export File) 7. Nhập tên và thư mục của module. 8. Lặp lại bước 6 và 7 theo ước chừng của bạn, đủ để trích xuất tất cả các module. 9. Đóng VBE và thoát Excel. 10. Mở một workbook trống (hoặc workbook mới chứa dữ liệu mới khôi phục được) và nhập các module.
Đồng bộ tài khoản