1001 thủ thuật máy tính P28

Chia sẻ: Son Nguu | Ngày: | Loại File: PDF | Số trang:8

0
163
lượt xem
115
download

1001 thủ thuật máy tính P28

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

249. Bảo vệ công thức trong Microsoft Excel Một bảng tính Excel thông thường có hai phần: dữ liệu “thô” là số liệu thực tế và phần công thức để tính toán. Công thức để tính toán đôi khi khá phức tạp và đòi hỏi nhiều công sức, còn dữ liệu thô thì có thể ai nhập cũng được. Do đó, vấn đề sẽ không còn đơn giản nếu trong bảng tính có chỗ ta muốn bảo vệ mà có chỗ lại không. Cách làm của tôi trong việc bảo vệ công thức là cứ để các ô bị locked...

Chủ đề:
Lưu

Nội dung Text: 1001 thủ thuật máy tính P28

  1. 249. Bảo vệ công thức trong Microsoft Excel Một bảng tính Excel thông thường có hai phần: dữ liệu “thô” là số liệu thực tế và phần công thức để tính toán. Công thức để tính toán đôi khi khá phức tạp và đòi hỏi nhiều công sức, còn dữ liệu thô thì có thể ai nhập cũng được. Do đó, vấn đề sẽ không còn đơn giản nếu trong bảng tính có chỗ ta muốn bảo vệ mà có chỗ lại không. Cách làm của tôi trong việc bảo vệ công thức là cứ để các ô bị locked theo mặc định, không cần phải thay đổi gì. Nhưng khi người dùng thay đổi (kể cả việc xóa) các ô có công thức (bắt đầu bằng dấu = ) thì việc khóa sẽ thực hiện (giống như vào menu Tools -> Protect Sheet). Còn khi người dùng thay đổi ô không phải là công thức thì việc thay đổi sẽ được chấp nhận (tương đương với việc chọn Tools\Unprotect Sheet) Vào menu Tools - Macro - Visual Basic Editor Cửa sổ soạn thảo Visual Basic hiện ra, khung bên trái là Project Explore (nếu chưa thấy thì chọn menu View - Project Explorer). Nhấp kép chuột vào This WorkBook, gõ vào khung soạn thảo bên phải đoạn mã Private Sub Workbook_SheetSelectionChange (ByVal Sh As Object, ByVal Target As Range) Dim rng As Range For Each rng In Target.Cells If rng.HasFormula Then ActiveSheet.Protect Exit Sub Else ActiveSheet.Unprotect End If Next rng End Sub Đóng cửa sổ Visual Basic Editor, lưu và thoát khỏi Excel. Kể từ đây, các công thức sẽ được bảo vệ.
  2. - Một số dữ liệu dù bản chất không là công thức nhưng bạn muốn nó không bị thay đổi thì có thể nhập như dưới dạng công thức với dấu bằng để có thể được bảo vệ luôn, chẳng hạn =290.000 thay vì là một con số 290.000 - Người dùng có thể “táy máy” chọn Tools\Unprotect Sheet để sửa đổi, vì vậy cần đặt thêm mật khẩu trong đoạn mã trên: Ở câu lệnh ActiveSheet.Protect ta viết thành (giả sử mật khẩu là “123456”): ActiveSheet.Protect(“123456”) Và do đó ở câu lệnh ActiveSheet.Unprotect phải sửa lại là: ActiveSheet.Unprotect(“123456”) - Nếu cẩn thận hơn, phòng người dùng vào Visual Basic Editor để “dòm” mật khẩu (giả sử tên book của bạn là bangtinh) thì mở cửa sổ Visual Basic Editor - khung Project Explorer, nhấp phải vào VBAProject(bangtinh.xls) - Properties - thẻ Protection, chọn Lock project for viewing - gõ mật khẩu - lưu và thoát khỏi Excel. 250. Chia sẻ máy in trong Windows XP Có thể vào một ngày đẹp trời nào đó tại nơi làm việc, bạn được trao quyền quản lý một cái máy in. Người ta khệ nệ bưng máy in đến chỗ bạn ngồi và nối nó với máy tính của bạn. Nếu máy tính của bạn đang chạy Windows XP thì việc cài đặt máy in cực kỳ đơn giản: bạn không phải làm gì cả, Windows XP tự động nhận biết máy in mới và hiển thị ở thanh tác vụ thông báo ngắn gọn Found New Hardware kèm theo tên của máy in. Từ lúc đó, bạn có thể thoải mái in ra giấy trên máy in mới bằng những công cụ quen thuộc: Word, Excel... Có điều đáng quan tâm, từ ấy bạn sẽ phải chịu áp lực: cho phép đồng nghiệp dùng máy in ấy thông qua mạng cục bộ (printer sharing). Và cũng từ ấy, bạn sẽ phải chịu tiếng ồn máy in và
  3. thường xuyên giật mình vì bất ngờ máy in bị ai đó cho chạy. Nhưng biết làm sao hơn khi sếp đã giao nó cho bạn. Chia sẻ máy in Để “se” (share) cái máy in “của nợ từ trên trời rớt xuống” ấy cho đồng nghiệp, bạn phải vào thư mục Printers and Faxes. Cụ thể, bạn làm như sau: Bấm nút Start, chọn Control Panel. Trong cửa sổ Control Panel, bạn mở Printers and Other Hardware rồi mở Printers and Faxes. Trong cửa sổ Printers and Faxes, bạn bấm-phải vào biểu tượng máy in và chọn Sharing trên trình đơn vừa hiện ra. Trong hộp thoại Properties, bạn chọn thẻ Sharing, chọn Share this printer và đặt tên cho máy in trong ô Share name. Tên máy in do bạn đặt sẽ giúp mọi người trong mạng hiểu ngay máy in đó thuộc loại gì, có ưu điểm gì (chẳng hạn, máy in màu hay “đen trắng”). Nếu thực tình... không muốn người ta dùng máy in, bạn có thể đặt tên chi đó thật “gợi hình gợi cảm” đại khái như May in LaserJet 6L ca rich ca tang (chuyện này nói nhỏ thôi nghen!). Xong xuôi, bạn bấm OK. Cần nói thêm rằng nếu trong mạng cục bộ của bạn vẫn còn những máy tính chạy Windows 95/98/ME, Windows NT 4.0 hoặc Windows 2000, bạn phải cài đặt bổ sung các trình điều khiển máy in (printer driver) thích hợp thì “người ta” mới dùng được máy in của bạn. Muốn vậy, trên hộp thoại Properties ứng với máy in đang xét, sau khi đặt tên Share name, bạn hãy... khoan bấm OK mà “chịu khó” chọn Additional Drivers. Trên hộp thoại Additional Drivers, bạn chọn trình điều khiển máy in cần thiết rồi bấm OK. Bạn sẽ được yêu cầu đưa đĩa Support trong bộ đĩa Windows XP vào ổ CD. Cài đặt máy in được chia sẻ Để cài đặt máy in nào đó đã được chia sẻ, bạn thực hiện các bước như sau: Vào thư mục Printers and Faxes. Nghĩa là phải bấm nút Start, chọn Control Panel, chọn Printers
  4. and Other Hardware rồi chọn Printers and Faxes. Trong cửa sổ Printers and Faxes, bạn chọn Add a printer trong danh sách Printers tasks. Hộp thoại Add Printer Wizard sẽ hiện ra ngay. Bấm vào Next để bỏ qua trang đầu (Welcome to the Add Printer Wizard) của hộp thoại Add Printer Wizard. Trên trang tiếp theo (Local or Network Printer), bạn chọn A network printer, or a printer attached to another computer rồi bấm Next. Trên trang Specify a Printer, bạn có thể chọn Browse for a printer và bấm Next để truy tìm máy in được chia sẻ trên mạng. Thông thường, bạn biết rõ tên của máy in được chia sẻ và tên của máy tính nối trực tiếp với máy in đó. (Quá dễ, bạn chỉ việc đi ngay đến chỗ ngồi của “khổ chủ” của máy in và cười thật... dễ thương, chắc chắn bạn sẽ được chỉ dẫn tận tình. Dù thế nào cũng phải nói với người ta một tiếng trước khi dùng máy in.) Thế thì bạn chọn Connect to this printer, gõ vào ô Name bên dưới theo dạng thức như sau: \\TênMáyTính\TênMáyInĐượcChiaSẻ rồi bấm Next. Trên trang Default Printer, bạn chọn Yes nếu muốn máy in “chùa” trở thành máy in mặc định của mình. Bạn có thể chọn No nếu có máy in riêng (nối trực tiếp với máy tính của bạn) và chỉ muốn nhờ vả người ta khi thật cần thiết (“dù trong dù đục ao nhà vẫn hơn”). Xong, bạn lại bấm Next. Trên trang cuối cùng Completing the Add Printer Wizard, bạn chỉ việc bấm Finish là xong. Từ đó, máy in mà bạn “mong mỏi” sẽ xuất hiện trong cửa sổ Printers and Faxes một cách “đàng hoàng”, bên cạnh máy in riêng của bạn (nếu có). Bạn hãy kiểm tra ngay xem có phải như vậy không.
  5. 251. Sử dụng thanh công cụ Word Count Khi muốn thống kê xem văn bản của mình đã dài bao nhiêu ký tự, nếu nhờ vả thanh công cụ Word Count, bạn sẽ mất ít thời gian hơn thay vì phải ngồi đếm từng chữ. Để mở nó, bạn vào menu View - Toolbars - Word Count hoặc vào menu Tools - Word Count - nhấn nút Show Toolbar Bạn chỉ việc nhấn nút Recount là mọi thông tin mong muốn sẽ hiện ra. Trong trường hợp muốn thống kê thông tin của đoạn văn bản thì trước khi nhấn Recount, bạn cần đánh dấu đoạn văn bản đó trước. 252. Thêm và thay đổi menu ngữ cảnh (context menu) của File, Thư mục và Drive Menu ngữ cảnh (context menu) là cái gì nhỉ? À, chính là cái menu bạn thấy khi nhấn chuột phải ấy mà. Ừ thì đúng là menu đấy, nhưng sao gọi là ngữ cảnh chứ? Vì tùy vào từng đối tượng bạn đang trỏ vào sẽ có một menu tương ứng với nó. Nghĩa là với các đối tượng khác nhau thì menu này sẽ khác nhau. Tùy chọn in đậm “Play” sẽ là mục chọn ngầm định khi bạn nháy đúp chuột trái. Các mục khác như “Eject”, “AutoPlay” chỉ có với ổ đĩa CD mà thôi. Một số chương trình như ACDSee, Winzip, Winrar... có thể thêm các mục chọn vào menu ngữ cảnh. Vậy chúng ta có thể làm điều đó được không vậy? Tất nhiên là được. Sau đây tôi xin hướng dẫn cách thêm một mục vào context menu của ổ đĩa cứng. Trong quá trình hoạt động, các ổ đĩa Windows sẽ bị phân mảnh (fragment), và ngày càng chạy chậm đi vì nguyên nhân này. Vì thế đòi hỏi ta phải thực hiện Defragment (giải phân mảnh). Để đơn giản quá trình, ta thêm một mục tên là “Defrag this” vào context menu của các ổ đĩa cứng
  6. như sau: Mở NotePad, nhập vào đoạn mã bên dưới rồi lưu lại với tên AddDefItem.inf: [version] signature=”$CHICAGO$” [DefaultInstall] AddReg=AddMe [AddMe] HKCR, ”Drive\Shell\Defragthis\command”,,,”DEFRAG.EXE %1" Sau đó nhấn chuột phải lên tập tin AddDefItem.inf và chọn Install để nạp vào Registry. Thế là xong! Nhưng nếu một hôm nào đó buồn buồn muốn gỡ bỏ mục “Defrag this” thì làm thế nào? Hãy mở Registry bằng cách vào menu Start -> Run, gõ lệnh regedit và Enter -> đến khóa: HKEY-CLASSES-ROOT\Drive\shell Nhìn vào menu con của khóa shell bạn sẽ thấy “chú em” Defrag this - nhấn phím Del - Yes để xóa nó đi. Đến đây chắc là bạn nắm được tất cả rồi chứ, không cần phải sử dụng file Inf cũng được. Bây giờ, bạn lại muốn thêm mục chọn vào context menu của Thư mục (thư mục) hả? OK, hãy vào Registry -> tìm đến khóa: HKEY-CLASSES-ROOT\Thư mục\shell Còn đối với File (tập tin) bạn tìm khóa: HKEY-LOCAL-MACHINE\SOFTWARE\Classes\* Sau đó, tạo khóa con “Shell” (bằng cách vào menu Edit - New - Key), trong khóa “Shell” vừa tạo lại tạo thêm khóa “Echip’s Word Pad”, tiếp tục tạo khóa “command” trong “VNEchip Word Pad” - nhấp chuột vào khóa “command”, nhìn qua khung bên phải sẽ thấy giá trị Default -> nhấp kép chuột vào giá trị Default, nhập vào nội dung: “đường-dẫn-đến-Word-pad %1” (%1 nghĩa là tên tập tin hiện hành), ví dụ: “C:\Program Files\Wordpad.exe %1”
  7. 253. Change Case (chuyển đổi chữ HOA - thường) nhanh hơn trong MS Word Khi muốn chuyển một đoạn văn bản từ chữ hoa sang thường hoặc ngược lại, thông thường bạn sẽ phải vào menu Format - Change Case - chọn kiểu mà mình muốn định dạng. Nhưng có một cách nhanh hơn để làm việc này. Đó là chỉ cần nhấn tổ hợp phím Ctrl + F3 cho đến khi nhận được đoạn văn bản vừa ý. 254. Cùng làm việc với "tay trợ lý văn phòng" MS Office Assistant MS Office Assistant có nhiệm vụ chính là giải quyết tất cả các yêu cầu vướng mắc khi bạn làm việc với bộ MS Office (trả lời trực tiếp cho bạn bằng ngôn ngữ tiếng Anh mà không cần tới một chuyên gia nào hết), và đưa ra thật nhiều tùy chọn cho bạn lựa chọn. Thật tuyệt vời phải không? Để gọi MS Office Assistant, bạn vào menu Help, chọn Show the Office Assistant hoặc nhấn F1. Trong trường hợp khi cài đặt, bạn chưa “tuyển mộ” tay trợ lý này, một hộp thoại sẽ xuất hiện báo là chưa cài đặt the Office Assistant, bạn có muốn cài đặt chức năng này không? Chỉ việc đồng ý là chương trình sẽ tự động cài đặt cho bạn. MS Office Assistant xuất hiện chào bạn với một dung mạo hơi bị ngộ, mặc định là một gã “kẹp giấy”. Để nhờ giúp đỡ, bạn chỉ việc nhấp chuột trái vào gã, một hộp văn bản đẹp hiện ra để bạn nhập nội dung cần nhờ (ví dụ như: I want to protect my documents, I want... Chúng ta có thể nhờ bất cứ việc gì, nhưng nên bắt đầu bằng I want... để gã dễ dàng vui lòng mà cảm thông) rồi nhấn Enter hoặc nhấp Search. Sau khi được “nhờ vả”, tay trợ lý bày ra thật nhiều tùy chọn mà bạn có thể chọn lựa cho phù hợp nhất với yêu cầu công việc của mình (bạn cũng có thể xem nhiều tùy chọn hơn nữa với See more... và quay lại với See previous).
  8. Tới đây, chắc bạn đã cảm thấy phần nào sức mạnh phi thường của tay trợ lý và hãy từ từ làm theo hướng dẫn trên màn hình nhằm giải quyết công việc được tốt nhất. Để đóng hộp văn bản, bạn cũng chỉ việc nhấp chuột vào gã lần nữa. Để MS Office Assistant luôn luôn đổi mới, luôn luôn tươi trẻ, bạn chỉ việc nhấp phải chuột vào và chọn Choose Assistant. Rồi đó, bạn có thể lựa chọn trợ lý của mình, kiểu cách, trạng thái với các nút Next và Back (nên thủ sẵn đĩa MS Office khi được yêu cầu). Và bạn cũng có thể tinh chỉnh các tùy chọn bằng cách nhấp phải chuột vào và chọn Options. Để yêu cầu tay trợ lý nhảy múa cho mình bớt stress trong công việc, bạn chỉ việc nhấp phải chuột vào và chọn Animate! Tới đây, chắc bạn sẽ cảm thấy công việc trở nên dễ chịu hơn! Và nếu muốn di chuyển MS Office Assistant đến bất kỳ nơi nào trên màn hình, bạn chỉ việc nhấp giữ trái chuột và kéo đi. Còn như cảm thấy gã hơi bị thừa thì bạn chỉ việc nhấp phải chuột vào và chọn Hide, gã từ từ được biến đi với lời chào “bye bye”.
Đồng bộ tài khoản