Adobe GoLive 6.0- P16

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

0
29
lượt xem
5
download

Adobe GoLive 6.0- P16

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Adobe GoLive 6.0- P16: This book, as well as the software described in it, is furnished under license and may be used or copied only in accordance with the terms of such license. The content of this book is furnished for informational use only, is subject to change without notice, and should not be construed as a commitment by Adobe Systems Incorporated. Adobe Systems Incorporated assumes no responsibility or liability for any errors or inaccuracies that may appear in this book

Chủ đề:
Lưu

Nội dung Text: Adobe GoLive 6.0- P16

  1. 470 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 3 Choose File > Export As, name the file with the .swf extension, and click Save to save it in the Lessons/Lesson13/13Start/ folder. (Do not name the file 13start.swf unless you wish to overwrite the 13start.swf file provided.) Choose File > Exit or Quit to exit LiveMotion. Integrating the composition with QuickTime movies Using the QuickTime editing tools in GoLive, it’s a matter of a few simple steps to integrate your final LiveMotion composition with the actual QuickTime movies. You’ll insert the SWF file into a new QuickTime movie, add video tracks for three QuickTime movies, link the video tracks to three movies that we’ve provided for this lesson, and add sound tracks for each of the movies. Creating a new QuickTime movie GoLive lets you create QuickTime movies from scratch. You’ll create a movie to contain the LiveMotion composition and the three provided QuickTime movies. 1 Start Adobe GoLive. 2 Close the Adobe GoLive introductory screen, and choose File > New Special > QuickTime Movie. 3 In the New QuickTime Movie dialog box, enter a name for the movie. We used QTmovie. Under Movie Size, enter 500 for Width and 420 for Height (the values you used for exporting the composition). Then click OK.
  2. ADOBE GOLIVE 6.0 471 Classroom in a Book About the movie viewer window The movie viewer window contains two tabs—one for previewing and the other for layout and editing: • The Preview tab lets you see the movie and set its properties in the Movie Inspector. By using the Quick- Time controller controls at the bottom of the movie viewer window, you can adjust the volume, play the movie all the way through, or step forward and backward through the movie one frame at a time just as view- ers of your movie will do. • The Layout tab offers a visual editing environment for your QuickTime movies. You can position, resize, and manipulate tracks in movies by dragging them in the Layout tab. For example, you can position a text track next to a video track by dragging the tracks in the Layout tab. When the Layout tab is active, you can also use buttons on the toolbar to skew or rotate tracks and create interesting visual effects. –From the Adobe GoLive online Help. Inserting the composition You’ll insert a SWF track into the movie’s timeline and link it to the SWF file that you created. If you didn’t create a SWF file using LiveMotion, you can link it to a SWF file that we’ve provided for this lesson. 1 Choose Movie > Show Timeline Editor to open the Timeline Editor. The Timeline Editor uses timeline bars to represent the tracks in a movie, including each track’s duration and the start and end times of tracks relative to other tracks. Here is where you do the majority of your work in creating and controlling movies. You add tracks to a movie by dragging icons from the QuickTime set in the Objects palette to the Timeline Editor. The Timeline Editor also lets you set options in Track Inspectors that affect the appearance and behaviors of the tracks in a movie. Tracks are the basic unit you use in creating a QuickTime movie, and each type of track contains a particular kind of information. For example, a video track contains video content, and a sound track contains audio content. In the Inspector for each track, you can set options that affect the track’s appearance and behavior in the movie, such as start time, duration, size, position, visibility, and various other behaviors specific to each track. 2 Choose Window > Objects to display the Objects palette, or click the Objects tab if the palette is collapsed. Then click the QuickTime button ( ) of the Objects palette. (You may have to click the arrow at the right of the Objects palette button bar to see the QuickTime button.)
  3. 472 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies The QuickTime set in the Objects palette provides icons for the tracks you need to assemble movies. 3 Drag the SWF Track icon from the QuickTime set of the Objects palette to the bottom of the track list in the Timeline Editor. In the dialog box that appears, navigate to the Lessons/Lesson13/13Start/ folder, select the SWF file that you created or the provided 13start.swf file, and click Open. Dragging SWF Track icon from the QuickTime set of the Objects palette to track list The first frame of the animation appears in the movie viewer window, which is black. Note: It’s important that you don’t stretch the SWF track’s duration bar in the Timeline Editor because it can cause the movie playback to jump to the wrong frame.
  4. ADOBE GOLIVE 6.0 473 Classroom in a Book Now you’ll use the Save command to save the movie. The first time that you save a movie, the Save As Movie dialog box appears and the movie will be flattened. Flattening a movie resolves all track references and optimizes the movie, so that your movie is ready to be placed on the Web. 4 Choose File > Save, name the file with the .mov extension, navigate to the Lessons/Lesson13/13Start/ folder, and click Save. If you don’t see the Save As dialog box, use the Movie > Flatten Movie command in GoLive to make sure you flatten the movie rather than simply save it. About the default color track When you first create a new movie, GoLive automatically adds a default color track to the movie. The pur- pose of the default color track is to specify a size and background color for the movie by providing a minimum of one track of visible content. (If GoLive didn’t add a default color track, the movie would have a size of zero width and height because it wouldn’t have any visible content.) The default color track keeps the movie viewer window (and the movie itself) expanded to the size you specified in the New QuickTime Movie dialog box, and uses the background color you specified. After you insert tracks that contain visible content to the movie (such as a video track), you can delete the default color track. The movie viewer window and the movie then resizes to the resulting boundary of the tracks you added. Or, you can modify the default color track (or insert other color tracks) to add a layer of color in the movie window. –From the Adobe GoLive 6.0 online Help. Inserting video tracks for each movie You’ll insert three video tracks, link them to three provided QuickTime movies, and set the movie properties in the Video Track Inspector. We designed the movies using Adobe Premiere®, where we added a title page and applied special effects to the original footage, including color correction, tinting, transitions between views, and audio fade in and fade out. First you’ll adjust the time resolution of the movie using the time scale slider, so that you can better examine the timing relationships between the multiple video tracks that you’ll add. The time scale slider extends from one frame (maximum resolution) to one minute (minimum resolution).
  5. 474 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 1 In the Timeline Editor, drag the time scale slider (at the bottom of the window) to the right to decrease the time resolution to 4 seconds. 2 Drag the Video Track icon from the QuickTime set ( ) of the Objects palette to the bottom of the track list in the Timeline Editor. In the dialog box that appears, select mov1.mov from the Lessons/Lesson13/13Start/media/ folder, and click Open. 3 In the Timeline Editor, select the new video track in the track list. Then click the Layout tab in the movie viewer window to go to Layout Editor. Notice that the movie appears selected in the upper left corner of the movie viewer window. Layout view lets you reposition elements in your movie document. You’ll place each movie in the same position by entering precise horizontal and vertical coordinates in the Video Track Inspector. (You can also reposition a movie by dragging.)
  6. ADOBE GOLIVE 6.0 475 Classroom in a Book 4 Choose Window > Inspector to display the Inspector, or click the Inspector tab if the palette is collapsed. The Inspector changes to the Video Track Inspector. (As a reminder, the phrase “Video Track” appears at the bottom of the Inspector to indicate that it has changed to the Video Track Inspector.) 5 In the Video Track Inspector, for Position, enter 170 in the left text box and 155 in the right text box. Press Enter or Return. Now you’ll name the movie track and position it in the timeline. 6 In the Video Track Inspector, enter Movie A in the Title text box and 00:00:01.00 in the Start Time text box. Press Enter or Return. Notice that this is the same start time that you set up in the LiveMotion composition timeline for Movie A. Also notice that the movie has disappeared from view in the movie viewer window at the current time.
  7. 476 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 7 Repeat steps 2 through 6 to insert video tracks for Movie B and Movie C, and enter the settings from this table in the Video Track Inspector. Insert this track Select this file Title Start Time Position Video Track mov1.mov Movie A 00:00:01.00 170 and 155 Video Track mov2.mov Movie B 00:00:22.00 170 and 155 Video Track mov3.mov Movie C 00:00:43.00 170 and 155 Note: If your system has limited memory, you may want to work with only one movie and its associated elements to avoid system crashes or freezes. 8 Choose File > Save to save the movie.
  8. ADOBE GOLIVE 6.0 477 Classroom in a Book Adding sound to QuickTime movies GoLive lets you add sound to your movie in several formats, including AIFF, WAV, and MP3. For each movie track that you inserted, you’ll add a sound track and link it to a sound file for the movie. The sound files that we’ve provided for this lesson are approxi- mately the same length as the QuickTime movies, about 20 seconds each. 1 Drag the Sound Track icon from the QuickTime ( ) set of the Objects palette to the track list in the Timeline Editor, and place it between Movie A and Movie B. In the dialog box that appears, select the mov1_audio.aif file in Lessons/Lesson13/13Start/media/, and click Open. (You may need to select All Files for the file type in order to see the sound file.) 2 In the Timeline Editor, select the new sound track in the track list. The Inspector changes to the Sound Track Inspector. 3 In the Sound Track Inspector, enter Sound for Movie A in the Title text box, and enter 00:00:01.00 in the Start Time text box. Press Enter or Return.
  9. 478 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 4 Repeat steps 1 through 3 to add sounds to Movie B and Movie C, and enter the settings from the following table in the Sound Track Inspector. Place the sound track for Movie B between Movie B and Movie C, and place the sound track for Movie C at the bottom of the track list. Insert this track Select this file Title Start Time Sound Track mov1_audio.aif Sound for Movie A 00:00:01.00 Sound Track mov2_audio.aif Sound for Movie B 00:00:22.00 Sound Track mov3_audio.aif Sound for Movie C 00:00:43.00 Timeline Editor with added sound tracks 5 Choose File > Save. How to separate sounds from movies in Adobe Premiere 5.0 The three QuickTime movies provided for this lesson include sound tracks within the movie files. You can use Adobe Premiere 5.0 to separate the sounds from the movies and save them as individual AIFF files. For infor- mation on how to do this, see the Adobe Premiere documentation or online Help.
  10. ADOBE GOLIVE 6.0 479 Classroom in a Book Adding special effects to QuickTime movies You can use filter tracks to add special effects to your QuickTime movies. GoLive includes one-source and two-source filter tracks. You can use one-source filter tracks to change the visual presentation of a single video track and two-source filter tracks to apply transitions between two tracks, such as a picture track and a video track. Adding a one-source filter track Now you’ll add a one-source filter track to apply a tint to Movie B. 1 Drag the One Source Filter Track icon from the QuickTime set ( ) of the Objects palette to the track list in the Timeline Editor, and place it between Movie B and Sound for Movie B. Dragging One Source Filter Track icon from the QuickTime set of the Objects palette to track list You use the filter track to specify properties of the track such as its title, start time, duration, and position. However, before you can specify these properties, you need to create a sample for the filter track, which you use to specify the effect that you want to apply. Now you’ll add a sample for the one-source filter track that you’ve added to the track list. 2 Click the triangle next to the One Source Filter Track to expand the track and display the samples.
  11. 480 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 3 In the Timeline Editor, click the Create Sample tool ( ) on the toolbar to select it. Then drag in the sample content area of the Timeline Editor to create a sample content bar. Note: If a sample is already present—the RGB Balance Filter, for example—select it and delete it before attempting to create a new sample. Select the Delete Sample tool, and click the sample you want to delete. Alternatively you can select the sample using the Standard Selection and Editing tool, click the sample in the Timeline Editor to select it, and edit its properties in the Inspector. A B C A. Create Sample tool B. One-source filter track C. Sample content bar created by dragging Now you’ll set properties for the one-source filter track. 4 In the Timeline Editor, select the new one-source filter track in the track list. The Inspector changes to the One Source Filter Track Inspector. 5 In the One Source Filter Track Inspector, enter Tint for Movie B in the Title text box. You’ll enter the same start time, duration, position, and size for the one-source filter track as Movie B. 6 Enter 00:00:22.00 in the Start Time text box, and enter 00:00:20.00 in the Duration text box. Enter 170 in the left text box and 155 in the right text box for Position. Enter 160 in the left text box and 120 in the right text box for Size, and deselect the Constrain Proportion option.
  12. ADOBE GOLIVE 6.0 481 Classroom in a Book 7 Choose Movie B from the Source pop-up menu to specify Movie B as the source for the filter track. Choosing Movie B from Source pop-up menu Now you’ll set properties for the sample to apply a tint to Movie B. 8 Select the sample content bar in the Timeline Editor. Selecting sample content bar
  13. 482 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies The Inspector changes to the One Source Filter Sample Inspector. 9 In the One Source Filter Sample Inspector, click Select. In the Select Effect dialog box, select Color Tint from the list box on the left, choose Other for Tint Type, and click to select the Light Color option. 10 In the Color Picker, choose a color, and click OK. (We used green.) 11 In the Select Effect dialog box, click OK. Notice that a tint is added to the movie in the movie viewer window. 12 Choose File > Save.
  14. ADOBE GOLIVE 6.0 483 Classroom in a Book Adding a two-source filter track Now you’ll add a title page to movie A by adding a picture track to the track list in the Timeline Editor. The title page is an image created in Photoshop. Then you’ll add a two- source filter track to apply a transition between the title page and movie A. Besides using picture tracks to add title pages to QuickTime movies, you can also use picture tracks to present slide shows. 1 Drag the Picture Track icon from the QuickTime set ( ) of the Objects palette to the track list in the Timeline Editor, and place it between Movie A and Sound for Movie A. 2 In the Timeline Editor, select the new picture track in the track list. The Inspector changes to the Picture Track Inspector. Now you’ll specify the image file for the title page that you want to add to the QuickTime movie. 3 In the Picture Track Inspector, click the Images tab to select it. Then deselect Images Constrain Proportion, and click Import. In the dialog box that appears, navigate to the Lessons/Lesson13/13Start/media/ folder, select titlepage.psd, and click Add and then click Done.
  15. 484 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 4 In the dialog box that appears, click OK to accept the default compression settings for the image file. Now you’ll set properties for the title page, including specifying that it be displayed after one second and for a duration of five seconds. 5 In the Picture Track Inspector, click the Basic tab to select it. Then enter Movie A Title Page in the Title text box. Enter 00:00:01.00 in the Start Time text box, and enter 00:00:05.00 in the Duration text box. For Position, enter 170 in the left text box and 155 in the right text box. For Size, enter 160 in the left text box and 120 in the right text box, and make sure that the Constrain Proportion option is deselected. Now you’ll add a two-source filter track to the track list to create the transition between the title page and Movie A. 6 Drag the Two Source Filter Track icon from the QuickTime set ( ) of the Objects palette to the track list in the Timeline Editor, and place it between Movie A and Movie A Title Page. Now you’ll add a sample for the two-source filter track.
  16. ADOBE GOLIVE 6.0 485 Classroom in a Book 7 Click the triangle next to the Two Source Filter Track to expand the track and display the samples. 8 In the Timeline Editor, click the Create Sample tool ( ) on the toolbar to select it. Then drag in the sample content area in the Timeline Editor to create a sample content bar. Note: If a sample is already present, select it and delete it before attempting to create a new sample. Select the Delete Sample tool, and click the sample you want to delete. Alternatively you can select the sample using the Standard Selection and Editing tool, click the sample in the Timeline Editor to select it, and edit its properties in the Inspector. Dragging to create sample content bar for two-source filter track Now you’ll set properties for the two-source filter track. 9 In the Timeline Editor, select the new two-source filter track in the track list. The Inspector changes to the Two Source Filter Track Inspector. 10 In the Two Source Filter Track Inspector, enter Transition in the Title text box. You’ll enter the same position and size for the two-source filter track as for Movie A.
  17. 486 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies 11 Enter 00:00:03.00 in the Start Time text box, and enter 00:00:03.00 in the Duration text box. For Position, enter 170 in the left text box and 155 in the right text box. For Size, enter 160 in the left text box and 120 in the right text box, and then deselect the Constrain Proportion option. 12 Choose Movie A Title Page from the Source A pop-up menu, and choose Movie A from the Source B pop-up menu. Notice that the area where you are applying a transition in the movie viewer window turns white. It remains white until you choose the transition effect that you want to apply. Now you’ll set properties for the sample to apply a Cross Fade effect between the title page and Movie A. The Cross Fade effect provides a smooth transition that fades out the picture track and fades in the video track. 13 Select the sample content bar in the Timeline Editor. The Inspector changes to the Two Source Filter Sample Inspector.
  18. ADOBE GOLIVE 6.0 487 Classroom in a Book 14 In the Two Source Filter Sample Inspector, enter 00:00:03.00 in the Start Time text box, and enter 00:00:06.00 in the End Time text box. Make sure that the Transition from Source A to B option is selected, and click Select. In the dialog box that appears, select Cross Fade from the list box in the upper left corner, and click OK. Now you’ll both flatten and save the movie using the Flatten movie command. Flattening a movie resolves all track references and optimizes the movie, so that your movie is ready to be placed on the Web. 15 Choose Movie > Flatten Movie. 16 Choose File > Save. Now that you’ve finished editing your QuickTime movie using GoLive, you’ll preview it. 17 Click the Preview tab in the movie viewer window. Then click the play button ( ) at the bottom of the movie viewer window. 18 When you are finished, choose File > Close to close your work.
  19. 488 LESSON 13 Combining Adobe LiveMotion Animations with QuickTime Movies Selecting tracks in the Layout tab Being able to select tracks easily is important when you’re working with movies. Some movies have several tracks and you must be able to select individual tracks to set the track’s properties in the Inspector. The Layout tab in the movie viewer window offers a context menu that lists all of the available tracks at the current time and position in the movie where your click. When you select a track in the Layout tab, GoLive also selects the track in the Timeline Editor, and vice versa. To select an individual track in the Layout tab: With the Layout tab active, do one of the following: • Click inside the track’s boundaries. • Place the mouse pointer over the track and then choose the track from the context menu. –From the Adobe GoLive 6.0 online Help.
  20. ADOBE GOLIVE 6.0 489 Classroom in a Book Review questions 1 How do you add a placeholder for a QuickTime movie to an existing composition in LiveMotion? 2 How do you export a composition from LiveMotion to a SWF file? 3 How do you create a new QuickTime movie in GoLive? 4 Why would you add a SWF track to a QuickTime movie in GoLive? 5 What does it mean to flatten a movie? And how do you do it? 6 How do you integrate QuickTime movies and sound in a final QuickTime movie in GoLive? 7 What can you use to add special effects, such as tinting and transitions, to QuickTime movies in GoLive? Review answers 1 To add a placeholder for a QuickTime movie to a composition, set up a start and an end label for the movie using LiveMotion. 2 To export a composition from LiveMotion to a SWF file, choose Window > Export to display the Export palette, and set options in the Export palette. Then choose File > Export As, name the file with the .swf extension, and click Save. 3 To create a new QuickTime movie in GoLive, choose File >New Special > QuickTime movie. In the dialog box that appears, enter a name for the movie, size for the movie, and click OK. 4 You would add a SWF track to a QuickTime movie in GoLive if you want to add a SWF file to the movie. 5 Flattening a movie resolves all track references and optimizes the movie so that your movie is ready to be placed on the Web. To both flatten and save a movie, choose Movie > Flatten Movie. 6 To integrate movies and sound in a final QuickTime movie in GoLive, you need to add video tracks for the movies and sound tracks for the sound to the track list in the Timeline Editor. 7 To add special effects to QuickTime movies, you can use filter tracks. One-source filter tracks let you change the visual presentation of a single video track. Two-source filter tracks let you apply transitions between two tracks, such as a picture track and a video track.
Đồng bộ tài khoản