Adobe illustrator cs4- P14

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

0
43
lượt xem
15
download

Adobe illustrator cs4- P14

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Adobe illustrator cs4- P14: Good designers have many tools at their disposal. Especially in an environment where most designers have other powerful graphics applications, it can be diffi cult to choose which one to use for a particular task. For example, a designer can apply soft drop shadows in Photoshop, Illustrator, and InDesign—is one application any better than the others for this?

Chủ đề:
Lưu

Nội dung Text: Adobe illustrator cs4- P14

  1. 364 CHAPTER 11: EXPLORING THE WORLD OF 3D The most important part of this exercise is to try to visualize where the invisible axis is. When you think of a barbell, you may think of it as you normally see it—lying on the ground in a horizontal format. Because the Illustrator Revolve effect always uses a vertical axis, you had to think of the barbell as standing on its side. Once it’s created, you can use the track cube to rotate it into any position or orientation you need. The examples you’ve tried so far should help fuel your creativity and give you the information you need to create complex 3D objects on your own. The Importance of Applying 3D Effects to Groups When applying any 3D effect, it’s important to understand its limitations so you can figure out how to make it do what you want. Previously in this chapter, we stated that the Illustrator 3D effects have two main limitations: 3D objects cannot intersect each other, and each 3D object lives in its own 3D world. Hence, each object main- tains its own individual vanishing point or invisible axis. Basically, multiple objects in your document cannot share a single vanishing point, share the same perspective, or revolve around the same axis. If you were paying attention in Chapter 5, “Organizing Your Artwork,” you remember that effects produce a different appearance when applied at the group or layer level instead of at the object level. Because 3D is a live effect, the same rules for how groups work apply here as well. If you apply a 3D effect at the group level, all objects inside that group can share the same vanishing point or perspective. In the example of the barbell you just created, you were able to create a single axis that all the objects shared by grouping all the objects together before applying the 3D effect. Had you selected the objects in the file and applied the 3D Revolve effect without first creating a group, the result would be different and not what you would expect (Figure 11.46). Figure 11.46 If you take the same barbell example but skip the step that collects all the shapes within a single group, the result is quite different.
  2. LOOKING INSIDE THE 3D EFFECT 365 Applying the 3D Rotate Effect The Revolve effect doesn’t add dimension to an object. Rather, the effect allows you to position a 2D object in a 3D space. Basically, the 3D Rotate effect does the same as the 3D Extrude effect without adding any depth. To apply this effect, select a vector object on the artboard, and choose Effect > 3D Rotate to open the 3D Rotate Options dialog box. The settings for this 3D effect are identical to those we’ve already discussed, although take note that the 3D Rotate effect is limited to far fewer options (Figure 11.47). Most notably, you can specify only the Diffuse Shading or No Shading option, there are no bevels, and there is no support for artwork mapping (which we’ll cover next). Figure 11.47 Although there is a More Options button in the 3D Rotate Options dialog box, you’ll find it doesn’t really offer that much. The 3D Rotate effect can be useful for applying distortion to artwork, such as making artwork look as if it’s mounted on a billboard. It also enables you to add perspective to your artwork.
  3. 366 CHAPTER 11: EXPLORING THE WORLD OF 3D Mapping Artwork to 3D Surfaces One of the features that really sets the Illustrator 3D effect apart from the 3D effects in other vector applications is the ability to map 2D artwork onto the surface of a 3D object. This method of combining 2D and 3D graphics is called artwork mapping. So that you understand what artwork mapping really is, let’s take a closer look at a 3D cube. As we discussed earlier in the chapter, a 3D cube has six surfaces. Each of these surfaces is treated as a separate entity, and artwork mapping is the process of placing artwork on these surfaces (Figure 11.48). Figure 11.48 Starting with a normal square, a 3D Extrude effect produces a cube with six surfaces. When 2D artwork is placed onto these surfaces, the result is a 3D object with artwork mapping. You need to know a few facts before working with artwork mapping: • Artwork must first be defined as a symbol before it can be mapped to a 3D surface. This is actually pretty cool because as you modify a symbol, you will see it automatically update on any 3D surfaces. Refer to Chapter 9, “Drawing with Efficiency,” for detailed information on how to create and modify symbols. • You can’t map (wrap) a single symbol across multiple surfaces of a 3D object. If your 3D object has multiple surfaces, you can map symbols to each side individually (Figure 11.49). Figure 11.49 To create the appearance of artwork that wraps around multiple sides of an object, you have to create multiple symbols and map each section separately.
  4. LOOKING INSIDE THE 3D EFFECT 367 • When rendering a 3D object, Illustrator uses corner anchor points to define a new surface. Smooth anchor points will not define a new surface. When drawing your art, carefully specifying where corner or smooth anchor points appear on your path gives you greater control over how many surfaces are created and where they appear (Figure 11.50). Figure 11.50 By using cor- ner anchor points at certain points on the path of this profile of a water bottle, you can specify several surface areas to which you can map art. • Stroked objects make things more complicated. As you learned earlier in the chapter, objects with fills and strokes applied result in an object that has many more surfaces, which makes it difficult to work with. When you’re creating a 3D object that will have artwork mapped to it, it’s best to avoid using stroked paths. • Although the 3D effect in Illustrator produces vector results, some- times the 3D effect has to rasterize mapped artwork. If your mapped artwork contains gradients or raster images (such as those placed from Photoshop), Illustrator renders them at the resolution that is set in the
  5. 368 CHAPTER 11: EXPLORING THE WORLD OF 3D Document Raster Effects Settings dialog box. Even if your mapped art contains a high-resolution Photoshop file, Illustrator resamples it to match the resolution set in the Document Raster Effects Settings dialog box. For best results, make sure the resolution setting in this dialog box is high enough for your output needs. Refer to “Massaging Pixels in Illustrator” in Chapter 7 for more information about the settings in this dialog box. Specifying Mapped Artwork To map artwork onto the surface of a 3D object, you must first apply a 3D effect to an object. Then, from either the 3D Extrude & Bevel Options dia- log box or the 3D Revolve Options dialog box, click the Map Art button to open the Map Art dialog box (Figure 11.51). If the Preview check box in the resulting Map Art dialog box isn’t selected, select it so you can see what your mapped artwork will look like as you adjust it. Figure 11.51 The Map Art button appears directly below the Cancel button in the 3D Revolve Options or 3D Extrude & Bevel Options dialog box. Before you can map art onto your object, you have to choose onto which surface of the object you want to place your artwork. At the top of the Map Art dialog box, the buttons with arrows allow you to navigate or step through each of the surfaces of your object. As you step through each sur- face, Illustrator displays the selected surface in the center of the Map Art dialog box. In addition, Illustrator tries to help you identify the selected surface by highlighting it with a red outline on the artboard (Figure 11.52). Depending on the color of your object, this red outline could be helpful, or it could be barely visible.
  6. LOOKING INSIDE THE 3D EFFECT 369 Figure 11.52 Illustrator tries to help you iden- tify each of the surfaces, although the alignment of the red outlines isn’t always perfect on the artboard. The surface that appears in the Map Art dialog box is shaped as if it is laid flat. You’ll notice as you step through the different surfaces on your object that some show a light gray background whereas others show a dark gray background. Some surfaces may even show a background that is dark gray only in certain areas. This is Illustrator letting you know which surfaces, or which parts of a surface, are not visible or are hidden from view (Figure 11.53). As you would expect, if you choose to use the track cube to view your object from a different perspective, the shaded surface areas in the Map Art dialog box update accordingly. Figure 11.53 This surface, which is the section that connects the body and neck of the water bottle, has both shaded and non- shaded sections. TIP It’s easier if you create your symbols at the correct size before you Once you’ve chosen the surface you want to map art onto, use the Symbol map them to a surface; this pop-up menu to choose a symbol. The selected symbol appears on the sur- way, you won’t have to worry face area in the Map Art dialog box with a bounding box. You can drag the about getting just the right symbol to position it to your liking on the surface, and you can also drag the size or position in the Map Art dialog box.
  7. 370 CHAPTER 11: EXPLORING THE WORLD OF 3D handles to resize it (Figure 11.54). As you adjust the position of the symbol, you will see the preview update on the actual 3D object on the artboard. Alternatively, you can use the Scale to Fit button at the bottom of the Map Art dialog box to have Illustrator resize your symbol to fit to the surface, although it does so nonproportionally. Figure 11.54 You can move and rotate a symbol so that it appears as you need it to on the surface of the object. Once you’re happy with the size and position of your symbol on the selected surface, use the arrows at the top of the dialog box to navigate to another side to map additional symbols, as needed. At any time, you can click the Clear button to remove a symbol from a selected surface, or you can click the Clear All button to remove symbols from all surfaces at once. NOTE A surface can By default, Illustrator calculates shading and lighting only for the actual sur- contain only one sym- face of a 3D object, not artwork that is mapped to a 3D surface. Illustrator bol. If you want multiple art does this purely for performance reasons. We mentioned earlier that items to appear on a single Illustrator uses blends to calculate shading, and the process of breaking surface, you have to define a single symbol with all the down intricately mapped artwork and shading each element with blends elements in it. takes quite a bit of processing. However, to get a realistic appearance, most likely you will want your mapped artwork to be shaded, even if it takes a bit longer to do so. Selecting the “Shade Artwork (slower)” check box forces Illustrator to shade both the surface of your object and the mapped artwork.
  8. LOOKING INSIDE THE 3D EFFECT 371 This setting applies to the entire object, and you don’t need to turn it on for each individual surface. The last setting in the Map Art dialog box is the Invisible Geometry check box; invisible geometry is a slightly technical phrase. When this option is selected, Illustrator hides the actual 3D object on your artboard and displays just the mapped artwork. The result is a symbol that appears to float in space. A good example of when this setting might be useful is when you want to make text appear as if it were wrapped around a sphere (Figure 11.55). Figure 11.55 You can map artwork around a sphere (left), and by using the Invisible Geometry option in the Map Art dialog box, you can hide the sphere leaving just the artwork (right). When you’re happy with your artwork mapping settings, click OK to accept the settings in the Map Art dialog box, and then click OK to close the 3D dialog box. What If…You Add Transparency to 3D? Throughout this entire book, you’ve seen how transparency is integrated into the Illustrator feature set with features such as soft drop shadows and opacity masks. You might ask yourself, “What if I added transparency to a 3D object?” After all, wouldn’t it be cool to make a 3D object that was also transparent so that you could see right through to the back of the object? Have no fear—as if the 3D effect weren’t cool enough, you can also create transparent 3D objects—but you’ll have to address two issues in order to get transparency and 3D to work together.
  9. 372 CHAPTER 11: EXPLORING THE WORLD OF 3D Applying Transparency NOTE If your symbol As you learned earlier in the chapter, before Illustrator applies a 3D effect to contains transparency an object, it breaks the object down into its components (fills and strokes). In or overprint settings, those that process, transparency attributes are tossed out, and just the appearance will not interact with the 3D remains. For example, if you set an object to 50% opacity, the 3D effect sets object itself. For example, if a symbol uses a blending mode the object to a 50% tint of that color, but you won’t be able to see through to and you mapped that symbol what’s behind the object. The trick is that you have to sneak transparency into to a 3D object, you wouldn’t the 3D effect without letting the effect know about it. You can accomplish this see the symbol multiplying in one of two ways: with the 3D shape, because the appearance is limited to • If you have a single object that you’re working with, you can target the symbol itself. just the fill of the object in the Appearance panel and then change the Opacity value (Figure 11.56). • Alternatively, you can create a group (you can create a group of one object, if you’d like). If transparency is applied to any object within a group, that transparency makes it through the 3D effect unscathed. Figure 11.56 When you’re using the Appearance panel, targeting the fill allows you to apply transparency to just the fill and not the entire object. Drawing Hidden Sides Another useful nugget of information that you learned earlier is that, by default, Illustrator renders only the parts of a 3D object that are visible. To speed up the rendering process, Illustrator doesn’t bother drawing the sides of a 3D object that are hidden from view. Well, this presents a problem if you’re creating an object that is transparent and you expect to see through the front of the object to the back side. After all, if Illustrator isn’t drawing the hidden side of an object, how does Illustrator know what the back side of the object looks like? The answer is that you have to force Illustrator to draw the hidden
  10. LOOKING INSIDE THE 3D EFFECT 373 sides—you do this by turning on the Draw Hidden Faces option in the 3D Extrude & Bevel Options or 3D Revolve Options dialog box. Once you’ve addressed the issues of transparency and hidden sides, you’ll end up with a 3D object that is truly transparent (Figure 11.57). Adding transparency to 3D objects opens new doors to creativity, such as when creating transparent glass bottles and vases. And don’t forget to throw some artwork mapping in there as well. If you map art to a transparent 3D object, you’ll be able to see through to the art on the other side. Now you’ve got to admit—that’s pretty freakin’ cool, no? Figure 11.57 This martini glass is transparent, allowing you to see what is inside. What If…You Blend 3D Objects? In Illustrator, you can select two objects and choose the Object > Blend > Make feature to morph one vector shape into another. This technique, cov- ered in Chapter 2, can be useful for a variety of tasks including shading, special effects, and object distribution. However, what if you created a blend using two 3D objects? Would the 3D effect morph as well, along with the blend? The answer is, yes, it will! If you apply a 3D effect to an object and then duplicate that object (so you have two identical objects), you can create a blend between them. Because 3D is a live effect, you can edit the 3D effect of one of the objects and change the position so you’re viewing the object
  11. 374 CHAPTER 11: EXPLORING THE WORLD OF 3D from a completely different angle. The blend will then update—and gener- ate the intermediate steps (Figure 11.58). Figure 11.58 By creating a blend between spheres with mapped artwork, you can create the illusion of the sphere rotating. Not impressed? Well, in Chapter 13, “Web and Mobile Design,” you’ll learn how to use blends to create instant Flash animations that you can put on your website. That means you can create a box and have it rotate in space. Hey, wait—don’t go running off to that chapter yet—we still have plenty of cool stuff to cover here. What If…You Apply a 3D Effect to a Graph? In Chapter 10, “Drawing with Data,” you learned that a graph consists of a group of objects. And because a 3D effect applied at the group level results in all the objects in that group sharing the same effect, what happens if you apply a 3D Extrude effect to a graph? The answer is that you get a powerful way to present numbers in an eye-catching manner (Figure 11.59). And if you add transparency to a 3D graph—well, you can see where that might lead. Figure 11.59 Adding 3D effects to just about anything, such as graphs, for example, can turn something ordinary into something unique and attention-grabbing. At the end of the day, the 3D effect in Illustrator has many creative uses. Now that you understand everything there is to know about 3D in Illustrator, the only limit is your own imagination.
  12. 375 Chapter Twelve Working with Images There’s no velvet rope barring entry to the Adobe Illustrator exclusive vector graphics club. Pixels are always welcome inside. In fact, you’ve already learned how certain live effects use pixels to pro- duce their appearance. In Illustrator, vectors and pixels peacefully coexist, and you can benefit by combining both vectors and pixels (such as adding a soft drop shadow to text). You shouldn’t feel you have to choose only one graphic type or the other. Although Illustrator does have the ability to sup- port pixels in some ways (as you’ll see throughout this chapter), it in no way replaces the need for applications such as Adobe Photoshop CS4. Quite the contrary; in this chapter, you’ll see how you can bring pixel-based images from Photoshop into Illustrator documents. You will also learn how both Photoshop and Illustrator can work together by enabling you to share editable content between them. You can then focus on producing the kinds of graphics you need by relying on the strengths of each of these powerful applications. So, turn up the music and feel the pulsing beat of vectors dancing with pix- els, because this chapter will also cover the Illustrator ability to assimilate pixels and convert them into vector paths using a feature called Live Trace.
  13. 376 CHAPTER 12: WORKING WITH IMAGES PLACING R ASTER-BASED FILES When creating designs and layouts in Illustrator, at times you will need to incorporate raster-based content, such as photographs. Naturally, these images are neither created nor edited in Illustrator—raster-based applications such as Photoshop take care of doing that. However, you can place raster-based content into your Illustrator file. In fact, Illustrator works very much like a page layout application in this way. When you place an image, Illustrator can incorporate that image in the file in two ways. In the first technique, Illustrator places a preview of the image on your artboard, but the image file itself is not incorporated into the Illustrator file. The image file exists as an external reference, separate from the Illustrator file. This technique is referred to as place-linking because the image file is linked to the Illustrator document. If you were to misplace the linked file, Illustrator would not be able to print the image. In the second technique, Illustrator places the actual image file in the Illustrator document and incorporates the image into the Illustrator file. This is referred to as place-embedding, where the image becomes part of the Illustrator file. You can choose which technique you want to use when you physically place the file. For a detailed explanation of the numerous benefits and caveats of using each technique, refer to the sidebar “Place-Linked Files and Place-Embedded Files.” Placing an Image You can place a raster file into an Illustrator document using one of three methods. You can either place a file, open it directly, or drag it right onto your artboard. Each method has its own benefits; your task is to determine which one you will use. Method One: Placing a File When you already have a file open and you need to place an image into your document, this method offers the most options and is one of the most com- monly used ways to place a file:
  14. PLACING RASTER-BASED FILES 377 1. From an open document, choose File > Place, and navigate to a raster file on your hard drive or server. 2. In the Place dialog box are three check boxes (Figure 12.1). Select one TIP See “Using of the following options: Template Layers to Manually Trace” later in this • Select the Link check box to place-link the file (deselecting the chapter for more information Link check box place-embeds the file). on creating a template layer. • Select the Template check box to have the image automatically placed on a template layer. • Select the Replace check box to have the image replace one that is already selected on the artboard. 3. Click the Place button to place the file into your document. Figure 12.1 When placing a file, you can control whether an image is place-linked by selecting the Link check box in the Place dialog box. Method Two: Opening a File Choose File > Open, choose a raster file on your hard drive or server, and then click the Open button. Illustrator creates a new letter-sized document and places the image in the center of it. When you’re opening a raster file in this way, the image is always place-embedded in your Illustrator document. The document takes on the color mode of the image. Method Three: Dragging a File From Adobe Bridge, from the Finder on Mac OS, or from any Windows Explorer window, drag a raster file right onto your Illustrator artboard. You can also select multiple files and place them all at once (Figure 12.2). Using this method, Illustrator place-links the files. To place-embed images Figure 12.2 When you’re while dragging them into your document, hold the Shift key while dragging several images at dragging the images. once from Bridge, an icon indicates the placement of multiple files into your Illustrator document.
  15. 378 CHAPTER 12: WORKING WITH IMAGES Place-Linked Files and Place-Embedded Files When placing an image into Illustrator, you can choose to have the image linked to your document or embedded within it. Each method has its own benefits, and which you choose depends on your needs and your workflow. When you place-link an image, a preview of the image appears in your layout, but the actual image exists in a completely separate file. At all times, Illustrator needs to know where this file is. Otherwise, Illustrator won’t be able to print the file correctly. In fact, if you were to save your Illustrator file and send it off to someone else (such as a service provider, for example), you would have to send the external linked image along with the file. If you have several linked images in your document, you have to keep track of many files. In contrast, a place-embedded file exists in your Illustrator document, and therefore, the original external image that you placed is no longer required. When you send the document to another user, the image travels along with the single Illustrator file. Images—especially high-resolution ones—feature hefty file sizes. When you choose to embed a placed image, the file size of the image is added to the size of your Illustrator file. For example, if your Illustrator file is 1 MB in size and you place-embed a 30 MB image into your document, the size of your Illustrator document grows to 31 MB. When you place-link an image, however, the file is never added to your document, so the Illustrator file stays at 1 MB. Although managing multiple files and file size is an issue that will affect your decision to link or embed image files, one of the main reasons you will choose to link a file rather than embed it is so you can easily update the image when necessary. When you place-link a file, the image you see in your layout is a preview of the file that really exists elsewhere. When you make an adjustment to the original image (say, in Photoshop), the preview in your layout updates to reflect those changes. Illustrator even has a feature called Edit Original that assists in this process of updating linked images (see “Managing Placed Images” later in this chapter). However, if you place-embed an image, you can no longer update that image easily.
  16. PLACING RASTER-BASED FILES 379 Placing Native Photoshop Files (PSD) Typically, the interchange file formats for images that are used in print TIP Illustrator CS4 design layouts are TIFF or EPS, but Illustrator allows you to place native can also place layered Photoshop files (PSD) as well. TIFF files. Generally, placing a native Photoshop file isn’t any different from placing any other file. Illustrator enjoys a wonderful relationship with Photoshop, however, and you can take advantage of extended functionality when plac- ing Photoshop files. If the PSD file you are placing contains Photoshop layer comps, Illustrator NOTE The Layer Comps presents you with the Photoshop Import Options dialog box, where you can feature in Photoshop choose which layer comp will be visible in the file from the Layer Comp allows you to create named sets of visible layers. For more pop-up menu (Figure 12.3). Select the Show Preview check box to see information on the Layer what the layer comp looks like before you place the file. You can also choose Comps feature, refer to whether Illustrator or Photoshop controls how layer visibility is updated Photoshop Help or Real World by choosing from the When Updating Link pop-up menu. The Photoshop Adobe Photoshop CS4 by Import Options dialog box offers additional options, which are covered later David Blatner and Conrad in this chapter in the “Working with Adobe Photoshop” section. Chavez (Peachpit Press). Figure 12.3 The Photoshop Import Options dialog box lets you control the appear- ance of your Photoshop file before you place it into your document.
  17. 380 CHAPTER 12: WORKING WITH IMAGES NOTE For a detailed Unfortunately, once you place an image into an Illustrator document, you description of the dif- don’t have any way to access the Photoshop Import Options dialog box to ferent file formats and their change to a different layer comp. To work around this apparent oversight, benefits and roles in a design you can use the Relink function, which effectively places the file again and workflow, refer to Chapter 14, “Saving and Exporting Files.” opens the dialog box (see “Managing Placed Images” for information on relinking files). Working with Placed Images Once you’ve placed an image into an Illustrator document, the image acts like a single rectangular shape that can be transformed (moved, scaled, rotated, sheared, and reflected). You can apply opacity and blending mode values from the Transparency panel, and you can also apply many different live effects to a placed image, including Feather and Drop Shadow. Sometimes a design calls for showing only a portion of a placed image. Programs such as Photoshop (which can crop images) and page layout applications such as Adobe InDesign CS4 (which use picture frames) are able to display only portions of an image. Illustrator, however, has no such tool or functionality. To have only a portion of an image display on your artboard, you have to create a mask (Figure 12.4). (See Chapter 9, “Designing with Efficiency,” for more information on creating masks.) Figure 12.4 Using a clipping mask, you can display just a portion of a placed image. You can also apply color to certain kinds of placed images. Illustrator lets you apply either a solid process or a spot color to a 1-bit TIFF image or to
  18. PLACING RASTER-BASED FILES 381 any image that uses the grayscale color model. Simply select the image on the artboard, and choose a fill color as you would for any vector object. Using Template Layers to Manually Trace Sometimes you may want to place an image into Illustrator—not as a design NOTE Template layers element but rather as a design guide. For example, you might sketch an idea are not to be confused for a design on paper and then scan that sketch into your computer. Then, with Illustrator templates, which are actual Illustrator you would place that scan into your Illustrator document as a guide for files that contain elements drawing final shapes with the Illustrator vector tools. Alternatively, you may already inside them. place a map into Illustrator so that you can create your own customized Illustrator templates are directions to an event. covered in Chapter 1, “Creating and Managing In these cases, you may not actually want to trace the scan exactly as it Documents.” appears (using the Live Trace feature in Illustrator, covered later in this chapter, might be a better choice for such a task), but rather, you may just want the image to act as a reference. To prevent the image from getting in the way of your design, you might want to adjust the opacity of the image (Figure 12.5). Additionally, you may want to lock the image so that you don’t move it accidentally. Figure 12.5 Drawing on top of an image at full strength may be difficult (left). Placing an image on a dimmed template layer allows you to trace over the image with ease (right). Rather than going through the process of adjusting and locking images, Illustrator has a way to manage this process in a more dignified manner— using a template layer. Once a template layer has been created, the image on that layer automatically becomes locked, and the opacity level of the image is set to 50%. You can select the Template option at the bottom of the Place dialog box when placing an image to have the image automatically appear on a template layer, or you can double-click any layer and select the Template option in the Layer Options dialog box (Figure 12.6 on the next page).
  19. 382 CHAPTER 12: WORKING WITH IMAGES Figure 12.6 The Template option appears in the Layer Options dialog box and applies to a single layer. Adding Keylines to Placed Images Often, when you place a photograph in an Illustrator document, you want to create a keyline, or an outline around the photo. It’s important to understand that a placed image is not a vector object and, hence, can’t have a fill or stroke. So, you’ll need to create another vector object to contain your stroke. Rather than create this new shape on your own, there are two methods you can use: have Illustrator automatically create a mask for the image or use an effect to convert the bounds of the object into a vector object. To add a keyline using a mask, follow these steps: 1. Choose File > Place, and pick an image to place into your Illustrator document. You can either link or embed the image. Once you’ve chosen the image, click the Place button. 2. The image is selected (or if your image already exists in your document, select it), so you’ll see the Mask button in the Control panel. Click it. This creates a mask at the exact bounds of the image. 3. Press the D key for Default. This gives the mask a black 1-point stroke. Feel free to adjust the stroke per your design needs (who uses a 1-point stroke anyway?). An additional benefit to this method of using a mask is that you now have the elements in place to simulate a “frame and image” paradigm like InDesign uses. Once you’ve created your mask, you can decide to “crop” your image by double-clicking the photo. This will put you into isolation mode. Now click the frame edge and resize at will. When you’re done, double-click outside the image to exit isolation mode and continue working. This method works wonderfully when you’re using the Selection tool (black arrow) and have the Bounding Box option selected (in the View menu). To add a keyline using a live effect, follow these steps: 1. Choose File > Place, and pick an image to place in your Illustrator document. You can either link or embed the image. Once you’re chosen the image, click the Place button. 2. With the image selected, open the Appearance panel, and click Add New Stroke. You won’t see the stroke appear just yet, but don’t worry, it will show up in the next step. 3. With the stroke highlighted in the Appearance panel, choose Effect > Path > Outline Object. The stroke will appear around the boundary of the photograph. To make the live effect easier to apply in the future, define a graphic style. For details on graphic styles, refer to Chapter 9.
  20. MANAGING PLACED IMAGES 383 M ANAGING PLACED IMAGES Whether the images you place in a file are linked or embedded, it’s important to be able to track where those images came from and to access additional information about the images. To manage all the placed images in your doc- ument, choose Window > Links to open the Links panel. By default, the Links panel lists all the images in your document. However, from the Links panel menu, you can specify that the Links panel should display only missing, modified, or embedded images (Figure 12.7). In addi- tion, you can choose to have the Links panel list images sorted by name (file name), kind (file type), or status (up-to-date or modified). Figure 12.7 Icons in the Layers panel indicate addi- Missing Image tional information about the images that are placed in your document. No icon Linked Image indicates a place-linked file. Embedded Image Modified Image Relink Edit Original Go to Link Update Link Double-clicking any file listed in the Links panel opens a Link Information dialog box, offering additional information about the image. Besides listing the file size of the image, the Link Information dialog box also gives you the location of the image (the file path) and detailed scaling and rotation infor- mation (Figure 12.8 on the next page).
Đồng bộ tài khoản