Báo cáo - Chuyên đề đồ họa ứng dụng

Chia sẻ: Son Nguu | Ngày: | Loại File: PDF | Số trang:40

0
182
lượt xem
55
download

Báo cáo - Chuyên đề đồ họa ứng dụng

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Chuyên đề đồ họa ứng dụng III.Tạo mô hình nhân vật A. LÝ THUYẾT POLYGON Tạo và chỉnh sửa polygons: - Nhân vật thực chất được tạo nên bởi sự nối ghép có quy tắc của nhiều Poligon. Thực chất poligon là những hình toán học với nhiều góc ,cạnh khác nhau.Nhưng ứng dụng chủ yếu chỉ là các hình tam giác và hình vuông trong việc tạo hình 1 nhân vật (còn được gọi là mô hình lưới 3 và lưới 4 ). - Trong maya có những công cụ để tạo sẵn các poligon chuẩn : Create /Poligon Primitive và nhấp...

Chủ đề:
Lưu

Nội dung Text: Báo cáo - Chuyên đề đồ họa ứng dụng

  1. Chuyên đề đồ họa ứng dụng III.Tạo mô hình nhân vật A. LÝ THUYẾT POLYGON Tạo và chỉnh sửa polygons: - Nhân vật thực chất được tạo nên bởi sự nối ghép có quy tắc của nhiều Poligon. Thực chất poligon là những hình toán học với nhiều góc ,cạnh khác nhau.Nhưng ứng dụng chủ yếu chỉ là các hình tam giác và hình vuông trong việc tạo hình 1 nhân vật (còn được gọi là mô hình lưới 3 và lưới 4 ). - Trong maya có những công cụ để tạo sẵn các poligon chuẩn : Create /Poligon Primitive và nhấp chọn những hình thích hợp với các thông số về chiều cao(heigh),bán kính(radus)…phù hợp.hoặc có thể tạo các poligon với những hình theo ý muốn :Poligon/create poligon tool,nhấp chuột vẻ từng đỉnh của poligon muốn tạo,nhấn Enter để hoàn tất việc tạo hình . - Tạo hình không gian :chọn mặt cần đẩy ,Edit polygons/Extrude face ,kéo chuột đẩy hình theo các chiều khác nhau với tỉ lệ và số mặt mong muốn ,có thể làm bằng tay hoặc nhập vào thông số trong Property
  2. Chuyên đề Đồ họa Ứng dụng - Đẩy mặt :Edit polygon/poke face ,công cụ này sẽ đẩy một mặt phẳng tạo thành một hình chóp gồm nhiều mặt phẳng ở cạnh bên ,bằng cách đẩy tại tâm của hình . • - Làm mịn:công cụ này sẽ tự động đẻo gọt những phần nhô cao,những phần sắc nhọn ,việc làm này sẽ tạo ra nhiều mặt đối với vật được làm mịn .Chọn phần cần làm mịn ,Polygon/smooth hay Polygon/smooth proxy.chức năng sau cùng này sẽ tạo ra hình 2 biến thể hình làm mịn - Vạt mặt : chức năng vạt mặt gần giống như chức năng làm mịn nhưng việc vạt mặt sẽ tạo ra ít mặt hơn và vẫn duy trì độ sắc nhọn của vật thể. .Chọn mặt cần vạt Edit polygons/Bevel ,có thể sữa lại thông số offset để thay đổi độ vạt mặt - Trám lỗ hổng :chọn tất cả các mặt xung quoanh ,Edit Polygons/fill hole, chức năng này sẽ tạo ra một mặt phẳng dựa vào các mặt xung quanh tại vị trí chỗ hổng - Bỏ mặt : Edit polygon /extract ,dùng chuột để lấy mặt cần lấy ra - Lật mặt : Edit polygon / normal/conform 0112144_0112026_0112279
  3. - - Ánh xạ :Polygon/mirror ,tạo ra một ánh xạ vật thể theo hướng chọn - Chuyển đổi 1 NURBS sang polygon : Modify /convert / NURBS to polygons - Chia mặt : Có thể dùng một trong các công cụ sau để chia hoặc cắt mặt: -Edit polygons/split polygon tool:công cụ này có thể được dùng để chia một mặt thành nhiều mặt theo ý muốn bằng cách sử dụng chuột click vào vị trí muốn chia
  4. Chuyên đề Đồ họa Ứng dụng trước khi chia (1 mặt ) sau khi chia (4mặt ) -Edit polygons/cut face tool : sẽ cắt ngang hình theo một chiều nào đó Nối : - chọn các hình cần nối , polygon /combine -> chức năng này dùng để nối các bộ phận riêng lẽ của cơ thể lại với nhau - có thể nối bằng cách nhập các điểm : Edit polygon/merge vertices ,đây là một chức năng khá mạnh khi tạo hình và chỉnh sửa hình dựa vào những đỉnh của những mặt trước khi trôn sau khi trộn 0112144_0112026_0112279
  5. - ngoài ra có thể dùng các chức năng sau để nối : Edit polygon/collapse hoặc Edit polygon /normals/conform để nối hình mà không bị vụn ô - có thể nối theo thuật toán boolean : Polygon /booleans B. Tạo cơ thể - tạo thân thể :dùng các hình lập phương cơ bản ,kết hợp với các công cụ đẩy ,tỉ lệ, chia mặt,nối mặt … (các công cụ cơ bản trình bày ờ phần lí thuyết )để tạo ra mô hình cơ thể như ý muốn - tạo mặt : dùng công cụ đẻo các mô hình NURBS bằng công cụ Edit NURBS/ sculpt surface tools .Trong tạo mặt cần chú ý là cách làm tăng số isoparamatric rồi đẻo ,cách này sẽ tăng độ nét cho gương mặt C. Tạo khung xương - trước khi tạo khung xương cho cơ thể thì phải có mô hình da của cơ thể để dựa vào đó mà có tỉ lệ xương và vị trí xương cho thích hợp với từng nhân vật. Chọn công cụ để tạo xương : Skeleton/joint tool ,trên thanh công cụ bên phải màn hình sẽ hiện lên biểu tượng xương,hãy click vào và tạo như tạo polygons,hãy canh vị từng vị trí thích hợp - chỉnh kich cỡ xương : Windows/setting/references > reference ,chọn size cho phù hợp ,thường cỡ khoảng 0.5 là đủ lớn
  6. Chuyên đề Đồ họa Ứng dụng - chỉnh lại phần trăm hiển thị xương cho thích hợp : display/joint size /chọn cỡ - xương(joint chains) = khớp xương (joint)+ đoạn xương (bone) - khớp xương gồm 3 loại sau : ball joint ->là khớp co thể quay 3 hướng, hinge joint ->là khớp chỉ có thể quay 1 hướng duy nhất ,khớp cuối cùng là universal -> có thể quay được cả 2 hướng - gắn xương con vào xương cha ( ví dụ như nối khớp cột sống với xương cánh tay,hoặc xương cột sống với xương chân ) : Chọn đoạn xương con,+(shift)chọn tiếp đoạn xương cha , Skeleton / connection joint ->nhấn connect - sau khi đã gắn xương ,chọn đoạn xương con muốn ánh xạ (như xương cánh tay và xương chân ) ,Skeleton /mirror ,chọn trục đối xứng thích hợp ->nhấn miror.chức năng này vừa tạo ra đoạn xương ánh xạ ,vừa gắn nó vào đoạn xương cha như là đoạn xương con trước đã làm - Khi tạo xương cho nhân vật việc chọn vị trí đặt xương là rất quan trọng ,nếu đặt sại vị trí ,khung xương sẽ không đỡ nổi phần da thịt và chuyển động của nhân vật trông rất kì dị - Có thể xem lại sơ đồ xương vừa tạo trong : window/hypergraph 0112144_0112026_0112279
  7. D. Tạo áo quần Nguyên liệu cơ bản ban đầu để tạo thành áo quần là các đường thẳng dạng curve tuơng tự như đường cắt áo quần ,gồm 2 mảnh chính nằm trên hai mặt phẳng trước và sau nhân vật (chú ý là các đường curve thuộc từng mảnh phải nằm trong cùng 1 mặt phẳng và phải tạo thành hình khép kín ) . Sau khi tạo xong các đường curve có hình như bên dưới - May áo quần : gồm các bước : + tạo khung panel từ các đường curve ( cloth / create panel ),mỗi khung sẽ có 1 kí hieu là + tạo lưới cho panel ( cloth / create garment ) + may áo quần (cloth / create seam ) ,may tất cả những vị trí cần ghép mảnh lại
  8. Chuyên đề Đồ họa Ứng dụng + rủ áo quần IV. Tạo chuyển động A. Tạo chuyển động cho khung xương Kỹ thuật IK (Inverse Kinematics) Giới thiệu: - Phần này giới thiệu cách tạo các IK handle để tạo tư thế cho nhân vật. 1. Tạo IK handle cho chân: • Chọn Skeleton > IK Handle Tool > . • Trong cửa sổ Tool Settings, chọn giá trị ikRPsolver cho Current Solver. • Trong perspective view, clik left_hip và left_ankle. Hành động này tạo một IK handle cho phép bạn điều khiển tất cả các điểm từ left_hip đến left_ankle. Xử lý chính của handle là left_ankle. Lưu ý: Không chọn đồng thời một đối tượng nào với một IK handle. • Đến frame đầu tiên tạo chuyển động. • Với IK handle được chọn, chọn Animate > Set Key để đặt khóa cho vị trí hiện tại của chân trái lúc này. • Đến frame 12 • Trong side view, dùng công cụ Move để kéo IK handle lên cao (xem hình) 0112144_0112026_0112279
  9. • Đặt khóa cho IK handle ở vị trí này. • Đến frame 24, di chuyển IK handle về chỗ cũ. Đặt khóa cho IK handle tại thời điểm này. • Trở vì frame đầu chuyển động và chơi thử. 2. Tạo IK handle cho tay: • Tạo IK handle cho cánh tay trái: i. Chọn Skeleton > IK Handle Tool. ii. Click chọn theo thứ tự left_shoulder, và left_wrist. • Tạo IK handle cho cánh tay phải i. Chọn Skeleton > IK Handle Tool ii. Click chọn theo thứ tự right_shoulder, và right_wrist. B. Gán khung xương vào cơ thể Xương sau khi được tạo chỉ là một mô hình độc lập ,để cho xương và da thịt tạo thành thể thống nhất thì ta phải buộc xương vào với cơ thể : chọn tất cả da + xương ,dùng công cụ Skin /bind skin /smooth bind ->bind skin để gắn kết , và nếu muốn gở ràng buộc ra chỉ cần dùng skin /edit smooth skin / delete non- skin history . từ đây mọi hoạt động của xương sẽ kéo theo sự chuyển động của cơ thể C. Export, import trang phục và hoàn chỉnh nhân vật Giới thiệu: Phần này giới thiệu cách import một bộ trang phục vào một mô hình nhân vật đã tạo chuyển động, hoàn chỉnh nhân vật. Chi tiết gồm: - Cách export, import trang phục. - Định lại vị trí cho trang phục được import. - Cách sử dụng lưới để giữ cho trang phục ở vị trí đúng.
  10. Chuyên đề Đồ họa Ứng dụng - Điều chỉnh cho trang phục vừa vặn hơn. 1. Export trang phục Cách export áo 3. Mở mô hìnhh shirtFinal.mb. 4. Chọn mẫu áo. 5. Chọn File > Export Selection > . Cửa sổ tùy chọn xuất hiện. Chọn Edit > Reset Settings, đánh dấu hộp kiểm History. Click Export Selection. Khi hộp kiểm History được chọn, Maya export cả điều khiển trang phục(solver) của tập tin shirtFinal.mb( Ở đây là điều khiển của mẫu áo ). Điều khiển này phải được export luôn bởi vì bạn cần dùng nó để giả lập mẫu áo sơ mi lần nữa ở bước import. Nếu không có dự định sử dụng lại giả lập cũ, bạn có thể bỏ đánh dấu hộp kiểm History. 6. Trong cửa sổ Export Selection, chọn mũi tên hướng xuống trên cùng để hiển thị menu kéo thả. Chọn Current scences. 7. Đánh tên shirtExport và click nút Export. Sau khi làm xong ta sẽ có một tập tin tên shirtExport.mb. Cách export quần 1. Mở tập tin tên pantsFinal.mb. 2. Chọn mẫu quần. 3. Chọn File > Export Selection > . 4. Trong cửa sổ Export Selection, chọn mũi tên hướng xuống trên cùng để hiển thị menu kéo thả. Chọn Current scences. 5. Đánh tên pantsExport và click nút Export. Sau khi làm xong ta sẽ có một tập tin tên pantsExport.mb. 2. Import và điều khiển mẫu áo Mở tập tin chứa mô hình đã tạo chuyển động 1. Mở tập tin tên importStart.mb. Ta thấy mô hình nhân vật ở thế đứng chuẩn. Khi bạn import trang phục vào, có thể phải định lại vị trí nhân vật cho vừa vặn với trang phục. 2. Định lại khoảng frame từ -20 đến 118. 3. Cho play scene. 0112144_0112026_0112279
  11. Bạn sẽ thấy từ frame 20 đến 1,nhân vật chuyển đổi tư thế từ thế đứng chuẩn sang thế đứng bắt đầu để chuyển động. 4. Trở lại frame đầu (-20). Import áo 1. Chọn File > Import > . Trong cửa sổ tùy chọn, chọn Edit > Reset Settings, đánh dấu hộp kiểm User Namespaces, sau đó click Import. 2. Trong cửa sổ Import Selection, click mũi tên trong hộp trên cùng cửa sổ để hiển thị menu kéo thả và chọn Current scenes. 3. Chọnn shirtExport.mb và click Import. => Mẫu áo đã được import. 4. Trong Outliner, chọn shirtExort:shirt. Trong Channel Box, để ý các tên shirtExport:cpSolver1 và shirtExport:cpStitcher1. Do các tùy chọn ta chọn ở cửa sổ tùy chọn Import, Maya thêm vào tiếp đầu ngữ shirtExport cho các node cpSolver1 và cpStitcher1 của tập tin shirtExport.mb. Điều này để đảm bảo tên là độc nhất, không bị trùng với các tên trong scene hiện tại. Định vị trí cho mẫu áo 1. Di chuyển và xoay áo để nó vừa vặn với nhân vật. Smooth shading (nhấn 5) để thấy được xuyên suốt mẫu áo. Ở bước này không cần phải làm cho mẫu áo quá vừa vặn với mô hình. Hãy tưởng tượng khi nhân vật di chuyển thì vị trí áo cũng phải thay đổi. Có thể định vị trí theo như số liệu dưới đây: o Translate X: 9.93 o Translate Y: 0.1 o Translate Z: -9.98 o Rotate Y: -24 Trong Channel Box, click shirtExport:cpSolver1. Cho Start Frame bằng -20 trong mục INPUTS ở hộp Channel Box. Cái này để định frame bắt đầu giả lập. Chú ý bạn vẫn ở trong bộ menu Cloth, chọn Simulation > Save as Initial Cloth State. Maya sẽ sử dụng vị trí áo hiện tại và tạo hình ở frame đầu tiên tạo chuyển động (frame - 20). Tạo đối tượng collision 1. Chọn mô hình nhân vật. 2. Chọn Cloth > Create Collision Object.
  12. Chuyên đề Đồ họa Ứng dụng 3. Trong Channel Box, gán giá trị Collision Offset bằng 0.16 và Collision Depth bằng 0.2. Không cần quan tâm đến báo lỗi Cycle on joint… Giả lập 1. Chọn Simulation > Start Local Simulation. Áo sẽ từ từ rũ xuống mô hình. Khi cảm thấy ưng ý thì nhấn Esc. 3. Import và điều khiển mẫu quần Import và định vị mẫu quần 1. Giấu mẫu áo. (Tên của mẫu áo là shirtExport:shirt). 2. Chọn File > Import … ( tương tự như cách import mẫu áo). 3. Sử dụng các số liệu sau (nếu muốn): o Translate X: 10 o Translate Y: 0 o Translate Z: -10 o Rotate Y: -30 4. Chọn mẫu quần, click pantsExport:cpSolver1 trong Channel Box. Đặt frame bắt đầu là -20. Khi giả lập, hành động giả lập sẽ bắt đầu ở frame -20. 5. Chọn Simulation > Save as Initial Cloth State Maya sẽ sử dụng vị trí mẫu quần hiện tại và tạo hình ở frame đầu tiên tạo chuyển động (frame -20). Khi bạn import mẫu áo quần, Maya cũng import luôn các solver. Tên của các solver là: pantsExport:cpSolver1, shirtExport:cpSolver1, được liệt kê trong menu Simulation > Solvers >. Lúc này, các solver chưa có tác dụng nào lên mẫu áo quần vì bạn chưa liên kết chúng với mô hình nhân vật trong scene này. Bây giờ, bạn sẽ tạo cho mô hình nhân vật một đối tượng collision( đối tượng điều khiển va chạm) để tương tác với mẫu quần trong suốt quá trình giả lập. 0112144_0112026_0112279
  13. Tạo đối tượng collision cho mẫu quần 1. Chọn Simulation > Solvers >pantsExport:cpSolver1 để tạo solver pantsExport:cpSolver1. 2. Chọn mô hình nhân vật. 3. Chọn Cloth > Create Collision Object. 4. Chọn mẫu quần để chỉ định rõ solver bạn muốn sử dụng. Mặc dù shirtExport:cpSolver1 chưa có tác dụng gì do nó chưa kết nối với mô hình nhân vật nhưng bạn vẫn phải chỉ rõ là chọn mẫu quần để đảm bảo thao tác là thực hiện trên mẫu quần khi tiến hành giả lập. Nếu một scene có nhiều hơn một solver, tại một thời điểm chỉ có thể thực hiện thao tác giả lập cho một đối tượng duy nhất. Do đó, bạn phải chọn rõ solver muốn thực hiện. Giả lập 1. Chọn Simulation > Start Local Simulation. Nhấn Esc khi cảm thấy ưng ý. 4. Điều khiển các solver Mục đích: Để tạo cho áo sơ mi phủ lên quần và để không chỉ mô hình nhân vật mà cả áo quần cũng được gắn đến solver Di chuyển solver của mẫu quần đến mẫu áo 1. Chọn Simulation > Solvers > shirtExport:cpSolver1 để tạo solver cho mẫu áo. 2. Chọn mẫu quần, chọn Simulation > Transfer Garment. Hành động này dùng để di chuyển mẫu quần đến solver của mẫu áo. Để xác nhận mẫu quần được điều khiển bởi solver của mẫu áo, đánh dấu hộp kiểm shirtExport:cpSolver1 trong phần INPUT của Channel Box. 3. Trong Command Line, đánh lệnh: delete pantsExport:cpSolver1 Lệnh này xóa solver của mẫu quần (vì không cần sử dụng nó nữa)
  14. Chuyên đề Đồ họa Ứng dụng 5. Tạo lưới Mục đích: Đảm bảo cho mẫu quần được định vị phù hợp khi nhân vật di chuyển. Thêm lưới cho mẫu quần 1. Chọn mô hình nhân vật và chọn Display > Object Display >Template. 2. Right-Click mẫu quần và chọn Vertex. 3. Chọn dòng trên cùng trong các vertex của mẫu quần. Nhấn phím Shift để thêm( hoặc bỏ) các vertive vào nhóm chọn lựa. 4. Trong Outliner, giữ phím Ctrl và click vào chỉ mục jackie. Hành động này thêm mô hình nhân vật vào nhóm chọn lựa mà không bỏ chọn các vertice. 5. Chọn Constraints > Mesh để tạo lưới. Biểu tượng lưới xuất hiện trên mẫu quần, chỉ ra vị trí mẫu quần được ràng buộc vào mô hình nhân vật. Giấu biểu tượng mesh. 6. Điều chỉnh lại trang phục Mục đích: Cho áo sơ mi phủ lên quần. Điều chỉnh lại mẫu áo 1. Bỏ chọn mẫu mô hình nhân vật (untemplate). 2. Hiển thị mẫu áo (show) 3. Giấu mô hình nhân vật cho đỡ rối mắt. 4. Chọn mẫu (template) mẫu quần để bạn không thể thực hiện thay đổi gì trên nó. 5. Right-Click con trỏ trên mẫu áo và chọn Vertex từ menu đang được đánh dấu. 6. Chọn tất cả các đỉnh(vertex) đè chồng mẫu quần và một nhánh nhỏ các đỉnh không đè chồng lên mẫu quần. Nếu không thể thấy khu vực đè chồng cách rõ ràng, nhấn 4 để hiển thị wireframe, sau đó chuyển vào view. 7. Dùng công cụ Move và Scale để di chuyển các vertice ra khỏi mẫu quần. 0112144_0112026_0112279
  15. 8. Chọn mẫu áo và chọn Simulation > Update Cloth State. Hành động này cập nhật cho solver vị trí mới của các vertice. Việc làm này cần thiết để có thể tạo giả lập chính xác ở bước kế tiếp. 9. Chọn Simulation > Properties > shirtExport:cpPropertyShirt > . Cài đặt các thông số: Thickness = 1.5 và Thickness Force = 3.5. Trường Thickness chỉ ra offset của điều khiển collision của bộ trang phục nó va chạm vào nhau hay vào các đối tượng quần áo khác. Trường Thickness Force cài đặt mức độ ép buộc Maya sử dụng Tiến hành simulation cho một loạt chuyển động Mục đích: Tiến hành simulation ở thế đứng thông thường để bắt đầu thực hiện chuyển động đi bộ. Thực hiện việc này để tạo cái nhìn tự nhiên hơn cho mẫu áo quần trước khi thực hiện chuyển động đi bộ. Thêm lưới cho mẫu quần 1. Trong Time slider, đặt vị trí đầu tiên bằng -20 và vị trí kết thúc bằng 1. 2. Chọn Simulation > Solvers > shirtExport:cpSolver1 > . Cài đặt giá trị cho các thuộc tính sau: • Start Frame: -20 • Frame Samples: 2 • Relax Frame Length: 0
  16. Chuyên đề Đồ họa Ứng dụng Giá trị thuộc tính Frame Samples định mức độ thường xuyên mà solver thực hiện những tính toán của quần áo trong suốt quá trình simulation. Giá trị này càng cao thì càng chính xác hơn nhưng thời gian xử lý sẽ lâu hơn. Mặc định, simulation là một tiến trình gồm 2 phần. Phần đầu, solver chỉnh vừa vặn áo quần cho nhân vật mà không có hiệu ứng gì khác. Phần hai, chỉnh vừa vặn áo quần cộng thêm một số hiệu ứng. Giá trị thuộc tính Rax Frame Length chỉ định độ dài thời gian mà Maya chỉnh vừa vặn trang phục cho mô hình cơ thể trước khi hiệu quả của các hiệu ứng hiệu quả khác thể hiện. Nhìn chung, số frame càng lớn thì độ vừa vặn sẽ càng cao hơn. 3. Chọn mẫu áo. Chọn Simulation > Delete Cache 4. Chọn Window > Settings/Preferences > Preferences. Click mục Timeline, chọn Looping to Once > Save. 5. Đến frame đầu của việc tạo chuyển động và cho play. Ta sẽ có chuyển động xuyên suốt từ frame -20 đến frame 1. Ở frame 1, mẫu áo và quần đã được định vị trên cơ thể trông tự nhiên hơn tại lúc bắt đầu thực hiện chuyển động đi bộ. 7. Lưu trạng thái khởi tạo cho trang phục Mục đích: Ở bước này, bạn sẽ lưu lại vị trí hiện tại của mẫu áo và quần, xem đây là vị trí đầu tiên của chúng tại thời điểm bắt đầu của chuyển động. Lưu trạng thái khởi tạo cho mẫu áo và quần 1. Chọn mẫu áo. 2. Simulation > Save as Initial Cloth State 3. Chọn mẫu quần. 4. Simulation > Save as Initial Cloth State Tiến hành simulation cho chuyển động đi bộ 1. Đặt vị trí bắt đầu và kết thúc của Time slider là 1 và 118. Đây là khoảng frame bạn sẽ tiến hành simulation. 2. Chọn Simulation >Solvers >shirtExport:cpSolver1 > và đặt frame bắt đầu bằng 1. Giá trị này chỉ định frame solver sẽ bắt đầu tiến hành simulation. 3. Chọn Simulation > Delete Cache 4. Play. Ta đã tiến hành simulation cho chuyển động đi bộ. Sau khi cho chạy simulation, chuyển động của quần áo đụơc ghi nhận lại trong cache. Do đó, bạn có thể hủy bỏ một số thời điểm trong Time slider để giúp cho hành động playback được nhanh hơn Nếu muốn tiến hành simulation lại với những cài đặt thụôc tính khác thì điều đầu tiên bạn phải làm là xóa cache. Mặc khác, việc hủy bỏ các thời điểm và cho playback sẽ sử dụng lại các chuyển động ở lần simulation trước. 0112144_0112026_0112279
  17. V. Hoạt cảnh và ánh sáng. A. Giới thiệu rendering. - Rendering là bước cuối cùng trong xử lý đồ hoạ 3D.Mặc dù nội dung tập trung chú ý của rendering bắt đầu với shading(độ sáng, vẽ bề mặt), texturing(gán vật liệu) lên đối tượng và lighting(chiếu ánh sáng)của toàn bộ khung cảnh, nhưng quá trình rendering kết thúc khi các suface(bề mặt), material(vật liệu), light(ánh sáng) và motion (chuyển động được xử lý tích hợp vào hình ảnh cuối cùng) 1. Quan sát kết quả render. - Khi bạn tạo khung cảnh( gồm share và texture cho đối tượng, ánh sáng cho khung cảnh, vị trí của camera .v.v.) bạn muốn thấy khung cảnh của bạn nhiều lần khác nhau trước khi đưa ra sản phẫm render cuối cùng. Quá trình này có thể liên quan đến việc tạo và khởi gán các camera thêm ngoài các camera mặc định trong Maya. - Việc nhìn thấy khung cảnh trong quá trình trương tác đế phát hiện và sửa những vấn đề về chất lượng của hình ánh, hoặc để giãm thời gian của quá trình render cuối cùng trước khi công bố sản phẫm cuối cùng. - Khi bạn đã đồng ý với kết quả của khung cảnh trong suốt quá trính kiễm tra render, bạn có thể công bố kết quả render cuối cùng. - Bạn có thể thấy và kết thúc render trong một frame( một phần của hoạt hình-nhiều frame) hoặc trong toàn bộ hoạt hình. 2. Điểm quyết định thực hiện render thành công. - Điểm quyết định cho thành công đó là tìm một sự cân bằng giữa chất lượng ảnh cao và tốc độ rendering(được xát định bao nhiêu frame được rende trong một chu kỳ thời gian. - Rendering giải quyết một số lượng lớn các tính toán phức tạp dẫn đến máy tính phải làm việc tong một thời gian dài. Quá trình rendering lấy dữ liệu từ nhiều hệ thống con trong Maya và tương tác các dữ liệu có liên quan làm nền tản cho quá trình áp vật liệu, độ bóng, trích đoạn phim, chiếu sáng. - Việc tạo ra hình ảnh render luôn liên quan vấn dề chọn lựa giữa chất lượng hình ảnh và tốc dộ thực hiện render, hoăc cả hai. - Hình ảnh chất lượng cao chiếm hầu hết thời gian render. Điễm quyết để làm việc thuận lợi là tạo ra hình ảnh có chất lượng vừa phải mà ớ đó thời gian thi hành ít nhất có thể. Trong thực tế chọn lưa giá trị có lợi đó là tạo ra hình ảnh có chất lượng có thể chấp nhận được trong đồ án của bạn. B. Các loại rendering: 1. Render phần mềm: - Software rendering cho hình ảnh chất lượng cao nhất, cho phép bạn tạo ra những kất quả tinh vi nhất. - Xử lý tính toán thực hiện trong CPU ( trái ngược với hardware rendering xử lý trên card đồ hoạ. Bởi vì nó không bị hạn chế bởi card đổ hoạ của máy tính,
  18. Chuyên đề Đồ họa Ứng dụng softvare rendering thường thì linh hoạt hơn. Tuy nhiên có hạn chế là software rendering thường chiếm nhiều thời gian hơn. - Chính xát là bạn render như thế nào là tuỳ thuộc vào software rendering nào bạn sử dụng và những hạn chế riêng của nó - Maya có 2 loại software render: o Maya software render. Software render là render cao cấp (renderer đa tiểu trình). Nó dựa trên cơ sở của công nghệ renderer xây dựng trực tiềp trên May phụ thuộc với kiến trúc đồ hoạ, điều đó có nghĩa các node đặc trưng của software renderer có thể kết nối trực tiếp với các node đặc trưng khác troong Maya. Nó cung cấp tính nghệ thuật cao để giải quyết rendering yêu cầu cao. Software rendering là một render hỗn hợp (kết hợp raytracing và ưu thế về tốc độ của renderer từng dòng. Mặc dù software renderer không chậm nhưng để hướng chất lượng hình ảnh mong muốn phức tạp thì có thể vượt qua tốc độ nguyên thuỷ. Software renderer hỗ trợ nhiều thực thể khác nhau thành lập trong Maya gồm các phần tử hiệu ứng paint, hiệu ứng sương mù, geometry. Nó cũng có API rất mạnh cho việc thêm các hiệu ứng lạ trong quá trình tạo lập. Software renderer hỗ trợ công cụ IPR cho phép bạn tạo tương tác điều chỉnh hình ảnh renderer cuối cùng. Quan trọng nhất đặc điểm tự nhiên của kiến trúc tích hợp của Maya cho phép các kết nối phức tạp( chẳng hạn như texture và mọc cỏ- quản lý sự phát ra và những mối quan hệ khác không dực đoán trước được để tạo ra các hiệu ứng nhìn thấy được. o Mental ray for Maya. Mental ray cung cấp tất cả các đặc điễm cơ bản của khía cạnh photorelistis rendering và các hàm không thấy được trong software rendering. Metal ray cho phép tương tác và xử lý mental ray rending theo lô từ trong giao diện người dùng. Với sự hỗ trợ của tạo độ bóng để hỗ trợ hầu hết các hiệu ứng có sẳn torng Maya, thì mental ray cho phép rendering khung cảnh được xử lý ngay trong Maya hoặc export vào trong file ảnh format kiểu mental (.mi). Sau khi bạn chọn kiểu render là mental ray thì một list các menu render có sẳn các menu item cho mental ray. Cũng giống như Attribute Editor có chứa mục mental ray, trong đó bạn có thể soạn thảo các thuộc tính để sử dụng trong quá trình rendering bẳng mental ray. 2. Render phần cứng - Hardware rendering sử dụng video card và các driver có trong máy để render hình ảnh lên đĩa. Hardware rendering thường nhanh hơn Software rendering, nhưng thường chất lượng hình ảnh thấp hơn. Tuy nhiên trong một vài trường hợp hardware rendering có thể cho kết quả đủ tốt việc giao hàng qua mạng. 0112144_0112026_0112279
  19. - Hardware rendering không thể tạo ra nhiều hiệu ứng tinh vi (chẳn hạn như độ bóng, phản xạ ...). Để tạo ra những hiệu ứng này bạn phải sử dụng software rendering. - Maya có hardware render: o Maya hardware render. Hardware renderer trình bày cách giải quyết rendering tích hợp nguyên vẹn,cách giải quyết này chiệu ành hưởng rất lớn của chất lượng card đồ hoạ để render hình ảnh. Các thuận lợi gồm: workflow tự nhiên để tạo ra hình ảnh được rendering cho việc xem trước, các phân tích đặc biệt, và các phần tử hardware render. Bạn có thể render và hiển thị hình ảnh bằng Render View, Render View cho phép bạn so sánh hình ảnh trong suốt qua trình thực hiện thao tác làm bóng và chiếu sáng. Kinh nghiệm của người dùng và chất lượng của hình ảnh cuối cùng, đã thấy được sự vượt trội của Hardware Render Buffer. Bạn có thể cung cấp braodcast- giải quyết hình ảnh trong thời gian ngắn hơn software rendering. Trong một vài trường hợp chất lượng hình ảnh đủ tốt để bàn giao. Hardware render dùng workflow và giao diện có sẳn để thực hiện làm bóng, cấu trúc, các phần tử, liên kết chiếu sáng … 3. Render dạng vector: - Vector rendering cho phép bạn tạo ra các rendering chuẩn (ví dụ nhân vật hoạt hình, ẩn đường thẳng, kỹ xảo trên đường thẳng, kỹ xảo trên đường cong, đường viền khung) trên các format hình ảnh bitmap hoặc format vactor 2D. - Maya có vector render: o Maya vector render. - 4. Cách chọn loại render: - Khi bạn chọn một loại render, giao diện người dùng của Maya sẽ tự động cấu hình để dùng cho render. Ví dụ nếu bạn render frame hiện tại, Maya dùng renderer để xử lý hình ảnh và hiển thị nó trong Render View. Hoặc nếu bạn biếtchọn nút Display Render Globals Setting thì cửa sổ Render Globals Setting xuất hiện, chọn tab Common và tab này đáp ứng được việc chọn render. - Để chọn render thực hiện một trong các cách sau: o Chọn Render > Render Using, cau đó chọn render o Rendering > Rendering Editors > Render View sau đó chọn kiểu render trong drop-down list trong Render View o Chọn kiểu render từ drop-down list trong cửa sổ Render Global Settings. - Chú ý: mental ray renderer và Maya Vector renderer là thêm vào mặc định. Nếu bãn không thấy nó trong listed trong Render > Render Using, thì chọn Window > Settings/Preferences > Plug-in Manager và chắc chắn phải chọn Mayatomr và VectorRender plug-ins. - Để định nghĩa renderer mặc định: o Chọn Window > Settings/ Preferences > Plug-in Manager.
  20. Chuyên đề Đồ họa Ứng dụng o Chọn Rendering sau đó chọn Preferred Renderer. C. Camera 1. Nhìn cảnh thông qua camera và thực hiện render qua camera. - Bất cứ khi nào dù bạn đang xây dựng khung cảnh hay đang render một hình ảnh, bạn cũng đang nhìn qua một camera.Tức là bạn đang nhìn theo môt hướng vào hình ảnh xuyên qua kính của camera cho nên vùng nhìn của bạn bị giới hạn trong những gì bạn thấy qua kính của camera. - Mặc dù maya có 4 camera để cho phép bạn nhìn thấy khung cảnh trong một panel: 1 camera phối toàn cảnh và 3 camera chiếu thẳng ( từ các vị trí trên đầu, bên hông và trước mặt) để phù hợp với các cách nhìn mặc định vào khung cảnh. Bạn nhìn thông qua các camera này khi bạn modeling, animate, share và texture các đối tượng. - Thông thường bạn không sử dụng 4 camera mặc định này để render một khung cảnh (bạn tạo ra 1 hoặc nhiều camera để thực hiện việc render này. Sự khác biệt giữa camera rendering và các camera khác đó là cho phép render khung cảnh của bạn. 2. Các loại camera - Camera của Maya có nhiều thuận lợi như camera ở thế gới thực, diều đó cho bạn tự do sáng tạo. Ví dụ vì camera của maya không hạn chế về kích thước và trọng lượng nên bạn có thể di chuyển camera đến bất kỳ vị trí nào trong khung cảnh, thận chí bên trong một đối tượng rất nhỏ. - Các camera tĩnh và động: có 3 kiểu camera giúp cho bạn tạo khung cảnh tĩnh hoặc động: o Sử dụng camera Basic cho khung cảnh tĩnh hoặc động đơn giản ( chẳng hạn như paint lên khung cảnh). o Sử dụng camera Aim hoặc Camera cho những khung cnảh hơi động (chẳng hạn như camera cho phép dic huyển theo đườg chim bay). o Sử dụng camera Aim,Camera và Up để định nghĩa bề mặt cốu cìng nào mà camera phải hướng đến. Camera cày là cáh chọn lựa tốt nhất cho các chuyển động phức tạp (chẳng hạn như camera chuyển động quay tròn quanh bờ biển). 3. Hiệu ứng mờ đần do di chuyển và độ sâu của vùng quan sát a) Tập trung chiếu sáng và làm lu mờ. - Xử lý ghi hình laị những gì bạn thấy thông qua camera rất đơn giản: nhấn vào một nút để mở shutter(shutter cho phép ánh sáng qua aperture (aperture làm cho phim trở nên sáng)) để ghi lại những gì bạn thấy. - Việc khởi gán thể hiện của camera được xát định bởi depth of field ( vùng tập trung thể hiện) và có hoặc không có một chủ thể bị làm lu mờ bằng thuộc tính motion. 0112144_0112026_0112279
Đồng bộ tài khoản