Các ứng dụng flash

Chia sẻ: Nguyen Thanh Cuong | Ngày: | Loại File: DOCX | Số trang:26

0
80
lượt xem
33
download

Các ứng dụng flash

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Đầu tiên, bạn mở file PowerPoint muốn chèn Flash bằng chương trình Microsoft PowerPoint. - Tiếp theo, từ menu, bạn chọn View - Toolbar - Control Toolbox. - Tại đây, một hộp thoại mới sẽ xuất hiện với tên gọi Control Toolbox. Tại hộp thoại này, bạn click vào biểu tượng More Control (nằm ngòai cùng bên phải) và một danh sách mới sổ xuống. Bạn chọn “Shockwave Flash Object” từ danh sách sổ xuống này.

Chủ đề:
Lưu

Nội dung Text: Các ứng dụng flash

  1. Làm thế nào để chèn file Flash vào PowerPoint ppt Tháng Năm 29, 2008 Posted by Kinh nghiệm hay in Máy tính, ĐTDĐ, Game, Uncategorized. Tags: flash, powerpoint trackback - Đầu tiên, bạn mở file PowerPoint muốn chèn Flash bằng chương trình Microsoft PowerPoint. - Tiếp theo, từ menu, bạn chọn View -> Toolbar -> Control Toolbox. - Tại đây, một hộp thoại mới sẽ xuất hiện với tên gọi Control Toolbox. Tại hộp thoại này, bạn click vào biểu tượng More Control (nằm ngòai cùng bên phải) và một danh sách mới sổ xuống. Bạn chọn “Shockwave Flash Object” từ danh sách sổ xuống này. - Sau khi chọn tùy chọn này xong, một khung hình chữ nhật sẽ hiện ra, file Flash của bạn sẽ được hiển bị bên trong khung này. Bây giờ bạn sử dụng chuột, kéo khung đến vị trí bất kỳ nào đó trong Slide mà bạn muốn file Flash hiển thị. Sau khi đã chọn xong cho mình vị trí thích hợp, bạn click chuột phải vào khung này và chọn Properties. - Hộp thọai Properties sẽ hiển ra với những tùy chọn mới. Tại khung hộp thoại này, bên dưới tab Alphebet, bạn tìm đến tùy chọn Movie và điền vào đó đường dẫn đầy đủ của file Flash muốn sử dụng vào khung ở bên phải. (Ví dụ D:\Flash\Test.swf) - Tiếp theo, ở trong cùng tab Alphabet này, tại tùy chọn Playing, bạn thiết lập giá trị “True” và tùy chọn EmbedMovie bạn cũng thiết lập giá trị True để file Flash tự động chơi khi trình diễn đến Slide chứa nó. Nếu không muốn, bạn thiết lập giá trị của EmbedMovie là False để điều khiển bằng tay. Tại hộp thoại Properties này, bạn cũng có thể thiết lập chất lượng Flash (Quality), kích thước Flash (Width)… - Cuối cùng, bạn đóng hộp thoại Properties, save lại file PowerPoint vừa chỉnh sửa và thử nghiệm lại kết quả.
  2. Làm Pháo Hoa đơn giản Bài này hướng dẫn các bạn chỉ dùng hiệu ứng Motion Tween tạo được pháo hoa rất thú vị Bước 1: tạo movie 1 vào Insert - new symbol (hoặc nhấn Ctrl+F8) Bạn bắt đầu vẽ viên pháo trong Stage của movie này có thể chọn công cụ PolyStar tool để vẽ hình ngôi sao cho viên pháo, để sử dụng công cụ này bạn cần kích vào nút tam giác nhỏ ở công cụ Rectangle Tool và hơi kéo nhích xuống Sau khi chọn được công cụ PlyStar Tool bạn mở bảng Properties kích chọn nút Options, ở bảng Tool Setting kích chọn star để vẽ hình ngôi sao số cánh tùy thuộc vào số bạn chọn ở dưới, nhấn OK
  3. Bây giờ bạn bắt đầu vẽ viên pháo với màu vẽ có đậm nhạt và không có viền xung quanh lưu ý vị trí đặt viên pháo (ngay dấu + ở giữa Stage) Trên Layer 1 bạn chọn key Frame 11 nhấn F6 sau đó kích chuột phải vào giữa và chọn Create Motion Tween , chọn tiếp key
  4. Frame 11, di chuyển viên pháo đi lên một đoạn bằng phím mũi tên trên bàn phím, nếu nhấn phím Enter thì sẽ thấy viên pháo di chuyển lên phía trên. Trở ra Stage chính, kích vào mũi tên xanh Bước 2: tạo movie 2 Tiếp tục vào Insert - new symbol (hoặc nhấn Ctrl+F8) tạo movie 2 đặt tên là pháo_hoa, chọn Movie clip, nhấn OK
  5. Trong Stage của movie 2, vào Library kéo viên pháo (chính là movie 1) vào movie 2 Kích chọn công cụ Free transform Tool, kích vào viên pháo, trên viên pháo lúc này xuất hiện các hạt bao quanh ở chính giữa có một chấm tròn , kích vào chấm tròn này kéo xuống cạnh dưới của viên pháo, di chuyển viên pháo sao cho chấm tròn trùng vào dấu + Nhấn Ctrl + T mở bảng Align & Info & Transfonm , chọn Rotate đánh vào số 60 (có thể 30,15 tùy theo hình dáng của viên pháo), sau đó kích vào nút Copy and apply transform ở góc dưới, mỗi lần kích vào thì viên pháo được nhân 1 bản, đến khi đủ thì thôi. Bây giờ bạn trở ra Stage chính kéo movie 2 pháo hoa ra đặt trên 1 Layer
  6. nhấn phím alt vừa kích chuột vào phim pháo hoa copy chồng lên phim đó thay đổi kích thước xoay một chút sao cho đồng tâm. Tạo thêm pháo hoa khác có hình , màu khác giống cách làm ở hai bước trên Bạn có thể vẽ viên pháo bằng các các nét thẳng, các loại nét nghệ thuật... Sắp xếp các viên pháo trên bầu trời cho hợp lý, kích thước to nhỏ khác nhau tạo thêm 1 Layer khác làm nền ở dưới layer pháo hoa có màu đậm như bầu trời đêm. Nhấn Ctrl + enter xem kết quả. Flash và các hiệu ứng đẹp mắt Motion Tween (đối tượng thay đổi vị trí) Flash có thể tạo ra hai cơ chế chuyển động của đối tượng thông qua vi ệc s ử dụng timeline đó là:Motion Tween & Shape Tween. (Để biểu diễn movie theo thời gian, người ta thường dùng một trục th ẳng n ằm ngang gọi là Timeline. Timeline được chia thành nhiều khoảng, mỗi kho ảng nh ư thế tương ứng với một hay một vài khung hình). Motion tween sẽ tạo ra sự chuyển động của đối tượng từ vị trí này đến vị trí khác.\ Bạn chỉ cần xác hai trạng thái đầu, cuối của đối tượng. Các trạng thái trung gian sẽ do Flash tự hình thành. Như ví dụ trên, bạn chỉ cần chuyển đối tượng chiếc bút chì sang thành Symbol trong Flash, sau đó xác định các vị trí điểm đầu và cuối của chuyển động, ngay lập tức bạn sẽ có được một chuyển động đẹp mắt. Các bước thực hiện: 1. Tạo mới một file flash với Ctrl+N. Nếu cửa sổ timeline chưa xuất hiện bạn nhấn Ctrl+Alt+T. Bạn sẽ thấy 'Layer1' trong cửa sổ timeline. Bạn chỉ cần xác hai trạng thái đầu, cuối của đối tượng. Các trạng thái trung gian sẽ do Flash tự hình thành. Như ví dụ trên, bạn chỉ cần chuyển đối tượng chiếc bút chì sang thành Symbol trong Flash, sau đó xác định các vị trí điểm đầu và cuối của chuyển động, ngay lập tức bạn sẽ có được một chuyển động đẹp mắt.
  7. Các bước thực hiện: 1. Tạo mới một file flash với Ctrl+N. Nếu cửa sổ timeline chưa xuất hiện bạn nhấn Ctrl+Alt+T. Bạn sẽ thấy 'Layer1' trong cửa sổ timeline. 9. Nhấn Ctrl+Enter để xem motion tween bạn vừa tạo 2. Shape Tween (đối tượng thay đổi hình dạng) Shape Tween là kỹ thuật tạo sự thay đổi hình dạng của đối tượng (vị trí, hình dạng, kích thước, màu sắc, …). Các bước thực hiện: Ví dụ: Bạn muốn biến đổi một đối tượng từ dạng hình tròn sang hình vuông. 1. Tạo mới một file flash với Ctrl+N. Nếu cửa sổ timeline chưa xuất hiện bạn nhấn Ctrl+Alt+T. Bạn sẽ thấy 'Layer1' trong cửa sổ timeline. 2. Chọn frame đầu tiên, vẽ bất kỳ một đối tượng (trong ví dụ này bạn sẽ vẽ một hình tròn). Đây chính là đối tượng khởi đầu của Shape tween. 3. Chọn frame 25 và nhấn F6 để chèn một keyframe mới. 4. Tại frame 25, xoá đối tượng ban đầu và vẽ mới một đối tượng khác (trong ví dụ này bạn sẽ xoá hình tròn và vẽ mới một hình vuông). 5. Kích chọn một frame ở giữa bất kỳ (2 đến 24), chọn Shape từ thực đơn pop- up trong phần Tween. Khi đó, Layer 1 sẽ có dạng như hình dưới.
  8. 4. Tại frame 25, xoá đối tượng ban đầu và vẽ mới một đối tượng khác (trong ví dụ này bạn sẽ xoá hình tròn và vẽ mới một hình vuông). 5. Kích chọn một frame ở giữa bất kỳ (2 đến 24), ch ọn Shape t ừ th ực đ ơn pop- up trong phần Tween. Khi đó, Layer 1 sẽ có dạng như hình dưới. 3. Masking (mặt nạ) Nếu biết cách sử dụng mặt nạ bạn sẽ có thể tạo ra các hiệu ứng để lộ dần dần hoặc từng phần nội dung của một bức tranh hay bức vẽ. Như ví dụ dưới đây, khi mặt nạ di chuyển, từng phần của ngọn núi s ẽ được hiển thị. Các bước thực hiện: 1. Chèn Layer và đặt tên cho chúng: - Mặc định, bạn đã có sẵn một layer trong cửa sổ timeline. Hãy chèn thêm một layer nữa, bạn cần phải có hai layer để tạo mặt nạ cho một đối tượng. - Đổi tên layer trên cùng thành 'Mask' và layer bên dưới thành 'background'. 2. Tạo Shape Tween cho vòng tròn của layer 'Mask': - Chèn bức ảnh của bạn vào layer 'background'. - Di chuyển đến frame 40 của layer 'background' và nh ấn phím F5 đ ể chèn thêm các frame mới, vì thế bức ảnh nền của bạn sẽ không bị thay đổi. - Sử dụng công cụ vẽ hình Oval vẽ một vòng tròn trên layer 'Mask', nh ớ xoá viền của vòng tròn (border). Kéo vòng tròn đến vị trí bắt đ ầu c ủa chuy ển đ ộng. - Di chuyển đến frame 40 trên layer 'Mask', nh ấn phím F6 đ ể chèn m ột keyframe mới. Kéo hình tròn di chuyển đến vị trí cuối của chuy ển động. - Sau đó chọn frame 1 của layer 'Mask', ch ọn Shape từ th ực đ ơn pop-up trong phần Tween. 3. Tạo mặt nạ: - Kích chuột phải trên layer 'Mask' (phần hiển thị tên của layer) và chọn mục Mask. 4. Khi đó lớp mặt nạ bạn tạo đã hoàn thành. Nhấn Ctrl+Enter để xem kết quả.
  9. Chúc các bạn thành công st
  10. Tự thiết kế banner cho trang web riêng trên Violet bằng Flash 8 Thầy Cô và các bạn muốn tự thiết kế một banner cho trang riêng của mình bằng phần mềm Flash cũng rất đơn giản. Bước 1: khởi động phần mềm Flash. Kích chuột phải vào giữa Stage chọn Document propeties để mở bảng Document propeties . Trong bảng này bạn phải chọn kích thước cho banner của mình. Banner của các website trên hệ thống của violet.vn có bề ngang là 770 pixel. và chiều cao của banner thì tùy ý. Thầy Cô chỉ nên để chiều cao ở khoảng từ 150pixel đến 200pixel là vừa . Nhấn OK, bây giờ kích thước Stage đã thay đổi đúng với kích thước banner sau này của bạn Bước 2: Chọn màu nền cho banner sao cho phù hợp với các mẫu nền Web trong thư viện cung cấpchọn công cụ Rectang Tool (R) vẽ một hình chữ nhật có màu dã chọn phù hợp vừa trùng khít Stage hoặc rộng hơn chút ít, Layer1 làm nền Chèn thêm 1 layer khác bằng cach kích vào nút inset layer là Layer2 vẽ hình chữ nhật nằm ngang phía cạnh trên của banner như hình dưới vị trí này sẽ hiển thị lời chào và tên thành viên khi đã đăng nhập.(Layer2 phải nằm trên Layer1) - Nếu muốn đưa một tấm ảnh KTS của cá nhân hoặc đơn vị mình vào làm nền cho banner thì vào File > impots>impost to Stage>chọn file ảnh nhập vào sau đó chọn công cụ Free Transform Tool (Q) . để chỉnh sửa, nếu muốn xóa bớt một phần của ảnh bạn vào Modify> Break apart để chuyển ảnh thành đối tượng Graphic sau đó có thể tẩy xóa dễ dàng. - *Phần còn lại là chữ Tên Web, Blog, tên cá nhân, tên trường...Bạn phải thêm một layer mới làLayer 3 bằng cách kích vào nút inset layer , chọn công cụ text Trong bảng Propeties , Theo kinh ngiệm của bản thân bạn chỉ nên chọn Font Vn......(Bảng mã TCVN3) và chọn kích thuớc chữ và màu sắc phù hợp với màu của nền banner.- Để tăng phần sinh động cho banner trong layer 3này ta không làm như vậy mà chèn vào một movie (đoạn phim), bằng cấch vào Insert> New symbol>Bảng Create New symbol hiện ra ta đạt lại tên cho đoạn phim này và kích chọn Type là Movie Clip>OK. Cửa sổ mới mở ra và bạn thao tác với các công cụ như phần trên(*) với nội dung chữ mà ta cần thể hiện . Sau đó trở ra Stage chính và kéo đoạn phim từ Library vào Layer 3- Đến đây ta có thể nhấn Ctrl+ Enter để kiểm tra và điều chỉnh File .swf sẽ là banner Bước 3:
  11. Lưu file sau đó nhấn Ctrl+ Enter để chương trình tự xuất ra một file có đuôi là .swf Đăng nhập vào Web, blog của bạn vào mục quản trị chọn ô Banner chọn tiếp file.swf là banner bạn vừa thiết kế sau đó cập nhật. Chúc các bạn thành công. *Một số kinh nghiệm cho banner tự thiết kế: · Nếu bạn biết nhiều hiệu ứng Flash thì có thể làm nhiều movie và chèn vào các layer khác nữa để tăng thêm phần hấp dẫn cho banner· Để chèn nhạc vào banner bạn cũng nên tạo layer mới sau đó vào file> impost vào nhưng cũng nên hạn chế vì nó sẽ gây cho thành viên cảm giác lẫn lộn giữa lời nhạc nền và nhạc sẽ phát lên trong mục tư liệu.· Dung lượng của banner càng nhỏ thì nó hiển thị càng nhanh và tạo được thiện cảm với thành viên khi họ truy cập.
  12. Tạo tài liệu Viết chữ bằng Flash Viết chữ c thường Bước 1: Mở chương trình Flash, kích phải chuột chọn Doccment Properties đ ặt kích th ước là 380 px (with) và 350 px(height), nhấn OK Trên Layer 1 Thầy Cô dùng công cụ vẽ ôly như ở trang vở học sinh thường dùng Bước 2:
  13. Chèn thêm Layer 2 vẽ chữ c thường vào chọn công cụ Oval Tool vẽ một vòng tròn sau đó xoá đi một đoạn sao cho giống với mẫu chữ chuẩn, cứ cách 2 frame trên thanh tiến trình ta nhấn F6 chèn vào một key frame cho đến key frame 25 là vừa và trong 25 key frame này cứ cách chọn lần lượt các key frame chính từ 1 đến 25 ta lần lượt xoá một phần chữ c ở key frame 1, 3, 5,… chỉ chừa lại một chấm nhỏ là điểm bắt đầu của con chữ, cho đến key frame 25 thì chữ c vừa đủ nét. nếu nhấn phím enter ta thấy chữ c đã tự vẽ nó theo tiến trình (ở đây chỉ có chữ c ở key frame 25 là đầy đủ nét từ key frame 24 chữ c mất dần từng phần đến key frame 1 chỉ còn một chấm nhỏ) Bước 3: Vào inser > new symbol chọn Graphic nhấn OK vẽ hình cây bút chì Chèn thêm Layer 3 nhấn Ctrl + L để xuất hiện Library vào Library kéo cây bút ra Stage kích chọn công cụ Free Transform Tool và kéo tâm điểm của cây bút về đầu bút, ở key frame 1 di chuyển đầu cây bút sao cho trùng khít với chấm còn lại của chữ c
  14. Bước 4: Trên Layer 3 ( chứa cây bút) kích chọn frame 25 và nhấn F6, kích phải vào giữa chọn Create Motion Teen tạo hiệu ứng chuyển động cho cây bút , chọn Layer 3 kích vào nút Add Motion Guide để làm cho cây bút chuyển động theo nét vẽ chữ c . tiếp tục chọn lớp Guide:La…Chọn công cụ Pencil Tool và vẽ một đường cong trùng khớp vối chữ c, sau đó di chuyển cây bút đến điểm đầu và điểm cuối của đường cong này.
  15. Lúc này nhấn Ctrl + enter ta thấy cây bút chạy theo nét vẽ , nếu thấy chưa trùng khớp tan chọn vào các vị trí trên thanh tiến trình chọn vào Layer 3 nhấn F6 chèn key frame đồng th ời dùng phím mũi tên di chuyển cây bút sao cho trùng khớp với nét vẽ chữ c. Lúc này ta thấy ở thanh Timeline như sau: Trên lớp Guide chèn thêm một Layer 4 kích chọn key frame cuối nhấn F6 chèn vào một key frame mở bảng Ations đánh vào lệnh sau: stop(); Chúc Thầy Cô thành công.
  16. Gốc > Bài 2: Làm quen với các công cụ chính trong Flash (phần 1) Phần 1 của Bài 2 sẽ giới thiệu về 8 công cụ đầu tiên trong Tools panel của Flash 8, bao gồm: 1. Select Tool 2. Subselect Tool 3. Free Transform Tool 4. Gradient Transform Tool 5. Line Tool 6. Lasso Tool 7. Pen Tool 8. Text Tool Các công cụ đều được minh họa bằng hình ảnh với hình chụp lần lượt các trạng thái của màn hình sau mỗi bước thao tác. Các mũi tên màu hồng dùng để chỉ đường di chuyển của chuột trong thao tác. Sẽ có 1 bài thực hành nhỏ sau khi giới thiệu hết các công cụ còn lại ở Phần 2 Nếu thầy cô có bổ sung gì hoặc phát hiện ra các sai sót trong bài giới thiệu thì xin hãy cho tôi biết để tôi cập nhật lại nội dung. Xin cám ơn!
  17. 1. Select Tool
  18. 2. Subselect Tool 3. Free Transform Tool

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản