Cách xóa và cải thiện menu chuột phải

Chia sẻ: Hoang Nhan | Ngày: | Loại File: PDF | Số trang:12

0
79
lượt xem
6
download

Cách xóa và cải thiện menu chuột phải

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Menu chuột phải là một trong những thành phần giao diện hữu dụng nhất trong Windows, tuy nhiên đôi khi, đặc biệt khi chúng ta cài đặt rất nhiều ứng dụng, hệ thống có thể sẽ hơi chậm và được lấp vào bằng các shortcut mà chúng ta lại thực sự không sử dụng.

Chủ đề:
Lưu

Nội dung Text: Cách xóa và cải thiện menu chuột phải

  1. Cách xóa và cải thiện menu chuột phải Nguồn : quantrimang.com  George Quản trị mạng - Menu chuột phải là một trong những thành phần giao diện hữu dụng nhất trong Windows, tuy nhiên đôi khi, đặc biệt khi chúng ta cài đặt rất nhiều ứng dụng, hệ thống có thể sẽ hơi chậm và được lấp vào bằng các shortcut mà chúng ta lại thực sự không sử dụng. Nếu bạn muốn đơn giản hóa để có thể chứa các tùy chọn muốn sử dụng, hãy sử dụng các công cụ được chúng tôi giới thiệu trong bài để cho phép bạn xóa và tùy chỉnh menu nội dung chuột phải theo những gì bạn muốn. Trong bài chúng tôi sẽ giới thiệu chi tiết về nơi bạn có thể tìm được các phần mềm này và những gì chúng có thể thực hiện cũng như cách sử dụng chúng như thế nào. Lưu ý: Trước khi thực hiện theo các bước bên dưới, bảo đảm rằng bạn phải thiết lập các chương trình mặc định đúng cách và tạo một điểm khôi phục cho hệ thống của mình để trong trường hợp nào đó bạn còn có thể chuyển đổi lại trạng thái trước đó một cách dễ dàng. Các ứng dụng bên dưới sẽ không hoạt động đúng cách nếu bạn không kích phải vào các shortcut của chúng và chọn 'Run as administrator'. Nếu bạn gặp phải bất cứ lỗi nào hoặc những thay đổi không được áp dụng một cách đúng, khi đó có thể bạn đã không chạy chúng với tư cách quản trị viên. Download và cài đặt các công cụ ShellMenuView, ShellExView và FileMenu Các công cụ bạn cần download và cài đặt là: ShellMenuView – Công cụ này rất tốt cho việc vô hiệu hóa cái gọi là các • mục menu chuột phải “tĩnh”. Thông thường, các tùy chọn này không được tổ chức theo các thư mục mà lại được liệt kê như các entry riêng lẻ. Ví dụ về các entry như vậy là các tùy chọn Play, Enqueue and Bookmark được cài đặt bởi Winamp hoặc 'Add/Play with' với VLC Media Player. ShellExView – Đây là một công cụ tốt cho việc xóa các entry menu nội • dung được cài đặt bởi các ứng dụng khác. Các entry menu nội dung này thường mở rộng chức năng của menu chuột phải và hầu hết đều được tổ chức theo các thư mục. Ví du về các entry như vậy là tùy chọn 'Scan for
  2. viruses' xuất hiện khi bạn cài đặt phần mềm antivirus, 'Adobe Drive CS4' khi bạn cài đặt Adobe Creative Suite 4 hoặc các menu được cài đặt bởi các bộ nén và giải nén file như 7-Zip hoặc WinZip. FileMenu Tools – Ứng dụng này cho phép bạn bổ sung thêm các hoạt • động nâng cao vào menu chuột phải và để cấu hình menu Send To. Mặc dù có các ứng dụng tương tự khác, nhưng chúng tôi chọn ứng dụng này vì nó có rất nhiều các tùy chọn được thiết lập trước. Nếu bạn không thích công cụ này, hãy thử với Open++. Nó có ít các tùy chọn mặc định hơn nhưng có thể khá thân thiện với người dùng. Lưu ý: Các công cụ này có cả các phiên bản 32-bit & 64-bit. Chúng cũng có các phiên bản trong các ngôn ngữ khác nhau. Bạn nên kiểm tra các trang download của chúng để tìm ra các liên kết download thích hợp. Cách làm việc với ShellMenuView Giao diện của ShellMenuView có rất nhiều cột nhưng chỉ có một vài cột trong chúng thực sự thú vị với người dùng thông thường. Hai cột đầu tiên liệt kê tên menu và các mở rộng của file mà chúng có thể mở trong menu chuột phải. Các cột còn lại chứa các thông tin về kiểu file, trạng thái file, tên file, phần mô tả, phiên bản, tên sản phẩm và công ty.
  3. Bạn có thể tùy chỉnh số cột bằng cách kích View -> Choose Columns. Trong cửa sổ Column Settings, chọn các cột mà bạn muốn xem. Trong bài này chúng tôi đã chọn các cột Menu Name, Extensions, Menu Key, File Type và Disabled.
  4. Lúc này chúng ta hãy bắt đầu một ví dụ với menu chuột phải điển hình: như những gì bạn có thể thấy, chúng tôi có rất nhiều entry. Với bài này, chúng tôi muốn remove các tùy chọn 'Add to Winamp's Bookmark list' và 'Play in Winamp'.
  5. Trong cửa sổ ShellMenuView, kích biểu tượng Find từ toolbar hoặc sử dụng shortcut bàn phím 'Ctrl+F'. Đánh vào tên của entry mà bạn muốn xóa và kích vào 'Find Next'. Trong trường hợp của chung tôi, chúng tôi đã tìm kiếm từ bookmark.
  6. Kích phải vào entry được tìm thấy và chọn Disable Selected Item. Lặp lại thủ tục này cho tới khi bạn vô hiệu hóa tất cả các entry. Một phương pháp dễ hơn đó là phân loại cột đầu tiên, sau đó sử dụng tùy chọn Find. Khi nó tìm entry đầu tiên bạn có thể dễ dàng chọn tấ cả chúng và kích phải vào Disable Selected Items. Các mục mà bạn vô hiệu hóa sẽ có màu nền màu xám và trong cột Disabled, sẽ có giá trị Yes. Cách làm việc với ShellExView Với hướng dẫn này, chúng tôi sẽ sử dụng ShellExView để vô hiệu hóa menu chuột phải của chương trình 7-Zip.
  7. Lưu ý: ShellExView có một giao diện giống như ShellMenuView. Chính vì vậy, các cột được hiển thị có thể được tùy chỉnh bằng thủ tục được mô tả ở trên cho ShellMenuView. Thêm vào đó, nút Find cũng tương tự. Khi bạn vào cửa sổ ShellExView, phân loại cột đầu tiên, tìm các entry mà bạn muốn vô hiệu hóa và chọn chúng. Sau đó kích phải và chọn Disable Selected Items. Trong hình bên dưới, chúng tôi đã chọn 7-Zip Shell Extension, đã kích phải vào nó và đã chọn Disable Selected Items. Kích Yes khi bạn được hỏi có muốn vô hiệu hóa các mục đã chọn hay không.
  8. Cách làm việc với các công cụ FileMenu FileMenu Tools là ứng dụng cho phép bạn tùy chỉnh menu chuột phải bằng cách bổ sung các lệnh bạn muốn. Nó cũng có thể được sử dụng để chỉnh sửa menu 'Send to'. Bạn cũng có thể sử dụng ứng dụng này cho các lệnh soạn thảo (kích hoạt hay vô hiệu hóa) được thêm bởi các ứng dụng khác vào menu chuột phải nhưng ShellMenuView và ShellExView dường như thực hiện tốt hơn công việc đó. Giao diện của FileMenu Tools có ba tab: Commands of FileMenu Tools, Send To menu and Commands of other applications. Tab đầu tiên cho phép bạn thêm các lệnh vào menu chuột phải.
  9. Chúng sẽ hiển thị tất cả dưới thư mục File Menu Tools trong menu chuột phải.
  10. FileMenu Tools có rất nhiều lệnh được định nghĩa trước. Bạn có thể remove bất kỳ lệnh nào từ menu chuột phải bằng cách hủy chọn chúng. Nếu bạn muốn thêm vào một lệnh, một menu cấp thấp hoặc tách riêng, kích vào nút tương ứng trong panel Actions. Sau khi đã thêm một lệnh mới, bạn có thể chọn kiểu lệnh gì bạn muốn: Run a
  11. program, Copy to a folder, Move to a folder, Delete specific files, Send to mail recipient. Sau đó bạn sẽ phải chọn ứng dụng sẽ thực thi lệnh cụ thể và cung cấp tất cả các đối số cần thiết. Tab thứ hai cho phép bạn bổ sung thêm hoặc remove các lệnh từ menu chuột phải Send To như: compressed (zipped) Folder, Desktop (create shortcut), Documents, Fax Recipient, Mail recipient. Quá trình remove hoặc bố sung một lệnh mới vào Send to menu hòan toàn tương tự như quá trình được mô tả ở trên cho Commands of FileMenu Tools tab. Lưu ý: Khi bạn đã thực hiện xong tất cả các thay đổi mong muốn, kích nút 'Apply Changes'. Nếu không thực hiện thao tác đó, bạn sẽ không thấy sự khác biệt trong menu chuột phải. Cách khác bạn có thể kích vào menu File và chọn 'Apply Changes'.
  12. Kết luận Tuy không có công cụ nào vừa cho bạn xóa và thêm các chức năng mới vào menu chuột phải. Mặc dù vậy ShellMenuView, ShellExView and FileMenu Tools có thể giúp bạn thực hiện được các công việc đó một cách nhanh chóng và có được menu chuột phải theo cách của mình.  
Đồng bộ tài khoản