CHƯƠNG VI : LẮP RÁP CÁC CHI TIẾT ( ASSEMBLY DESIGN )

Chia sẻ: Truong Van Mao | Ngày: | Loại File: DOC | Số trang:25

0
156
lượt xem
66
download

CHƯƠNG VI : LẮP RÁP CÁC CHI TIẾT ( ASSEMBLY DESIGN )

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

I/ GIỚI THIỆU VỀ ASSEMBLY DESIGN WORKBENCH Trong phần Sketch và Part Design chúng ta đã được tìm hiểu phương pháp để thiết kế một chi tiết. Trong phần này chúng ta sẽ tìm hiểu cách ghép nối các chi tiết với nhau để hoàn thiện bản vẽ bằng Assembly Design Workbench. Để vào Assembly Design Workbench trên menu chọn: Start - Mechanical Design - Assembly Design. Assembly Design Workbench xuất hiện. Chúng ta có thể thấy Product1 xuất hiện trên Specification ...

Chủ đề:
Lưu

Nội dung Text: CHƯƠNG VI : LẮP RÁP CÁC CHI TIẾT ( ASSEMBLY DESIGN )

  1.                         CHƯƠNG VI : LẮP RÁP CÁC CHI TIẾT ( ASSEMBLY DESIGN ) I/ GIỚI THIỆU VỀ ASSEMBLY DESIGN WORKBENCH         Trong phần Sketch và Part Design chúng ta đã được tìm hiểu phương pháp để thiết kế một chi tiết. Trong phần này chúng ta sẽ tìm hiểu cách ghép nối các chi tiết với nhau để hoàn thiện bản vẽ bằng Assembly Design Workbench. Để vào Assembly Design Workbench trên menu chọn: Start -> Mechanical Design -> Assembly Design. Assembly Design Workbench xuất hiện. Chúng ta có thể thấy Product1 xuất hiện trên Specification Tree.                      ii/ c«ng cô trong assembly design  worbench 1/ Më 1 b¶n vÏ Assembly Click vào open trên thanh công cụ hoặc vào File > Open…
  2. Hộp thoại File selection xuất hiện. Trong hộp thoại File Selection ta chọn đường dẫn và chọn File có đuôi *.CATProduct.              2/ C«ng cô Define Multi­Instantiation Cũng tương tự như lệnh Rectangle Pattern trong phần Part Design, Công cụ Dm dùng để tạo các đối tượng bằng cách copy một đối tượng theo một phương xác định. _ Click vào Multi-Instantiation trên thanh công cụ. Hoặc vào Insert > Dm. Hộp thoại Multi Instantate xuất hiện. Nhập các thông số cho hộp thoại : - Component to Instantiate : Chọn đối tượng thực hiện lệnh. - Prameters: Chọn kiểu nhập thông số. + Instance(s) & Spacing: Nhập số đối tượng và khoảng cách giữa các đối tượng (1). + Instance(s) & Length: Nhập số đối tượng và khoảng chiều dài từ đối tượng gốc đến đối tượng cuối (2).
  3. + Spacing & Length: Nhập khoảng cách giữa các đối tượng và chiều dài từ đối tượng gốc đến đối tượng cuối (3). - New Instance(s): Số lượng các đối tượng cần tạo mới. Sử dụng ô này khi kiểu nhập thông số là kiểu (1) hoặc kiểu (2). - Spacing: Khoảng cách giữa các đối tượng. Sử dụng ô này khi kiểu nhập thông số là kiểu (1) hoặc kiểu (3). - Length: Chiều dài từ đối tượng gốc đến đối tượng cuối. Sử dụng ô này khi kiểu nhập thông số là kiểu (2) hoặc kiểu (3). - Axis: Chọn một trục tọa độ làm hướng tạo các đối tượng mới. - OR Select Element: Chọn một đường thẳng làm hướng tạo đối tượng mới. - Reverse: Đảo ngược hướng vừa chọn. - Result: Hộp thoại thông báo vector đơn vị của phưong tạo đối tượng. Ví dụ nếu phương tạo đối tượng là X thì vector đơn vị tạo đối tượng là: (1, 0, 0). Nếu phương tạo đối tượng là Y thì giá trị của véc tơ tạo đối tượng là: (0, 1, 0) vv…Ta có thể nhập phương tạo đối tượng vào ô này. - Define As Default: Giữ lại các thông số để thực hiện lệnh Fast Multi- Istantiation. Chú ý: Mỗi lần Click vào Apply là một lần thực hiện lệnh nhưng hộp thoại vẫn mở cho phép ta thực hiện tiếp các lệnh khác.         3/ C«ng cô Fast Multi­Instantiation Sau khi thực hiện lệnh Dm và lựa chọn Define As Default, Click vào Fast Multi-Instantiation trên thanh công cụ. Hoặc vào Insert > Fast Multi-Instance. Sau đó chọn đối tượng cần thực hiện lệnh thì ngay lập tức các đối tượng mới đựơc tạo thành theo các thông số của lệnh Dm vừa thực hiện. C. Các ràng buộc (Constraints) trong Assembly Design Workbench. Trong một bản vẽ Assembly, các ràng buộc được sử dụng để sắp đặt các chi tiểt về đúng vị trí của nó trong bản vẽ, cũng như đặt mối quan hệ vị trí giữa các chi tiết. iii/ QU¶N Lý C¸c rµng buéc ( constraints )                       trong assembly design worbench      1/ Mét sè lu ý khi sö dông contraints  _ Chúng ta chỉ có thể đặt Constraints giữa hai đối tượng con của một đối tượng đang làm việc (Active Component). Một Active Component sẽ có màu xanh lục trên Specification Tree. Chú ý: Để kích hoại một đối tượng thành đối tượng làm việc ta Double Click lên đối tượng đó. _ Không thể đặt ràng buộc giữa các thành phần của cùng một đối tượng. _ Không thể đặt ràng buộc giữa các nhóm chi tiết con trong cùng một nhóm chi tiết nếu nhóm chi tiết đó không phải là đối tượng đang làm việc.
  4. Ví dụ: Trên hình vẽ dưới đây ta có thể thấy đối tượng đang làm việc là Product B. (1). Các đối tượng không thuộc cùng một đối tượng làm việc do đó không thể đặt ràng buộc. (2). Các đối tượng thuộc cùng một nhóm chi tiết nhưng nhóm chi tiết đó không phải là nhóm chi tiết đang làm việc. (3). Product C và Product D là đối tượng con của Product B là đối tuợng đang làm việc do đó có thể đặt ràng buộc. _ Các biểu tượng của các ràng buộc: Symbol used Symbol displayed Constraints in the geometry area in the specification tree Coincidence Contact Contact (point) Contact (line) Offset
  5. Angle Planar Angle Parallelism Perpendicularity Fix        2/ Rµng buéc c¸c ®èi tîng trïng nhau ( Coincidence  Constraint )  (Mở file: Constraint1. CATProduct). Coincidence Constraints dùng để đặt các đối tượng trùng nhau. Bảng các đối tượng có thể đặt Coincidence Constraints: Sphere Cylinder Planar Point Line Plane Face (point) (axis) Point Line Plane Planar Face Sphere (point) Cylinder (axis)
  6. _ Click vào Coincidence Constraint trên thanh công cụ. Hoặc vào Insert > Coincidence. Sau đó chọn hai đối tượng cần đặt ràng buộc. Hộp thoại Constraints Properties xuất hiện. _ Nhập các thông số cho hộp thoại: - Name: Đặt tên cho ràng buộc nếu ta không đặt thì chương trình sẽ tự đặt tên cho ràng buộc. -Supporting Elements: Thông báo các đối tượng vừa được chọn để đặt ràng buộc. - Reconect: Chọn lại các đối tượng đặt ràng buộc. Muốn chọn lại đối tượng đặt ràng buộc ta Click vào đối tượng trong ô Supporting Elements rồi Click vào Reconect sau đó chọn đối tượng mới. Orientation: Chọn hướng ràng buộc cho các đối tượng: + Undefine: Không xác định hướng. + Same: Cùng một hướng. + Opposite: Ngược hướng nhau. _ Click vào OK để kết thúc. Sau khi thực hiện ràng buộc thì ràng buộc vừa tạo xuất hiện trên Specification Tree.        3/ Rµng buéc c¸c ®èi tîng tiÕp xóc víi nhau  ( Contact Constraint )     (Mở file: Constraint7.CATProduct ). Contact Constraint dùng để đặt các đối tượng tiếp xúc với nhau. Bảng các đối tượng có thể đặt Contact Constraint. Planar Sphere Cylinder Cone Circle Face Planar Face Sphere Cylinder Cone Circle _ Click vào Contact Constraint trên thanh công cụ. Hoặc vào Insert > Contact. Sau đó chọn hai đối tượng cần đặt ràng buộc. Contact Constraint được thực hiện và xuất hiện trên Specification Tree, biểu tượng Contact Constraint xuất hiện trên màn hình.
  7.                   4/ Rµng buéc kho¶ng c¸ch gi÷a 2 ®èi tîng ( Offset  Constraint ) (MởfileAssemblyConstraint02.CATProduct). Offset Constraint dùng để đặt ràng buộc về khoảng cách giữa hai đối tượng. Bảng các đối tượng có thể đặt Offset Constraint. Point Line Plane Planar Face Point Line Plane Planar Face Click vào Contact Constraint trên thanh công cụ. Hoặc vào Insert > Contact. Sau đó chọn hai đối tượng cần đặt ràng buộc. Hộp thoại Constraints Properties xuất hiện. Nhập các thông số cho hộp thoại: Giống như với lệnh Coincidence.              5/ Rµng buéc gãc gi÷a 2 ®èi tîng song song hoÆc  vu«ng gãc víi nhau ( Angle Constraint ) (Mở file: AssemblyConstraint03.CATProduct ). Angle Constraint dùng để đo góc giữa hai đối tượng, đặt hai đối tượng song song với nhau hoặc đặt hại đối tượng vuông góc với nhau. Bảng các đối tượng có thể đặt Angle Constraint:
  8. Cylinder Cone Planar Line Plane Face (axis) (axis) Line Plane Planar Face Cylinder (axis) Cone (axis) Click vào Angle Constraint trên thanh công cụ. Hoặc vào Insert > Angle. Sau đó chọn hai đối tượng cần đặt Constraints. Hộp thoại Constraints Properties xuất hiện. Nhập các thông số cho hộp thoại: - Chọn kiểu ràng buộc: + Perpendicularity: Đặt các đối tượng vuông góc với nhau. + Prallelism: Đặt các đối tượng song song với nhau. +Angle: Đặt các đối tượng tạo với nhau một góc nào đó. - Sector: Chọn vị trí đặt góc, có 4 vị trí đặt góc có thể lựa chọn: - Angle: Nhập giá trị góc giữa hai đối tượng. - OK: Kết thúc Angle Constraint và đóng hộp thoại.            
  9.             6/ Cè ®Þnh vÞ trÝ cña ®èi tîng trong kh«ng gian  ( Fix ) ( Mở file: Fix.CATProduct ). Fix dùng để đặt cố định vị trí một đối tượng trong không gian bản vẽ. Click vào Fix trên thanh công cụ. Hoặc vào Insert > Fix. Sau đó chọn đối tượng cần cố định. Sau khi chọn đối tượng một biểu tượng hình cái neo màu xanh xuất hiện chứng tỏ đối tượng đã được cố định trong không gian bản vẽ. Chú ý: Khi double-Click vào Fix vừa tạo, hộp thoại Constraints Definition xuất hiện. Lick vào More hộp thoại có dạng như sau. Bỏ lựa chọn Fix in space sau đó Click vào OK để đóng hộp thoại, bây giờ lệnh Fix đã bị vô hiệu hóa.               7/ Cè ®Þnh vÞ trÝ cña 1 nhãm ®èi tîng ( Fix  Together ) Công cụ Fix Together dùng để đặt một nhóm các đối tượng cố định tương đối với nhau. Tức là vị trí tương đối của các đối tượng cùng chịu ảnh hưởng của Fix Together là không thay đổi nhưng vị trí của cả nhóm có thể thay đổi đối với các đối tượng không thuộc nhóm. Click vào Fix Together trên thanh công cụ. Hoặc vào Insert > Fix Together. Hộp thoại Fix Together xuất hiện. Chọn các đối tượng cần đặt ràng buộc, tên của các đối tượng đó sẽ xuất hiện trong hộp thoại. Để loại bỏ một đối tượng khỏi hộp thoại ta Click vào đối tượng đó trên màn hình hoặc trong hộp thoại.             8/ §Æt nhanh rµng buéc gi÷a c¸c ®èi tîng ( quick  constraint ) (Mở file: QuickConstraint.CATProduct).
  10. Công cụ Quick Constraint dùng để đặt nhanh ràng buộc giữa các đối tượng. Tùy từng loại đối tượng khác nhau chương trình sẽ tự đặt các ràng buộc phù hợp. Ràng buộc sẽ được tạo ra theo thứ tự ưu tiên: Surface Contact, Angle, Coincidence, Offset, Perpendicularity. Click vào Quick Constraint trên thanh công cụ. Hoặc vào Insert > Quick Constraint. Sau đó chọn các đối tượng cần đặt ràng buộc, ràng buộc tương ứng sẽ được tạo ra. Chú ý: Thứ tự ưu tiên trên có thể thay đổi: Vào Tool > Options. Trong hộp thoại Options chọn Mechanical Design > Assembly Design. Chọn tab Constraints > Quick constraint.                 9/ BiÕn ®æi mét contraint thµnh mét contraint kh¸c  ( Change Contraint ) Công cụ Change Constraint cho phép thay đổi một Constraint đã tạo thành một Constraint khác. Click vào Change Constraint trên thanh công cụ. Sau đó Click vào Constraint cần thay đổi, hộp thoại Change Type xuất hiện.\ Trong hộp thoại Change Type, ta chọn loại Constraint rồi Click vào OK để thực hiện sự thay đổi.           10/ Kh«ng kÝch ho¹t hay kÝch ho¹t mét constraint  ( Deactive/Active )
  11. Các Constraint ở trạng thái bình thường luôn được kích hoạt ngay sau khi nó được tạo ra. Khi một Constraint khi không được kích hoạt thì các chức năng ràng buộc của nó sẽ không còn tác dụng. Ví dụ: Để đưa Coicedence.21 về trạng thái không được kích hoạt, ta Click chuột phải lên Coicedence.21 trên Specification Tree hoặc trên màn hình đồ họa. Từ menu trạng thái chọn Coincedence.21 object > Deactivate. Các Constraint ở trạng thái không được kích hoạt sẽ có biểu tượng Deactivate trên Specification Tree và có màu trắng trên màn hình đồ họa. Muốn kích hoạt lại các Constraint ta làm tương tự như trên và chọn Activate.           11/ T×m c¸c contraint cña ®èi tîng  Một đối tượng có thể có nhiều Constraint khác nhau, bình thường khi quan sát trên bản vẽ ta khó có thể biết được một đối tượng có những Constraint nào. Để tìm và chọn các Constraint của đối tượng một cách nhanh chóng và dễ dàng, ví dụ tìm các Constraint của CRIC_BRANCH1, ta Click chuột phải lên CRIC_BRANCH1 trên Specification Tree, từ menu trạng thái chọn CRIC_BRANCH1.1object > Component Constraints. Các Constraint thuộc CRIC_BRANCH1 sẽ tự động sáng lên trên Specification Tree.           12/ CËp nhËt 1 constraint ( Updating an Assembly ) Updating một bản Assembly có nghĩa là đưa tất cả các đối tượng có trong bản vẽ về đúng vị trí của nó theo các ràng buộc đã đặt. Một Constraint chưa được Update sẽ có màu đen trên màn hình và có biểu tượng Update ở bên cạnh tên của nó ở trên Specification Tree. Ta có thể điều khiển quá trình Update của bản vẽ: Tool > Options. Trong hộp thoại Options chọn Mechanical Design > Assembly Design. Chọn tab General > Update. Để Update toàn bộ bản Assembly ta Click vào Update trên thanh công cụ, tức thì toàn bộ các ràng buộc có trong bản vẽ sẽ được Update, đưa tất cả các đối tượng về đúng vị trí của nó.
  12. Để Update một Constraint, ta Click chuột phải lên Constraint đó, từ menu trạng thái chọn *object > Update. Khi các Constraint được Update nó sẽ có màu xanh trên màn hình đồ họa.            13/ KiÓm tra vµ thay ®æi c¸c thuéc tÝnh cña  constraint Click chuột phải lên Constraint cần kiểm tra, chọn Properties từ menu trạng thái. Hộp thoại Properties xuất hiện. a. Constraint. Trong tab Constraint ta có thể đặt lại các thông số của Constraint. b.Mechanical. Tab Mechanical thông báo trạng thái của Constraint: Deactivate, Update, Unsolve. c.Graphic. Tab Graphic cho phép ta đặt màu sắc hiển thị của Constraint và đặt một số thuộc tính khác. d.Features. Thông báo tên của Constraint, tên người tạo, thời gian tạo, thời gian lần chỉnh sửa cuối cùng.            14/ Cµi ®Æt chÕ ®é cho 1 rµng buéc ( Setting a  Constraint Creation Mode ) (Mở file: Constraint_Creation.CATProduct). Kiểu tạo Constraint sử dụng khi ta ghi một chuỗi Constraint liên tiếp.
  13. Chú ý: Để lặp lại quá trình thực hiện một lệnh ta Double Click vào biểu tượng của lệnh đó trên thanh công cụ. Trong trường hợp này để tạo chuỗi Constraint liên tiếp ta Double Click vào biểu tượng Constraint cần tạo. a. Default mode . Chế độ Default mode cho phép ta đặt các cặp Constraint độc lập với nhau. Trên thanh công cụ Constraint Creation, chọn Default mode . Double Click vào Offset Constraint trên thanh công cụ, chọn hai mặt phẳng song song để đặt Constraint. Hộp thoại Constraint Creation xuất hiện, Click vào OK để hoàn thành kích thước thứ nhất. Sau khi Click vào OK lệnh Offset Constraint vẫn còn được kích hoại. Ta có thể chọn tiếp các cặp mặt phẳng khác để đặt Constraint. Các Constraint tạo thành độc lập với nhau. b. Chain Mode . Chain Mode cho phép ta tạo những Constraint có liên kết với nhau, điểm cuối của Constraint trước là điểm đầu của Constraint sau. Trên thanh công cụ Constraint Creation, chọn Chain Mode . Double Click vào Offset Constraint trên thanh công cụ, chọn hai mặt phẳng song song để đặt Constraint. Hộp thoại Constraint Creation xuất hiện, Click vào OK để hoàn thành kích thước thứ nhất. Sau khi Click vào OK lệnh Offset Constraint vẫn còn được kích hoại. Ta có thể chọn tiếp phẳng khác để đặt Constraint. c. Stack MOde .
  14. Stack mode cho phép tạo các Constraint liên tiếp có chung nhau một điểm đầu, các điểm cuối khác nhau. Trên thanh công cụ Constraint Creation, chọn stack Mode . Double Click vào Offset Constraint trên thanh công cụ, chọn hai mặt phẳng song song để đặt Constraint. Hộp thoại Constraint Creation xuất hiện, Click vào OK để hoàn thành kích thước thứ nhất. Sau khi Click vào OK lệnh Offset Constraint vẫn còn được kích hoại. Ta có thể chọn tiếp phẳng khác để đặt Constraint.                15/ Sö dông l¹i 1 parttern ( Reuse Parttern ) (Mở file: Pattern.CATProduct). Trong phần Part Design chúng ta đã làm quen với các công cụ Pattern: Rectangular Pattern, Circular Pattern, User Pattern. Trong phần Assembly Design này chúng ta có công cụ Reuse Pattern có tác dụng sử dụng lại các Pattern đã tạo trong Part Design. Click vào Reuse Pattern trên thanh công cụ. Hoặc vào Insert > Reuse Pattern. Hộp thoại Instantiation on a pattern xuất hiện.
  15. Sau khi xuất hiện hộp thoại, ta chọn một Pattern và một Component làm đối tượng thực hiện lệnh (trong ví dụ này chúng ta chọn Rectpattern.1 và Part2(Part2.1) làm đối tượng thực hiện lệnh). Nhập các thông số cho hộp thoại: - Keep link with Pattern: Giữ liên kết với Pattern ban đầu. Khi chức năng này được kích hoạt thì mọi thay đổi trên Pattern ban đầu sẽ dẫn đến sự thay đổi trên Pattern mới. Ta có thể định nghĩa cách xác định vị trí các đối tượng mới tạo thành: + Pattern’s Definition: Vị trí của các đối tượng mới trùng với vị trí của các Pattern ban đầu. + Generate Constraints: Tạo các ràng buộc cho các đối tượng mới. Khi đặt ở chế độ này, nếu ta Click vào nút Clear thì toàn bộ các Constraint sẽ bị xóa. - Pattern: Ô Pattern thông báo các thông số về Pattern: Tên Pattern, số đối tượng được tạo thành bởi Pattern, tên Component chứa Pattern. - Component to Istantiate: Thông báo tên của Component sử dụng trong lệnh Pattern. - First Instance on Pattern: Lựa chọn cách tạo đối tượng đầu tiên trong Pattern. + reuse the original component: Đối tượng dùng để tạo Pattern được dùng luôn làm đối tượng đầu tiên. + create a new instance: Tạo một đối tượng mới làm đối tượng đầu tiên. Đối tượng ban đầu vẫn còn và tồn tại song song với đối tượng mới đầu tiên. + cut & paste the original component: Đối tượng đầu tiên được tạo thành bằng cách cắt và dán đối tượng ban đầu. Như vậy đối tượng ban đầu sẽ mất. - Put new Instance in Flexible Component: Đặt các đối tượng mới trong cùng một Component. iv / di chuyÓn ®èi tîng trong assembly        1/ Di chuyÓn c¸c ®èi tîng ( Manipulating  Components )         (Mở file: MovingComponents02.CATProduct). Công cụ Manipulation dùng để di chuyển các đối tượng trong Assembly. Đối tượng dịch chuyển phải thuộc Component đang được kích hoạt. Click vào Manipulation trên thanh công cụ . Hộp thoại Manipulation Parameter xuất hiện.
  16. Sử dụng hộp thoại: - Trong hộp thoại ta có thể thấy biểu tượng của các dịch chuyển mà ta có thể thực hiện được: + Dọc trục: X, Y, Z, hoặc một trục do ta chỉ định. + Trượt trên mặt phẳng: XY, YZ, ZX, hoặc mặt phẳng do ta chỉ định. + Xoay quanh trục: X, Y, Z, hoặc một trục do ta chỉ định. - Để thực hiện một dịch chuyển ta Click vào biểu tượng của dịch chuyển đó rồi chọn đối tượng trên màn hình và di chuột để thực hiện dịch chuyển. - With respect to constraints: Cho phép ta di chuyển các đối tượng trong các ràng buộc. - Click vào OK để thoát khỏi hộp thoại.      2/ Di chuyÓn ®èi tîng theo bíc nh¶y ( Snapping  Components )        (Mở file: MovingComponents01.CATProduct). Công cụ Snap dùng để di chuyển đối tượng theo những bước nhảy. Đối tượng di chuyển là các Component còn các đối tượng dùng để xác định các bước nhảy đó là các mặt, đường và các điểm thuộc các Component đó. Ví dụ: - Double Click vào Product2 trên Specification Tree. - Click vào Snap trên thanh công cụ. - Chọn đối tượng thứ nhất là một mặt thuộc CRIC_BRANCH1. - Chọn đối tượng thứ hai là một mặt thuộc CRIC_BRANCH3.
  17. - Kết quả là mặt phẳng thứ nhất thuộc CRIC_BRANCH1 trùng với mặt phẳng thuộc CRIC_BRANCH3. - Có thể Click vào mũi tên màu xanh xuất hiện trên màn hình để đảo chiều của CRIC_BRANCH1.
  18. - Click ra ngoài màn hình để thoát khỏi lệnh Snap.       3/ Di chuyÓn ®èi tîng mét c¸ch linh ho¹t (Smart Move ) Công cụ Smart Move dùng để di chuyển đối tượng một cách linh hoạt. Click vào Smart Move trên thanh công cụ. Hộp thoại Smart Move xuất hiện, Click vào More trên hộp thoại Smart có dạng như sau:  v/ ph©n tÝch mét l¾p r¸p  Trong phần này chúng ta sẽ tìm hiểu các công cụ để phân tích một bản Assembly.        1/ TÝnh to¸n xung ®ét ( Computing Clash ) (Mở file: AnalyzingAssembly01.CATProduct). Một bản Assembly có thể gồm rất nhiều các Component khác nhau, giữa các Component có thể có các xung đột lẫn nhau (xung đột ở đây có thể hiểu là hiện tượng các vật thể chèn lên nhau, có một phần thể tích giao nhau, hay khoảng cách giữa các Component không được đảm bảo). Rất khó để cho chúng ta tìm ra sự xung đột giữa các Component đó.Công cụ Compute Clash dùng để phân tích sự xung đột gữa các Component trên toàn bộ bản vẽ. Trên menu chọn Analyze -> Compute Clash. Hộp thoại Clash Detection xuất hiện. Sử dụng hộp thoại Clash Detection: a. Hộp thoại Cash Detection cho phép ta chọn hai đối tượng để phân tích xung đột với nhau (Phải sử dụng phím Ctrl để chọn hai đối tượng ở trên Specification Tree). Tên của hai đối tượng được chọn xuất hiện trong hộp thoại. b. Chọn kiểu phân tích là Clash: Tìm sự giao nhau giữa các đối tượng. - Click vào Apply để xem kết quả. - Result: Xem kết quả. + No Interference: Không có sự xung đột giữa các Component. + Clash: Có sự xung đột, vùng đối tượng xung đột sẽ có màu đỏ trên màn hình đồ họa. + Contact: Các đối tượng tiếp xúc với nhau, hai đối tượng có màu vàng trên màn hình đồ họa. c. Chọn kiểu phân tích là Clearance. Phân tích khoảng cách giữa các đối tượng, khoảng cách này nhập vào ô bên cạnh. - Click vào Apply để xem kết quả phân tích.
  19. - Result: Xem kết quả. + No Interference: Không có sự xung đột, khoảng cách giữa hai Component lớn hơn khoảng cách nhập trong hộp thoại. + Clearance violation: Có sự xung đột, khoảng cách giữa hai đối tượng nhỏ hơn khoảng cách nhập trong hộp thoại.Các đối tượng chuyển thành màu xanh trên màn hình đồ họa. + Contact: Khoảng cách giữa hai đối tượng bằng khoảng cách nhập trong hộp thoại. Các đối tượng chuyển thành màu vàng trên màn hình đồ họa.           2/ NhËn biÕt c¸c rµng buéc ( Analyzing Contraints ) (Mở file: AnalyzingAssembly02.CATProduct) Như chúng ta đã biết, các Component trong bản Assembly được liên kết với nhau bởi các Constraint. Với một bản Assembly có nhiều Component thì số lượng các Constraint trong bản vẽ là rất lớn. Công cụ Analyzing Constraints cho phép chúng ta phân tích các Constraint có trong bản vẽ, quản lý các Constraint một cách tổng thể. Trên menu chọn:Analyze > Constraints. Hộp thoại Constraint Analysis xuất hiện. Sử dụng hộp thoại: a. Constraints. - Active Component: Thông báo Component đang hoạt động trong bản vẽ. Chỉ có các Component đang hoạt động mới được phân tích. - Components: Số lượng các Component trong Component đang hoạt động. - Not Constrained: Hiển thị số lượng các Component con của Component hiện hành không được đặt Constraint. - Status: Trạng thái của các Constraint trong Component hiện hành. + Verified: Số lượng các Constraint tồn tại trong bản vẽ. + Impossible: Số lượng các Constraint không thể thực hiện được. + Not Update: Số lượng các Constraint chưa được Update. + Brocken: Số lượng các Constraint đã bị phá mất liên kết. + Deactive: Số lượng các Constraint ở trạng thái không được kích hoạt. + Measure mode: Số lượng các Constraint ở dạng Measure (chỉ dùng để do, không dùng để làm ràng buộc). + Fix together: Số lượng các Constraint Fix together. + Total: Tổng số các Constraint có trong Component hiện hành.
  20. b. Brocken: Thông báo tên Constraint ở trạng thái Brocken có trong bản vẽ. Trong ví dụ này ta có hai Constraint: Coincidence.12(1) và Coincidence.12(2). Khi Click vào các Constraint này thì biểu tượng của nó ở trên Specification Tree sáng lên. Có thể Double-Click vào Constraint để xem lại định nghĩa của chúng. d. Deactivate: Thông báo tên của các Constraint ở trạng thái không được kích hoạt. e. Degree of Freedom: Thông báo bậc tự do của Component mà tất cả các Constraint của nó đều hợp lệ. Có thể Double Click vào Component có tên trong danh sách để xem các bậc tự do của nó. f. Click OK để đóng hộp thoại. 3/ Ph©n tÝch mèi quan hÖ phô thuéc gi÷a c¸c ®èi tîng                   ( Analyzing Dependences ) (Mở file: AnalyzingAssembly03.CATProduct). Công cụ Analyzing Dependences dùng để phân tích mối quan hệ phụ thuộc giữa các đối tượng. Click vào CRIC_BRANCH_3.1, trên menu chọn Analyze > Dependencies. Hộp thoại Assembly Dependencies Tree xuất hiện. Click chuột phải vào Product1 chọn Expend node, các Constraint có trong CRIC_BRANCH_3.1 xuất hiện:
Đồng bộ tài khoản