Công nghệ CAD / CAM Phần 6

Chia sẻ: Tuong Phu | Ngày: | Loại File: PDF | Số trang:12

0
138
lượt xem
90
download

Công nghệ CAD / CAM Phần 6

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

PHẦN MỀM Pro/ENGINEER CHỨC NĂNG CƠ BẢN - Các mặt phẳng toạ độ cho trước. - Thực hiện tạo các hệ toạ độ cấu trúc và lắp ráp CHỨC NĂNG PHÁT THẢO - revolve, extrude, blend, sweep Tham số hoá Ý tưởng CHI TIẾT - gồm nhiếu kết cấu - đối xứng, quan hệ.. TẠO MỘT BẢN VẼ - của chi tiết, lắp ráp, có kích thước - lập danh mục tự động - mặt cắt, mặt cắt chi tiết … PHẦN LẮP RÁP - gồm nhiếu chi tiết - tạo các chi tiết trong phần lắp ráp - nghiên cứu sự giao nhau - lập...

Chủ đề:
Lưu

Nội dung Text: Công nghệ CAD / CAM Phần 6

  1. C6 CAD-CAM> ProEWF 1 GVC NGUYỄN THẾ TRANH Chương 6 PHẦN MỀM Pro/ENGINEER CHỨC NĂNG PHÁT THẢO CHỨC NĂNG CƠ BẢN - revolve, extrude, blend, - Các mặt phẳng toạ độ cho sweep trước. - Thực hiện tạo các hệ toạ độ cấu trúc và lắp ráp Tham số hoá Ý tưởng CHI TIẾT - gồm nhiếu kết cấu - đối xứng, quan hệ.. PHẦN LẮP RÁP TẠO MỘT BẢN VẼ - gồm nhiếu chi tiết - của chi tiết, lắp ráp, có - tạo các chi tiết trong kích thước phần lắp ráp - lập danh mục tự động - nghiên cứu sự giao nhau - mặt cắt, mặt cắt chi tiết … - lập thư viên
  2. C6 CAD-CAM> ProEWF 2 GVC NGUYỄN THẾ TRANH Parametric Technology Corporation * Pro/ENGINEER có cả phiên bản UNIX lẫn Windows (NT, 95, 98). Hiện nay, Pro/ENGINEER đã giới thiệu một giao diện mới. * Các verson Pro/E 2000i1, Pro/E 2000i2 chạy trên Win 98, các verson Pro/E 2001, Pro/E Wildfire chạy trên Win XP với card mạng. 6.1. CHỨC NĂNG PHẦN MỀM Pro/ENGINEER. • Đây là một trong số các bộ phần mềm CAD/CAM chuyên nghiệp và nổi tiếng trên thế giới. • Có cấu trúc lệnh đơn giản. • Phương thức giao tiếp rõ ràng và dễ sử dụng. Bộ phần mềm Pro/ENGINEER bao gồm có 5 môđun (chế độ) chương trình ứng dụng chính: a. Sketch : Vẽ phát thảo. b. Part : Tạo mẫu thiết kế, c. Assembly: Lắp ráp tạo mô hình. d. Manufacturing : Chế tạo e. Drawing : Tạo hình chiếu và bản vẽ kỹ thuật,
  3. C6 CAD-CAM> ProEWF 3 GVC NGUYỄN THẾ TRANH 6.2. TẠO MÔ HÌNH THEO THAM SỐ. Tạo mô hình theo tham số là một cách lập bản vẽ thiết kế có sự trợ giúp của máy vi tính mà Pro/E sử dụng. Các lệnh trong 2D CAD được chuyển sang Pro/E như: LINE, CIRCLE, ARC, DELETE, OFFSET, TRIM, MIRROR, COPY, ARRAY. Trên cơ sở đó, Pro/E có khả năng thực hiện các công việc: 1. Tạo mô hình dựa trên chi tiết (không gian dương hay âm) . 2. Vẽ phác hoạ (vẽ mặt cắt không cần đúng kích thước). 3. Tạo mô hình bằng sự cưỡng bức (vuông góc, song song, tiếp xúc, trùng khớp, thẳng đứng, nằm ngang). 4. Mối quan hệ giữa các chiều được thiết lập qua các công thức toán học. 5. Sự tham chiếu giữa các chi tiết (mối quan hệ phả hệ). Model TREE với các chức năng: xác định lại một chi tiết, xoá một chi tiết, sắp xếp lại trình tự các chi tiết, dựa vào các chi tiết và xoá các chi tiết. Các chi tiết chuẩn trong Pro/E: Mặt phẳng chuẩn: Trục chuẩn: Đường cong chuẩn: Điểm chuẩn: Hệ toạ độ: Mục đích của việc thiết kế: Khả năng đưa mục đích của việc thiết kế vào một mô hình là một tính năng độc đáo của Pro/E. Các chương trình tạo mô hình theo tham số có nhiều công cụ khác nhau để kết hợp các mục đích thiết kế, như: - Sơ đồ định kích cỡ. - Các hình thức cưỡng bức chi tiết. - Các hình thức cưỡng bức khối lắp ráp. - Các tham chiếu. 6.3. MÀN HÌNH LÀM VIỆC CỦA Pro/ENGINEER WILDFIRE. 6.3.1 Thanh Menu. Trong chế độ Part trong Pro/ENINEER, các tuỳ chọn trên thanh Menu gồm: 1. Menu File. 6. Menu Info: 2. Menu Edit. 7. Menu Applications: 3. Menu View. 8. Menu Utilities: 4. Menu Insert. 9. Menu Window: 5. Menu Analysis: 10. Menu Help.
  4. C6 CAD-CAM> ProEWF 4 GVC NGUYỄN THẾ TRANH 6.3.2 Thanh công cụ. 1. Nhóm quản lý file: New, Open, Save, Save A Copy, Print. 2. Nhóm hiển thị khung xem: Repaint, Zoom in, Zoom Out, Refit, Orient, Saved Views. 3. Nhóm hiển thị mô hình: nhằm thay đổi cách hiển thị các đối tượng trong Pro/ENGINEER: Wireframe (theo khung dây), Hidden Line (có nét ẩn), No Hidden (không có nét ẩn), Shade (tạo bóng đổ), Model Tree. 4. Nhóm hiển thị các chi tiết chuẩn: điều chỉnh cách hiển thị các chi tiết chuẩn: Datum Planes (tắt mở hiển thị các mặt phẳng chuẩn), Datum Axes (tắt mở hiển thị các trục chuẩn), Point Symbold (tắt mở hiển thị các điểm chuẩn), Coordinate Systems (tắt mở hiển thị các hệ toạ độ). 5. Nhóm Context - Sensitive Help: dùng để hiển thị thông tin trợ giúp về các menu riêng lẽ hay các tuỳ chọn trong hộp thoại. 6.4 CÁC CHỨC NĂNG THÔNG THƯỜNG. 6.4.1 Quản lý file. Lệnh mở và lưu file trong Pro/ENGINEER có một số điểm khác biệt quan trọng giữa tính năng quản lý file trong trình ứng dụng của Windows: • Tên file trong Pro/E đòi hỏi chặt chẽ hơn. • Việc lưu một đối tượng trong Pro/E sẽ tạo ra một phiên bản mới. • Pro/E không cho phép một đối tượng được lưu với một tên file đã được đặt trước đó, tức là không lưu trên một file hiện có.
  5. C6 CAD-CAM> ProEWF 5 GVC NGUYỄN THẾ TRANH 1. Tên file. Bảng 5.1; các tên file mở rộng với các chế độ trong Pro/E CHẾ ĐỘ PHẦN MỞ RỘNG Sketch *.sec* Part *.prt* Assembly *.asm* Manufacturing *.mfg* Drawing *.drw* Format *.frm* Bảng 5.2: Các tên file không có hiệu lực và có hiệu lực Tên file không có Sự cố Tên file có hiệu lực hiệu lực Part one Có khoảng trống trong tên file part_one Part@ 11 Có ký tự không phải chữ hay số part_11 Part[1_10] Trong tên file có sử dụng dấu ngoặc part_1_10 2. Bộ nhớ. 3. Thư mục hiện hành. 4. Mở một đối tượng: dùng hộp thoại File Open: bước 1: Chọn FILE>>OPEN để hiển thị hộp thoại File Open. bước 2: Chọn thư mục có chứa đối tượng như minh hoạ bước 3: Chọn đối tượng cần mở. bước 4: Chọn Open trong hộp thoại. 5. Tạo một đối tượng mới. bước 1: Chọn FILE>>NEW để hiển thị hộp thoại New. bước 2: Chọn một loạt kiểu chế độ và kiểu phụ của Pro/E. bước 3: Nhập vào một tên file. bước 4: Chọn OK từ hộp thoại. 6.4.2 Lưu một đối tượng. Có nhiều tuỳ chọn có thể được dùng để lưu các đối tượng: 1. Save ; 2. Lưu một bản sao; 3. Backup; 4. Rename; 5. Delete 6. Erase; 7. Kích hoạt một đối tượng. 5.4.3 Xem các mô hình. Có nhiều cách để xem một đối tượng hoặc thay đổi kiểu hiển thị một mô hình. 7. Xem động, 1. Shaded Display 8. Dynamic Zoom 2. Định hướng hình chiếu 9. Dynamic Rotate 3. Angle 10. Dynamic Pan 4. Dynamic Orientation 11. Wireframe Display 5. Orientation By Reference 12. Hidden Display 6. Đặt tên và lưu các hình 13. No Hidden Display chiếu.
  6. C6 CAD-CAM> ProEWF 6 GVC NGUYỄN THẾ TRANH 6.4.4 Thiết lập một mô hình. 1. Các đơn vị. Pro/E có 4 loại đơn vị chính: Độ dài, khối lượng, thời gian và nhiệt độ. • Thiết lập một hệ thống đơn vị: Từ hộp thoại Unit Manager ta truy cập các hệ thống đơn vị: KMS, CGS, mmNS, FPS, IPS, Pro/E default. • Tạo một hệ thống đơn vị: 2. Chất liệu. • Ấn định một chất liệu: - Bước 1: Chọn SET UP>>MATERIALS>>DEFINE - Bước 2: Nhập vào một tên chất liệu. - Bước 3: Nhập vào các tham số có liên quan đến chất liệu. • Lưu một chất liệu vào đĩa: Các chất liệu được tạo cho một thành phần không được tự động lưu vào đĩa. Để lưu đặc tính của mọt chất liệu để các thành phần khác có thể sử dụng thì chất liệu đó phải được lưu ở một vị trí lâu dài. - Bước 1: Chọn SET UP>>MATERIALS>>WRITE - Bước 2: Chọn đặc tính của một chất liệu cần lưu vào đĩa. - Bước 3: Nhập vào một tên cho file lưu chất liệu đó. • Gán các chất liệu: - Bước 1: Chọn SET UP >> MATERIALS >> ASSIGN - Bước 2: Chọn FROM PART hay FROM FILE làm nguồn gán chất liệu. 3. Xác lập dung sai kích thước. Dung sai là khoảng dao động cho phép về hình dáng và kích thước của một chi tiết. Theo mặc định Pro/E hiển thị các dung sai ở dạng giá trị tiêu chuẩn. Có 4 dạng hiển thị dung sai: Nominal; Limits; Plusminus; Plusminussym. • Tiêu chuẩn dung sai ANSI: được xác lập trước tiên dựa trên các giá trị được tìm thấy trong file cấu hình. • Tiêu chuẩn dung sai ISO: 6.5. TẠO MỘT BẢN PHÁC THẢO (Chế độ Sketch). Phác thảo là một kỹ năng cơ bản của Pro/E. Các chi tiết hình học như Protrusion hay Cut yêu cầu sử dụng một bản phác thảo để xác định mặt cắt của các chi tiết. 6.5.1 Các điểm cơ bản về phác thảo. Các phần phác thảo được kết hợp với các kích thước (DIMENSION), ràng buộc (CONSTRAINT) và tham chiếu (REFERENCE) hình thành một mặt cắt. Các phần kéo, đùn, phần cắt, trục và gờ là ví dụ về các chi tiết đòi hỏi một mặt cắt phát thảo.
  7. C6 CAD-CAM> ProEWF 7 GVC NGUYỄN THẾ TRANH Mặt phẳng phát thảo có thể là một bề mặt của chi tiết hay mặt phẳng, hay có thể là một mặt phẳng số liệu không hiện hữu trên một bộ phận nào, nó được tạo ra nhờ tuỳ chọn Make Datum và không được xem là các chi tiết và không hiển thị. Thông tin mặt cắt: Menu Sketch cung cấp các tuỳ chọn để nhận được thông tin về các thực thể trong môi trường phác thảo hiện hành: Distance, Angle, Entity, Intersection point, Tangency point, Curvature. 6.5.2 Constraint. Một Constraint là một quan hệ được ấn định hiện hữu giữa 2 thực thể hình học ( song song, thẳng góc, bằng nhau...) - Các Constraint với Intent Manager: Các Constraint được tạo trong khi phác thảo. - Các Constraint với Intent Manager được tắt: Không có tuỳ chọn nào để người dùng áp dụng một constraint sau khi tạo lại một mặt cắt. - Các tuỳ chọn Constraint: Intent Manager cho phép áp dụng động các Constraint vào các thực thể được phác thảo thông qua các tuỳ chọn: Same points * , Horizontal H , Vertical V , Point on entity, Tangent T , Perpendicular, Parallel, Equal Radii R , Equal lengths L , Symetric, Line up horizontal, Line up vertical, Collinear, Alignment. 6.5.3 Các tuỳ chọn hiển thị phác thảo. Undo và Redo, Parallel sketch plane (Mặt phẳng phác thảo song song), Dimension Display (Hiển thị kích thước), Constraint Display (Hiển thị ràng buộc), Grid Display (Hiển thị lưới), Vertex Display (Hiển thị đỉnh). 6.5.4 Phác thảo với Intent Manager. 6.5.5 Phác thảo không sử dụng Intent Manager. 6.6. KÉO, CHỈNH SỬA VÀ ẤN ĐỊNH LẠI CÁC CHI TIẾT. Khái niệm các chi tiết kéo đi cùng với các điểm cơ bản về lập mô hình. Trong Pro/E, tuỳ chọn Extrude thường được sử dụng giữa các lệnh Protrusion và Cut. Lệnh Redefine cung cấp các kỹ thuật chỉnh sửa chi tiết và tạo số liệu. 6.6.1 Định nghĩa: Chi tiết cơ sở: Chi tiết hình đầu tiên được tạo trong một bộ phận, là chi tiết bố cho tất cả các chi tiết khác.
  8. C6 CAD-CAM> ProEWF 8 GVC NGUYỄN THẾ TRANH Chi tiết con. Phần cắt: Một chi tiết khoảng trống âm. Phần ấn định: Một tham số của bộ phận, như chiều sâu của lỗ. Phần kéo: Một chi tiết khoản trống dương. Chi tiết khoảng trống âm: Xoá chất liệu ra khỏi một mô hìnhn như các lỗ, phần cắt, khe. Chi tiết khoảng trống dương: Thêm chất liệu vào một mô hình như các phần kéo, trục, gờ. 6.6.2. Lập mô hình dựa vào chi tiết. 6.1 Hình học là sự mô hình một chi tiết bằng hình ảnh được xác định bằng phác thảo hay được ấn định sẵn. Các gói phần mềm thiết kế thường được xem là các bộ lập mô hình dựa trên chi tiết. Một chi tiết là một thành phần con của một bộ phận có các tham số, các tham chiếu và hình riêng của nó. 6.6.3 Quan hệ bố - con. Các chi tiết được tạo dựa vào những chi tiết khác theo một cách giống như cây gia phả, đó là một cây lịch sử về các mối quan hệ giữa các chi tiết trong một mô hình Pro/E giống như một mạng. Mối quan hệ này có thể được thiết lập một cách trực tiếp (một chi tiết được sử dụng để cấu tạo một chi tiết khác) hay gián tiếp (thông qua việc bổ sung một phương trình số bằng cách sử dụng tuỳ chọn Relations).
  9. C6 CAD-CAM> ProEWF 9 GVC NGUYỄN THẾ TRANH 6.6.4 Chi tiết thứ nhất. Việc xác định chi tiết nào là chi tiết thứ nhất hay chi tiết cơ sở của một bộ phận sẽ là một quyết định quan trọng và nó sẽ trở thành chi tiết bố trong bọ phận đó. Có 3 chi tiết đầu tiên có thể có của một bộ phận: 1. Mặt phẳng số liệu: Theo mặc định các mặt phẳng số liệu mặc định được đặt tên là DTM1, DTM2 và DTM3 dùng làm hệ tham chiếu. 2. Phần kéo: Lệnh Protrusion tạo một chi tiết hình học. Ví dụ về các phần kéo bao gồm các chi tiết được kéo, được xoay và được quét. 3. Một chi tiết do người dùng ấn định: Chi tiết đã được lưu sẵn. 6.6.5 Các bước để tạo một bộ phận mới. 1. Thiết lập thư mục làm việc chính xác. 2. Tạo một đối tượng mới với Template mặc định của Pro/E. 3. Thiết lập mô hình. 4. Chọn phương pháp tạo chi tiết: Protrusion là công cụ chính có sẵn đối với bộ phận đặc. 5. Thiết lập mặt phẳng phác thảo 5. Phác thảo mặt cắt của chi tiết. 6. Hoàn chỉnh chi tiết. 7. Thực hiện các yêu cầu quản lý file. 6.6.6 Các phần kéo và phần cắt. Các thủ tục để thực hiện một phần kéo (Protrusion) và cắt (Cut) hầu như hoàn toàn giống nhau. Extrude: Quét một mặt cắt phác thảo dọc theo một quĩ đạo thẳng. Revolve: Quét một mặt cắt quanh một đường tâm. Sweep: Kéo một mặt cắt dọc theo quỹ đạo nào đó do người dùng phác thảo. Blend: Nối 2 hay nhiều mặt cắt phác thảo, quỹ đạo có thể thẳng hay được xoay. Advanced: Gồm các tuỳ chọn: Variable Section Sweep, Swept Blend và Helical Sweep.
  10. C6 CAD-CAM> ProEWF 10 GVC NGUYỄN THẾ TRANH Hình 6.2
  11. C6 CAD-CAM> ProEWF 11 GVC NGUYỄN THẾ TRANH Hình 6.3 Hình 6.4 Các tuỳ chọn chiều sâu: Blind , Both Side Blind (2 phía), Thru Next , Thru All, Thru Until, Pnt/Vtx (kéo một chi tiết sang một điểm hay đỉnh), UpTo Curve (kéo một chi tiết đến một cạnh, trục hay đường cong được chọn), UpTo Surface 6.7. CÁC CÔNG CỤ TẠO CHI TIẾT. Pro/E cung cấp nhiều công cụ tạo chi tiết như các lỗ, các phần bo và các mặt vát. Hình 6.5
  12. C6 CAD-CAM> ProEWF 12 GVC NGUYỄN THẾ TRANH Chương này được bổ trợ thêm các buổi thực hành trên máy tính với nội dung: Sử dụng phần mềm Pro/ENGINEER Wildfire V2.0 phiên bản Educationnal để rèn luyện các kỹ năng CAD và CAM trên máy tính. 1. Làm quen với giao diện và các qui định của ProE. 2. Vẽ , thiết kế các chi tiết đơn giản. 3. Vẽ, thiết kế các chi tiết phức tạp. 3. Xuất bản vẽ kỹ thuật. 4. Lắp ráp các chi tiết.
Đồng bộ tài khoản