Customizing Your Menus and Toolbars

Chia sẻ: Tuan Bui Nghia | Ngày: | Loại File: PDF | Số trang:14

0
41
lượt xem
6
download

Customizing Your Menus and Toolbars

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Customizing Your Menus and Toolbars Outlook now has two methods you can use to customize toolbars to show the buttons and menus you use the most and to remove the ones you don't use

Chủ đề:
Lưu

Nội dung Text: Customizing Your Menus and Toolbars

  1. [ Team LiB ] Customizing Your Menus and Toolbars Outlook now has two methods you can use to customize toolbars to show the buttons and menus you use the most and to remove the ones you don't use. If you've customized toolbars in older versions of Office, you're familiar with the first method in which you drag menus and buttons around with the mouse. Choose Tools, Customize to open the Customize dialog to create customized toolbars (see Figure 16.2). Select the Toolbars tab to make a new toolbar, Commands to add new buttons and menus to your toolbars, or Options to configure display options such as personalized menus and icon sizes. Figure 16.2. Use the Customize dialog to create customized toolbars. While the Customize dialog is open, you're in Edit mode and the normal actions of the buttons and menus are disabled. The second method of customizing toolbars is the Rearrange Commands button found by choosing the Customize, Commands menu selection. The Rearrange Commands option is new to Office 2003 and gives users the opportunity to use an interface to add, delete, or move commands. Rearrange Commands keeps the menu in view until you're finished
  2. editing it, which is especially helpful when you're editing submenus. Get in the habit of creating new toolbars for your customizations rather than adding custom buttons or menus to the default toolbars. It's too easy to reset the default toolbars before realizing you have custom tools on them. Using Rearrange Commands Option Rearrange Commands is a new way to customize tools in Office 2003. Open the Customize dialog using Tools, Customize and look for the Rearrange Commands button on the Commands tab. You'll see a dialog like the one shown in Figure 16.3. Figure 16.3. Rearrange Commands provides a simple interface for customizing command bars. Using the Rearrange Commands menu, do the following: 1. Choose the menu or toolbar you want to rearrange by selecting the Menu Bar or Toolbar radio button.
  3. 2. Choose the menu or toolbar from the drop-down list. The entries are listed in the order they appear on the menu bar and toolbars, from left to right, and include submenus. 3. Add a new command by selecting a command and choosing Add to create the new command above the selection. 4. Select a command and choose Delete to remove it from the menu. 5. Use Move Up or Move Down to change positions on the command bars. 6. Choose the Modify Selection menu, and then select Begin a Group to add separators between the tools to group commands. The separator is added above the selected command, and you can use the Move Up and Move Down buttons to move separators into new positions. Table 16.1 lists all the options available when you use Rearrange Commands. Table 16.1. Rearrange Commands Options Button Action Add Opens the Add Command dialog; use it to add additional tools Delete Deletes the selected command Move Up Moves the selected command up one position Move Down Moves the selected command down one position Modify Selection Opens a dialog so that you can change how the button or menu looks Reset Removes all customizations made to the selected menu or toolbar The Reset button in the Rearrange Commands dialog restores the command bar shown in the window to its default settings, removing all of your customizations, including any changes made to submenus. Changing the Toolbar Appearance When you select a menu and see just a few commands on the menu along with a round button at the bottom, as shown in Figure 16.4, personalized menus are enabled. If the menu doesn't expand after a few seconds, click on the button to expand the menu. If you don't like personalized menus, you can disable the option on the Options tab of the Customize dialog. Figure 16.4. Personalized menus show the most frequently used commands when you first open the menu. When the menu remains selected for more than a few seconds, the menu expands and you can see all the commands on it.
  4. It's often easier to learn where to look for commands if you disable personalized menus until you're familiar with the menus. Personalized menu usage data is stored in C:\Documents and Settings\username\ Application Data\Microsoft\Office\MSOUTLO.PIP. Each Office program has a *.pip file in this directory that contains the usage data for its toolbars. You can reset the data for the Outlook toolbar by choosing the Reset Menu and Toolbar Usage Data button on the Options tab. If this is your first time using Outlook, other settings on the Options tab that you might find helpful are Show ScreenTips on Toolbars and Show Shortcuts in ScreenTips. Both of these options help you learn the keyboard shortcuts Outlook uses by displaying them in a small balloon when you hover over a button. Changes made in the Options tab of the Customize dialog affect all Office programs, not just Outlook. Outlook's toolbars dock at the top of the window by default, but they can be placed anywhere on the screen (see Figure 16.5). You can dock them on the sides of Outlook's window or float them on the screen. When a toolbar is floating, you can drag any edge in or out to adjust the height and width of the toolbar, from horizontal to vertical. Figure 16.5. Dock toolbars on any edge of the Outlook windows or float toolbars inside or outside the window.
  5. Move a toolbar by hovering the mouse over the resize handles on the left, holding down the left mouse button, and dragging the toolbar. When you drag a toolbar close to the window edge, it changes shape and docks on the window edge. When toolbars are docked on the left or right window edges, the icons rotate so that they're always in the correct position; text labels on the buttons remain vertical. Vertically docked toolbars are helpful to anyone who uses a high- resolution monitor setting and has a lot of white space on the right side of the window. Moving the toolbars to the side frees up enough space at the top of the screen to show more lines of text on the screen. Two or more toolbars can share a row to save screen space. When you place multiple toolbars on one row, you'll have some tools that won't fit on the screen. Look under the Toolbar Options button at the end of the toolbar for the buttons that are hidden. When you choose a hidden button, the button shows and a less-used tool moves to the overflow area. This is part of the personalized menu feature which hides less used menu items but remains enabled if the personalization settings in Tools, Customize, Options are disabled. Although you can't close the menu bar, you can dock it on any window edge or float it on the screen. When the menu bar is placed at the top or bottom of the window, it cannot share the row with toolbars. But when the menu bar is docked vertically, it can share a
  6. row with toolbars. Using the Modify Selection Menu Use the Modify Selection menu to customize individual buttons or menus. After opening the Customize dialog from the Tools menu, right-click on any button on the toolbar or menu to show the Modify Selection menu for that command. If you use the Rearrange Commands dialog to edit your menus, select the command and click Modify Selection to show the Modify Selection menu for that command. Finally, selecting any button enables the Modify Selection button in the Customize dialog, which you can use to modify the command. Table 16.2 is a list of the Modify Selection options. Table 16.2. Modify Selection Options Command Action Reset Resets the button to its default appearance. Delete Deletes the selected command. Name Names the button. Insert an ampersand (&) in front of the letter you want to use for keyboard shortcut, and then press Alt+ the shortcut key to activate the command. Copy Button Copies the selected button image. Image Paste Button Pastes an image to the selected button. Image Reset Button Restores a button image to the default image. Image Edit Button Opens the button editor so that you can create your own image. Image Change Button Enables you to select from a limited selection of included images. Image Default Style Uses the default style for the button: text only, image only, or text and image. The commands are shown in their default styles on the Commands tab. Text Only Always uses text only. (Always) Text Only (in Uses text only when the button is in a menu. For example, the Tools
  7. Menus) menu has some commands that include images and others that are text only. Image and Uses both images and text for the button. The Reply and Forward Text buttons use both image and text on both menus and toolbars. Begin a Group Adds a separator above the command if on a menu, or to the left if on a toolbar. Assign Adds a hyperlink to change the action of the command. Hyperlink Among the commands listed here, Assign Hyperlink is a powerful, yet underused feature in Outlook. You can use it to create buttons to open and run almost any program or file, from Windows utilities such as Notepad or Calculator to Word documents or Access databases, open Web sites, and create preaddressed email messages. For example, you can enter calc in the Hyperlink field so that when you click the assigned button, Windows Calculator runs. (Some programs might need the full pathname, but many Windows utilities need only the filename.) You can use a Web address, mailto URL, or network path as a hyperlink. When you want to create a custom toolbar button, pick any toolbar button from the Commands dialog because Outlook doesn't include blank toolbar buttons. Add a hyperlink to it and then edit its name and image. The hyperlink you use displays as the ScreenTip. Don't choose a menu button, which has a small triangle at the right side. Use toolbar buttons only. Task: Create a Custom Command Button Customizing toolbar buttons enables you to open almost any file or folder and requires no VBA code. One example of the usefulness of this is for users who upgrade from older versions and use the Outlook Bar for shortcuts to frequently used files and folders. This example shows you how to make a shortcut to an Outlook folder, but keep in mind that you can create a shortcut to any folder or file in the Windows file system: 1. Select the folder you want to use a button to open. 2. Show the Web toolbar (right-click the toolbar area and select Web) and copy the folder path from the Address bar, which will look like this: outlook:Inbox\ OutlookTips\Sent Tips (see Figure 16.6).
  8. Figure 16.6. Copy the folder path from the Web tool's Address bar. 3. Open the Customize dialog (click Tools, Customize). 4. From the Toolbar tab, click the New button to create a new toolbar. 5. Choose any button from the Commands tab and drag it to the toolbar. 6. Right-click on the button you just added and choose Assign Hyperlink. The Assign Hyperlink dialog opens (see Figure 16.7), and you can select from files or enter your own URL. Figure 16.7. Use the Assign Hyperlink button to create toolbar buttons for your files. 7. Paste the folder path in the URL field or browse for the folder and close all open dialogs. 8. When you click the button, a new Outlook window opens with the folder in view. To use a Windows folder or file instead of an Outlook folder, enter the file path to the folder and filename in step 7. You can browse the Assign Hyperlink dialog for the file or folder or copy the folder path from the Address bar in Windows Explorer. If the Address bar isn't showing, right-click on the Windows Explorer toolbar and select Address Bar. When you assign shortcuts to buttons and menus, you should try to use a key that isn't already in use or that isn't visible on the screen. When a shortcut is assigned to two different buttons or menus, the first Alt+ keystroke selects the first button that matches the
  9. keystroke. When you use the keystrokes a second time, it cycles to the next instance. After it has cycled to the command you want to use, you need to press Enter to activate the button. Adding and Deleting Tools To customize your command bars, open the Customize dialog by choosing the Tools, Customize menu selection. When you select a button or menu item, an outline appears around the edge of the button. Clicking the right mouse button grabs the command so that you can move it. You can then drag it to the position where you'd like it to appear and release the mouse button. If the commands you use the most are missing from the toolbars, you can add them to the existing toolbars or create new toolbars for them. If the toolbars have commands you don't use, you can remove them. To add additional commands to a toolbar: 1. Open the Customize dialog and select the Commands tab. 2. Locate the command you need by first browsing the Categories list and then the Commands list. 3. Drag the command to the toolbar or menu where you want it positioned and drop it. To delete commands from a toolbar: 1. Open the Customize dialog and select the Commands tab. 2. Select the command you want to remove and drag it away from the toolbar. 3. Release the mouse button when the cursor displays a small x, which indicates you want to delete the command from the command bar. You can move and remove buttons from command bars without opening the Customize dialog by holding Alt and left-clicking a button. The cursor image changes, and you can drag the button to a new position or drag it off the command bar to delete it. Adding and Removing Separators Many menus and toolbars have small bars called separators between the buttons (refer to Figure 16.1), giving you the ability to organize the buttons into groups. You can create separators using the Begin a Group command found on the Modify Selection menu of a button or just by dragging a command button.
  10. Create separators between two buttons by dragging the rightmost of the two buttons slightly farther from the button to its left. You can remove separators by dragging the rightmost button closer to the button on the left. Create menu separators by sliding a menu item down and remove separators by sliding a menu item up. Changing How Tools Display As mentioned earlier, each command has a default display setting. The Commands tab of the Customize dialog displays commands using the default settings. You can change any button or menu to use any of these settings: • Text only • Text only when used on a menu • Text and image • Image only After opening the Customize dialog, right-click on the button you want to change and choose the command from the Modify Selection menu (see Figure 16.8). The change is applied immediately so that you can see how it looks. Figure 16.8. Change the display of the button using the Modify Selection dialog.
  11. If you're having trouble remembering what some toolbar buttons do, change the buttons from image only to text and image until you're familiar with them. You can also enable ScreenTips in Tools, Customize, Options to help you learn the button images. Along with changing how the button name and image are displayed, you can also change the name and the keyboard shortcut used to activate the button. However, it's not a good idea to change the name or shortcut for the default commands. Doing so leads to confusion if someone else uses your computer or if you tell someone to look for a command by name and you forget that you changed the name. To change a name or keyboard shortcut, open the Customize dialog and right-click on the button. Enter a new name in the Name field and place an ampersand (&) in front of the character you want to use as the shortcut. For example, the hot key for Forward is w, which is entered in the Name field as For&ward. To activate the command, press Alt+ the character that follows the ampersand. If the shortcut already exists, pressing Alt+ the character will move you from the first instance to each additional instance, starting at the top of the window. When you use the same shortcut more than once, you must press Enter to activate the highlighted command. If you don't like an image, you can either edit it or paste an image from another tool or program. All the Office programs have the same Customize dialog and editing options. You can copy a button image from Word or Excel and paste it on a button in Outlook. You can also copy any 32x32 pixel bitmap and paste it as a button image. To copy a button image from Word to use in Outlook: 1. Open Word's Tools, Customize dialog. 2. Right-click on the button whose image you want to use in Outlook. 3. Select Copy Button Image from the Modify Selection menu. 4. Close the Customize dialog in Word. 5. Open Outlook's Tools, Customize dialog. 6. Select the command you want to paste the image on. 7. Right-click on the button and choose Paste Button Image from the Modify Selection menu. Outlook's button now uses the button image copied from Word. When copying an image, open the image in your favorite image editor. Select a 32x32 area of the image to copy. Then paste it into Outlook beginning with step 5 in the preceding list.
  12. Use Edit Button Image to edit the button images. Select a color and click in the squares in the Picture field. Double-click to create transparency by erasing color from the squares (see Figure 16.9). Figure 16.9. The image editor included with Outlook offers only basic editing features. Select Erase to create transparent areas. Select Color Picker to choose from additional colors. You can paste a bitmap of almost any size in the paste dialog, but because the button image can only be 32x32, larger bitmaps won't be recognizable. It's better to resize the image to 32x32 using an image editor such as Paint Shop Pro than to paste it as a button image. You'll also want to crop larger images as much as possible before resizing to 32x32. Moving Tools on Toolbars You can position commands anywhere you'd like—in a different order on the existing toolbar, on a different toolbar or menu, and even on a new toolbar. When you're just moving the command, hold the Alt key + left mouse button and drag the button to a new position or toolbar. If you're planning more customizations, use Tools, Customize and open the Customize dialog. Drag the buttons around to reposition them.
  13. When you use the personalized menu feature, Outlook remembers the most frequently used commands and displays them, hiding the less used commands. You might need to disable this feature if you have problems finding commands or if your custom buttons don't seem to stay where you position them. Modifying the Display of Drop-Down Lists Along with normal command bar buttons, Outlook includes command buttons that contain drop-down lists. You're already familiar with the New button on the Standard toolbar, as well as the menus on the menu bar and the menu commands on some of the menus with triangles pointing to the right to indicate that they contain more menus. When you create hyperlinks using a standard button, you can edit any command button without affecting the behavior of other buttons that were created using the same button. For example, if you need three buttons, you can drag three copies of the same button to a toolbar and assign different hyperlinks to each button. However, you can't edit the predefined drop-down buttons—if you drag a drop-down button to a toolbar and edit it, the changes are mirrored in the original button. In the case of the New menu, the changes are reflected in both the New button on the Standard toolbar and the New menu on the File menu. When you want to create custom drop-down buttons, you need to use the blank New Menu button found in Tools, Customize, Commands. Scroll to the bottom of the Categories list to locate the New Menu category and then drag a New Menu button from the Commands list to a menu or toolbar. When you place a New Menu button on a toolbar, the button has the small triangle pointing down. When you place it on the submenu, the triangle points right, as shown in Figure 16.10. When it's put on the menu bar, it looks like the other menus and doesn't have the triangle. Figure 16.10. When you use menu commands on a toolbar, the commands include triangles to indicate they include submenus. You can position menus and tool buttons on a toolbar, menu, or submenu.
  14. All New Menu drop-downs have most of the Modify Selections menu options dimmed, and you're limited to deleting the button, resetting it, editing the name, or beginning a new group. You're also limited to using text for the buttons, not images. After you've added and named the New Menu command, you can drag buttons to submenus. When you hover the mouse over a menu, it opens and you can then move the mouse over the opened menu and drop the tool on it. You might find it easier to use the Rearrange Commands option on the Commands tab to arrange the submenus. Resetting Toolbars After you make changes to your command bars, you might decide that you want to restore the default settings. You can easily reset the command bars: 1. Open the Customize dialog (choose Tools, Customize). 2. Select the Toolbars tab. 3. Select the menu or toolbar by name. 4. Click the Reset button. If you have many changes to reset, close Outlook, delete outcmd.dat, and restart Outlook. This restores the toolbars and menus to the default settings and removes every custom toolbar you created. [ Team LiB ]
Đồng bộ tài khoản