Essential Blender- P19

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

0
30
lượt xem
4
download

Essential Blender- P19

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Essential Blender- P19:You may copy and distribute exact replicas of the OpenContent (OC) as you receive it, in any medium, provided that you conspicuously and appropriately publish on each copy an appropriate copyright notice and disclaimer of warranty; keep intact all the notices that refer to this License and to the absence of any warranty; and give any other recipients of the OC a copy of this License along with the OC.

Chủ đề:
Lưu

Nội dung Text: Essential Blender- P19

  1. Figure UVD.12: Selecting in non-local mode selects all nodes connected in the 3D view. This is particularly useful when your mesh is divided into many islands and you need to find which parts of one island correspond to which parts of another. Tip: Node selection in the UV Editor shares many selection functions with meshes in Edit mode. Fixing the Unwrap Although the default unwrap is usually pretty good, you will probably need to optimize it for texture painting. Areas that will be a focus of rendering and detail need to be carefully painted, and an even, proportional unwrap can only help.
  2. Pinning and Live Unwrap Transform Areas of an unwrap that you are happy with can be frozen by "pinning." Pressing the P-key pins selected nodes. Fixing portions of an unwrap that you are unhappy with is as simple as pinning a few key nodes within the bad area and moving them into a better configuration. Then, after also pinning the good areas, Blender can re-unwrap the mesh, hopefully giving better results. It uses all the pinned nodes as a starting point for its next attempt. Asking for another unwrap can be done from the 3D view with the U-key menu as before, or directly from within the UV Editor with Ctrl-E. One great thing Blender can do to make this process much more intuitive is called "Live Unwrap Transform," and can be accessed only through the UVs menu on the UV Editor's header. Once Live Unwrap Transform is enabled, there is no need to re-unwrap your meshes after pinning and adjusting. The unwrap adjusts itself in real time as you pull and push pinned nodes, giving you great visual feedback that helps to quickly optimize the unwrap. Figure UVD.13: A bad unwrap, with several nodes pinned, and one selected.
  3. Figure UVD.14: The selected, pinned nodes have been moved, causing the rest of the unwrap to adjust itself. When you have the unwrap the way you want it, be sure to turn off Live Unwrap in the UVs menu so you don't accidentally move a pinned node and ruin your work. Tip: P-key pins nodes. Alt-P unpins. Moving pinned nodes while in Live Unwrap Transform mode adjusts the unwrap in real time. Paint Tools Blender's painting tools can be used to paint onto existing images or to create new ones, and can be used either in the UV/Image Editor or directly within the 3D view. To be able to texture paint
  4. a model in the 3D view, you need to have assigned UV coordinates to the mesh's faces by unwrapping. Texture Painting mode Is accessed through the Image menu on the UV Editor header, or by changing the object mode on the 3D header to "Texture Paint". Figure UVD.15: The Image menu in the UV/Image Editor.
  5. Figure UVD.16: Texture Paint mode, with the Image Paint panel. Whether you are painting in the 3D view or in the UV/Image Editor, you must have an image selected in the UV/Image Editor (just called the Image Editor from now on, as we're done with the UV functionality). If you have an image loaded for some other reason (a texture, a background, etc.), you can select it on the Imageblock selector dropdown on the Image Editor header.
  6. Figure UVD.17: The Imageblock selector. If you would like to create a completely new image, choose "New" from the Image menu, then set a resolution in the dialogue that pops up. A new, black image is created and loaded into the Image Editor. Tip: You can paint directly on images by setting the Image Editor or object to Texture Paint mode. Pressing the C-key in Texture Painting mode in the Image Editor brings up the Image Paint palette. A nearly identical panel, called Paint, is available in the Edit buttons (F9) for use in the 3D view.
  7. Figure UVD.18: The Image Paint and Paint panels. Painting is accomplished by LMB dragging across either the image itself or the model in the 3D view. The general brush controls are: Color: Chosen by LMB clicking on the color swatch. This is the main color that is used for painting. Opacity: How strongly the painting blends with the current image. An Opacity value of 1.0 causes the painted color to completely cover the existing image. 0.50 would cause the color to be applied at only 50%. Size: Adjusts the size of the paint brush. Falloff: The hardness of the brush. Setting Falloff to 1.0 creates a hard-edged brush. Reducing it to 0.0 creates a brush with a very soft edge. Spacing: How frequently the brush "stamps" its color as you drag. Painting in Blender isn't truly continuous as it is if you were to drag a brush loaded with oil paints in the real world. The Image Editor simulates continuous painting by stamping the color every few pixels, in the shape of the brush. The Spacing value is a percentage of the Size value and determines how far apart these
  8. stamps occur. If Size is set to 45 and Spacing is set to 10, the brush will paint a new blob of color every 4.5 pixels (10% of 45). If you happen to have a pen and art tablet for your computer, you'll find that it works very well with texture painting. Clicking the little "P" icon beside any of these settings will allow them to be controlled by your pen's pressure. Airbrush: Enabling this option causes paint to continue to flow for as long as you have the LMB pressed, even if the brush is stationary. Normally, painting only occurs as the brush moves. In addition to painting with a color, it is also possible to paint with a Blender texture, giving even more detail to your painted image. Any texture that has been created in the Texture buttons (F6) can be selected in the dropdown at the bottom of the Image Paint palette. That texture is then used along with the palette color when painting. Note: See Chapter 9 for information on using the Texture buttons. Textured brushes can be created in the Texture buttons by selecting the Brush button in the Preview panel. Draw Modes The top of the Image Paint and Paint palettes control the brush mode. Draw: This is the normal painting brush that you have been using. Soften: This brush blurs the image as you use it. Smear: Dragging with this brush pulls and smears the image. Clone: The clone brush lets you paint portions of other images into the one you are working on. The clone brush is not available when painting in the 3D view. When the clone brush is selected, the texture dropdown at the bottom of the Image Paint palette is replaced by an image selector dropdown. You can select any other image that has already been loaded into Blender. When you do, that image shows up in the background at 50% opacity. Painting with the clone brush copies the portion of the image under the brush into the active image. The background image may be moved around with the RMB in order to align portions of it with different sections of your main image.
  9. Figure UVD.19: A clone image used in the background. Image File Management It is important to remember to save any images you create or alter in the Image Editor. If you don't, any changes you've made will be lost when you quit Blender. To save your changes to an image, or to save a new image for the first time, select "Save" from the Image menu in the Image Editor. Blender will let you know that an image has unsaved changes by placing an asterisk (*) beside the Image menu.
  10. Figure UVD.20: Unsaved image indicator. One Last Bit of Fun For a final cool trick, try clicking the Lock icon on the Image Editor header. If your object is visible in the 3D view while painting in the Image Editor, the Lock will show you the painting in the 3D view in real time. To be able to see it, either enable Texture Paint mode in the 3D view or set the object's Draw mode to Textured.
  11. Chapter 10: UV Unwrapping and Painting: Tutorial By Modron The process of UV Mapping a mesh is very much like taking a physical paper model of an object, cutting it in various places, and flattening it onto a table. Once that is done, photographs can be fastened to it, or it can be painted directly. Then, the flattened paper is reassembled into its original 3D configuration. In UV Mapping in Blender, mesh models are cut and unwrapped into a flat UV Editor window where textures and images are applied. Of course, because this is 3D graphics, you can do other cool things once you have this basic procedure down, such as painting directly on your model in the 3D view and baking lighting and texturing information for later use. Although there are several methods for unwrapping mesh objects, Blender's automated unwrapper does such an excellent, easy job that it's the one we'll cover. In this tutorial, you'll unwrap an organic shape using Blender's live unwrapping feature, and do some texture painting in the UV window. Unwrapping an Organic Shape Before you begin, either run Blender or, if it's already running, start a new session with Ctrl-X. When the default screen appears, use the MMB to split the 3D view into two separate windows (see Chapter 2 if you need a reminder of how to do this). Then, change the right hand 3D view into a UV/Image Editor window using the Window Type icon menu on the far left of the header.
  12. Figure UVT.00: The default screen, with the 3D view split and set to a UV/Image Editor window. You could unwrap the default cube, but that would be boring. RMB select it, and get rid of it (X- key). You need something worthwhile to unwrap, so go into a front view (Numpad-1) and add Suzanne to your scene by choosing Add->Mesh->Monkey from the spacebar toolbox. (Suzanne is the pet name of Blender's default Monkey primitive.) If you know how from the Mesh Modeling chapter, you can Set Smooth on Suzanne and add a Subsurf modifier (Shift-O) so she looks a little nicer. Defining Seams, or How the Mesh Will Be Cut The Suzanne mesh is added in Edit mode, which is what you want. If the mesh you are working on is not in Edit mode, use the Tab-key to get there. Imagine for a moment that Suzanne is made out of a skin of rubber, or fabric, and the idea will be to make cuts in a way that the surface could be laid out flat, with minimal stretching or bunching. The main consideration is to place the seams in areas that will create "islands" of faces where continuous detail will be needed. If there is going to be a highly visible area with lots of detail or a smooth gradient, you do not want to put a seam there. Seams should be placed in unobtrusive areas, as though you were a plastic surgeon trying to hide your cuts.
  13. To make a seam, select an edge and press Ctrl-E. From the Edge Specials menu that pops up, choose "Mark Seam." Any edges marked as seams will display with twice the thickness of a normal mesh edge, and will be a dark orange in color. Seams that are mistakenly marked can be cleared with the "Clear Seam" option in the Ctrl-E menu. In the illustrations below, you can see where we have chosen to set seams on the Suzanne model. Really though, you can make your seams wherever you like. We encourage you to experiment with different seam placements later to get a feel for how unwrapping works. For now, though, try to at least approximate the configuration in the illustrations, so that the rest of the tutorial follows what you are doing. One thing to keep in mind while making selections for seams is that Edge Select mode and Alt-RMB Edge Loop select can be very useful. Figure UVT.01
  14. Figure UVT.02 Getting the Faces Into the UV Editor Let's ask Blender to unwrap and flatten Suzanne based on the seams you've marked, then transfer that configuration to the UV Editor. Press the Tab-key to put Suzanne into Object mode. Now, you'll learn a new mode specifically for dealing with faces and UV unwrapping. Press the F-key, and see that you've entered a new mode called UV Face Select mode. Image:Dummy.png Figure UVT.02.5: Face mode can be identified on the modes menu on the 3D header, and by the broken lines designating selected faces. Press the A-key to deselect all your faces (deselected faces are white) and press it again to reselect them all (selected faces are pink). This double A-key technique is a good habit to get into
  15. to make sure that all faces are included in the unwrap. If your Suzanne turned pink on the first tap of the A-key, that's okay - it just means that it began with no faces selected. When in Face mode, the Tab-key still works to enter and exit Edit mode. Any face selections made in Edit mode will be carried back into Face mode when you return. With all faces selected in Face mode, press the U-key (for Unwrap). A menu pops up with a number of options. Choose "Unwrap." In the UV Editor window, the sliced and unwrapped version of Suzanne appears. Figure UVT.03: Your unwrap will be different than this if you created different seams than the previous samples. Note how the front of the face, which will be an area of continuous detail, has been kept as a single piece. Many of the commands and tools that work with mesh editing also work when dealing with the flattened mesh in the UV Editor window. One of the more useful commands is Ctrl-L, which selects an entire continuous section of faces from a single selected node. Note: For technical reasons, the "vertices" you see in the UV Editor aren't exactly vertices as they are in the mesh. In the UV Editor, they are referred to as "nodes."
  16. RMB select a node in the UV Editor, then press Ctrl-L. That will select the entire UV "island" that the node belongs to. You can move, rotate and scale UV nodes and islands using the G, S and R-keys as in other editing situations. The mouse gestures work here, too. Arranging the Islands As you'll be painting a texture, it would be nice to have the islands oriented in a way to make it simpler. The arrangement of the islands in the previous illustration would require you to paint textures at odd angles. It would help to rearrange them. Figure UVT.04: The UV islands rearranged and rotated to assist with texture painting. There are a couple of things to note in this illustration. First, see how the front face island has been scaled up a little bit. It will be the visual focus of the monkey model and should be given more area in the unwrap so it can have more detailed texturing. Second, the two eye islands have been placed on top of each other. You'll see why later. And finally, notice how the nose has been separated from the rest of the front face mesh. In some cases, it might be okay to leave them
  17. apart, but since you'll be painting the entire front of the face as one piece, you should reconnect them. The nose island is shown in the illustration, but you should look at how to identify parts of an unwrap in case it's not so clear. In the 3D view, RMB select one of the faces on the nose. In the UV Editor, you'll see that all the UV nodes disappear except the one you have just selected. Now, keeping your eye on the UV Editor, but keeping the mouse over the 3D view, press the A-key twice. All faces are again selected, and all the nodes reappear in the UV Editor. You will be able to see which portion of the UV nodes contained the one you had selected. Select the nose island (hover the mouse over the nose island and press the L-key) and use the G- key to move it into the middle of the hole on the front of the face. If you need to, use the S-key to scale the nose island until it is slightly smaller than the hole. Select all the nodes around the outer edge of the nose island and press the P-key. The selected nodes turn red. This means they are "Pinned." Pinned nodes form the basis of the "Live Unwrap Transform" feature, which we will look at next. In the "UVs" menu on the header, select "Live Unwrap Transform." Figure UVT.05: The nose island in place inside the nose hole on the main face's island.
  18. Now RMB select the pinned nodes one by one and drag them roughly to where they will attach to the face. Notice that the unpinned nodes on the nose island follow along and optimize themselves in real time to keep the rest of the faces in proportion to the ones being fixed. Your goal is to stitch these two islands back together, so you would like to get the nose nodes fairly close to their corresponding face nodes. You don't need to be exact, though, because Blender has some handy tools to help with the job. Figure UVT.06: This is all the closer you need to get. To use the stitching tool, you need to select all of the nodes that will be stitched: the outer nodes of the nose island and the inner ring of nodes on the nose hole on the face island. Since these nodes actually share vertices in the 3D mesh, there is a different selection mode that will help you to access corresponding nodes, no matter where they are in the unwrap. On the Select menu in the header, choose "Stick UVs to Mesh Vertex," or use the Ctrl-C hotkey. Now, when you RMB select the nodes on the nose island, the corresponding node on the face island is also selected for you. Using Shift-RMB select, build a selection of the outer ring of the nose island.
  19. When you are finished doing that, you should see that the inner ring of the nose hole on the face island is also selected, due to "Stick UVs to Mesh Vertex." Activate the Stitch command by pressing the V-key. It's also in the UVs menu on the header. The two islands are now joined. Figure UVT.07 To show the use of the "Live Unwrap" tool a little better, let's do one more thing to the unwrap before you begin painting. Select all UV nodes in the UV Editor by pressing the A-key. When everything is selected, clear the pinning you made before with Alt-P. All of the pinned red nodes should return to normal. Now, from the Select menu, choose "Stick Local UVs to Mesh," which is the opposite of the setting you used before. For the next part, you only want the nodes that you directly select to be active, not any extra nodes that might be connected to this one in the 3D mesh. With that done, RMB select the uppermost node of the face island, then Shift-RMB select the lowest. Also, Shift-RMB select one node on either side of the mouth. Use the P-key to Pin these four nodes.
  20. Figure UVT.07.1 Make sure that "Live Unwrap Transform" is selected in the UVs menu. RMB select the node at the top of the face island, and using the G-key, start to move it around. The UV faces change shape and location to try to keep everything in proportion, but the other three pinned nodes stay exactly where they were put. They do not move. Pinning tells the UV unwrapping procedure to use those nodes and their locations as its new baseline for calculating the unwrap. As you move any pinned node by hand, the unwrap is recalculated for the new positioning of all pinned nodes and displayed. And so, if you knew that you would be painting significantly more detail in the forehead area, you could drag the top pinned node slowly upward, expanding the area covered by the upper part of the face island, while having everything automatically adjust to stay proportional. Likewise, you could select the pinned nodes on either side of the mouth and S-key scale them, expanding the space given to the mouth faces, while the unwrapper used the other two pinned nodes as pivot points for determining the rest of the unwrap. When you're satisfied with the unwrap, turn off "Live Unwrap Transform" in the UVs menu. Select all the nodes in the UV Editor and use Alt-P to unpin them.
Đồng bộ tài khoản