Flash CS4 Professional in 24 Hours- P4

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

0
53
lượt xem
8
download

Flash CS4 Professional in 24 Hours- P4

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Flash CS4 Professional in 24 Hours- P4: The creation of this book could not have happened without the skill and patience of many, many people at Sams Publishing. Most of all, I want to thank Mark Taber for offering me this opportunity and Philip Kerman for writing such a great book. I also greatly appreciate the efforts of Songlin Qiu for keeping me on track and organized, not an easy task.

Chủ đề:
Lưu

Nội dung Text: Flash CS4 Professional in 24 Hours- P4

  1. Using Bitmaps (Also Known as Raster Graphics) 81 Figure 3.11 shows the results of using several different compression levels on the same image. Notice JPEG 80 and JPEG 100 are almost identical in quality, but JPEG 80 has a much smaller file size. You get the ultimate quality by using the compression option Lossless (GIF/PNG). It is selected by default when you import .png and .gif files, but you can select it any other time you want to use it. When this option is FIGURE 3.11 The results of different compres- sion settings on the same image shows how quality degrades and file size shrinks. selected, Flash leaves the image in its original state. This option always pro- vides the best quality—but not without a price. File size is highest when this option is selected. This is a suitable alternative if you’re making a movie that doesn’t need to download from the web—for example, if you’re making a presentation that you are delivering on your hard drive or CD- ROM. Otherwise, you should use this option only on images where you want to retain the best quality possible. If your imported image is a .gif that already has a small file size, selecting Lossless is perfectly suitable. Be- cause even 100% JPEG compression causes some image degradation, the Lossless option is suitable for images that are particularly important. Fi- nally, the only way Flash supports 32-bit graphics (that is, raster images with varying degrees of transparency) is through .png items that you set to Lossless. The fact that PNG is the only format that supports transparency is another perfectly legitimate reason to use PNG.
  2. 82 HOUR 3: Importing Graphics into Flash Smoothing Regardless of which compression option you use for your imported bitmaps, Allow Smoothing (as shown earlier in Figure 3.10) is another op- tion in the Bitmap Properties dialog. If you plan to scale or rotate the raster graphic, you want to click that check mark. Normally, a bitmap with its ex- plicit number of pixels looks fine without smoothing. However, smoothing lets Flash apply a tiny bit of blur when the image’s pixels don’t align per- fectly with the screen’s pixels, which is the case when you rotate or scale an image. You can see the effect of smoothing in a side-by-side comparison in Figure 3.12. FIGURE 3.12 Applying smoothing to the image on the left improves it when rotated, but the same effect makes the im- age look soft. The downside of smoothing is images can look a bit fuzzy, so don’t use it if you’re not rotating or scaling the image. If you’re using the image in a de- tailed animation, you want to opt for smoothing. Compared to how raspy a modified image looks without smoothing, you probably want to click the check mark to enable smoothing when appropriate. Importing Layered Raster Graphics Flash CS4 can import Photoshop .psd files. The value is that artists can work in Photoshop, and you can conveniently import the graphics they cre- ate. Compared to having the artist individually export each element and then you import it and place it in the correct position, this is a huge work- flow improvement. What’s doubly great about this new feature is that it’s so intuitive there’s not a whole lot to learn.
  3. Using Bitmaps (Also Known as Raster Graphics) 83 Like the Illustrator Import dialog, when you select File, Import, Import to Stage and point to a Photoshop file, you see all the layers and folders con- tained in the source Photoshop file, as shown in Figure 3.13. There are some striking similarities between the Photoshop import dialog and the Illustrator one discussed earlier—though this one is more ad- vanced. You can see similar global options at the bottom left as to whether FIGURE 3.13 Importing a Photoshop document allows you to select how to import each layer. to keep objects in position and or to convert layers into Flash layers or keyframes. Also similar is the way you can include or exclude layers by clicking check marks. A particularly handy feature in Photoshop, called layer comps, lets you save multiple arrangements of your layers and their contents. Artists can include tons of layers with all the graphics for an entire project in a single Photo- shop file. Then, they can make multiple compositions—for example, one where only the layers related to the home screen in your project are visible and another where the layers for a video section are visible. With layer comps, artists can quickly view different arrangements without going through and turning layers on and off. When you import a Photoshop doc- ument with layer comps, you see them listed at the top left, as shown in Figure 3.14. This gives you a quick way to select all the layers related to a particular layout.
  4. 84 HOUR 3: Importing Graphics into Flash FIGURE 3.14 You can use the Layer Comp drop- down to quickly select the layers re- lated to a particular layout. After you’ve selected the layers you want to import, you can set the options for how each layer gets imported on the right side of the import dialog. Provided you don’t want to accept the defaults, you individually select each layer and make adjustments to the options on the right. All layer types can be imported as a flattened bitmap, which is the best way to retain the exact look created by the artist. You see slightly different options in text lay- ers and shape layers, but the big difference from the Illustrator importer discussed earlier is that for each layer you import as a flattened bitmap, you can individually set the publish settings. The publish settings for each imported layer affect the Bitmap properties for the contained objects when they appear in the Library. These settings are the same ones you learned about in the previous section “Adjusting Bitmap Properties.” This way, you can make the decision between JPEG and PNG/GIF and whether to use Flash document’s publish settings for compression or set them individually for each item. The odd thing is that the terms are slightly different than the ones you just learned. Where the Photoshop importer says Lossy Compression, it means JPEG in the Bitmap Properties dialog (accessible by double-clicking an item after it’s in the Li- brary). Where the Photoshop importer says Lossless, it means PNG. Although you always see the best quality by importing layers as flattened bitmaps, other options also have some value. In the case of text layers, you can opt to import as editable text. You can make edits to the actual wording
  5. Summary 85 later, but realize you immediately lose any layer effects applied to the text. Photoshop supports very detailed text effects that are unmatched in Flash. For both shape and text layers, you can choose to keep paths and layer styles editable. Not only does this mean you see subtle differences in the image after it’s inside Flash, but a complex Photoshop document translates to a complex Flash document. Be prepared to test any import process if you’re not importing as flattened bitmaps. To summarize the suggested workflow, select the layers you want to im- port, either by clicking the check marks or by selecting a layer comp, which effectively selects the layers for you. Then, go through each layer to adjust the publish settings or do this later via the Library item’s bitmap properties. Summary When possible, you should create graphics inside Flash. But sometimes you can’t. There are times when you need to import graphics, such as when you have an existing graphic that would be impossible or difficult to recreate in Flash or when a graphic requires a raster file type, such as a photograph. When you’re certain you want to import, Flash provides you with mecha- nisms to do so. Q&A Q. Importing Photoshop and Illustrator files looks pretty cool, but I don’t have those programs. How can I test out some of what I learned this hour? A. You can find some sample .ai and .psd files in the downloads section of the publisher’s website. Q. I’m having trouble importing images from a digital camera. I have some great shots of my potato chip collection, but they’re huge after I import them. How can I resize them? A. Because multi-megapixel cameras produce originals that can be thou- sands of pixels wide, you don’t want to import these directly. First use an image editing program, such as Fireworks, to resize the image to fit comfortably on a normal screen size—that is, less than 1024×768 or 800×600. Taking a megapixel image and scaling it down inside Flash does not improve the sharpness and actually does the opposite if you don’t select the Allow Smoothing option. Worse still, the file size will be huge. Don’t do that; instead resize and optimize the image before importing!
  6. 86 HOUR 3: Importing Graphics into Flash Q. I have a photograph that I use as a raster graphic in my Flash movie. After I scan it into the computer and touch it up, what file format should I choose? There are so many. A. Generally, you want to keep all your raster graphics in the highest-quality format possible before importing into Flash. One exception is when you use a tool, such as Fireworks, to produce an optimally compressed im- age. If you use an outside program to compress the image, make sure you don’t recompress in Flash; leave the default setting Use Imported JPEG Quality. Alternatively, if you import a high-quality .pct, .bmp, or .png, you can compress it in Flash until you’re satisfied with the com- pression level. JPEGs are all right, but they always have some compres- sion that could result in artifacts. GIFs are not a good alternative because they can’t have more than 256 explicit colors. Changing the file format of an existing image never makes a graphic better andpotentially makes it worse. You should start with the best quality possible, and then reduce it as the very last step. Q. How do you determine how much one graphic is contributing to the fi- nal movie’s file size? A. If it’s a raster graphic, you can explore the Bitmap Properties dialog box, which tells you exactly how big a graphic is. With vector graphics, deter- mining the size is more difficult. Ultimately, you should copy the graphic into a new file and export a .swf of that file by selecting File, Export. You can look at the file size. Sometimes it’s not so important how much one graphic is contributing, especially if it’s an important graphic; your concern should always be to not add to the file size unnecessarily. Q. I have a fairly simple Illustrator file graphic that I would like to import into Flash. It’s impossible to redraw in Flash, so I have to import it, right? A. If the file is simple, it should be possible to create it in Flash. Make sure you’re fully exploiting the potential of Flash. Read Hour 2, “Drawing and Painting Original Art in Flash,” again, if necessary. Of course, if you have to import the image, do so. You might still have luck if you first ex- port it from Illustrator as a .swf before importing.
  7. Workshop 87 Workshop The Workshop consists of quiz questions and answers to help you solidify your understanding of the material covered in this hour. You should try to answer the questions before checking the answers. Quiz 1. What’s the most appropriate image file format to import into Flash? A. Raster. B. Vector. C. It depends on the nature or content of the image. 2. If you import a .gif image into Flash, what kind of compression does Flash use on the image when it exports the entire movie? A. It depends on the Compression setting in the Bitmap Properties dialog box. B. Flash always uses JPEG compression, but it’s up to you to specify what quality level to use. C. GIFs are exported as GIFs. 3. How do you import photographs created with a digital camera? A. You can’t; you must use conventional film. B. It’s simple; click File, Import. C. Be sure to resize the image in an outside program first, then click File, Import.
  8. 88 HOUR 3: Importing Graphics into Flash Quiz Answers 1. C. Although a vector graphic has benefits over a raster graphic, the most appropriate image file format to import into Flash depends on the graphic. Photographs usually have to stay as raster graphics. 2. A. Each image imported can have a unique compression setting that is not dependent on its original format. By default, however, im- ported .gifs get exported as .gifs. 3. C. Maybe we’re being tricky including a question whose explanation is only found in the Q&A section, but be sure to read the second question in that section if you didn’t get this answer right because it’s important.
  9. HOUR 4 Staying Organized with the Library and Layers Flash’s Library is so fundamental that creating a Flash movie without it is al- WHAT YOU’LL LEARN IN most impossible. If you don’t use the Library, it’s fair to say you’re doing THIS HOUR: something wrong. The Library is where master versions of graphics are . How to create symbols kept. Editing a graphic in the library changes all instances of that graphic . How to use the Library throughout a movie. Also, graphics stored in the Library—despite how to minimize work many times they’re used in a movie—are stored and downloaded only once, making your movie more efficient. This hour explores organization of . How to identify clues in your movie using the Library. the Flash interface to help keep your bearings Symbols are things, usually graphics, that you put in the Library. Anything created in Flash and placed onstage, such as shapes, groups, other symbols, . How to use multiple symbol instances with- even animations, can be converted into a symbol and placed in the Library. out increasing a You can choose from three symbol types, and each has unique characteris- movie’s size tics. We get to these in a moment. Item is the term used for each media element imported into your movie, and thereby resides in the Library. Items can be bitmaps, audio files, and digital videos. However, symbols created in Flash are the Library items with which you become most familiar. Instance is the term given to a symbol anytime it’s used outside the Library. As you see, only one master of any symbol exists—the one saved in the Li- brary. However, you can drag as many instances of a master symbol out of the Library as you like. Each instance is like a copy of the original. The Concept of the Library The process of using the Library involves creating symbols and then using instances of those symbols throughout a movie. You always have one master
  10. 90 HOUR 4: Staying Organized with the Library and Layers version of a symbol stored in the Library. You can drag multiple instances of that symbol from the Library to any other part of the movie—even inside other symbols. The ability to create instances of a master symbol offers two important benefits. First, this means file size remains small because only the master symbol adds to the file size, and each instance just points to the master, (similar to how a shortcut in Windows or an alias on the Macintosh points to a master file). Second, you can make a visual change to the master symbol, and that change is then reflected in each instance. This is like using styles in a word processing document: You make a change to the style, and each instance where you use that style reflects the change. You learn more about these benefits in a minute, but let’s first go over the basics of how to create and use symbols. How to Create and Use Symbols Two ways to create symbols are to convert any selected object onstage into a symbol or make a symbol from scratch. The following task looks at the first method. ▼ TRY IT YOURSELF In this task, you create symbols using the Convert to Symbol feature. Create a Symbol by Follow these steps: Converting Selected 1. In a new file, use the Oval tool to draw a circle. Click the Selection tool Objects and make sure the circle is entirely selected. You can double-click the center if it’s not a Drawing object, marquee the whole thing, or simply click Edit, Select All. 2. Click Modify, Convert to Symbol or press F8. Flash forces you to spec- ify the name and type for this symbol (as shown in Figure 4.1). FIGURE 4.1 When you convert to a symbol, you must specify a name and type. 3. You should always name symbols logically. The default Symbol 1 might seem logical, but having 35 symbols all named in this manner can be- come unwieldy. (You learn more about naming symbols later in this hour, in the section “Managing the Library by Using Names, Sorting, and Fold- ers.”) Name this one Circle. We look at all three types of symbols
  11. The Concept of the Library 91 eventually, but for now consider Movie Clip the best choice when you’re ▼ TRY IT YOURSELF not sure which to choose. Buttons are useful only when you’re creating buttons, and Graphics are primarily used for static graphics. Set Type as Create a Symbol by Converting Selected Movie Clip, and click OK. It’s possible that your Convert to Symbol dia- Objects log box is set to Advanced so it looks much larger than the one in Figure 4.1. If this is the case, you can collapse it by clicking the Basic button (which toggles to read Advanced) because we aren’t exploring the Ad- vanced settings now. 4. Open your Library window by clicking Window, Library (or Ctrl+L), and you should notice one symbol, Circle, in the Library. When you selected Convert to Symbol, you did two things: You stored your new symbol in the Library, and you caused the object that remained on the Stage to become an instance of the Circle symbol. If you drag more instances from the Library window (by single-clicking and dragging the picture of the circle from the Library window onto the Stage), each new instance is equivalent to the instance already on the Stage. If you double-click by accident, you see Scene 1: Circle in your Edit Bar, indicating you’re edit- ing the master version of the symbol. In this case, you can simply click Scene 1 or press Ctrl+E to get back to editing the document. 5. Try dragging a few instances of the Circle symbol onto the Stage. You now have multiple instances of the Circle symbol. You’re about to make a change to the master version in the Library, and you see that change in each instance on the Stage. 6. From the Library panel, double-click the picture of your Circle symbol or select Edit from the Library’s menu, as shown in Figure 4.2. It might ap- pear that nothing has happened, but now you’re inside the Circle symbol where you can edit its contents. The best indication is the Edit Bar, cov- ered in Hour 2, “Drawing and Painting Original Art in Flash” (also see Figure 4.3). In addition, you should see only one copy of your circle, the original, in the center of the Stage. The Stage appears to have no bor- ders. These clues tell you that you are currently inside the master ver- sion of the Circle symbol about to edit it. 7. Now we get out of Edit mode for the master version and reenter another way. Click Scene 1 in the Edit Bar. You return to the main scene with multiple instances of the Circle symbol visible. Enter the master version of the symbol by double-clicking one of the instances of it. You should see the Edit Bar and all the other instances dim slightly. This is similar to how you can edit the contents of a grouped shape. In this case, you’re doing what’s called Edit in Place. This is where you can edit the Circle symbol. 8. Take a “chunk” out of the master graphic of the Circle by using the mar- quee technique with the Selection tool (see Figure 4.4). If the Circle is a Drawing Object, then be sure to double-click it first.
  12. 92 HOUR 4: Staying Organized with the Library and Layers ▼ TRY IT YOURSELF Create a Symbol by Converting Selected Objects FIGURE 4.2 The Library’s options menu in- cludes several choices, including Edit. FIGURE 4.3 Edit Bar Center of symbol You can tell you’re editing the contents of a symbol when you look at the Edit Bar. 9. Go back to the main scene by clicking Scene 1 in the Edit Bar. Now all instances of the Circle symbol have the same chunk taken out of them! Any new instances of the symbol you drag from the Library will have the same effect.
  13. The Concept of the Library 93 ▼ TRY IT YOURSELF Create a Symbol by Converting Selected Objects FIGURE 4.4 The edits you make to this symbol affects each instance. In the preceding task, you converted a selection into a symbol. This gener- ated an instance of the symbol you created on the Stage. The other way to create a symbol is to create it directly in the Library, as described in the fol- lowing task. Neither method is better than the other, and both give you the same result. In this task, you make a symbol by using the New Symbol feature. Follow TRY IT YOURSELF ▼ these steps: Create a New Symbol 1. Open a new file and choose Insert, New Symbol. from Scratch 2. You see the same Symbol Properties dialog box that you see when you use Convert to Symbol. In this case, name the new symbol Square and set the Type option to Movie Clip. This time when you click OK, you are presented with the editing screen for the master version of the Square symbol. Since we haven’t created it yet, the stage is blank, as shown in Figure 4.5. You should see the Edit Bar indicate you are editing the Square symbol. Think of it this way: Convert to Symbol puts your selec- tion in the Library; whereas New Symbol makes you name the symbol, and then takes you to the master version of that symbol, so you can draw something—effectively saying, “Okay, you want a new symbol? Draw it.” 3. Now that you’re in the master version of the Square symbol, you can draw the square. You probably want to draw it near the registration point of the symbol, indicated by the plus sign (shown in Figure 4.5). This
  14. 94 HOUR 4: Staying Organized with the Library and Layers ▼ TRY IT YOURSELF Create a New Symbol from Scratch FIGURE 4.5 Selecting New Symbol takes you into a blank symbol, so you can draw its contents. becomes the reference point whenever you view or change the in- stance’s location onscreen. But how do you get the square you draw in the center? You might have discovered the Paste in Place command in the Edit menu (or Ctrl+Shift+V). It enables you to paste anything to the same location from where you copied it. The Paste in Center command is useful here. Select your drawn square, click Edit, Cut, and then im- mediately Edit, Paste in Center. Presto! It’s centered. You could also use the Info panel to set the shape’s transformation point to 0,0 or use the Align Panel’s To Stage option, and then click both Align Horizontal Center and Align Vertical Center. 4. When you’re done creating the Square symbol, go back to the main scene by clicking Scene 1 in the Edit Bar. Where’s the square? Well, New Symbol creates a symbol and keeps it safe in the Library panel, where you can find it. Locate the new Square symbol in the Library, and then drag a few instances of the Square symbol onto the Stage. How Symbols Help You Let’s go over the two fundamental advantages of storing symbols in the Li- brary: reducing the movie’s file size and minimizing your work.
  15. The Concept of the Library 95 Reducing File Size Believe it or not, if you have one symbol in your Library and 100 instances of that symbol on the Stage, your file is barely larger than if you have only one instance. Here’s how it works: The graphic, movie clip, or button in the master symbol contributes to the file size. Therefore, if the graphic is 1KB, the master symbol adds 1KB; if the master symbol is 100KB, it adds 100KB. The size depends on what’s in that symbol. No matter how many times a symbol is used, it’s only stored once. Even as you drag many instances onto the Stage, the symbol is still stored only once. A tiny bit of data is saved in- side Flash that specifies how each instance is different from the others, (for example, their positions) so each instance does add a small amount of data to the file size. However, it’s such a tiny bit of information that it’s almost not worth mentioning. Imagine what would happen if it didn’t work this way; a 100KB graphic used 10 times would make a movie balloon to 1MB! In reality, though, 10 instances of a 100KB symbol might make your file grow to, say, 101K, if even that much. Using symbols is also powerful because each instance can differ from the others. So far, you’ve used symbols to display identical replicas of an origi- nal. The only way each instance has varied has been in its onscreen posi- tion. However, the tiny bit of extra data telling Flash where each instance is positioned onscreen can also contain information about how each instance is scaled or rotated differently. This way, each instance can look different. You learn more about this in the section, “How Each Instance Behaves Dif- ferently,” but for now, realize if you have three instances on the Stage and you have each one scaled to a different size, you haven’t added to the file size in any significant amount. Minimizing Work In addition to reducing file size, the Library can reduce the amount of work you do. For example, say you have a block of text (maybe a title) that’s used in several places within a movie. If you first put the text in a symbol in the Library, each time you need that text onscreen, you can drag an instance from the Library. Later, if you want to change the text, you can edit the master version in the Library and see the change in every instance. This ad- vantage requires only that you invest a little bit of time and planning.
  16. 96 HOUR 4: Staying Organized with the Library and Layers Using the Library Although you’ve already used the Library to do several tasks, we haven’t taken time to really explore all the details of the Library. Let’s do that now so you can to take full advantage of the Library’s offerings. Getting Your Bearings Hour 1, “Basics,” discusses the importance of knowing where you are at all times. In the Library, this point is especially important. Using the Library can be very confusing if you don’t pay attention to interface elements that help keep track of what you’re editing. Before you resize, move, or in any other way edit a graphic, take a second to figure out whether you are changing an instance or the master. Here are a few interface elements to help you get your bearings in the Li- brary: . Three things: the Edit Bar, the Edit Bar, and the Edit Bar. The Edit Bar is the most important indicator and one you should pay attention to at all times. . Anytime you’re inside a Library symbol, you see a plus sign, usually in the center, that indicates the registration point of the symbol. You don’t see the plus sign when you’re editing the contents of a regular scene. . You use the registration point when controlling an instance’s exact lo- cation. If a symbol is positioned at 0x and 0y, (the upper left of the stage) that registration point coincides with 0x,0y. In addition, you can use ActionScript to rotate or scale an instance, and Flash uses the registration point as the axis of rotation or center from which it grows. It’s confusing because, when you use the Transform tool to ro- Edit Symbols tate or scale an instance, Flash uses the Transformation point. By de- fault, the Transformation point is the visual center. The Transformation point appears as a solid white circle when you use the Free Transformation tool to select an instance onstage. The main thing to remember is you can always go inside and move the contents of a FIGURE 4.6 symbol relative to its registration point. The Edit Symbols menu gives you quick access to all the symbols in a . In addition to seeing the plus sign while editing a symbol, you never file. see edges to the Stage because there isn’t a Stage when you’re inside a symbol editing it. When you drag instances onto the Stage, you are placing them within the Stage borders when you want them to be visible
  17. Using the Library 97 to users. Symbols don’t have a Stage—the point of reference of a sym- NOTE bol is its center or registration point. Transformation Point Versus Registration Point . You can access the contents of a master symbol in several ways: It’s important to understand the dif- . First, from the Library window, you can select the symbol, and then ference between transformation and registration. Transformation is the click Edit in the Library’s options menu. Alternatively, you can dou- point around which you can scale or ble-click the symbol. (Double-clicking the symbol name lets you re- rotate an object while authoring. name the symbol.) Registration is an arbitrary reference point inside a symbol. If you open . Second, you can simply double-click any instance onscreen, and the Info panel, you find the X and Y you are taken to the master symbol to edit. The difference in doing coordinates shown reflect either the Transformation point’s location or it this way as opposed to using the Library window is that while ed- the symbol’s registration point, de- iting, you see the rest of your onscreen contents dimmed out but in pending on which option you have position. You can also do this by right-clicking an instance and se- selected in the toggle button (in the lecting Edit in Place. middle of the Info panel). However, when you use ActionScript to move a . Third, you can access any symbol from the Edit Symbols menu. Re- symbol instance or you use the call the two buttons at the top right of the screen: The clapper but- Properties panel to view the coordi- nates, values always reflect the loca- ton is the Edit Scene button, and the circle-square-triangle button tion of the registration point. When (which looks like a graphic symbol’s icon) is the Edit Symbols but- you use Convert to Symbol to create ton (see Figure 4.6). The Edit Symbols menu provides a list of all the the symbol, you choose a registra- symbols in a movie. Also, the Edit Scene menu is an easy way to get tion point from nine logical posi- tions—including the center plus any back to a scene. of the four sides or four corners. This setting only affects where the objects you have selected appear within the new symbol you’re creat- Managing the Library by Using Names, ing. You can always go inside the Sorting, and Folders symbol and move its contents rela- tive to its registration. You see the The Library is a panel that you use all the time. As the number of symbols registration point as a plus (both in- in the Library grows, you want to develop ways to keep them organized. side the symbol and when it’s se- lected onstage). You can’t exactly This section looks at three techniques to help you keep your Library’s sym- edit the registration point; rather, you bols organized: naming, sorting, and using folders. can move the contents relative to the registration point. Because every symbol must have a name and because they are easy to re- Any object onstage has a transfor- name, naming symbols meaningfully makes sense. How to best name sym- mation point (shown as a white cir- cle when you select the object with bols is subjective, but some standard practices are worth following. First, the Free Transform tool). The trans- you should be clear and concise. If you have an image of a circle, you can formation point is always the visual call it Circle. There’s no need to be cryptic and call it Cir. Then again, a name center at the time the object is cre- ated or dragged from the Library. You such as Red Circle with No Line might be a bit too detailed. You should say can use the Free Transform tool to what you have to, but nothing more. Also, realize the Library can be sorted move the transformation point. In ad- dition, when you rotate or scale, the alphabetically by symbol name, so you can develop a naming strategy to object rotates or scales around that plan ahead. For example, if you have several symbols all being used in a transformation point. For example, particular part of a movie, you can begin each name with the same text pre- you could move the transformation point to the corner of a flower petal, fix—for example, game_name. Therefore, you might have symbols named and then rotate several petal in- stances to make a flower.
  18. 98 HOUR 4: Staying Organized with the Library and Layers game_background, game_piece, game_scorecard, and so on. You can even use a similar method when an entire team is working on the same file. You can have each person precede symbol names with his initials so figuring out which symbols were created by which team member is easy. As mentioned earlier in this section, the Library automatically sorts sym- bols alphabetically by name. If you widen the Library window, you can ex- plore additional sorting options. You can resize the window by dragging a corner of it, as shown in Figure 4.7. You should take a look at Figure 4.7 to familiarize yourself with the Library window. You can sort by name, by type (such as buttons or movie clips), by use count (meaning how many in- stances you’ve dragged from the Library—although this won’t be accurate unless you select the option for Keep Use Counts Updated from the Li- brary’s menu), or by date modified. FIGURE 4.7 Options menu Several indicators Current library drop-down list Pin current library and tools are built into the Library. New library panel Preview window Sort order Column headings New symbol New folder Delete symbol Properties The Library window has several useful features: . The preview window gives you a thumbnail view and preview of any animation or audio. . Column headings do more than just explain what’s listed in the col- umn. If you click a column heading, the Library is sorted by the attrib- ute you select (Name, Kind, Use Count, Linkage, or Date Modified). . You can click the tiny arrow to toggle between ascending and de- scending alphabetical sorting.
  19. Using the Library 99 . Clicking New Symbol has the same effect as selecting Insert, New Symbol. . New Folder lets you create a new folder to hold several Library items. . Clicking Properties gives you access to the same Symbol Properties dialog box you see when you create a symbol. . The Pin Current Library option stops Flash’s default behavior of al- ways reflecting the Library for the currently active file. By pinning the Library, you can easily drag items from one file’s library to another file’s (because each file has its own single library). . The Library’s drop-down list gives you a quick way to edit another file’s library without activating that file. . The New Library Panel button lets you arrange library windows. For example, you might want to copy items from one library to another, or you might be getting tired of jumping between two files’ libraries using the list box. . The Options menu provides all the available options. Don’t forget about it! Finally, you can organize your Library by using folders. This is almost iden- tical to using files and folders on your computer’s hard drive, except that in the Library you have symbols and folders. Creating a folder is as simple as selecting New Folder in the Library’s options menu or clicking the New Folder button at the bottom of the Library panel. You can name the folder immediately after you create it, or you can name it later. Naming a folder is the same as renaming symbols— double-click the name or select Rename from the options menu. Organizing folders is pretty intuitive. You can put symbols inside folders by dragging a symbol’s icon, which appears to the left of its name, on top of the folder. You can open a folder to reveal its con- tents by double-clicking the folder’s icon. You can even put folders inside folders. Organizing the Library isn’t difficult to figure out. If you know how to re- name Library items, sort, and use folders, you are well on your way to hav- ing an organized Library.
  20. 100 HOUR 4: Staying Organized with the Library and Layers Using Symbols from the Library The ability to drag a symbol from the Library to create as many instances as you want is powerful. For example, imagine you create one symbol of a cloud. You could then create many instances of the cloud symbol to make a cloudy sky—but you could do much more than that. Each instance on the Stage could be different from the next. One could be large, and another one could be stretched out and darkened. In the upcoming task, for example, you see how multiple instances of one symbol can vary in size, scale, and rotation. Later this hour in the section, “Nesting Instances of Symbols In- side Symbols,” you make a symbol that contains instances of another sym- bol. Such nesting means not only can you have many instances on the Stage, but you can also recycle symbols to create other symbols. Placing Instances of Symbols on the Stage This discussion might seem like repeated material, but the concept and process are very specific. One master symbol in the Library can be dragged on the Stage as an instance. Let’s review a couple of points. If you copy and paste an instance that is already on the Stage, you are simply creating another instance. Not only is this okay, but it’s sometimes easier to the alter- native of dragging an instance from the Library because all the properties of the instance being copied are in the new instance. Remember the copy is just another instance. Modifying Instances of Symbols By dragging two instances of the same symbol onto the Stage, you create two instances with different properties because they vary in position. In other words, each instance is in a different location on the Stage. Each in- stance can be made different in other ways, too. For example, you can transform the scale of any instance on the Stage—without adding to the file size in any significant way. You can rotate each instance separately as well. The following task explores how to vary the properties of separate in- stances in regard to their position, scale, and rotation.
Đồng bộ tài khoản