Flash - Menu lạ .Menu Lạ 1. Tạo 1 file có thông số như hình 1 Hình 1 2. Chọn công

Chia sẻ: Thanh Cong | Ngày: | Loại File: PDF | Số trang:17

0
53
lượt xem
6
download

Flash - Menu lạ .Menu Lạ 1. Tạo 1 file có thông số như hình 1 Hình 1 2. Chọn công

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Flash - Menu lạ Menu Lạ 1. Tạo 1 file có thông số như hình 1 Hình 1 2. Chọn công cụ Oval Tool, bỏ màu viền, nhấp vào tam giác nhỏ ở màu tô để làm hiện ra bảng màu rồi chọn màu như hình 2 Hình 2 3. Vẽ một hình tròn (nhấn thêm phím Shift khi vẽ) trên khung làm việc rồi nhấp chuột phải vào nó và chọn Convert to Symbol… Hình 3 4. Trong hộp thoại hiện ra chọn Movie Clip. Nhấp đúp vào Movie Clip mới tạo để vào bên trong nó. Nhấp chuột phải vào Frame 20 và...

Chủ đề:
Lưu

Nội dung Text: Flash - Menu lạ .Menu Lạ 1. Tạo 1 file có thông số như hình 1 Hình 1 2. Chọn công

  1. Flash - Menu lạ
  2. Menu Lạ 1. Tạo 1 file có thông số như hình 1 Hình 1 2. Chọn công cụ Oval Tool, bỏ màu viền, nhấp vào tam giác nhỏ ở màu tô để làm hiện ra bảng màu rồi chọn màu như hình 2 Hình 2 3. Vẽ một hình tròn (nhấn thêm phím Shift khi vẽ) trên khung làm việc rồi nhấp chuột phải vào nó và chọn Convert to Symbol…
  3. Hình 3 4. Trong hộp thoại hiện ra chọn Movie Clip. Nhấp đúp vào Movie Clip mới tạo để vào bên trong nó. Nhấp chuột phải vào Frame 20 và chọn Insert KeyFrame
  4. Hình 4 5. Tại Frame 20 này chỉnh màu của hình tròn thành đỏ như hình 5
  5. Hình 5 6. Nhấp vảo dòng chữ Scene 1 để quay ra khung làm việc chính
  6. Hình 6 7. Nhấp chọn hình tròn trên khung làm việc và nhấn Ctrl-C để Copy nó vào clipboard, để dành cho các bước sau này. 8. Nhấp chuột phải vào Frame 5 và chọn Insert KeyFrame Hình 7 9. Nhấp chuột phải vào Frame 20 và chọn Insert KeyFrame
  7. Hình 8 10. Nhấp chuột vào hình tròn trên khung làm việc để chọn nó. Chọn Modify > Transform > Flip Vertical
  8. Hình 9 11. Nhấp chuột phải vào giữa Frame 5 và Frame 20 rồi chọn Create Motion Tween
  9. Hình 10 12. Nhấp chuột phải vào Frame 21 và chọn Insert KeyFrame, sau đó nhấn Ctrl-V để dán hình tròn mà ta đã để dành trên clipboard ở Bước 7
  10. Hình 11 13. Thực hiện tương tự cho Frame 22, 23. Chọn Window > Align và chọn 2 mục như hình 12 để có được 4 hình tròn cách đều nhau và thẳng hàng Hình 12
  11. 14. Khóa lớp hiện có lại, tạo một lớp mới, chọn công cụ Oval Tool, bỏ mảu viền, chọn màu tô là đỏ rồi vẽ một hình tròn phủ kín hình tròn màu xanh ở lớp bên dưới Hình 13 15. Nhấp chuột phải vào nó và chọn Convert to Symbol..
  12. Hình 14 16. Trong hộp thoại hiện ra chọn Button. Nhấp đúp vào hình tròn màu đỏ để vào bên trong nó. Dùng chuột rê chấm tròn ở vị trí Up qua vị trí Hit
  13. Hình 15 17. Nhấp chuột vào dòng chữ Scene 1 để quay ra khung làm việc chính, nếu thao tác đúng thì bạn sẽ được kết quả như hình 16
  14. Hình 16 18. Nhấp vào Button vừa mới tạo, chọn Window > Actions để mở bảng Actions-Button (bạn lưu ý là phải đúng Actions – Button nhé!) rồi nhập vào các dòng lệnh sau: on(rollOver) { gotoAndPlay(5); } on(release) { getURL("http://www.quantrimang.com"); }
  15. Hình 17 19. Khóa lớp hiện có lại, thêm một lớp mới, chọn Window > Actions để mở bảng Actions-Frame ra rồi nhập vào dòng lệnh sau: stop(); Hình 18 20. Nhấp chuột phải vào Frame 23 của lớp này và chọn Insert KeyFrame rồi mở bảng Actions-Frame ra, nhập vào dòng lệnh stop();
  16. Hình 19 21. Khóa lớp này lại, mở khóa lớp thứ nhất, nhấp chuột vào Frame 23, chọn công cụ Text Tool và nhập vào các dòng chữ home, news, relax, help cho từng hình tròn
  17. Hình 20 22. Thực hiện tương tự Bước 14 đến Bước 18 để có các nút nhấn cho các mục news, relax, help (trong phần code nhập vào bạn chỉ cần dùng on(release) vời các đường link do bạn tùy chọn) 23. Nhấn Enter + Ctrl để kiểm tra kết quả
Đồng bộ tài khoản