Ghép chữ tạo từ FLAX vào FLASH 5 phần 1

Chia sẻ: Lac Tran | Ngày: | Loại File: PDF | Số trang:13

0
349
lượt xem
64
download

Ghép chữ tạo từ FLAX vào FLASH 5 phần 1

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Bài tập này, chúng tôi hướng dẫn cách nhập (import) một file có đuôi .swf vào trong Flash. Sau đó kết hợp các file này lại để tạo riêng cho mình những hình ảnh động đẹp mắt. Hơn thế nữa, qua bài tập này, các bạn sẽ cập nhật thêm vào kho tàng đồ họa của mình một chương trình mới đó là Flax. Đây là chương trình tạo chữ động rất đặc sắc và có giao diện rất dễ dùng. Để ứng dụng cách ghép các file được tạo ra từ Flax sau đó đưa vào Flash dàn dựng,...

Chủ đề:
Lưu

Nội dung Text: Ghép chữ tạo từ FLAX vào FLASH 5 phần 1

  1. GHÉP CHỮ TẠO TỪ FLAX VÀO FLASH 5 Bài tập này, chúng tôi hướng dẫn cách nhập (import) một file có đuôi .swf vào trong Flash. Sau đó kết hợp các file này lại để tạo riêng cho mình những hình ảnh động đẹp mắt. Hơn thế nữa, qua bài tập này, các bạn sẽ cập nhật thêm vào kho tàng đồ họa của mình một chương trình mới đó là Flax. Đây là chương trình tạo chữ động rất đặc sắc và có giao diện rất dễ dùng. Để ứng dụng cách ghép các file được tạo ra từ Flax sau đó đưa vào Flash dàn dựng, chúng ta sẽ tiến hành tạo dòng chữ “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI” xoay theo hình vòng tròn và chữ STK động trong chương trình Flax. Sau đó sẽ cho vòng tròn chữ này quay quanh chữ STK bằng chương trình Macromedia Flash 5. Bắt đầu công việc, hãy đảm bảo rằng hai chương trình Flax và Flash đã được cài đặt vào hệ thống máy tính của bạn. Bây giờ, hãy khởi động chương trình Flax bằng cách nhấp chọn Start > Programs > start_flax
  2. Cửa sổ Welcome xuất hiện cho bạn hai lựa chọn là Order và OK. Nhấp OK để bỏ qua việc đăng ký mã trong Flax. Giao diện Flax xuất hiện, cho bạn 4 cửa sổ làm việc: Cửa sổ Flax gồm hai trình đơn chính là File và Help. Cửa sổ Movie Properties: Dùng để định dạng chiều rộng (Width), chiều cao (Height), số frame trong một giây (Fps) và màu nền (background) cho văn bản động mà bạn sẽ tạo ra. Cửa sổ Text Properties: Dùng để nhập dòng văn bản (Text), định vị trí xuất hiện dòng văn bản (X,Y), chọn Font chữ, định cỡ chữ, khoảng cách giữa các ký tự và màu chữ.
  3. Cửa sổ Rotate Fx Properties: Cung cấp cho bạn 22 hiệu ứng và các hiệu chỉnh đi kèm với những hiệu ứng này. Chú ý rằng tên của cửa sổ này sẽ thay đổi tùy vào việc chọn tên hiệu ứng. Bây giờ, chúng ta sẽ tạo dòng chữ “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI” có hình vòng tròn và chuyển động theo chiều kim đồng hồ. Đầu tiên bạn hãy định chiều rộng và chiều cao vùng hiển thị dòng chữ này với Width: 300, Height: 300 và màu nền là màu trắng (#FFFFFF). Tiếp theo, trên cửa sổ Text Properties, tại ô Text bạn hãy nhấp vào dòng chữ “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI”. Sau đó chọn các thông số còn lại như sau: X: 9, Y: 120, Font: VNI-Swiss-Extreme, cỡ chữ là 30 (nhập từ bàn phím) và màu chữ là màu xanh dương (#0000FF). Lưu ý: Trong cửa sổ này, tại mục Font, có thể bạn sẽ không tìm thấy Font chữ VNI-Swiss- Extreme (hoặc nhiều Font khác). Vì vậy, để có được Font chữ như mong muốn bạn hãy thực hiện một số thao tác sau: Tại cửa sổ Flax, nhấp chọn trình đơn File sau đó chọn Convert TTF Font (hoặc nhấn tổ hợp phím Ctrl + F).
  4. Cửa sổ Font xuất hiện, hãy tìm và nhấp chọn Font VNI-Swiss-Extreme (như hình minh họa). Xong nhấp OK. Font chữ này sẽ xuất hiện trong mục Font của cửa sổ Text Properties. Tiếp tục, bạn nhấp vào mũi tên hướng xuống trong cửa sổ Rotate Fx Properties. Một danh xuất hiện gồm nhiều hiệu ứng, nhấp chọn hiệu ứng Circle. Lưu ý rằng khi chọn hiệu ứng xong, tên của cửa sổ này đã đổi thành Circle Fx Properties.
  5. Trong cửa sổ này hãy nhập các thông số sau: Hiệu chỉnh mục Radius (đường kính đường tròn) là 280 bằng cách kéo thanh trượt hoặc nhấp số 280 vào ô cạnh thanh trượt. Tại mục Speed (tốc độ quay của vòng tròn chữ) bạn nhập 2 và cuối cùng trong mục Direction bạn chọn hướng quay của vòng tròn theo chiều kim đồng hồ. Lúc này, bạn sẽ thấy trong cửa sổ Flax dòng chữ “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI” xuất hiện như sau: Cuối cùng, để lưu giữ lại kết quả trên, nhấp vào trình đơn File chọn Save FX As… Cửa sổ Save As: xuất hiện. Trong mục Save in hãy chọn thư mục để lưu file. Trong mục File name, nhập tên của file này là vong tron chu. Sau đó, nhấn nút Save để hoàn tất.
  6. Tuy nhiên, file này sẽ chỉ được mở trong chương trình Flax, nghĩa là bạn không thể nhập (import) nó vào trong chương trình Flash. Để giải quyết, hãy lưu file này với đuôi .swf như sau: Trong cửa sổ Flax, nhấp vào trình đơn File sau đó nhấp chọn mục Export as SWF… (hoặc nhấn tổ hợp phím Ctrl + E). Cửa sổ Save As: xuất hiện, chọn thư mục để lưu file tại mục Save in, sau đó nhập tên file là vong tron chu swf vào mục File name. (Lưu ý: Tại mục Save as type bây giờ hiện dòng chữ Shockwave Flash chứ không phải là Flax Files như trong lần lưu trữ trước đó). Chọn xong, nhấp nút Save.
  7. Việc tạo vòng tròn chữ quay theo chiều kim đồng hồ đã hoàn tất. Bây giờ, chúng ta sẽ tiến hành tạo chữ STK động (chỉ thay đổi màu chữ). Chữ này sẽ được đặt vào giữa vòng tròn chữ được tạo trước đó (điều này sẽ được hướng dẫn trong các bước tiếp theo). Đầu tiên, bạn hãy định vùng hiển thị cho chữ STK với Width: 170, Height: 65, Fps: 25 và màu nền (background) là màu trắng (#FFFFFF). Tiếp theo, hãy nhập chữ STK vào hộp thoại Text, các thông số còn lại thiết đặt như sau: X: 3, Y: -50, Font: VNI-Swiss-Extreme, cỡ chữ: 72, Spacing: 0, màu chữ là màu Blue (#0000FF). (Nhấp vào mũi tên lên, xuống để thay đổi các thông số X, Y, …). Bây giờ, để cho chữ STK đổi màu hãy nhấp vào mũi tên hướng xuống để tìm và chọn hiệu ứng Rainbow (cầu vòng) đồng thời thiết đặt các thông số cho hiệu ứng này như sau: Speed: 3; Colors: Đỏ (#FF0000), Vàng (#FFFF00), Xanh lá (#00FF00), Xanh dương (#0000FF); Direction: Chọn ô thứ 4 từ trái qua. Tuy nhiên, với mục Color bạn có thể chọn các màu tùy thích bằng cách nhấp chọn mũi tên hướng xuống tại các ô màu – bảng màu sẽ hiển thị (như hình minh họa) để bạn chọn, và ở mục Direction bạn cũng có thể chọn những hướng chuyển màu khác nhau bằng cách nhấp chọn. Bây giờ, bạn sẽ thấy chữ STK hiển thị với những thay đổi về màu sắc trong cửa sổ Flax như sau:
  8. Cuối cùng, bạn hãy lưu giữ file này bằng cách nhấp chọn File > Save FX As… Cửa sổ Save As xuất hiện, chọn thư mục để lưu trữ file trong mục Save in (tốt nhất là chọn thư mục đã lưu file vong tron chu trước đó), sau đó tại mục File name nhập chữ logo stk và nhấn Save để lưu lại. Tuy nhiên, tương tự như file vong tron chu trước đó, bạn phải lưu lại file này với đuôi .swf (để có thể nhập vào Flash) bằng cách chọn File > Export as SWF… Cửa sổ Save As xuất hiện. Trong cửa sổ này, bạn chọn thư mục để lưu trữ file trong mục Save in (tốt nhất là chọn thư mục đã lưu file vong tron chu swf trước đó), sau đó tại mục File name nhập chữ logo stk swf và nhấn Save để lưu lại.
  9. Như vậy là bạn đã hoàn tất việc tạo hai text động là “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI” và STK với chương trình Flax. Tiếp theo, chúng ta sẽ ghép hai text này vào cùng một file để tạo một chuyển động hỗn hợp giữa vòng tròn chữ quay theo chiều kim đồng hồ và chữ STK đổi màu bên trong nó. Để tiếp tục, hãy khởi động chương trình Flash bằng cách chọn Start > Programs > Macromedia Flash 5 > Flash 5. Cửa sổ Flash xuất hiện. Đầu tiên, hãy định vùng làm việc của file Flash này bằng cách nhấp chọn Modify > Movie trên thanh trình đơn hoặc nhấn tổ hợp Ctrl+M.
  10. Cửa sổ Movie Properties xuất hiện, hãy thiết đặt các thông số sau: Frame Rate: 12 fps; Dimensions với Width: 300, Height: 300; Background Color: màu trắng (bạn có thể chọn màu khác bằng cách nhấp chọn mũi tên hướng xuống); Ruler Units: Pixels GHÉP CHỮ TẠO TỪ FLAX VÀO FLASH 5 Sau khi đã thiết đặt xong, nhấp OK. Tiếp tục, tiến hành nhập hai text đã tạo trong Flax vào. Tuy nhiên, bạn không nên nhập trực tiếp hai text này trên Scene 1 mà nên đưa chúng vào từng Symbol để việc thao tác được dễ dàng hơn. Bây giờ chúng ta sẽ tạo một Symbol mới bằng cách nhấp chọn Insert > New Symbol trên thanh trình đơn hoặc nhấn tổ hợp phím Ctrl+F8. Cửa sổ Symbol Properties xuất hiện. Tại mục Name, hãy nhập tên của Symbol này là vong tron chu. Do text được nhập vào là text động với đuôi .swf nên tại mục Behavior hãy nhấp chọn nút (button) trước chữ Movie Clip. Xong chọn OK.
  11. Lúc này, trang làm việc hiện hành của bạn không phải là ở Scene 1 mà là Movie Clip vong tron chu. Một lần nữa hãy đảm bảo rằng cửa sổ làm việc hiện hành của bạn là Movie Clip vong tron chu. Bây giờ, bạn sẽ tiến hành nhập file vong tron chu swf vào Clip này bằng cách nhấp chọn File > Import… trên thanh trình đơn hoặc nhấn tổ hợp phím Ctrl+R. Cửa sổ Import xuất hiện.
  12. Trong cửa sổ này, tại mục Look in, nhấp vào mũi tên hướng xuống và chọn thư mục chứa các file đã lưu được thực hiện từ chương trình Flax trước đó. Tiếp theo, nhấp chọn file vong tron chu swf. Khi đó, tên file này sẽ được hiển thị trong mục File name. Cuối cùng hãy nhấp Open để hoàn tất công việc. Lúc này, bạn sẽ thấy vòng tròn chữ “TỦ SÁCH STK SƯU TẦM THÔNG TIN KỸ THUẬT MỚI” xuất hiện trong Clip vong tron chu.
  13.  
Đồng bộ tài khoản