Giáo trình Access11

Chia sẻ: Dương Duy Long | Ngày: | Loại File: DOC | Số trang:36

0
99
lượt xem
46
download

Giáo trình Access11

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Access là một hệ quản trị cơ sở dữ liệu (Data Base Management System – viết tắt là DBMS) dùng để tạo, xử lý các cơ sở dữ liệu. Cho phép quản lý các số liệu một cách thống nhất có tổ chức, liên kết các số liệu rời rạc lại với nhau và giúp người sử dụng có thể thiết kế các chương trình một cách tự động, tránh những thao tác thủ công trong quá trình tính toán xử lý.

Chủ đề:
Lưu

Nội dung Text: Giáo trình Access11

  1. Bài 1 Giới thiệu chung về access Khái niệm chung về Access Access là một hệ quản trị cơ sở dữ liệu ( Data Base Management System – viết tắt là DBMS) dùng để tạo, xử lý các cơ sở dữ liệu. Cho phép qu ản lý các s ố li ệu m ột cách thống nhất có tổ chức, liên kết các số liệu rời rạc lại với nhau và giúp ng ười s ử dụng có thể thiết kế các chương trình một cách tự động, tránh nh ững thao tác th ủ công trong quá trình tính toán xử lý. Cách cài đặt Access. 1. Microsoft Access là một bộ phận của Microsoft Office. Nên khi cài đặt Microsoft Office nếu không có gì thay đổi thì phần Access cũng được mặc định là được cài đặt. Trong trường hợp khi cài đặt Microsoft Office không có Access thì có thể bổ sung thêm từ trình Setup của Microsoft Office với lựa chọn Add/Move và sau đó đánh dấu vào mục Access để chọn thêm phần mềm này. Khởi động Access. 2. Có nhiều cách khởi động Microsoft Access. Nhưng ta có thể khởi động theo hai cách sau đây: Cách 1: Tại màn hình nền của Windows. Nhấp Start  Programs  Microsoft Access. Cách 2: Chọn biểu tượng Microsoft Access trên màn hình Windows Sau khi khởi động Access thì xuất hiện môi trường làm việc của Access. Giáo trình access cơ bản 1 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  2. 3. Cửa sổ Microsoft Access. Tại hộp thoại Microsoft Access của cửa sổ xuất hiện ba lựa chọn: Chọn Blank Database: Nếu tự tạo mới một file cơ sở dữ liệu . Chọn Database Wizards: Nếu muốn tạo 1 file cơ sở dữ liệu theo mẫu file cơ sở dữ liệu đã tạo sẵn trong Access. Chọn Open an Existing Database: Nếu muốn mở một cơ sở dữ liệu đã có. Hình – Hộp thoại đầu tiên khi khởi động Access 4. Cơ sở dữ liệu trong Access. Dữ liệu là các thông tin mà ta muốn lưu trữ và s ử d ụng l ại. CSDL là t ập h ợp có tổ chức những dữ liệu liên quan đến một chủ đề hay một mục đích nào đó. Mỗi CSDL của Access được lưu trữ trong 1 file mà tên file có đuôi mặc nhiên là .MDB. Một cơ sở dữ liệu của Access có 6 thành phần(Object): Giáo trình access cơ bản 2 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  3. Table - Bảng dữ liệu a. Là thành phần quan trọng, cơ bản nhất của CSDL, ch ứa các d ữ li ệu c ần thi ết c ủa CSDL. b. Query - Bảng truy vấn( bảng vấn tin) Dùng để xử lý, tính toán các dữ liệu ở Table. c. Form - Mẫu biểu Là công cụ tạo ra các mẫu trình bày dữ liệu theo các dạng mà người sử dụng mong muốn để có thể nhập hay sửa một cách dễ dàng, giống các m ẫu phi ếu thông thường. d. Report - Mẫu báo cáo Là công cụ tạo các mẫu và in các báo cáo. e. Macro - Lệnh vĩ mô Là một tập hợp các lệnh được chọn, sắp xếp hợp lý cho việc tự động hoá các thao tác. f. Module - Đơn thể chương trình Là phương tiện lập trình trong Access với ngôn ngữ lập trình Access Basic (Visual Basic for Access). 5. Tạo - Mở - Đóng một cơ sở dữ liệu a. Tạo một cơ sở dữ liệu mới Chọn menu File/ New Database để mở hộp thoại New. Chọn Database: Nếu muốn tạo một File CSDL theo mẫu đã có sẵn trong Access. Chọn General: Nếu muốn tự tạo một File CSDL. Giáo trình access cơ bản 3 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  4. Hình – Cửa sổ tạo mới file CSDL b. Mở một cơ sở dữ liệu Chọn menu File/Open. Chọn đường dẫn vào File CSDL  Open c. Đóng cơ sở dữ liệu Menu File/ Close hoặc đóng cửa sổ cơ sở dữ liệu Chú ý: Khi chấm dứt làm việc với cơ sở dữ liệu, nên nhớ phải đóng cơ sở dữ li ệu, nếu không đóng có thể dẫn đến tình trạng bị hỏng CSDL. Giáo trình access cơ bản 4 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  5. Bài 2 Xây dựng một cơ sở dữ liệu 1. Mở tệp CSDL mới. Sau khi khởi động Access ta chọn Blank Database thì xuất hiện cửa sổ “ File New Database”. Tại cửa sổ này ta cần xác định các tham s ố: - Đặt tên CSDL mà bạn muốn tạo tại ô File Name. - Lưu tệp CSDL bạn tạo tại ô Save In. - Kích vào nút Create để ghi lại các nội dung mà ta đã chọn. Chú ý: Tên CSDL mà bạn đặt không dài quá 64 ký tự và không đ ược b ắt đ ầu b ằng dấu cách, dấu chấm, dấu phẩy, dấu chấm ph ẩy, dấu ngo ặc, d ấu nháy, d ấu ch ấm than... Khi đang làm việc với một CSDL bạn có thể chuyển sang tạo một CSDL m ới khác bằng cách: Giáo trình access cơ bản 5 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  6. Chọn File/New Database/ General/ Bank Database/ Gõ tên CSDL vào ô File Name/ Create. 2. Tạo cấu trúc bảng dữ liệu mới. a. Thiết kế một bảng CSDL. Trong cửa sổ Database. Chọn đối tượng Table để tạo ra các cơ sở dữ liệu. Để tạo một bảng cơ sở dữ liệu ta phải xác định: Tạo cấu trúc dữ liệu. - Nhập dữ liệu cho bảng. - Cách tạo bảng cơ sở dữ liệu: Tại cửa sổ Database, Chọn Table/New /Design View/ OK. Xuất hiện cửa sổ thiết kế cấu trúc dữ liệu của bảng. Giáo trình access cơ bản 6 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  7. Trong cửa sổ này có hai vùng khai báo: Vùng chính gồm 3 thành phần: : Tên trường CSDL. Field Name  : Kiểu dữ liệu. Có các dạng dữ liệu sau: Data Type  : Chuỗi ký tự, dài tối đa 255 ký tự. + Text : Văn bản nhiều dòng, tối đa 64 000 ký tự. + Memo : Kiểu số + Number : Kiểu ngày giờ. + Date/Timer : Kiểu tiền tệ. + Currency + Auto Number : Acceess tự động gán giá trị số phân biệt nhau vào File này : Giá trị logic đúng/ sai. + Yes/ No : Đối tượng nhúng và liên kết (Hình ảnh). + OLE Object : Kiểu siêu liên kết. + Hyperlink +Lookup Wizard: Hộp liệt kê để chọn 1 giá trị trong danh sách các giá trị đã có theo trợ giúp của Wizard. Description: Mô tả.  Vùng Field Properties gồm hai thành phần: General: Gồm các nội dung sau:  : Kích thước trường. Field Size ♦ : Định dạng dữ liệu. Format ♦ : Số số lẻ. Decimal Place ♦ : Mặt nạ nhập liệu. Input Mask ♦ : Phụ đề của trường (Đây là tiêu đề của cột). Caption ♦ : Giá trị mặc định. Default Value ♦ Giáo trình access cơ bản 7 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  8. : Quy tắc nhập liệu. Validation Rule ♦ : Văn bản hướng dẫn quy tắc nhập liệu. Validation Text ♦ : Yêu cầu tính duy nhất. Required ♦ Allow Zero Length: Cho phép độ dài = 0, cho phép dữ liệu rỗng ♦ : Chỉ số hoá (Sắp xếp theo tệp chỉ số, ngầm định sắp Indexed ♦ xếp theo thứ tự tăng dần). Lookup gồm các nội dung sau:  Display Control: Điều khiển hiển thị, nhưng phụ thuộc vào nội dung ta ♦ chọn trong hộp này như “Text box (Hộp văn bản)”, “List Box (H ộp li ệt kê)”, “Combo Box (Hộp chọn)” mà có thêm các trường: : Kiểu nguồn dữ liệu cho dòng. Row Source Type ♦ : Nguồn dữ liệu cho dòng. Row Source ♦ : Cột dữ liệu liên kết. Bound Column ♦ : Số các cột dữ liệu..... Column Count ♦ : Có sử dụng không (Yes/No) tên trường hay dữ Column Heads ♦ liệu dòng đầu tiên trong danh sách làm tiêu đề cho cột trong danh sách. : Độ rộng của các cột trong danh sách. Column Widths ♦ : Số dòng hiển thị trong danh sách. List Row ♦ : Tổng độ rộng của cột trình bày trong danh sách. List Width ♦ Limit to list : Yes: Chỉ được nhập dữ liệu cho trường là 1 giá trị trong danh ♦ sách. : No : Có thể nhập 1 giá trị ngoài danh sách cho trường. b. Khoá chính. Mỗi Table thường có mục khoá chính. Mục khoá chính của 1 Table có thể là một hay kết hợp nhiều trường để Access nhận diện một cách duy nhất mỗi bản ghi trong bảng (trên vùng được chọn làm khoá chính không được có 2 bản ghi có giá trị gi ống nhau). Cách tạo khoá chính: Giáo trình access cơ bản 8 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  9. - Đánh dấu trường được chọn làm khoá chính. Chọn menu Edit/ Primary hoặc chọn biểu tượng chìa khoá trên thanh công cụ. - Cách xoá khoá chính: Cách 1: Chọn lại biểu tượng chìa khoá trên thanh công cụ. Cách 2: - Chọn menu View/ Indexes. - Chọn dòng chứa khoá chính, ấn Delete. c. Chi tiết một số thuộc tính File Thuộc tính Field Size:  Đối với kiểu dữ liệu Text: Quy định chiều dài tối đa của dữ liệu. Cho  phép bạn khai báo tối đa chiều dài từ 1 đến 255 ký tự. Đối với kiểu Number: Quy định miền giá trị của dữ liệu  Giá trị Miền giá trị Số số Số lẻ Byte 0 đến 255 Byte 0 1 -32768 đến 32767 Integer 0 2 -214783648 đến 214783647 Long Integer 0 4 -3.4 x 1038 đến 3.4 x 1038 Single 7 4 -1.79 x 10 308 đến 1.79 x 10308 Double 15 8 Thuộc tính Format:  Đối với dạng Number: Giả sử bạn có giá trị 3456.789 thì : - Chọn Dạng hiển thị Mô tả General Number 3456.789 Có ký hiệu tiền tệ ở đầu và Currency $3,456.79 có dấu cách hàng ngàn. Số số lẻ cố định Fixed 3456.79 Có dấu cách hàng ngàn Standard 3,456.79 Tính theo phần trăm Percent 345678.90% Định dạng số mũ Scientific 3.46E +03 Giáo trình access cơ bản 9 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  10. Đối với dạng Date/Time - Chọn Dạng hiển thị General Date 19/6/02 Long Date Sunday, June 19, 2002 Medium Date 19- June- 02 Sort Date 19/06/02 Long Time 5:34:23PM Medium Time 5:34 PM Short Time 17:34  Thuộc tính Indexed: : Không sắp xếp. No : Có sắp xếp và các giá trị trên Field có thể trùng nhau. Yes[Duplicate Ok] : Có sắp xếp và các giá trị trên Field không trùng nhau Yes[No Duplicate] Thuộc tính Input Mask:  0 Vị trí dành cho một số từ 0-9 (Bắt buộc nhập) 9 Vị trí dành cho một số từ 0-9 (Không bắt buộc nhập) # Vị trí dành cho một số từ 0-9, dấu +, -, trống L Vị trí dành cho một ký tự (Bắt buộc nhập) ? Vị trí dành cho một ký tự chữ hoặc số (Không bắt buộc nhập) A Vị trí dành cho một ký tự chữ hoặc số (Bắt buộc nhập) a Vị trí dành cho một ký tự chữ hoặc số (Không bắt buộc nhập) & Vị trí dành cho một ký tự bất kỳ (Bắt buộc nhập) C Vị trí dành cho một kýtự (Không bắt buộc nhập) . ; : , / Các dấu . , : ; / < Các ký tự bên phải ký hiệu phải biến thành chữ thường > Các ký tự bên phải ký hiệu phải biến thành chữ hoa \ Quy định ký tự theo sau dấu \ là dữ liệu d. Các thao tác xử lý thiết kế Table Giáo trình access cơ bản 10 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  11. Chèn Field vào giữa các Field hiện có  Xoá Field  Thay đổi vị trí Field.  3. Sao chép, Xoá, Đổi tên table a. Sao chép Bước 1: Đánh dấu tên Table Bước 2: Chọn Menu Edit, Copy hoặc nháy phải chuột chọn Copy. Bước 3: Chọn Edit, Paste sẽ hiện 1 hộp thoại và chọn lệnh Table Name : Khai báo tên Table đích.  : Chọn dạng sao chép. Paste Option  : Chỉ sao chép cấu trúc Table. Structure Only  Structure and Data : Sao chép cấu trúc và dữ liệu.  Append Data to Existing Table: Thêm dữ liệu vào cuối bảng đích.  Bước 4: Chọn OK. b. Đổi tên. - Chọn bảng cần đổi tên. Chọn menu Edit / Rename hoặc nháy phải chuột chọn Rename. - - Gõ tên mới. Enter. - c. Xoá. - Chọn bảng cần xoá. Chọn Edit / Delete hoặc nháy phải chuột chọn Delete hoặc ấn phím Delete. - Giáo trình access cơ bản 11 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  12. 4. Khai báo quan hệ giữa các Table a. Các loại quan hệ Quan hệ một - một  Quan hệ một – nhiều  Quan hệ nhiều – nhiều  b. Khai báo quan hệ giữa các Table Chọn menu Tool / Relationship  Chọn các bảng tham gia đặt quan hệ  Đặt quan hệ giữa hai bảng như sau:  - Kích chuột tại trường quan hệ của bảng thứ nhất (Bảng chính) và kéo đ ến trường quan hệ của bảng thứ hai (Bảng quan hệ) khi đó xuất hiện hộp hội thoại Relationships. + Enfore Referential Integrity: Nếu muốn ép buộc tính toàn vẹn của dữ liệu thì dây quan hệ sẽ có biểu diễn 2 đầu mút. + Cascade Update Related Fields: Khi sửa giá trị trên trường quan hệ của bảng chính thì dữ liệu tương ứng trên trường quan hệ của bảng quan hệ sẽ tự động thay đổi theo. + Cascade Delete Related Fields : Khi xoá một bản ghi của bảng chính thì các bản ghi tương ứng trong quan hệ sẽ tự động xoá theo. Relationship Type: Kiểu quan hệ. : Quan hệ một – một. + One to one : Quan hệ một – nhiều. + One to many c. Sửa/ Xoá mối quan hệ. - Sửa lại mối quan hệ : Nháy đúp tại dây quan hệ. Xoá mối quan hệ : Chỉ chuột vào dây quan hệ và ấn phím Delete. - Giáo trình access cơ bản 12 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  13. Bài 3 Query - truy vấn tin Khái niệm Query là công cụ khai thác và xử lý dữ liệu của Access. Nó có thể đáp ứng các nhu cầu tra cứu về dữ liệu của các bảng thuộc cơ sở dữ liệu. 1. Tạo mới một Query và xem kết quả a. Tạo mới một Query Bước 1: Trên cửa sổ Database. Chọn Queries/ New/ DesignView/OK. Bước 2: Xác định các Queries, Table hoặc cả hai tham gia truy vấn tại Show Table. Chọn Table :Xác định các bảng tham gia truy vấn. Chọn Quereis :Xác định các Query tham gia truy vấn. Chọn Both :Xác định cả 2 tham gia truy vấn. Chọn các Table/ Queries trên ShowTable: Add/Close. Nếu chọn nhiều bảng hoặc Queries cùng một lúc thì giữ Shift hoặc Ctrl và nhấp chọn. Bước 3: Xác định quan hệ giữa các Table/Queries (Nếu có nhiều bảng tham gia truy vấn) Bước 4: Xác định truy vấn tin tại phần dưới cửa sổ SelectQuery. Field: Xác định các trường trực tiếp tham gia truy vấn. Có hai cách: - Lấy từ bảng (Con chuột). - Nhấp đúp chuột tại Field cần lấy nội dung Table : Khi trường được lấy từ một bảng xuống dòng Field thì tại dòng Sort: Xác định chỉ tiêu sắp xếp: Ascending: Sắp xếp theo thứ tự tăng dần. ♦ Descending: Sắp xếp theo thứ tự giảm dần. ♦ Giáo trình access cơ bản 13 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  14. Not sortted: Không sắp xếp. ♦ Show: Xác định ẩn / hiện nội dung các trường. Criteria và Or : Đặt điều kiện sàng lọc dữ liệu Bước 5: Lưu Queries Chọn File/ Save/Đặt tên/OK Hoặc ấn phím CTRl+S b. Xem kết quả của Một Query: Tại cửa Database: Chọn Queries/ Chọn Queries cần mở/ Open. Design: Mở Query ở chế độ DesignView để hiệu chỉnh thiết kế. ♦ Open: Mở Query ở chế độ DatasheetView để hiển thị dữ liệu. ♦ 2. Tạo Simple QueryWizard Trên Database/ Query/ New/ SimpleQueryWizard/ Ok. Bước 1: Chọn trường tham gia truy vấn: Table/Queries: Chọn bảng chứa trường tham gia truy vấn ♦ AvailableField: Chọn trường tham gia truy vấn ♦ Bước 2: Lựa chọn việc hiển thị chi tiết kết quả hay thực hiện tổng kết dữ liệu. Chọn Summary: Nếu muốn thực hiện tổng kết số liệu. ♦ Chọn Detail: Nếu muốn hiển thị chi tiết toàn bộ giá trị các Field đã chọn. ♦ Nếu chọn Summary thì bước tiếp theo là chọn Summary Options để chọn chi tiết tổng kết. Sum: Tính tổng giá trị các Field. ♦ Avg: Tính giá trị trung bình các Field. ♦ Min: Tìm giá trị nhỏ nhất của Field. ♦ Max: Tìm giá trị lớn nhất của Field. ♦ Count: Đếm số bản ghi. ♦ Giáo trình access cơ bản 14 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  15. Sau chọn OK/ Next/ Chọn kiểu dữ liệu Data /Time (Nếu việc tổng kết dựa trên các Field có kiểu dữ liệu là Data/ Time) để báo thêm khoảng thời gian tổng kết theo nội dung sau: : Tổng kết theo ngày (Hiển thị theo dạng Long Date) Day :Tổng kết theo tháng. Month :Tổng kết theo năm. Year :Tổng kết theo quý (3 tháng). Quarter UniqueDate/Time:Tổng kết theo ngày, giờ. Chọn Next. Chú ý: Nếu Các Field mình chọn có kiểu Number thì mới thực hiện bước 2 còn không thì thực hiện luôn bước 3. Bước 3: Đặt tên Query cho dòng “What tilte do you want for your query” Chọn Finish. 3. Đặt điều kiện cho Query. Bước 1: Xác định Field làm điều kiện sàng lọc tại dòng field. Bước 2: Xác định ẩn hiện nội dung của Field làm điều kiện tại dòng Show. Bước 3: Đặt điều kiện tương ứng tại các dòng Criteria, Or… 4. Các phép toán: a. Phép toán số học: Ký Hiệu Nội Dung Cú Pháp Tên Phép cộng + A+B Phép trừ - A-B / A/B Phép chia ^ A^B Phép mũ Phép chia lấy phần Lấy số dư của A chia cho B Mod A Mod B dư Lấy phần thương nguyên \ A\B Phép Chia nguyên trong phép chia A cho B * A*B Phép nhân b.Các phép toán so sánh. Ký hiệu Kết quả ý nghĩa Giáo trình access cơ bản 15 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  16. Bằng = Các kết quả so Khác sánh là một biểu Nhỏ hơn < Lớn hơn > thức lôgic( cho kết Nhỏ hơn hoặc bằng = c. Các phép toán Logic: Dùng để xử lý các giá trị logic 1. Not: Phép toán phủ định A NOT A True False False True 2. And: Phép toán Và A B A AND B True True True True False False False True False False False False 3. OR: Phép toán hoặc. A B A OR B True True True True False True False True True False False False Thứ tự ưu tiên Phép toán: Not->And->Or. 4. Các toán tử: Between: Lấy giữa khoảng giá trị đầu And giá trị cuối. Ví dụ: Between 20 and 45. In: Lấy một trong các giá trị nào đó. Ví dụ: In (0,20,40,56). Like: Dùng để so sánh chuỗi dữ liệu với mẫu dữ liệu được chỉ sau Like. Các ký tự đại diện sử dụng trong mẫu dữ liệu: *: Đại diện cho nhiều ký tự. Giáo trình access cơ bản 16 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  17. ?: Đại diện cho một ký tự. #: Đại diện cho một chữ số. Dữ liệu dạng ngày giờ luôn đặt trong dấu #. Ví dụ: #03/05/1998#. Một số hàm cho ra: + Day : Ngày + Month : Tháng + Year : Năm : Thứ +Date : Tuần + Weekday Chú ý: Các kiểu ký tự phải đưa vào “ “. Giáo trình access cơ bản 17 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  18. Bài 4 Các loại Query khác 1. Find duplicates Query Wizard ý nghĩa: Tìm các bản ghi (Record) trùng lặp trên 1 số trường nào đó. Cách tạo: Bước 1: Chọn Queries/New/ Find duplicates Query Wizard/OK. Bước 2: Chọn bảng chứa dữ liệu trùng lặp cần tìm/ Next. Bước 3: Chọn những trường chứa giá trị trùng lặp cần tìm/ Next. Bước 4: Chọn cột hiện ở bảng kết quả/ Next. Bước 5: Đặt tên Query/Finish. 2. Find Unmatched Query Wizard. ý nghĩa: Tìm các bản ghi (Record) xuất hiện trong bảng này mà không xuất hiện trong bảng kia. Cách tạo: Bước 1: Chọn Queries/ New/ Find Unmatched Query Wizard/OK. Bước 2: Chọn bảng A/Next. Bước 3: Chọn bảng B/Next. Chú ý: Hai bảng A, B ở đây khác nhau, tìm các bản ghi có trong A mà không có trong B. Bước 4: Chọn cột quan hệ giữa hai bảng và nhấp nút /Next. Bước 5: Chọn cột hiện ở bảng kết quả/ Next. Bước 6: Đặt tên Query kết quả/ Finish. 3. Crosstab Query: a.Tạo Crosstab Query bằng Wizard: ý nghĩa: Crosstab Query Wizard là một loại Query dùng để tổng hợp. Trong đó giá trị của một số Field trong Table hoặc Query nguồn được dùng làm tiêu đề Giáo trình access cơ bản 18 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  19. dòng, giá trị của một số trường được dùng làm tiêu đề các cột và giá trị tổng hợp của một trường được biến thành giá trị của các cột . Cách tạo: Bước 1: Chọn Queries/ New/ Crosstab Query Wizard/OK. Bước 2: Chọn Query hoặc các bảng chứa các cột cần tính/ Next. Bước 3: Chọn các cột chứa các giá trị đặt ở Row Heading/ Next. Bước 4: Chọn hàng chứa giá trị đặt ở vùng Column Heading/Next. Bước 5: Chọn cột chứa giá trị tính toán và chọn hàm tính toán/Next. Chọn Yes/Include rowsums: Nếu bạn muốn tạo thêm 1 cột là kết quả, tổng cộng số liệu của các cột tạo bởi Column Heading. Bước 6: Đặt tên cho Query kết quả. b. Tạo các Crosstab query không dùng Wizard. Bước1: Tại bảng Database/Queries/New/DesignView/Ok. Bước 2: Chọn bảng hoặc Query chứa các cột cần tính toán. Bước 3: Chọn biểu tượng Querytype/Crosstab Query (Trên Query Design Toolbal) tại cửa sổ Design View hiện dòng Crosstab dưới dòng Total. Bước 4: Chọn các giá trị trên dòng Crosstab tuỳ theo cột: : Các giá trị của cột chọn đặt ở vùng RowHeading của bảng Rowheading Crosstab. : Các giá trị của cột chọn đặt ở vùng Column Heading của ColumnHeading bảng Crosstab. : Các giá trị của cột chọn tính toán ở vùng Value của bảng Value Crosstab và chọn hàm tính toán ở dòng Total. Notshow: Dòng cho cột ứng với mục Total =Where. Bước 5: Ghi tên Query và xem kết quả. Giáo trình access cơ bản 19 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
  20. c. Tạo Crosstab bằng cách tổng hợp dữ liệu. Chức năng: Gộp các Record giống nhau theo một giá trị nào đó thành một nhóm  và tính tổng, đếm số bản ghi,… trong nhóm. Cách dùng: Trong cửa sổ DesignView của Query: Bước 1: Nhấp biểu tượng Σ trên Query DesignToolbar -> Dòng Total dưới dòng Table. Bước 2: Tuỳ chọn giá trị trên dòng Total theo cột. : Gộp các dòng có giá trị giống nhau trên cột thành nhóm. Group by : Tính tổng của các giá trị trên cột của nhóm. Sum : Tính tổng giá trị trung bình của các giá trị trên cột của nhóm. Avg : Tìm giá trị lớn nhất trong các giá trị trên cột của nhóm. Max : Tìm giá trị nhỏ nhất trong các giá trị trên cột của nhóm. Min : Đếm số Record có trong nhóm mà tại đó cột có giá trị. Count : Tìm giá trị đầu tiên trong các giá trị trên cột của nhóm. First : Tìm giá trị cuối cùng trong các giá trị trên cột của nhóm. Last Expression : Cho biết cột là một biểu thức toán học. : Cho biết cột là một biểu thức điều kiện dùng để lọc Record trước Where khi tính toán và không hiện nội dung khi xem kết quả. + Nếu lọc Record trước khi tính toán dùng Where. + Nếu lọc Record sau khi tính toán thì không dùng Where Giáo trình access cơ bản 20 Chúc   các   bạn   Thành   công   hẹn   gặp   lại   trong   chương   trình   tiếp  theo!
Đồng bộ tài khoản