Giáo trình tin học địa chất hướng dẫn sử dụng Mapinfo

Chia sẻ: buiquynh

Trước sự phát triển ngày càng mạnh mẽ của tin học, và sự ứng dụng rộng rãi Tcủa công nghệ GIS (Geographic Information System) trong quản lý, sản xuất cũng như trong các nghành khác nhau đặc biệt là các nghành khoa học trái đất cho phép con người mô phỏng hình dáng bề mặt trái đất, quản lý tài nguyên thiên nhiên... cùng với các phép toán, các công cụ để phân tích, truy xuất, tìm kiếm dữ liệu một cách nhanh chóng hiệu quả, công cụ ngày càng khẳng định vị trí vững...

Bạn đang xem 10 trang mẫu tài liệu này, vui lòng download file gốc để xem toàn bộ.

Nội dung Text: Giáo trình tin học địa chất hướng dẫn sử dụng Mapinfo

Cục địa chất và khoáng sản Việt Nam
Viện Thông tin Tư liệu địa chất




Giáo trình tin học địa chất
hướng dẫn sử dụng MapInfo
( Dùng cho lớp tin học địa chất )




Người Viết : Tuấn

Anh
Lê Minh Tuân




Hà nội, 1997
Mở đầu

T rước sự phát triển ngày càng mạnh mẽ của tin học, và sự ứng dụng rộng rãi
của công nghệ GIS (Geographic Information System) trong quản lý, sản xuất
cũng như trong các nghành khác nhau đặc biệt là các nghành khoa học trái đất cho phép
con người mô phỏng hình dáng bề mặt trái đất, quản lý tài nguyên thiên nhiên... cùng
với các phép toán, các công cụ để phân tích, truy xuất, tìm kiếm dữ liệu một cách
nhanh chóng hiệu quả, công cụ ngày càng khẳng định vị trí vững chắc của nó trong thế
giới tin học.

Trong nhiều năm qua, Cục Địa chất Việt nam đã chú ý đầu tư, xây dựng và phát
triển các cơ sở tin học (con người, thiết bị ...) ngày càng trở nên mạnh mẽ hơn, trở
thành công cụ hữu ích giúp cho các nhà địa chất trong công tác thu thập, phân tích, xử
lý số liệu và phục vụ các cấp lãnh đạo trong việc quản lý tài nguyên khoáng sản.

Tại Viện Thông tin Tư liệu Địa chất đã có những phần mềm GIS của các hãng nổi
tiếng trên thế giới như MGE của InterGraph, ArcInfo của ESRI và MAPINFO của
MapInfo Co... Trong những năm qua, bằng sự nỗ lực của tất cả các anh em làm tin học
tại Viện trong công tác nghiên cứu, xây dựng các quy trình công nghệ và triển khai sản
xuất đã bước đầu tạo ra được những sản phẩm có chất lượng. Ngày nay, công tác đào
tạo GIS cũng như chuyển giao công nghệ trở thành một trong những mục tiêu đào tạo
của Viện.

Trong giáo trình này, chúng tôi cố gắng cung cấp những kiến thức cơ bản nhất về
MAPINFO, một phần mềm GIS hiện đang được sử dụng phổ biến rộng rãi trong các
nghành đặc biệt là nghành Địa chất Việt Nam cũng như trên thế giới. Chúng tôi cũng
rất mong mọi người đọc qua đó sẽ nắm bắt được một cách nhìn tổng quan về các hệ
GIS cũng như những kiến thức cơ sở của MAPINFO một cách hệ thống và sử dụng
sao cho hiệu quả nhất trong công việc của mình.

Để cho giáo trình ngày càng hoàn thiện hơn chúng tôi rất mong nhận được sự đóng
góp quý báu của các bạn./.




2
Tác giả.




3
Mục lục

- Chương I : Cấu trúc của phần mềm MapInfo và một số khái niệm cơ bản

- Chương II : Tạo mới các Table, Làm việc với Project

- Chương III : Làm việc với các đối tượng hình học trên Mapinfo.

- Chương IV : Làm việc với các đối tượng thuộc tính trên Mapinfo.

- Chương V : Làm việc với Layer Cosmetic.

- Chương VI : Một số sử lý khác.




4
Chương I : một số khái niệm cơ bản

I - Khái niệm về GIS (Geographic Infomation System)
Từ những sự phát triển mạnh mẽ trong tin học và những nhu cầu trong thực tế của
các nghành khoa học trái đất về công tác thành lập và quản lý các lọai bản đồ trên máy
tính, ngày nay trên thế giới đã có rất nhiều hệ phần mềm GIS được áp dụng và đưa
vào thực tế phục vụ con người.
GIS là một hệ phần mềm máy vi tính cung cấp các công cụ phục vụ cho việc thu
thập, lưu trữ, phân tích, xử lý và hiển thị các thông tin địa lý. Các thông tin đó mô tả về
hình dạng, vị trí cũng như các tính chất của các đối tượng trên trái đất trong một hệ
tọa độ nào đó. Dữ liệu của một hệ GIS bao giờ cũng gồm hai lọai đó là :
- Dữ liệu không gian
- Dữ liệu thuộc tính

MapInfo là một hệ GIS hiện đang được sử dụng rộng rãi tại Việt Nam và một số
nước khác trên thế giới như Mỹ, Canada, úc ... Hơn nữa, Mapinfo còn cung cấp một
ngôn ngữ MapBasic giúp cho các lập trình viên có thể can thiệp vào CSDL cũng như
phát triển các công cụ phục cho mục đích của người dùng.
MapInfo là một phần mềm có khả năng tương thích cao với các hệ GIS khác, cho
phép ta có thể trao đổi dữ liệu giữa MapInfor với các hệ đó thông qua các dạng Format
chuẩn như AutoCad DXF File (Data Exchange File).
Hơn nữa, với phiên bản MapInfo Profesional 4.0 trở lên hãng đã cung cấp những
khả năng mới đó là :
- Cung cấp một Project mới đó là Gauss-Kruger (Pulkovo 1942) cho phép ta đưa
các bản đồ vào MapInfo theo đúng hệ tọa độ Gauss (Hà nội 72) hiện đang dùng tại
Việt nam.
- ODBC (Open DataBase Conectivity) : Là chức năng cho phép người dùng có thể
sử dụng môi trường ODBC để tạo các liên kết tới các CSDL lớn như MicroSoft
Access, MicroSoft SQL Server, Oracle, Fopro for Windows ...
- Cung cấp một thư viện hàm OLE giúp cho việc đưa các bản đồ được tạo ra trên
MapInfo vào trang tài liệu của các hệ sọan thảo văn bản như Microsoft Word phục vụ
cho công tác thành lập các bản thuyết minh báo cáo....

ii - Cấu trúc File dữ liệu của phần mềm MapInfo
Một bản đồ trên MapInfo được gọi là một Table nó bao gồm ít nhất là 4 File cơ
bản :
*.Tab : File chứa các thông tin cơ bản về cấu trúc CSDL
của một Table trên MapInfo



5
*.Dat : Chứa các thông tin thuộc tính của các đối tượng đồ họa trong
Table
*.Map : Chứa các thông tin của các đối tượng đồ họa tring Table
*.id : Chứa các thông tin cách sắp xếp, liên kết giữa các đối tượng đồ
họa
và các thông tin thuộc tính.
Ngoài ra còn có thể có một số File phụ trợ khác như :
*.Ind : Chứa các thông tin về thứ tự xắp xếp (Index) theo một giá trị
trường được chỉ định trong CSDL
*.Dbf : Chứa các thông tin của FoxPro, Dbase nếu như được mở trong
MapInfo và các file này sẽ thay thế chức năng của file *.dat
*.bmp: Chứa các thông tin về ảnh nếu được mở trong MapInfo




6
Chương II: Làm việc với Table & Project

I - Khái niệm về PROJECT.
Cũng như tất cả các hệ GIS, trong MapInfo cũng có khái niệm về hệ tọa độ được
gọi là Project cho phép ta thành lập, hiển thị các bản đồ trong hệ tọa độ thực của trái
đất.
Các thông tin về Project của bao gồm : Bán kính trục của Ellips, các thông số về sai
số trong phép chiếu từ mặt cầu xuống mặtt phẳng, giá trị giới hạn của một múi tọa
độ ... tất cả các thông số đó được Mapinfo lưu trong File “C:\MAPIN
FO\MAPINFO.PRJ”.
Tuỳ thuộc vào tính chất bản đồ mà ta chọn các hệ tọa độ khác nhau như Gauss,
UTM, Longitude - Latitude, Non-Erath v..v..

II - Làm việc với table

1. Tạo một bản vẽ (Table) mới.
Có 4 cách tạo được một bản vẽ mới trên Mapinfo :
1 - Tạo 1 bản vẽ mới bằng NEW TABLE
2 - IMPORT từ các file khác vào Mapinfo.
3 - Ghi 1 số đối tượng lựa chọn từ 1 Table, Query, Selection
ra 1 bản vẽ mới bằng lệnh SAVE COPY AS.

a - Tạo bản vẽ mới bằng lệnh NEW TABLE
Các bước thực hiện :
Bước 1 : Vào menu [ FILE ] ----> NEW TABLE ---> Xuất hiện Hình 1
Chức năng này cho phép tạo mới ban vẽ mới trên Mapinfo với cấu trúc
do ta tự xây dựng (Xem hình 2).




Hình 1




7
- Chọn Open New Browser : Nếu muốn mở màn hình Brow để xem và
nhập dữ liệu thuộc tính.
- Chọn Open New Mapper : Nếu muốn mở một cửa sổ mới để vẽ
- Chọn Add to Current Mapper : Nếu muốn hiển thị bản vẽ vào trong
cửa sổ hiện thời trên màn hình.
Để chọn các thuộc tính trên có thể dùng chuột hoặc bằng bàn phím
Sau đó chọn : Create... nếu muốn tạo bản vẽ mới (chuyển sang bước 2)
hoặc Cancel nếu muốn thóat khỏi lệnh này
Bước 2 : Khai báo cấu trúc CSDL và chọn Project cho bản vẽ (Xem Hình 2)




Hình 2

Tạo cấu trúc cho CSDL :

+ FIELD NAME : Khai báo tên trường trong CSDL.
: Cho phép đặt kiểu trường gồm các kiểu
+ FIELD TYPE
- CHARACTER : Trường có kiểu ký tự
: Trường có kiểu số nguyên
- INTEGER
: Trường có kiểu số thực
- FLOAD
: Trường có kiểu Logic, v...v..
- LOGICAL



8
+ LENGTH : Đặt độ dài lớn nhất cho các giá trị của trường.
+ DECIMAL : Đặt độ dài lớn nhất cho các giá trị thập phân của trường
và tuỳ chọn này chỉ áp dụng cho trường số.
- Khi muốn thêm một trường sử dụng : ADD FIELD
- Khi muốn xoá một trường sử dụng : REMOVE FIELD

Khai báo Project cho bản vẽ :




Hình 3

Project ngầm định của MapInfo là kinh vĩ độ (Long/Lat) ta phải chọn
Project thích hợp cho bản vẽ như :
- Bản vẽ sử dụng hệ tọa độ GAUSS (cho BĐ thuộc lãnh thổ Việt nam)
chọn:
-> Category : Gauss-Kruger (Pulkovo 1942)
-> Category member : GK Zone 17 (96o --> 102 o)
GK Zone 18 (102 o --> 108 o)
GK Zone 19 (108 o --> 114 o)
- Bản vẽ sử dụng hệ tọa độ UTM (cho BĐ thuộc lãnh thổ Việt nam)
chọn:
-> Category : Universal Transverse Mercato (WGS 84)
-> Category member : GK Zone 47 (96o --> 102 o) Northern
GK Zone 48 (102 o --> 108 o) Northern
GK Zone 49 (108 o --> 114 o) Northern
- Bản vẽ sử dụng hệ tọa độ vuông góc chọn:


9
-> Category : Non-Earth
-> Category member : tùy chọn đơn vị khoảng cách (mét,km,fit...)
-> Đối với bản vẽ trong hệ tọa độ Non-Earth ta phải khai báo
giới hạn của bản vẽ




Hình 4

Sau khi khai báo cấu trúc CSDL cũng như Project chọn Create. để tạo bản vẽ
mới
- Chú ý : Một Table trên MapInfo sẽ phải có ít nhất 1 trường trong CSDL

b - Tạo một Table bằng lệnh IMPORT
Sử dụng lệnh IMPORT để biến đổi các dưới dạng các format chuẩn như :
*.DXF, *.MIF, *.MMI, *.MBI,*.IMG thành một Table của Mapinfo (Hình 5)




Hình 5


10
Trong đó, các file *.DXF (Data Exchange File) là một trong những chuẩn mực
của hãng AutoDesk mà các hệ CAD và GIS dùng để trao đổi dữ liệu với nhau.


Các bước thực hiện :
Bước 1 : Vào menu [TAB] --> Import
Bước 2 : Chọn kiểu của File (VD : AutoCad DXF)
Bước 3 : Chọn File cần Import (*.Dxf) --> Chọn nút Import
Bước 4 : Khai báo Project (xem trên) --> Chọn nút Projection...




Hình 6

Bước 5 : Khai báo thông tin chuyển đổi tọa độ từ File DXF vào
Mapinfo
Chọn nút: Set Transfomation...




11
Hình 7

Chú ý : - Khi bạn đã đặt tương quan toạ độ bằng SET
thì tất cả các đối tượng sẽ được tính lại
TRANFOMATION
theo tỉ lệ và giá trị toạ độ mới.
- Khi khai báo chuyển đổi toạ độ bằng SET TRANFOMATION
2 điểm Point1 và Point2 trong Mapinfo phải là các giá trị hợp
thì
lệ tức là giá trị đó phải nằm trong khoảng min/max được
trong File Mapinfo.PRJ. Nếu có đối tượng nằm
khai báo
ngoài khoảng min/max thì đối tượng đó sẽ không được Import
nhận được thông báo lỗi.
vào Mapinfo và
Sau khi khai báo xong chọn OK để trở về màn hình trước (Hình
6)
Bước 6 : Tại Hình 6 chọn OK để thực hiện công việc Import
Chú ý : Trong trường hợp Import một file *.mif là một dạng dữ liệu chuẩn của
Mapinfo để chuyển đổi dữ liệu từ Mapifo for DOS sang Mapinfo
Window thì ta không cần phải thực hiện các bước 4,5,6 vì trực
for
tiếp trong file *.mif đã chứa các thông tin về Project nên bạn chỉ cần
File muốn tạo và ấn sẽ tạo được một bản vẽ mới
đánh vào tên
trên Mapinfo

c - Tạo 1 bản vẽ mới bằng lệnh SAVE COPY AS
Vào Menu [File] ---> chọn SAVE COPY AS
Lệnh SAVE COPY AS có thể tạo ra một File mới mà dữ liệu được lấy ra từ
- Table đang mở
- Query ( tạo Query bằng lệnh SQL Select sẽ nói đến ở chương III).
- Selection : là các đối tượng đang được chọn.
Lệnh này sẽ tự động sao lưu cấu trúc dữ liệu và thuộc tính của các đối
tượng ra File mới và trong chức năng này còn cho phép ta đặt lại thuộc
tính Project của đối tượng bằng lựa chọn Project.

2. Mở một Table đã tồn tại (Hình 8)
Trong MapInfo cho phép mở nhiều loại file khác nhau như :
*.Tab : Là file do Mapinfo tạo ra
*.DBF : Là các file được tạo ra trên FOXPRO hoặc DBASE
- Khi mở các file *.Dbf MapInfo sẽ tạo ra một file có cùng tên và
phần mở rộng là "tab" chứa cấu trúc của file DBF.
Hơn nữa, khi mở file DBF Mapinfo sẽ lọai bỏ các trường :
MEMO,PICTURE,GENERAL


12
*.TXT : (Delimited ASCII) là các file text có các cột được phân cách bởi
một kí tự bất kì hoặc dấu Tab.
*.wk? : LOTUS 1-2-3 là các file dạng bảng tính trên phần mềm Lotus
*.xls : Là file dạng bảng tính trên phần mềm Microsoft Excel
Bitmap : Là các file ảnh có phần mở rộng *.gif, *.bmp,*.pcx ...
Các bước thực hiện :
Bước 1 : Vào Menu [File] ---> Chọn Open (xem hình 8)
Bước 2 : Chọn kiểu File --> vào List File of Type
Bước 3 : Chọn tên File (tùy từng trường hợp cụ thể sẽ phải khai báo các
thông số khác nhau) ---> Kết thúc : Chọn nút OK.




Hình 8

3. Lưu một Table
Bước 1 : Vào Menu [File]-->Chọn SAVE Tables
--> Xuất hiện danh sách các Table đã bị sửa đổi cần lưu




13
Hình 9

Bước 2 : Chọn Table hoặc dùng phím Shift or Ctrl để chọn một nhóm các File
Sau đó : Chọn nút Save để thực hiện lệnh.

4. Đóng các Table đang được mở.
Vào menu [File] --> Chọn Close Table nếu muốn đóng một table
hoặc chọn Close All nếu muốn đóng tất cả các Table đang được mở.

5. Làm việc với File WorkSpace
File WorkSpace có phần mở rộng là *.WOR là một file kịch bản của MapInfo dạng
ASCII ta có thể dùng các phần mềm sọan thảo để thay đổi, sửa chữa.
Trong File WorkSpace chứa các thông tin về các Table đang được mở khi tạo ra
File đó như : Tên file (đầy đủ đường dẫn nếu nằm ở thư mục khác với file *.wor), bí
danh, hiện trạng của màn hình (vị trí, kích cỡ,tỷ lệ zoom ..).... và các lệnh để cho
Mapinfo thực hiện.
Ví dụ :
!Workspace
!Version 400
!Charset WindowsLatin1
Open Table "vnmap" As VNMAP Interactive
Open Table "color_vn" As COLOR_VN Interactive
Set Window Info
Position (0.239583,0.864583) Units "in"
Width 2.39583 Units "in" Height 3.64583 Units "in"
Font ("MS Sans Serif",0,8,0)
Open Window Info
Map From VNMAP,COLOR_VN
Position (0.0520833,0.0520833) Units "in"
Width 3.29167 Units "in" Height 2.04167 Units "in"



14
Set Window FrontWindow() ScrollBars Off Autoscroll On
Set Map
CoordSys Earth Projection 1, 1001
Center (101.0980608,16.52158878)
Zoom 3198.42992 Units "km"
Preserve Zoom Display Zoom
XY Units "degree" Distance Units "km" Area Units "sq km"
Set Map
Layer 1
Display Graphic
Selectable Off
Label Line None Position Center Font ("Arial",0,9,0) Pen (1,2,0)
With fcode
Parallel On Auto Off Overlap Off Duplicates Off Offset 2
Visibility On
Layer 2
Display Graphic
Selectable Off
Label Line None Position Center Font (".VnBlackH",1,12,0) Pen (1,2,0)
With TINH_THANHPHO
Parallel On Auto On Overlap Off Duplicates On Offset 2
Visibility Zoom (110, 780) Units "km"
Object 157 Anchor (105.830895483766,21.138336088167)
Object 64 Anchor (105.549182986651,19.918577057342)
Object 2 Anchor (103.060009278429,22.146572108219)
Set Window Frontwindow() Max
-----------------

- Tạo một File WorkSpace : Vào menu [File] ---> Save WorkSpace --> Đặt tên File
- Mở một File WorkSpace :Vào menu [File] --->Open WorkSpace-->Chọn File
*.wor
Chú ý : Khi ta thay đổi vị trí của các File mà file *.wor gọi đến --> Mapinfo sẽ
báo không tìm thấy File . Do vậy nếu muốn chạy được ta có thể chữa trực
thông
tiếp đường dẫn tới Table trong file *.wor




15
Chương III : Làm việc với các đối tượng Đồ họa


Các đối tượng trên Mapinfo được lưu giữ thành 2 phần :
- Các đối tượng hình học (Object) : Là các đối tượng hiển thị trên bản vẽ như
LINE, PLINE, TEXT, REGION, RECTANGULAR,SYMBOL.
- Các đối tượng thuộc tính (Attribute): Là giá trị thuộc tính của các đối tượng
đồ họa được lưu giữ trong CSDL.



I - Một số khái niệm

1- Khái niệm về đối tượng hình học
Các đối tượng hình học trong Mapinfo bao gồm
: Là đoạn thẳng có hai đỉnh.
- LINE
: Là đường thẳng đi qua n đỉnh ( n >= 2).
- PLINE
: Là hình Ellipse với 1 tâm và 2 bán kính.
- ELLIPSE
Trong trường hợp hai bán kính bằng nhau ta được hình
tròn.
- SYMBOL : Là ký hiệu được dán vào 1 điểm nào đó của bản vẽ.
: Là Pline khép kín có chứa thuộc tính về vùng
- REGION
- RECTANG : Là hình chữ nhật, hoặc hình vuông
: Là các đối tượng Text hiển thị trên bản vẽ
- TEXT

2- Khái niệm về thuộc tính hình học
Trong mỗi một đối tượng hình học có chứa các thuộc tính hình học. Thuộc tính
hình học của đối tượng bao gồm mầu đường bao, mầu nền, loại đường bao, kiểu chữ
v..v
Mỗi loại đối tượng hình học khác nhau sẽ có một số thuộc tính khác nhau
: Có thuộc tính
- LINE và PLINE
• Mầu đường ( Line color )
• Loại đường ( Line style)
• Độ dày đường ( Line with)
• Độ dài đường (Length)




16
- ELLIPSE, REGION và RECTANG : Ngoài các thuộc tính của đường bao
giống Line và Pline còn có thuộc tính về vùng
như :
• Mầu vùng ( Fill color)
• Kiểu nền (Pattern)
• Diện tích vùng ( Area square)
• Chu vi (Primeter)
- SYMBOL : Có các thuộc tính
• Loại Symbol (Symbol Style)
• Cỡ Symbol (Size)
• Tọa độ (Coordinate)
• Màu sắc (Color)
: Có các thuộc tính
-TEXT
• Kiểu chữ (Text font)
• Cỡ chữ (Text Size)
• Màu sắc (Color)


3- Khái niệm về Layer
Cũng như các hệ GIS khác, trên Mapinfo ta có thể mở được nhiều file bản đồ cùng
một lúc (*.tab) nhằm phục vụ mục đích chồng ghép các lớp bản đồ khác nhau để có
được một bản đồ chuyên đề theo theo yêu cầu của người dùng tin.
Đối với GIS việc phân loại và tách các đối tượng trong một hệ cơ sở dữ liệu thành
các lớp hay, nói riêng trong Mapinfo là các table (*.tab) là rất cần thiết. Việc phân loại
thông tin theo từng lớp như thế nào, nhằm mục đích gì là hoàn toàn phụ thuộc vào yêu
cầu của mức độ và quy mô quản lý cũng như các kết quả đưa ra của người dùng.
Ví dụ như trên Mapinfo, đối với các bản đồ địa chất ta có thể phân chia thành các
lớp đối tượng khác nhau như:
- Lớp các bản đồ : Sông, suối
- Lớp các bản đồ : Giao thông (đương bộ, đường sắt,đường mòn..)
- Lớp các bản đồ : Địa giới, Địa danh
- Lớp các bản đồ : Đường đồng mức
- Lớp các bản đồ : Ranh giới địa chất
- Lớp các bản đồ : Tuổi, kí hiệu địa chất
................


17
Với việc phân chia thành các lớp dựa trên cơ sở phân loại nào đó giúp cho việc
quản lý chặt chẽ hơn, cũng như tạo điều kiện thuận tiện trong việc sửa chữa và cập
nhật về sau.


Trên Mapinfo, mỗi Table được mở sẽ được gọi là một Lớp (Layer) trong một
cửa sổ (Window).
Layer trong Mapinfo có tên trùng với tên file *.tab mà bạn mở. Trường hợp đặc biệt
khi bạn mở cùng một file nhiều lần thì sau mỗi lần mở Mapinfo sẽ tự động thêm các
số hiệu lần mở vào sau tên Layer của bạn.
Ngoài các Layer do người dùng mở trong Mapinfo còn có một Layer đặc biệt có tên
“Layer Cosmetic” sẽ được nói đến trong chương V.
Để xem các Layer đã được mở trong một cửa sổ, hoặc thay đổi thứ tự, thuộc tính
thể hiện trên màn hình của một Layer nào đó ta thực hiện các bước sau :
Bước 1 : Vào menu [Map] --> chọn Layer Control
Bước 2 : Thực hiện các thay đổi cần thiết (xem hình 10)




Hình 10

- Lựa chọn Visiable : Có hiện Layer được chọn hay không
Trong đó :
- Lựa chọn Editable : Cho phép thêm mới, sửa chữa các đối
tượng
trên Layer được đánh dấu.
Chú ý : Tại một thời điểm Mapinfo chỉ cho phép đặt một
Layer ở chế độ Editable.
- Lựa chọn Selectable : Cho phép chọn các đối tượng trên
Layer hiện thời hay không.


18
- Lựa chọn Label : Hiện thị nhãn (Label) của các đối tượng trong
Layer được chọn
- Nút Add : Thêm một Layer (một Table đã được mở)
vào cửa sổ hiện thời.
- Nút Remove : Loại bỏ không hiển thi Layer được chỉ định ra
khỏi của sổ hiện thời nhưng chưa đóng Table đó.
- Nút Up/Down : Dịch chuyển Layer được chọn
lên trên/xuống dưới để xắp xếp thứ tự xuất hiện
trên màn hình của các Layer.
- Nút Display : Thay đổi cách thể hiện trên màn hình của các
Layer như giới hạn phạm vi hiển thị trên
màn hình(Zoom Max/Zoom Min) ...
- Nút Label : Tạo nhãn cho các đối tượng của Layer được chọn
theo một trường mà người dùng chỉ định
- Nút Thematic : Thay đổi cách hiển thị các bản đồ chủ đề được
tạo ra do lệnh: Creat Thematic Map.


II. TạO MớI các đối tượng Đồ HọA
Để thuận tiện cho người dùng Mapinfo cũng đưa ra hai hộp công cụ là :
Main và Drawing (Xem Hình 11)




Hình 11




19
1a. Tạo mới một đối tượng Text
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ
EditAble)
Bước 2 : Vào Menu [Options] --> chọn Text Style
Khai báo : Kiểu chữ (Font), Cỡ chữ (Size), Màu sắc ... nếu cần
Bước 3 : Chọn biểu tượng Text ( A ) trong hộp công cụ Drawing
Bước 4 : Chọn vị trí con trỏ (điểm bắt đầu của Text)
Bước 5 : Nhập giá trị của Text, để kết thúc nhấn phím trái chuột
hoặc tắt nút tạo Text mới ( A ) trong hộp công cụ Drawing

1b. Thay đổi thuộc tính của một đối tượng Text
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ
EditAble)
Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa
Hoặc lựa chọn đối tượng cần sửa --> Vào menu [Edit] --> Get info
----> Cho ta hình 12




Hình 12

Tại hộp đối thoại này, ta có thể thay đổi nội dung, kiểu, góc quay... của text



20
2a. Tạo mới 1 đối tượng Symbol:
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ
EditAble)
Bước 2 : Vào Menu [Options] --> chọn Symbol Style
Khai báo : Kiểu Symbol, Cỡ Symbol (Size), Màu sắc ... nếu cần
Bước 3 : Chọn biểu tượng Symbol trong hộp công cụ Drawing
Bước 4 : Chọn vị trí con trỏ đặt Symbol, để kết thúc tắt nút tạo Symbol

2b. Thay đổi thuộc tính của một đối tượng Symbol
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ
EditAble)
Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa
Hoặc lựa chọn đối tượng cần sửa --> Vào menu [Edit] --> Get info
----> Cho ta hình 13




Hình 13

Tại đây, ta có thể thay đổi Kiểu của Symbol hoặc tọa độ ...

3a. Tạo mới 1 đối tượng Line:
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ
EditAble)
Bước 2 : Vào Menu [Options]--> chọn Line Style
Khai báo : Kiểu đường , Màu sắc, độ rộng ... nếu cần




21
Hình 14

Bước 3 : Chọn biểu tượng Line trong hộp công cụ Drawing
Bước 4 : Chọn vị trí điểm đầu của Line (Nhấn phím trái, giữ nguyên),
kéo tới vị trí điểm cuối của Line ---> Thả phím trái


3b. Thay đổi thuộc tính của một đối tượng Line
Bước 1 : Vào menu Map --> chọn Layer Control
(Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ
EditAble)
Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa
Hoặc lựa chọn đối tượng cần sửa --> Vào menu Edit --> Get info
----> Cho ta hình 15




Hình 15

4. Tạo mới 1 đối tượng Vùng (Region, Circle, Ellip, Rectangular):



22
Bước 1 : Vào menu [Map] --> chọn Layer Control
(Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ
EditAble)
Bước 2 : Vào Menu [Options] --> chọn Region Style
Khai báo : Kiểu nền (Pattern), màu nền,
Kiểu đường biên, Màu đường biên, độ rộng ... nếu
cần




Hình 16



Bước 3 : Chọn biểu tượng Region(Circle, Rectangular...)
trong hộp công cụ Drawing
Bước 4 :
- Nếu vẽ Region : Bấm phím chuột trái tại những điểm cần vẽ,
để kết thúc nhấn đúp phím trái chuột tại điểm cuối cùng
- Nếu vẽ đường tròn hoặc Ellip : Nhấn phím trái chuột tại vị trí
xác định tâm (giữ nguyên kéo tới vị trí xác định) thả
chuột




23
- Nếu vẽ hình vuông, hình chữ nhật : Nhấn phìm trái chuột tại
vị trí một góc --> giữ nguyên, kéo tới góc đối diện -->
thả chuột
Chú ý : Ngoài các chức năng nêu trên đối với các đối tượng dạng Line, Pline,
còn cho phép ta thực hiện các chức năng :
Region
. Edit Vetex : Cho phép ta di chuyển từng Vetex của đối tượng. Khi đã chọn
chức năng Edit Vetex trong hộp công cụ Drawing thì chỉ có
thể di chuyển được từng Vetex chứ không thể di chuyển
( Move) được cả đối tượng, muốn huỷ bỏ chế độ Edit Vetex
ta chọn lại vào chức năng đó 1 lần nữa.
. Insert Vetex : Cho phép chèn thêm Vetex vào đối tượng. Muốn chèn thêm
vào một đối tượng thì buộc phải kích hoạt các Vetex của đối
Vetex
tượng, sau đó chọn chức năng Insert Vetex trong hộp công cụ
Drawing.

5. Chọn một nhóm các đối tượng trên Mapinfo
- Nhấn phím Shift trong khi chọn từng đối tượng
- Chọn tất cả các đối tượng trong một hình chữ nhật (Marquee Select)
- Chọn tất cả các đối tượng nằm trong 1 Region (Boundary Select)
- Chọn tất cả các đối tượng nằm trong 1 Hình tròn (Radius Select)
Khi một nhóm hay một đối tượng được chọn Mapinfo sẽ đưa vào một Table tạm
thời có tên là Selection hoặc các Query . Khi ta đóng các Layer hoặc thoát khỏi
Mapinfo thì các Query và Selection sẽ tự động được xoá
Chú ý : Trên Mapinfo không những cho phép ta thay đổi thuộc tính của 1 đối tượng
mà còn cho phép ta thay đổi thuộc tính của cả một nhóm đối tượng được chọn.

III- sửa chữa các đối tượng Đồ họa
Ngoài việc thay đổi các thuộc tính hình học của các đối tượng, trong Mapinfo còn
cho phép một số phép xử lý phức hợp khác với đối tượng hình học. Cụ thể là :
- Sao chép 1 đối tượng (Copy)
- Di chuyển 1 đối tượng (Move)
- Chia 1 đối tượng thành nhiều đối tượng (Split)
- Tạo một đối tượng phức hợp từ nhiều đối tượng (Combine)
- Xoá phần đối tượng này bị đối tượng khác đè lên (Erase, Erase Outside)
- Chèn Vetex vào các vị trí giao nhau (Ovelay Note)
- Biến đổi các đối tượng từ loại này thành loại khác (Convert)

1. Sao chép đối tượng ( Copy)



24
Các bước thực hiện
Bước 1 : Chọn đối tượng cần sao chép (hoặc 1 nhóm đối tượng)
Bước 2 : Vào Menu Bar [Edit] --> chọn Copy.
Bước 3 : Vào menu [Map] ---> Layer Control
đặt Layer cần dán các đối tượng sao chép ở chế độ Editable
Bước 4 : Vào Menu Bar [Edit] ---> Chọn Paste để dán
Sau khi thực hiện lệnh sao chép ta được các đối tượng mới nằm trùng vị trí với đối
tượng cũ với dữ liệu thuộc tính (Attribute) không thay đổi khi hai Layer có cấu trúc
CSDL giống nhau.

2. Di chuyển đối tượng ( Move)
Muốn di chuyển đối tượng việc đầu tiên phải kích hoạt Layer chứa chúng ( đặt
Layer ở chế độ Editable) sau đó đánh dấu đối tượng và dùng phím chuột trái(nhấn và
giữ nguyên) để di chuyển, kết thúc thả chuột trái.

3. Chia 1 đối tượng thành nhiều đối tượng (Split)
Chức năng này chỉ có thể áp dụng với các đối tượng là Line, Pline, Ellipse, Region
Các bước thực hiện :
Bước 1 : Muốn thực hiện chức năng này đầu tiên ta phải xác định được các vị
cần chia. Sau đó tạo 1 vùng (Region) đi qua các điểm đó ( gọi là
trí
vùng A).
Bước 2 : Đặt Layer chứa các đối tượng cần chia ở chế độ EditAble
Bước 3 : Đánh dấu các đối tượng cần chia
Bước 4 : Vào Menu Bar [Objects] ---> Chọn Set Target
(Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp)
Bước 5 : Chọn “vùng A” vừa vẽ (được coi như là chuẩn)
Vào Menu Bar [Objects] ---> Chọn Split để chia đối tượng
Sau các thao tác trên về mặt hình học đối tượng sẽ bi chia thành 1 số đối tượng
nhỏ hơn tuỳ thuộc vào số giao điểm của “vùng A” với đối tượng.
Bước 6 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện




25
Hình 17

Đối với giá trị thuộc tính tuỳ lựa chọn “Disaggreation Method” mà ta sẽ thu được
các giá trị khác nhau như chọn :
() Blank : Khi trường nào được chọn với lựa chọn Blank thì giá trị
thuộc tính của đối tượng thu được sẽ
Bằng 0 (= 0) nếu đó là trường số
Bằng rỗng (= ‘ ‘ ) nếu đó là trường ký tự
( ) Value : Giá trị thuộc tính của các đối tượng mới thu được sẽ giống như của
đối tượng ban đầu.
( ) Area Propotion : Lựa chọn này chỉ có tác dụng với các trường là trường số
đối tượng được chia là đối tượng vùng. Sau phép chia này

trị mới tạo ra sẽ được xác định lại dựa vào tỷ số
các giá
giữa diện tích các vùng được chia và giá trị của đối tượng
đầu.
Việc chia 1 đối tượng thành nhiều đối tượng mới có khá nhiều tác dụng.
Một ví dụ đơn giản: Nếu bạn có 1 đường Đứt Gãy liên tục mà qua mỗi vùng địa
chất nó lại có 1 Line Style khác nhau muốn giải quyết nó thì bạn phải chia đối tượng
đó thành những đối tượng bé hơn bằng lệnh Split sau đó thay đổi các đối tượng mới
cho phù hợp với yêu cầu.

4. Cộng nhiều đối tượng thành 1 đối tượng mới (Combine)
Ta có thể cộng nhiều đối tượng thành một đối tượng nhờ lệnh Combine. nhưng có
một số chú ý sau :



26
- Lệnh Combine chỉ làm việc với các đối tượng là Line, Pline, Region.
- Khi thực hiện lệnh cộng (Combine) thì chỉ có các đối tượng cùng kiểu mới có
thể cộng được với nhau. Ví dụ như ta có thể cộng các đối tượng là Pline với nhau chứ
không thể cộng Pline với Region.
Các bước thực hiện :
Bước 1 : Đánh dấu các đối tượng cần Combine
Bước 2 : Vào Menu Bar [Objects] ---> Chọn Combine
Bước 3 : Khai báo giá trị thuộc tính (xem hình 18)




Hình 18

Có 4 tuỳ chọn trong mục “Aggregate Method”
Trong 4 tuỳ chọn này thì 2 tuỳ chọn và chỉ áp dụng với trường
số.
Mỗi tuỳ chọn trên có ảnh hưởng đến giá trị thuộc tính của đối tượng mới như sau :
- No Change : Nếu 1 trường được xác định là “No Change” thì sẽ nhận giá trị
giá trị của của đối tượng được chọn làm Set Target.

: Cho phép nhập giá trị cho đối tượng mới sẽ tạo ra
- Value
: Đối tượng mới tạo ra có giá trị bằng tổng các giá trị của các đối
- Sum
tượng ban đầu (chỉ áp dụng với trường số).
: Đối tượng mới tạo ra có giá trị bằng giá trị trung bình cộng của
- Avegare
các đối tượng ban đầu (chỉ áp dụng với trường số).
Với lệnh Combine đối tượng mới tạo ra sẽ có thuộc tính hình học (loại đường,
mầu sắc ..v.v ) của đối tượng được chọn làm Set Target.


27
5. Xoá phần trùng nhau của các đối tượng ( Erase)
- Lệnh Erase chỉ làm việc với các đối tượng là Line, Pline, Region.
Mục đích : Tạo ra các Polygon đảo để thuận tiện trong việc tô màu, xác định chính
xác diện tích của một vùng thì bắt buộc ta phải xoá phần diện tích bị chèn và đè của
các vùng khác lên nó.
Các bước thực hiện :
Bước 1 : Đặt Layer chứa các đối tượng cần xóa ở chế độ Editable
Bước 2 : Đánh dấu các đối tượng cần xóa một phần
Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target
(Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp)
Bước 4 : Chọn các đối tượng dạng vùng có phần chung với "Target" cần xóa
Vào Menu Bar [Objects] ---> Chọn Erase
Bước 5 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện

6. Xóa các đối tượng nằm ngoài một vùng (Erase Outside)
- Lệnh Erase Outside chỉ làm việc với các đối tượng là Line, Pline, Region.
Các bước thực hiện :
Bước 1 : Đặt Layer chứa các đối tượng cần xóa ở chế độ Editable
Bước 2 : Đánh dấu các đối tượng cần xóa một phần
Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target
(Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp)
Bước 4 : Chọn các đối tượng dạng vùng có phần chung với "Target" cần xóa
Vào Menu Bar [Objects] ---> Chọn Erase OutSide
Bước 5 : Khai báo giá trị thuộc tính (xem hình 17) --> Chọn OK để thực hiện

7. Chèn Vetex vào các vị trí giao nhau (Ovelay Note)
- Lệnh Ovelay Note chỉ làm việc với các đối tượng là Line, Pline, Region.
- Thực hiện nó sẽ chèn Vetex vào các vị trí giao nhau của các đối tượng.
Các bước thực hiện :
Bước 1 : Đặt Layer chứa các đối tượng cần chèn Vetex ở chế độ Editable
Bước 2 : Đánh dấu các đối tượng cần chèn Vetex
Bước 3 : Vào Menu Bar [Objects] ---> Chọn Set Target
(Xác định các đối tượng được chọn sẽ chịu ảnh hưởng của lệnh kế tiếp)
Bước 4 : Đánh dấu đối tượng thứ 2 có giao điểm hay phần chung với "Target"



28
Bước 5 : Vào Menu [Object] ---> chọn Ovelay Note
Sau khi thực hiện xong chức năng này đối tượng đầu của bạn ( đối tượng chọn
Set Targe) sẽ được chèn thêm 1 Vetex vào mỗi điểm giao
làm
ứng dụng : Nếu như bạn muốn vẽ 1 đối tượng mới bắt đầu tại vị trí giao nhau
của 2 đối tượng cho trước, vì chế độ bắt điểm (Snap) của Mapinfo chỉ bắt
được vào các đỉnh Vetex. Hãy thực hiện chức năng Ovelay Note để chèn thêm
Vetex vào điểm giao nhau đó và bắt đầu quá trình vẽ của bạn.




29
8. Biến đổi các đối tượng từ loại này thành loại khác (Convert)
Trong Mapinfo cho phép biến đổi giữa 2 kiểu đối tượng là Pline Region
Chức năng này khá quan trọng trong khi bạn muốn Edit các đối tượng, sẽ được nói
kỹ hơn trong phần thực hành.
Các bước thực hiện
Bước 1 : Đặt Layer chứa các đối tượng cần thay đổi ở chế độ Editable
Bước 2 : Chọn đối tượng (hoặc một nhóm các đối tượng) cần thay đổi
Bước 3 : Vào Menu [Object] ---> chọn Convert to ...
- Convert to Region : Biến đổi từ Pline thành Region
- Convert to Polyline : Biến đổi từ Region thành Pline
Trên đây là 1 số thao tác cơ bản khi sử lý với các đối tượng hình học của 1 bản vẽ.
Sau đây ta sẽ thao tác với các đối tượng thuộc tính của chúng.




30
Chương IV: Làm việc với các đối tượng thuộc tính
(Attribute) trên Mapinfo


Trong Mapinfo thuộc tính của bản vẽ được lưu trữ bằng dạng bảng (Table) trong
đó có các trường (Field) và các bản ghi (Record). Mỗi bản ghi sẽ lưu trữ các giá trị
thuộc tính của 1 đối tượng hình học.
Làm việc với thuộc tính (Attribute) trên Mapinfo có những thao tác sau:
- Thay đổi cấu trúc của 1 Table (Modify Structure)
- Sửa đổi dữ liệu của 1 Table (Update Column)
- Chèn thêm dữ liệu vào 1 Table ( Append Rows To Table).
- Lựa chọn dữ liệu của 1 Table ( Select SQL).

I. Thay đổi cấu trúc 1 Table ( Modify Structure)
Muốn thay đổi cấu trúc 1 Table làm như sau vào :
Menu Bar [Table] ---> [Maintenance] ---> Table Structure .
Thay đổi cấu trúc 1 Table cho phép :
- Chèn thêm 1 trường bằng tuỳ chọn Add Field.
- Huỷ bỏ 1 trường bằng cách di vệt sáng về trường đó sau đó chọn Remove
Field.
- Thay đổi (tên trường, kiểu dữ liệu) của 1 trường bằng cách di vệt sáng về
trường đó --> đặt lại tên, chọn lại kiểu dữ liệu trong bảng chọn.
Sau khi thao tác xong ấn < OK > table sẽ nhận cấu trúc mới đã thay đổi.

II. Sửa đổi dữ liệu của 1 Table ( Update Column)
Có 3 cách sửa đổi dữ liệu từ 1 Table :
- Sửa từ cửa sổ Brows
- Sửa từ bảng cửa sổ Info Tool.
- Sửa bằng chức năng Update Column.

1- Sửa từ cửa sổ Brows
Muốn sửa chữa dữ liệu từ cửa sổ Brows ta vào :
Menu bar [Window] ---> [New Brower Window]
để mở cửa sổ Browse với Table muốn sửa chữa.



31
Đánh dấu 1 bản ghi sau đó, nếu bạn muốn tìm đối tượng chứa bản ghi đó
vào[ Menu Bar\ Query\ Find Selection]. Sau đó sửa chữa ngay trên cửa sổ Brows.

2- Sửa từ bảng cửa sổ Info Tool.
Vào hộp công cụ Main chọn chức năng Infomation ( chữ I ) --> Nhấn chuột trái
trên đối tượng cần xem ---> Các thông tin thuộc tính sẽ xuất hiện trên cửa sổ
Infomation, có thể tiến hành sửa chữa trực tiếp trên đó . Mọi sửa chữa của bạn sẽ
được ghi lại thành thuộc tính của đối tượng.

3- Sửa bằng chức năng Update Column.
Vào Menu [Table] ----> Update Column
Chức năng Update Column cho phép bạn cập nhật dữ liệu của một trương theo
một trường khác của cùng Table hay theo các trường của Table khác cùng mở.
Ta chia làm 2 phần :
- Update Column theo các trường của bản thân nó.
- Update Column theo các trường của các Table khác cùng mở.

a- Update Column theo các trường của bản thân nó.
Chức năng này cho phép thay đổi giá trị của 1 trường dựa vào giá trị 1 trường khác
có những tuỳ chọn sau (Hình 19):




Hình 19

: Lựa chọn tên Table muốn cập nhật.
- Table To Update
- Column To Update : Lựa chọn trường (Field) muốn cập nhật.




32
: Cho phép lựa chọn giá trị trường đó theo các trường
- Value
Giá trị mới này có thể xác định bằng biểu thức
khác.
trường hoặc các hàm khác trong Mapinfo.
Ví dụ :
Bạn có 1 Table tên là A, trong Table A có 2 trường [ ID(char), DES(char)].
Muốn thay đổi trường ID với giá trị tương ứng bằng ID + DES làm như sau :
- Table To Update : A
- Column To Update : ID
- Value : ID + DES
Sau các thao tác này bạn sẽ được kết quả theo ý muốn.

b- Update Column theo các trường của các Table khác cùng mở.
Khi bạn mở đồng thời nhiều Table thì có thể sửa chữa dữ liệu của mình theo các
Table khác. Các thao tác này như sau
- Table To Update : Lựa chọn tên Table muốn cập nhật
(Gọi là Table 1)
- Column To Update : Lựa chọn Trường ( Field) cần cập nhật.
- Get Value From Table : Lựa chọn tên Table lấy giá trị
(Gọi là Table 2)
- Join : Khi Update Column từ 1 Table khác buộc bạn phải có điều
kiện cộng. Mapinfo cho phép có 2 điều kiện cộng chuẩn
- Where Matche : Tức là
lấy giá trị tương thích theo thứ tự hàng (RowId)
- Where Objects With From < Table 2>
-Is Within Objects From
-Contain Objects From
-Intersects Objects From
Điều kiện cộng thứ 2 sẽ xác định tương quan của các đối tượng hình học trong
< Table 1> với các đối tượng hình học thuộc < Table 2>.
Điều kiện cộng là đúng với từng tuỳ chọn nếu :
Is Within - Đối tượng thuộc < Table 2 > nằm hoàn toàn
trong đối tượng
Contain - Khi đối tượng thuộc bao hàm đối
tượng của < Table 1>
Intersects- Khi đối tưọng của 2 Table giao nhau



33
-Caculate : Xác định giá trị lấy theo phương thức nào
. Value : Lấy theo giá trị.
. Avg : Lấy theo giá trị trung bình ( chỉ áp dụng với trưòng số)
. v..v..
- Of : Xác định xem giá trị lấy theo trường nào hoặc lấy theo biểu thức
của trường nào ( Expresion). Chú ý khi kiểu dữ liệu của 2
trường không tương thích thì kết quả sẽ là 0- với trường số
và bằng trống với trường kí tự.

4. Thêm dữ liệu vào một Table ( Append Rows To Table).
Có nhiều cách để chèn thêm dữ liệu vào 1 Table. Trong đó có 3 cách chính như sau
- Vẽ 1 đối tượng mới.
- Copy 1 đối tượng từ 1 Table khác
- Chọn chức năng Append Rows To Table

a. Vẽ 1 đối tượng mới.
Khi vẽ 1 đối tượng mới Mapinfo tự động chèn thêm một bản ghi trẵng vào CSDL
chứa nó Record này không có giá trị, muốn gán giá trị bạn có thể làm theo thao tác ở
phần 2

b. Copy 1 đối tượng từ 1 Table khác
Khi Copy đối tượng từ Table này (gọi là Table 1) sang Table khác ( gọi là Table 2)
Mapinfo tự động chèn thêm vào Table được ghi 1 số Record tương ứng với số đối
tượng được Copy.
Nếu theo thứ tự từ trái sang phải kiểu dữ liệu giữa 2 Table là phù hợp Mapinfo sẽ
tự động lấy giá trị thuộc tính của đối tượng ở chèn sang theo
đúng thứ tự của các trường. Nếu số trường trong < Table 1> lớn hơn số trường trong
thì số trường lớn hơn đó sẽ bị bỏ. Nếu số trường trong < Table 2> lớn hơn
số trường trong thì số trường lớn hơn đó sẽ bị gán giá trị 0 ( với trường số )
hoặc trống ( Với trường ký tự).

c. Chọn chức năng Append Rows To Table
Chức năng này cho phép thêm các bản ghi từ một Table vào Table khác
Vào Menu bar [Table] ----> Append Rows To Table
trong đó có các chức năng sau :
- Append Table : Chọn Table được lấy để Append ( gọi là Table 1).
: Chọn Table kết quả ( gọi là Table 2).
- To Table



34
Khi thực hiện lệnh Append, Mapinfo sẽ chèn thêm các bản ghi của
vào cuối trong CSDL đồng thời Copy tất cả đối tượng hình học
của sang .
Dữ liệu được lấy tương ứng theo vị trí các trưòng theo thứ tự từ trái sang phải tức

tương ứng
-Field1. Table 1 Field1. Table2
tương ứng
-Field2. Table 1 Field2. Table2 v..v..
Nếu 2 trường tương ứng không có kiểu dữ liệu thích hợp thì Mapinfo gán kết quả
bằng 0 với trường số và bằng trống với trường kí tự
Vì vậy cách tốt nhất trước khi sử dụng Append là thay đổi cấu trúc các trường cho
phù hợp với nhau bằng tuỳ chọn Modify Structure.

5. Sử dụng câu hỏi truy vấn CSDL ( Select SQL).
Khi ta cần lựa chọn 1 mhóm các đối tượng dựa vào thuộc tính của nó ta sử dụng
lệnh :
Vào Menu bar [Query] ----> SQL Select
Câu lệnh này sẽ lựa chọn các đối tượng thoả mãn điều kiện truy vấn tin theo yêu
cầu của người dùng (Hình 20).




Hình 20

Các lựa chọn bao gồm




35
- From Tables : Cho phép bạn đánh vào tên các Table sẽ tham gia vào lệnh
Select
- Where Condition : Cho phép bạn đánh vào điều kiện của câu lệnh Select gồm
. : Nhặt ra tên các trường tham gia trong câu lệnh Select
. : Biểu thức xác định quan hệ giữa các giá trị
trong câu lệnh Select gồm ( = ; = ; + ; - ; Within;
Contains; v..v)
. : Gồm các hàm chuẩn trong Mapinfo trả lại các giá
trị thuộc tính như :
- Trả về giá trị tuyệt đối của đối tượng.
.ABS[]
-Trả về diện tích của đối tượng.
.AREA[]
.CENTROIDX - Trả về giá trị tọa độ X của điểm tâm.
.CENTROIDY - Trả về giá trị tọa độ X của điểm tâm

- Trả lại mã ký tự của số nguyên
.CHAR$[]
tương ứng trong bảng mã . v..v..


- Group By Column : Nhóm dữ liệu theo cột được chỉ định (lấy một đại diện)
- Order By Column : Xắp xếp theo thứ tự tăng dần theo giá trị của trường.
- Into Table Name : Ngầm định là Selection, nếu bạn đánh vào đó 1 tên thì kết
quả truy vấn của ban sẽ được mang tên do ta đặt.
Nếu bạn muốn giữ lại những giá trị truy vấn của mình
nên đánh vào đó 1 tên nó sẽ rất dễ tìm khi muốn
thì
sử dụng lại kết quả đã truy vấn.
Thực hiện các thao tác trên xong bạn sẽ thu được 1 số đối tượng thoả mãn 1 số
tính chất nào đó. Muốn ghi nó ra 1 File mới thì hãy chọn chức năng Save Copy As để
ghi lại lựa chọn của mình.




36
Chương V : Làm việc với Layer Cosmetic
Layer Cosmetic là Layer tự động của Mapinfo, với 1 số thao tác như Create Label,
Create Thematic Map ..v..v, sẽ được ghi vào Layer Cosmetic.
Các đối tượng trong Layer Cosmetic chỉ mang chức năng hiển thi, nó không cho
phép ta Edit. Có thể ghi các đối tượng trong Layer Cosmetic thành 1 bản vẽ như trong
trường hợp Create Label v..v.
Trong phần này ta sẽ nói đến chức năng biến các đối tượng thuộc tính thành những
đối tượng hình học bằng tuỳ chọn Create Label.
Thực hiện tuần tự vào Menu bar [Map] ---> Layer Control chọn chức năng Label.
Nó cho phép ta lựa chọn các tuỳ chọn sau :
- Label With : Khai báo tạo Label với trường nào trong dữ liệu của bạn.
- Label Posision : Khai báo vị trí đặt Label, có tất cả 9 vị trí cho phép
bạn đặt Label
: Vì Label tạo ra sẽ có dạng Text nên cho phép khai báo Font
- Font
Text, Side Text, Color Text.
Sau đó ấn < OK > để thoát ra ngoài.
Muốn hiển thị Label vừa tạo đánh dấu vào tùy chọn Label.
Muốn ghi Label thành 1 Tables mới bạn chọn chức năng
[ Menu Bar\Map\Save Cosmetic Layer] để ghi ra File mình muốn.
Chọn [Menu Bar\Map\Clear Cosmetic Layer] sẽ xóa Label bạn vừa tạo.




37
Chương VI : Một số sử lý khác.

I. Tô mầu - Vẽ biểu đồ - Tô mầu Pattern
Tuỳ chọn Create Thematic Map cung cấp cho bạn 1 số chức năng để tô mầu, vẽ
biểu đồ, theo các giá trị của các trường thuộc tính.
Muốn sử dụng chức năng này vào Menu [Map] ---> Create Thematic Map
cho ta các tuỳ chọn sau
- Range - Tô mầu theo khoảng giá trị của trường chỉ định.
- Bar Chart - Hiển thị dạng đồ thị cột theo khoảng giá trị của trường chỉ định.
- Pre Chart - Hiển thị dạng đồ thị phần trăm (đồ thị tròn) theo
khoảng giá trị của trường chỉ định.
- Gradueted - Tô các vùng tròn độ lớn khác nhau theo khoảng giá trị
của trường chỉ định.
- Dot Density - Tô thành các vùng Pattern chấm tuỳ thuộc vào giá trị
của trường chỉ định
- Individual - Tô mầu từng đối tượng riêng biệt.


1- Sử dụng Create Thematic Map với tuỳ chọn Range
Chọn điều khoản Range sau đó chọn cho ta những chức năng chọn
.Table : Cho phép chọn Table làm việc.
. Field : Cho phép chỉ định trường sẽ làm việc. Nếu muốn sử dụng giá
trị của 1 biểu thức trường bạn chọn .
Sau đó chọn bạn sẽ thấy có 3 chức năng sau :
-Range : Bao gồm các thông số về số về
. : Cho phép khai báo số khoảng chia.
. : Gồm các thông số về cách chia
.: Tính theo tổng phần tử.
.: Tính theo giới hạn giá trị.
.: Cho phép đánh vào giá trị Max,
Min theo từng khoảng.
- Style : Chức năng này cho phép tạo ra các mầu vùng tô theo yêu cầu sử dụng.
Bạn hãy vào chức năng Style để lựa chọn giá trị mầu tô theo yêu cầu
của mình.
- Legend : Sử dụng chức năng Create Thematic Map thì khi hiển thị Mapinfo



38
luôn luôn hiển thị khung cửa sổ Legend. Vì vậy chức năng này cho phép đặt
kiểu Legend và Title của nó trong Window Legend.
Chọn xong các chức năng này và xác nhận nó bạn sẽ tô được mầu các đối
tượng bản vẽ theo thuộc tính của nó.
2- Sử dụng Create Thematic Map với tuỳ chọn khác
Bạn có thể làm tương tự với các thông số có dạng như trong tuỳ chọn Range

Sau khi sử dụng Create Thematic Map Mapinfo sẽ chuyển các đối tượng vừa tạo
ra vào Layer Cosmetic. Bạn có thể :
- Huỷ bỏ chúng bằng cách vào Layer Control đưa vệt sáng vào đó và
chọn chức năng .
- Cho phếp sửa đổi chúng bằng tuỳ chọn
Menu bar [Map] ----> Modify Thematic Map
cho phép thay đổi lại mầu, khoảng chia, legend của các đối tượng đã tạo ra.
Khi sử dụng Create Thematic Map kết quả chỉ cho phép hiển thị và in ra chứ không
thể Edit được. Khi bạn đóng bản vẽ lại Layer Cosmetic tự động bị xoá.
Muốn giữ lại chúng bạn có thể ghi vào Work Space bằng cách lệnh
Menu bar [File] ----> Save Work Space
lúc đó tất cả công việc bạn vừa làm sẽ được bảo toàn.

II. Tạo các điểm mỏ tự động ( Create Point )
Yêu cầu của dữ liệu đầu vào :
- Một File *.dbf phải có hai trường số chứ tọa độ của điểm (X,Y)
Các bước thực hiện :
Bước 1 : menu [File] ----> Open Table (Mở file *.dbf)
Bước 2 : menu [Table] ---> Create Points...




39
Hình 21



Bước 3 : Khai báo Project
Bước 4 : Khai báo cột chứa giá trị tọa độ X , Y
Bước 5 : Khai báo kiểu của Symbol (Xem chương III)
Kết thúc chọn OK.
Chú ý : Nếu trong quá trình Create Point có sai sót muốn làm lại ta phải ra
ngoài Mapinfo xóa bỏ các File cùng tên với file dbf có phần mở rộng là Tab và map.
Sau đó chạy lại lệnh Creat Point.

III- Các chức năng về View.
Trong Mapinfo cho phép 3 chức năng về View
- View Entire Layer
- Previous View
- Change View


1. Chức năng View Entire Layer.
Cho phép bạn xem toàn bộ đối tượng của một Layer bằng cách chọn
hoặc của tất cả đối tượng thuộc các tables đang mở bằng cách chọn .
2. Chức năng Previous View.
Chức năng này trả lại giá trị màn hình trước đó.
3. Chức năng Change View.
Cho phép thay đổi giá trị View của cửa sổ do người sử dụng đưa vào.
Nó được sử dụng nhiều khi làm việc với đối tượng là Text. Lý do vì các đối tượng
là Text khi thay đổi độ Zoom sẽ thay đổi Size của Font Text không theo độ Zoom của
màn hình. Do vậy, muốn in ra được 1 dòng Text đúng kích thước ban đầu bạn nên thay
đổi tỷ lệ Zomm về đúng tỉ lệ in ra sau đó hãy lựa chọn Text.
Cách thay đổi độ Zoom của bản vẽ về tỷ lệ in :
- View tất cả các đối tượng của bản vẽ (View Entire).
- Kích hoạt Layer cần đô (đặt ở chế độ Editable)
- Vào Tool Main, chọn để đo kích thước bản vẽ
- Đo độ dài thực tế bản vẽ.
- Lấy độ dài bản vẽ chia độ dài thực tế để ra được tỷ lệ Zoom.
- Vào để thay đổi lại tỷ lệ.


40
Ngoài ra trong Mapinfo còn có các chức năng Zoom ( + ), Zoom ( - ) để thay đổi độ
Zoom của 1 bản vẽ.




IV- Thay đổi Project của 1 bản vẽ.
Thay đổi Project của 1 bản vẽ bằng lựa chọn [ Menu Bar\Map\Option], trong mục
này có các chức năng sau :
- : Cho phép thay đổi lưới chiếu của 1 bản vẽ (Xem chương II).
- : Cho phép thay đổi đơn vị toạ độ của 1 bản vẽ.
- : Cho phép thay đổi đơn vị đo chiều dài của 1 bản vẽ.
- : Cho phép thay đổi đơn vị đo diện tích của 1 bản vẽ.
Tất cả các thay đổi này sẽ ảnh hưởng đến tất cả các hàm sử dụng đến các đơn vị
đo, như hàm đo diện tích (Area), hàm đo chiều dài ( Length).

V- Lấy thông tin bằng sử dụng Get Info
Sử dụng Get Info cho phép ta lấy ra được thuộc tính hình học của đối tượng như
toạ độ đường bao, loại đường, loại vùng, kiểu Text, Font Text.v.v.
Đầu tiên bạn đặt Layer chứa đối tượng ở chế độ kích hoạt, đánh dấu đối tượng,
sau đó vào [Menu Bar\Edit\Get Info] để hiển thị thuộc tính đối tượng.
Mọi thay đổi về toạ độ, thuộc tính hình học của đối tượng đều có thể thay đổi ở
đây bằng cách thay đổi Vetex hoặc các giá trị tương ứng

VI- Các thao tác với cửa sổ Layout Window & In ấn
Cửa sổ Layout Window cho phép đặt màn hình in của Mapinfo.
Các bước thực hiện
Bước 1 : Chọn máy In, Khai báo khổ giấy (nếu cần)
Bước 2 : Xác định phạm vi In trong cửa sổ hiện thời.
Trong trường hợp muốn in tất cả chọn View Entire Layer --> All
Bước 3 : Vào Menu bar [Window] ---> New Layout Window
(*) One Frame For Window: Chọn chức năng này cho phép tạo
thành 1 khung bao ngoài tất cả các đối tượng của 1 cửa
sổ.
( ) Frames For All Currently Open Window: Chọn chức năng này cho
phép tạo thành 1 số khung bao ngoài tất cả các đối tượng của
các cửa sổ được mở. Sử dụng chức năng này khi bạn muốn in 1 số
tờ bản đồ có toạ độ khác nhau trên cùng một tờ giấy, lúc đó bạn hãy mở mỗi
bản đồ trong một Window khác nhau và sử dụng chức năng này.


41
( ) No Frames : Tạo thành khung màn hình in cho phép vẽ đối tượng
muốn in vào đó
Trong cửa sổ Layout Window bạn có thể vẽ thêm một số đối tượng và không làm
ảnh hưởng đến đối tượng của bản vẽ. Ngược lại, nếu đã tạo cửa sổ Layout cho một
bản vẽ nào đó thì tất cả các thao tác tiếp theo trên bản vẽ ( sau khi đã tạo cửa sổ
Layout ) như chèn thêm Object, xoá Object đều được phản ánh lại trong cửa sổ
Layout.




Hình 22

Bước 4 : Thay đổi tỷ lệ In của bản vẽ
(Nhấn đúp chuột trái trên cửa sổ LayOut ---> Xem hình 22)
Khai báo tỷ lệ in tại Scale on Paper
Bước 5 : Đưa ra máy In
Vào menu [File] ----> Print
Ngoài ra làm việc với Layout Window còn cho phép thay đổi tỷ lệ hiển thị trên màn
hình (Zoom). Vào Menu bar [Layout] ---> Change Zoom, đặt lại số trang in cho màn
hình Layout bằng tuỳ chọn Menu bar [Layout] ---> Option
Chú ý : Khổ giấy trong cửa sổ Layout Window được quyết định trong cách đặt khổ
giấy trong Print Setup, vì vậy nếu bạn muốn thay đổi lại khổ giấy
Vào Menu bar [ File ] ----> Print Setup để đặt lại khổ giấy


Tóm lại : Trên đây là những thao tác đơn giản nhất của Mapinfo, nó vẫn chưa thực
sự được đâỳ đủ và có thể còn có nhiều khiếm khuyết và sai sót. Nếu còn chức năng
nào đó của Mapinfo chưa được đề cập ở đây bạn có thể tra nó trong Help.




42
Cuối cùng xin chúc các bạn làm tốt với phần mềm Mapinfo ./.

Hà nội, 6 - 8 - 1997




43
Đề thi vào lớp 10 môn Toán |  Đáp án đề thi tốt nghiệp |  Đề thi Đại học |  Đề thi thử đại học môn Hóa |  Mẫu đơn xin việc |  Bài tiểu luận mẫu |  Ôn thi cao học 2014 |  Nghiên cứu khoa học |  Lập kế hoạch kinh doanh |  Bảng cân đối kế toán |  Đề thi chứng chỉ Tin học |  Tư tưởng Hồ Chí Minh |  Đề thi chứng chỉ Tiếng anh
Theo dõi chúng tôi
Đồng bộ tài khoản