Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo

Chia sẻ: Trần Văn Hùng | Ngày: | Loại File: PDF | Số trang:43

0
897
lượt xem
365
download

Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Mapinfo là một hệ Gis hiện đang được sử dụng rộng rãi tại Việt Nam và một số nước k hác trên thế giới như Mỹ, Canada, Úc,... Hơn nữ, Mapinfo còn cung cấp một ngôn ngữ mapBasic giúp cho các lập trình viên có thể can thiệp vào CSDL cũng như phát triển các công cụ phục vụ cho mục đích của người dùng.

Chủ đề:
Lưu

Nội dung Text: Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo

  1. Cục địa chất và khoáng sản Việt Nam Viện Thông tin Tư liệu địa chất Giáo trình tin học địa chất hướng dẫn sử dụng MapInfo ( Dùng cho lớp tin học địa chất ) Người Viết : Tuấn Lê Anh Lê Minh Tuân Hà nội, 1997
  2. Mở đầu T rước sự phát triển ngày càng mạnh mẽ của tin học, và sự ứng dụng rộng rãi của công nghệ GIS (Geographic Information System) trong quản lý, sản xuất cũng như trong các nghành khác nhau đặc biệt là các nghành khoa học trái đất cho phép con người mô phỏng hình dáng bề mặt trái đất, quản lý tài nguyên thiên nhiên... cùng với các phép toán, các công cụ để phân tích, truy xuất, tìm kiếm dữ liệu một cách nhanh chóng hiệu quả, công cụ ngày càng khẳng định vị trí vững chắc của nó trong thế giới tin học. Trong nhiều năm qua, Cục Địa chất Việt nam đã chú ý đầu tư, xây dựng và phát triển các cơ sở tin học (con người, thiết bị ...) ngày càng trở nên mạnh mẽ hơn, trở thành công cụ hữu ích giúp cho các nhà địa chất trong công tác thu thập, phân tích, xử lý số liệu và phục vụ các cấp lãnh đạo trong việc quản lý tài nguyên khoáng sản. Tại Viện Thông tin Tư liệu Địa chất đã có những phần mềm GIS của các hãng nổi tiếng trên thế giới như MGE của InterGraph, ArcInfo của ESRI và MAPINFO của MapInfo Co... Trong những năm qua, bằng sự nỗ lực của tất cả các anh em làm tin học tại Viện trong công tác nghiên cứu, xây dựng các quy trình công nghệ và triển khai sản xuất đã bước đầu tạo ra được những sản phẩm có chất lượng. Ngày nay, công tác đào tạo GIS cũng như chuyển giao công nghệ trở thành một trong những mục tiêu đào tạo của Viện. Trong giáo trình này, chúng tôi cố gắng cung cấp những kiến thức cơ bản nhất về MAPINFO, một phần mềm GIS hiện đang được sử dụng phổ biến rộng rãi trong các nghành đặc biệt là nghành Địa chất Việt Nam cũng như trên thế giới. Chúng tôi cũng rất mong mọi người đọc qua đó sẽ nắm bắt được một cách nhìn tổng quan về các hệ GIS cũng như những kiến thức cơ sở của MAPINFO một cách hệ thống và sử dụng sao cho hiệu quả nhất trong công việc của mình. Để cho giáo trình ngày càng hoàn thiện hơn chúng tôi rất mong nhận được sự đóng góp quý báu của các bạn./. 2
  3. Tác giả. 3
  4. Mục lục - Chương I : Cấu trúc của phần mềm MapInfo và một số khái niệm cơ bản - Chương II : Tạo mới các Table, Làm việc với Project - Chương III : Làm việc với các đối tượng hình học trên Mapinfo. - Chương IV : Làm việc với các đối tượng thuộc tính trên Mapinfo. - Chương V : Làm việc với Layer Cosmetic. - Chương VI : Một số sử lý khác. 4
  5. Chương I : một số khái niệm cơ bản I - Khái niệm về GIS (Geographic Infomation System) Từ những sự phát triển mạnh mẽ trong tin học và những nhu cầu trong thực tế của các nghành khoa học trái đất về công tác thành lập và quản lý các lọai bản đồ trên máy tính, ngày nay trên thế giới đã có rất nhiều hệ phần mềm GIS được áp dụng và đưa vào thực tế phục vụ con người. GIS là một hệ phần mềm máy vi tính cung cấp các công cụ phục vụ cho việc thu thập, lưu trữ, phân tích, xử lý và hiển thị các thông tin địa lý. Các thông tin đó mô tả về hình dạng, vị trí cũng như các tính chất của các đối tượng trên trái đất trong một hệ tọa độ nào đó. Dữ liệu của một hệ GIS bao giờ cũng gồm hai lọai đó là : - Dữ liệu không gian - Dữ liệu thuộc tính MapInfo là một hệ GIS hiện đang được sử dụng rộng rãi tại Việt Nam và một số nước khác trên thế giới như Mỹ, Canada, úc ... Hơn nữa, Mapinfo còn cung cấp một ngôn ngữ MapBasic giúp cho các lập trình viên có thể can thiệp vào CSDL cũng như phát triển các công cụ phục cho mục đích của người dùng. MapInfo là một phần mềm có khả năng tương thích cao với các hệ GIS khác, cho phép ta có thể trao đổi dữ liệu giữa MapInfor với các hệ đó thông qua các dạng Format chuẩn như AutoCad DXF File (Data Exchange File). Hơn nữa, với phiên bản MapInfo Profesional 4.0 trở lên hãng đã cung cấp những khả năng mới đó là : - Cung cấp một Project mới đó là Gauss-Kruger (Pulkovo 1942) cho phép ta đưa các bản đồ vào MapInfo theo đúng hệ tọa độ Gauss (Hà nội 72) hiện đang dùng tại Việt nam. - ODBC (Open DataBase Conectivity) : Là chức năng cho phép người dùng có thể sử dụng môi trường ODBC để tạo các liên kết tới các CSDL lớn như MicroSoft Access, MicroSoft SQL Server, Oracle, Fopro for Windows ... - Cung cấp một thư viện hàm OLE giúp cho việc đưa các bản đồ được tạo ra trên MapInfo vào trang tài liệu của các hệ sọan thảo văn bản như Microsoft Word phục vụ cho công tác thành lập các bản thuyết minh báo cáo.... ii - Cấu trúc File dữ liệu của phần mềm MapInfo Một bản đồ trên MapInfo được gọi là một Table nó bao gồm ít nhất là 4 File cơ bản : *.Tab : File chứa các thông tin cơ bản về cấu trúc CSDL của một Table trên MapInfo 5
  6. *.Dat : Chứa các thông tin thuộc tính của các đối tượng đồ họa trong Table *.Map : Chứa các thông tin của các đối tượng đồ họa tring Table *.id : Chứa các thông tin cách sắp xếp, liên kết giữa các đối tượng đồ họa và các thông tin thuộc tính. Ngoài ra còn có thể có một số File phụ trợ khác như : *.Ind : Chứa các thông tin về thứ tự xắp xếp (Index) theo một giá trị trường được chỉ định trong CSDL *.Dbf : Chứa các thông tin của FoxPro, Dbase nếu như được mở trong MapInfo và các file này sẽ thay thế chức năng của file *.dat *.bmp: Chứa các thông tin về ảnh nếu được mở trong MapInfo 6
  7. Chương II: Làm việc với Table & Project I - Khái niệm về PROJECT. Cũng như tất cả các hệ GIS, trong MapInfo cũng có khái niệm về hệ tọa độ được gọi là Project cho phép ta thành lập, hiển thị các bản đồ trong hệ tọa độ thực của trái đất. Các thông tin về Project của bao gồm : Bán kính trục của Ellips, các thông số về sai số trong phép chiếu từ mặt cầu xuống mặtt phẳng, giá trị giới hạn của một múi tọa độ ... tất cả các thông số đó được Mapinfo lưu trong File “C:\MAPIN FO\MAPINFO.PRJ”. Tuỳ thuộc vào tính chất bản đồ mà ta chọn các hệ tọa độ khác nhau như Gauss, UTM, Longitude - Latitude, Non-Erath v..v.. II - Làm việc với table 1. Tạo một bản vẽ (Table) mới. Có 4 cách tạo được một bản vẽ mới trên Mapinfo : 1 - Tạo 1 bản vẽ mới bằng NEW TABLE 2 - IMPORT từ các file khác vào Mapinfo. 3 - Ghi 1 số đối tượng lựa chọn từ 1 Table, Query, Selection ra 1 bản vẽ mới bằng lệnh SAVE COPY AS. a - Tạo bản vẽ mới bằng lệnh NEW TABLE Các bước thực hiện : Bước 1 : Vào menu [ FILE ] ----> NEW TABLE ---> Xuất hiện Hình 1 Chức năng này cho phép tạo mới ban vẽ mới trên Mapinfo với cấu trúc do ta tự xây dựng (Xem hình 2). Hình 1 7
  8. - Chọn Open New Browser : Nếu muốn mở màn hình Brow để xem và nhập dữ liệu thuộc tính. - Chọn Open New Mapper : Nếu muốn mở một cửa sổ mới để vẽ - Chọn Add to Current Mapper : Nếu muốn hiển thị bản vẽ vào trong cửa sổ hiện thời trên màn hình. Để chọn các thuộc tính trên có thể dùng chuột hoặc bằng bàn phím Sau đó chọn : Create... nếu muốn tạo bản vẽ mới (chuyển sang bước 2) hoặc Cancel nếu muốn thóat khỏi lệnh này Bước 2 : Khai báo cấu trúc CSDL và chọn Project cho bản vẽ (Xem Hình 2) Hình 2 Tạo cấu trúc cho CSDL : + FIELD NAME : Khai báo tên trường trong CSDL. : Cho phép đặt kiểu trường gồm các kiểu + FIELD TYPE - CHARACTER : Trường có kiểu ký tự : Trường có kiểu số nguyên - INTEGER : Trường có kiểu số thực - FLOAD : Trường có kiểu Logic, v...v.. - LOGICAL 8
  9. + LENGTH : Đặt độ dài lớn nhất cho các giá trị của trường. + DECIMAL : Đặt độ dài lớn nhất cho các giá trị thập phân của trường và tuỳ chọn này chỉ áp dụng cho trường số. - Khi muốn thêm một trường sử dụng : ADD FIELD - Khi muốn xoá một trường sử dụng : REMOVE FIELD Khai báo Project cho bản vẽ : Hình 3 Project ngầm định của MapInfo là kinh vĩ độ (Long/Lat) ta phải chọn Project thích hợp cho bản vẽ như : - Bản vẽ sử dụng hệ tọa độ GAUSS (cho BĐ thuộc lãnh thổ Việt nam) chọn: -> Category : Gauss-Kruger (Pulkovo 1942) -> Category member : GK Zone 17 (96o --> 102 o) GK Zone 18 (102 o --> 108 o) GK Zone 19 (108 o --> 114 o) - Bản vẽ sử dụng hệ tọa độ UTM (cho BĐ thuộc lãnh thổ Việt nam) chọn: -> Category : Universal Transverse Mercato (WGS 84) -> Category member : GK Zone 47 (96o --> 102 o) Northern GK Zone 48 (102 o --> 108 o) Northern GK Zone 49 (108 o --> 114 o) Northern - Bản vẽ sử dụng hệ tọa độ vuông góc chọn: 9
  10. -> Category : Non-Earth -> Category member : tùy chọn đơn vị khoảng cách (mét,km,fit...) -> Đối với bản vẽ trong hệ tọa độ Non-Earth ta phải khai báo giới hạn của bản vẽ Hình 4 Sau khi khai báo cấu trúc CSDL cũng như Project chọn Create. để tạo bản vẽ mới - Chú ý : Một Table trên MapInfo sẽ phải có ít nhất 1 trường trong CSDL b - Tạo một Table bằng lệnh IMPORT Sử dụng lệnh IMPORT để biến đổi các dưới dạng các format chuẩn như : *.DXF, *.MIF, *.MMI, *.MBI,*.IMG thành một Table của Mapinfo (Hình 5) Hình 5 10
  11. Trong đó, các file *.DXF (Data Exchange File) là một trong những chuẩn mực của hãng AutoDesk mà các hệ CAD và GIS dùng để trao đổi dữ liệu với nhau. Các bước thực hiện : Bước 1 : Vào menu [TAB] --> Import Bước 2 : Chọn kiểu của File (VD : AutoCad DXF) Bước 3 : Chọn File cần Import (*.Dxf) --> Chọn nút Import Bước 4 : Khai báo Project (xem trên) --> Chọn nút Projection... Hình 6 Bước 5 : Khai báo thông tin chuyển đổi tọa độ từ File DXF vào Mapinfo Chọn nút: Set Transfomation... 11
  12. Hình 7 Chú ý : - Khi bạn đã đặt tương quan toạ độ bằng SET thì tất cả các đối tượng sẽ được tính lại TRANFOMATION theo tỉ lệ và giá trị toạ độ mới. - Khi khai báo chuyển đổi toạ độ bằng SET TRANFOMATION 2 điểm Point1 và Point2 trong Mapinfo phải là các giá trị hợp thì lệ tức là giá trị đó phải nằm trong khoảng min/max được trong File Mapinfo.PRJ. Nếu có đối tượng nằm khai báo ngoài khoảng min/max thì đối tượng đó sẽ không được Import nhận được thông báo lỗi. vào Mapinfo và Sau khi khai báo xong chọn OK để trở về màn hình trước (Hình 6) Bước 6 : Tại Hình 6 chọn OK để thực hiện công việc Import Chú ý : Trong trường hợp Import một file *.mif là một dạng dữ liệu chuẩn của Mapinfo để chuyển đổi dữ liệu từ Mapifo for DOS sang Mapinfo Window thì ta không cần phải thực hiện các bước 4,5,6 vì trực for tiếp trong file *.mif đã chứa các thông tin về Project nên bạn chỉ cần File muốn tạo và ấn sẽ tạo được một bản vẽ mới đánh vào tên trên Mapinfo c - Tạo 1 bản vẽ mới bằng lệnh SAVE COPY AS Vào Menu [File] ---> chọn SAVE COPY AS Lệnh SAVE COPY AS có thể tạo ra một File mới mà dữ liệu được lấy ra từ - Table đang mở - Query ( tạo Query bằng lệnh SQL Select sẽ nói đến ở chương III). - Selection : là các đối tượng đang được chọn. Lệnh này sẽ tự động sao lưu cấu trúc dữ liệu và thuộc tính của các đối tượng ra File mới và trong chức năng này còn cho phép ta đặt lại thuộc tính Project của đối tượng bằng lựa chọn Project. 2. Mở một Table đã tồn tại (Hình 8) Trong MapInfo cho phép mở nhiều loại file khác nhau như : *.Tab : Là file do Mapinfo tạo ra *.DBF : Là các file được tạo ra trên FOXPRO hoặc DBASE - Khi mở các file *.Dbf MapInfo sẽ tạo ra một file có cùng tên và phần mở rộng là "tab" chứa cấu trúc của file DBF. Hơn nữa, khi mở file DBF Mapinfo sẽ lọai bỏ các trường : MEMO,PICTURE,GENERAL 12
  13. *.TXT : (Delimited ASCII) là các file text có các cột được phân cách bởi một kí tự bất kì hoặc dấu Tab. *.wk? : LOTUS 1-2-3 là các file dạng bảng tính trên phần mềm Lotus *.xls : Là file dạng bảng tính trên phần mềm Microsoft Excel Bitmap : Là các file ảnh có phần mở rộng *.gif, *.bmp,*.pcx ... Các bước thực hiện : Bước 1 : Vào Menu [File] ---> Chọn Open (xem hình 8) Bước 2 : Chọn kiểu File --> vào List File of Type Bước 3 : Chọn tên File (tùy từng trường hợp cụ thể sẽ phải khai báo các thông số khác nhau) ---> Kết thúc : Chọn nút OK. Hình 8 3. Lưu một Table Bước 1 : Vào Menu [File]-->Chọn SAVE Tables --> Xuất hiện danh sách các Table đã bị sửa đổi cần lưu 13
  14. Hình 9 Bước 2 : Chọn Table hoặc dùng phím Shift or Ctrl để chọn một nhóm các File Sau đó : Chọn nút Save để thực hiện lệnh. 4. Đóng các Table đang được mở. Vào menu [File] --> Chọn Close Table nếu muốn đóng một table hoặc chọn Close All nếu muốn đóng tất cả các Table đang được mở. 5. Làm việc với File WorkSpace File WorkSpace có phần mở rộng là *.WOR là một file kịch bản của MapInfo dạng ASCII ta có thể dùng các phần mềm sọan thảo để thay đổi, sửa chữa. Trong File WorkSpace chứa các thông tin về các Table đang được mở khi tạo ra File đó như : Tên file (đầy đủ đường dẫn nếu nằm ở thư mục khác với file *.wor), bí danh, hiện trạng của màn hình (vị trí, kích cỡ,tỷ lệ zoom ..).... và các lệnh để cho Mapinfo thực hiện. Ví dụ : !Workspace !Version 400 !Charset WindowsLatin1 Open Table "vnmap" As VNMAP Interactive Open Table "color_vn" As COLOR_VN Interactive Set Window Info Position (0.239583,0.864583) Units "in" Width 2.39583 Units "in" Height 3.64583 Units "in" Font ("MS Sans Serif",0,8,0) Open Window Info Map From VNMAP,COLOR_VN Position (0.0520833,0.0520833) Units "in" Width 3.29167 Units "in" Height 2.04167 Units "in" 14
  15. Set Window FrontWindow() ScrollBars Off Autoscroll On Set Map CoordSys Earth Projection 1, 1001 Center (101.0980608,16.52158878) Zoom 3198.42992 Units "km" Preserve Zoom Display Zoom XY Units "degree" Distance Units "km" Area Units "sq km" Set Map Layer 1 Display Graphic Selectable Off Label Line None Position Center Font ("Arial",0,9,0) Pen (1,2,0) With fcode Parallel On Auto Off Overlap Off Duplicates Off Offset 2 Visibility On Layer 2 Display Graphic Selectable Off Label Line None Position Center Font (".VnBlackH",1,12,0) Pen (1,2,0) With TINH_THANHPHO Parallel On Auto On Overlap Off Duplicates On Offset 2 Visibility Zoom (110, 780) Units "km" Object 157 Anchor (105.830895483766,21.138336088167) Object 64 Anchor (105.549182986651,19.918577057342) Object 2 Anchor (103.060009278429,22.146572108219) Set Window Frontwindow() Max ----------------- - Tạo một File WorkSpace : Vào menu [File] ---> Save WorkSpace --> Đặt tên File - Mở một File WorkSpace :Vào menu [File] --->Open WorkSpace-->Chọn File *.wor Chú ý : Khi ta thay đổi vị trí của các File mà file *.wor gọi đến --> Mapinfo sẽ báo không tìm thấy File . Do vậy nếu muốn chạy được ta có thể chữa trực thông tiếp đường dẫn tới Table trong file *.wor 15
  16. Chương III : Làm việc với các đối tượng Đồ họa Các đối tượng trên Mapinfo được lưu giữ thành 2 phần : - Các đối tượng hình học (Object) : Là các đối tượng hiển thị trên bản vẽ như LINE, PLINE, TEXT, REGION, RECTANGULAR,SYMBOL. - Các đối tượng thuộc tính (Attribute): Là giá trị thuộc tính của các đối tượng đồ họa được lưu giữ trong CSDL. I - Một số khái niệm 1- Khái niệm về đối tượng hình học Các đối tượng hình học trong Mapinfo bao gồm : Là đoạn thẳng có hai đỉnh. - LINE : Là đường thẳng đi qua n đỉnh ( n >= 2). - PLINE : Là hình Ellipse với 1 tâm và 2 bán kính. - ELLIPSE Trong trường hợp hai bán kính bằng nhau ta được hình tròn. - SYMBOL : Là ký hiệu được dán vào 1 điểm nào đó của bản vẽ. : Là Pline khép kín có chứa thuộc tính về vùng - REGION - RECTANG : Là hình chữ nhật, hoặc hình vuông : Là các đối tượng Text hiển thị trên bản vẽ - TEXT 2- Khái niệm về thuộc tính hình học Trong mỗi một đối tượng hình học có chứa các thuộc tính hình học. Thuộc tính hình học của đối tượng bao gồm mầu đường bao, mầu nền, loại đường bao, kiểu chữ v..v Mỗi loại đối tượng hình học khác nhau sẽ có một số thuộc tính khác nhau : Có thuộc tính - LINE và PLINE • Mầu đường ( Line color ) • Loại đường ( Line style) • Độ dày đường ( Line with) • Độ dài đường (Length) 16
  17. - ELLIPSE, REGION và RECTANG : Ngoài các thuộc tính của đường bao giống Line và Pline còn có thuộc tính về vùng như : • Mầu vùng ( Fill color) • Kiểu nền (Pattern) • Diện tích vùng ( Area square) • Chu vi (Primeter) - SYMBOL : Có các thuộc tính • Loại Symbol (Symbol Style) • Cỡ Symbol (Size) • Tọa độ (Coordinate) • Màu sắc (Color) : Có các thuộc tính -TEXT • Kiểu chữ (Text font) • Cỡ chữ (Text Size) • Màu sắc (Color) 3- Khái niệm về Layer Cũng như các hệ GIS khác, trên Mapinfo ta có thể mở được nhiều file bản đồ cùng một lúc (*.tab) nhằm phục vụ mục đích chồng ghép các lớp bản đồ khác nhau để có được một bản đồ chuyên đề theo theo yêu cầu của người dùng tin. Đối với GIS việc phân loại và tách các đối tượng trong một hệ cơ sở dữ liệu thành các lớp hay, nói riêng trong Mapinfo là các table (*.tab) là rất cần thiết. Việc phân loại thông tin theo từng lớp như thế nào, nhằm mục đích gì là hoàn toàn phụ thuộc vào yêu cầu của mức độ và quy mô quản lý cũng như các kết quả đưa ra của người dùng. Ví dụ như trên Mapinfo, đối với các bản đồ địa chất ta có thể phân chia thành các lớp đối tượng khác nhau như: - Lớp các bản đồ : Sông, suối - Lớp các bản đồ : Giao thông (đương bộ, đường sắt,đường mòn..) - Lớp các bản đồ : Địa giới, Địa danh - Lớp các bản đồ : Đường đồng mức - Lớp các bản đồ : Ranh giới địa chất - Lớp các bản đồ : Tuổi, kí hiệu địa chất ................ 17
  18. Với việc phân chia thành các lớp dựa trên cơ sở phân loại nào đó giúp cho việc quản lý chặt chẽ hơn, cũng như tạo điều kiện thuận tiện trong việc sửa chữa và cập nhật về sau. Trên Mapinfo, mỗi Table được mở sẽ được gọi là một Lớp (Layer) trong một cửa sổ (Window). Layer trong Mapinfo có tên trùng với tên file *.tab mà bạn mở. Trường hợp đặc biệt khi bạn mở cùng một file nhiều lần thì sau mỗi lần mở Mapinfo sẽ tự động thêm các số hiệu lần mở vào sau tên Layer của bạn. Ngoài các Layer do người dùng mở trong Mapinfo còn có một Layer đặc biệt có tên “Layer Cosmetic” sẽ được nói đến trong chương V. Để xem các Layer đã được mở trong một cửa sổ, hoặc thay đổi thứ tự, thuộc tính thể hiện trên màn hình của một Layer nào đó ta thực hiện các bước sau : Bước 1 : Vào menu [Map] --> chọn Layer Control Bước 2 : Thực hiện các thay đổi cần thiết (xem hình 10) Hình 10 - Lựa chọn Visiable : Có hiện Layer được chọn hay không Trong đó : - Lựa chọn Editable : Cho phép thêm mới, sửa chữa các đối tượng trên Layer được đánh dấu. Chú ý : Tại một thời điểm Mapinfo chỉ cho phép đặt một Layer ở chế độ Editable. - Lựa chọn Selectable : Cho phép chọn các đối tượng trên Layer hiện thời hay không. 18
  19. - Lựa chọn Label : Hiện thị nhãn (Label) của các đối tượng trong Layer được chọn - Nút Add : Thêm một Layer (một Table đã được mở) vào cửa sổ hiện thời. - Nút Remove : Loại bỏ không hiển thi Layer được chỉ định ra khỏi của sổ hiện thời nhưng chưa đóng Table đó. - Nút Up/Down : Dịch chuyển Layer được chọn lên trên/xuống dưới để xắp xếp thứ tự xuất hiện trên màn hình của các Layer. - Nút Display : Thay đổi cách thể hiện trên màn hình của các Layer như giới hạn phạm vi hiển thị trên màn hình(Zoom Max/Zoom Min) ... - Nút Label : Tạo nhãn cho các đối tượng của Layer được chọn theo một trường mà người dùng chỉ định - Nút Thematic : Thay đổi cách hiển thị các bản đồ chủ đề được tạo ra do lệnh: Creat Thematic Map. II. TạO MớI các đối tượng Đồ HọA Để thuận tiện cho người dùng Mapinfo cũng đưa ra hai hộp công cụ là : Main và Drawing (Xem Hình 11) Hình 11 19
  20. 1a. Tạo mới một đối tượng Text Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer sẽ chứa đối tượng được tạo mới và đặt ở chế độ EditAble) Bước 2 : Vào Menu [Options] --> chọn Text Style Khai báo : Kiểu chữ (Font), Cỡ chữ (Size), Màu sắc ... nếu cần Bước 3 : Chọn biểu tượng Text ( A ) trong hộp công cụ Drawing Bước 4 : Chọn vị trí con trỏ (điểm bắt đầu của Text) Bước 5 : Nhập giá trị của Text, để kết thúc nhấn phím trái chuột hoặc tắt nút tạo Text mới ( A ) trong hộp công cụ Drawing 1b. Thay đổi thuộc tính của một đối tượng Text Bước 1 : Vào menu [Map] --> chọn Layer Control (Chọn Layer chứa đối tượng sẽ được sửa chữa và đặt ở chế độ EditAble) Bước 2 : Nhấn đúp phím trái chuột lên đối tượng cần sửa Hoặc lựa chọn đối tượng cần sửa --> Vào menu [Edit] --> Get info ----> Cho ta hình 12 Hình 12 Tại hộp đối thoại này, ta có thể thay đổi nội dung, kiểu, góc quay... của text 20
Đồng bộ tài khoản