Giáo trình Tin học văn phòng Phần 3: Chương trình bảng tính điện tử Microsoft Excel

Chia sẻ: Lê Thế Vinh | Ngày: | Loại File: PDF | Số trang:38

0
822
lượt xem
492
download

Giáo trình Tin học văn phòng Phần 3: Chương trình bảng tính điện tử Microsoft Excel

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Giáo trình Tin học văn phòng Phần 3 "Chương trình bảng tính điện tử Microsoft Excel" nhằm cung cấp các kiến thức về: Giới thiệu; soạn thảo, định dạng và in ấn bảng tính; phân tích dữ liệu; sử dụng hiệu quả MS Excel. Hi vọng đây sẽ tài liệu hữu ích trong việc giúp các bạn học Excel.

Chủ đề:
Lưu

Nội dung Text: Giáo trình Tin học văn phòng Phần 3: Chương trình bảng tính điện tử Microsoft Excel

  1. SỞ KHOA HỌC, CÔNG NGHỆ & MÔI TRƯỜNG NGHỆ AN TRUNG TÂM CÔNG NGHỆ THÔNGTIN Lê Thế Vinh GÍAO TRÌNH TIN HỌC VĂN PHÒNG Phần 3 Chương Trình bảng Tính Điện Tử Microsoft excel
  2. SỞ KHOA HỌC, CÔNG NGHỆ & MÔI TRƯỜNG NGHỆ AN TRUNG TÂM CÔNG NGHỆ THÔNG TIN Lê Thế Vinh GIÁO TRÌNH TIN HỌC VĂN PHÒNG Phần 3: Chương trình bảng tính điện tử Microsoft Excel Vinh, 12/2002
  3. LTVinh Trung tâm CNTT Nghệ an MỤC LỤC Mục lục .............................................................................................................2 I. Giới thiệu.......................................................................................................3 I.1. Vào ra Excel và các thành phần trong cửa sổ chương trình.......................3 I.2. Tạo, mở và lưu một file..............................................................................4 I.3. Làm việc với các Bảng tính và file dữ liệu ................................................5 II. Soạn thảo, định dạng và in ấn Bảng tính .....................................................7 II.1. Soạn thảo...................................................................................................7 II.2. Cách quản lý dữ liệu của Excel: địa chỉ, kiểu dữ liệu...............................10 II.3. Làm việc với biểu đồ và đồ thị .................................................................11 II.4. Định dạng bảng tính..................................................................................14 II.5. In bảng tính ...............................................................................................15 III. Phân tích dữ liệu .........................................................................................18 III.1. Sử dụng các hàm......................................................................................18 III.2. Sử dụng các công cụ................................................................................28 IV. Sử dụng hiệu quả MS Excel .......................................................................36 Bài tập...............................................................................................................37 Tài liệu tham khảo ...........................................................................................38 2 Giáo trình Tin học văn phòng – MS Excel
  4. LTVinh Trung tâm CNTT Nghệ an I. Giới thiệu Microsoft Excel cho phép lưu trữ dữ liệu ở dạng bảng (gồm nhiều ô: cells). Nó cung cấp cho người dùng các công cụ xử lý, phân tích số liệu. Việc minh hoạ số liệu bằng biểu đồ và đồ thị trong Excel giúp cho người dùng quan sát kết quả một cách trực quan và dễ hiểu. Ngoài ra, phần mềm này còn cung cấp nhiều dịch vụ và tiện ích khác. Hiện nay Excel đã được sử dụng hiệu quả trong nhiều lĩnh vực như công tác văn phòng, kế toán, quản lý hàng hoá, điểm thi của học sinh và nhiều thông tin khác. I.1. Vào ra Excel và các thành phần trong cửa sổ chương trình + Khởi động chương trình Microsoft Excel (gọi tắt là Excel). ◄ 1. Chọn nút Start, chỉ vào Programs và chọn Microsoft Excel; Cửa sổ chương trình xuất hiện. + Các thành phần trong cửa sổ chương trình Excel. ◄ 2. Cửa sổ chương trình Excel. Theo thứ tự từ trên xuống dưới là: Thanh tiêu đề (cuối thanh này có các nút lệnh: thu nhỏ, phóng to và đóng cửa sổ), Thanh menu: chứa các menu như: File, Edit, View, v.v, Hai thanh công cụ: chứa các biểu tượng: New, Open, Save, v.v, 3 Giáo trình Tin học văn phòng – MS Excel
  5. LTVinh Trung tâm CNTT Nghệ an Thanh chỉ địa chỉ và nội dung của ô được chọn: cho biết địa chỉ ô đang chọn, cho phép nhập dữ liệu số, chuỗi, ngày tháng hoặc một công thức vào ô này, bảng tính gồm nhiều ô: gồm tên hàng 1,2,3 ... và tên cột A,B,C, ... ví dụ: ô đang chọn là B2, Tên các bảng tính: sheet1, sheet2,... ta có thể làm việc trong các bảng tính này, Thanh cuốn ngang (thanh cuốn dọc ở mép ngoài bên phải cửa sổ, bảng tính có số lượng ô rất lớn nên có nhiều ô bị khuất để xem các ô này ta dùng các thanh cuốn) Và thanh trạng thái: hiển thị trạng thái của chương trình ví dụ: chữ NUM cho biết nút Num Lock đang bật (đèn LED Num Lock trên bàn phím sáng) như vậy ta có thể sử dụng được nhóm các phím số ở góc bên phải bàn phím. Tham khảo thêm mục II.2 “Làm việc với các chương trình, file và thư mục” trong giáo trình “Hệ điều hành Windows” về các thành của cửa sổ. Khi rê chuột đến các nút trên thanh công cụ thì nhãn của nút đó được hiện ra, trên hình vẽ là nút save (lưu dữ liệu trong bảng vào file). ◄3. Chọn menu File\Save Để lưu dữ liệu vào file, ta có thể thực hiện bằng 3 cách: + chọn menu File\Save + chọn nút save trên thanh công cụ + ấn tổ hợp phím Ctrl+S Các công việc khác cũng có tương ứng 3 cách làm như vậy. + Thoát khỏi chương trình Excel Chọn menu: File\Exit hoặc chọn nút Close (nút có dấu x) ở góc trên bên phải cửa sổ chương trình. I.2. Tạo, mở và lưu một file + Tạo một file tài liệu mới trong Excel Trong menu File chọn New, cửa sổ new xuất hiện ◄ 1. Để tạo một file mới, chọn táp General và sau đó nháy đúp chuột vào biểu tượng Workbook Để tạo file theo mẫu có sẵn, chọn táp Spreadsheet Solution, chọn mẫu cần tạo (giao diện của mẫu sẽ hiện ra trong khung Preview) và chọn OK. 4 Giáo trình Tin học văn phòng – MS Excel
  6. LTVinh Trung tâm CNTT Nghệ an Một tài liệu được mở ra. Trong tài liệu này này ta gõ thử vào các ô một chữ, số rồi lưu dữ liệu vừa gõ vào file. + Lưu dữ liệu vào file Để lưu dữ liệu vào file ta chọn menu: File\Save như hình 3, mục I.1. Cửa sổ Save as hiện ra. ◄2. Chọn thư mục nơi lưu dữ file gõ tên file vào ô trắng có tiêu đề File name chọn nút Save để lưu. + Mở một file Ta chọn menu File\Open, cửa sổ Open hiện ra. ◄ 3. Tìm và chọn file cần mở Chọn nút Open để mở file này I.3. Làm việc với các Bảng tính và file tài liệu Trong Excel, một tài liệu (workbook) là một file trong đó ta thực hiện các công việc như nhập, phân tích, xử lý và lưu trữ dữ liệu. Một tài liệu có thể chứa nhiều bảng, giúp cho ta có thể tổ chức các thông tin liên quan khác nhau chỉ trong một file. Dùng bảng tính (worksheet) để liệt kê và phân tích dữ liệu. Ta có thể nhập vào, sữa đổi dữ liệu trên các bảng tính và thực hiện tính toán trên các bảng tính này. Tên của các bảng tính xuất hiện trên các táp ở phía dưới cửa sổ workbook. Để chuyển từ bảng tính này sang bảng tính khác ta chọn vào táp tương ứng. Tên của bảng tính đang kích hoạt được tô đậm. + Trong một bảng tính (xem hình 2 mục I.1) để xem các ô bị khuất ta dùng các thanh cuốn ngang, thanh cuốn dọc hoặc phím Page Up, Page Down, các phím mũi tên. 5 Giáo trình Tin học văn phòng – MS Excel
  7. LTVinh Trung tâm CNTT Nghệ an + Quản lý bảng tính a) Chọn bảng tính Khi chọn một bảng ta nháy chuột vào táp của bảng đó Khi chọn nhiều bảng tính kế tiếp nhau ta ấn đồng thời phím Shift trong khi chọn bảng đầu tiên và bảng cuối cùng. Và thay việc ấn phím Shift bằng ấn phím Ctrl để chọn các bảng tính không kế tiếp nhau. b) Chèn thêm một bảng tính: chọn menu Insert\Worksheet c) Sao chép hoặc di chuyển bảng tính: Ta có thể sao chép hoặc di chuyển bảng tính từ một file này sang file khác, để thực hiện việc này trước hết ta mở các file này ra. - Trong file nguồn chọn bảng tính cần thực hiện - Chọn menu: Edit\Move or Copy Sheet, cửa sổ Move or Copy xuất hiện, ở đây: - Trong hộp To book, chọn file đích (file sẽ sao chép hoặc di chuyển bảng tới); trong hộp Before sheet chọn bảng tính mà vị trí trước nó sẽ là bảng tính sắp sao chép hoặc di chuyển tới. Nếu muốn bảng tính mới nằm ở cuối cùng của tài liệu thì chọn (move to end). - Để sao chép thì chọn vào hộp kiểm Create a copy, nếu hộp này không được chọn có nghĩa là thực hiện di chuyển. d) Xoá một bảng tính - Chọn bảng tính cần xoá - Chọn menu: Edit\Delete sheet. - Chọn OK để chấp nhận xoá e) Đổi tên bảng tính - Nháy đúp chuột vào táp của bảng tính cần đổi tên - Gõ vào tên mới, kết thúc bằng ấn phím Enter Các công việc trên có thể thực hiện nhanh chóng bằng cách nháy chuột phải lên táp của bảng tính (một hoặc nhiều bảng đã được lựa chọn). ◄ 1. Nháy chuột phải vào táp của bảng tính (sheet1). Ở đây có thể thực hiện việc chèn thêm, xoá, đổi tên, sao chép hoặc di chuyển bảng tính, chọn tất cả các bảng tính và xem mã lệnh Visual Basic của file tài liệu 6 Giáo trình Tin học văn phòng – MS Excel
  8. LTVinh Trung tâm CNTT Nghệ an II. Soạn thảo, định dạng và in ấn Bảng tính Thứ tự các công việc thực hiện các công việc để lưu trữ, quản lý, phân tích dữ liệu và in ra các kết quả báo cáo gồm: nhập dữ liệu vào máy, lưu dữ liệu lên đĩa cứng bằng chương trình Excel, xử lý dữ liệu đưa ra các kết quả, định dạng dữ liệu cần in ra, minh trang và in ra giấy. Trong đó việc xử lý và phân tích số liệu cần nhiều chức năng và phức tạp nên được tách ra thành một phần riêng (phần III). Trong phần này chúng tôi trình bày cách soạn thảo, định dạng dữ liệu, định dạng bảng tính, vẽ và hiển thị dữ liệu bằng biểu đồ và in bảng tính ra giấy. II.1. Soạn thảo + Cách nhập dữ liệu Nhập dữ liệu, chọn ô cần nhập, nhập dữ liệu vào từ bàn phím (theo quy ước kiểu dữ liệu), kết thúc việc nhập bằng cách gõ phím Enter hoặc chuyển đi ô khác. Sữa dữ liệu trong của ô, chọn ô cần sửa gõ phím F2, dùng phím mũi tên (hoặc chuột) đưa con trỏ (dấu vạch đứng) đến vị trí cần sửa và thực hiện việc sửa, muốn xoá một ký tự dùng phím Delete để xoá ký tự bên phải con trỏ và phím Backspace đểxoá ký tự bên trái con trỏ. Ghi đè dữ liệu mới vào một ô: thực hiện như nhập dữ liệu. Cách di chuyển con trỏ: dùng các phím: (sang trái một cột), (lên một dòng), (sang phải một cột), (xuống một dòng); Alt + Page Up (sang trái một trang), Alt + Page Down (sang phải một trang), Page Up (lên trên một trang), Page Down (xuống dưới một trang). Home (về đầu một dòng), Ctrl+Home (về đầu trang: ô A1). dùng chuột: Nháy chuột vào ô muốn đến. Nhập hàm vào một ô: bắt đầu là dấu bằng “=”, tiếp theo là tên hàm, tiếp theo là các tham số của hàm (nằm trong ngoặc đơn( ... )) và kết thúc bằng gõ phím Enter. Ví dụ: trong ô B2 ta nhập hàm tính tổng cho các ô A1 đến A10 thì viết: =sum(a1:a10) và gõ phím Enter (); Sử dụng dùng công cụ tự động điền dữ liệu vào các ô dựa vào dữ liệu của các ô bên cạnh (Automatically fill in data based on adjacent cells- Fill handle) ◄1. Sử dụng Fill handle điền dữ liệu dự vào các ô dựa vào dữ liệu của các ô bên cạnh. Ví dụ: Ta điền số 1 vào ô A1, số 2 vào ô A2, sau đó chọn hai ô này, rê chuột đến Fill handle (ở góc dưới bên phải ô A2) con chuột biến thành dấu cộng (+), thí ấn và rê chuột đến ô A3, A4 v.v thì Excel căn cứ vào giá trị ở hai ô A1, A2 để điền tiếp giá trị vào các ô tiếp theo. Kết quả số 3 được điền vào ô A3 (hình vẽ). Tương tự cho các ví dụ điền thứ hai (Mon) vào ô B1, điền tháng giêng January (viết tắt Jan) vào ô C5. Sau đó thực hiện điền dữ liệu tự động kết quả sẽ được như hình vẽ. Sử dụng công cụ này đặc biệt hiệu quả khi điền tự động các công thức. + Sao chép, di chuyển, xoá dữ liệu Thực hiện việc sao chép, di chuyển, xoá dữ liệu trong Excel cũng tương tự như phần “Soạn thảo một văn bản đơn giản trong Windows” ở mục II.2 giáo trình “Hệ điều hành Windows”. 7 Giáo trình Tin học văn phòng – MS Excel
  9. LTVinh Trung tâm CNTT Nghệ an Bước 1: Chọn (bôi đen) dữ liệu cần thực hiện Bước 2: Để sao chép ta chọn menu: Edit\Copy Hoặc ấn: Ctrl + C Để di chuyển ta chọn menu: Edit\Cut Hoặc ấn: Ctrl + X Để xoá ta chọn menu: Edit\Clear\Contents Hoặc ấn: Delete Bước 3: Để sao chép hoặc di chuyển dữ liệu ta chỉ ra vị trí đưa dữ liệu đến và chọn menu: Edit\Paste Hoặc ấn: Ctrl + V Tuy nhiên ta có thể thực hiện việc này một cách nhanh chong từ thanh công cụ. + Thêm bớt ô, hàng, hoặc cột Để chèn thêm một hàng hoặc cột ta thực hiện như sau: 1) đánh dấu hàng (cột) nơi ta muốn hàng (cột) mới sẽ xuất hiện; 2) chọn menu Insert\Row để chèn thêm hàng, Insert\Column để chèn thêm cột. Để xoá bớt một hàng hoặc một cột, trước tiên ta chọn nó, sau đó chọn menu: Edit\Delete. Khi thực hiện thêm hoặc bớt một ô vào bảng tính. Hộp thoại Insert hoặc Delete xuất hiện. Trong đó có các lựa chọn sau: ◄ 2. Hộp thoại Insert và hộp thoại Delete Ý nghĩa của từng lựa chọn: Shift Cells right (left): đẩy ô hiện tại sang phải (trái) Shift Cells down (up): đẩy ô hiện tại xuống dưới (lên trên) Entire row: Chèn thêm (huỷ bỏ) một hàng vào vị trí hiện tại Entire column: Chèn thêm (huỷ bỏ) một cột vào vị trí hiện tại Để thêm một ô vào bảng tính ta thực hiện như sau: 1) đánh dấu vị trí ô nơi cần chèn thêm ô mới; 2) chọn menu: Insert\Cells, cửa sổ Insert xuất hiện; chọn một trong 4 lựa chọn (tuỳ vào mục đích) và nháy chuột vào nút OK; hoặc chọn nút Cancel để huỷ bỏ; Tương tự như việc thêm một ô, để xoá một ô khỏi bảng tính ta thực hiện như sau: 1) đánh dấu ô cần xoá; 2) chọn menu: Insert\Delete ..., cửa sổ Delete xuất hiện; chọn một trong 4 lựa chọn (tuỳ vào mục đích) và nháy chuột vào nút OK; hoặc chọn nút Cancel để huỷ bỏ; + Tìm kiếm hoặc thay thế dữ liệu Ta có thể tìm kiếm một chuỗi ký tự, hoặc một số để xem, sữa hoặc tự động thay thế bằng một dữ liệu khác. Trước khi tìm kiếm hoặc thay thế ta đưa con trỏ chuột vào một ô bất kỳ trong bảng tính. a) Tìm kiếm dữ liệu: Ta chọn menu: Edit\Find, hộp thoại tìm kiếm xuất hiện (giống hình 3). Ta cần điền vào các thông tin sau: Nhập chuỗi ký tự cần tìm vào hộp trắng Find what; Đánh dấu vào Match Case nếu cần phân biệt chữ hoa, chữ thường và chọn nút lệnh Find Next để tìm kiếm. 8 Giáo trình Tin học văn phòng – MS Excel
  10. LTVinh Trung tâm CNTT Nghệ an b) Để thay thế dữ liệu ta chọn: Edit\Replace, hộp thoại thay thế (Replace) xuất hiện trong đó ta điền vào dữ liệu cần tìm vào ô Find What; dữ liệu thay thế vào ô: Replace with; sau đó chọn nút Find Next để tìm kiếm; khi tìm kiếm được chọn nút lệnh Replace để thay thế và lặp hai động tác này cho đến lúc hoàn thành. Hoặc nếu khẳng định cần thay đổi dữ liệu này trong toàn bảng tính thì sau khi điền xong các thông tin ta chọn Replace All (hình 3). ◄ 3. Hộp thoại thay thế (Replace) dữ liệu + Sắp xếp dữ liệu Ví dụ ta có bảng dữ liệu dưới đây: Bảng này đang được sắp xếp theo Thang, bây giờ ta cần xem số liệu theo Cửa hàng. Để sắp xếp dữ liệu trong bảng theo Cửa hàng ta thực hiện các bước sau: Thứ nhất là đưa con trỏ chuột vào một ô bất kỳ trong bảng tính; Thứ hai chọn menu: Data\Sort, cửa sổ sắp xếp hiện ra. Ta nháy chuột vào nút mũi tên chỉ xuống trong ô Sort by ta chọn trường cần sắp xếp; các ô Then by ta chọn tiếp các trường được ưu tiên trong việc sắp xếp này. Và cuối cùng ta chọn nút lệnh OK để thực hiện. ▲ 4. Cửa sổ sắp xếp dữ liệu 9 Giáo trình Tin học văn phòng – MS Excel
  11. LTVinh Trung tâm CNTT Nghệ an II.2. Cách quản lý dữ liệu của Excel: địa chỉ, kiểu dữ liệu + Địa chỉ a) Cách phân loại và quản lý địa chỉ Đối tượng quản lý của Excel là ô (cell). Ứng với mỗi ô có các thông tin sau: dữ liệu mà ô đó lưu dữ, định dạng của ô, và địa chỉ của ô. Ô là đơn vị dữ liệu nhỏ nhất, lớn hơn là bảng tính (gồm nhiều ô), tiếp theo là tài liệu (gồm nhiều bảng tính). Dữ liệu của workbook được lưu trên một file. Một bảng tính gồm tối đa là 65536 hàng, 256 cột (65536 x 256 = 16.777.216 ô). Ô là nơi giao nhau của một hàng với một cột. Nên một ô được xác định bằng địa chỉ của nó gồm 2 ký tự chỉ ra ô này là giao của cột nào với hàng nào. Ví dụ: ô B2 là ô giao của cột B với hàng số 2; ô đầu tiên trong bảng là ô A1 và ô cuối cùng là ô IV65536. Trong các liên kết dữ liệu, từ file đích có thể truy cập dữ liệu của file nguồn thông qua địa chỉ. ví dụ: Ta có hai file dulieu.xls (gồm sheet1, sheet2, v.v.) và baocao.xls (gồm sheet1, sheet2, v.v.) lưu trong thư mục “My Documents”. Ô A1 trong sheet2 của file baocao.xls ta viết: ='C:\My Documents\[dulieu.xls]Sheet1'!A2; khi đó ô A1 ở file baocao.xls\sheet2 sẽ nhận giá trị của ô A2 ở file dulieu.xls\sheet1. Các loại địa chỉ: Trong Excel cung cấp hai loại địa chỉ, địa chỉ tương đối và địa chỉ tuyệt đối. Ví dụ trong một bảng, ở ô B2 ta viết =A1. Địa chỉ ta viết như vậy gọi là địa chỉ tương đối, nếu đổi cách viết A1 thành $A$1 thì địa chỉ này trở thành địa chỉ tuyệt đối. Sự khác nhau giữa địa chỉ tương đối và địa chỉ tuyệt đối: thứ nhất là nếu giá trị trong ô A1 di chuyển sang một ô khác (dùng Cut và Paste) thì giá trị trong ô B2 sẽ dữ nguyên nếu ta dùng địa chỉ tuyệt đối, ngược lại giá trị này sẽ =0 khi ta dùng địa chỉ tương đối. Thứ hai khi ta dùng công cụ tự động điền dữ liệu vào các ô dựa vào dữ liệu của các ô bên cạnh (Automatically fill in data based on adjacent cells- Fill handle) thì biểu thức điền vào các ô sẽ không thay đổi nếu ta dùng địa chỉ tuyệt đối, ngược lại nếu dùng địa chỉ tương đối thì biểu thức điền vào các ô sẽ tự động thay đổi. + Một số kiểu dữ liệu trong Excel Kiểu dữ liệu Ví dụ Tiếng anh Tiếng việt General Chung chung Trung tam CNTT Nghe An; 123; 1.234 Number Số 1432498; Currency Tiền tệ $ 30 Date Ngày tháng 12/25/2002 Time Thời gian 10:30 Percentage Phần trăm 50 % Scientific Khoa học 1.00E4; 1.254E00; 1.00E+03 Text Chuỗi (ký tự) Trung tam CNTT Nghe An 10 Giáo trình Tin học văn phòng – MS Excel
  12. LTVinh Trung tâm CNTT Nghệ an II.3. Làm việc với biểu đồ và đồ thị Trong nhiều trường hợp ta cần xem xét sự quan hệ giữa hai hay nhiều dữ liệu với nhau. Ví dụ: xét số lượng hàng hoá bán ra trong một năm theo thời gian (đơn vị là tháng) để biết vào khoãng thời gian nào bán được số lượng hàng nhiều nhất, ít nhất. Hay cùng một mặt hàng, ta cần xem xét số lượng bán ra ở các cửa hàng khác nhau như thế nào? cửa hàng nào bán được nhiều nhất, ít nhất? Excel cung cấp cho người sử dụng công cụ Biểu đồ và Đồ thị cho phép quan sát trực quan các yêu cầu này. Giúp cho quá trình nhận định, đánh giá số liệu được thuận tiện. Vậy việc sử dụng công cụ này như thế nào? ta xét các ví dụ sau: Ví dụ 1: Nhập vào Excel bảng dữ liệu gồm hai cột: cột Tháng và cột Doanh thu như hình 1. Để vẽ đồ thị mô tả quan hệ Doanh thu theo từng Tháng ta chọn (bôi đen) vùng dữ liệu sau đó chọn menu: Insert\Chart, cửa sổ Chart Wizard hiện ra; Trong ô Chart type ta chọn mục XY(Scatter) và ở vùng bên phải cửa sổ này ta chọn ô thứ 2 trên xuống (được bôi đen) như hình 1, cuối cùng ta chọn nút Finish để hoàn thành. Kết quả ta có đồ thị như hình 2. ▲ 1. Vùng dữ liệu được chọn và cửa sổ Chart Wizard Chú ý: Chart Wizard có 4 bước, ở đây ta kết thúc từ bước 1 như vậy ta đã sử dụng các lựa chọn mặc định ở các bước sau đó. Các bước sau cho phép đặt tiêu đề cho trục dọc (trục tung), trục ngang (trục hoành), cho phép chọn bảng tính để hiển thị kết quả v.v. Chart Wizard cung cấp nhiều cách thể hiện khác nhau (xem hình 1). Tưong tự cách làm trên, ta có thể thử nghiệm các lựa chọn còn lại để biết và chọn ra lựa chọn phù hợp cho mình. 11 Giáo trình Tin học văn phòng – MS Excel
  13. LTVinh Trung tâm CNTT Nghệ an ◄ 2. Đồ thị mô tả quan hệ doanh thu theo tháng Từ đồ thị ta thấy doanh thu các tháng đầu và một số tháng cuối năm nói là thấp; Và doanh thu cao ở các tháng 7,8,9; Ví dụ 2: Xem Nhập vào Excel bảng dữ liệu, chọn vùng dữ liệu cần vẽ sơ đồ (hình 3a), chọn menu: Insert\Chart, cửa sổ Chart Wizard hiện ra; ở bước một chọn Pie và ở vùng bên phải chọn ô thứ hai ngoài, hàng trên (hình 3b). ◄ 3. Vùng dữ liệu được chọn và bước 1 của Chart Wizard ◄ 4. Thực hiện lựa chọn ở bước 3 12 Giáo trình Tin học văn phòng – MS Excel
  14. LTVinh Trung tâm CNTT Nghệ an Sau đó chọn nút lệnh “Next >” đến bước 4, chọn như hình 4; Kết quả thực hiện được trình bày trên hình 5. ◄ 5. Biểu đồ mô tả quan hệ doanh thu của ba doanh nghiệp Ở đây khi ta chọn từng phần trong biểu đồ các thông tin về biểu đồ sẽ hiện ra. Tương tự cách làm này ta có thể mô tả dữ liệu của bất kỳ lĩnh vực nào bằng biểu đồ hoặc đồ thị. Chúng sẽ trợ giúp cho việc đánh giá phân tích cũng như tạo các báo cáo trực quan, dễ hiểu. 13 Giáo trình Tin học văn phòng – MS Excel
  15. LTVinh Trung tâm CNTT Nghệ an II.4. Định dạng bảng tính + Định dạng cho một ô hoặc một nhóm ô Chọn (bôi đen) ô hoặc một nhóm ô cần định dạng, sau đó chọn menu: Format\Cells ... cửa sổ Format Cells hiện ra: ◄ 1. Cửa sổ định dạng dữ các ô dữ liệu. Trong cửa sổ này, tương ứng với các táp cho phép ta chọn các định dạng cho dữ liệu được mô tả tóm tắt trong bảng sau: Tên táp Công việc sẽ thực hiện Chi tiết Number Chọn kiểu dữ liệu Như mô tả ở phần kiểu dữ liệu Alignment Chọn căn lề Căn trái, phải, chính giữa, căn đều hai bên; dữ liệu nằm ngang, dựng đứng, nghiêng v.v Lựa chọn Warp text cho phép hiện nhiều dòng trong một ô Font Chọn phông chữ Chọn: mẫu chữ (hộp Fonts) kiểu chữ (Fonts style) cỡ chữ (Size) màu chữ (Color), vv Border Chọn đường kẻ viền Chọn: có hay không có bao quanh đường bao xung quanh các đường kẻ ở giữa có gạch chéo kiểu đường (nét đứt, liền, vv) Patterns Các mẫu tô nền Chọn màu tô nền Sau khi chọn kiểu dữ liệu, nhập dữ liệu vào và chọn định dạng cho các ô ta có thể thêm lời ghi chú cho từng ô dữ liệu trong đó bằng cách chọn menu: Insert\Comment, một hộp soạn thảo hiện ra, gõ vào lời ghi chú, khi gõ xong nháy chuột ra ngoài hộp soạn thảo để kết thúc. 14 Giáo trình Tin học văn phòng – MS Excel
  16. LTVinh Trung tâm CNTT Nghệ an Như vậy, mỗi ô trong Excel chứa các thông tin sau: nội dung, định dạng, lời ghi chú. Phần trên đã trình bày cách đưa dữ liệu vào, đặt định dạng và thêm lời ghi chú. Vậy muốn loại bỏ chúng thì làm như thế nào? Việc này được thực hiện bằng cách chọn menu: Edit\Clear và chọn: All để xoá tất cả, Formats để xoá định dạng, Contents để xoá nội dung và Comments để xoá lời ghi chú. + Thay đổi độ rộng cột và chiều cao dòng Ta thực hiện như sau: trước hết là chọn cột (hoặc dòng) cần thay đổi, sau đó chọn menu: Format\Column\Width; điền vào giá trị độ rộng; chọn OK để thay đổi độ rộng. Format\Row\Height; điền vào giá trị chiều cao; chọn OK để thay đổi chiều cao. Cách làm nhanh hơn là đưa chuột đến đường phân cách giữa hai cột (gạch đứng), hoặc giữa hai hàng (đường ngang) trên thanh ghi địa chỉ A,B,C ... hoặc 1,2,3 ..., hình dạng con chuột đổi thành mũi tên hai chiều, ấn và rê chuột để thay đổi. II.5. In bảng tính Trước khi in ta phải định dạng trang giấy bằng cách chọn: File\Page Setup, xuất hiện hộp thoại Page Setup với 4 táp như sau: ◄ 1. Hộp thoại Page Setup, trong táp Page Trong táp Page (hình 1): - Trong Oriention: chọn Portrait để in dọc, Landscape để in ngang trang giấy. - Trong Scaling: nên dữ Adjust to 100% normal size. Trường hợp chỉ thiếu vài dòng sẽ trọn một trang nên chọn Fit to 1 page để Excel ép lại cho vừa một trang. - Trong Paper size: Chọn cỡ giấy in. thông thường ta chọn giấy khổ A4 - Trong Print Quality: chọn chất lượng in; 600 dpi nghĩa là in với độ phân giải 600 điểm/in; Trong táp Margins (hình 2): Đặt các canh lề cho trang giấy - Tương ứng: Top, Bottom, Left và Right là lề trên, dưới, trái và phải; Tức là vùng in sẽ cách các mép tương ứng của trang giấy một khoảng bao nhiêu cm (hoặc in). 15 Giáo trình Tin học văn phòng – MS Excel
  17. LTVinh Trung tâm CNTT Nghệ an - Header, Footer khoảng cách mép trên và mép dưới trang giấy đến mép dưới (trên) của phần Header (Footer). - Horizontally, Vertically: Canh giữa theo chiều ngang, dọc hay không? ◄ 2. Táp căn lề trang (táp Margins). Trong táp Header/Footer: dùng để định tiêu đề đầu trang và cuối trang. Excel sẽ in ra một dòng trên đỉnh trang gọi là dòng đầu trang (Header) và một dòng ở cuối trang gọi là dòng chân trang (Footer). Trong mục Header và mục Footer của táp này có các dòng gợi ý có sẵn ta có thể chọn chúng để in. Trường hợp ta không thích các dòng này mà muốn thay nó bằng một dòng khác ta chọn: Custom Header và Custom Footor. Khi thực hiện lựa chọn này một cửa sổ soạn thảo sẽ xuất hiện, trong đó Excel chia dòng ra làm 3 phần: Trái, Giữa và Phải ta có thể soạn thảo vào các ô này (hình 3). ▲ 3. Cửa sổ soạn thảo dòng đầu trang Header (cửa sổ soạn thảo dòng cuối trang giống cửa sổ này, chỉ khác tiêu đề là Footer) 16 Giáo trình Tin học văn phòng – MS Excel
  18. LTVinh Trung tâm CNTT Nghệ an Trong cửa sổ soạn thảo có thanh công cụ, gồm các biểu tượng theo thứ tự từ trái qua phải là: Font chữ (chọn Fonts), số trang, tổng số trang, ngày giờ, tên file, tên bảng tính (cho phép chèm vào). Táp Sheet: Cho phép in một vùng dữ liệu bất kỳ trong bảng tính - Hộp Print Area: nhập vào địa chỉ vùng dữ liệu cần in ra - Trong Page Order: cho phép chọn hướng in; ◄ 4. Khung Page Order trong táp Sheet, cho phép chọn hướng trang in Sau khi định dạng trang xong, trước khi in ra giấy ta nên xem thử các trang in đã vừa ý chưa bằng cách chọn menu: File\Print Preview (hoặc chọn nút Print Preview trong cửa sổ Page Setup, hoặc chọn biểu tượng Print Preview trên thanh công cụ) Thực hiện in dữ liệu ra giấy bằng cách chọn menu: File\Print, hộp thoại Print hiện ra: ◄ 5. Hộp thoại in dữ liệu Khung Printer: chọn máy in, lựa chọn Print to file: in ra một file mới, mặc định không chọn nó sẽ in ra giấy. Khung Print range: chọn trang in, All: in tất cả các trang; Pages: từ trang ... đến trang ...; Khung Print what: Selection: in vùng dữ liệu đã chọn, Active sheets: in các bảng tính đang kích hoạt; Entire workbook: in tất cả các bảng tính trong file. Khung Copies: Number of copies: số bản được in ra (sao chép nhiều bản), Collate: có duyệt thứ tự trang in. Chọn: nút Print Preview để xem thử, nút OK để Excel thực hiện in và nút Cancel để huỷ bỏ. 17 Giáo trình Tin học văn phòng – MS Excel
  19. LTVinh Trung tâm CNTT Nghệ an III. Phân tích dữ liệu Sau khi vào dữ liệu xong, việc phân tích dữ liệu cung cấp thêm những thông tin có giá trị. Ví dụ: Kết thúc kỳ thi tuyển sinh kết quả thi đã được lưu trữ, dữ liệu này mới cho biết thí sinh nào đạt hay chưa đạt, bao nhiêu điểm. Khi ta muốn biết các thông tin tổng hợp như: có bao nhiêu phần trăm thí sinh đạt loại xuất sắc, giỏi, khá, trung bình, yếu và kém; theo khu vực hay theo tỉnh thành hoặc theo từng trường học thì tỷ lệ này là bao nhiêu; để qua đó đánh giá giá chất lượng đào tạo, có ý kiến phản ánh và luật lập kế hoạch đào tạo. Các bài toán trong quản lý hay trong kinh tế v.v cũng có những nhu cầu tương tự. Việc xử lý dữ liệu trong Excel nên thực hiện bằng cách: dữ liệu đầu vào -> xử lý -> dữ liệu đầu ra. Trong đó dữ liệu đầu vào có thể là một bảng (có một số hàng và cột), hoặc một Bảng tính (sheet), hoặc là một file dữ liệu (book) tuỳ vào dữ liệu này là ít hay nhiều (mỗi sheet có thể lưu 65000 hàng, mỗi hàng 256 cột). Dữ liệu đầu ra có thể lưu trên một file khác, sheet khác hoặc là một bảng khác ngay trong sheet đó. Phần này chúng tôi cung cấp một số hàm và công cụ của Excel dùng cho việc phân tích dữ liệu, và các ví dụ áp dụng đơn giản. Những ví dụ đơn giản, các hàm được cung cấp cho học viên như những công cụ cơ bản để học viên vận dụng linh hoạt chúng trong từng bài toán cụ thể. III.1. Sử dụng các hàm 1) Danh sách một số hàm thường dùng (các hàm khác ta có thể tra cứu bằng chương trình trợ giúp của Excel bằng cách chọn menu: Help\Contents and Index\tab Index\gõ vào từ khoá “functions”\Display và thực hiện theo hướng dẫn trên màn hình để xem) Phân loại Tên hàm Ý nghĩa Ví dụ minh hoạ Xử lý số abs(n) cho giá trị tuyệt đối của số n abs(-2) = 2 sqrt(n) cho giá trị căn bậc hai của số n sqrt(9) = 3 (n>0) power(x,n) cho giá trị xn power(2,3) = 8 int(x) cho giá trị phần nguyên của x int(3.45) = 3 mod(n,m) lấy phần dư của phép chia n cho mod(10,3) = 1 m round(x,n) làm tròn số x đến n số thập phân round(2.1246,3)=2.125 min(danh cho giá trị nhỏ nhất trong một min({1,2,5,0}) = 0 sách giá trị) danh sách các giá trị max(danh cho giá trị lớn nhất trong một max({1,2,5,0}) = 5 sách giá trị) danh sách các giá trị average( cho giá trị trung bình của các giá average({1,2,6,0}) = 2.25 danh sách trị trong danh sách giá trị) sum(danh tính tổng các giá trị có trong danh sum({1,2,6,0}) = 9 sách giá trị) sách product( tính tích các giá trị có trong danh product(2,3,4) = 24 danh sách sách giá trị) pi() cho số pi pi() = 3.141593 sin(x) tính sin của x radian sin(pi()/2) = 1 18 Giáo trình Tin học văn phòng – MS Excel
  20. LTVinh Trung tâm CNTT Nghệ an cos(x) tính cos của x radian cos(pi()/2) = 0 tan(x) tính tang của x radian tan(pi()/4) = 1 asin(x) tính arcsin của x asin(1) = 1.570796 acos(x) tính arccos của x acos(0) = 1.570796 atan(x) tính arctang của x atan(1) = 0.785398 exp(x) tính ex exp(1) = 2.718282 Xử lý left(s,n) cho chuỗi con của chuỗi s được left(“nghe an”,4) = nghe chuỗi tính từ trái qua phải n ký tự mid(s,n1,n2 cho chuỗi con của chuỗi s được mid(“nghe an”,6,2) = an ) lấy ra từ vị trí n1 ra n2 ký tự right(s,n) cho chuỗi con của chuỗi s được right(“nghe an”,4) = e an tính từ phải qua trái n ký tự len(s) cho độ dài của chuỗi s len(“nghe an”) = 7 lower(s) chuyển chuỗi s thành chữ thường lower(“Nghe An”) = nghe an upper(s) chuyển chuỗi s thành chữ hoa lower(“Nghe An”) = NGHE AN proper(s) chuyển các chữ đầu của mỗi từ proper(“nghe an”) = Nghe trong chuỗi s thành chữ hoa An trim(s) cắt các ký tự trống ở hai đầu chuỗi trim(“ an “) = “an” s Hàm tìm count(danh cho số giá trị là số có trong danh count({1,4,6,”a”,”c”}) = 3 kiếm sách giá trị) sách counta(danh cho số giá trị có trong danh sách counta({1,4,6,”a”,”c”}) = sách giá trị) (không tính các ô không chứa dữ 5 liệu) khi các ô A1:A5 tương ứng nhận các giá trị: {1,4, , ”a”,”c”} (A3 không có dữ liệu) thì counta(A1:A5) = 4 rank(x, cho biết vị trí của số x trong danh các ô A1:A5 lần lượt chứa danh sách sách các số; tương ứng n=1 và các giá trị: 7, 3.5, 3.5, 1, số, n) n=0 (hoặc không viết) các số và 2 thì: trong danh sách sắp theo thứ tự rank(A2,A1:A5,1) = 3 giảm dần và tăng dần. rank(A1,A1:A5,1) = 5 rank(A1,A1:A5,0) = 1 rank(A1,A1:A5) = 1 vlookup(x, Tìm giá trị x trong bảng giá trị và cho các ô nhận giá trị bảng giá trị, trả về giá trị cùng hàng với giá trị tương ứng sau: n, điều kiện tìm được đầu tiên và ở cột thứ n A1:A3 là A, B, C ) trong bảng. Nếu điều kiện là B1:B3 là 10, 8, 5 TRUE, cách tìm gần đúng, vlookup("C",A1:B2,2, FALSE tìm chính xác; false) = 5 hlookup(x, Tương tự hàm vlookup, hàm này cho các ô nhận giá trị bảng giá trị, không tìm theo cột mà tìm theo tương ứng sau: n, điều kiện hàng. A1, B1, C1 là A, B, C ) A2, B2, C2 là 10, 8, 5 hlookup("A",A1:C2,2, false) = 10 19 Giáo trình Tin học văn phòng – MS Excel

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản