Graphic-Multimedia part 6

Chia sẻ: Dqwdasdasd Qwdasdasdasd | Ngày: | Loại File: PDF | Số trang:6

0
50
lượt xem
6
download

Graphic-Multimedia part 6

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

MP4Box + MeGUI miễn phí, phức tạp trong cài đặt, dễ sử dụng, ổn định,có thể mux phụ đề, không thể delay ***1/2 YAMB miễn phí tại http://www.unite-video.com/ đơn giản,nhiều tính năng, không thật ổn định,có thể mux phụ đề Graphic-Multimedia part 6

Chủ đề:
Lưu

Nội dung Text: Graphic-Multimedia part 6

  1. phí,nhiều tùy chọn, có thể mux phụ đề, có delay,giao diện trực quan,hỗ trợ nhiều định dạng, rất ổn định. Đối với mp4: MP4UI tại http://mp4ui.sourceforge.net/ Rất đơn giản,ít tùy chọn,không thể mux phụ đề, không delay và các tính năng thêm, *** GUI cho MP4Box: (http://gpac.sourceforge.net/) MP4Box + MeGUI miễn phí, phức tạp trong cài đặt, dễ sử dụng, ổn định,có thể mux phụ đề, không thể delay ***1/2 YAMB miễn phí tại http://www.unite-video.com/ đơn giản,nhiều tính năng, không thật ổn định,có thể mux phụ đề, không thể delay ***1/2 Đối với MPEG-1 và MPEG-2: Sử dụng tính năng MPEGtools của TMPGEnc Plus /Ổn định Tạo Karaoke với JetAudio 6.0 Tác giả: DTHA Đoàn Duy Thành Add:Lớp VAT5 – khoa hợp tác quốc tế - trường Đại học công nhiệp Hà Nội (HaUI) – Nhổn - Từ Liêm – Hà Nội Bạn là người thích nghe nhạc, chắc hẳn khi mỗi bài hát cất lên thì bạn cũng lẩm nhẩm theo giai điệu của nó ! Bạn đã thử nghe nhạc với JetAudio 6.0 chưa ? Nêu từng sử dụng JetAudio thì chắc hẳn bạn cũng đã biết chức năng hiên thị lyric của nó. Nhưng có một tính năng khác tương tự nhưng chuyên nghiệp hơn rất nhiều – vì nó hiện thị như Karaoke! Để soạn cho mình một bản Karaoke rất dễ ràng. Trước hết bạn nhấn chuột phải vào bài hát muốn tạo karaoke chọn Edit > Edit Tag (hay đơn giản là nhấn F4). Ok bây giờ vào Lyric, như bình thường để hiện thị lời bài hát khi nghe nhạc bạn đưa lời vào phần Lyric ở bên dưới OK nhưng cách này quá thường! Để chạy như Karaoke ta làm như sau: Nhấn vào Run Lyric Maker (for synchsonized lyric). Ở cửa sổ kế tiếp bạn đưa lời bài hát vào như bên dưới :
  2. Bây giờ bạn đưa con trỏ vào dòng đầu tiên của lời bài hát. Nhấn nút Để chạy bài hát này. Và nhấn để đặt thời gian cho từng đoạn lời. Để chuyên nghiệp hơn nữa sau khi copy đoạn lời bài hát bạn vào File > Import Lyric from Clipboard (Lấy lời từ bộ nhớ - lời vừa được copy). Sau đó chọn lựa chọn I will add time for each word trong Import options. Sau khi chọn xong, lời bài hát sẽ được chuyển thành mỗi dòng một từ như hình dưới. Sau đó bạn cho bài hát chạy và đặt thời gian cho từng từ một (hơi mất công một chút!). Sau khi đã gán thời gian hiện thị cho đoạn lời xong công việc tiếp theo bạn vào File> Save Lyic to Tag. Bây giờ bạn thử mở sản phẩm của mình ra nghe thử xem kết quả của bạn có như vầy không ? Chúc bạn vui vẻ với những bản Karaoke của mình! Cách đưa phụ đề tiếng Việt dạng text vào tập tin video tạo bởi DivX codec. Những công cụ cần thiết: SubRip http://zuggy.wz.cz/ Subtitle Workshop http://www.urusoft.net/ MaestroSBT http://www.videohelp.com/tools?tool=MaestroSBT Son2Vsub http://www.anime.cz/s2v/ BmptoXsub http://www.updatesofts.com/forums/at...1&d=1133484998 Fuse http://download.divx.com/labs/Fuse02182005.zip Tất cả các công cụ trên đều miễn phí và dễ dàng tìm thấy.
  3. Thực ra,vấn đề này sẽ khá đơn giản và chỉ cần 2 bước ( không trình bày trong bài này ) nếu phụ đề muốn sử dụng là tiếng Anh hay những ngôn ngữ được hỗ trợ đầy đủ từ bảng mã ANSI ,nhưng đối với tiếng Việt việc convert sẽ khá rối rắm bởi có không nhiều phương pháp hỗ trợ những ngôn ngữ dùng bởi bảng mã Unicode. Bạn cũng có thể áp dụng phương pháp này cho bất cứ ngôn ngữ nào khác vì đây là giải pháp toàn diện cho việc tạo Xsub đa ngôn ngữ. Cách làm: Đầu tiên, chắc chắn chúng ta đã có một file video được mã hóa bởi codec DivX.Các định dạng hỗ trợ trong guide này là .avi và .divx .Nếu video thuộc dạng container khác, xin đọc kỹ các guide trước để hiểu rõ hơn cách chuyển đổi container.Nếu không thể tìm thấy hướng dẫn cần thiết, bạn có thể PM cho tác giả để được tư vấn hoặc tạo thread mới ở phần Helpdesk, tác giả sẽ cố gắng giúp bạn trong khả năng hiểu biết của mình. Phụ đề dạng text có thể được download dễ dàng từ Internet, thường có dạng .srt , .sub , .ssa ... và có thể load bởi modul VobSub ,nhưng thứ chúng ta đang cần bây giờ là đưa chúng vào container .divx. 1.Convert phụ đề dạng text thành phụ đề text mặc định của Sub Station Alpha. Dùng Subtitle Workshop, (SubRip nếu phụ đề là .srt) để load phụ đề dạng text muốn convert. SubRip sẽ load phụ đề sử dụng unicode một cách dễ dàng, nhưng chỉ sử dụng được khi text sub là .srt. Nếu sử dụng SubRip,chọn Show/hide subtitles text window ,load file .srt. Chọn Output format/set output format, tìm đến dòng text sub/Sub Station Alpha(.ssa) ,chọn địng dạng đó. Cuối cùng save as để lấy file .ssa (nhớ dùng định dạng unicode cho tiếng Việt) Nếu text sub không phải dạng .srt , lúc ấy SubRip không thể load được và chúng ta không thể dùng chương trình này.Bây giờ là lúc phải dùng đến Subtitle Workshop.Một điếu rất bất tiện là Subtitle Workshop không hỗ trợ hiển thị unicode nên nếu bạn load text sub dùng font unicode,nó sẽ báo lỗi và không chấp nhận mở file.Gặp trường hợp này,hãy làm như sau: Mở file text sub bằng notepad,chọn save as,trong hộp thoại save as,chọn encoding là UTF-8,đuổi mở rộng giống như file text sub cũ.Sau đó lưu lại.
  4. Bây giờ file sub mới sẽ có thể load được bằng Subtitle Workshop.Trong Subtitle Workshop,chọn save as, chọn dịnh dạng Sub Station Alpha và lưu lại. Lại dùng NotePad mở file .ssa vừa thu được và chuyển nó về encoding là Unicode như cũ. Sau bước này,chúng ta sẽ có file .ssa hoàn chỉnh. 2.Tạo phụ đề bitmap dạng DVDMaestro với MaestroSBT. Dùng MaestroSBT load file .ssa ở bước 1 (MaestroSBT chỉ load được .ssa) Thiết lập thông số cho MaestroSBT (các dữ liệu khớp với file video và cấu hình phụ đề).Quan trọng nhất cần nhớ là phải đặt định dạng xuất là .son (trong phần Rendering) Vì MaestroSBT là một phần mềm hoàn toàn riêng biệt và khác phức tạp nên tôi không thể trình bày trong khuôn khổ bài viết này.Nếu có gì thắc mắc hoặc chưa hiểu rõ,bạn có thể nêu câu hỏi ở Helpdesk. Sau khi cài đặt thiết lập cho MaestroSBT, nhấn Generate.MaestroSBT sẽ hoạt động để chuyển đổi các dòng text thành hình ảnh dạng bitmap.Chúng ta sẽ thu được rất nhiều file ảnh (số lượng ứng với số dòng phụ đề) vì vật nên đặt output riêng trên một thư mục (trong phần set file). Khi hoàn thành, ta sẽ thu được một file .son ,một file .spf và một series ảnh bitmap. 3.Tạo phụ đề mặc định của VobSub với Son2VSub Bước này thực sự đơn giản,chọn file .son ở bước 2,chọn thông số rồi convert. 4.Tạo Philips SVCD Designer với SubRip Sau khi thu được 2 file có đuôi mở rộng là .sub và .idx (là mặc định cho định dạng phụ đề VobSub),dùng SupRip để convert dạng phụ đề này thành dạng phụ đề của Philips SVCD Designer.Cách làm như sau Khởi động SubRip, chọn mode VOBs (Open decrypted Vobs),chọn Open Dir và tìm đường dẫn tới file .idx thu được ở bước 3. Trong phần Action ở bên phải,chọn Save SubPicture as BMP. Chọn hình chiếc camera ở phía dưới để đặt output format,trong phần output format,chọn định dạng Philips SVCD Designer(*.sub) Chọn Start và chỉ đường dẫn tới thư mục sẽ lưu bitmap (nên để riêng một thư mục như bước 2) Sau khi đặt tên cho file bitmap,sẽ có một cửa sổ tùy chọn khác hiện ra.Bạn có thể tinh chỉnh nếu hiểu mình đang làm gì ,nhưng hãy lưu ý hai điều quan trọng sau: -Vào Tab Colors,chọn Custom color and contrast,Color số 1 bắt buộc phải là màu đen (!),ở phần preset chọn Philips SVCD Designer -Vào Tab Cropping và vô hiệu hóa tính năng này.
  5. Sau khi thiết lập xong,chọn OK để bắt đầu lưu hình ảnh. Khi quá trình lưu hình ảnh hoản tất, một cửa sổ mới hiện ra ,hãy dùng save as để lưu thông tin trên cửa sổ với định dạng .sub của Philips SVCD Designer. Đặt file .sub của Philips SVCD Designer vào cùng thư mục với bitmap của Philips SVCD Designer,ta đã có đủ nguyên liệu để tạo ra Xsub file. 5.Tạo Xsub file từ phụ đề bitmap của Philips SVCD Designer Vào thời điểm tôi có nhu cầu tạo Xsub,thực sự chưa có công cụ nào có thể tiến hành convert thẳng từ bitmap ra Xsub một cách đơn giản.Vào khoảng tháng 2 năm 2005,có một chương trình giúp convert từ bitmap Philips SVCD Designer ra Xsub ra đời,đó là bmptoxsub,nhưng nó không hề có GUI , vì vậy người sử dụng phải dùng có bằng cách gõ lệnh như trên dos cổ xưa. Dùng tổ hợp phím windows + R để mở cửa sổ Run,gõ lệnh cmd. Cửa sổ Dos chạy trên Windows hiện ra.Ta sẽ dùng cửa sổ này để điều khiển bmptoxsub. sau đây là những dòng lệnh được dùng trong chương trình (gõ lện help để xem) ================================================= Code: bmptoxsub 1 2 3 (4) (5) (6) 1: Timecodefile (Philips SVCD-Designer .sub format 2: Output subtitle file (.xsub format) 3: (optional) Path to bitmap files 4: (optional) PALMODE1/PALMODE2(default) 5: (optional) SRT2SUP1/SRT2SUP2/SRT2SUP3/SRT2SUP4 6: (optional) REPOS ================================================= Giả sử tôi lưu image và .sub của Philip SVCD Designer trên phân vùng E,vậy dòng lệnh đơn giản nhất của tôi để thu được file Xsub là --------------------------------------------------------------- Code: E:\>bmptoxsub Madagascar.philip.sub subtitle.xsub --------------------------------------------------------------- Khi gõ lệnh này hợp lệ,tôi thu được kết quả sau: --------------------------------------------------------------- Code: Timecode file: Madagascar.philip.sub Subtitle file: subtitle.xsub Bitmap file path:
  6.  
Đồng bộ tài khoản