Học Adobe Flash CS4 căn bản Flash CS4 – Bài 6

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:18

0
163
lượt xem
125
download

Học Adobe Flash CS4 căn bản Flash CS4 – Bài 6

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Flash CS4 – Bài 6 - điều chỉnh Motion Path TTO - Trong bài này, bạn sẽ điều chỉnh đường bay của chim ở bài thực hành 3 bằng cách điều chỉnh hoặc thay mới motion path.

Chủ đề:
Lưu

Nội dung Text: Học Adobe Flash CS4 căn bản Flash CS4 – Bài 6

  1. Học Adobe Flash CS4 căn bản Flash CS4 – Bài 6 - điều chỉnh Motion Path TTO - Trong bài này, bạn sẽ điều chỉnh đường bay của chim ở bài thực hành 3 bằng cách điều chỉnh hoặc thay mới motion path. Các bước thực hành như sau: 1. Chuyển về vùng làm việc mặc định Bạn bấm chọn vùng Essentials để chọn lại vùng làm việc mặc định của Flash, tiếp đến bấm chọn Reset Essentials để khôi phục vùng làm việc mặc định này và bắt đầu vào bài thực hành 4 (xem bài thực hành 1 về vùng làm việc). 2. Mở một flash document Bạn mở lại file 003_shape_tween.fla đã thực hiện ở bài thực hành 3 (phải chuột vào liên kết vào chọn "Save target as" để lưu tập tin). 2.1 Chọn File > Open từ menu: 2.2 Di chuyển đến folder FLASH CS4 ONLINE, chọn file 003_shape_tween.fla và bấm nút Open.
  2. Học Adobe Flash CS4 căn bản Bạn thu được kết quả như sau: 3. Lưu một flash document 3.1 Chọn File > Save as từ menu: Chọn folder FLASH CS4 ONLINE, sau đó lưu file này lại với tên 004_motion_path.fla. 4. Điều chỉnh motion path 4.1. Rê chuột vào con chim phía dưới cho đến khi phía dưới chuột xuất hiện hình mũi tên bốn chiều.
  3. Học Adobe Flash CS4 căn bản 4.2. Bấm chọn con chim. Lúc này đường thẳng nối từ vị trí đầu đến vị trí cuối của chim xuất hiện. Đường này gọi là motion path của motion tween trong Flash CS4. 4.3. Đưa chuột vào giữa motion path cho đến khi xuất hiện đường cong phía dưới chuột.
  4. Học Adobe Flash CS4 căn bản 4.4. Bấm chuột và kéo xuống để chuyển motion path thành đường cong. 4.5. Bấm chọn con chim còn lại để thấy motion path của nó:
  5. Học Adobe Flash CS4 căn bản 4.6. Đưa chuột vào giữa motion path cho đến khi xuất hiện đường cong phía dưới chuột: 4.7 Bấm chuột và kéo xuống để chuyển motion path thành đường cong:
  6. Học Adobe Flash CS4 căn bản Lúc này nếu bạn chọn Control > Test Movie từ menu thì Flash xuất ra flash movie với hai con chim đang vỗ cánh bay từ góc dưới bên trái sang góc trên bên phải theo hai đường cong vừa được điều chỉnh. 5. Tạo motion path mới để thay thế motion path cũ Bạn có thể cho chim bay theo motion path bất kz bằng cách tự mình vẽ lấy một đường cong bất kz rồi áp vào motion tween. 5.1 Bấm vào nút New Layer để thêm một layer vào Timeline: 5.2 Bấm chọn Pencil Tool trên thanh công cụ bên phải (xem thêm phần Tìm hiểu về Pencil Tool ở cuối bài):
  7. Học Adobe Flash CS4 căn bản 5.3 Bấm chọn Pencil Mode phía dưới cuối thanh công cụ: Một menu phụ xuất hiện. Bạn chọn Smooth từ menu phụ này.
  8. Học Adobe Flash CS4 căn bản Bạn thu được kết quả như sau: 5.4 Đưa chuột vào Stage. Lúc này chuột biến thành cây bút chì. Bạn vẽ một đường cong bất kz từ góc dưới bên trái lên góc trên bên phải:
  9. Học Adobe Flash CS4 căn bản Nhả chuột ra bạn thu được đường cong như trên. 5.5 Bấm chọn Selection Tool từ thanh công cụ: 5.6 Bấm đúp chuột vào đường cong vừa vẽ để chọn nó. Đường cong sẽ phình to ra một chút và có những hạt li ti, thể hiện nó đã được chọn.
  10. Học Adobe Flash CS4 căn bản 5.7 Chọn Edit > Cut từ menu, đường cong sẽ biến mất khỏi màn hình: 5.8 Bấm chọn Layer 1 từ Timeline, Motion path của con chim đầu tiên hiện lên:
  11. Học Adobe Flash CS4 căn bản 5.9 Chọn Edit > Paste in Place từ menu: 5.10 Motion path cũ được thay thế bằng đường cong bạn vừa vẽ:
  12. Học Adobe Flash CS4 căn bản Bạn có thể lặp lại các thao tác như mô tả ở trên để tạo motion path mới cho con chim còn lại. 6. Xóa Layer thừa Layer 4 không còn sử dụng nữa, bạn có thể xóa layer này: 6.1 Chọn Layer 4 từ Timeline: 6.2 Bấm nút Delete để xóa:
  13. Học Adobe Flash CS4 căn bản 7. Xuất file thành flash movie Để xuất file thành flash movie, bạn chọn Control > Test Movie từ menu: Flash sẽ xuất thành file 004_motion_path.swf: GV TRƯƠNG VĂN NĂNG Công ty TNHH Khải Thiên (KTC Co., Ltd) -------------------------------------------------------------------------------------------
  14. Học Adobe Flash CS4 căn bản Phần l{ thuyết bổ sung cho bài thực hành Tìm hiểu về Pencil Tool Pencil Tool là công cụ để vẽ đường cong bất kz. Sau khi chọn Pencil Tool, chuột sẽ chuyển sang hình cây bút chì. Để vẽ, bạn bấm chuột vào vị trí đầu, kéo chuột theo đường cong bất kz đến vị trí cuối và nhả chuột ra để thu được một đường cong. Bạn cũng có thể vẽ đường thẳng bằng cách giữ phím Shift trước khi vẽ. Bạn có thể chọn bổ sung phương án xử l{ nét vẽ bằng cách chọn Pencil Mode phía dưới cuối thanh công cụ: Menu phụ xuất hiện để bạn chọn lựa: Straighten: Khi chọn phương án này, flash sẽ sửa các nét vẽ cong của bạn thành các đường thẳng. Smooth: Khi chọn phương án này, flash sẽ làm trơn mượt các nét vẽ cong của bạn. Ink: Khi chọn phương án này, flash sẽ không sửa các nét vẽ của bạn. Dưới đây là ví dụ các nét vẽ được flash thể hiện khi chọn Straighten, Smooth và Ink:
  15. Học Adobe Flash CS4 căn bản Property Inspector sẽ tự động cập nhật để cung cấp các thông tin liên quan đến Pencil Tool như sau: Ngay dưới Property Inspector là biểu tượng một cây bút chì kèm dòng chữ cho biết bạn đang chọn Pencil Tool. Ngay dưới phần Fill and Stroke là phần chọn màu cho viền (Stroke-bên trái) và ruột (Fill-bên phải). Do Pencil Tool chỉ vẽ đường viền nên bạn không thể đổi màu Fill trong trường hợp này. Bạn chọn màu từ bảng màu khi bấm vào ô màu đen kế bên cây bút chì: Kế đến là chọn độ lớn của đường viền. Bạn có thể nắm kéo thanh trượt nằm ngay bên phải chữ Stroke hoặc gõ số trực tiếp vào ô bên phải. Khi bạn kéo thanh trượt, ô bên phải sẽ cập nhật giá trị tùy theo vị trí thanh trượt. Phần tiếp theo là chọn kiểu dáng cho nét vẽ. Nếu bạn bấm vào hình tam giác đen kế bên cây bút chì, bạn có thể chọn một trong các kiểu nét vẽ sau đây:
  16. Học Adobe Flash CS4 căn bản Nếu bạn bấm vào cây bút chì, bạn có thể tùy biến thêm các thông số phụ cho nét vẽ trong hộp thoại sau đây: Bạn có thể thử nghiệm để tìm cho mình một kiểu dáng nét vẽ ưng {. Tuy nhiên cần lưu { một điều là kiểu dáng phức tạp sẽ làm tăng kích thước cuối cùng của tác phẩm. Phần Scale giúp hiển thị nét vẽ khi được phóng to hoặc thu nhỏ. Nếu bấm vào hình tam giác đen, bạn sẽ có các tùy chọn sau đây: Normal: Thay đổi theo giá trị scale. Horizontal: Chỉ scale theo chiều ngang. Vertical: Chỉ scale theo chiều dọc.
  17. Học Adobe Flash CS4 căn bản None: Không thay đổi theo giá trị scale. Nếu chọn ô Hinting, flash sẽ tự điều chỉnh để làm tròn giá trị stroke, tránh xuất hiện những nét nhòe trên đường thẳng nằm ngang hoặc thẳng đứng. Tùy chọn Cap giúp bạn thể hiện kiểu dáng đầu mút của nét vẽ. Nếu bấm vào hình tam giác đen, bạn sẽ có các tùy chọn sau đây: Join giúp bạn thể hiện kiểu dáng chỗ giao nhau của hai nét vẽ. Bạn sẽ thu được các chọn lựa sau đây khi bấm vào hình tam giác đen: Smoothing: Mức độ làm trơn mượt giao điểm các nét vẽ của Pencil Tool. Tùy chọn này chỉ xuất hiện khi chọn phương án Smooth được đề cập ở
  18. Học Adobe Flash CS4 căn bản phần đầu giới thiệu về Pencil Tool. Đối với các phương án còn lại, giá trị này bị mờ đi. Giá trị mặc định của Smoothing là 50.

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản