Học Adobe Flash CS4 cơ bản - Bài 17

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:22

0
178
lượt xem
136
download

Học Adobe Flash CS4 cơ bản - Bài 17

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets tạo slideshow (Phần 1)

Chủ đề:
Lưu

Nội dung Text: Học Adobe Flash CS4 cơ bản - Bài 17

  1. Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets tạo slideshow (Phần 1) TTO - Trong bài này, bạn sẽ sử dụng Motion Presets để tạo SlideShow cho một loạt ảnh. Các bước thực hành như sau: 1. Chuyển về vùng làm việc mặc định. Bạn bấm chọn vùng Essentials để chọn lại vùng làm việc mặc định của Flash, tiếp đến bấm chọn Reset Essentials để khôi phục vùng làm việc mặc định này và bắt đầu vào bài thực hành 17. (Xem bài thực hành 1 về vùng làm việc) 2. Tạo mới một flash document. (Xem bài thực hành 1 về tạo một flash document) 3. Lưu một flash document. (Xem bài thực hành 1 về lưu một flash document) Chọn folder FLASH CS4 ONLINE, sau đó lưu file này lại với tên 017_slideshow2.fla 4. Import một loạt ảnh vào Stage. 4.1. Chọn File > Import > Import to Stage… từ menu (Hoặc phím tắt Ctrl+R):
  2. Học Adobe Flash CS4 cơ bản 4.2 Hộp thoại Import mở ra. Di chuyển đến folder chứa các ảnh cần import. Giữ phím Ctrl, bấm chọn các file ảnh Blue-hills.jpg, Sunset.jpg, Water-lilies.jpg, Winter.jpg (các file này được đính kèm theo bài). Bấm nút Open để đóng hộp thoại lại (Xem thêm phần Xử lý ảnh bằng Photoshop trước khi import vào Flash):
  3. Học Adobe Flash CS4 cơ bản Bạn thu được các tấm ảnh nằm giữa Stage:
  4. Học Adobe Flash CS4 cơ bản 4.3 Rê chuột vào vùng các tấm ảnh cho đến khi dưới chuột xuất hiện mũi tên bốn chiều: 4.4 Bấm phím phải chuột cho xuất hiện menu ngữ cảnh và chọn Distribute to Layers:
  5. Học Adobe Flash CS4 cơ bản 4.5 Trên Timeline bạn thu được bốn layer với tên tương ứng của bốn tấm ảnh. Layer 1 không còn chứa đối tượng nào nên chỉ còn keyframe trắng. Bạn tạm thời vẫn để Layer 1 ở vị trí hiện hữu để sử dụng ở phần cuối bài thực hành: 5. Chuyển các tấm ảnh thành symbol. 5.1 Bấm chọn keyframe của layer Water-lilies.jpg:
  6. Học Adobe Flash CS4 cơ bản 5.2 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8): 5.3 Hộp thoại Convert to Symbol xuất hiện. gõ tên Water-lilies vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 5.4 Bấm chọn keyframe của layer Sunset.jpg:
  7. Học Adobe Flash CS4 cơ bản 5.5 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8): 5.6 Hộp thoại Convert to Symbol xuất hiện. gõ tên Sunset vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 5.7 Bấm chọn keyframe của layer Blue-hills.jpg:
  8. Học Adobe Flash CS4 cơ bản 5.8 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8): 5.9 Hộp thoại Convert to Symbol xuất hiện. gõ tên Blue-hills vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 5.10 Bấm chọn keyframe của layer Winter.jpg:
  9. Học Adobe Flash CS4 cơ bản 5.11 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8): 5.12 Hộp thoại Convert to Symbol xuất hiện. gõ tên Winter vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 7. Sử dụng Motion Presets cho các symbol vừa tạo ở trên.
  10. Học Adobe Flash CS4 cơ bản 7.1. Chọn keyframe 1 của layer Water-lilies.jpg: 7.2 Giữ phím Shift, chọn keyframe 1 của layer Winter.jpg, bạn thu được các keyframe của các layer được chọn: 7.3 Chọn Window > Motion Presets từ menu: Motion Presets Panel xuất hiện với folder Default Presets đang đóng:
  11. Học Adobe Flash CS4 cơ bản 7.4 Bấm chuột vào hình tam giác bên trái folder Default Presets để mở ra:
  12. Học Adobe Flash CS4 cơ bản 7.5 Chọn motion preset zoom-in-3D và bấm nút Apply để áp dụng cho các symbol trên từng layer đã được chọn trước đó:
  13. Học Adobe Flash CS4 cơ bản 7.6 Bấm vào dấu x để đóng Motion Presets Panel lại:
  14. Học Adobe Flash CS4 cơ bản Bạn thu được các motion preset đã áp dụng trên các layer của Timeline: 8. Di chuyển cho các motion tween lệch pha nhau. Các motion preset (motion tween) được chia thành bốn giai đoạn. Bạn sẽ di chuyển các motion tween ở các layer sao cho giai đoạn đầu của motion tween ở một layer trùng với giai đoạn cuối của motion tween ở một layer khác. 8.1. Bấm chọn motion tween của layer Winter.jpg và di chuyển sang phải một frame:
  15. Học Adobe Flash CS4 cơ bản Nhả chuột ra bạn thu được như sau: Mục đích của việc để trống một keyframe đầu tiên là để bổ sung một Movie Clip làm Preloader để play khi file đang được tải từ mạng vào máy của người sử dụng. 8.2 Chọn motion tween của layer Blue-hills.jpg: 8.3 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Winter.jpg:
  16. Học Adobe Flash CS4 cơ bản Nhả chuột ra bạn thu được như sau: 8.4 Chọn motion tween của layer Sunset.jpg: 8.5 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Blue-hills.jpg: Nhả chuột ra bạn thu được như sau: 8.6 Chọn motion tween của layer Water-lilies.jpg:
  17. Học Adobe Flash CS4 cơ bản 8.7 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Sunset.jpg: Nhả chuột ra bạn thu được như sau: Chọn Control > Test Movie từ menu (hoặc phím tắt Ctrl+Enter) để xem kết quả. Nhận xét: Tấm ảnh cuối có thời gian chờ nhiều hơn nửa giây (14 frame) trước khi tấm ảnh đầu xuất hiện trở lại. Ngoài ra, tấm ảnh đầu xuất hiện mà không có sự chuyển tiếp từ tấm ảnh cuối. Bạn cần dời 14 frame cuối của tấm ảnh cuối đến phần đầu của Timeline để tạo sự chuyển tiếp này. 9. Chuyển 14 frame cuối về phần đầu của Timeline. 9.1 Giữ phím Ctrl, bấm chọn frame 183 và kéo chuột đến frame 196, các frame này được chọn:
  18. Học Adobe Flash CS4 cơ bản 9.2 Bấm phím phải chuột vào vùng các frame được chọn cho xuất hiện menu ngữ cảnh và chọn Cut Frames: Các frame được đưa vào Clipboard để chuẩn bị chuyển về phần đầu Timeline. Tuy nhiên các frame trắng vẫn còn tồn tại. Bạn cần xóa hẳn các frame trắng này. 9.3 Bấm phím phải chuột vào vùng các frame được chọn cho xuất hiện menu ngữ cảnh và chọn Remove Frames.
  19. Học Adobe Flash CS4 cơ bản Các frame trắng được xóa khỏi Timeline: 9.4 Bạn di chuyển về phần đầu của Timeline. Lúc này layer Water-lilies.jpg đang được chọn (bên cạnh layer có cây bút chì). Bấm chuột vào nút New Layer để bổ sung thêm một layer:
  20. Học Adobe Flash CS4 cơ bản Flash bổ sung Layer 6 vào Timeline với số frame trãi dài đến cuối Timeline: 9.5 Bấm chọn Layer 6, toàn bộ các frame của layer này được chọn: 9.6 Bấm phím phải chuột vào frame 1 của Layer 6 cho xuất hiện menu ngữ cảnh và chọn Paste Frames: Bạn thu được một motion tween với 14 frame, đồng thời Layer 6 được tự động đổi tên thành Water-lilies.jpg:
Đồng bộ tài khoản