Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets để tạo slideshow (Phần

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:23

0
182
lượt xem
97
download

Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets để tạo slideshow (Phần

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tạo preloader. - Trong phần này, bạn sử dụng lại preloader từ bài 16 và cải tiến một chút để làm phong phú thêm phần preloader. Bạn hãy thực hiện theo các hướng dẫn sau nhé.

Chủ đề:
Lưu

Nội dung Text: Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets để tạo slideshow (Phần

  1. Học Adobe Flash CS4 cơ bản Bài 17: sử dụng Motion presets để tạo slideshow (Phần 2) TTO - 10. Tạo preloader. Trong phần này, bạn sử dụng lại preloader từ bài 16 và cải tiến một chút để làm phong phú thêm phần preloader. 10.1 Chọn File > Open… từ menu (Hoặc phím tắt Ctrl+O): 10.2 Chọn file 016_slideshow.fla và bấm nút Open để mở file này:
  2. Học Adobe Flash CS4 cơ bản 10.3 Chọn keyframe 1 của layer preloader: 10.4 Trên Stage bạn thấy preloader được chọn:
  3. Học Adobe Flash CS4 cơ bản 10.5 Chọn Edit > Copy từ menu (Hoặc phím tắt Ctrl+C): 10.6 Bấm chuyển sang file 017_slideshow2.fla:
  4. Học Adobe Flash CS4 cơ bản 10.7 Bấm đúp vào Layer 1 và đổi tên layer thành preloader: 10.8 Chọn frame đầu của layer preloader: 10.9 Chọn Edit > Paste in Center từ menu (Hoặc phím tắt Ctrl+V):
  5. Học Adobe Flash CS4 cơ bản 10.10 Bạn thu được Movie Clip preloader ở giữa Stage. Bấm đúp chuột vào Movie Clip preloader để mở Timeline ra: 10.11 Bấm đúp chuột tiếp vào Graphic symbol vong tron bên trong Timeline của Movie Clip preloader. Flash đưa bạn vào Timeline của Graphic symbol vong tron với một vòng tròn đang được chọn (xuất hiện các hạt li ti):
  6. Học Adobe Flash CS4 cơ bản 10.12 Kéo chuột từ góc trên bên trái sang góc dưới bên phải một đoạn ngắn sao cho hình chữ nhật phủ khoảng 2/3 vòng tròn:
  7. Học Adobe Flash CS4 cơ bản Nhả chuột ra, bạn thu được 2/3 vòng tròn được chọn: 10.13 Bấm phím Delete để xóa phần đã được chọn:
  8. Học Adobe Flash CS4 cơ bản 10.14 Bấm chọn Scene 1 để quay ra Timeline chính:
  9. Học Adobe Flash CS4 cơ bản Flash đưa bạn ra Timeline chính với Movie Clip preloader đã được điều chỉnh: Chọn Control > Test Movie từ menu (hoặc phím tắt Ctrl+Enter) để xem lại kết quả. Flash sẽ xuất thành file 017_slideshow2.swf như sau:
  10. Học Adobe Flash CS4 cơ bản 10.15 Để thấy được hoạt động của preloader, bạn chọn View > Simulate Download từ menu của Flash Player đang chạy. (Không phải từ menu lúc đang biên soạn Flash document) (Hoặc phím tắt Ctrl+Enter).
  11. Học Adobe Flash CS4 cơ bản Lúc này bạn sẽ nhìn thấy vòng tròn xoay liên tục, báo hiệu tác phẩm của bạn đang được tải về:
  12. Học Adobe Flash CS4 cơ bản Sau khi tải về và play:
  13. Học Adobe Flash CS4 cơ bản 11 Bỏ qua keyframe đầu khi đã tải về đầy đủ. Khi Flash play đến frame cuối và quay lại frame đầu, bạn thấy màn ảnh hiện lên preloader rất nhanh. Điều này có thể gây khó chịu cho người xem. Bạn có thể sử dụng một dòng lệnh actionscript đơn giản để khắc phục điều này. 11.1 Lúc này layer preloader đang được chọn. Bấm vào nút New Layer để bổ sung layer mới: 11.2 Flash bổ sung Layer 7 vào Timeline. Bấm đúp vào và đổi tên thành actions:
  14. Học Adobe Flash CS4 cơ bản 11.3 Di chuyển đến frame cuối. Bấm chọn frame cuối (frame 182) của layer actions: 11.4 Bấm phím tắt F6 để bổ sung keyframe: 11.5 Bấm phím phải chuột vào frame 286 của layer actions cho xuất hiện menu ngữ cảnh và chọn Actions: 11.6 Action Panel xuất hiện. Bạn gõ vào dòng chữ gotoAndPlay(2); như hình minh họa (chú ý không có khoảng trắng ở giữa và viết đúng chữ hoa và chữ thường). Câu lệnh này yêu cầu Flash di chuyển đến frame số 2 và play:
  15. Học Adobe Flash CS4 cơ bản Bấm vào dấu x ở góc trên bên phải để đóng Actions Panel lại. Trên Timeline tại keyframe 182 bạn thấy có một chữ a nhỏ. Đó là dấu hiệu cho biết có action tại frame này: Chọn Control > Test Movie từ menu (hoặc phím tắt Ctrl+Enter) để xem lại kết quả. Trong bài thực hành, bài đã tạo được slideshow cho bốn ảnh. Bạn có thể thực hiện theo cách tương tự để áp dụng cho nhiều ảnh hơn. Bạn có thể tạo một slideshow cho bộ sưu tập mới bằng cách thay thế các ảnh trong Library như được hướng dẫn ở bài thực hành 16. Phần này được trích dẫn từ bài thực hành 16 cho bạn tiện tham khảo. 12. Cập nhật ảnh cho slideshow.
  16. Học Adobe Flash CS4 cơ bản 12.1 Chọn Library Panel: Nội dung của Libray hiện ra: 12.2 Bạn có thể tạo các folder để sắp xếp Library theo các nhóm đối tượng để dễ quản lý. Bạn bấm vào nút New Folder phía dưới Library để bổ sung một folder:
  17. Học Adobe Flash CS4 cơ bản Flash bổ sung folder với tên mặc định là untitled folder 1: 12.3 Bạn đổi tên folder thành bitmaps:
  18. Học Adobe Flash CS4 cơ bản 12.4 Bạn sẽ chuyển các ảnh vào folder này. Giữ phím Ctrl, bạn bấm chọn lần lượt vào các tấm ảnh, các ảnh được chọn sẽ có màu đậm hơn trong Library: 12.5 Rê chuột đến một trong các ảnh đã được chọn:
  19. Học Adobe Flash CS4 cơ bản 12.6 Kéo chuột về phía folder bitmaps. Khi chuột đã đến folder bitmaps, folder sẽ đổi màu như hình minh họa: Nhả chuột ra, các ảnh đã được chuyển vào folder bitmaps:
  20. Học Adobe Flash CS4 cơ bản 12.7 Bấm vào hình tam giác bên trái folder để mở nội dung folder ra, các ảnh lại xuất hiện với biểu tượng nằm dịch sang phải một chút so với biểu tượng của các symbol khác: 12.8 Bấm đúp vào biểu tượng bitmap của ảnh tên Blue-hills.jpg:

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản