Học Adobe Flash CS4 cơ bản Flash CS4 - bài 16: Áp dụng color effect để tạo slideshow (phần 2)

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:23

0
207
lượt xem
148
download

Học Adobe Flash CS4 cơ bản Flash CS4 - bài 16: Áp dụng color effect để tạo slideshow (phần 2)

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Học Adobe Flash CS4 cơ bản Flash CS4 bài 16: Áp dụng color effect để tạo slideshow (phần 2)

Chủ đề:
Lưu

Nội dung Text: Học Adobe Flash CS4 cơ bản Flash CS4 - bài 16: Áp dụng color effect để tạo slideshow (phần 2)

  1. Học Adobe Flash CS4 cơ bản Flash CS4 bài 16: Áp dụng color effect để tạo slideshow (phần 2) TTO - 8. Copy motion tween sang các layer khác. 8.1. Bấm phím phải chuột vào motion tween vừa tạo ra cho xuất hiện menu ngữ cảnh và chọn Copy Motion: 8.2 Bấm phím phải chuột vào keyframe của layer Sunset.jpg cho xuất hiện menu ngữ cảnh và chọn Paste Motion:
  2. Học Adobe Flash CS4 cơ bản Bạn thu được motion tween như sau: 8.3 Bấm phím phải chuột vào keyframe của layer Blue-hills.jpg cho xuất hiện menu ngữ cảnh và chọn Paste Motion: Bạn thu được motion tween như sau:
  3. Học Adobe Flash CS4 cơ bản 8.4 Bấm phím phải chuột vào keyframe của layer Winter.jpg cho xuất hiện menu ngữ cảnh và chọn Paste Motion: Bạn thu được motion tween như sau: 9. Di chuyển cho các motion tween lệch pha nhau. Như đã đề cập ở trên, bạn sẽ cho chuyển tiếp từ ảnh cũ sang ảnh mới trong một giây. Bạn sẽ di chuyển các motion tween ở các layer sao cho giây đầu của motion tween mới trùng với giây cuối của motion tween cũ. 9.1. Bấm chọn motion tween của layer Winter.jpg và di chuyển sang phải một frame:
  4. Học Adobe Flash CS4 cơ bản Nhả chuột ra bạn thu được như sau: Mục đích của việc để trống một keyframe đầu tiên là để bổ sung một Movie Clip làm Preloader để play khi file đang được tải từ mạng vào máy của người xem (xem thêm phần Tìm hiểu về Preloader ở cuối bài). 9.2 Chọn motion tween của layer Blue-hills.jpg: 9.3 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Winter.jpg: Nhả chuột ra bạn thu được như sau:
  5. Học Adobe Flash CS4 cơ bản 9.4 Chọn motion tween của layer Sunset.jpg: 9.5 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Blue-hills.jpg: Nhả chuột ra bạn thu được như sau: 9.6 Chọn motion tween của layer Water-lilies.jpg: 9.7 Kéo motion tween này sang phải sao cho keyframe đầu của motion tween này trùng với keyframe áp chót của motion tween trên layer Sunset.jpg:
  6. Học Adobe Flash CS4 cơ bản Nhả chuột ra bạn thu được như sau: Chọn Control > Test Movie từ menu (hoặc phím tắt Ctrl+Enter) để xem kết quả. Nhận xét: Tấm ảnh cuối có thời gian chờ nhiều hơn một giây trước khi tấm ảnh đầu xuất hiện trở lại. Ngoài ra, tấm ảnh đầu xuất hiện mà không có sự chuyển tiếp từ tấm ảnh cuối. Bạn cần dời các frame của giây cuối cùng của tấm ảnh cuối đến phần đầu của Timeline để tạo sự chuyển tiếp này. 10. Chuyển các frame của giây cuối về phần đầu của Timeline. 10.1 Giữ phím Ctrl, bấm chọn frame 287 và kéo chuột đến frame 310, các frame này được chọn: 10.2 Bấm phím phải chuột vào vùng các frame được chọn cho xuất hiện menu ngữ cảnh và chọn Cut Frames:
  7. Học Adobe Flash CS4 cơ bản Các frame được đưa vào Clipboard để chuẩn bị chuyển về phần đầu Timeline. Tuy nhiên các frame trắng vẫn còn tồn tại. Bạn cần xóa hẳn các frame trắng này. 10.3 Bấm phím phải chuột vào vùng các frame được chọn cho xuất hiện menu ngữ cảnh và chọn Remove Frames
  8. Học Adobe Flash CS4 cơ bản Các frame trắng được xóa khỏi Timeline: 10.4 Bạn di chuyển về phần đầu của Timeline. Lúc này layer Water-lilies.jpg đang được chọn (bên cạnh layer có cây bút chì). Bấm chuột vào nút New Layer để bổ sung thêm một layer: Flash bổ sung Layer 6 vào Timeline với số frame trải dài đến cuối Timeline: 10.5 Bấm chọn Layer 6, toàn bộ các frame của layer này được chọn: 10.6 Bấm phím phải chuột vào frame 1 của Layer 6 cho xuất hiện menu ngữ cảnh và chọn Paste Frames:
  9. Học Adobe Flash CS4 cơ bản Bạn thu được một motion tween với 24 frame, đồng thời Layer 6 được tự động đổi tên thành Water-lilies.jpg: 10.7 Bạn chọn motion tween vừa thu được và di chuyển sang phải một frame: 10.8 Bạn kéo layer Water-lilies.jpg vừa thu được và thả xuống phía dưới layer Winter.jpg:
  10. Học Adobe Flash CS4 cơ bản Thu được kết quả như sau: Chọn Control > Test Movie từ menu (hoặc phím tắt Ctrl+Enter) để xem kết quả. 11. Tạo preloader (xem thêm phần Tìm hiểu về Preloader ở cuối bài). Nếu bạn tạo slideshow cho các tấm ảnh có kích thước nhỏ, có thể bạn không cần sử dụng preloader. Trong trường hợp đó, bạn có thể không cần sử dụng keyframe trắng đầu tiên trên Timeline. Bạn gỡ bỏ frame trắng này bằng cách chọn frame 1 trên Timeline (bấm vào số 1, nơi đánh dấu số frame trên Timeline) và bấm phím tắt Shift+F5. Nếu bạn tạo slideshow cho các tấm ảnh có kích thước lớn, bạn cần tạo preloader để thông báo tiến trình tải slideshow về máy người xem. Lúc đó keyframe trắng đầu tiên trên Timeline được sử dụng để chứa preloader này. Preloader được thực hiện qua các bước như sau: 11.1 Bấm đúp vào Layer 1 và đổi tên thành preloader:
  11. Học Adobe Flash CS4 cơ bản 11.2 Chọn frame 1 của layer preloader: 11.3 Lúc này, Stage chưa có gì. Bấm chọn Rectangle Tool và giữ vài giây cho menu phụ xuất hiện và chọn Oval Tool: 11.4 Bấm vào ô Fill color để chọn màu ruột:
  12. Học Adobe Flash CS4 cơ bản 11.5 Bảng màu xuất hiện, chọn màu ruột là không màu (No color): 11.6 Bấm vào ô Stroke color để chọn màu viền:
  13. Học Adobe Flash CS4 cơ bản 11.7 Bảng màu xuất hiện, bạn chọn màu linear gradient ở góc dưới bên trái: 11.8 Gõ số 2 vào ô Stroke height:
  14. Học Adobe Flash CS4 cơ bản 11.9 Đưa chuột vào Stage, giữ phím Shift và vẽ một vòng tròn: Nhả chuột ra bạn thu được vòng tròn có màu tô chuyển:
  15. Học Adobe Flash CS4 cơ bản 11.10 Chọn Selection Tool: 11.11 Chọn vòng tròn vừa vẽ, vòng tròn được chọn với các hạt li ti xuất hiện:
  16. Học Adobe Flash CS4 cơ bản 11.12 Chọn Edit > Cut từ menu: 11.13 Chọn Edit > Paste in Center từ menu: Bạn thu được vòng tròn ở giữa Stage: 11.14 Lúc này vòng tròn đang được chọn. Bạn chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8):
  17. Học Adobe Flash CS4 cơ bản 11.15 Hộp thoại Convert to Symbol xuất hiện. Gõ tên vong tron (vòng tròn) vào ô Name, chọn Type là Graphic. Registration ở giữa. Bấm OK để đóng hộp thoại lại: 11.16 Lúc này Graphic symbol đang được chọn. Bạn chọn Modify > Convert to Symbol… từ menu (hoặc phím tắt F8):
  18. Học Adobe Flash CS4 cơ bản 11.17 Hộp thoại Convert to Symbol xuất hiện. Gõ tên preloader vào ô Name, chọn Type là Movie Clip. Registration ở giữa. Bấm OK để đóng hộp thoại lại 11.18 Bấm đúp vào Movie Clip preloader để mở Timeline của Movie Clip ra: 11.19 Trên Stage đang là Graphic symbol vong tron. Đưa chuột vào Graphic symbol vong tron, khi thấy phía dưới chuột xuất hiện mũi tên bốn chiều, bấm phím phải chuột cho xuất hiện menu ngữ cảnh và chọn Create Motion Tween:
  19. Học Adobe Flash CS4 cơ bản 11.20 Flash tạo Motion Tween với thời gian mặc định là một giây, đồng thời di chuyển Playhead đến frame 24 cho bạn. Bạn bấm chuột vào vùng có motion tween: 11.21 Trên Property Inspector, bạn gõ số 1 vào mục Rotate:
  20. Học Adobe Flash CS4 cơ bản Bạn thu được kết quả như sau: 11.22 Bấm chuột vào Scene 1 để trở ra Timeline chính:
Đồng bộ tài khoản