Học Adobe Flash CS4 cơ bản Flash CS4 - Bài 16 phần 2

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:17

0
223
lượt xem
159
download

Học Adobe Flash CS4 cơ bản Flash CS4 - Bài 16 phần 2

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Học Adobe Flash CS4 cơ bản Flash CS4 - Bài 16: Áp dụng color effect để tạo slideshow

Chủ đề:
Lưu

Nội dung Text: Học Adobe Flash CS4 cơ bản Flash CS4 - Bài 16 phần 2

  1. Học Adobe Flash CS4 cơ bản Flash CS4 - Bài 16: Áp dụng color effect để tạo slideshow TTO - Trong bài này, bạn sẽ áp dụng Color Effect cho symbol khi tạo Motion Tween để tạo SlideShow cho một loạt ảnh. Các bước thực hành như sau: 1. Chuyển về vùng làm việc mặc định. Bạn bấm chọn vùng Essentials để chọn lại vùng làm việc mặc định của Flash, tiếp đến bấm chọn Reset Essentials để khôi phục vùng làm việc mặc định này và bắt đầu vào bài thực hành 16. (Xem bài thực hành 1 về vùng làm việc) 2. Tạo mới một flash document. (Xem bài thực hành 1 về tạo một flash document) 3. Lưu một flash document. (Xem bài thực hành 1 về lưu một flash document) Chọn folder FLASH CS4 ONLINE, sau đó lưu file này lại với tên 016_slideshow.fla 4. Import một loạt ảnh vào Stage. 4.1. Chọn File > Import > Import to Stage… từ menu (Hoặc phím tắt Ctrl+R): 4.2 Hộp thoại Import xuất hiện. Di chuyển đến folder chứa các ảnh cần import. Giữ phím Ctrl, bấm chọn các file ảnh Blue-hills.jpg, Sunset.jpg, Water-lilies.jpg, Winter.jpg (các file này được
  2. Học Adobe Flash CS4 cơ bản đính kèm theo bài). Bấm nút Open để đóng hộp thoại lại (Xem thêm phần Xử lý ảnh bằng Photoshop trước khi import vào Flash ở cuối bài): Bạn thu được các tấm ảnh nằm giữa Stage: 4.3 Rê chuột vào vùng các tấm ảnh cho đến khi dưới chuột xuất hiện mũi tên bốn chiều:
  3. Học Adobe Flash CS4 cơ bản 4.4 Bấm phím phải chuột cho xuất hiện menu ngữ cảnh và chọn Distribute to Layers: 4.5 Trên Timeline bạn thu được bốn layer với tên tương ứng của bốn tấm ảnh. Layer 1 không còn chứa đối tượng nào nên chỉ còn keyframe trắng. Bạn tạm thời vẫn để Layer 1 ở vị trí hiện hữu để sử dụng ở phần cuối bài thực hành:
  4. Học Adobe Flash CS4 cơ bản 5. Thiết lập lại kích thước cho tác phẩm. Lúc này, tấm ảnh đang được chọn, ở Property Inspector bạn thấy biểu tượng hình Bitmap. Kích thước tác phẩm theo mặc định là 550x400 pixel, trong khi kích thước ảnh chỉ là 320x240 pixel: 5.1. Bấm chuột vào vùng trắng của Stage để bỏ chọn tấm ảnh:
  5. Học Adobe Flash CS4 cơ bản 5.2 Bấm vào nút Edit… bên phải mục Size của Property Inspector: 5.3 Hộp thoại Document Properties xuất hiện. Bấm chọn nút Contents ở mục Match. Kích thước của tác phẩm thay đổi thành 320x240 pixel. Bấm nút OK để đóng hộp thoại lại: Bạn thu được kết quả như sau:
  6. Học Adobe Flash CS4 cơ bản 6. Chuyển các tấm ảnh thành symbol. 6.1 Bấm chọn keyframe của layer Water-lilies.jpg: 6.2 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8):
  7. Học Adobe Flash CS4 cơ bản 6.3 Hộp thoại Convert to Symbol xuất hiện. Gõ tên Water-lilies vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 6.4 Bấm chọn keyframe của layer Sunset.jpg: 6.5 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8):
  8. Học Adobe Flash CS4 cơ bản 6.6 Hộp thoại Convert to Symbol xuất hiện. Gõ tên Sunset vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 6.7 Bấm chọn keyframe của layer Blue-hills.jpg: 6.8 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8):
  9. Học Adobe Flash CS4 cơ bản 6.9 Hộp thoại Convert to Symbol xuất hiện. Gõ tên Blue-hills vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 6.10 Bấm chọn keyframe của layer Winter.jpg: 6.11 Chọn Modify > Convert to Symbol… từ menu (Hoặc phím tắt F8):
  10. Học Adobe Flash CS4 cơ bản 6.12 Hộp thoại Convert to Symbol xuất hiện. Gõ tên Winter vào ô Name, chọn Type là Movie Clip, bấm nút OK để chấp nhận: 7. Tạo Motion Tween cho layer Water-lilies.jpg. 7.1. Bấm phím phải chuột vào keyframe của layer Water-lilies.jpg cho xuất hiện menu ngữ cảnh và chọn Create Motion Tween:
  11. Học Adobe Flash CS4 cơ bản 7.2 Flash tạo motion tween với thời gian mặc định là một giây, đồng thời di chuyển Playhead đến frame 24: Bạn cần tạo keyframe cho frame 24 này. Bạn bấm phím mũi tên đi lên (Up), kế đến bấm phím mũi tên đi xuống (Down). Flash bổ sung một keyframe cho frame 24, đồng thời vị trí của Movie Clip vẫn không thay đổi do đã được bù trừ ở thao tác di chuyển phím mũi tên vừa rồi. Bạn sẽ sử dụng tùy chọn Alpha của Color Effect để cho Movie Clip Water-lilies chuyển tiếp từ trạng thái trong suốt (tương ứng với Alpha=0) sang trạng thái hiện rõ hoàn toàn (tương ứng với Alpha=100). 7.3 Giữ phím Ctrl, bấm chọn keyframe đầu của motion tween:
  12. Học Adobe Flash CS4 cơ bản 7.4 Bấm chọn vào Movie Clip Water-lilies trên Stage: 7.5 Chọn Alpha ở mục Style của Color Effect trên Property Inspector:
  13. Học Adobe Flash CS4 cơ bản 7.6 Kéo thanh trượt cho Alpha về giá trị 0:
  14. Học Adobe Flash CS4 cơ bản Lúc này Movie Clip Water-lilies hoàn toàn trong suốt nên bạn nhìn thấy Movie Clip Sunset phía dưới: 7.7 Giữ phím Ctrl, bấm chọn keyframe cuối của motion tween: Lúc này, symbol trên Stage đang ở dạng trong suốt do bị ảnh hưởng từ giá trị Alpha=0 từ keyframe 1:
  15. Học Adobe Flash CS4 cơ bản 7.8 Chọn lại symbol trên Stage 7.8: Kéo thanh trượt cho Alpha về giá trị 100: Bạn thu được kết quả symbol hiện rõ nét:
  16. Học Adobe Flash CS4 cơ bản 7.9 Bạn sẽ giữ nguyên trạng thái hiện rõ nét này trong 2 giây. Chọn frame 72 của layer Water- lilies.jpg: 7.10 Bấm phím tắt F6 để bổ sung keyframe: 7.11 Bạn sẽ thêm 1 giây để chuyển tiếp từ ảnh này sang ảnh khác. Bấm chọn frame 96 của layer Water-lilies.jpg:
  17. Học Adobe Flash CS4 cơ bản 7.12 Bấm phím tắt F6 để bổ sung keyframe: Ghi chú: keyframe tại frame 72 nhằm giúp bạn định vị dễ dàng khi di chuyển các motion tween được giới thiệu ở phần tiếp theo. (còn tiếp)
Đồng bộ tài khoản