Hướng dẫn làm quen với Maya 3D P1

Chia sẻ: Chau Duong | Ngày: | Loại File: PDF | Số trang:10

0
286
lượt xem
107
download

Hướng dẫn làm quen với Maya 3D P1

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Bài đầu tiên có hai phần chính, trong phần 1 sẽ giới thiệu các bạn sơ lược về giao diện chương trình Maya 3D, chức năng các công cụ. GIỚI THIỆU GIAO DIỆN CHƯƠNG TRÌNH VÀ CÁC CÔNG CỤ Khởi động chương trình Maya 3D. Nhấp đúp vào biểu tượng FLEXlm License Manager trên màn hình Desktop. Hộp thoại FLEXlm License Manager xuất hiện, nhấp nút Start sau đó nhấp chọn OK. Chú ý: Nếu không nhấp đúp biểu tượng FLEXlm License Manager trên màn hình Desktop và không nhấp nút Start và OK trong hộp thoại thì bạn không khởi...

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn làm quen với Maya 3D P1

  1. LÀM QUEN VỚI MAYA 3D Bài đầu tiên có hai phần chính, trong phần 1 sẽ giới thiệu các bạn sơ lược về giao diện chương trình Maya 3D, chức năng các công cụ. GIỚI THIỆU GIAO DIỆN CHƯƠNG TRÌNH VÀ CÁC CÔNG CỤ Khởi động chương trình Maya 3D. Nhấp đúp vào biểu tượng FLEXlm License Manager trên màn hình Desktop. Hộp thoại FLEXlm License Manager xuất hiện, nhấp nút Start sau đó nhấp chọn OK. Chú ý: Nếu không nhấp đúp biểu tượng FLEXlm License Manager trên màn hình Desktop và không nhấp nút Start và OK trong hộp thoại thì bạn không khởi động được chương trình. Nhấp đúp biểu tượng Maya Unlimited 2.5 trên màn hình hoặc nhấp chọn Start > Programs > Maya Unlimited 2.5 > Maya khởi động chương trình Maya. Khi đó biểu tượng của hãng và chương trình xuất hiện như hình dưới:
  2. GIAO DIỆN CHƯƠNG TRÌNH Sau khi khởi động xong, giao diện chương trình hiển thị như hình dưới: Bạn có thể ẩn những thành phần giao diện của chương trình, dùng các lệnh đặc trưng của Maya như: Hotbox (hộp thoại nóng), Marking Menu và các phím nóng. Theo mặc định, màn hình Perspective (màn hình phối cảnh) hiển thị đầy màn hình. Nếu muốn hiển thị các màn hình còn lại, di chuyển con trỏ vào màn hình nhấn nhanh phím Spacebar. Khi nhấn nhanh phím Spacebar, vùng làm việc chia thành 4 màn hình top, front, side và persp. Trên mỗi màn hình đều có 5 trình đơn con, những trình đơn con này cho phép chọn dạng hiển thị cho bề mặt (trình đơn Shading), chọn các đối tượng hiển thị (trình đơn Show), chuyển sang màn hình khác (trình đơn Panels)….
  3. Giao diện chương trình bao gồm các phần chính sau: Vùng làm việc, thanh trình đơn, thanh trạng thái, thanh tiêu đề của chương trình, thanh công cụ…v.v. Main Menubar: Thanh trình đơn chính. Status Line: Dòng trạng thái. Tools / Shelf: Các công cụ và ngăn kệ. Feedback line: Dòng thông tin phản hồi Layers bar: Thanh Layer. Pane Menubars: Thanh trình đơn trong các màn hình làm việc (màn hình Top, Left, Perspective…). Workspace: Vùng làm việc. Time Slider: Nút trượt thời gian. Range Slider: Nút trượt dãy. Command line: Dòng lệnh. Help line: Dòng trợ giúp. Channel Box: Các thuộc tính cơ bản của đối tượng hiển thị trong bảng Channel.
  4. Thanh trình đơn chính (Main Menubar): Các thanh trình đơn chính trong Maya được nhóm thành 4 bộ trình đơn khác nhau. Bao gồm: • Animation: Thiết lập keyframe tạo chuyển động cho đối tượng. • Modeling: Xây dựng các nhân vật, đối tượng trong Maya. • Dynamics: Bổ sung các hiệu ứng hạt cho hoạt cảnh. • Rendering: Diễn hoạt cảnh phim hoạt hình. Ngoài ra Maya Unlimited có thêm hai bộ trình đơn: Cloth và Live. Khi chuyển đổi qua lại giữa những bộ trình đơn, trình đơn bên trái vẫn giữ nguyên (7 trình đơn đầu tiên File, Edit, Modify, Create, Display, Window, Options không thay đổi và đây là những trình đơn thông dụng) nhưng những trình đơn bên phải thay đổi. Chuyển đổi qua lại giữa bộ trình đơn bằng cách sử dụng hộp chọn trên dòng Status Line hoặc các phím nóng. Những phím nóng là: F2 (Animation), F3 (Modeling), F4 (Dynamics) và F5 (Rendering).
  5. Khi chọn bộ trình đơn Modeling (F3), thanh trình đơn chính thay đổi như hình dưới: Thanh công cụ Tool và Shelf. Thanh công cụ Tool chứa những công cụ thông dụng dùng chọn (Select Tool), di chuyển (Move Tool), định kích cỡ (Scale Tool), xoay (Rotate Tool)… Thanh công cụ Shelf là một tập hợp những công cụ và những lệnh còn lại, có thể chọn các công cụ và lệnh trong nhóm Shelf phù hợp tùy theo yêu cầu sử dụng. Bằng cách tạo ra những Shelf tùy chỉnh, sắp xếp những công cụ thường sử dụng vào những nhóm (các Shelf) khác nhau. Bạn nên tạo những Shelf lập mô hình (Modeling), Shelf hoạt cảnh (Animating) và diễn hoạt (rendering)…) với những công cụ thích hợp. Một công cụ có thể lưu trữ trong nhiều Shelf nhưng với những thiết đặt khác nhau. Dòng trạng thái (Status Line): Dòng trạng thái có những lệnh khác nhau, được dùng lập mô hình. Nhóm nút ở giữa được dùng chọn các đối tượng và các phần tử. • Menu Selector: Bộ chọn trình đơn. • Lock Button: Nút khóa. • Selection Mode: Các chế độ vùng chọn. • Selection Mask: Vùng chọn mặt nạ. • Snap Mode: Chế độ bắt dính. • Make Live Button: Làm cho sống động. • List of operations buttons: Danh sách những thao tác đã thực hiện. • Construction History Button: Lưu lại quá trình dựng cảnh phim.
  6. Feedback Line: Dòng Feedback Line cung cấp thông tin cần thiết khi biến đổi các đối tượng. Dòng Feedback Line có hai ngăn: Một ngăn phản hồi thông tin, một ngăn dùng nhập giá trị muốn thay đổi cho đối tượng. Thực hiện ví dụ sau đây để hiểu rõ hơn công dụng của Feedback Line. Trên thanh trình đơn chính (Main Menubar) nhấp chọn File > New Scene tạo môi trường làm việc mới. Nếu cửa sổ WARNING xuất hiện, chọn No không lưu cảnh phim hiện hành. Nếu dòng Feedback Line chưa được mở, trên thanh trình đơn chính nhấp chọn Options > Feedback Line (bật dấu kiểm). Tiếp tục, chọn lệnh Create > Polygon Primitives > Cube tạo khối hình hộp. Theo mặc định, đối tượng vừa tạo được chọn và nằm ở gốc tọa độ. Trên thanh trình đơn của màn hình persp, chọn Shading > Smooth Shade All hiển thị tất cả đối tượng ở dạng trơn phẳng. Trên thanh công cụ, chọn Scale Tool hoặc nhấn phím R trên bàn phím. Trong khung bên phải của dòng lệnh Feedback Line nhập giá trị abs: 5 2 2 để tăng tỉ lệ hình khối theo 3 trục x, y, z: (5, 2, 2). Nhớ nhấn phím Spacebar định khoảng trắng giữa các giá trị, sau khi nhập giá trị xong nhấn phím Enter chấp nhận.
  7. Quan sát kết quả trước và sau khi thay đổi giá trị Scale. Nếu muốn thay đổi một trục, chỉ nhập giá trị cho trục đó, còn trục không muốn đổi thì để dấu “.”. Mỗi ký tự được cách nhau bởi một khoảng trắng (Spacebar). Tiếp tục, chỉ thay đổi kích cỡ theo trục Y, còn trục X và Z vẫn giữ nguyên. Nhập giá trị abs: (. 5 .) vào dòng lệnh Feedback Line, nhấn phím Enter chấp nhận. Kết quả khối hình hộp thay đổi như hình: Pane Menubar: Pane Menubar là một dạng trình đơn trong các màn hình. Pane Menubar trong các màn hình persp, side, front, top giống nhau, còn các trình đơn của màn hình Hypergraph, Hypershade, Render View… khác nhau tùy theo chức năng của chúng. Để chuyển đổi từ màn hình persp sang màn hình Hypergraph, trên thanh trình đơn của màn hình (Pane Menubar) nhấp chọn Panels > Panel > Hypergraph. Kết quả màn hình persp được chuyển thành màn hình Hypergraph như hình dưới:
  8. Chuyển màn hình Hypergraph sang màn hình persp bằng cách: Trên thanh trình đơn của màn hình Hypergraph chọn Panels > Perspective > persp. Trình đơn Show của mỗi màn hình cho phép chọn các đối tượng hiển thị. Nếu không muốn đối tượng nào hiển thị trong màn hình làm việc, bỏ dấu kiểm trước mục đó. Trên thanh trình đơn Show của màn hình persp, bỏ dấu kiểm trước mục Grid để không hiển thị mặt phẳng lưới. Kết quả có được như hình:
  9. Thanh Layer (Layer Bar): Thanh Layer tập hợp các đối tượng để việc quản lý các đối tượng trong màn hình dễ dàng hơn. Để quản lý các đối tượng, tạo layer mới, gán các đối tượng vào layer, khóa các đối tượng trong layer, làm cho layer hiển thị (visible) hoặc không hiển thị (invisible). Theo mặc định thanh Layer được ẩn, hiển thị thanh Layer bằng cách chọn lệnh Options > Layer Bar từ thanh trình đơn chính. Tạo layer mới bằng cách nhấp nút Create a new Layer. Layer mới được tạo với tên mặc định layer1. Nhấp đúp vào layer1, nhập tên hinhhop trong cửa sổ Rename Layer. Vùng làm việc (Workspace): Vùng làm việc chính là nơi quan sát các đối tượng. Có thể hiển thị những trình chỉnh sửa Editor và sắp xếp các vùng làm việc theo những bố cục khác nhau. Vuøng laøm vieäc (Workspace)
  10. Theo mặc định màu nền màn hình có màu xám, thay đổi màu nền bằng cách chọn lệnh Options > Customize UI > Colors.  
Đồng bộ tài khoản