Hướng dẫn làm quen với Maya 3D P5

Chia sẻ: Chau Duong | Ngày: | Loại File: PDF | Số trang:13

0
139
lượt xem
59
download

Hướng dẫn làm quen với Maya 3D P5

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Sử dụng trình đơn Marking trong Hotbox: Nhấn giữ phím Spacebar hiển thị hộp thoại nóng Hotbox. Hotbox có 5 vùng: North, South, East, West và Center. Chúng được xác định bằng những đường chéo. Nhấn giữ phím Spacebar, nhấp nút trái chuột vào một vùng rồi rê để chọn một đề mục trình đơn và nhả phím Spacebar. Ở một trong 5 vùng này, Hotbox hỗ trợ một trình đơn Marking khác nhau cho từng nút chuột. Điều này tạo ra ba trình đơn trong mỗi vùng, tổng cộng là 15 trình đơn Marking và xấp xỉ 120 vùng...

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn làm quen với Maya 3D P5

  1. LÀM QUEN VỚI MAYA 3D Sử dụng trình đơn Marking trong Hotbox: Nhấn giữ phím Spacebar hiển thị hộp thoại nóng Hotbox. Hotbox có 5 vùng: North, South, East, West và Center. Chúng được xác định bằng những đường chéo. Nhấn giữ phím Spacebar, nhấp nút trái chuột vào một vùng rồi rê để chọn một đề mục trình đơn và nhả phím Spacebar. Ở một trong 5 vùng này, Hotbox hỗ trợ một trình đơn Marking khác nhau cho từng nút chuột. Điều này tạo ra ba trình đơn trong mỗi vùng, tổng cộng là 15 trình đơn Marking và xấp xỉ 120 vùng chọn. Tùy chỉnh một trình đơn Marking bằng Marking Menu Editor. Các trình đơn Marking mặc nhiên Những trình đơn Marking sau đây là thiết đặt mặc nhiên cho mỗi vùng trong số 5 vùng: o North zone: Đổi sang bố cục màn hình mới, nhấn giữ phím Spacebar rồi nhấp tiếp vào vùng trên của Hotbox. o South zone: Thay đổi màn hình quan sát trong màn hình hiện hành, nhấn giữ phím Spacebar rồi nhấp tiếp vào vùng dưới của Hotbox.
  2. o West zone: Chuyển đổi giữa các mặt nạ vùng chọn preset, nhấn giữ phím Spacebar rồi nhấp tiếp vào vùng dưới của Hotbox. o East zone: Mở và tắt những phần trong màn hình hiển thị giao diện, nhấn giữ phím Spacebar rồi nhấp tiếp vào vùng bên phải của Hotbox. o Center zone: Chuyển đổi giữa các màn hình quan sát, nhấn giữ phím Spacebar rồi nhấp tiếp vào vùng giữa Hotbox. QUẢN LÝ CẢNH PHIM Trong Maya, có những đặc trưng khác nhau nhằm tổ chức những thành phần trong cảnh phim và để tối ưu kích cỡ file. Danh sách dưới đây tóm tắt một số đặc trưng quản lý cảnh phim chính. Groups: Tập hợp những đối tượng để có vùng chọn nhanh và vận hành chúng trọn vẹn.
  3. Set và Partition: Set giống như các nhóm (group) nhưng thuận lợi hơn trong khi làm việc với phần tử. Partition là một tập hợp các Set, được dùng để ngăn ngừa hai set có những đối tượng trùng lắp. Layer: Layer là một phương pháp tập hợp các đối tượng để bạn dễ dàng ẩn chúng từ màn hình quan sát. Layer Bar cung cấp những lệnh điều khiển chính trong việc tạo các layer, bổ sung đối tượng vào layer và làm cho các layer hiển thị hoặc không hiển thị. Tạo cảnh phim tối ưu: Trước khi lưu, nên tối ưu kích cỡ cảnh phim, công dụng bộ nhớ và rút gọn không gian đĩa (chọn lệnh trên thanh trình đơn chính File > Optimize Scene Size). Xóa tổng thể Construction History (nếu nó đã kích hoạt) khi kết thúc việc lập mô hình và sẵn sàng linh hoạt hóa đối tượng. (Construction history: Là một bản ghi thông tin đã được dùng trong việc xây dựng một đối tượng). Xóa tổng thể đối tượng để giảm bộ nhớ máy tính bằng cách chọn đối tượng và chọn lệnh Edit > Delete by Type > History từ thanh trình đơn chính. Tắt bảng Construction History bằng cách nhấp chọn Construction History On/Off trong thanh Status Line. TRỢ GIÚP HELP Có nhiều loại trợ giúp trực tuyến được cung cấp: Popup Help: Khi di chuyển con trỏ qua một công cụ hoặc nút, phần mô tả của nó xuất hiện. Đặc trưng này mở theo mặc định, vô hiệu hóa nó bằng cách chọn Help > Popup Help (bỏ dấu kiểm).
  4. Help Line: Help Line ở đáy cửa sổ của Maya cho thấy thông tin về các công cụ, trình đơn và các đối tượng. Nó hiển thị những mô tả khi di chuyển chuột qua các công cụ cũng như những đề mục trình đơn. Nó cũng hiển thị những hướng dẫn khi chọn một công cụ. Trên thanh trình đơn chính chọn lệnh Help > Product Information xem phiên bản của Maya và ngày tháng phát hành. Online Library: Cũng ở phía dưới trình đơn Help là những vùng chọn cho thư viện tài liệu trực tuyến. Trợ giúp này đòi hỏi phiên bản 4.0 hoặc cao hơn hoặc của Netscape Communicator hoặc Internet Explorer. Nhiều tài liệu trong số này khả dụng trong định dạng PDF, có thể in, đọc từ Maya CD-ROM. Help on: Đối với một số trình chỉnh sửa Maya, mở trợ giúp về trình chỉnh sửa Editor trực tiếp bằng cách chọn Help > Library. CÁC CHỨC NĂNG TRONG MAYA: GIAO DIỆN NGƯỜI SỬ DỤNG (USER INTERFACE): Giao diện người sử dụng bao gồm một số công cụ, các trình chỉnh sửa và các nút điều khiển. Có thể dùng các Shelf lưu trữ các công cụ thường sử dụng hoặc các phím nóng (Hot key) để tăng năng suất khi làm việc. Maya cho phép thiết đặt giao diện người sử dụng phù hợp với yêu cầu. Khi làm việc với các đối tượng, nhập các giá trị vào bảng Channel bên phải giao diện (định vị trí, kích thước và một số thuộc tính của đối tượng…) hoặc sử dụng bộ điều khiển Manipulator 3D để tương tác.
  5. Làm việc trong không gian ba chiều (3D) Trong Maya, bạn sẽ xây dựng và linh hoạt hóa các đối tượng theo không gian ba chiều, được xác định bởi các trục cơ bản X, Y và Z. Với trục X - chiều dài (X), trục Y- chiều cao và trục Z – chiều sâu. Những trục này được qui ước như sau: Đỏ cho trục X, xanh lục cho trục Y và xanh lam cho trục Z. Move Rotate Scale Bộ điều khiển (Transform Manipulator) Khi định vị trí, định tỉ lệ và xoay các đối tượng, ba trục Manipulator đóng vai trò như những điểm tham chiếu chính. Tâm của hệ thống được gọi là gốc tọa độ có trị số (0, 0, 0). Không gian tọa độ UV (UV coordinate space) Khi xây dựng các bề mặt trong Maya, chúng được tạo với chính không gian tọa độ được xác định bởi U theo một hướng và V theo một hướng khác. Dùng tọa độ UV khi làm việc với các đối tượng đường cong trên một bề mặt hoặc khi bố trí các kết cấu trên một bề mặt. Một gốc của bề mặt có vai trò như gốc tọa độ của hệ thống và tất cả các tọa độ nằm trực tiếp trên bề mặt đó. Màn hình (View) Màn hình là nơi xây dựng các đối tượng và xem diễn hoạt các cảnh phim, màn hình phối cảnh Perspective cho xem các cảnh phim trong không gian 3 chiều. Màn hình nào có khung hình chữ nhật bao quanh, màn hình đó được chọn. Thông thường bạn nên nhấp chuột phải để chọn màn hình làm việc. Các màn hình Top, Side và Front là các màn hình nhìn đối tượng từ mặt trên, mặt bên và mặt trước.
  6. Trong quá trình xây dựng đề án sẽ cần nhiều màn hình để xác định vị trí thích hợp cho các đối tượng và xem kết quả trong màn hình Perspective, Render. Quay phim (Camera) Để đạt được một màn hình riêng biệt, hãy nhìn qua máy ảnh kỹ thuật số. Máy quay phim phối cảnh sử dụng tầm nhìn ở một điểm và tiêu cự. Mặt phẳng hình ảnh (Image Plane) Khi làm việc với các máy quay phim, có thể đặt các đối tượng lên mặt phẳng hình ảnh trên máy quay phim. Mặt phẳng hình ảnh được đặt trên máy quay phim sao cho khi di chuyển máy quay phim, mặt phẳng vẫn đứng thẳng. ĐỒ HỌA PHỤ THUỘC (DEPENDENCY GRAPH): Cấu trúc hệ thống của Maya sử dụng một hệ biến hóa theo mẫu cho bạn hợp nhất loại hoạt hình keyframe theo truyền thống, động học đảo, động lực học và viết kịch bản theo cấu trúc dựa trên tiếp điểm, gọi là đồ họa phụ thuộc (Dependency Graph). Nếu muốn thu gọn đồ họa này thành những yếu tố rỗng, mô tả nó như là những tiếp điểm với các thuộc tính được nối kết. Cấu trúc dựa trên tiếp điểm mang đến cho Maya những tính chất theo mẫu linh hoạt của nó. Tiếp điểm (Node) Mỗi thành phần trong Maya, dù là một đường cong, bề mặt, khối biến dạng, ánh sáng, kết cấu, sự biểu diễn, một tác vụ lập mô hình hoặc một đường cong hoạt hình đều được mô tả bằng một tiếp điểm đơn lẻ hay một dãy tiếp điểm nối kết. Tiếp điểm là một loại đối tượng chung trong Maya. Những tiếp điểm khác nhau được thiết kế với các thuộc tính riêng biệt. Các tiếp điểm xác định tất cả các loại đối tượng bao gồm đối tượng hình học, việc tạo bóng và chiếu sáng. Dưới đây là ba loại tiếp điểm điển hình khi chúng xuất hiện trên một hình cầu nguyên thể.
  7. • Tiếp điểm biến đổi (Transform node): Các tiếp điểm biến đổi chứa thông tin bố trí cho các đối tượng, khi dịch chuyển, quay tròn hoặc định tỉ lệ, đây là tiếp điểm mà bạn đang tác động đến. • Tiếp điểm đầu vào (Input node): Tiếp điểm đầu vào trình bày các tùy chọn, hướng dẫn sự sáng tạo hình dáng hình cầu. • Tiếp điểm hình dạng (Shape node): Tiếp điểm hình dạng chứa tất cả thông tin chi tiết trình bày hình dáng thực của hình cầu. Giao diện người sử dụng của Maya trình bày các tiếp điểm theo nhiều cách. Hình bên là bảng Channel, nơi chỉnh sửa và linh hoạt hóa các thuộc tính tiếp điểm. Các thuộc tính (Attribute): Mỗi tiếp điểm được xác định bởi các thuộc tính có liên quan đến tiếp điểm đó. Trong trường hợp của tiếp điểm biến đổi, Translate X là một thuộc tính. Đối với trường hợp của tiếp điểm shade, Color Red là một thuộc tính. Có thể gán những trị số cho các thuộc tính đó, làm việc với các thuộc tính trong một số cửa sổ giao diện người sử dụng bao gồm Attribute Editor, Channel box và Spread Sheet Editor. Cửa sổ Attribute Editor hiển thị tất cả các thuộc tính của đối tượng được chọn. Mở cửa sổ Attribute Editor bằng cách nhấp chọn đối tượng cần hiển thị thuộc tính, nhấn tổ hợp phím Ctrl + A. Một đặc trưng quan trọng là có thể linh hoạt hóa gần như mỗi thuộc tính trên một tiếp điểm bất kỳ. Những trợ giúp này mang lại cho Maya một quyền năng khi làm hoạt hình, các thuộc tính đều được xem như những kênh (channel).
  8. Các nối kết (Connection): Các tiếp điểm không tồn tại trong sự cô lập. Một phim hoạt hình hoàn chỉnh mang lại kết quả khi bắt đầu thực hiện những nối kết giữa các thuộc tính trên những tiếp điểm khác nhau. Trong khi lập mô hình, những kết nối này đôi khi được xem như tổng thể dựng hình. Đa số những nối kết đều được tạo bởi giao diện người sử dụng như một kết quả của việc sử dụng lệnh hoặc các công cụ. Xây dựng và chỉnh sửa những nối kết này bằng cách nhập các lệnh MEL (Maya Embedded Language - Ngôn ngữ Maya) hoặc bằng cách ghi các biểu thức dựa trên MEL. Thứ bậc (Hierarchies): Khi xây dựng những hoạt cảnh, xây dựng những nối kết phụ thuộc để liên kết các thuộc tính tiếp điểm. Khi làm việc với các tiếp điểm biến đổi hoặc những tiếp điểm khớp nối, xây dựng các thứ bậc tạo mối quan hệ khác nhau giữa các đối tượng. Trong một thứ bậc, tiếp điểm biến đổi là bậc trên đối với tiếp điểm khác. Khi làm việc với những tiếp điểm này, trước tiên Maya nhìn vào tiếp điểm phía trên hoặc tiếp điểm gốc, sau đó tìm xuống thứ bậc đó. Vì thế, chuyển động từ các tiếp điểm ở trên được di chuyển xuống thành các tiếp điểm thấp hơn. Nếu tiếp điểm ở trên được quay tròn, hai tiếp điểm thấp hơn (nurbsCone) sẽ quay theo tiếp điểm ở trên. Nếu tiếp điểm nurbsCone quay tròn, các tiếp điểm trên không bị ảnh hưởng. Các thứ bậc khớp nối được dùng khi xây dựng nhân vật. Khi tạo các khớp nối, các trục quay khớp nối đóng vai trò như những khớp nối chân tay trong khi các xương được vẽ giữa chúng giúp hình dung ra một chuỗi khớp nối. Theo mặc định, những thứ bậc này hoạt động giống như các thứ bậc đối tượng. Khi quay tròn một đối tượng sẽ quay tròn tất cả các tiếp điểm dưới thấp cùng một lúc. Trục quay (Pivot): Các tiếp điểm biến đổi đều được xây dựng với một thành phần đặc biệt được biết như điểm trục quay. Cũng giống như các trục quay cánh tay quanh khuỷu tay, trục quay giúp quay tròn một tiếp điểm biến đổi. Bằng cách thay đổi vị trí của điểm trục quay, sẽ có những kết quả khác nhau. Các trục quay cơ bản là một điểm tĩnh mà từ đó có thể quay tròn hoặc định tỉ lệ các đối tượng. Khi thực hiện hoạt hình, đôi khi cần xây dựng những thứ bậc nơi một tiếp điểm biến đổi quay tròn đối tượng, tiếp điểm biến đổi thứ hai định tỉ lệ. Từng tiếp điểm có vị trí trục quay của chính nó để đạt được hiệu ứng theo ý.
  9. Các lệnh MEL: MEL là chữ viết tắt từ Maya Embedded Language. Trong giao diện làm việc khi sử dụng một công cụ nào đó hoặc mở một cửa sổ có nghĩa bạn đang sử dụng MEL. MEL được dùng thực hiện những lệnh đơn giản, ghi các biểu thức hoặc xây dựng kịch bản sẽ triển khai tính hoạt động hiện hữu của Maya. LÀM PHIM HOẠT HÌNH VỚI MAYA: Khi làm phim hoạt hình, tức là mang lại sự sống cho các đối tượng. Có nhiều phương cách khác nhau để linh hoạt hóa cảnh phim và các nhân vật. Phim hoạt hình trong Maya được đo tổng quát bằng các frame. Có thể trình chiếu những frame này theo những tốc độ khác nhau để đạt được hiệu ứng hoạt hình. Theo mặc định, Maya trình chiếu 24 frame trong mỗi giây (24 khung hình trong 1 giây). Keyframe: Phương pháp quan trọng nhất trong việc làm phim hoạt hình là thiết lập keyframe hay còn gọi tắt là key (tạo chuyển động cho đối tượng). Khi sử dụng kỹ thuật này, phải xác định từng phần của đối tượng trông như thế nào trong một frame riêng biệt, sau đó lưu giữ các thuộc tính quan trọng như những key. Thiết lập key được tính theo một thuộc tính riêng biệt, những trị số lập key đều được lưu trữ trong những đường đặc biệt gọi là các đường cong hoạt hình. Những đường cong này xác định bởi những key ánh xạ trị số của thuộc tính đối lập với thời gian. Điều chỉnh đối tượng chuyển động nhanh hoặc chậm bằng cách chỉnh sửa hình dạng của những đường cong hoạt hình. Nói chung, độ nghiêng của đường cong đồ họa cho biết tốc độ của chuyển động. Độ nghiêng dốc của đường cong mang ý nghĩa chuyển động nhanh, đường cong phẳng có nghĩa là không có chuyển động. Bạn hãy tưởng tượng người đi ván trượt tuyết đang xuống đồi, độ nghiêng càng dốc càng tăng tốc độ trong khi những phần phẳng hơn sẽ làm chậm tốc độ. Đường dẫn hoạt hình (Path animation): Đường dẫn hoạt hình được xác định ngay từ tên gọi của nó, có thể gán một hay nhiều đối tượng sao cho chúng di chuyển dọc theo đường dẫn được vẽ như một đường cong trong không gian ba chiều. Sau đó, sử dụng hình dáng đường cong đó và những điểm marker đường dẫn để điều chỉnh chuyển động. Hoạt hình Reactive: Hoạt hình Reactive là một thuật ngữ được dùng để mô tả phim hoạt hình mà trong đó sự linh hoạt của đối tượng này dựa trên chuyển động của một đối tượng khác. Ứng dụng kỹ thuật này như sau: Làm chuyển động các bánh răng, khi quay tròn một bánh răng sẽ làm cho bánh răng kia quay tròn theo. Sau đó, thiết lập key trên bánh răng thứ nhất và tất cả những bánh răng còn lại sẽ quay theo. Khi muốn chỉnh sửa các key, chỉ cần một đối tượng hoạt động những đối tượng còn lại cũng cập nhật một cách tương tác (chúng cũng chuyển động theo). Thiết lập hoạt hình Reactive với một số công cụ sau: • Set Driven Key: Thiết lập thuộc tính một cách tương tác trên một đối tượng để điều khiển một hay nhiều thuộc tính trên một đối tượng khác. • Expression: Những lệnh cho phép nối kết các thuộc tính khác nhau trên những tiếp điểm khác nhau. • Constraints: Cho phép thiết lập một đối tượng, hướng đến hoặc nhìn vào một đối tượng khác. • Các kết nối (Connection): Những thuộc tính có thể được liên kết trực tiếp với một thuộc tính khác bằng các nối kết tiếp điểm phụ thuộc. • Động lực học (Dynamics): Một kỹ thuật hoạt hình khác nữa là động lực học (Dynamics). Thiết lập các đối tượng trong cảnh phim sống động dựa trên các hiệu ứng vật lý như sự va chạm, trọng lực, gió...
  10. Có thể thiết lập những biến số khác nhau như: Sự nẩy, ma sát hoặc vận tốc ban đầu. Kỹ thuật này cho phép tạo chuyển động tự nhiên, nếu các bạn thiết lập keyframe để tạo chuyển động cho đối tượng thì chuyển động không tự nhiên. Có thể sử dụng động lực học với những đối tượng cứng, những hạt hoặc các đối tượng mềm. • Đối tượng cứng (Rigid body objects) là những đối tượng không cần biến dạng. Thiết lập loại mô phỏng bằng cách thiết lập các đối tượng như những cơ thể hoạt động hoặc cứng nhắc, thụ động. Các cơ thể hoạt động phản ứng với động lực học, trong khi những cơ thể thụ động chỉ đóng vai trò như những đối tượng va chạm dành cho các cơ thể hoạt động. Để mô phỏng các hiệu ứng như gió hoặc trọng lực, sử dụng các trường thuộc động lực học được bổ sung cho cảnh phim sau đó được nối kết với các đối tượng. • Hạt Particle là những phần thật nhỏ được dùng tạo những hiệu ứng như khói, lửa hoặc những vụ nổ. • Đối tượng mềm là những bề mặt muốn làm biến dạng trong suốt quá trình mô phỏng. Để tạo một đối tượng mềm, cần phối hợp một bề mặt với một loạt các hạt. Các hạt này phản ứng với sức ép động lực học làm cho bề mặt biến dạng. LẬP MÔ HÌNH TRONG MAYA: Những đối tượng phim hoạt hình thường được xây dựng bằng các bề mặt NURBS hoặc bề mặt lưới đa giác. • Đường cong NURBS: NURBS (viết tắt từ chữ Non-Uniform Rational B-Splines) là một thuật ngữ kỹ thuật dùng cho đường cong Spline. NURBS có được tính linh hoạt phụ thuộc vào việc chỉnh sửa hình dạng hình học bằng các nút điều khiển. Khi hình dạng trở nên phức tạp, có nhiều nút điều khiển hơn. • Bề mặt NURBS (NURBS surfaces): Các bề mặt được xác định giống như những đường cong, ngoại trừ có trong hai chiều U và V. Về cơ bản, những hình dạng phức tạp có thể được khắc họa bằng loại bề mặt NURBS khi điều chỉnh các nút điều khiển để tạo dáng cho bề mặt đó. • Đa giác (Polygon): Đa giác là một loại hình học khả dụng trong Maya. Trong khi các bề mặt NURBS thêm vào dựa trên phép nội suy dạng của hình học một cách tương tác, thì các mắt lưới đa giác vẽ trực tiếp vào các chỏm điều khiển. Khi một mắt lưới đa giác được trình diễn, nó được thêm vào để hình dáng sắc xảo hơn. • Tổng thể dựng hình (Construction History): Khi tạo những mô hình mẫu trong Maya, những bước dựng hình khác nhau đều được ghi lại như những tiếp điểm có tính phụ thuộc nối kết với bề mặt. Người ta sử dụng một đường cong để tạo ra một bề mặt xoay tròn. Maya giữ lại tổng thể này bằng cách tạo những điểm phụ thuộc giữa đường cong, tiếp điểm xoay tròn và tiếp điểm hình dạng. Khi chỉnh sửa sẽ làm cho đường cong và tiếp điểm xoay tròn cập nhật hình dạng cuối cùng. Nhiều tiếp điểm trong số này đi kèm với những bộ thao tác (Manipulator) đặc biệt giúp cho việc cập nhật các thuộc tính tiếp điểm được dễ dàng hơn. BỘ BIẾN DẠNG (DEFORMER): Bộ biến dạng được dùng tái tạo hình dạng đối tượng. Bằng cách sử dụng những bộ biến dạng, có thể khai thác tính chất bóp dẹp và kéo căng vào cảnh hoạt hình. Một đặc trưng nữa có tác động mạnh trong bộ biến dạng của Maya 3D là được xếp lớp đối với những hiệu ứng phức tạp hơn. Có thể liên kết các bộ biến dạng vào các bộ khung hoặc tác động với động lực học thân mềm. Bên dưới trình bày một số loại bộ biến dạng khả dụng: Mạng, dàn (Lattices): Lattices là những khung bên ngoài được áp dụng cho các đối tượng, nếu đổi hình dạng khung thì đối tượng biến dạng theo.
  11. Đối tượng khắc họa, chạm trổ (Sculpt objects): Các đối tượng điêu khắc làm biến dạng bề mặt bằng cách khắc lên nó một đối tượng khác. Có thể đạt được những biến dạng bề mặt sinh động bằng cách linh hoạt hóa vị trí của đối tượng điêu khắc. Cluster: Cluster là những nhóm CVs hoặc các điểm dàn được xây dựng thành một bộ riêng rẽ. Cluster dùng cho điểm trục quay của chính nó và được dùng để kéo các điểm cluster. Gắn thêm trọng lượng cho Cvs trong một cluster để đạt được những hiệu ứng phức tạp hơn. Hoạt hình nhân vật: Hoạt hình nhân vật bao hàm cả việc hoạt hình của các mặt phẳng sử dụng các chuỗi khớp nối bộ khung và đảo ngược các mấu động hình học để điều khiển chuyển động. Các mắt xích được thiết lập để hoạt động với những đối tượng điêu khắc đặc biệt và những dàn (lattices) được biết như những công cụ. Những công cụ này cho phép làm biến dạng mặt phẳng để tăng thêm tính hiện thực cho nhân vật. Bộ khung và các khớp nối (Skeletons and joints): Các dãy khớp nối bộ khung thực ra là những thứ bậc. Một bộ khung được chế tạo từ các tiếp điểm khớp được nối kết với nhau bên ngoài bởi những biểu tượng xương. Các thứ bậc này cho phép tập hợp hoặc liên kết theo hình học nhằm tạo biến dạng trên mặt phẳng. Động hình học đảo (Reverse Kinematics): Theo mặc định, các dãy khớp nối hoạt động giống như những thứ bậc khác. Sự quay tròn một khớp sẽ làm chuyển động các tiếp điểm khớp nối bên dưới. Điều này được biết như động hình học tiến tới. Phương pháp này có tác động mạnh, ngoài ra có nhiều khó khăn trong việc đặt chân của nhân vật xuống hoặc làm chuyển động bàn tay để điều khiển cánh tay. Động hình học đảo cho phép làm việc với thứ bậc theo hướng ngược lại. Bằng cách đặt một mấu IK chạy từ khớp khởi đầu đến khớp cuối có thể điều khiển dãy khớp đó thuận lợi hơn. Có ba bộ giải trong Maya - đó là IK spline, dãy IK riêng rẽ (In single chain) và mặt phẳng quay IK (IK rotate plane). Từng phần trong số những bộ giải này được thiết kế nhằm điều khiển sự quay khớp, sử dụng mấu IK như là mục đích. Khi mấu IK chuyển động, bộ giải IK xác định những khớp quay để cho khớp cuối cùng chuyển động đến vị trí mấu IK. Các bộ giải riêng biệt có những tiếp tuyến điều khiển riêng. Một số bộ giải được trình bày như sau: Bộ giải chuỗi xích riêng lẻ (Single chain solver): Bộ giải chuỗi xích riêng lẻ cung cấp một cơ cấu tiến tới thẳng để bố trí tư thế và làm sống động cho một chuỗi. Bằng cách di chuyển mấu IK, chuỗi xích sẽ cập nhật sao cho các khớp nối cùng nằm trên một mặt phẳng. Bộ giải mặt phẳng quay (Rotate plane solver): Bộ giải mặt phẳng quay cho phép điều khiển nhiều hơn. Với bộ giải này, mặt phẳng hoạt động như mục tiêu đối với tất cả các khớp nối có thể được chuyển động bởi việc quay bằng thuộc tính vặn xoắn hoặc bằng cách chuyển động mấu vector cực. Bộ giải IK spline (IK spline solver):
  12. Bộ giải IK spline điều khiển chuỗi xích bằng đường cong spline. Chỉnh sửa các điểm CVs trên đường spline điều khiển sự quay của các khớp nối trong chuỗi xích. Tạo lớp da cho nhân vật: Một khi đã xây dựng một bộ khung, nối liền bộ da cho bề mặt nhân vật sao cho chúng thay đổi hình dáng theo sự quay của các khớp. Có thể tạo lớp da mềm hoặc cứng, phần da mềm sử dụng các cluster có trọng lượng trong khi lớp da cứng thì không. Flexors: Trong nhiều trường hợp, việc tạo lớp da cho nhân vật không phải là những biến dạng thực sự của sản phẩm trong các vùng khớp nối của nhân vật. Có thể sử dụng các flexors để bổ sung mức độ biến dạng thứ yếu vào việc phồng lên và xẹp xuống của đối tượng. TRÌNH DIỄN (RENDERING): Sau khi đã có cảnh phim hoàn chỉnh, áp dụng thêm màu sắc và kết cấu sau đó trình diễn với ánh sáng thực. Các nhóm bóng đổ Bổ sung thêm các bản đồ kết cấu và những hiệu ứng trình diễn khác bằng các nhóm bóng đổ. Nhóm bóng đổ là một mạng các tiếp điểm phụ thuộc cùng nối kết với nhau thành một tiếp điểm nhóm bóng đổ. Có thể nghĩ nhóm bóng đổ như là một cái xô mà trong đó đặt tất cả các tính chất về màu sắc, kết cấu và chất mà bạn muốn tô điểm trên bề mặt nhân vật. Sau đó, nhúng bề mặt đó vào chiếc xô và đưa thêm vào một hoặc hai ánh đèn và thế là đạt được kết quả sau cùng. Bản đồ kết cấu (Texture map) Để bổ sung chi tiết cho các nhóm bóng đổ, lập bản đồ kết cấu với nhiều thuộc tính khác nhau. Một vài thuộc tính trong số này bao gồm cả sự rung động, tính trong suốt và màu sắc. Chiếu sáng (Lighting) Trước khi trình diễn một cảnh hoạt hình, chiếu sáng cảnh đó bằng một số nguồn ánh sáng, phần ánh sáng này bổ sung thêm tâm trạng và bầu không khí cho cảnh phim theo nhiều cách như ánh sáng của nhà nhiếp ảnh. Trình diễn phần cứng (Hardware rendering) Maya bao gồm cả hiệu ứng phần cứng trình diễn để xem trước những hình ảnh trên màn hình. Sử dụng công cụ trình diễn (render) để biểu diễn một số hiệu ứng hạt (particle effect), các hiệu ứng này được phối hợp vào phần mềm trình diễn hình ảnh trong mô hình hình học. Chuyển động nhòe (Motion Blur) Hiệu ứng chuyển động làm nhòe bổ sung thêm phần sống động cho hoạt cảnh, có hai loại hiệu ứng làm nhòe chuyển động là solution 2 1/2D và solution 3D (ba chiều). Trình diễn trong vùng đệm (Buffer Rendering) Mặc định, chương trình sử dụng phần trình diễn buffer cho trình diễn phần mềm (Software rendering). Kiểu trình diễn này xem những cảnh được tạo bóng với những bóng đổ và
  13. chuyển động nhòe. Phương pháp này rất quan trọng với hầu hết các trình diễn. Nếu muốn tạo các hiệu ứng phản xạ (reflection) và khúc xạ (refraction), cần mở hiệu ứng raytracing. Trình diễn hiệu ứng phát tia (Raytrace rendering) Hiệu ứng raytracing đưa cả hiệu ứng khúc xạ và phản xạ vào cảnh phim. Công cụ trình diễn (render) Công cụ trình diễn hoạt động bằng cách xem xét cảnh phim qua máy ảnh. Sau đó nó thực hiện một phân đoạn hoặc chia ra rồi phân tích có hay không thể trình diễn phân đoạn đó. Nếu có thể, phối hợp thông tin được tìm thấy trong nhóm tạo bóng (hình học, ánh sáng và mạng tạo bóng) với thông tin Render Global và toàn bộ các phân đoạn đều được trình diễn. Khi công cụ trình diễn di chuyển trên phân đoạn kế tiếp, nó phân tích tình huống lần nữa. Khi đang sử dụng hiệu ứng phát tia (raytracing) trước tiên mỗi phân đoạn sẽ được trình diễn với Buffer, sau đó công cụ trình diễn (render) mới tìm những phần tử cần thiết cho việc phát tia. Nếu tìm ra điều gì đó, nó sẽ xếp lớp trong những phân đoạn đã phát tia. Khi kết thúc, sẽ có được hình ảnh sau cùng hoặc nếu đang trình diễn một cảnh hoạt hình thì đó là một chuỗi hình ảnh (đoạn phim). IPR Maya bao gồm công cụ trình diễn ảnh thực tương tác (Interactive Photorealistic Renderer) nhằm cung cấp sự hồi tiếp (feedback) nhanh nhằm lập kết cấu và cập nhật ánh sáng.  
Đồng bộ tài khoản