Hướng dẫn sử dụng chương trình Microsim Eval 8.0

Chia sẻ: Tran Long | Ngày: | Loại File: PDF | Số trang:57

1
120
lượt xem
36
download

Hướng dẫn sử dụng chương trình Microsim Eval 8.0

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Lĩnh vực điện tử - công nghệ thông tin trong những thập kỉ gần đây paht1 triển với tốc độ nhanh chóng. Các ứng dụng của nó rất phong phú và đang thâm nhập vào nhìu lĩnh vực kinh tế, kĩ thuật...Một trong số những ứng dụng đó là sự ra đời các chương trình kinh tế, mô phỏng tự động các mạch điện tử.

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng chương trình Microsim Eval 8.0

  1. ng d n s d ng ch ng trình MicroSim Eval 8.0 NG D N S D NG CH NG TRÌNH Giáo viên h ng d n : Th c s H Vi t Vi t p : 03 T1 Nhóm : 06 Các thành viên : Ngô c Ngh a Hu nh Kim Oanh Lê H ng Phong Th Phú 1 Nhóm 6 - L p 03 T1
  2. ng d n s d ng ch ng trình MicroSim Eval 8.0 I NÓI U nh v c n t -Công ngh thông tin trong nh ng th p k g n ây phát tri n it c nhanh chóng. Các ng d ng c a nó r t phóng phú và ang thâm nh p vào nhi u l nh v c kinh t , k thu t…M t trong s nh ng ng d ng ó là s ra i các ch ng trình thi t k , mô ph ng t ng các m ch n t . Qu th t, ây không ch là tín hi u vui cho các k s n t chuyên nghi p mà còn là công c thi t th c giúp các sinh viên có b c kh i u d dàng trong vi c tìm hi u các m ch n t . Thi t k th nghi m m t m ch n t th t v i y các linh ki n và ho t ng hi u qu là m t vi c làm mang nhi u thách th c. Nó òi h i ng i thi t k ph i có nhi u kinh nghi m và tài chính v ng m nh m i có th làm c. Nh ng v i ch ng trình thi t k m ch n t , a s ý t ng u có th th c hi n trên máy tính và c mô ph ng t ng t o tín hi u ngõ ra m t cách d dàng. Sau m t th i gian tìm hi u vài ch ng trình thi t k , mô ph ng t ng các ch n t . Nay, chúng tôi hân h nh và t tin gi i thi u v i các b n ch ng trình MicroSim Eval 8.0 g m nh ng công c chính sau: -Schematics : v m ch n -Part Editor : Thay i k t c u linh ki n -Probe : Phân tích, v sóng hi u -PCBoards : Thi t k m ch in ây là ch ng trình có nhi u ch c n ng, t ng i toàn di n. Chúng tôi biên so n tài li u v i ph ng châm ng n, g n, d ti p thu và hi v ng sau khi tìm hi u k tài li u này, k t h p v i ch ng trình, các b n s v n d ng t t khi thi t k m ch. i n i dung c p có ph m vi r ng, yêu c u l p ráp các m ch n t ng ng th c t a d ng nên vi c biên so n không tránh kh i nh ng thi u sót và h n ch nh t nh. Chúng tôi r t mong các b n c thông c m. Cu i cùng, chúng em xin chân thành c m n th y giáo GVC Th c s H Vi t Vi t ã g i ý, t o c h i chúng em hoàn thành tài li u này. à N ng, ngày 2/12/2006 TM Các tác gi 2 Nhóm 6 - L p 03 T1
  3. ng d n s d ng ch ng trình MicroSim Eval 8.0 3 Nhóm 6 - L p 03 T1
  4. ng d n s d ng ch ng trình MicroSim Eval 8.0 Ch ng 1: S NGUYÊN LÝ 1.1 Gi i thi u ph n m m: 1.1.1 Cài t: Trong gói cài t, nh p úp ch n vào file __32.exe có bi u t ng là , s có 2 l a ch n, ch n MicroSim DesignLab, sau ó ti n hành cài t bình th ng nh các ph n m m khác. Hình 1.1.1: Cài t ch ng trình 4 Nhóm 6 - L p 03 T1
  5. ng d n s d ng ch ng trình MicroSim Eval 8.0 ây, mình ch n ng d n là D:\Program Files\MicroSim Eval 8.0 Hình 1.1.2: Th m c cài t 1.1.2 M ch ng trình v s nguyên lý c a Microsim 8(Microsim Schematics Evalution8): Sau khi ã hoàn t t quá trình cài t, m ch ng trình v s nguyên lý, t ng t các ph n m m khác, vào Start>All programs>DesignLab Eval 8>Schematics ho c Start>Programs>DesignLab Eval 8>Schematics i v i Classic Start Menu Ngoài ra, c ng có th vào th ng n i cài t m : D:\Program Files\MicroSim Eval 8.0\BinDL\PSCHED.EXE 5 Nhóm 6 - L p 03 T1
  6. ng d n s d ng ch ng trình MicroSim Eval 8.0 Hình 1.1.3: M s nguyên lý 1.1.3.Giao di n c a ch ng trình Microsim Schematics Evaluation 8: - C a s DesignLab Design Manager: 6 Nhóm 6 - L p 03 T1
  7. ng d n s d ng ch ng trình MicroSim Eval 8.0 Hình 1.1.3a: C a s DesignLab Design Manager -C a s Microsim Message Viewer: G i các thông báo trong quá trình làm vi c. Có 3 lo i thông báo: +Error : Thông báo l i +Warning : C nh báo +Info(Information) : Thông tin Hình 1.1.3b: C a s Microsim Message Viewer 7 Nhóm 6 - L p 03 T1
  8. ng d n s d ng ch ng trình MicroSim Eval 8.0 -C a s Microsim schematics: Hình 1.1.3c: C a s Microsim schematics 1.1.4.Thanh trình n(menu bar) c a Microsim Schematics 8: Hình 1.1.4.Thanh trình n(Menu bar) 1.1.5.Các thanh công c : 1.1.5.1.Standard Schematics: Hình 1.1.5: Thanh công c Standard Schematics 8 Nhóm 6 - L p 03 T1
  9. ng d n s d ng ch ng trình MicroSim Eval 8.0 t cách chi ti t: New Schematic: t o m t s nguyên lý m i. Công c này t ng ng v i vào File>New. Open Schematic: M m t s nguyên lý có s n. Công c này t ng ng v i vào File>Open… Save: L u file l n u ho c v i l u l i file v i tên hi n th i c a nó. Công c này t ng ng v i vào File>Save ho c hotkey Ctrl+S. Print: In trang ang m . Công c này t ng ng v i vào File>Print. Cut: t m t i t ng. Công c này t ng ng v i vào Edit>Cut ho c hotkey Ctrl+X. Copy: Sao chép m t i t ng. Công c này t ng ng v i vào Edit>Copy ho c hotkey Ctrl+C. Paste: Dán m t i t ng. Công c này t ng ng v i vào Edit>Paste ho c hotkey Ctrl+V. Undo: Quay tr l i tình tr ng tr c ó. Công c này t ng ng v i Edit>Undo ho c hotkey Ctrl+Z. Redo: Quay tr l i tình tr ng tr c Undo. Công c này t ng ng v i vào Edit>Redo ho c hotkey Ctrl+Y. Redraw: p l i nh ng thao tác ã v trên b ng v . Công c này t ng ng v i View>Redraw ho c Hotkey Ctrl+L. Zoom in: Phóng to b n v . M c nh, m i l n nh p chu t, b n v s phóng to 20%. Công c này t ng ng v i View>In ho c hotkey Ctrl+I. 9 Nhóm 6 - L p 03 T1
  10. ng d n s d ng ch ng trình MicroSim Eval 8.0 Zoom out: Thu nh b n v . M c nh, m i l n nh p chu t, b n v s thu nh 20%. Công c này t ng ng v i View>Out ho c hotkey Ctrl+O. View Area: Phóng to m t khu v c c l a ch n trên s . Công c này t ng ng v i View>Area ho c hotkey Ctrl+A. View Fit: Xem toàn b trang s v a v n trong c a s làm vi c. Công c này t ng ng v i View>Fit ho c hotkey Ctrl+N. 1.1.5.2 Drawing Các nút công c trong nhóm này dùng l y linh ki n ra trang s , v các ng n i dây, ng bus gi a các linh ki n v i nhau v.v… Hình 1.1.5.2 Thanh công c Drawing t cách chi ti t: Draw Wire: o các dây n i gi a các linh ki n trong b ng m ch n t . Khi chon công c này, con tr chu t s có d ng cây bút cho bi t vùng làm vi c ang tr ng thái v dây n i. Mu n k t thúc ông vi c n i dây thì ch c n kích chu t ph i, con tr chu t s tr v d ng m i tên nh bình th ng. Công c này t ng ng v i Draw>Wire hay phím nóng Ctrl+W. Draw Bus: Dùng v các ng Bus i v i nh ng m ch n có s ph c t p hay nh ng h th ng vi x lý …khi ch n công c này con tr chu t c ng có d ng cây bút nh công n i dây. Mu n k t thúc công vi c n i Bus thì ch vi c kích chu t ph i. Các b n c ng có th ch n menu Draw>Bus v Bus,hay phím nóng Ctrl+B. 10 Nhóm 6 - L p 03 T1
  11. ng d n s d ng ch ng trình MicroSim Eval 8.0 Draw Block: Dùng t o nh ng h p linh ki n trong s m ch n,chúng ta s tìm hi u thêm ph n sau. Công c này t ng ng v i Draw>Block. Get New Part: Khi nh p vào công c này s hi n th h p tho i Part Browser Basic(hay Part Browser Advanced) cho phép a ch n linh ki n a ra b n v . Công c này t ng ng v i Draw>Get New Part…hay phím nóng Ctrl+G. Get Recent Part: i công c này các b n s l y linh ki n ra ch n nhanh chóng h n do ch ng trình Pspice ã t o m t danh sách linh ki n ã s d ng vào m ch n công c này, th y c danh sách này hãy kích chu t vào m i tên h ng xu ng phía ph i c a thanh công c . Edit Attributes: Dùng s a i thu c tính c a các thành ph n linh ki n trên b ng v nh : i tên, tr s c a linh ki n hay là thay i các giá tr n áp, dòng n trên b ng v . s ng công c này, hãy ch n linh ki n trên b n v r i ch n nút công c . Khi ã ch n công này, h p tho i PartName xu t hi n và b n có th thay i các giá tr c a linh ki n. Công c này t ng ng v i Edit>Attributes… Edit symbol: M ch ng trình Symbol editor s a i các ký hi u hay bi u t ng c a linh ki n, ho c b n có th v thêm ký hi u c a linh ki n v i các hình v do Symbol Editor cung c p. Công c này t ng ng v i Edit>Symbol… 1.1.5.3 Annotation Graphics Hình 1.1.5.3 Thanh công c Annotaion Graphics 11 Nhóm 6 - L p 03 T1
  12. ng d n s d ng ch ng trình MicroSim Eval 8.0 Draw arc: hình vòng cung. Công c này t ng ng v i Draw> arc. Draw Box: hình vuông. Công c này t ng ng v i Draw>Box. Draw Circle: hình tròn. Công c này t ng ng v i Draw>circle. Draw polyline: a giác. Công c này t ng ng v i Draw>polyline. Draw text: Ghi v n b n trên m t hàng. Công c này t ng ng v i Draw>text. Draw text box: Ghi v n b n trên nhi u hàng. Công c này t ng ng v i Draw>text box. Insert picture: Chèn hình nh. Công c này t ng ng v i Draw>insert picture... 1.1.5.4 Simulation Hình 1.1.5.4.a Thanh công c Simulation Setup Analysis: khi c n mô ph ng m t m ch b t k thì u tr c tiên là b n ph i ch n ch làm vi c khi kích vào bi u t ng này h p tho i Analysis Setup xu t hi n. Công c này t ng ng v i Analysis >Setup… 12 Nhóm 6 - L p 03 T1
  13. ng d n s d ng ch ng trình MicroSim Eval 8.0 Hình 1.1.5.4.b H p tho i Analysis Setup. Cho phép vi c ch n ch làm vi c: DC ,AC ,quá .v.v... Simulation: Sau khi v m ch và ch n ch mô ph ng,n u mu n xem d ng sóng c a tín hi u ra ta nh n vào bi u t ng trên Công c này t ng ng v i Analysis > Simulate ho c hotkey F11. Marker color : ch n màu cho marker, marker t i m t m trên dây c ch n màu nào thì d ng sóng t i m ó có màu ó. Voltage marker: là công c hi n th d ng sóng áp t i m t m trên m ch n khi ch y mô ph ng. current marker: là công c hi n th d ng sóng dòng t i m t m trên m ch n khi ch y mô ph ng. G m có 4 l a chon cho phép vi c có hi n th hay không các giá tr n áp và dòng n. 13 Nhóm 6 - L p 03 T1
  14. ng d n s d ng ch ng trình MicroSim Eval 8.0 1.1.6 Các phím nóng(Hotkey) 1.1.6.1 Các phím nóng u khi n F1: Hi n th h p tho i Help topic. F2: Di chuy n n s nguyên lý có kh i hay linh ki n c ch n. F3: Di chuy n lên s nguyên lý m c trên i v i s nguyên lý nhi u m c. F4: Gi v n b n t tên. B m Shirft+F4 t t. F5: Gi buses và dây v tr c giao. B m Shirf+F5 t t. F6: Gi Parts, Wires, Buses,… B m Shirf+F6 t t. F7: B t ch t ng n tên. B m Shirf+F7 t t ch này. F8: B t ch t ng l p l i. B m Shirf+ F8 t t ch này. F9: Ch n thu c tính dây n i có th co giãn. B m Shirf+F9 h y b vi c tùy ch n. F10: M Message Viewer và hi n th b t c h p tho i nào t màn hình thi t k . F11: Ch y mô ph ng v i u ki n ã thi t l p ch mô ph ng cho m ch. F12: Ch n Probe khi ã kh i t o. 1.1.6.2 Các phím nóng v n b n Ctrl + S: (Save) L u t p tin s . Ctrl + X: (Cut) t m t i t ng. Ctrl + C: (Copy) Ch n và copy i t ng, không xóa I t ng. Ctrl + V: (Paste) Dán các i t ng ã ch n copy và cut. Ctrl + Z: (Undo) Quay tr l i tình tr ng tr c ó. Ctrl + Y: (Redo) Quay tr l i tình tr ng tr c Undo. Del: (Delete) Xóa các i t ng trên s d . 1.1.6.3 Các phím nóng công c Ctrl + E: (Label) t nhãn cho các linh ki n ( i t ng) trên s . Ctrl + R: (Rotate) Xoay i t ng 90o. Ctrl + F: (Flip) L t i t ng theo chi u ngang. Ctrl + T: (Text) t m t v n b n vào s Ctrl+ W: (Wire) V ng dây n i các linh ki n. Ctrl + B: (Bus) V ng Bus n i các linh ki n. Ctrl + G: (Get New Part) L y linh ki n t vào trang s . Ctrl + P: (Place Part) t các i t ng ã ch n lên s . Ctrl + I: (In) Phóng to s . Ctrl + O: (Out) Thu nh s . Ctrl + N: (Fit) Xem toàn trang s . Ctrl + A: (Area) Phóng to m t khu v c ã ch n trên s . Ctrl + L: (Redraw) V l i màn hình hi n th . Space : (Repeat) L p l i thao tác cu i cùng trên s . 1.2 V s nguyên lý 1.2.1 Chu n b b n v T o m t trang s m i: Có 2 cách, 14 Nhóm 6 - L p 03 T1
  15. ng d n s d ng ch ng trình MicroSim Eval 8.0 Cách 1: Rê nh p chu t vào nút l nh file trên Menu Bar, ch n New… Cách 2: Ch vi c nh p vào bi u t ng New Schematic trên thanh công c Standard Schematics ã nói trên. t tilte cho b n v : , trên Menu Bar, rê nh p vào Navigate>Edit Page Info…-> xu t hi n m t c a s cho phép t tên as . Hình 1.2.1.a t Title cho b n v nh d ng b n v : ti n hành nh d ng s , trên Menu Bar, rê nh p vào Options>Paper size…-> xu t hi n 1 c a s cho phép ch n kích c cho trang v trong h p tho i ho c t nh ngh a. Hình 1.2.1.b H p tho i Paper Size 15 Nhóm 6 - L p 03 T1
  16. ng d n s d ng ch ng trình MicroSim Eval 8.0 t t t ch Grid: trên Menu Bar, rê nh p chu t vào Options>Display Options…->… Hình 1.2.1.c H p tho i Display Options • Stick vào ô tr ng b t các tùy ch n và ng c l i. • Grid Spacing, Stay-on-Gird, Snap-to-Pin: Gõ các kích th c vào thay i các thông s . 1.2.2 Tìm, l y, t linh ki n 1.2.2.1 Tìm và l y linh ki n: Thông qua menu list Part Browser Basic/Advanced ho c n u ã bi t tr c tên thì có th l y tr c ti p thông qua h p tho i Get recent Part. m h p tho i Part Browser, có th dùng 1 trong các cách sau. + Trên Menu Bar, rê nh p chu t vào Draw>Get New Part… + Trên thanh công c Drawing, nh p vào bi u t ng Get New Part + Nh n t h p phím nóng Ctr+G ð Xu t hi n h p tho i Part Brower Basic. ð th y c hình d ng linh ki n, ta có th nh p chu t vào nút Advanced góc d i cùng bên ph i h p tho i chuy n qua h p tho i Part Brower Advanced. 16 Nhóm 6 - L p 03 T1
  17. ng d n s d ng ch ng trình MicroSim Eval 8.0 Hình 1.2.2.1.a H p tho i Part Browser Basic Hình 1.2.2.1.b H p tho i Part Browser Advanced n ây, tìm linh ki n, ta có th d a vào 1 trong các tùy ch n sau.ho c c ng có th k t h p các u ki n tìm. Tìm linh ki n theo tên: Gõ tên linh ki n vào khung Part Name. Tìm linh ki n theo mô t (description):Gõ mô t c a linh ki n c n tìm vào khung Description Search, sau ó click vào Search ho c nh n Enter. 17 Nhóm 6 - L p 03 T1
  18. ng d n s d ng ch ng trình MicroSim Eval 8.0 Ví d : Khi c n tìm linh ki n là các c ng XOR ,ta ch c n ánh ch XOR vào khung này và nh n enter, k t qu trong khung Partial list s xu t hi n t t c các linh ki n trong th vi n có mô t ch a ch “XOR” Hình 1.2.2.1.c K t qu tìm ki m nh ng kinh ki n trong mô t có ch XOR 18 Nhóm 6 - L p 03 T1
  19. ng d n s d ng ch ng trình MicroSim Eval 8.0 Tìm linh ki n theo th vi n: Trong h p tho i Part Browser Basic/Advanced, Ch n Libraries… p tho i Library Browser xu t hi n nh hình 1.2.2.1.d. Th vi n linh ki n c a Microsim c t tên theo ch c n ng ho c thu c tính c a các linh ki n trong th vi n: Analog ch a các linh ki n t ng t , source ch a các lo i ngu n… Hình 1.2.2.1.d H p tho i Library Browser y linh ki n Có nhi u cách l y linh ki n. -Sau khi ã tìm c linh ki n trong h p tho i Part Brower, sau ó nh p chu t vào nút Place&Close ho c nh p úp tr c ti p vào tên linh ki n. N u mu n l y linhh ki n và v n gi l i h p tho i c a h p tho i Part Brower, ta nh n vào nút Place. -Ngoài ra, n u bi t tr c tên c a linh ki n c n tìm trong th vi n linh ki n thì ta có th ánh tên tr c ti p vào khung Get recent Part, r i nh n Enter. Hình 1.2.2.2 Khung Get Recent Part 1.2.2.2 t linh ki n -Di chuy n con tr và t linh ki n vào v trí mong mu n trên c a s Schematics. -Nh p chu t trái t linh ki n l n th nh t. -Di chuy n con tr và nh p chu t nh ng n i mà b n còn mu n t linh ki n ó. -Nh p chu t ph i (nh p 2 l n chu t trái) k t thúc ch t linh ki n. Chú ý: Khi k t thúc vi c ch n linh ki n thì linh ki n cu i cùng s có màu , còn các linh ki n khác u có màu xanh. Khi t linh ki n ,b n c n l u ý: +Ph i ch a kho ng cách cho phép k t n i các linh ki n v i dây n i 19 Nhóm 6 - L p 03 T1
  20. ng d n s d ng ch ng trình MicroSim Eval 8.0 +N u nh tên và giá tr c a các linh ki n không gi ng nh tên các linh ki n trong m ch n thì chúng ta có th s a ch a sau c ng c +Ch n ch v l i Redraw trong trình n View ho c nh p t h p phím Ctrl+D v l i ch n n u c n. *Ngoài ra b n còn có th t n i ti p ho c song song liên ti p các linh ki n nhanh chóng b ng cách dùng ch c n ng Auto Repeat trong trinh n Options. Hình 1.2.2..a Ch n ch c n ng Auto-Repeat Ta ch n ch c n ng này b ng cách tick vào ô Enable Auto-Repeat. -N u mu n t các linh ki n n i ti p liên ti p và cách u nhau m t kho ng là bao nhiêu thì ánh s ó vào ô bên c nh c a khung Horizontal Offset (v i n v inch) và giá tr c a khung Vertical Offset b ng "00.00", sau ónh n OK. Hình 1.2.2.2.b H p tho i Auto-Repeat. Ti p theo ta ch n linh ki n và nh n phím Space trên bàn phím ta s có k t qu nh sau: Hình 1.2.2.3.c K t qu khi thi t t Horrizontal Offset 20 Nhóm 6 - L p 03 T1
Đồng bộ tài khoản