Hướng dẫn sử dụng CircuitMaker 2000

Chia sẻ: Dth Dth | Ngày: | Loại File: PDF | Số trang:23

0
1.024
lượt xem
288
download

Hướng dẫn sử dụng CircuitMaker 2000

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tài liệu bổ trợ hướng dẫn sử dụng CircuitMaker 2000

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng CircuitMaker 2000

  1. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Mục lục Mục lục ............................................................................................................................i Giới thiệu.......................................................................................................................iii Chương 1 Mở Đầu...................................................................................................... 1 1.1 CircuitMaker là gì ................................................................................................. 1 1.2 Môi trường làm việc CircuitMaker ....................................................................... 1 1.3 Các file của CircuitMaker ..................................................................................... 2 1.4 Quy trình sử dụng CircuitMaker ........................................................................... 2 1.5 Toolbar của CircuitMaker ..................................................................................... 3 1.6 Phím nóng (hotkey)............................................................................................... 4 Chương 2 Vẽ và chỉnh sữa các mạch nguyên lý ...................................................... 6 2.1 Tìm các thiết bị...................................................................................................... 6 2.1.1 Tab Browse .................................................................................................... 6 2.1.2 Tab Search...................................................................................................... 7 2.1.3 Thiết lập phím nóng ....................................................................................... 7 2.1.4 Thay đổi phím nóng. ...................................................................................... 7 2.2 Đặt thiết bị vào trong bản vẽ ................................................................................. 8 2.3 Các công cụ vẽ và chỉnh sửa ................................................................................. 8 2.3.1 Arrow Tool..................................................................................................... 8 2.3.2 Wire Tool ....................................................................................................... 8 2.3.3 Text Tool........................................................................................................ 8 2.3.4 Delete Tool..................................................................................................... 9 2.3.5 Zoom Tool...................................................................................................... 9 2.3.6 Rotate Tool..................................................................................................... 9 2.3.7 Mirror Tool..................................................................................................... 9 Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính i
  2. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 2.4 Lưới ....................................................................................................................... 9 2.5 Nối dây cho mạch................................................................................................ 10 2.5.1 Nối dây tự động............................................................................................ 10 2.5.2 Nối dây bằng tay .......................................................................................... 10 2.5.3 Nối dây nhanh .............................................................................................. 10 2.6 Dây BUS ............................................................................................................. 11 2.6.1 Nối dây dẫn tới bus ...................................................................................... 11 2.6.2 Nối các dây dẫn trên Bus với nhau. ............................................................. 12 2.7 Tên của node và sự kết nối.................................................................................. 12 2.8 Thông số của các thiết bị..................................................................................... 13 2.9 Thay đổi dữ liệu RAM/ ROM:............................................................................ 15 Chương 3 Mô phỏng mạch số.................................................................................. 16 3.1 Bắt đầu mô phỏng mạch số ................................................................................. 16 3.2 Các công cụ mô phỏng mạch số.......................................................................... 16 3.2.1 Công cụ Prope .............................................................................................. 16 3.2.2 Công cụ Reset .............................................................................................. 17 3.2.3 Công cụ Trace .............................................................................................. 17 3.2.4 Công cụ Run \ Pause: ................................................................................... 17 3.2.5 Công cụ Step ................................................................................................ 17 3.2.6 Công cụ Tile Windows................................................................................. 17 3.3 Bộ tạo xung ......................................................................................................... 18 3.4 Các thông số mô phỏng:...................................................................................... 18 3.5 Thời gian trễ ........................................................................................................ 19 3.6 Xem dạng sóng.................................................................................................... 19 Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính ii
  3. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Giới thiệu CircuitMaker là một phần mềm thân thiện, dễ sử dụng để mô phỏng mạch. Đặc biệt là mô phỏng mạch số. Những người bắt đầu tìm hiểu thế giới số cũng như các chuyên gia trong lĩnh vực này đều tìm thấy các công cụ hữu ích trong phần mềm CircuitMaker Từ ý nghĩa đó, tài liệu này được biên soạn nhằm cung cấp cho những người mới bắt đầu những kiến thức căn bản nhất để có thể nhanh chóng làm chủ được phần mềm CircuitMaker. Tài liệu được biên soạn gồm ba phần: phần đầu, MỞ ĐẦU, sẽ giới thiệu một số khái niệm căn bản, các phím nóng…; phần thứ hai, VẼ VÀ CHỈNH SỮA MẠCH NGUYÊN LÝ, sẽ hướng dẫn cách vẽ mạch nguyên lý trong CircuitMaker; phần thứ ba, MÔ PHỎNG MẠCH SỐ, sẽ hướng dẫn cách thực hiện mô phỏng mạch nguyên lý đã vẽ. Để giúp tài liệu tốt hơn mong nhận được các ý kiến đóng góp từ các bạn đọc. Mọi ý kiến đóng góp về nội dung, hình thức trình bày, bố cục… của tài liệu xin vui lòng gửi qua e- mail: Trần Hoàng Hà: hoangha@dit.hcmut.edu.vn Bùi Văn Hiếu: bvhieu@dit.hcmut.edu.vn Phạm Quốc Cường: cuongpham@cse.hcmut.edu.vn Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính iii
  4. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Chương 1 Mở Đầu Phần này cung cấp những kiến thức cơ bản về CircuitMaker như: môi trường làm việc, quy trình sử dụng…. Đây là những kiến thức cơ bản để có thể thiết kế mạch cũng như là mô phỏng mạch trên môi trường CircuitMaker. 1.1 CircuitMaker là gì CircuitMaker là một chương trình cho phép người dùng nhanh chóng lắp ráp thử nghiệm và mô phỏng các mạch số cũng như các mạch tương tự ở mức logic. Đồng thời cũng hỗ trợ việc xuất ra file netlist để vẽ mạch in. Tài liệu hướng dẫn sử dụng này tập trung vào việc lắp ráp và mô phỏng mạch số. 1.2 Môi trường làm việc CircuitMaker Môi trường CircuitMaker bao gồm Title Bar, Menu Bar, Toolbar, Status Bar, Panel, Schematic Window và Analysis Window như Hình 1.1 Hình 1.1: Môi trường làm việc của CircuitMaker Ngoài những thành phần căn bản tồn tại trong hầu hết các ứng dụng đồ họa hiện nay như Title Bar, Menu Bar, Status Bar các thành phần còn lại có ý nghĩa như sau: Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -1-
  5. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 • Panel gồm ba tab là Browse, Search, Digital dùng để tìm kiếm các thiết bị phục vụ cho việc ráp mạch và mô phỏng, thiết lập các thông số cho mô phỏng số, • Schematic Window là cửa sổ soạn thảo, trên đó ta sẽ thực hiện vẽ mạch, • Analysis Window là cửa sổ hiển thị các kết quả đo đạc như áp, dòng, dạng sóng…. Hai cửa sổ Schematic và Analysis có thể có hoặc không tùy theo ta thay đổi, cụ thể sẽ trình bày trong phần mô phỏng mạch số. Các linh kiện sau khi đã được đặt đúng vị trí sẽ được kết nối với nhau bằng các dây nối. Mạch sau khi đã được nối dây cho phép mô phỏng, kiểm tra bằng các công cụ mô phỏng của CircuitMaker. 1.3 Các file của CircuitMaker CircuitMaker gồm nhiều file sử dụng cho các mục đích riêng với các phần đuôi như sau: .CKT Mạch nguyên lý .DAT File dữ liệu (phím nóng; đặc tả kỹ thuật của các thiết bị) .MOD File lưu trữ chế độ hoạt động .LIB Thư viện các thiết bị. .SUB File các mạch con .SDF Dạng sóng mô tả file setup. 1.4 Quy trình sử dụng CircuitMaker Việc sử dụng CircuitMaker có thể chia làm sáu bước như sau 1. Chọn các thiết bị cần thiết (điện trở, tụ, IC …) và đưa lên bản vẽ, 2. Sắp xếp các thiết bị này cho hợp lý, 3. Thiết lập các thông số của thiết bị (độ trễ, nội dung ROM…), 4. Xóa hoặc thêm các thiết bị tùy theo yêu cầu, 5. Nối dây, 6. Mô phỏng và kiểm tra mạch đã vẽ. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -2-
  6. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 1.5 Toolbar của CircuitMaker Có thể thực hiện các chức năng của CircuitMaker bằng các nút nhấn trên thanh Toolbar nằm phía trên của Schematic Window. Toolbar gồm có các thành phần như Hình 1.1 Hình 1.2: Tool bar của CircuitMaker Chức năng của các công cụ này được giới thiệu ở Bảng 1.1. Chức năng chi tiết sẽ được trình bày ở các phần sau. Panel Bật tắt cửa sổ panel Rotate Xoay thiết bị New Tạo bản vẽ mới Mirror Lật thiết bị đối xứng qua trục đứng Open Mở bản vẽ đã lưu Traxmaker Tạo netlist và chạy traxmaker Save Lưu bản vẽ Help Trợ giúp Print In bản vẽ Reset Khởi động lại quá trình mô phỏng Arrow tool Chọn, di chuyển các Analyses Thiết lập thông số phân tích thành phần setup Wire tool Vẽ dây nối, bus Run analog Chạy, dừng mô phỏng tương tự Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -3-
  7. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Text tool Chèn đoạn văn bản Trace digital Hiển thị giá trị số của dây dẫn Delete tool Xóa một thành phần Run digital Chạy, dừng mô phỏng số Probe tool Đo tín hiệu Step digital Chạy một bước mô phỏng số Zoom tool Phóng to thu nhỏ bản Tile windows Chọn cách hiển thị các cửa sổ vẽ Fit to window Hiện toàn bộ bản vẽ trên cửa sổ Bảng 1.1: Chức năng của Toolbar 1.6 Phím nóng (hotkey) CircuitMaker cung cấp các phím nóng được liệt kê trong bảng 2. Đồng thời cũng cho phép người dùng định nghĩa tối đa sáu mươi hai phím nóng để lấy các thiết bị thường sử dụng, chi tiết sẽ được trình bày ở phần Vẽ và chỉnh sửa mạch nguyên lý. Ctrl+A Chọn tất cả F3 Hiển thị tỉ lệ bình thường Ctrl+C Copy F4 Hiển thị toàn bộ bản vẽ Ctrl+D Nhân đôi thiết bị F5 Thay đổi thông số bản vẽ Ctrl+F Tìm thành phần F7 Vẽ lại màn hình Ctrl+K Hiển thị thông số thiết bị F8 Thiết lập phân tích Ctrl+L Hiển thị thông số bản vẽ F9 Mô phỏng số một bước Ctrl+M Lật thiết bị F10 Chạy dừng mô phỏng Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -4-
  8. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Ctrl+N Tạo bản vẽ mới F11 Hiển thị giá trị số Ctrl+O Mở bản vẽ đã lưu Esc Bỏ qua thao tác đang làm Ctrl+P In bản vẽ Page Up Phóng to bản vẽ Ctrl+Q Khởi động lại mô phỏng Page Down Thu nhỏ bản vẽ Ctrl+R Xoay thiết bị Delete Xóa thành phần đang chọn Ctrl+S Lưu bản vẽ Home Vị trí trung tâm là vị trí con trỏ Ctrl+V Paste Arrow Keys Di chuyển thiết bị đang chọn F1 Trợ giúp Shift+Insert Di chuyển một nhóm thiết bị F2 Thay đổi tỉ lệ hiển thị Bảng 1.2: Các phím nóng của CircuitMaker Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -5-
  9. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Chương 2 Vẽ và chỉnh sữa các mạch nguyên lý CircuitMaker cung cấp nhiều công cụ mạnh mẽ cho phép vẽ và chỉnh sửa mạch nguyên lý nhanh chóng và dễ dàng. Phần này sẽ cung cấp các kiến thức về các công cụ vẽ và chỉnh sửa mạch nguyên lý. 2.1 Tìm các thiết bị CircuitMaker cung cấp thư viện hàng ngàn các thiết bị (có thể tham khảo hướng dẫn sử dụng các thiết bị để có thêm thông tin). Có thể lấy các thiết bị bằng cách dùng tab Browse hay tab Search trong cửa sổ Panel hay sử dụng phím nóng. Hình 2.1: Tab Browse và Tab Search 2.1.1 Tab Browse Người sử dụng có thể lựa chọn các thiết bị thông qua tab browse. Các thiết bị được chia theo dạng cây phân cấp. Để tìm một thiết bị cần thực hiện các bước sau: 1. Chọn tab Browse trong panel, 2. Lựa chọn các thiêt bị bằng cách chọn theo cây phân cấp (có thể chọn theo tên, theo chức năng…), Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -6-
  10. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 3. Nhấn đúp chuột để chọn thiết bị đưa vào vùng vẽ. Thiết bị sẽ theo con trỏ chuột cho đến khi nào nhấn chuột trái. Trong khi đang kéo thiết bị có thể quay (nhấn phím R) hay lật ngược (nhấn phím M) thiết bị. 2.1.2 Tab Search Tab này cho phép tìm kiếm các thiết bị thỏa điều kiện tìm kiếm. Điều kiện này là tên thiết bị hoặc phần mô tả chức năng thiết bị có chứa các kí tự tìm kiếm. Có thể dùng các kí tự đại diện như *. Ví dụ tìm kiếm 74* là tìm tất cả IC họ 74. 2.1.3 Thiết lập phím nóng Một cách khác để lấy linh kiện từ thư viện là dùng phiếm nóng. Để gán phím nóng cho một thiết bị thực hiện các bước sau: 1. Chọn tab Browse trong Panel, sau đó tìm thiết bị mong muốn gán phím nóng cho nó, 2. Nhấn vào nút Hotkey, hộp thoại quản lý các phím nóng sẽ xuất hiện, tất cả các phím nóng xếp theo thứ tự alphabet cùng với các thiết bị tượng ứng được gán với nó, 3. Tìm phím tắt nào muốn gán cho thiết bị đang chọn và chọn Assign. 2.1.4 Thay đổi phím nóng. Để thay đổi phím nóng ta làm những bước như sau: 1. Thực hiện các bước 1 và 2 như phần thiết lập phiếm nóng 2. Gán một thiết bị mới hay gán rỗng (ở trên đầu của các thiết bị) như là phím nóng. Hình 2.2: Hộp thoại quản lý phím nóng Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -7-
  11. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 2.2 Đặt thiết bị vào trong bản vẽ Sau khi đã tìm thấy thiết bị, có thể đặt chúng vào trong bản vẽ. Để đặt một thiết bị thực hiện theo các bước sau: 1. Lựa chọn thiết bị bằng các phương pháp đã nêu ở trên, 2. Nhấn phím R hay nhấn chuột phải để quay thiết bị đến vị trí mong muốn, 3. Nhấn phím M để lât ngược thiết bị, 4. Nhấn chuột trái để đặt thiết bị vào trong bản vẽ. Hay nhấn bất kỳ phím nào (trừ M và R) để đặt thiết bị vào bản vẽ. 2.3 Các công cụ vẽ và chỉnh sửa Phần này giới thiệu tính năng của các phần tử trên thanh Toolbar để người sử dụng có thể đặt và nối dây các thiết bị với nhau. Hình 2.3: Các công cụ vẽ và chỉnh sữa 2.3.1 Arrow Tool Công cụ Arrow cho phép lựa chọn và di chuyển các thành phần của sơ đồ, kích công tắc…. Ngoài ra còn có thể nhấn đúp chuột lên một thiết bị để thực hiện một số thao tác như thay đổi thông số thiết bị. 2.3.2 Wire Tool Sử dụng công cụ vẽ dây (Wire tool) có thể vẽ dây nối các thiết bị. Có thể vẽ Bus bằng cách nhấn và giữ phím Shift khi bắt đầu vẽ. Có thể vẽ dây không liền nét bằng cách nhấn giữ phím Alt khi bắt đầu vẽ. Dây không liền nét giống như dây dẫn thông thường nhưng nếu nó không được nối với bất kỳ thiết bị nào thì đường dây sẽ không hiện diện trong mạch netlist. 2.3.3 Text Tool Sử dụng công cụ text để có thể đặt các đoạn văn bản vào trong bản vẽ. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -8-
  12. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 2.3.4 Delete Tool Sử dụng công cụ xóa ta có thể xóa các thành phần (dây dẫn, thiết bị…) trên bản vẽ. Chọn delete tool sau đó nhấn vào thành phần nào muốn xóa. Ngoài ra có thể xóa bằng cách chọn thành phần muốn xóa bằng công cụ mũi tên rồi bấm phím Delete trên bàn phím. 2.3.5 Zoom Tool Sử dụng Zoom tool để phóng to hay thu nhỏ bản vẽ (zoom in và zoom out). 2.3.6 Rotate Tool Sử dụng Rotate Button để quay thiết bị ngược chiều kim đồng hồ. Ngoài ra có thể quay các thiết bị sau khi đã chọn chúng trong thư viện bằng cách nhấn phím R. 2.3.7 Mirror Tool Sử dụng nút nhấn Mirror để lật đối xứng các thiết bị theo trục thẳng đứng. Ngoài ra có thể lật các thiết bị bằng cách nhấn phím M khi chọn thiết bị từ thư viện. 2.4 Lưới Có thể hiển thị lưới để sắp xếp các linh kiện trong khung vẽ dễ dàng hơn. Để chọn hiển thị lưới thực hiện như sau. Vào menu Options|Schematic, trong tab General chọn Visible. Size là khoảng cách ô lưới, Snap To là các thiết bị sẽ đặt ngay lưới, Print là khi in ra có in lưới hay không. Hình 2.4: Hộp thoại điều chỉnh lưới Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -9-
  13. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 2.5 Nối dây cho mạch Để mô phỏng hoặc để tạo nestlist vẽ mạch in thì các thành phần của mạch phải được nối với nhau bằng dây dẫn. CircuitMaker cung cấp các phương thức tự động nối dây, nối dây bằng tay và nối dây nhanh. 2.5.1 Nối dây tự động Để nối dây tự động ta làm như sau: 1. Chọn công cụ vẽ dây (Wire Tool) trên Toolbar, 2. Đưa con trỏ đến nơi cần nối dây (chân của một thiết bị hay là dây dẫn), 3. Nhấn và giữ nút trái chuột, 4. Kéo đến nơi cần nối dây đến, 5. Dây dẫn sẽ tự động được sinh ra giữa hai điểm. Chế độ vẽ dây tự động chỉ có thể vẽ dây dẫn giữa hai điểm là một dây dẫn hay là chân của một linh kiện. 2.5.2 Nối dây bằng tay Nối dây bằng tay cho phép vẽ dây dẫn trong bản vẽ chính xác như mong muốn. Thực hiện như sau: 1. Chọn công cụ vẽ dây (Wire Tool) trên Toolbar, 2. Đưa con trỏ đến nơi ta cần nối dây (chân của một thiết bị hay là dây dẫn), 3. Nhấn và nhả chuột trái, 4. Con trỏ vẽ dây tự động được thay bằng con trỏ vẽ dây bằng tay. Nhấn chuột trái một lần để có thể đổi chiều dây, nhấn hai lần để kết thúc. Chú ý: Muốn vẽ một dây bus ta sử dụng phương pháp vẽ bằng tay. 2.5.3 Nối dây nhanh Một trong những cách đơn giản để nối dây là sử dụng tính năng vẽ dây nhanh. Chức năng này cho phép đặt thiết bị chưa được nối dây vào một dây dẫn hoặc một chân chưa nối của một thiết bị khác và dây nối sẽ được tự động vẽ. Thực hiện như sau: 1. Chọn một thiết bị trong thư viện hay là một thiết bị đã có sẵn trong bản vẽ, 2. Di chuyển thiết bị sao cho chân chưa nối của thiết bị cham vào một dây dẫn hay là một chân của một thiết bị khác. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -10-
  14. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.5: Nối dây cho hai thiết bị 2.6 Dây BUS Dây bus là một loại dây nối đặc biệt bao gồm nhiều dây nối riêng biệt. Mỗi dây nối có một tên riêng và bus cũng có tên riêng. Bus được nhận diện dễ dàng vì nó được vẽ đậm hơn các dây còn lại. Để vẽ Bus thực hiện như sau: 1. Nhấn giữ phím Shift trước khi vẽ dây nối, 2. Vẽ dây dẫn sử dụng phương pháp như phương pháp vẽ dây dẫn bằng tay đã đề cập ở trên, 3. Sau khi vẽ xong sẽ có hộp thoại yêu cầu đặt tên cho bus. Hình 2.6: Đặt tên cho BUS 2.6.1 Nối dây dẫn tới bus Để nối dây dẫn tới bus ta làm như sau: 1. Chọn công cụ nối dây, 2. Nối dây từ vị trí muốn nối tới bus, 3. Đặt tên cho dây dẫn. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -11-
  15. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.7: Đặt tên cho dây dẫn nối tới BUS 2.6.2 Nối các dây dẫn trên Bus với nhau. Nếu đặt tên cho hai dây dẫn nối đến bus cùng một tên và nối đến cùng một đường bus (hoặc nối đến hai bus khác nhau nhưng cùng một tên) thi hai dây dẫn trên sẽ tự động nối với nhau. 2.7 Tên của node và sự kết nối CircuitMaker sử dụng tên cho các node trên mạch. Tên của node sử dụng để xác định các sóng khi mô phỏng hay phân biệt các dây dẫn khi vẽ mạch in. Ngoài ra node còn được dùng để nối dây dẫn, hai đoạn dây dẫn được đặc cùng tên node sẽ nối với nhau. Có nhiều cách để đặt tên cho node: ngầm định, các thiết bị đặc biệt, nhãn. Tên node ngầm định là tên của node được sinh ra tự động khi dây dẫn được nối vào một thiết bị. Ví dụ, node name U2_6 có tên như vậy vì được nối vào chân số 6 của thiết bị U2. Dây dẫn trên có thể nối với các thiết bị khác, tên node của nó được xác định bởi thiết bị được đặt lên bản vẽ trước nhất trong các thiết bị nối với nó. Một số thiết bị có độ ưu tiên cao hơn (VCC, GND…) thì khi nối với nó thì tên node sẽ là tên của thiết bị đó. Sử dụng các thiết bị kết nối đặc biệt, đó là các thiết bị Input (Connectors| Active| Input), Output (Connectors| Active| Output) và Terminal (Connectors| Active| Terminal), các thiết bị trên cho phép gán nhãn cho các node. Khi đặt một trong các thiết bị trên vào mạch thì phải gán nhãn cho thiết bị nói trên. Và khi nối với một node (dây dẫn) thì tên node sẽ là tên của thiết bị đó. Các thiết bị này có độ ưu tiên về tên của node cao hơn các thiết bị khác kể cả nguồn điện. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -12-
  16. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.8: Thiết bị output Nhãn (label), một Node Label có thể được gán cho dây dẫn để tạo thành tên của một node. Đặt Node label như sau: 1. Chọn Edit > Place Node Label, 2. Kéo hình vuông của Node Label cho đến khi nào góc trái của nó chạm vào dây dẫn. Nhấn nút trái chuột, 3. Nhấn tên của node và nhấn OK. Hình 2.9: Gán node label Để xem tất cả tên của các node trong bản vẽ ta thực hiện các bước sau. • Chọn Options > Schematic (hay nhấn F5.) • Cho phép Show Node Names checkbox. Nhấn OK. Tên của các node sẽ xuất hiện trên các dây dẫn của bản vẽ. 2.8 Thông số của các thiết bị Người sử dụng có thể chỉnh thông số, thông tin liên quan đến bản vẽ, mô phỏng, netlist và các thông số khác một cách dễ dàng. Ở trong mục này, chỉ giới thiệu những thông số có liên quan đến việc vẽ mạch và sử dụng trong các mạch số. Để có thể điều chỉnh các thông số ta nhấn dup chuột vào thiết bị hoặc nhấn chuột phải và chọn Device Properties. Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -13-
  17. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.10: Hộp thoại thay đổi thông số thiết bị Các thuộc tính của thiết bị: 1. Device: tên của thiết bị được lưu trong thư viện, 2. Label-Value: nhãn của thiết bị, 3. Designation: dùng để phân biệt các thiết bị trong bản vẽ, như U1, U2… 4. Description: thông tin thêm, chỉ có ý nghĩa tham khảo trong bản vẽ, không ảnh hưởng mô phỏng, Lưu ý: bốn thuộc tính trên có thể cho hiển thỉ hay không bằng cách chọn hay không tùy chọn Visible tương ứng. 5. Package: cách đóng gói của thiết bị ( DIP, TO…), có ý nghĩa khi vẽ mạch in, 6. Auto Designation Prefix: tiền tố tự động thêm vào phần Designation mỗi khi tạo thiết bị mới, 7. Spice Prefix Character, Parameters, Spice Data: có ý nghĩa khi chạy Spice, ở đây ta không cần quan tâm, 8. Bus Data: mô tả chân nào của thiết bị sẽ nối với nguồn, đất, 9. Exclude From PCB: không đưa vào netlist, thường dùng cho các thiết bị chỉ phục vụ mô phỏng(tạo xung…), 10. Analog, digital: cho biết thiết bị có thể mô phỏng ở chế độ nào, Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -14-
  18. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 11. Pin: nhấn vào sẽ hiện số thứ tự chân của thiết bị. 2.9 Thay đổi dữ liệu RAM/ ROM: RAM/ROM là các thiết bị dung để lưu trữ dữ liệu cho mạch. Khi thay đổi dữ liệu của ROM thì dữ liệu này sẽ được ghi lại khi ta lưu bản vẽ, còn đối với RAM ta có thể xem, thay đổi dữ liệu để kiểm tra, gỡ lỗi nhưng sẽ không được lưu với bản vẽ. Để thay đổi dữ liệu của RAM/ROM ta làm như sau: 1. Nhấp chuột phải vào thiết bị rồi chọn Edit PROM/RAM để hiện hộp thoại thay đổi dữ liệu, 2. Thay đổi như ý muốn rồi bấm OK lưu lại. Hình 2.11: Thay đổi dữ liệu ROM/RAM Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -15-
  19. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Chương 3 Mô phỏng mạch số Mục đích của mô phỏng là để chạy thử, kiểm tra mạch, phát hiện lỗi, gỡ lỗi. Circuit maker vừa có thể mô phỏng mạch tương tự vừa có thể mô phỏng mạch số, tài liệu hướng dẫn sử dụng này chỉ đề cập đến vấn đề mô phỏng mạch số. Mô phỏng số chỉ có thể thực hiện được với thiết bị thuộc dạng số hoặc thiết bị vừa dạng số vừa tương tự (xem phần thuộc tính của thiết bị để biết chi tiết). Nếu trong mạch có thiết bị dạng tương tự sẽ có cảnh báo trước khi mô phỏng nhưng vẫn cho mô phỏng, khi đó thiết bị này sẽ bị bỏ qua và đường dây nối tới thiết bị này xem như để hở. 3.1 Bắt đầu mô phỏng mạch số Để chọn chế độ mô phỏng mạch số ta làm như sau: chọn menu Simulation|Digital Mode; nếu chọn Simulation|Analog Mode là chọn chế độ mô phỏng mạch tương tự. Thực hiện Simulation|Check Pin Connections để kiểm tra các thiết bị có chân nào chưa được nối dây hay không. Thực hiện Simulation|Check Wire Connections để kiểm tra có đường dây nối nào chỉ mới nối một đầu hay không. 3.2 Các công cụ mô phỏng mạch số Đây là các công cụ phục vụ cho việc mô phỏng mạch số. Những công cụ này sẽ khác nếu chọn chế độ mô phỏng là tương tự Hình 3.1: Công cụ mô phỏng số 3.2.1 Công cụ Prope Sử dụng công cụ Prope để xem giá trị logic của một dây dẫn hoặc một node trong mạch; ngoài ra còn có thể sử dụng công cụ Prope để thay đổi trạng thái của dây nối. Để xem trạng thái, rê công cụ này lên dây dẫn hoặc chân của thiết bị muốn xem. Khi đó công cụ sẽ hiển thị một trong bốn giá trị: Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -16-
  20. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 X 1.1 Không xác định hoặc ba trạng thái Để thay đổi trạng thái dây nối, rê đến dây nối và nhấn chuột trái, 1 sẽ chuyển thành 0 và 0 sẽ chuyển thành 1. Để gán giá trị ba trạng thái, nhấn giữ shift và nhấn chuột trái. Nếu dây nối với một ngõ xuất của thiết bị nào đó thì sau khi đổi nó sẽ chuyển ngay lại giá trị của ngõ xuất đó. 3.2.2 Công cụ Reset Khởi động lại quá trình mô phỏng. 3.2.3 Công cụ Trace Bật tắt tính năng Trace. Tính năng này hiển thị giá trị logic của các dây dẫn bằng các màu khác nhau. Màu đỏ mức 1, màu xanh dương mức 0, màu xanh lá là không xác định hoặc ba trạng thái. 3.2.4 Công cụ Run \ Pause: Bắt đầu hoặc dừng quá trình mô phỏng. 3.2.5 Công cụ Step Quá trình mô phỏng sẽ thực hiện từng bước. Khi nhấn vào công cụ này, mô phỏng sẽ thực hiện một bước và dừng lại. Nhấn lần nữa sẽ thực hiện tiếp một bước nữa. 3.2.6 Công cụ Tile Windows Chọn một trong bốn cách xem các cửa sổ. Chỉ cửa sổ vẽ mạch (Schematic) Chỉ cửa sổ dạng sóng Cửa sổ vẽ mạch bên trên, cửa sổ dáng sóng bên Cửa sổ vẽ mạch bên trái, cửa sổ dáng sóng bên Bộ môn Kỹ thuật Máy tính – Khoa Khoa học và Kỹ thuật Máy tính -17-
Đồng bộ tài khoản