Hướng dẫn sử dụng CircuitMaker

Chia sẻ: Nguyen Van Phong | Ngày: | Loại File: PDF | Số trang:17

3
3.849
lượt xem
776
download

Hướng dẫn sử dụng CircuitMaker

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

CircuitMaker là một phần mềm thân thiện, dễ sử dụng để mô phỏng mạch. Đặc biệt là mô phỏng mạch số. Những người bắt đầu tìm hiểu thế giới số cũng như các chuyên gia trong lĩnh vực này đều tìm thấy các công cụ hữu ích trong phần mềm CircuitMaker. Từ ý nghĩa đó, tài liệu này được biên soạn nhằm cung cấp cho những người mới bắt đầu những kiến thức căn bản nhất để có thể nhanh chóng làm chủ được phần mềm CircuitMaker....

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng CircuitMaker

  1. Giới thiệu CircuitMaker là một phần mềm thân thiện, dễ sử dụng để mô phỏng mạch. Đặc biệt là mô phỏng mạch số. Những người bắt đầu tìm hiểu thế giới số cũng như các chuyên gia trong lĩnh vực này đều tìm thấy các công cụ hữu ích trong phần mềm CircuitMaker Từ ý nghĩa đó, tài liệu này được biên soạn nhằm cung cấp cho những người mới bắt đầu những kiến thức căn bản nhất để có thể nhanh chóng làm chủ được phần mềm CircuitMaker. Tài liệu được biên soạn gồm ba phần: phần đầu, GIỚI THIỆU sẽ giới thiệu một số khái niệm căn bản, các phím nóng…; phần thứ hai, VẼ VÀ CHỈNH SỮA MẠCH NGUYÊN LÝ sẽ hướng dẫn cách vẽ mạch nguyên lý trong CircuitMaker; phần thứ ba, MÔ PHỎNG MẠCH SỐ sẽ hướng dẫn cách thực hiện mô phỏng mạch nguyên lý đã vẽ. Để giúp tài liệu tốt hơn mong nhận được các ý kiến đóng góp từ các bạn đọc. Mọi ý kiến đóng góp về nội dung, hình thức trình bày, bố cục… của tài liệu xin vui lòng gửi qua e-mail: Trần Hoàng Hà: hoangha@dit.hcmut.edu.vn Bùi Văn Hiếu: bvhieu@dit.hcmut.edu.vn
  2. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 M ở Đ ầu Phần này cung cấp những kiến thức cơ bản về CircuitMaker như: môi trường làm việc , quy trình sử dụng…. Đây là những kiến thức cơ bản để có thể thiết kế mạch cũng như là mô phỏng mạch trên môi trường CircuitMaker. CircuitMaker là gì CircuitMaker là một chương trình cho phép người dùng nhanh chóng lắp ráp thử nghiệm và mô phỏng các mạch số ở mức logic cũng như các mạch tương tự. Đồng thời cũng hỗ trợ việc xuất ra file netlist để vẽ mạch in. Trong phần hướng dẫn sử dụng này tập trung vào việc lắp ráp và mô phỏng mạch số. Môi trường làm việc CircuitMaker Môi trường CircuitMaker bao gồm Title Bar, Menu Bar, Toolbar, Status Bar, Panel, Schematic Window và Analysis Window như hình 1.1. Hình 1.1: Môi trường làm việc của CircuitMaker Ngoài những menu căn bản như Title Bar, Menu Bar, Status Bar các thành phần còn lại có ý nghĩa như sau. Panel: gồm ba tab, Browse, Search, Digital dùng để tìm kiếm các thiết bị phục vụ cho việc ráp mạch và mô phỏng, thiết lập các thông số cho mô phỏng số. Schematic Window: cửa sổ soạn thảo, trên đó ta sẽ thực hiện vẽ mạch. Analysis Window: cửa sổ hiển thị các kết quả đo đạc như áp, dòng, dạng sóng … Hai cửa sổ Schematic và Window có thể có hoặc không tùy theo ta thay đổi, cụ thể sẽ trình bày trong phần mô phỏng mạch số. -1-
  3. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Sau khi đã đặt các linh kiện đúng vị trí, tiếp theo nối chúng lại bằng dây dẫn. Mạch sau khi đã nối dây cho phép mô phỏng, kiểm tra bằng các công cụ mô phỏng của CircuitMaker. Các file của CircuitMaker CircuitMaker gồm nhiều file sử dụng cho các mục đích riêng với các phần đuôi như sau. .CKT Mạch nguyên lý .DAT File dữ liệu (phím nóng; đặc tả kỹ thuật của các thiết bị) .MOD File lưu trữ chế độ hoạt động .LIB Thư viện các thiết bị. .SUB File các mạch con .SDF Dạng sóng mô tả file setup. Quy trình sử dụng CircuitMaker Việc sử dụng CircuitMaker có thể chia làm sáu bước như sau 1. Chọn các thiết bị cần thiết (điện trở, tụ, IC …) và đưa lên bản vẽ 2. Sắp xếp các thiết bị này cho hợp lý 3. Thiết lập các thông số của thiết bị (độ trễ, nội dung ROM…) 4. Xóa hoặc thêm các thiết bị tùy theo yêu cầu 5. Nối dây 6. Mô phỏng và kiểm tra mạch đã vẽ Toolbar của CircuitMaker Có thể thực hiện các chức năng của CircuitMaker bằng các nút nhấn trên thanh Toolbar nằm phía trên của vùng làm việc. Toolbar gồm có các thành phần như hình 1.2 Hình 1.2: Tool bar của CircuitMaker Chức năng của các công cụ này được giới thiệu ở bảng 1. Chức năng chi tiết sẽ được trình bày ở các phần sau. -2-
  4. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Bật tắt cửa sổ panel Xoay thiết bị Panel Rotate Tạo bản vẽ mới Lật thiết bị New Mirror Mở bản vẽ đã lưu Tạo netlist và chạy traxmaker Open Traxmaker Lưu bản vẽ Trợ giúp Save Help In bản vẽ Khởi động lại quá trình mô phỏng Print Reset Chọn, di chuyển các Thiết lập thông số phân tích Arrow tool Analyses thành phần setup Vẽ dây nối, bus Chạy, dừng mô phỏng tương tự Wire tool Run analog Chèn đoạn văn bản Hiển thị giá trị số của dây dẫn Text tool Trace digital Xóa một thành phần Chạy, dừng mô phỏng số Delete tool Run digital Đo tín hiệu Chạy một bước mô phỏng số Probe tool Step digital Phóng to thu nhỏ bản Chọn cách hiển thị các cửa sổ Zoom tool Tile windows vẽ Hiện toàn bộ bản vẽ Fit to window trên cửa sổ Bảng 1: Chức năng của Toolbar Phím nóng (hotkeys) CircuitMaker cung cấp các phím nóng được liệt kê trong bảng 2. Đồng thời cũng cho phép người dùng định nghĩa tối đa sáu mươi hai phím nóng để lấy các thiết bị thường sử dụng, chi tiết sẽ được trình bày ở phần Vẽ và chỉnh sửa mạch nguyên lý. Chọn tất cả Hiển thị tỉ lệ bình thường Ctrl+A F3 Copy Hiển thị toàn bộ bản vẽ Ctrl+C F4 Nhân đôi thiết bị Thay đổi thông số bản vẽ Ctrl+D F5 Tìm thành phần Vẽ lại màn hình Ctrl+F F7 Hiển thị thông số thiết bị Thiết lập phân tích Ctrl+K F8 Hiển thị thông số bản vẽ Mô phỏng số một bước Ctrl+L F9 Lật thiết bị Chạy dừng mô phỏng Ctrl+M F10 Tạo bản vẽ mới Hiển thị giá trị số Ctrl+N F11 Mở bản vẽ đã lưu Bỏ qua thao tác đang làm Ctrl+O Esc In bản vẽ Phóng to bản vẽ Ctrl+P Page Up Khởi động lại mô phỏng Thu nhỏ bản vẽ Ctrl+Q Page Down Xoay thiết bị Xóa thành phần đang chọn Ctrl+R Delete Lưu bản vẽ Vị trí trung tâm là vị trí con trỏ Ctrl+S Home Paste Di chuyển thiết bị đang chọn Ctrl+V Arrow Keys Trợ giúp Di chuyển một nhóm thiết bị F1 Shift+Insert Thay đổi tỉ lệ hiển thị F2 Bảng 2: Các phím nóng của CircuitMaker -3-
  5. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Vẽ và chỉnh sửa mạch nguyên lý CircuitMaker cung cấp nhiều công cụ mạnh mẽ cho phép vẽ và chỉnh sửa mạch nguyên lý nhanh chóng và dễ dàng. Phần này sẽ cung cấp kiến thức về các công cụ vẽ và chỉnh sửa mạch nguyên lý. Tìm và đặt các thiết bị CircuitMaker cung cấp thư viện hàng ngàn các thiết bị (có thể tham khảo hướng dẫn sử dụng các thiết bị để có thêm thông tin). Ta có thể lấy các thiết bị bằng cách dùng tab Browse hay tab Search trong cửa sổ Panel hay sử dụng phím tắt. Tab Browse Ta có thể lựa chon các thiết bị thông qua tab browse. Các thiết bị được chia theo dạng cây phân cấp. Để tìm một thiết bị cân thực hiện các bước sau: 1. Chọn tab Browse trong panel. 2. Lưa chọn các thiêt bị bằng cách chọn theo cây phân lớp (có thể chọn theo tên, theo chức năng…). 3. Nhấn đúp chuột để chọn thiết bị đưa vào vùng vẽ. Thiết bị sẽ theo con trỏ chuột cho đến khi nào nhấn chuột trái. Trong khi đang kéo thiết bị bạn có thể quay (nhấn phím R) hay lật ngược (nhấn phím M) thiết bị. Tab Search Tab này cho phép ta tìm kiếm các thiết bị thỏa điều kiện tìm kiếm của ta. Điều kiện này là tên thiết bị hoặc phần mô tả chức năng thiết bị có chứa các kí tự ta tìm kiếm. Có thể dùng các kí tự đại diện như *. Ví dụ tìm kiếm 74* là tìm tất cả IC họ 74. Hình 2.1: Tab Browse và Tab Search -4-
  6. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Thiết lập phím nóng Ngoài ra ta cũng có thể chọn thiết bị trực tiếp bằng phím nóng. Để gán phím nóng cho một thiết bị ta thực hiện các bước sau: 1. Chọn tab Browse trong Panel, sau đó tìm thiết bị mà ta muốn gán phím nóng cho nó. 2. Nhấn vào nút Hotkey, hộp thoại quản lý các phím nóng sẽ xuất hiện, tất cả các phím nóng xếp theo thứ tự alphabet cùng với các thiết bị tượng ứng được gán với nó. 3. Tìm phím tắt nào mà ta muốn gán cho thiết bị đang chọn và chọn Assign. Thay đổi phím nóng. Để thay đổi phím nóng ta làm những bước như sau: 1. Thực hiện các bước 1 và 2 như trên. 2. Gán một thiết bị mới. Hay gán rỗng (ở trên đầu của các thiết bị) như là phím nóng. Hình 2.2: Hộp thoại quản lý phím nóng Đặt thiết bị vào trong bản vẽ Sau khi đã tìm thấy thiết bị, ta có thể đặt chúng vào trong bản vẽ. Để đặt một thiết bị ta làm theo các bước sau. 1. Lựa chọn thiết bị bằng các phương pháp đã nêu ở trên. 2. Nhấn phím r hay nhấn chuột phải để quay thiết bị đến vị tri mong muốn. 3. Nhấn phím m để lât ngược thiết bị. 4. Nhấn chuột trái để đặt thiết bị vào trong bản vẽ. Hay nhấn bất kỳ phím nào (trừ m và r) để đặt thiết bị vào bản vẽ. Các công cụ vẽ và chỉnh sửa Phần này giới thiệu tính năng của các phần tử trên thanh Toolbar để bạn có thể đặt và nối dây các thiết bị với nhau. -5-
  7. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.3: Các công cụ vẽ và chỉnh sữa Arrow Tool Công cụ mũi tên cho phép lựa chọn và di chuyển các thành phần của sơ đồ, có thể kích công tắc…. Ngoài ra còn có thể nhấn đúp chuột lên một thiết bị để thực hiện một số thao tác như thay đổi thông số thiết bị… Wire Tool Sử dụng công cụ vẽ dây (wire tool) ta có thể vẽ dây nối các thiết bị. Có thể vẽ Bus bằng cách nhấn và giữ phím Shift khi bắt đầu vẽ. Có thể vẽ dây không liền nét bằng cách nhấn giữ phím Alt khi bắt đầu vẽ. Dây không liên nét giống như dây dẫn thông thường nhưng nếu nó không được nối với bất kỳ thiết bị nào thì đường dây sẽ không hiện diện trong mạch netlist. Text Tool Sử dụng công cụ text để có thể đặt các đoạn văn bản vào trong bản vẽ. Delete Tool Sử dụng công cụ xóa ta có thể xóa các thành phần (dây dẫn, thiết bị…) trên sơ đồ nguyên lý . Chọn delete tool sau đó nhấn vào thành phần nào mà bạn muốn xóa. Bạn cũng có thể xóa bằng cách chọn thành phần muốn xóa bằng công cụ mũi tên rồi bấm phím Delete trên bàn phím. Zoom Tool Sử dụng Zoom tool bạn có thể phóng to thu nhỏ bản vẽ (zoom in và zoom out). Rotate Button Sử dụng Rotate Button để quay thiết bị ngược chiều kim đồng hồ. Ngoài ra ta còn có thể quay các thiết bị sau khi đã chọn chúng trong thư viện bằng cách nhấn phím r. Mirror Button Sử dụng nút nhấn Mirror để quay các thiết bị theo chiều thẳng đứng góc 1800 (giốn như ta lật trang sách). Ta cũng có thể quay các thiết bị bằng cách nhấn phím m khi chọn thiết bị từ thư viện. -6-
  8. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Lưới Ta có thể hiển thị lưới để sắp xếp các linh kiện trong khung vẽ dễ dàng hơn. Để chọn hiển thị lưới ta làm như sau. Vào menu Options|Schematic, trong tab General ta chọn Visible. Size là khoảng cách ô lưới, Snap To là các thiết bị sẽ đặt ngay lưới, Print là khi in ra có in lưới hay không. Hình 2.4: Chỉnh hiển thị lưới Nối dây cho mạch Để mô phỏng hoặc để tạo nestlist vẽ mạch in thì các thành phần của mạch phải được nối với nhau bằng dây dẫn. CircuitMaker cung cấp cho ta các phương thức tự động nối dây, nối dây bằng tay và nối dây nhanh. Nối dây tự động Để nối dây tự động ta làm như sau: (hình 7a) 1. Chọn công cụ vẽ dây (Wire Tool) trên Toolbar. 2. Đưa tool đến nơi ta cần nối dây(chân của một thiết bị hay là dây dẫn) 3. Nhấn và giữ nút trái chuột. 4. Kéo đến nơi mà ta cần nối dây đến. 5. Dây dẫn sẽ tự động được sinh ra giữa hai điểm. Chế độ vẽ dây tự động chỉ vẽ dây dẫn giữa hai điểm là một dây dẫn hay là chân của một linh kiện. -7-
  9. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Nối dây bằng tay Nối dây bằng tay cho phép vẽ dây dẫn trong bản vẽ chính xác như mong muốn. Thực hiện như sau: (hình 7b) 1. Chọn công cụ vẽ dây (Wire Tool) trên Toolbar. 2. Đưa tool đến nơi ta cần nối dây(chân của một thiết bị hay là dây dẫn). 3. Nhấn và nhả chuột trái. 4. Con trỏ vẽ dây tự động được thay bằng con trỏ vẽ dây bằng tay. Nhấn chuột trái một lần để có thể đổi chiều dây, nhấn hai lần để kết thúc. Chú ý: Muốn vẽ một dây bus ta sử dụng phương pháp vẽ bằng tay. Nối dây nhanh Một trong những cách đơn giản để nối dây là sử dụng tính năng vẽ dây nhanh. Chức năng này cho phép ta đặt thiết bị chưa được nối dây vào một dây dẫn hoặc một chân chưa nối của một thiết bị khác và dây nối sẽ được tự động vẽ. Thực hiện như sau: (hình 7c) 1. Chọn một thiết bị trong thư viện hay là một thiết bị đã có săn trong bản vẽ. 2. Di chuyển thiết bị sao cho chân chưa nối của thiết bị cham vào một dây dẫn hay là một chân của một thiết bị khác. Hình 2.5: Nối dây cho hai thiết bị Dây BUS Dây bus là một loại dây nối đặc biệt bao gồm nhiều dây nối riêng biệt. Mỗi dây nối có một tên riêng và bus cũng có tên riêng. Bus được nhận diện dễ dàng vì nó được vẽ đậm hơn các dây còn lại. Để vẽ Bus ta làm như sau: 1. Nhấn giữ phím Shift trước khi vẽ dây nối. 2. Vẽ dây dẫn sử dụng phương pháp như phương pháp vẽ dây dẫn bằng tay đã đề cập ở trên. 3. Sau khi vẽ xong sẽ có hộp thoại yêu cầu đặt tên cho bus. Hình 2.6: Đặt tên cho BUS -8-
  10. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Nối dây dẫn tới bus Để nối dây dẫn tới bus ta làm như sau: 1. Chọn công cụ nối dây. 2. Nối dây từ vị trí muốn nối tới bus. 3. Đặt tên cho dây dẫn. Hình 2.7: Đặt tên cho dây dẫn nối tới BUS Nối các dây dẫn trên Bus với nhau. Nếu ta đặt tên cho hai dây dẫn nối đến bus cùng một tên và nối đến cùng một đường bus (hoặc nối đến hai bus khác nhau nhưng cùng một tên), hai dây dẫn trên sẽ tự động nối với nhau. Tên của node và sự kết nối CircuitMaker sử dụng tên cho các node trên mạch. Tên của node sử dụng để xác định các sóng khi mô phỏng hay phân biệt các dây dẫn khi vẽ mạch in. Ngoài ra node còn được dùng để nối dây dẫn, hai đoạn dây dẫn được đặc cùng tên node sẽ nối với nhau. Có nhiều cách để đặt tên cho node: ngầm định, các thiết bị đặc biệt, nhãn. Tên node ngầm định, tên của node được sinh ra tự động khi dây dẫn được nối vào một thiết bị. Ví dụ, node name U2_6 có tên như vậy vì được nối vào chân số 6 của thiết bị U2. Dây dẫn trên có thể nối với các thiết bị khác, tên node của nó được xác định bởi thiết bị được đặt lên bản vẽ trước nhất trong các thiết bị nối với nó. Một số thiết bị có độ ưu tiên cao hơn (VCC, GND…) thì khi nối với nó thì tên node sẽ là tên của thiết bị đó. Sử dụng các thiết bị kết nối đặc biệt, đó là các thiết bị Input (Connectors| Active| Input), Output (Connectors| Active| Output) và Terminal (Connectors| Active| Terminal), các thiết bị trên cho phép ta gán nhãn cho các node. Khi đặt một trong các thiết bị trên vào mạch thì phải gán nhãn cho thiết bị nói trên. Và khi nối với một node (dây dẫn) thì tên node sẽ là tên của thiết bị đó. Các thiết bị này có độ ưu tiên về tên của node cao hơn các thiết bị khác kể cả nguồn điện. -9-
  11. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.8: Thiết bị output Nhãn (label), một Node Label có thể được gán cho dây dẫn để tạo thành tên của một node. Đặt Node label như sau: 1. Chọn Edit > Place Node Label. 2. Kéo hình vuông của Node Label cho đến khi nào góc trái của nó chạm vào dây dẫn. Nhấn nút trái chuột. 3. Nhấn tên của node và nhấn OK. Hình 2.9: Gán node label Để xem tất cả tên của các node trong bản vẽ ta thực hiện các bước sau. Chọn Options > Schematic (hay nhấn F5.) Cho phép Show Node Names checkbox. Nhấn OK. Tên của các node sẽ xuất hiện trên các dây dẫn của bản vẽ. Thông số của các thiết bị Ta có thể chỉnh thông số của thiết bị như: các thông tin liên quan đến bản vẽ, mô phỏng, netlist và các thông số khác một cách dễ dàng. Ở trong mục này, chỉ giới thiệu những thông số có liên quan đến việc vẽ mạch và sử dụng trong các mạch số. Để có thể điều chỉnh các thông số ta nhấn dup chuột vào thiết bị hoặc nhấn chuột phải và chọn Device Properties. -10-
  12. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.10: Hộp thoại thay đổi thông số thiết bị Các thuộc tính của thiết bị: 1. Device: tên của thiết bị được lưu trong thư viện. 2. Label-Value: nhãn của thiết bị. 3. Designation: dùng để phân biệt các thiết bị trong bản vẽ, như U1, U2… 4. Description: thông tin thêm, chỉ có ý nghĩa tham khảo trong bản vẽ, không ảnh hưởng mô phỏng. Lưu ý: bốn thuộc tính trên có thể cho hiển thỉ hay không bằng cách chọn hay không tùy chọn Visible tương ứng. 5. Package: cách đóng gói của thiết bị ( DIP, TO…), có ý nghĩa khi vẽ mạch in. 6. Auto Designation Prefix: tiền tố tự động thêm vào phần Designation mỗi khi tạo thiết bị mới. 7. Spice Prefix Character, Parameters, Spice Data: có ý nghĩa khi chạy Spice, ở đây ta không cần quan tâm. 8. Bus Data: mô tả chân nào của thiết bị sẽ nối với nguồn, đất. 9. Exclude From PCB: không đưa vào netlist, thường dùng cho các thiết bị chỉ phục vụ mô phỏng(tạo xung…). 10. Analog, digital: cho biết thiết bị có thể mô phỏng ở chế độ nào. 11. Pin: nhấn vào sẽ hiện số thứ tự chân của thiết bị. Thay đổi dữ liệu RAM/ ROM: Đôi khi trong mạch có thiết bị là RAM hoặc ROM. Khi thay đổi dữ liệu của PROM thì dữ liệu này sẽ được lưu chung khi ta lưu bản vẽ, còn đối với RAM ta có thể xem, thay đổi dữ liệu để kiểm tra, gỡ lỗi nhưng sẽ không được lưu với bản vẽ. Để thay đổi dữ liệu của RAM/ROM ta làm như sau 1. Nhấp chuột phải vào thiết bị rồi chọn Edit PROM/RAM để hiện hộp thoại thay đổi dữ liệu 2. Thay đổi như ý muốn rồi bấm OK lưu lại -11-
  13. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Hình 2.11: Thay đổi dữ liệu ROM/RAM -12-
  14. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Mô phỏng mạch số Mục đích của mô phỏng là để chạy thử, kiểm tra mạch, phát hiện lỗi, gỡ lỗi. Circuit maker vừa có thể mô phỏng mạch tương tự vừa có thể mô phỏng mạch số, trong phần hướng dẫn sử dụng này ta chỉ đề cập đến vấn đề mô phỏng mạch số. Mô phỏng số chỉ có thể thực hiện được với thiết bị thuộc dạng số hoặc thiết bị vừa dạng số vừa tương tự(xem phần thuộc tính của thiết bị để biết chi tiết). Nếu trong mạch có thiết bị dạng tương tự sẽ có cảnh báo trước khi mô phỏng nhưng vẫn cho mô phỏng, khi đó thiết bị này sẽ bị bỏ qua và đường dây nối tới thiết bị này xem như để hở. Bắt đầu mô phỏng mạch số Để chọn chế độ mô phỏng mạch số ta làm như sau: chọn menu Simulation|Digital Mode; nếu chọn Simulation|Analog Mode là chọn chế độ mô phỏng mạch tương tự. Thực hiện Simulation|Check Pin Connections để kiểm tra các thiết bị có chân nào chưa được nối dây hay không. Thực hiện Simulation|Check Wire Connections để kiểm tra có đường dây nối nào chỉ mới nối một đầu hay không. Các công cụ mô phỏng mạch số Đây là các công cụ phục vụ cho việc mô phỏng mạch số. Những công cụ này sẽ khác nếu chọn chế độ mô phỏng là tương tự Hình 3.1 Công cụ mô phỏng số Công cụ Prope Sử dụng công cụ Prope để xem giá trị logic của một dây dẫn hoặc một nốt trong mạch; ngoài ra còn có thể sử dụng công cụ Prope để thay đổi trạng thái của dây nối. Để xem trạng thái, rê công cụ này lên dây dẫn hoặc chân của thiết bị muốn xem. Khi đó công cụ sẽ hiển thị một trong bốn giá trị : Mức 1 Mức 0 Xung Không xác định hoặc ba trạng thái Để thay đổi trạng thái dây nối, rê đến dây nối và nhấn chuột trái, 1 sẽ chuyển thành 0 và 0 sẽ chuyển thành 1. Để gán giá trị ba trạng thái, nhấn giữ shift và nhấn chuột trái. Nếu dây nối với một ngõ xuất của thiết bị nào đó thì sau khi đổi nó sẽ chuyển ngay lại giá trị của ngõ xuất đó. -13-
  15. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Công cụ Reset Khởi động lại quá trình mô phỏng Công cụ Trace Bật tắt tính năng Trace. Tính năng này hiển thị giá trị logic của các dây dẫn bằng các màu khác nhau. Màu đỏ mức 1, màu xanh dương mức 0, màu xanh lá là không xác định hoặc ba trạng thái. Công cụ Run \ Pause: Bắt đầu hoặc dừng quá trình mô phỏng Công cụ Step Quá trình mô phỏng sẽ thực hiện từng bước. Khi nhấn vào công cụ này, mô phỏng sẽ thực hiện một bước và dừng lại. Nhấn lần nữa sẽ thực hiện tiếp một bước nữa. Công cụ Tile Windows Chọn một trong bốn cách xem các cửa sổ. Chỉ cửa sổ vẽ mạch (Schematic) Chỉ cửa sổ dạng sóng (Waveforms) Cửa sổ vẽ mạch bên trên, cửa sổ dáng sóng bên dưới Cửa sổ vẽ mạch bên trái, cửa sổ dáng sóng bên phải Sử dụng thiết bị Instruments/ Digital/SCOPE nối với một nốt của mạch thì Circuit Maker sẽ vẽ dạng sóng cho nốt đó trong cửa sổ dạng sóng Bộ tạo xung Bộ tạo xung, thiết bị trong Instruments|Digital, dùng để tạo ra xung cho các thiết bị mô phỏng cần clock. Để chỉnh các thông số của bộ tạo xung co thể nhấp kép vào thiết bị này hoặc nhấp phải chuột rồi chọn Edit Pulser. Hình 3.2: Bộ tạo xung Pulse High, Pulse Low tương ứng chỉnh thời gian mức một (tính bằng Tick), mức không của bộ tạo xung, giá trị hợp lệ là 1 đến 100. External Trigger là chỉnh bộ tạo xung sẽ đóng vai trò như Trigger, chỉ phát ra xung khi có kích vào chân CP1 hoặc CP2. -14-
  16. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Các thông số mô phỏng: Step size: chỉnh số bước mỗi khi nhấn Step tool. Có thể chọn Cycles hoặc Ticks. Một Cycle bằng 10 Ticks. Tick là đơn vị nhỏ nhất, một Tick sẽ thực hiện một bước trong mô phỏng. X Magnification: chỉnh độ rộng của đồ thị hiển thị dạng sóng Speed: chỉnh tốc độ mô phỏng. Ví dụ như khi cần xem các giá trị xuất ra led bảy đoạn thì chỉnh tốc độ mô phong nhỏ lại. Breakpoint: thiết lập điểm dừng. Mô phỏng sẽ dừng lại khi điều kiện Breakpoint thỏa mãn. Có thể có nhiều điều kiện Breakpoint và các điều kiện Hình 3.3: Thông số mô phỏng này kết hợp với nhau bởi phép logic and hoặc or tùy theo ta thiết lập. Để thiết lập Breakpoint ta làm như sau: sử dụng Instruments/ Digital/SCOPE để nối với dây hoặc chân thiết bị, mở cửa sổ vẽ dạng sóng. Nhấn chuột vào ô nhỏ trước tên của tín hiệu như hình sau Hình 3.4: Thiết lập Breakpoint Nhấn sẽ lần lượt là chọn logic 1, logic 0; chọn kiểu là kích cạnh (Edge) hay kích mức (Level). Thời gian trễ Thời gian trễ của thiết bị là thời gian cần thiết để tín hiệu input lan truyền đến tín hiệu output. Trong CircuitMaker thời gian trễ được tính bằng đơn vị Tick, mặc định tất cả thiết bị có thời gian trễ là một Tick, tuy nhiên có thể thay đổi giá trị này từ 1 đến 14. Để thay đổi thời gian trễ làm như sau 1. Chọn thiết bị cần thay đổi 2. Chọn Edit| Set Prop Delays 3. Gán giá trị mới và bấm OK Hình 3.5: Thay đổi thời gian trễ -15-
  17. Tài liệu bổ trợ Hướng dẫn sử dụng CircuitMaker 2000 Xem dạng sóng Bằng cách nối với thiết bị Scope có thể xem được dạng sóng khi đang mô phỏng cũng như kết quả của mô phỏng. Sau khi kết nối, có thể xem dạng sóng trong cửa sổ phân tích. Hình 3.6: Xem dạng sóng -16-
Đồng bộ tài khoản