Hướng dẫn sử dụng Mapinfo Professional-Phần nâng cao

Chia sẻ: Nguyen Van Linh | Ngày: | Loại File: PDF | Số trang:61

0
245
lượt xem
109
download

Hướng dẫn sử dụng Mapinfo Professional-Phần nâng cao

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Trong MapInfo dữ liệu được tổ chức thành lớp dữ liệu. Đây là một tập hợp gồm nhiều tập tin cí cùng tên nhưng phần mở rộng là tab, dat,map..

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng Mapinfo Professional-Phần nâng cao

  1. ĐẠI HỌC KHOA HỌC KHOA ĐỊA LÝ - ĐỊA CHẤT -----@@@----- HƯỚNG DẪN SỬ DỤNG MAPINFO PROFESSIONAL Phần nâng cao Người biên soạn: Th.S Đỗ Thị Việt Hương (Tài liệu lưu hành nội bộ) Huế, 2008
  2. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ MỤC LỤC CHƯƠNG 1. BIÊN TẬP VÀ TRÌNH BÀY BẢN ĐỒ ............................................................ 3 1.1. BIÊN TẬP BẢN ĐỒ ....................................................................................................... 4 1.1.1. Tạo lớp bản đồ chuyên đề ............................................................................................. 4 1.1.2. Tạo biểu đồ và đồ thị .................................................................................................... 9 1.1.3. Gắn nhãn cho đối tượng ............................................................................................. 15 1.1.4. Tạo chú giải ............................................................................................................... 16 1.1.5. Làm lưới tọa độ .......................................................................................................... 19 1.1.6. Tạo thước tỷ lệ ........................................................................................................... 22 1.1.7. Tạo kim chỉ nam (phương hướng) .............................................................................. 23 1.2. SẮP XẾP THỨ TỰ CÁC LỚP DỮ LIỆU ..................................................................... 23 1.3. TRÌNH BÀY BẢN ĐỒ ................................................................................................. 24 1.3.1. Điều chỉnh phần muốn trình bày ................................................................................. 24 1.3.2. Tỷ lệ bản đồ ............................................................................................................... 25 1.4. CHUẨN BỊ BẢN ĐỒ TRONG CỬA SỔ LAYOUT ..................................................... 26 CHƯƠNG 2. MỘT SỐ CHỨC NĂNG KHÁC CỦA MAPINFO ......................................... 30 2.1. CHỌN VÀ TÌM KIẾM THÔNG TIN TRÊN BẢN ĐỒ ................................................. 30 2.1.1. Lệnh chọn thông tin (Select) ....................................................................................... 30 2.1.2. Lệnh SQL Select ........................................................................................................ 31 2.1.3. Lệnh Find (Tìm kiếm) ................................................................................................ 33 2.1.4. Lệnh tìm kiếm thông tin (Find Selection) ................................................................... 35 2.2. PHÂN LOẠI VÀ TỔ CHỨC DỮ LIỆU (New Redistrict Window) ............................... 36 2.3. MÃ ĐỊA HOÁ (Geocode) ............................................................................................. 41 2.4. TẠO ĐỐI TƯỢNG ĐIỂM TỪ CƠ SỞ DỮ LIỆU NGOÀI MAPINFO (Create point) ........ 47 2.5. TẠO LIÊN KẾT NÓNG (HotLink) ............................................................................... 47 2.6. KẾT XUẤT DỮ LIỆU ĐO ĐẠC BẰNG GPS THÔNG QUA MAPSOURCE 6.13.17 VÀ ĐĂNG NHẬP VÀO MAPINFO .......................................................................................... 48 2.6.1. Kết xuất dữ liệu đo đạc từ máy định vị GPS ............................................................... 48 2.6.2. Đăng nhập dữ liệu vào MapInfo ................................................................................. 49 2.7. CHỈNH SỮA DỮ LIỆU CỦA BẢN ĐỒ SỐ HOÁ ........................................................ 50 CHƯƠNG 3. SỬ DỤNG CHƯƠNG TRÌNH PHẦN MỀM VERTICAL MAPER TRONG MÔI TRƯỜNG MAPINFO ................................................................................................. 52 1- Bước I: Chuẩn bị một bản đồ địa hình, thể hiện bằng phương pháp đường đẳng cao: ....... 52 Hình 1: Trích bản đồ topo 1/10.000. - Đường đẳng cao địa hình ........................................... 52 2- Bước II: Chuyển các đường đẳng cao thành các chuỗi điểm độ cao. ................................. 52 Hình II.4: Bản đồ đường đẳng cao sau khi VM nội suy, tạo thành chuỗi điểm. ..................... 53 3- Bước III: Thực hiện phép nội suy để tạo ra mô hình số độ cao địa hình. .......................... 54 2 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  3. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ CHƯƠNG 1. BIÊN TẬP VÀ TRÌNH BÀY BẢN ĐỒ Khi chúng ta có các lớp dữ liệu riêng biệt về một khu vực lãnh thổ, chúng ta có thể xây dựng các bản đồ chuyên đề khác nhau. Xây dựng bản đồ trên máy tính là kết hợp các lớp dữ liệu đã được số hoá, sắp xếp thứ tự, tô màu, ghi chú giải, tạo lưới tọa độ… cũng như sắp xếp vị trí của chúng để có thể in ra giấy. Công tác biên tập và trình bày bản đồ là một công việc không những có tính chất khoa học, chính xác mà còn có tính chất nghệ thuật cao. Để có một bản đồ trình bày rõ ràng, đầy đủ chi tiết và đẹp người biên tập phải có những kiến thức cơ bản về bản đồ học và cần phải có đức tính cẩn thận trong công tác biên tập. Nói chung, một bản đồ khi được trình bày sẽ có các thành phần dưới đây. Tuỳ theo loại bản đồ và mục đích sử dụng mà các thành phần này có thể có hoặc không, hoặc thay đổi nhưng cơ bản là chúng cần thiết. 1- Tên của bản đồ: Mọi bản đồ được in ra hay được trình bày đều nhằm phục vụ cho một mục đích nào đó, vì vậy tên của bản đồ phải giải thích một cách tóm tắt nhưng đầy đủ nội dung của bản đồ. 2- Nội dung bản đồ: Đây là phần quan trọng nhất của bản đồ, bao gồm các thông tin dưới dạng đồ hoạ như sông suối, đường xá, tỉnh, thành phố, đường cao độ,... Nội dung của bản đồ phải phù hợp với tên của bản đồ, tức làm nổi bật được nội dung muốn trình bày. 3- Nhãn: Trên bản đồ ta thấy có tên tỉnh, có tên thành phố, tên sông suối,... Đó là các nhãn nhằm mục đích làm rõ nghĩa của các đối tượng trên bản đồ. 4- Chú giải: Đây là phần giải nghĩa rõ thêm cho các biểu tượng, kiểu đường, kiểu vùng được trình bày trên bản đồ, ví dụ trong chú giải có nội dung sau: đường liền mảnh màu xanh dương tượng trưng cho sông suối, đường liền màu đỏ tượng trưng cho đường bộ, đường gạch chấm đậm tượng trưng cho ranh giới tỉnh, ngôi sao màu đỏ tượng trưng cho thủ đô,.... Phần chú giải (hay còn gọi là chú dẫn, chú thích) của bản đồ thường được đặt riêng trong một khung. 5- Lưới tọa độ: Phần này có thể có hay không, tuy nhiên lưới tọa độ thường là cần thiết vì nó giúp người xem bản đồ xác định được vị trí trên bản đồ. Lưới tọa độ là những đường song song với kinh tuyến và xích đạo, cách đều nhau một khoảng nhất định và trên mỗi đường đều có toạ độ. 6 - Thước tỷ lệ: Thường nằm ở một góc của bản đồ biểu thị cho tỷ lệ khoảng cách trên bản đồ tương ứng với khoảng cách ngoài thực địa là bao nhiêu. Thước tỷ lệ cũng có thể được trình bày hay không, ví dụ như trong tên của bản đồ ta đã ghi t ỷ lệ của bản đồ rồi thì thước tỷ lệ trên bản đồ có thể không cần thiết, tuy nhiên nếu có thì bản đồ càng trở nên rõ ràng, thuận tiện cho người sử dụng hơn. 7 - Phương hướng bản đồ (mũi tên chỉ hướng): Mũi tên chỉ hướng nhằm giúp cho người đọc bản đồ xác định được hướng Bắc trên bản đồ. Yếu tố này có thể có hoặc không vì thông thường thì hướng bắc được quy ước là hướng thẳng lên trên. Trong một số trường hợp 3 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  4. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ do mục đích mỹ thuật khi trình bày bản đồ mà người ta có thể xoay bản đồ đi sao cho thuận tiện, lúc đó kim chỉ nam là cần thiết để giúp xác định hướng Bắc như đã nói. Đối với những bản đồ được xây dựng để sử dụng ngoài thực địa thì lưới tọa độ, thước tỷ lệ và kim chỉ nam rất cần thiết. 8 - Các yếu tố khác: Trong bản đồ ta cũng có thể cung cấp thêm những thông tin khác cho người xem, ví dụ như tác giả của bản đồ, hệ quy chiếu mà bản đồ đang sử dụng, nguồn của những thông tin trên bản đồ,... Ở đây ta nói đến bản đồ được trình bày trong MapInfo, đối với bản đồ in chuyên nghiệp, còn có các thông tin về nhà xuất bản, số lượng in, thời gian in,... Trong khi trình bày một bản đồ chúng ta nên dùng lệnh lưu Workspace để tiện cho công tác biên tập, được thực hiện như sau: - Từ menu chính chọn File > Save Workspace. Hộp thoại Save Workspace mở ra. - Đặt tên cho workspace (không gian làm việc) trong ô File Name, chọn thư mục lưu tập tin workspace trong ô Save In rồi nhấn nút Save. Lưu ý trong khi kết thúc một lần biên tập và chỉnh sửa thì ta phải lưu trang làm việc Workspace. 1.1. BIÊN TẬP BẢN ĐỒ 1.1.1. Tạo lớp bản đồ chuyên đề Lệnh tạo bản đồ chuyên đề (Create Thematic Map) chỉ được kích hoạt khi có một cửa sổ bản đồ đang được kích hoạt. Để tiến hành tạo bản đồ chuyên đề ta vào Map>Create Thematic Map, khi đó màn hình hiện ra hộp thoại chuyên đề với thực đơn chính cho phép tạo ra bản đồ theo các phương pháp khác nhau, muốn lập bản đồ theo phương pháp nào đó, ta cần bấm chọn biểu tượng của phương pháp đó. Trong hộp thoại có các phương pháp: 1- Ranges (Phương pháp đồ giải - Cartogram): Lập bản đồ chủ đề theo các khoảng giới hạn giá trị của dữ liệu. Các khoảng giới hạn được biểu thị bằng màu/kiểu đối tượng khác nhau và có sự thay đổi có tính quy luật tương ứng với giá trị dữ liệu. Bản đồ chủ đề theo khoảng giới hạn cho phép ta minh hoạ các dữ liệu của điểm, đường và vùng. Chúng được sử dụng để minh hoạ mối quan hệ giữa giá trị dữ liệu và vùng địa lý (ví dụ như doanh số bán ra của từng khu vực, thu nhập bình quân đầu người của từng khu vực) hoặc để biểu thị thông tin kiểu tỷ lệ, ví dụ như mật độ dân số. 2- Bar Charts (Phương pháp biểu đồ bản đồ- Cartodiagram): Vẽ biểu đồ cột theo giá trị dữ liệu của từng bản ghi. Biểu đồ cột được sử dụng để minh hoạ nhiều biến của một bản ghi trong bản đồ. Ta có thể so sánh kích thước các cột trong mỗi biểu đồ để có được thông tin về từng bản ghi trong dữ liệu của bảng, hoặc có thể so sánh một cột với tất cả các cột khác để có nhận định về một biến theo tất cả các bản ghi, hoặc so sánh chiều cao của biểu đồ cột để có thông tin về toàn bộ bảng. Đối với mỗi đối tượng biểu đồ cột được đặt tại vị trí trọng tâm của nó. Ví dụ: Trên bản đồ phát triển dân số, các cột của biểu đồ thể hiện cho dân số phát triển qua từng năm tại từng đơn vị hành chính. Hoặc ta cũng có thể thành lập nội dung chuyên đề cho lượng mưa trong năm thu được tại các trạm đo trên cả nước, lúc này với biểu đồ cột có thể được biểu diễn trên đối tượng điểm tại vị trí trạm đi, mỗi cột thể hiện lượng mưa trung bình trong từng tháng. 4 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  5. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ 3- Pie Charts (Phương pháp biểu đồ bản đồ- Cartodiagram): Vẽ biểu đồ dạng hình quạt, đây là dạng biểu đồ nhiều biến. Loại này được sử dụng trong bản đồ để phân tích một hay nhiều biến cùng một lúc. Ta có thể so sánh kích thước của các hình rẻ quạt trong mỗi biểu đồ để có thông tin về từng bản ghi, hoặc so sánh một hình rẻ quạt với tất cả các biểu đồ hình quạt để có nhận định về một biến nào đó theo các bản ghi, hoặc so sánh đường kính của các biểu đồ quạt để có thông tin về toàn bộ dữ liệu được vẽ biểu đồ. 4- Graduated (Phương pháp ký hiệu): Biễu diễn mỗi bản ghi trong bảng bằng một biểu tượng, kích thước của biểu tượng tỷ lệ trực tiếp với giá trị dữ liệu. Một bản đồ có các biểu tượng được phân cấp hiển thị dữ liệu theo các giá trị của chúng. Kiểu phân cấp này hữu ích trong việc trình bày các thông tin có tính chất định lượng, ví dụ như phân hạng từ cao đến thấp. Kích thước của các biểu tượng tỷ lệ với các giá trị dữ liệu của bản ghi. Các điểm có giá trị trong bảng dữ liệu lớn hơn sẽ được vẽ to hơn và ngược lại. 5- Dot Density (Phương pháp chấm điểm): Áp dụng đối với bảng kiểu vùng. Kiểu này biểu diễn giá trị dữ liệu thành các chấm trên bản đồ, mỗi một chấm tương đương với một con số và tổng số chấm trong một vùng tương ứng với giá trị dữ liệu của vùng đó. Một bản đồ theo kiểu mật độ điểm cho phép ta ước lượng nhanh giá trị dữ liệu (ví dụ như dân số chẳng hạn). 6- Individual (Phương pháp nền chất lượng): “Tô màu” các bản ghi theo các giá trị dữ liệu riêng lẻ. Các mẫu giá trị tạm kiểu riêng lẻ thuộc loại nhiều biến. Ta có thể chọn “tô màu” cho điểm, đường hay vùng. Một bản đồ chủ đề vẽ các đối tượng bản đồ theo từng giá trị riêng lẻ được sử dụng khi ta muốn nhấn mạnh sự khác biệt giữa từng đối tượng (định tính), ví dụ như các kiểu nhà hàng trong một khu vực, các cấp phân chia vùng trong một khu vực,...chứ không quan tâm đến tính chất định lượng. Đây là kiểu bản đồ chủ đề duy nhất có thể được xây dựng từ trường dữ liệu không phải kiểu số (not numeric field). 7- Grid: Bản đồ chủ đề kiểu lưới (grid) biểu diễn giá trị dữ liệu thành sự thay đổi màu từ từ trên toàn bản đồ. Kiểu bản đồ chủ đề này được xây dựng bằng cách nội suy các dữ liệu dạng điểm từ bảng dữ liệu gốc. Một tập tin lưới (grid file) được tạo ra khi nội suy dữ liệu và được biểu diễn thành một ảnh quét trên cửa sổ bản đồ. Ở đây chúng tôi đưa ra phương pháp Cartogram làm ví dụ: Một cách tổng quát, lệnh Create Thematic Map bao gồm 3 bước: - Bước 1: Chọn kiểu bản đồ chủ đề Chọn Map > Create Thematic Map, hộp thoại Create Thematic Map - Step 1 of 3 mở ra. Trong hộp thoại này ta chọn Kiểu chủ đề và mẫu được sử dụng để tạo bản đồ chủ đề. 5 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  6. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Hộp thoại này có các nội dung sau: + Phần Type dùng để chọn kiểu bản đồ chủ đề. Chọn kiểu Range: + Phần Template: Ứng với mỗi kiểu trong cột Type thì trong phần Template có một số mẫu bản đồ theo chủ đề có sẵn tương ứng với kiểu được chọn. Tùy theo ý muốn mà người dùng chọn mẫu sao cho thích hợp. + Phần Preview: Hiển thị minh họa chú giải cho từng kiểu được chọn. + Hai tuỳ chọn là Sort by Name và Sort by Time, dùng để sắp thứ tự các mẫu theo tên hay theo trình tự thời gian chúng được tạo thành. Chọn Next, hộp thoại Create Thematic Map - Step 2 of 3 mở ra. - Bước 2: Thiết lập các thông số để tạo bản đồ chủ đề Trong hộp thoại Create Thematic Map - Step 2 of 3 ta chọn bảng và trường dữ liệu dùng để tạo bản đồ chủ đề. Nếu chọn phương pháp tạo bản đồ chủ đề theo một biến, ở bước 2 ta có thể đánh dấu ô Ignore Zeroes or Blanks để bỏ đi những bản ghi có giá trị là 0 (dữ liệu kiểu số) hay rỗng (dữ liệu kiểu ký tự) nếu muốn. Khi điều chỉnh xong chọn Next. Hộp thoại Create Thematic Map - Step 3 of 3 mở ra. - Bước 3: Điều chỉnh bản đồ chủ đề 6 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  7. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Trong hộp thoại Create Thematic Map - Step 3 of 3, ta chọn kiểu “tô màu”, kiểu chữ cho chú giải, khoảng giới hạn, số bước phân cấp, cách sắp thứ tự chú giải,... (tuỳ kiểu bản đồ chủ đề chọn lúc đầu). Hai tuỳ chọn Ascending (Sắp thứ tự xuôi) và Descending (Sắp thứ tự ngược). Trong phần Legend Label Order cho phép ta chọn cách xếp thứ tự cho chú giải. Ở phần Template ta có thể lưu các thiết lập thành một mẫu để sử dụng sau này. Ta có thể thay đổi các tham số của bản đồ chuyên đề như định nghĩa lại các khaỏng giá trị, các thuộc tính thể hiện băng cách chọn các nút lệnh khác nhau như Ranges, Styles, Settings. + Ranges cho phép điều chỉnh các khoảng giới hạn trong một bản đồ chủ đề có chia các khoảng giới hạn. Method: Phương pháp tạo bản đồ chuyên đề, bao gồm các phương pháp sau: Equal count: tạo ra các nhóm đối tượng có số bản ghi như nhau, Equal range: tạo ra nhóm đối tượng có khoảng dữ liệu như nhau; Natural Break: Sự phân tách các khoảng dữ liệu chuyên đề dựa trên cơ sở tối thiểu hoá các hiệu số của các dữ liệu với giá trị trung bình của chúng; Standard Deviation: khoảng cách được phân tách tại giá trị trung bình của dữ liệu, khoảng trên và khoảng dưới được xác định bằng khoảng giữa cộng trừ đi một sai lệch chuẩn; Quantile: Xác định sự phân bố của một biến dữ liệu dọc theo khoảng dữ liệu, Custom: tự xác định các khoảng dữ liệu chuyên đề; #range: nhập số lượng các khoảng dữ liệu chuyên đề, theo 7 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  8. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ giá trị này hệ thống sẽ tự động tính toán giá trị của các khoảng giá trị dựa trên giá trị Min, Max; Round by: chọn số chữ làm tròn cho hệ thống. + Styles dùng để điều chỉnh các thuộc tính về kiểu như màu sắc và kích thước. Chọn color để chọn tạo lớp bản đồ chuyên đề dựa trên cơ sở tô màu các nhóm đối tượng hoặc chọn None để loại bỏ tô màu. Để tạo chú giải cho lớp chuyên đề, bấm nút Legend, xuất hiện hộp thoại Customize Legend. Trong hộp thoại cần xác định: Title Font: Font cho tiêu đề ghi chú Tile: Biên tập tiêu đề ghi chú Subtilte: Biên tập tiêu đề phụ ghi chú Subtitle font: Biên tập kiểu chữ tiêu đề phụ Font: Chọn kiểu chữ cho các nhãn Edit selected range here: Biên tập các khoảng giá trị dữ liệu chuyên đề Show this range: Hiển thị khoảng dữ liệu chuyên đề Show record count: Chọn hiển thị số lượng bản ghi Sau khi hoàn tất bước 3, bản đồ nguyên thuỷ lúc đầu sẽ được “tô màu” theo thiết lập đã chọn trong 3 bước trên, đồng thời một chú giải cũng được tạo thành để giải thích cho cách “tô màu” đó. 8 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  9. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Lệnh này không làm thay đổi bảng MapInfo nguyên thuỷ, nó chỉ “phủ” lên lớp bản đồ nguyên thuỷ một lớp “vỏ”theo các dữ liệu do ta thiết lập. Nếu mở hộp thoại Layer Control, ta sẽ thấy trên lớp được tạo bản đồ chủ đề có thêm một lớp nữa. Lớp này hơi thụt vào một chút so với các lớp bình thường. Tên của lớp này là tên phương pháp tạo bản đồ chủ đề và dữ liệu được sử dụng để tạo bản đồ chủ đề. Bài tập ứng dụng Bài tập 7. Tạo lớp bản đồ chuyên đề Từ cơ sở dữ liệu bản đồ Thừa Thiên Huế đã thiết lập, thành lập lớp bản đồ chuyên đề mật độ dân cư. 1.1.2. Tạo biểu đồ và đồ thị a. Phương pháp tạo biểu đồ Tạo biểu đồ trong MapInfo được thực hiện bằng lệnh Window > New Graph Window hoặc bằng nút lệnh New Grapher trên thanh công cụ Standard. Trong bảng phải có trường dữ liệu kiểu số (numeric field) thì mới có thể lập biểu đồ được. Các bước để lập biểu đồ như sau: - Mở lớp bản đồ có chứa dữ liệu ta muốn lập biểu đồ ra. - Từ menu chính chọn Window > New Graph Window. Cửa sổ Create Graph - Step 1 of 2 mở ra. Ô Graph: Liệt kê danh sách các kiểu biểu đồ của MapInfo. Trong MapInfo có các kiểu biểu đồ sau: + 3D (dạng không gian 3 chiều). + Area (dạng diện tích). 9 ________________________________________________________________________ Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  10. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ + Bar (dạng hình que). + Bubble (dạng bong bóng). + Column (dạng cột). + Histogram (biểu đồ tần số). + Line (dạng đường). + Pie (dạng hình quạt). + Scattered (dạng điểm phân tán). + Surface (dạng bề mặt). Chọn kiểu biểu đồ ta muốn. - Khi chọn xong kiểu biểu đồ thì phần Template bên phải sẽ liệt kê danh sách các mẫu của kiểu đã được chọn. Chọn mẫu ta muốn rồi chọn OK. Hộp thoại Create Graph - Step 2 of 2 mở ra. + Ô Table dùng để chọn bảng tạo biểu đồ. + Phần Fields có hai mục.  Ô Fields from Table: Liệt kê danh sách các trường kiểu số có trong bảng đã chọn.  Ô Fields for Graph: Liệt kê tên các trường được chọn để tạo biểu đồ bằng nút Add hoặc muốn loại chúng ra thì có thể chọn nút Remove. Ta có thể di chuyển vị trí trường bằng cách chọn trường đó trong ô Fields for Graph rồi nhấn nút Up hay Down. Thứ tự trên/dưới của các trường trong ô Fields for Graph sẽ quyết định thứ tự hiển thị của biểu đồ sau này. + Ô Label with Column: Chọn trường để dán nhãn biểu đồ. Ta cũng có thể chọn None nếu không muốn dán nhãn.  Series in Rows: Sắp xếp dữ liệu theo hàng  Series in Columns: Sắp xếp dữ liệu theo cột - Sau khi chọn xong nhắp chuột vào nút OK. Biểu đồ sẽ được trình bày trong một cửa sổ có tiêu đề dạng [tên bảng] Graph. Biểu đồ sau khi vẽ xong có các phần sau: ________________________________________________________________________ 10 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  11. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ - Trên cùng là phần có dạng Graph of: [tên bảng/tên phép chọn], ngay phía dưới là hàng <subtitle>. - Bên trái cửa sổ là phần biểu đồ gồm có: tên trục trung có dạng [Y1 axis title], tên trục hoành có dạng [tên trường được dán nhãn]. - Bên phải biểu đồ là chú giải. - Dưới cùng là các nội dung <group title> (tên nhóm) và <footnote> (ghi chú). Khi cửa sổ biểu đồ được kích hoạt thì trên menu chính có thêm một menu con nữa là Graph. Menu này cho phép ta điều chỉnh các thành phần của biểu đồ. b. Điều chỉnh biểu đồ * Lệnh Formatting Đây là lệnh định dạng các thành phần của biểu đồ. Muốn định dạng phần nào của biểu đồ thì ta phải nhắp chuột chọn phần đó trước rồi từ menu chính chọn Graph > Formatting hoặc click doup vào đối tượng đã được chọn thì menu định dạng tương ứng của phần được chọn sẽ mở ra. * Lệnh General Options Lệnh này dùng để điều chỉnh các tuỳ chọn của biểu đồ trong hộp thoại General Options. Ta điều chỉnh từng mục bằng cách nhắp chuột vào thanh t iêu đề của từng mục ở phía trên hộp thoại. ________________________________________________________________________ 11 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  12. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ - General: Bên trái hộp thoại này hiển thị dạng của cửa sổ biểu đồ. Mục này có các nội dung sau: + Overlap: Thanh trượt này để điều chỉnh khoảng cách giữa các yếu tố thành phần của một chuỗi dữ liệu. Khi ta điều chỉnh thanh trượt này thì các cột của biểu đồ sẽ cách xa hay xích lại gần nhau. Khi ta điều chỉnh thanh trượt này thì biểu đồ mẫu bên trái sẽ thay đổi tương ứng. + Gap Width: Thanh trượt này để điều chỉnh khoảng cách giữa các nhóm dữ liệu khác nhau khi vẽ biểu đồ từ nhiều trường. + Riser Shape cho phép ta thay đổi hình dạng của các cột biểu đồ. Trong biểu đồ cột có 3 tuỳ chọn là Rectangle (hình chữ nhật), Beveled Box (đổ bóng xuôi) và Reverse Beveled Box (đổ bóng ngược). + Use Depth: (tạo biểu đồ dạng khối 3 chiều): Nếu ta đánh dấu chọn vào phần này thì phần Riser Shape sẽ bị mờ đi vì tác dụng chỉnh dạng biểu đồ sẽ thuộc phần này.  Depth: Điều chỉnh chiều sâu của cột biểu đồ.  Direction: Điều chỉnh góc nhìn của biểu đồ 3 chiều. - Layout: Dùng để điều chỉnh cách sắp xếp các dữ liệu thành phần trong một nhóm/chuỗi dữ liệu. Phần Type cho phép chọn các kiểu Clustered, Stacked, Percent và True 3D Column. Chọn kiểu trình bày biểu đồ và xem sự thay đổi của biểu đồ mẫu bên trái để quyết định chọn kiểu nào ưng ý. Tuỳ chọn Dual Axes cho phép biểu diễn dữ liệu theo hai trục tung trên biểu đồ, một số bản ghi theo một trục tung và một số bản ghi khác theo trục tung thứ hai. Nếu đánh dấu tuỳ chọn này thì ta có thêm một tuỳ chọn nữa phía dưới là Split Dual Axes. Tuỳ chọn này cho phép tách dữ liệu ra làm hai nhóm và biểu diễn trên hai đồ thị nằm cạnh nhau. Xem sự thay đổi tương ứng của biểu đồ mẫu bên trái để chọn. - Data Labels: Dán nhãn dữ liệu lên biểu đồ, mặc định tuỳ chọn này tắt đi. Nếu đánh dấu vào ô Show Data labels thì các tuỳ chọn Labels Location và Label Format hiện lên.  Labels Location: Chỉnh vị trí của giá trị dữ liệu, có 4 tuỳ chọn là Outside Maximum (giá trị dữ liệu nằm trên đầu và ngoài từng cột biểu đồ), Inside Maximum (nằm trong biểu đồ và ở trên cùng), Center (nằm ngay giữa biểu đồ) và Base of Chart (nằm ngay dưới đáy biểu đồ). Xem sự thay đổi tương ứng ở biểu đồ mẫu bên trái khi chọn các kiểu khác nhau.  Label Format cho phép chọn cách dán thông tin lên biểu đồ. Có 3 tuỳ chọn là Value (dán nhãn là giá trị dữ liệu), Label (dán nhãn là tên trường được chọn dán nhãn) và Value & Lables (dán nhãn cả hai thông tin trên). Nếu dán nhãn là giá trị dữ liệu lên biểu đồ thì phần Number sẽ hiện rõ lên cho phép định dạng kiểu dữ liệu. - Numbers: Chọn các kiểu định dạng dữ liệu khác nhau. Khi chọn mục này ta có ô Category cho phép chọn hiển thị dữ liệu thao các định dạng khác nhau. Ta có các kiểu sau: General (kiểu tổng quát, không định dạng), Number (kiểu số), Currency (kiểu tiền tệ), Date (kiểu ngày tháng), Time (kiểu thời gian), Percent (kiểu tỷ lệ phần trăm), Fraction (kiểu phân số), Scientific (kiểu số khoa học, số mũ của logarit Neper), Special (kiểu đặc biệt). Mỗi tuỳ chọn này khi được chọn lại có một số nội dung khác chi tiết hơn cho từng loại. ________________________________________________________________________ 12 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  13. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ - Dual Y Options: Chỉ hiện lên khi chọn Dual Axes trong mục Layout. Phần này cho phép ta chọn những bản ghi nào hiển thị trên trục tung sơ cấp (Primary Y1 Axis) và những bản ghi nào hiển thị trên trục tung thứ cấp (Secondary Y2 Axis). Giữa hai cột này có một nút lệnh hình mũi tên nút cho phép ta chọn bản ghi và chuyển chúng qua lại giữa hai cột. - Look: Bao gồm hai phần chính là Color Mode và Show Legend.  Color Mode: Dùng để chọn kiểu tô màu biểu đồ. Có hai tuỳ chọn là Color by Series (tô màu biểu đồ khác nhau cho từng giá trị cá thể trong nhóm/chuỗi dữ liệu) và Color by Category (tô màu biểu đồ theo nhóm/chuỗi dữ liệu, nếu chọn mục này các giá trị dữ liệu cá thể trong từng nhóm sẽ có cùng màu).  Show Legend cho phép bật/tắt phần chú giải của biểu đồ.  Phần Markers and Text cho phép chỉnh nội dung và vị trí của chú giải. Chọn từng kiểu và xem sự thay đổi tương ứng của biểu đồ mẫu bên trái. Phần Layout cho phép chỉnh vị trí của chú giải so với vị trí biểu đồ. Phần Box Style cho phép chỉnh đường viền của chú giải, bao gồm các tuỳ chọn No Frame, Single Line Frame, Double Line Frame, Beveled Frame (khung đổ bóng xuôi) và Reverse Beveled Frame (khung đổ bóng ngược). - Display Status: bật/tắt các yếu tố chính của biểu đồ. Phần Axes có hai tuỳ chọn là Category Axis (bật tắt tên trục hoành) và Value Axis (bật/tắt tên trục tung). Phần Major Grid và Minor Grid cho phép bật/tắt các đường lưới chính và phụ theo chiều trục hoành và trục tung tương ứng bên trái. Hai tuỳ chọn dưới cùng là Legend và Data Labels cho phép bật/tắt chú giải và nhãn. * Lệnh Series Options Series Options cho phép điều chỉnh một thành phần riêng lẻ của biểu đồ (tức một bản ghi trong bảng dữ liệu). Để điều chỉnh, dùng công cụ chọn nhắp chuột vào thành phần đó trên biểu đồ hay trên chú giải rồi chọn Graph > Series Options. Hộp thoại Series Options mở ra cho phép ta điều chỉnh hình dạng cũng như các thiết lập về nhãn của phần được chọn. * Lệnh Grid and Scales Lệnh này cho phép điều chỉnh các đường lưới định vị cũng như hình dạng của biểu đồ Y1 Axis và Category Axis. Khi chọn một trong hai menu này thì các nội dung ở các mục trên hàng ngang thay đổi tương ứng. - Y1 Axis: Gồm các nội dung sau + General: Cho phép chỉnh vị trí trục tung. Nó bao gồm các tuỳ chọn  Axis on Left: Vẽ trục tung bên trái biểu đồ.  Axis on Right: Vẽ trục tung bên phải.  Axis on Both Sides: Vẽ trục tung cả hai bên.  Make this a Descending Axis: Đánh dấu tuỳ chọn này sẽ cho phép vẽ biểu đồ theo chiều ngược từ trên xuống - tức trục tung nằm trên đầu cột biểu đồ. + Scale: Cho phép điều chỉnh các tỷ lệ biểu diễn dữ liệu trên trục tung. Nó bao gồm các tuỳ chọn: ________________________________________________________________________ 13 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  14. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________  Use Logarithmic Scale on this Axis: Chấm khoảng cách giá trị trên trục tung theo tỷ lệ logarit.  Always Include Zero in This Scale: Trục tung luôn có giá trị zero ở gốc đồ thị).  Use Manual Settings for Maximum Value: Điều chỉnh thiết lập theo giá trị tối đa.  Use Manual Settings for Minimum Value: Điều chỉnh thiết lập theo giá trị tối thiểu - tức gốc đồ thị là giá trị nhỏ nhất. + Labels: Có một tuỳ chọn là Show Labels for this Axis, dùng để hiển thị nhãn của trục này trên biểu đồ. Nếu đánh dấu tuỳ chọn này thì sẽ có hai tuỳ chọn nữa:  Don’t Show Maximum Value Label: Không hiển thị nhãn có giá trị lớn nhất.  Don’t Show Minimum Value Label: Không hiển thị nhãn có giá trị nhỏ nhất. + Number: Định dạng số liệu, tương tự mục Number của phần General Options. + Grid: Chỉnh các đường lưới định vị của biểu đồ. Mục này có hai phần là Major Gridlines (Đường lưới chính) và Minor Gridlines (Đường lưới phụ). Nội dung của hai hộp thoại này giống nhau, bao gồm các tùy chọn:  Show Gridlines: Nếu đánh dấu phần này thì bên dưới nổi lên ô Grid Style. Ô này dùng để chọn định dạng kiểu đường chia lưới, gồm các tuỳ chọn Regular Grids, Grids and Ticks, Inner Ticks, Outer Ticks và Spanning Ticks.  Use Manual Grids: Nếu đánh dấu thì ô Interval Value phía dưới nổi lên cho phép chọn khoảng giá trị giữa các đường lưới.  Draw Custom Line At: Nếu đánh dấu thì ta có thể vẽ một đường chạy song song với trục hoành và cách trục hoành một khoảng giá trị do ta nạp vào ô giá trị bên phải tuỳ chọn này. - Category Axis: Bao gồm 3 phần. + General: Cho phép chỉnh vị trí trục hoành, gồm 3 tuỳ chọn là Axis on Bottom (vẽ trục hoành dưới đáy), Axis on Top (vẽ trục ho ành phía trên) và Axis on Both Sides (vẽ trục hoành cả trên lẫn dưới). Dưới cùng là tuỳ chọn Draw Categories in Reverse Order. Đánh dấu vào t uỳ chọn này sẽ khiến cho biểu đồ được vẽ với thứ tự các nhóm/chuỗi dữ liệu ngược lại. Tùy chọn này không có tác dụng nếu ta chỉ chọn vẽ một nhóm dữ liệu trên biểu đồ. + Labels: Điều chỉnh việc bật/tắt tên của trục hoành (là tên trường được được sử dụng để vẽ biểu đồ). Nếu đánh dấu chọn vào Show Labels for this Axis thì có hai tuỳ chọn nữa phía dưới là Stagger Labels (Nhãn có đường chỉ) và Use manual Numbers of Categories. + Grids: Có các tuỳ chọn tương tự như trong mục Grids của phần trục tung. * Lệnh Titles ________________________________________________________________________ 14 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  15. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Phần này cho phép ta chỉnh nội dung các tiêu đề trong cửa sổ biểu đồ. Nó bao gồm các tuỳ chọn sau: - Title: Đánh dấu ô này sẽ mở tên chính của biểu đồ lên. Ô bên trái dùng để gõ lại tên biểu đồ. - Subtitle: Bật/tắt và chỉnh nội dung của tiêu đề phụ. - Footnote: Bật/tắt chân đề và gõ nội dung của nó. - Category Title: Bật/tắt và gõ tên (tiêu đề) của nhóm dữ liệu. - Value Title (Y1): Bật/tắt và sửa tên của trục tung (trục giá trị). * Lệnh 3D View Angle Lệnh này chỉ hiện lên nếu trong phần Graph > General Options > Layout ta chọn True 3D Column. Phần 3D View Angle này giúp điều chỉnh chiều sâu và góc nhìn của biểu đồ kiểu 3 chiều. Chọn lệnh này sẽ mở hộp thoại Choose a viewing Angle, cho phép ta chọn 10 góc nhìn khác nhau của biểu đồ 3D theo mẫu. Phía trên còn có nút Advanced Options dùng để chỉnh góc nhìn của biểu đồ chi tiết hơn nữa. c. Lưu biểu đồ Biểu đồ được lưu lại bằng lệnh File > Save Workspace. Trong trường hợp có nhiều cửa sổ biểu đồ được tạo ra và ta dùng lệnh Save Workspace thì MapInfo sẽ lưu mỗi cửa sổ biểu đồ dưới một tên riêng có đuôi mở rộng là .3tf trong cùng thư mục với tên tập tin workspace được lưu. Tên của tập tin workspace sẽ có dạng [tên workspace], [tên biểu đồ].3tf; trong đó [tên workspace] là tên tập tin phiên làm việc mà ta đang muốn lưu và [tên biểu đồ] là tên của cửa sổ biểu đồ đã được tạo ra. Bài tập ứng dụng Bài tập 8. Tạo biểu đồ Từ cơ sở dữ liệu thuộc tính về dân số các đơn vị hành chính của tỉnh Thừa Thiên Huế, hãy tạo biểu đồ dân số, biểu đồ tỉ lệ dân số nam/nữ. 1.1.3. Gắn nhãn cho đối tượng ________________________________________________________________________ 15 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  16. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Việc gắn nhãn (địa danh) cho đối tượng trên bản đồ có thể thực hiện bằng phương pháp tự động hay bằng công cụ tạo đối tượng chữ trên thanh công cụ Main. Cách gắn nhãn tự động: - Chọn Map > Layer Control. - Chọn lớp muốn gắn nhãn, chọn Label , trong ô Label with, chọn trường muốn gắn nhãn (ví dụ: ten). - Chỉnh kiểu chữ thành tiếng Việt, chữ hoa, cỡ chữ 5; đánh dấu chọn vào ô Halo trong phần Background. - Làm xong chọn OK hai lần, các nhãn được hiển thị trên bản đồ. Sau khi các nhãn đã hiện lên, cần kiểm tra và chỉnh sửa vị trí các nhãn nếu cần thiết. Để chỉnh vị trí một nhãn, nhắp chuột đúp vào nhãn đó, hộp thoại Label Options mở ra và ta thực hiện các điều chỉnh cần thiết. Bài tập ứng dụng Bài tập 9. Gắn nhãn cho đối tượng - Hãy gắn nhãn tên hành chính cho lớp hành chính vùng bản đồ hành chính Thừa Thiên Huế đã thiết lập (đối với các đối tượng đã nhập dữ liệu thuộc tính). - Mở rộng: Sử dụng trình của MapBasic chuyển đổi các label thành các text trên bản đồ (?) 1.1.4. Tạo chú giải Chú giải trên bản đồ ta có thể tạo bằng phương pháp thủ công hay tự động. Tạo chú giải bằng phương pháp thủ công bằng cách tạo các đối tượng chữ, đường, vùng, điểm bằng cách công cụ tạo đối tượng trên thanh công cụ Main. Tạo chú giải bằng phương pháp tự động được tiến hành như sau. - Từ menu chính chọn Map > Create Legend. Hộp thoại Create Legend - Step 1 of 3 mở ra. + Ô Legend Frames liệt kê tất cả các lớp bản đồ đang được mở và có thể làm chú giải. + Ô Layers liệt kê tất cả các lớp bản đồ không làm chú giải. ________________________________________________________________________ 16 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  17. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ Để thêm hay bớt các lớp làm chú giải, ta chọn nút Add hay Remove. Có thể chỉnh thứ tự chú giải bằng cách chọn một lớp rồi nhấn nút Up hay Down để di chuyển lớp được chọn lên hay xuống. Nên xếp các chú giải cùng kiểu chung với nhau, và cái nào quan trọng nên xếp trước. Chọn Next. Hộp thoại Create Legend - Step 2 of 3 mở ra. + Điều chỉnh phần Legend Properties:  Window Title cho phép ta đặt tên cho cửa sổ chú giải.  Scroll Bars hiển thị thanh cuộn ngang và đứng trên cửa sổ chú giải.  Portrait hiển thị chú giải theo kiểu đứng.  Landscape hiển thị chú giải theo kiểu ngang. + Điều chỉnh trong phần Legend Frame Defaults:  Title Pattern để chỉnh kiểu chữ cho tiêu đề của chú giải. Chọn nút Aa, hộp thoại Text Style mở ra, chỉnh kiểu chữ.  Style Name Pattern chỉnh kiểu chữ cho nội dung chú giải, hộp thoại Text Style mở ra, chỉnh kiểu. + Subtitle Pattern (tiêu đề phụ) có thể có hoặc không. + Border Style: Điều chỉnh kiểu đường viền cho khung chú giải, hộp thoại Line Style mở ra, chọn kiểu đường. - Thực hiện xong các mục trên chọn Next. Hộp thoại Create Legend - Step 3 of 3 mở ra. ________________________________________________________________________ 17 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  18. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ + Legend Frames liệt kê danh sách các lớp đã được chọn trong bước 1. Khi nhắp chuột chọn một lớp nào đó thì ta có thể điều chỉnh chú giải cho lớp đó ở các nội dung bên phải. + Ô Title: Đặt tên tiêu đề chú giải, chú ý gõ tiếng Việt cho đúng. + Ô Subtiles: Đặt tên tiêu đề chú giải phụ. Giữ nguyên tuỳ chọn Unique Map Styles trong phần Styles from. + Ô Label Styles with: Chọn trường để dán nhãn cho kiểu. Trong trường hợp muốn tạo ra chú giải mới, chọn Expression rồi chọn OK. Làm tương tự đối với các lớp khác. Tuy nhiên ở mục tittle ta chỉ sử dụng chữ “CHÚ GIẢI” của lớp đầu tiên làm tiêu đề chung - Nhắp chuột chọn Finish để kết thúc. Ta thấy chú giải được tạo thành trong một cửa sổ có tên là CHU GIAI. - Để điều chỉnh lại nội dung của chú giải, click doup vào đối tượng cần hiệu chỉnh hoặc từ menu chính chọn Legend > Properties. Hộp thoại Legend Frame Properties của lớp thanh_pho mở ra. ________________________________________________________________________ 18 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  19. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ + Trong ô Styles: Thể hiện các biểu tượng và chú giải mặc định. Click chọn nội dung muốn hiệu chỉnh và sửa tại ô Edit selected text here ở phía dưới. + Tương tự như vậy lần lượt nhắp chuột vào các biểu tượng và các chú giải mặc định còn lại để sửa lại nội dung chú giải + Làm xong chọn OK. Bài tập ứng dụng Bài tập 10. Tạo chú giải - Tạo chú giải tự động cho bản đồ - Tạo chú giải thủ công cho bản đồ - So sánh hai cách thức tạo chú giải tr ên 1.1.5. Làm lưới tọa độ Để làm lưới toạ độ, ta phải sử dụng một trong những tính năng mở rộng của MapInfo, đó là chương trình MapBasic. a. Cách làm lưới toạ độ - Chọn Tools > Run MapBasic Program; theo mặc định, MapInfo sẽ mở thư mục Tools ra và liệt kê danh sách các trình MapBasic. - Chọn GRIDMAKR rồi chọn Open. Nút lệnh Create Grid được thêm vào thành công cụ Tools. Ngoài ra nếu ta mở menu Tools, trên menu này có thêm dòng lệnh Grid Maker (tạo lưới). Nhắp chuột chọn nút này. - Khi di chuyển chuột trở lại cửa sổ bản đồ, con trỏ chuột biến thành hình dấu cộng. Ta giữ nút chuột trái và rê chuột theo đường chéo qua vùng ta muốn làm lưới tọa độ, hộp thoại Grid Maker (Version 1.3) mở ra. ________________________________________________________________________ 19 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
  20. Sưu tâm và thiết kế bởi Đỗ Thị Việt Hương ___________________________________________________________________________ + Phần Extents: Liệt kê bốn cận ranh giới của vùng ta rê chuột, có thể thay đổi các giá trị trong ô này nếu muốn. Ô Round Extents: Làm tròn các giá trị giá trị các cận của vùng rê chuột. + Phần Object Types:  Ô Straight Polylines: Tạo lưới dạng các đường, trên đó có thể thể hiện toạ độ của chúng.  Ô Closed Regions: Tạo lưới dạng các vùng là các ô vuông và ta không có toạ độ của các đường lưới mà các ô vuông đó được đánh số thứ tự theo kiểu A1, B1,...). + Phần Objects Styles: Điều chỉnh kiểu đường cho lưới tọa độ. + Phần Spacing between lines: Xác định khoảng cách giữa hai đường lưới toạ độ liền nhau, đơn vị tính có thể bằng độ (degrees), feet hay mét; giả sử ta chọn degrees và nạp giá trị là 1 (độ). + Phần Smoothness: Quy định số nốt trên một đoạn của một đường lưới toạ độ nằm giữa hai đường lưới toạ độ liền nhau vuông góc với nó. Giá trị mặc định là 4 nốt. + Phần New Table hiển thị vị trí thư mục để lưu lưới toạ độ bằng cách chọn nút Browse. + Nút Projection: Chọn hệ quy chiếu cho lưới toạ độ. Nếu không thay đổi gì thì hệ quy chiếu được sử dụng sẽ là hệ quy chiếu của cửa sổ bản đồ hiện hành được vẽ lưới toạ độ. Xong chọn OK. - MapInfo sẽ tự động tính toán số ô lưới toạ độ sẽ được vẽ cách đều nhau một giá trị do ta nạp vào ô Spacing between lines và hiển thị một hộp thoại hỏi ta có ưng ý số ô lưới to ạ độ đó hay không. Nếu ưng ý với số lượng ô lưới tọa độ thì ta chọn OK, nếu không ta có thể chọn Cancel để nạp lại giá trị trong ô Spacing between lines. - Trên cửa sổ bản đồ sẽ xuất hiện một lưới toạ độ. Ta đặt tên cho bảng này và nhấn nút Save để lưu lại lưới toạ độ mới tạo thành. Bảng dữ liệu của lớp này bao gồm hai cột, một cột có tên là Degrees, cột kia là DMS. Ý nghĩa của hai cột này như sau: - Cột Degrees: Toạ độ của các đường lưới toạ độ được nạp vào và tính bằng độ thập phân, tuy nhiên trong trường hợp này vì khoảng cách ta nạp trong ô Spacing between lines là 1 (độ) nên toạ độ trong cột này không có số lẻ. - Cột DMS: Toạ độ của các đường lưới toạ độ được tính bằng Độ - Phút - Giây (Degree - Minute - Second). ________________________________________________________________________ 20 Khoa Địa lý - Địa chất - Trường Đại học Khoa học - Đại học Huế
Đồng bộ tài khoản