HƯỚNG DẪN SỬ DỤNG NHANH VISUAL C++ 6.0

Chia sẻ: Xuan Khuong | Ngày: | Loại File: PDF | Số trang:5

4
3.464
lượt xem
489
download

HƯỚNG DẪN SỬ DỤNG NHANH VISUAL C++ 6.0

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Visual C++ 6.0 là phần mềm lập trình cho ngôn ngữ C++ với nhiều tính năng và hổ trợ tốt. Trong phần thực hành này, chúng ta chỉ dùng nó để lập trình các ứng dụng không phải trên nền Windows (chỉ dùng Win32 Console Application). Các tính năng và những hổ trợ khác sinh viên tự nghiên cứu và ứng dụng trong công việc sau này.

Chủ đề:
Lưu

Nội dung Text: HƯỚNG DẪN SỬ DỤNG NHANH VISUAL C++ 6.0

  1. Thực hành môn: Cấu trúc dữ liệu & Giải thuật HƯỚNG DẪN SỬ DỤNG NHANH VISUAL C++ 6.0 I. Giới thiệu: Visual C++ 6.0 là phần mềm lập trình cho ngôn ngữ C++ với nhiều tính năng và hổ trợ tốt. Trong phần thực hành này, chúng ta chỉ dùng nó để lập trình các ứng dụng không phải trên nền Windows (chỉ dùng Win32 Console Application). Các tính năng và những hổ trợ khác sinh viên tự nghiên cứu và ứng dụng trong công việc sau này. Một project trong VC++ chỉ dùng để lập trình cho một ứng dụng duy nhất. Để làm ví dụ thì ta có thể tạo ra nhiều project khác nhau cho những ví dụ khác nhau, hoặc đơn giản là sửa đổi đoạn chương trình trong hàm main. Cửa sổ workspace. (View -> Workspace) Vùng soạn thảo. Cửa sổ output. (View -> Output) Hình 1. Giao diện Visual C++ 6.0 II. Các bước tạo ra một project đơn giản - Bước 1: Tạo một project đơn giản o Chọn File -> New, chọn tab Project (hình 2) o Chọn Win32 Console Application o Gõ tên của project muốn tạo vào mục Project name o Chọn thư mục cần lưu trữ trong mục Location. Chú ý, sau khi chọn thư mục xong thì phần mềm tự động thêm tên của project vào để thành tên đầy đủ của thư mục chứa project này. Toàn bộ các tập tin của project này đều nằm trong thư mục đã chỉ ra. o Nhấn nút OK o Một hội thoại khác xuất hiện (Win32 Console Application – Step 1 of 1) để giúp ta tạo ra một project bước ban đầu. Để cho đơn giản ta chọn An empty project (hình 3). o Nhấn nút Finish để tạo ra một project rỗng. - Bước 2: Tạo một tập tin header MyFirst.h o Chọn File -> New, chọn tab Files (hình 4) o Chọn C/C++ Header Files GV: Bùi Hoài Thắng 09/2003
  2. Thực hành môn: Cấu trúc dữ liệu & Giải thuật o Gõ tên tập tin với phần mở rộng là .h vào mục File name. Chú ý rằng dấu đánh dấu ở mục Add to project cho biết là tập tin mới tạo này sẽ được thêm vào trong project có tên được hiển thị lên đó. Nếu tên project mà khác thì phải chọn lại trong danh sách. o Chú ý đến mục Location để đảm bảo là tập tin mới tạo ra cũng sẽ ở trong cùng thư mục với project vừa tạo ra. o Nhấn nút OK và bắt đầu soạn thảo - Bước 3: Tạo một tập tin nguồn MyFirst.cpp o Chọn File -> New, chọn tab Files (hình 5) o Chọn C/C++ Source Files o Gõ tên tập tin với phần mở rộng là .cpp vào mục File name. o Nhấn OK và bắt đầu soạn thảo. - Bước 4: Tạo tập tin nguồn dùng thực thi MyMain.cpp o Tạo một tập tin nguồn o Soạn thảo hàm chính của chương trình là main - Bước 5: Thực thi chương trình o Chọn Build -> Build first_project.exe o Chọn Build -> Execute first_project.exe o Chú ý là tên của project đang tạo ra sẽ được thay thế vào các chữ in nghiêng ở trên Hình 3. Chọn kiểu project cho Win32 Console Hình 2. Tạo một project mới Application Hình 5. Tạo một tập tin nguồn Hình 4. Tạo một tập tin header GV: Bùi Hoài Thắng 09/2003
  3. Thực hành môn: Cấu trúc dữ liệu & Giải thuật III. Ví dụ về một project đơn giản: - Tạo ra một project đơn giản tên là Vidu - Tạo một tập tin header tên là MyUtility.h với nội dung như sau: //file MyUtility.h #ifndef _MYUTILITY_H_ //dde^? tra’nh bị lo^~i redefination #define _MYUTILITY_H_ #include //du`ng cho ca’c le^.nh cout, cin #include //du`ng cho ca’c ha`m tolower enum Error_code {success, overflow, underflow}; typedef int my_type; #endif - Tạo một tập tin header tên là MyClass.h với nội dung như sau: //file MyClass.h #ifndef _MYCLASS_H_ //dde^? tra’nh bị lo^~i redefination #define _MYCLASS_H_ class MyClass { public: MyClass(); my_type input(const int &); my_type output(int &); private: int data; }; #endif - Tạo một tập tin source tên là MyClass.cpp với nội dung như sau: //file MyClass.cpp #include "MyUtility.h" //dde^? du`ng ca’c khai ba’o chung #include "MyClass.h" //dde^? du`ng ca’c khai ba’o cu?a MyClass MyClass::MyClass() { cout
  4. Thực hành môn: Cấu trúc dữ liệu & Giải thuật //file Vidu.cpp #include "MyUtility.h" //dde^? du`ng ca’c khai ba’o chung #include "MyClass.h" //dde^? du`ng ca’c khai ba’o cu?a MyClass int main() { MyClass obj; int x; cout x; obj.input(x); cout x; cout
  5. Thực hành môn: Cấu trúc dữ liệu & Giải thuật Nguồn: Internet. Search, download tại http://www.cse.hcmut.edu.vn/~thang, ngày 06/08/2009. ********************************************************************** http://ngoclinhson.violet.vn, http://ngoclinhson.tk - website đang xây dựng, cập nhật: + Văn bản thiết yếu về Giáo dục và Đào tạo; + Tài liệu về Quản lý Giáo dục và các hoạt động giáo dục; + Tài liệu về Tin học, công nghệ thông tin; + Giáo trình, giáo án, đề thi/kiểm tra (và đáp án); + Tài liệu và phần mềm cá nhân có được về mọi lĩnh vực; (Một số chuyên mục, nội dung trước tiên ưu tiên khối THPT). Các tài liệu đã upload có thể được chỉnh sửa, bổ sung theo thời gian, có thể thay thế bằng một tài liệu khác giá trị hơn; sẽ bị xóa đi nếu phát hiện thiếu chính xác hoặc không có giá trị. Do đó, tại một địa chỉ, cùng một tiêu đề có thể download được tài liệu khác hoặc mới hơn. Ban quản trị cố gắng cung cấp kèm theo nguồn gốc tài liệu một cách đầy đủ nhất, đặc biệt là về tác giả, thời gian tài liệu, thời gian upload hay cung cấp... Ban quản trị ưu tiên tài liệu dạng văn bản (word). Các tài liệu sẽ được chuyển mã Unicode và chuẩn hóa văn bản trong điều kiện cho phép. Yêu cầu cao quả thực quá sức của một website cá nhân do đó không tránh khỏi sai sót, rất mong sự đóng góp chia sẻ, quản trị website rất trân trọng và cảm ơn sự ủng hộ của quý thầy cô và các bạn. ********************************************************************** GV: Bùi Hoài Thắng 09/2003
Đồng bộ tài khoản