Hướng dẫn sử dụng Vietkey Linux 2.4 (P2)

Chia sẻ: Tuyen Thon | Ngày: | Loại File: PDF | Số trang:20

0
310
lượt xem
23
download

Hướng dẫn sử dụng Vietkey Linux 2.4 (P2)

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Thanh tiêu đề Thanh tiêu đề chứa tên của cửa sổ có thể nhấn đúp và để thu nhỏ nó lại. Sử dụng nút chuột phải: Menu cửa sổ sẽ xuất hiện, cho phép bạn thu lại, thành biểu tượng, di chuyển, thay đổi kích thước, bóc dán cửa sổ, để di chuyển nó đến các màn hình khác (nó làm việc nhanh hơn phương pháp của nút dính). Khi chương trình không phản ứng gì nữa, bạn có thể đóng (một số trường hợp nó cho bạn ghi lại các công việc đã làm). Iconify, phóng to và Nút...

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn sử dụng Vietkey Linux 2.4 (P2)

  1. Hướng dẫn sử dụng Vietkey Linux 2.4 Thanh tiêu đề Thanh tiêu đề chứa tên của cửa sổ có thể nhấn đúp và để thu nhỏ nó lại. Sử dụng nút chuột phải: Menu cửa sổ sẽ xuất hiện, cho phép bạn thu lại, thành biểu tượng, di chuyển, thay đổi kích thước, bóc dán cửa sổ, để di chuyển nó đến các màn hình khác (nó làm việc nhanh hơn phương pháp của nút dính). Khi chương trình không phản ứng gì nữa, bạn có thể đóng (một số trường hợp nó cho bạn ghi lại các công việc đã làm). Iconify, phóng to và Nút đóng Phía phải của thanh tiêu đề, có các nút có thể cũng được sử dụng để iconify hoặc phóng to cửa sổ (nó nhanh hơn việc sử dụng menu quản lý cửa sổ). Các cửa sổ được iconify có thể gọi lại với một lần nhấn vào taskbar. Ở phía cuối bên trái của thanh tiêu đề (với kiểu trang trí màn hình ngầm định) là một nút để đóng cửa sổ. Để di chuyển cửa sổ, hãy đặt con trỏ vào thanh tiêu đề và giữ nút chuột trái. Không nhả nút chuột, di chuyển cửa sổ đến vị trí bạn chọn, sau đó thả nút chuột. Nếu bạn muốn thay đổi kích thước cửa sổ, di chuyển con trỏ chuột đến viền cửa sổ bạn muốn thay đổi. Khi bạn đã đến điểm chính xác, con trỏ chuột sẽ thay đổi từ mũi tên sẽ thành mũi tên hai chiều. Giữ chuột trái và kéo đến vị trí bạn muốn, sau đó thả nút chuột. Chú ý rằng bạn kéo cạnh hoặc góc (cái sẽ điều chỉnh cả chiểu ngang và chiều dọc một lần.) Sử dụng thanh menu của mỗi cửa sổ KDE rất đơn giản. Chỉ nhấn vào cái bạn muốn, và nó sẽ được thực hiện. Phía dưới thanh menu, có một tập các biểu tượng công cụ bạn có thể thực hiện các lệnh. Bất cứ khi nào bạn di chuyển qua chúng, một hình kích hoạt sẽ được thay vào. Nhưng thanh menu có thể mà nhiều hơn cho bạn. Có thấy những hình kẻ xọc trên phía trái thanh menu và thanh menu và biểu tượng? Chán nản với việc nhấn nút chuột phải và một menu ngữ cảnh Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 31
  2. Hướng dẫn sử dụng Vietkey Linux 2.4 sẽ xuất hiện, cho phép bạn đặt thanh menu lên đỉnh , trái, phải, hoặc đáy của cửa sổ. Bạn cũng có thể ẩn thanh menu bả bằng Flat Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 32
  3. Hướng dẫn sử dụng Vietkey Linux 2.4 Gọi trợ giúp Trợ giúp có sẵn ở mọi nơi: Trên màn hình, chỉ cần nhấn nút chuột phải và chọn Trợ giúp trên màn hình . Trên KDE panel, mở menu ứng dụng và chọn Trợ giúp. Mọi chương trình KDE có một menu trợ giúp. Tất cả các trợ giúp dựa trên HTML, do đó bạn sử dụng hệ thống trợ giúp dễ như bạn dùng trình quyệt Web ưa thích! Bắt đầu Đến nối, bạn có thể nghĩ là KDE là nhỏ hơn các trình quản lý file khác. Hãy thư giãn, và đọc chương này, và chúng tôi sẽ giới thiệu với bạn một vài đặc trưng mà cam đoan với bạn là KDE rất nhiều chức năng hơn trình quản lý màn hình - nó là môi trường đầy đủ. Sửa file Khi bạn chưa có các ứng dụng KDE được cài vào hệ thống, bạn chắc đã hiểu việc soạn thảo một file cấu hình ASCII. Nhưng thực tế còn rất nhiều kiểu file cần soạn thảo theo cách này. Ví dụ, file nguồn XML™ cho tài liệu này được viết theo ASCII, cũng như mã nguồn của các chương trình KDE. Chúng tôi sẽ chỉ cho bạn cách sử dụng KWrite trong KDE để soạn thảo file ASCII của bạn. Mở một Cửa sổ chứa thư mục Home của bạn Nhấn vào nút khởi động ứng dụng và chọn Thư mục Home. Một cửa sổ hiển thị nội dung của thư mục Home sẽ hiện ra. Để thấy danh sách chi tiết hơn về các file trong thư mục gốc, chọn Hiện các file ẩn trong menu Hiển thị. Bên phía tay trái của cửa sổ, một cây hệ thống file xuất hiện, trong khi bên phía tay phải, bạn có thể thấy mỗi file của thư mục Home, bao gồm bấy kỳ một ‘file ẩn ’ nào, các file — hoặc thư mục. Màn hình quản lý file Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 33
  4. Hướng dẫn sử dụng Vietkey Linux 2.4 Chúng tôi đã cố gắng để trình quản lý file dễ dùng hết mức, và nếu bạn biết một trình quản lý cửa sổ khác (bao gồm cả cho các hệ điều hành khác) kết hợp với trình quản lý file, nhiều khái niệm sau có thể đã quen thuộc với bạn. Trên đỉnh, có một menu Vị trí chứa chức năng để mở và đóng cửa sổ quản lý files. Bạn có thể đồng thời in nội dung hiện tại. Chú ý Muốn xem trên Internet? Có một vài đường dẫn bạn có thể lấy. Bạn có thể chọn Vị trí->Mở địa chỉ (hoặc gõ Ctrl-O) và nhập vào một URL. Cách đơn giản nhất, là cách gõ địa chỉ bạn muốn vào thanh vị trí. Ví dụ, nếu bạn muốn thăm trang chủ KDE , nhập vào http://www.kde.org. Bạn cũng có thể truyền file nhanh qua FTP sử dụng phương pháp này. KDE là “sẵn sàng với Internet”, có nghĩa là bạn có thể tải về và ghi lại file không chitrên đĩa cứng của bạn, mà cả trên máy chủ FTP từ xa mà bạn có quyền truy nhập. Trong khi các hệ điều hành khác tạo khoảng cách khác biệt giữa hệ thống file cực bộ và hệ thống file từ xa, nhưng KDE thì không. Menu Soạn thảo cung cấp các chức năng, sao chép và di chuyển các file. Chúng ta sẽ sử dụng chúng sau. Đã dùng menu Xem, bạn hẳn đã nhìn thấy bạn có thể hiển thị theo nhiều cách khác nhau. Chỉ cần thử các lựa chọn khác nhau và xem hiệu ứng của nó.Bạn sẽ dễ dàng thấy rằng Bookmarks rất hữu dụng: Bây giờ bạn có thể ghi nhớ các liên kết, trên máy cục bộ hoặc nơi nào đó trên mạng. Tính trong suốt mạng của KDE làm việc với cả hai cách, cho phép bạn coi các thư mục trên máy cục bộ như là các bookmarks trên mạng internet. Menu Công cụ giúp bạn tìm các file rõ ràng tôi đã để ở đâu đó mà tôi không nhớ. Duyệt qua các thư mục Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 34
  5. Hướng dẫn sử dụng Vietkey Linux 2.4 Chúng tôi sẽ lấy một trong các file cấu hình và soạn thảo nó. Trước hết, chúng ta phải thay đổi thư mục trong Trình quản lý File. Konqueror bắt đầu với thư mục Home làm đỉnh ‘cây’. Với hầu hết các công việc hàng ngày, nó là nơi bạn muốn làm việc, do đó nó được đặt làm ngầm định. Đôi khi bạn cần có hình ảnh rộng hơn về hệ thống file, phần còn lại của hệ thống cũng không xa đó lắm. Bạn có thể hiển thị nhanh / hoặc ‘root’ theo một số cách: nhấn vào nút nhỏ folder bên cạnh thanh duyệt để chuyển sang cây của hệ thống file đầy đủ, sử dụng mũi tên Lên trên Thanh công cụ ở trên để chuyển lên đỉnh hệ thống file trên thanh bên phải, hoặc gõ vào / trên thanh vị trí. Để theo các hướng dẫn này, nhấn vào nút nhỏ màu xanh bên cạnh thanh duyệt, thanh duyệt sẽ chuyển thành hiển thị hệ thống file đầy đủ. Chú ý rằng phần của cây được mở rộng, và thư mục Home của bạn vẫn được chọn. Bây giờ bạn có thể thấy thư mục Home của bạn nằm trong cây phân cấp thư mục, và các file trong thư mục Home của bạn vẫn hiển thị ở bảng bên tay phải. Cuộn bảng duyệt bên tay trái xuống cho đến khi bạn thấy thư mục /etc. Nhấn đúp chuột vào etc. Bạn sẽ thấy một danh sách dài của các file bên cửa sổ bên phải. Mở một file Một vài file bạn thấy ở đây là trái tim của hệ điều hành, do đó khi sửa đổi chúng bạn cần phải là root hoặc superuser. Chúng ta đang thực hành trên một file mà nó không ảnh hưởng gì nếu có lỗi, tên là motd. Cuộn xuống dưới cho tới khi bạn thấy file motd và nhấn nút chuột phải. Trong menu ngữ cảnh, chọn Mở với. Một menu xuất hiện. Chọn KWrite. Có nhiều cách để mở một file, và đây chỉ là một trong chúng. KWrite là trình soạn thảo với một giao diện đơn giản. Bạn có thể cũng có thể duyệt Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 35
  6. Hướng dẫn sử dụng Vietkey Linux 2.4 xuống dưới vào phần Soạn thảo , và chọn trình soạn thảo khác, hoặc đơn giản chỉ mở file đó bằng trình soạn thảo ngầm định. Đến lúc đó, bạn có file /etc/motd được mở trong KWrite và chúng ta sẵn sàng để soạn thảo. Màn hình soạn thảo Khi bạn càng làm việc nhiều với KDE, bạn sẽ càng nhận ra rằng hầu hết các giao diện của các ứng dụng là như nhau menu File KWrite là một ví dụ sinh động nhất. Hầu hết mọi chương trình KDE có cùng menu, cho phép bạn tạo file mới, mở file cũ trong hệ thống file hoặc (sắp tới sẽ có) thậm chí cả trên Web, ghi chúng lại (cũng sắp có trên Web!), in ra hoặc gửi chúng đi qua thư điện tử. Menu soạn thảo cũng có thể tìm thấy trong hầu hết các ứng dụng KDE cho phép bạn cắt dán các thông tin giữa các chương trình. Bạn cũng có thể tìm kiếm và thay thế văn bản. Sử dụng menu Thiết lập, bạn có thể tuỳ chọn trình soạn thảo theo nhiều cách khác nhau. Ví dụ, bạn có thể tăng kích thước font để hợp với độ phân giải của bạn - và mắt của bạn. Tất nhiên, như các ứng dụng KDE khác bạn có thể tìm thấy một menu Trợ giúp, cung cấp cho bạn trợ giúp trực tuyến bất kỳ khi nào bạn cần. Sử dụng trình soạn thảo Hầu hết nội dung file motd chứa những thứ vô nghĩa như ‘Do not forget to back up your data’ hoặc ‘Do not annoy the system manager’. Hãy đổi thay đổi văn bản mà người sử dụng đăng nhập vào lấy các thông tin thực sự quan trọng. Bạn có thể duyệt qua văn bản sử dụng mũi tên, và các phần đánh dấu Shift-Mũi tên hoặc sử dụng chuột với nút trái được nhấn. Sử dụng Menu Soạn thảo để cắt và dán văn bản. Nhập bất kỳ bạn muốn, hoặc sử dụng các ví dụ sau: Ghi lại công việc của bạn Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 36
  7. Hướng dẫn sử dụng Vietkey Linux 2.4 Bây giờ bạn đã sửa file motd, đã đến lúc phải ghi lại file. Để ghi, bạn có thể sử dụng Menu File, hoặc bạn có thể sử dụng biểu tượng Ghi trên Thanh công cụ. Bạn cần phải có quyền root ghi thay đổi lên file. KDE quản lý việc này bằng cách hỏi mật khẩu root. Nếu bạn không muốn ghi lại file, bạn có thể nhấn nút Hủy bỏ trong hộp thoại mật khẩu và Hủy bỏ trong hộp thoại ghi. Cuối cùng, kết thúc công việc của bạn bằng cách đóng trình soạn thảo và trình quản lý cửa sổ. Bạn có thể làm việc này bằng cách nhấn nút X phía trên bên trái của thanh tiêu đề, bằng cách sử dụng menu cửa sổ trên Thanh công cụ, hoặc chọn File->Thoát. Đơn giản và dễ hiểu, phải không bạn? Tạo file mới Giống như mọi thứ trong KDE, có vài cách để tạo một file mới. Bạn có thể mở trình quản lý file, nhấn chuột phải vào một chỗ trống, và chọn Tạo mới->Text File.... Một file rỗng mới sẽ xuất hiện, bạn có thể mở giống như các file khác. Bạn có thể làm ngay trên màn hình nền. Cách thông thường hơn là khi bạn đang ở sẵn trong ứng dụng. Hầu hết các ứng dụng KDE cung cấp một menu File->Tạo mới, và một biểu tượng Thanh công cụ để làm việc này. Một tài liệu rỗng mới sẽ xuất hiện và ngay lập tức bạn có thể làm việc với nó. Cả hai cách tiếp cận trên đều có lợi thế, do đó sử dụng một cách thích hợp nhất trong từng thời điểm. Di chuyển các file với tính năng Kéo và Thả Như bạn đã thấy trong các phần trước, làm việc với file dễ như đếm 1- 2-3. Dù sao, khi bạn muốn sao chép và di chyển các file, toàn bộ công việc sao chép di chuyển có thể làm bạn gặp rắc rối. Đừng lo - một thủ tục gọi là “kéo và thả” cho phép bạn sao chép và di chuyển các file rất nhanh và dễ dàng. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 37
  8. Hướng dẫn sử dụng Vietkey Linux 2.4 Mở hai cửa sổ quản lý file Trước khi bạn có thể bắt đầu, bạn sẽ cần phải mở hai cửa sổ quản lý file. Các đơn giản nhất là nhấn vào hình cái bánh xe trên góc phải cửa sổ. Nếu bạn không thấy khung cây thư mục trong cửa sổ mới, hãy kích hoạt nó (Window->Bảng duyệt). Kéo một file từ cửa sổ các một cửa sổ khác Trong cửa sổ đầu tiên, mở file/etc và cuộn cho đến khi bạn thấy file motd chúng ta đã thay đổi ở phần trước. Trong cửa sổ thứ hai, mở thư mục Home của bạn. Nhấn vào file motd. Giữ chuột trái và kéo file của bạn về thư mục Home. Thả nút chuột trái (nó được gọi là thả file). Bạn sẽ có ba lựa chọn: sao chép, di chuyển và liên kết. Liên kết sẽ tạo một liên kết tượng trưng đến file, trong khi sao chép và di chuyển làm chính xác như ý nghĩa của nó. Chọn sao chép. Bạn sẽ có một bản của file motd trong thư mục Home của bạn. Sử dụng dòng lệnh và thiết bị cuối Như mong đợi, bạn đã làm việc với các chương trình KDE cung cấp. Bạn sẽ muốn sử dụng các chương trình UNIX® khác. Có hai cách để chạy chúng: dòng lệnh nhanh. Dòng lệnh nhanh Nhấn Alt+F2 hiện lên một cửa sổ nơi bạn nhấn lệnh vào để chạy. Hãy chú ý là bạn sẽ không thấy các dòng text thông báo của chương trình! Phương pháp này chỉ nên chạy cho các chương trình X Window System® hoặc các chương trình mà chạy không cần nhìn hoặc gõ gì cả. Với các chương trình khác, bạn sẽ cần phải dùng trình đầu cuối. Trình mô phỏng thiết bị đầu cuối UNIX® Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 38
  9. Hướng dẫn sử dụng Vietkey Linux 2.4 Từ menu các ứng dụng, chọn Hệ thống ->Đầu cuối. Một cửa sổ đầu cuối sẽ mở ra. Tại đây bạn có thể sử dụng các lệnh shell UNIX® : ls, cat, less, và các lệnh khác. Sử dụng menu tuỳ chọn, bạn có thể tuỳ chọn trình mô phỏng đầu cuối để thích hợp với bạn. Tìm kiếm file bạn bị mất Mọi người thường mắc phải các vấn đề sau: Bạn khởi động ftp, đăng nhập vào các site lớn như ftp.kde.org và bắt đầu tải xuống các file. Đến cuối buổi rồi và bạn tắt máy sau khi hoàn thành các giao dịch. Sáng hôm sau, bạn mở máy và không biết trong hai thư mục, thì thư mục nào là mới tải về. Sử dụng tiện ích KDE's KFind để tìm các file thật đơn giản. Khởi động KFind Khởi động KFind rất đơn giản: Chọn Tìm kiếm File trong Menu chương trình. KFind sử dụng một giao diện có thể bạn chưa gặp trong KDE: tabs. Khi KFind khởi động, bạn sẽ thấy Tên/Vị trí được chọn. Khi bạn nhấn vào Date Range, nội dung tab thay đổi. Khi bạn đã chạy trình tìm kiếm một lần rồi, hầu hết các biểu tượng trên Thanh công cụ bị cấm. Chúng tôi sẽ thay nó sớm. Tìm kiếm file mà ta nhớ một phần tên của nó Khi bạn biết một phần tên file, tìm kiếm rất dễ. Chọn tab Tên/Vị trí, và nhập vào tên file trong trường Tên. Điều kiện có thể được dùng nếu cần. Như là một ví dụ, gõ *.tar.gz. Ngầm định, việc tìm kiếm sẽ bắt đầu trong thư mục Home, nhưng bạn có thể chọn bất kỳ thư mục nào bằng cách nhấn vào Tìm ở hoặc Duyệt.... Để bắt đầu tìm kiếm, nhấn Tìm kiếm. Sau một lát, một danh mục các file sẽ xuất hiện trong cửa sổ kết quả tìm kiếm. Nếu chúng không xuất hiện, bạn bắt đầu tìm kiếm nhầm thư mục, hoặc gõ sai chính tả trong trường Tên, hoặc không có kết thúc với một đuôi.tar.gz trên máy của bạn. Tìm kiếm một file theo nhiều ràng buộc phức tạp hơn Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 39
  10. Hướng dẫn sử dụng Vietkey Linux 2.4 Có nhiều mục ở đây bạn có thể sử dụng để việc tìm kiếm có giá trị hơn. Bạn càng hiểu nhiều về file, bạn càng có nhiều cơ hội tìm thấy nó hơn. Khoảng ngày Tại đây, bạn có thể xác định là bạn chỉ muốn xem các file mà mới được sửa trong một khoảng thời gian. Bạn có thể xác định rằng bạn chỉ muốn nhìn thấy file được sửa trong một khoảng tháng hoặc ngày nhất định. Của kiểu trong tab Cao cấp. Nếu bạn biết file đó thuộc kiểu xác định (ví dụ một file nén tar/gzip hoặc một ảnh jpeg), bạn có thể cho KFind chỉ tìm loại này thôi. Chứa văn bản trong tab Cao cấp Bạn có thể nhập đoạn văn bản mà trong file phải có. Kích thước là, cũng ở trong tab Cao cấp Nếu bạn biết kích thước file, bạn có thể giới hạn vùng tìm kiếm. KFind có nhiều lựa chọn khác để tinh lọc kết quả tìm kiếm, bạn hãy khám phá hết chúng đi! Sử dụng nhiều màn hình Sử dụng nhiều màn hình giúp bạn tổ chức công việc. Bạn có thể đặt các chương trình trên các màn hình khác nhau, và đặt tên màn hình để bạn biết bạn đang làm gì ở đó. Nó tăng và tối ưu hóa không gian làm việc của bạn. Nó cũng giúp bạn khi bạn duyệt Web thay vì làm việc và ông chủ bước vào. Nhưng tất nhiên nó hiếm khi xảy ra - ít nhất là ở văn phòng tôi làm việc. Bạn có thể chuyển giữa các màn hình bằng cách nhấn vào nút màn hình trên bảng Kicker. Nếu bạn muốn thay đổi tên chúng, bạn có thể nhấn đúp vào chúng. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 40
  11. Hướng dẫn sử dụng Vietkey Linux 2.4 Bạn có thể sử dụng nhiều cửa sổ trên nhiều màn hình. Nếu bạn muốn có một cửa sổ hiện ở mọi màn hình, chỉ cần nhấn vào nút dính ở phía trên trái màn hình. Để chuyển một màn hình sang một cửa sổ khác, nhấn vào thanh tiêu đề bằng nút chuột phải, chọn Đến Màn hình, và chọn màn hình nơi mà bạn muốn cửa sổ chuyển về đó. Thoát khỏi KDE Để thoát khỏi KDE, bạn có thể sử dụng mục Logout trong menu khởi động ứng dụng . Bạn sẽ được hỏi là có thực sự muốn thoát khỏi KDE. Thoát sẽ đóng tất cả các sửa sổ và chuyển bạn về màn hình console. Để biết thêm thông tin về các chương trình ghi lại công việc của bạn khi logout, hãy đọc chú ý khi logout. Tất cả mọi thứ về màn hình của bạn Các bạn càng nhìn thấy nhiều, các bạn càng có thể sử dụng màn hình hiệu quả hơn. KDE cho bạn cơ hội để làm cho màn hình trở thành như bạn muốn, cho phép bạn làm việc nhanh hơn và hữu ích hơn. Thậm chí nó còn cho bạn cơ hội được cảnh báo nếu có một con sói định ăn thịt bạn, (nếu bạn là bà) hoặc báo động cho bạn khi Cô bé quàng khăn đỏ trên đường mang đồ đến cho bạn. Bây giờ nó là dịch vụ. Thư mục Autostart Trước khi tôi khám phá thư mục Autostart, các công việc hàng ngày lúc khởi động của tôi khởi động cùng với KDE bao gồm: chạy KDE, chạy KEdit, chạy Konsole, chạy Netscape®, và chạy Kscd. Nó mất thời gian và tôi có thể dùng nó tốt hơn. Các chương trình KDE vẫn để các chương trình mở ở cuối mỗi phiên làm việc và ghi lại trạng thái của chúng và mở lại như thế ngay sau khi bạn đăng nhập trở lại, nhưng có một vài chương trình (như Netscape®) sẽ không làm được như vậy. Bạn có thể sử dụng thư mục Autostart cho các chương trình này. Để chạy các chương trình khi KDE khởi động, hãy làm các việc sau: Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 41
  12. Hướng dẫn sử dụng Vietkey Linux 2.4 Thủ tục 1. 1. Mở thư mục Autostart.Theo ngầm định thư mục này tại $HOME/.kde/share/autostart 2. Mở một cửa sổ Konqueror và duyệt đến chương trình bạn muốn thêm. Nếu bạn không biết cách làm, nó được mô tả tại the section called “Mở một Cửa sổ chứa thư mục Home của bạn ” 3. Kéo và thả chương trình bạn muốn từ cửa sổ Konqueror sang thư mục autostart. Khi được hỏi, chọn Liên kết để tạo một liên kết thay vì sao chép cả file, là một cách tiết kiệm dung lượng đĩa mà. 4. Lặp lại các bước như trên với các chương trình bạn muốn khởi động cùng KDE. Hãy nhớ, bạn không cần thêm các chương trình KDE, chỉ cần vẫn mở chúng khi logout, và chúng sẽ tự mở ra nếu không có lỗi gì, trong lần tiếp theo bạn đăng nhập vào KDE. 5. Khởi động lại KDE nếu bạn muốn xem chức năng tự khởi động. Chương trình của bạn nên chạy tự động khi KDE được khởi động lại. Nếu bạn muốn thêm gì đó đặc biệt (ví dụ, bạn muốn thấy một trang Web nào đó khi khởi động máy), đọc Sử dụng mẫu. Thủ tục mô tả ở đó làm việc với mọi thư mục, do đó bạn có thể áp dụng chúng cho thư mục Autostart. Thêm chương trình và biểu tượng liên kết vào K menu và Panel của bạn KDE K Menu và Kicker không bị giới hạn lại ngay sau khi cài đặt KDE. Bảng KDE được thiết kế để mở rộng, và có hai cách chính để làm việc này: Thêm một chương trình mới, và thêm biểu tượng liên kết. Thêm mới một mục trên menu Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 42
  13. Hướng dẫn sử dụng Vietkey Linux 2.4 KDE đi kèm với rất nhiều ứng dụng có sẵn trên menu. Phụ thuộc vào bản phân phối hệ điều hành của bạn, nó có thể bao gồm nhiều ứng dụng non-KDE (không xây dựng trên thư viện KDE nhưng chạy được trên đó) . KDE cũng bao gồm một ứng dụng sẽ tìm trên đĩa cứng của bạn để thấy nhiều ứng dụng khác hơn, và thêm chúng vào menu cho bạn. Hãy gõ Alt+F2 và nhập vào Kappfinder để thấy nó hoạt động —. Kappfinder khá thông minh, nhưng nó không biết có bao nhiêu ứng dụng ở đó. Hoặc đơn giản là bạn không buốn có tất cả các ứng dụng trên menu, và chỉ muốn thêm một chương trình thôi. Để thêm một chương trình yêu thích của bạn vào KDE menu, bạn có thể sử dụng Trình soạn thảo Menu KDE. Để chạy nó, sử dụng khởi động ứng dụng và chọn Hệ thống->Soạn thảo menu. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 43
  14. Hướng dẫn sử dụng Vietkey Linux 2.4 Menu hệ thống Một cửa sổ sẽ mở ra và hiển thị các K Menu vào bên trái, và một mục hội thoại menu ở bên phải. Trong ví dụ này, chúng tôi sẽ thêm một mục là Gimp trong menu nhỏ Đồ họa. Nếu bạn đã có mục Gimp ở đó và không muốn thêm một cái nữa, bạn có thể xem qua ví dụ này, nhưng đừng nhấn vào nút Ứng dụng khi bạn làm xong. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 44
  15. Hướng dẫn sử dụng Vietkey Linux 2.4 Thủ tục 2. 1. Duyệt xuống phía dưới cây bên trái xuống mục Đồ họa. 2. Nhấn chuột trái để mở rộng mục này. 3. Nhấn vào biểu tượng có nhãn Mục mới trong thanh công cụ, hoặc chọn File->Mục mới trên menu. 4. Trong hộp thoại hiện ra, nhập vào tên bạn muốn có cho mục mới này. Với ví dụ này, hãy nhập Gimp. Nhấn nút Đồng ý trong hộp thoại. 5. Nhấn vào mục menu Gimp mới được tạo trong menu nhỏ Đồ họa. Hộp thoại bên phải sẽ thay đổi thành gần như là rỗng, ngoại trừ tên bạn đã nhập vào. 6. Điền vào một mục tuỳ chọn Ghi ghú. Bạn có thể muốn thêm vào dòng như Một chương trình xử lý ảnh. Văn bản nhập vào đây sẽ được hiện ra như một tool-tip trong Khởi động ứng dụng 7. Nhập vào trong hộp có nhãn Lệnh, lệnh bạn gõ trong dòng lệnh để gọi chương trình. Trong ví dụ này, nó là Gimp. Bạn có thể cũng muốn nhập vào một tham số dòng lệnh nếu bạn muốn. Bạn có thể sử dụng nó để tạo một mục menu luôn luôn mở một tài liệu hoặc ảnh cố định. Đọc thêm các tài liệu của ứng dụng để biết thêm các tham số dòng lệnh. 8. Nếu bạn muốn một ứng dụng chạy trong một thư mục xác định (ví dụ Gimp bắt đầu mở hộp thoại Tải Ảnh của nó ở một chỗ xác định) nhập nó vào mục Đường dẫn làm việc. Mục này là tuỳ chọn. 9. Nếu bạn muốn thay đổi biểu tượng từ ‘không biết’, nhấn vào biểu tượng sang bên phải hộp thoại, để mở trình chọn biểu tượng chuẩn KDE. 10. Một vài ứng dụng phải chạy trong cửa sổ thiết bị cuối (ví dụ Pine). Nếu trong trường hợp này hãy chọn hộp chọn thích hợp. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 45
  16. Hướng dẫn sử dụng Vietkey Linux 2.4 11. Nếu bạn muốn chạy ứng dụng của bạn dưới một người dùng khác, chọn hộp chọn có nhãn chạy bằng người dùng khác và nhập vào tên người dùng tương ứng. 12. Nếu bạn thoả mãn với mục menu của bạn, nhấn Áp dụng. Nếu bạn muốn bỏ qua, hãy nhấn Xóa. Và đó là tất cả. Bạn bây giờ có thể có một mục menu mới. Các biểu tượng liên kết Mặc dù KDE khá là thuận tiện so với các hệ thống quản lý màn hình trung bình khác của UNIX® , mọi người muốn một giải pháp là chỉ nhấn chuột một lần và chạy ngay một chương trình. Sau đây, bạn sẽ học cách tạo các liên kết và file trên màn hình nền của bạn, nhưng nó cũng có một vài hạn chế: đôi khi màn hình của bạn đầy các cửa sổ, và bạn không thể tìm thấy các biểu tượng trừ phi bạn thu nhỏ hết các cửa sổ lại. Với các chương trình thường được dùng, bạn có thể giảm vấn đề này và tăng tốc độ truy nhập bằng cách tạo một biểu tượng liên kết đến KDE panel. Để tạo một liên kết trên Kicker panel, bạn phải chọn: Kéo và thả, hoặc quan một menu. Thủ tục 3. Thêm một biểu tượng liên kết với menu 1. Trên thanh khởi động ứng dụng và chọn Menu Panel ->Thêm ->Ứng dụng. 2. Bạn sẽ thấy mức cao nhất của khởi động ứng dụng. Đến menu để tìm kiếm mục bạn muốn tạo liên kết, như là Thư mục Home hoặc Konqueror. Nhấn vào chương trình bạn muốn. Một biểu tượng mới sẽ xuất hiện trên panel. Nhấn vào nó, và chương trình sẽ chạy. Thêm một biểu tượng liên kết với kéo và thả còn đơn giản hơn - chỉ cần kéo biểu tượng trưng màn hình, hoặc một cửa sổ Konqueror lên một chỗ trống trên panel. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 46
  17. Hướng dẫn sử dụng Vietkey Linux 2.4 Cái gì xảy ra khi bạn kéo một biểu tượng vào panel phụ thuộc vào kiểu của mục: Nếu bạn kéo một thư mục... Một menu sẽ cho bạn chọn Thêm như là một URL quản lý file hoặc Thêm như là một trình duyệt nhanh. Chọn kiểu thứ nhất sẽ tạo một biểu tượng mở cửa sổ Konqueror, bắt đầu ở thư mục này, trong khi chọn kiểu thứ hai sẽ mở thư mục này như một menu trên Panel. Nếu bạn kéo một liên kết nhanh từ trên màn hình... Nó sẽ được sao chép vào bảng. Nếu bạn kéo một tài liệu... Một liên kết sẽ được tạo trên panel, vẫn giữ nguyên cái cũ. Nhấn vào biểu tượng kết quả sẽ mở tài liệu đó bằng ứng dụng ngầm định. Trong mọi trường hợp, nếu bạn muốn chuyển biểu tượng, nhấn vào nó bằng nút chuột Phải và chọn Di chuyển. Chuyển biểu tượng của bạn đến nơi bạn muốn và nhấn nút chuột trái. Nếu bạn muốn xóa bỏ biểu tượng, nhấn nút chuột phải và chọn Di chuyển. Bạn cũng có thể di chuyển các biểu tượng dùng nút chuột giữa, và kéo nó đến vị trí mới. Tạo một file mới trên màn hình nền Màn hình của bạn có thể là một nơi làm việc hiệu quả. Thậm chí bạn khởi động KDE, bạn có thể thấy toàn bộ các file, thư mục và URL bạn thường sử dụng. Có hai cách để tạo và sửa một file trên màn hình nền của bạn. Trong bất kỳ một ứng dụng nào, bạn có thể ghi lại tài liệu của bạn vào thư mục Desktop trong thư mục Home. Ví dụ, thư mục Home của tôi là /Home/stupiddog, thư mục Desktop là /Home/stupiddog/Desktop. Mọi thứ bạn ghi ở đây đều sẽ hiện lên trên màn hình nền. Nếu bạn muốn di chuyển file có sẵn của bạn đến màn hình nền, cách tốt nhất là sử dụng Konqueror. Mở một cửa sổ quản lý file Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 47
  18. Hướng dẫn sử dụng Vietkey Linux 2.4 và kéo file bạn cần đến màn hình nền. Bạn có thể chọn để sao chép chúng nếu bạn muốn giữ tất cả mọi thứ ở trên màn hình, hoặc bạn có thể tạo một liên kết ảo đến file thực. Mọi thứ bạn thay đổi trên file liên kết sẽ tự động cập nhật vào file gốc. Để có thêm thông tin về kéo & thả và trình quản lý file, hãy xem phần Di chuyển file với kéo & thả. Đặt liên kết lên màn hình của bạn Đặt một file lên màn hình nền của bạn để bạn làm việc nhanh hơn. Dù sao, đôi khi nó cũng đáng giá nếu bạn có thể khởi động KDE với một file thường được sửa đã mở sẵn trong đó. Và bạn thường chán nản với việc duyệt qua danh sách dài vô tận các bookmarks để tìm một trang bạn thường thăm. Thật là hay nếu bạn chỉ cần nhấn chuột vào một biểu tượng nhỏ trên màn hình và các trang sẽ tự động được mở. Sử dụng mẫu Mẫu cung cấp một cơ chế thuận tiện để thực hiện các tác vụ như đã mô tả ở trên. Mẫu cũng có thể sử dụng để kết hợp các phần mở rộng của file với một ứng dụng xác định. Khi một file kết thúc bằng một kiểu đã biết được nhấn đúp, ứng dụng tương ứng với kiểu file này sẽ tự động chạy. Nói ngắn gọn, mẫu giúp bạn làm đa số mọi việc trong KDE. Ví dụ: bạn muốn đặt một biểu tượng để thăm trang Web KDE trên màn hình nền. Thủ tục 4. 1. Nhấn chuột Phải và một vùng trống trên màn hình nền. 2. Chọn Tạo mới->Địa chỉ Internet (URL) trêm menu ngữ cảnh.Một hộp thoại sẽ xuất hiện nơi bạn có thể gõ vào đường dẫn bạn đang tạo liên kết nhanh. 3. Một biểu tượng con sẽ được tạo ra trên màn hình nền. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 48
  19. Hướng dẫn sử dụng Vietkey Linux 2.4 Liên kết nhanh đến Internet của bạn có thể được thay đổi giống như các liên kết khác. Nhấn chuột Phải vào biểu tượng và chọn Thuộc tính, và bạn có thể thay đổi biểu tượng, hoặc tên của liên kết như bạn muốn. Sử dụng kiểu MIME Kiểu MIME rất mạnh. Sử dụng chúng, bạn có thể dễ dàng tuỳ chọn hệ thống của mình như ấn vào một file có kiểu xác định sẽ tự mở ứng dụng đã được kết hợp loại file này. Ví dụ, tất cả các file .mod sẽ được đặt để mở với Noatun, các file .html được mở bởi một cửa sổ Konqueror, và một file core có thể được xem bởi KHexEdit bằng cách đơn giản là nhấn vào file core. Chú ý Mặc dù kiểu MIME rất mạnh, chúng không phải là không có nguy hiểm. Làm việc với kiểu MIME như một người quản trị hệ thống (root) có thể làm hỏng một hệ thống KDE làm cho nó không khởi động được! Trong ví dụ này, bạn sẽ tạo kiểu MIME cá nhân, chỉ liên quan đến bạn. Nó sẽ chỉ có hiệu lực với người dùng khác nếu bạn sao chép chúng hoặc chuyển chúng sang $KDEDIR/share/mimelnk. Để liên kết các kiểu file tới một ứng dụng nhất định: Thủ tục 5 1. Hãy chắc chắn rằng ứng dụng bạn muốn chạy với file này có một mục trên K menu. 2. Trong Konqueror tìm hoặc tạo một file với phần mở rộng bạn muốn liên kết. 3. Nhấn chuột Phải vào file, và chọn Soạn thảo kiểu file trên menu ngữ cảnh, hoặc chọn Soạn thảo->Soạn thảo kiểu file trong menu của Konqueror. Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 49
  20. Hướng dẫn sử dụng Vietkey Linux 2.4 4. Thêm vào ứng dụng bằng cách nhấn nút Thêm, và nhập vào kiểu file bạn muốn. Hãy nhớ rằng UNIX® là phân biệt chữ hoa chữ thường, do đó bạn có thể thêm một vài biến thể ví dụ -*.mp3 có thể cần *.MP3. Thêm bao nhiêu tuỳ ý bạn. 5. Thêm vào một miêu tả nếu bạn muốn. Nó là một chọn lựa. 6. Trong phần có nhãn Thứ tự tham chiếu ứng dụng, nhấn vào nút Thêm. Một bản sao chép nhỏ của menu Khởi động ứng dụng sẽ mở ra, nơi bạn có thể chọn ứng dụng bạn muốn file có kiểu này được mở với nó. 7. Đôi khi, bạn cũng có thể muốn sử dụng các ứng dụng khác nhau để mở kiểu file này. Ví dụ, bạn có thể cũng muốn sử dụng Kate để mở các file văn bản để soạn thảo, và KEdit cho các file bạn chỉ muốn xem qua. Bạn có thể thêm nhiều ứng dụng theo cùng một cách này, và bạn có thể thay đổi thứ tự ưu tiên sử dụng các nút Chuyển lên và Chuyển xuống. 8. Nếu bạn đã thoả mãn với lựa chọn của mình, bạn có thể nhấn vào nút Áp dụng để ghi lại các thay đổi mà không đóng hộp thoại. Nó cho bạn cơ hội kiểm tra trong cửa sổ Konqueror xem các file đã. Bạn có thể chọn Đồng ý để ghi các thay đổi và đóng hộp thoại, hoặc nút Hủy bỏ nếu bạn đã thay đổi ý định và chỉ muốn đóng hộp thoại. Hãy chắc chắn rằng bạn đang thử sự liên kết mới bằng cách mở một thư mục chứa các file bạn đã nhập vào kiểu. Nhấn vào file, và các chương trình cần thiết sẽ được gọi. Chú ý Kiểu MIME là một cách miêu tả nội dung của file. Bạn có thể sử dụng kiểu mở rộng file cho mục đích này, và bạn có thể biết là trong hệ thống UNIX® phần mở rộng của file đôi khi không liên quan nhiều đến nội dung file. Nói cách khác, nó có thể rất quan trọng - ví dụ, một và bản của gunzip không chạy với các file không có phần mở rộng là .gz. Kiểu MIME dùng với các kiểu file, nhưng không cần thiết phần mở rộng - bạn có thể thiết lập bất kỳ mẫu file nào bạn muốn. Ví dụ, nếu bạn luôn muốn mở bất kỳ một file nào với Kate, và bạn tạo một thói quen đặt Copyright (C) 2002, Vietkey Group & Vietkhang JSC Trang 50
Đồng bộ tài khoản