Hướng dẫn tạo và chỉnh sửa báo cáo trong SQL Server Reporting Services

Chia sẻ: robben1357

Tham khảo tài liệu 'hướng dẫn tạo và chỉnh sửa báo cáo trong sql server reporting services', công nghệ thông tin, cơ sở dữ liệu phục vụ nhu cầu học tập, nghiên cứu và làm việc hiệu quả

Bạn đang xem 7 trang mẫu tài liệu này, vui lòng download file gốc để xem toàn bộ.

Nội dung Text: Hướng dẫn tạo và chỉnh sửa báo cáo trong SQL Server Reporting Services

Hướng dẫn tạo và chỉnh sửa báo cáo trong SQL Server
Reporting Services



Bộ sản phẩm SQL Server 2005, 2008 và 2008 R2, tất cả đều
được đóng gói cùng với SQL Server Reporting Services
(SSRS) – giải pháp chuyên dụng tạo báo cáo dành cho các
doanh nghiệp. Với SSRS, người sử dụng có thể tạo, đặt lịch,
đăng tải và quản lý các bản báo cáo khác nhau từ nhiều nguồn
dữ liệu gốc đa dạng. Trong phần sau của bài viết, chúng ta sẽ
cùng nhau tạo, chỉnh sửa và export báo cáo SSRS theo cách thủ
công.

Gán SSRS Report vào Project trong BIDS:

Trước tiên, các bạn cần tham khảo và hoàn thiện những bước
đầu về SSRS tại đây. Để tạo bản báo cáo theo cách bình
thường trong Business Intelligence Development Studio
(BIDS), các bạn làm theo trình tự sau:

Mở BIDS, và chọn File > Open > Project/Solution.

Chỉ đường dẫn tới Report Server Project tạo trước đó.
Trong cửa sổ Solution Explorer, kích chuột phải tại Reports và
chọn Add > New Item.

Chọn Report tại mục Add New Item, đặt tên cho báo cáo (ví dụ
MyReport.rdl) và nhấn OK.

Tại đây, bạn sẽ có bản báo cáo SSRS rỗng, đang mở trong
BIDS:




Tại cửa sổ bên trái, các bạn sẽ thấy thẻ Toolbox và Report
Data. Nếu những thẻ này không hiển thị, hãy lựa chọn những
thẻ tương ứng phù hợp từ menu View. Công cụ Toolbar hiển
thị toàn bộ thành phần trên bản báo cáo như textbox và table,
chức năng Report Data sẽ hiển thị các nguồn dữ liệu, bao gồm
kết quả truy xuất từ gốc, bao gồm các file ảnh, trường dữ liệu
(ví dụ như tham số Page Number).

Thêm Data Source và Dataset vào Project:

Khái niệm data source - nguồn dữ liệu, ở đây sẽ làm nhiệm vụ
nhận dạng cơ sở dữ liệu (hoặc các đối tượng dữ liệu khác, ví dụ
như file XML) từ vị trí bạn dùng để đẩy dữ liệu, các thuộc tính
của giao thức kết nối – tên server và tài khoản, được sử dụng.
Bài hướng dẫn lần này dựa trên nguồn dữ liệu SQL Server đã
tạo trước đó, các bạn hãy làm theo trình tự sau:

Tại thẻ Report Data, chọn New > Data Source và đặt tên cho
dữ liệu gốc này.

Chọn Use shared data source reference

Chọn nguồn cơ sở dữ liệu SQL Server đã tạo trước đó từ menu,
nhấn OK:
Khái niệm dataset ở đây là tập hợp các yêu cầu về dữ liệu,
thông qua các câu lệnh truy vấn, hoặc quá trình lưu trữ, tất cả
đều được bắt đầu từ nguồn dữ liệu, ngoài ra, dataset còn chỉ
định những dữ liệu nào phù hợp để hiển thị trên báo cáo. Để
thêm dataset vào các bản báo cáo, các bạn làm theo bước sau:

Tại thẻ Report Data, chọn New > Dataset và đặt tên cho thành
phần này.

Chọn nguồn cơ sở dữ liệu tại bước trên.

Tại đây, các bạn gõ/paste các câu lệnh mẫu, hoặc đơn giản hơn
là sử dụng tính năng Query Designer. Ví dụ như sau:
SELECT P.Name ,
ProductNumber ,
Color ,
ListPrice ,
SC.Name [Category]
FROM Production.Product P
LEFT OUTER JOIN
Production.ProductSubCategory SC
ON P.ProductSubCategoryID =
SC.ProductSubCategoryID
WHERE ListPrice BETWEEN 0 AND 1000
ORDER BY Category, ListPrice ASC

Sau đó nhấn OK. Khi kết thúc bạn sẽ thấy data set hiển thị
trong các trường dữ liệu tại thẻ Report Data.

Thêm các thành phần dữ liệu khác vào báo cáo:

Sau khi đã khởi tạo thành công dataset, các bạn bắt đầu tạo báo
cáo. Trước tiên là các thuộc tính đơn giản và quen thuộc như
bảng sản phẩm, tiêu đề và số trang.

Kéo thả Table từ thẻ Toolbox vào giao diện chính của báo cáo.

Tại thẻ Report Data, tiếp tục kéo và thả các trường dữ liệu
Category, Color, Product, Name, và List Price như sau:




Làm tương tự như vậy với thành phần Textbox, gõ
AdventureWorks Products.

Tại phần trống của bản báo cáo, các bạn kích chuột phải và
chọn Insert > Page Footer.

Kéo thả textbox vào phần footer này, tại mục Built-In Fields
trên thẻ Report Data, kéo thẻ tiếp thành phần Page Number.

Sử dụng tính năng Preview để xem trước bảng báo cáo với dữ
liệu truyền vào đã chuẩn hay chưa.


Định dạng báo cáo và export:
Đây là bước cuối cùng để hoàn thiện các bản báo cáo, bao gồm
những tính năng tại thẻ Design:

Thêm và xóa các cột: click chuột phải vào bảng và chọn Insert
Column > Left hoặc Right.

Thay đổi độ rộng của cột dữ liệu: kéo và thay đổi phần bên
ngoài.

Thay đổi font và định dạng: chọn các trường dữ liệu tương ứng,
tùy chỉnh hoặc thay đổi theo nhu cầu sử dụng.

Định dạng chuẩn chữ số hiển thị: nhấn chuột phải vào trường
dữ liệu số, chọn Text Box Properties và thay đổi phần Number.

Thay đổi kích cỡ của báo cáo: di chuột và kéo tại các góc để
phóng to hoặc thu nhỏ kích thước.

Để export báo cáo ra các định dạng khác nhau như PDF,
Excel... các bạn làm như sau:

Chọn thẻ Preview

Nhấn nút Export ở phía bên trên:

Sau đó chọn định dạng phù hợp, đường dẫn lưu file và nhấn
Save.
Trên đây là những bước cơ bản để tạo và chỉnh sửa báo cáo
trong SQL Server Reporting Services, ngoài ra các bạn có thể
tham khảo thêm ví dụ tại đây: SQL Server Books Online, SQL
Server Books Online Tutorials, Microsoft Press - Stacia Misner
và CodePlex. Chúc các bạn thành công!
Đề thi vào lớp 10 môn Toán |  Đáp án đề thi tốt nghiệp |  Đề thi Đại học |  Đề thi thử đại học môn Hóa |  Mẫu đơn xin việc |  Bài tiểu luận mẫu |  Ôn thi cao học 2014 |  Nghiên cứu khoa học |  Lập kế hoạch kinh doanh |  Bảng cân đối kế toán |  Đề thi chứng chỉ Tin học |  Tư tưởng Hồ Chí Minh |  Đề thi chứng chỉ Tiếng anh
Theo dõi chúng tôi
Đồng bộ tài khoản