Hướng dẫn thực hành Excel

Chia sẻ: Truong Cong Tri | Ngày: | Loại File: DOC | Số trang:24

5
3.079
lượt xem
1.067
download

Hướng dẫn thực hành Excel

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Cca1 bước hướng dẫn chi tiết về thực hành Excel

Chủ đề:
Lưu

Nội dung Text: Hướng dẫn thực hành Excel

  1. HƯỚNG DẪN THỰC HÀNH I. Thực hành trên Excel 1. Để xử lý số liệu bằng excel, chúng ta cần cài đặt công cụ Analysis Toolpak bằng cách: (1) Lắp dĩa nguồn cài đặt Office gốc vào ổ CD-ROM hoặc ổ DVD. (2) Mở một file Excel bất kỳ (3) Tools -> Add-Ins -> Nhấp vào hộp kiểm chọn Analysis Toolpak -> OK (4) Hộp thoại yêu cầu lắp đĩa Office xuất hiện -> lần lượt nhấp OK theo hướng dẫn cài đặt. 2. Các ứng dụng chính của Analysis Toolpak Tính các trị thống kê mô tả: Đường dẫn: Tools -> Data Analysis -> Descriptive Statistics Ví dụ : Tính các trị thống kê mô tả của GDP trong workbook thuchanh.xls (trong thư mục //gui SV/data) Input range-Nhập số liệu: Input range: Quét vùng giá trị của GDP kể cả nhãn GDP Khai báo: Labels in the first row (Khai báo nhãn GDP là tên biến) Chọn mặc định : Grouped by column Output range-Chọn vùng xuất dữ liệu: ệ Output range: nhấp vào ô đầu tiên mà chúng ta muốn đặt kết quả. ả New worksheet ply: Đưa kết quả ra trang mới có tên mà chúng ta đặt. Nếu không đặt tên thì Excel tự động đặt tên sheet!4 nếu trước đó có sheet!3 . ớ New workbook: Đưa kết quả ra một workbook mới. Chúng ta không cần đến cấp độ này. Chọn trị thống kê cần báo cáo: Summary statistics. 1 / 24
  2. Chúng ta có kết quả như sau: GDP Mean 1270.006 Standard Error 45.74627 Median 1245.75 Mode #N/A Standard Deviation 250.5626 Sample Variance 62781.63 Kurtosis -1.16974 Skewness -0.02911 Range 864.32 Minimum 833.28 Maximum 1697.6 Sum 38100.18 Count 30 Tính ma trận tương quan Đường dẫn: Tools -> Data Analysis -> Correlation Input Range: quét vùng dũ liệu kể cả nhãn Labels in the first row: khai báo nhãn ở hàng thứ nhất chính là tên biến. Grouped by column: trạng thái mặc định Output options: ý nghĩa như thủ tục Descriptive statistics Kết quả ta nhận được ma trận tương quan của GDP và Expenditure như sau: Expenditur GDP e GDP 1 Expenditure 0.997797 1 Ước lượng mô hình hồi quy Đường dẫn: Tools -> Data Analysis ->Regression Input Y Range: Quét dữ liệu biến phụ thuộc Input X Range: Quét dữ liệu biến độc lập 2 / 24
  3. Và thu được kết quả như sau: 3. Vẽ đồ thị Bước 1- Chọn loại đồ thị 3 / 24
  4. Bước 2: Nhập liệu Bước 3: Đặt tên cho đồ thị và các trục 4 / 24
  5. Bước 4: Lưu đồ thị Và có kết quả TÀI LIỆU THAM KHẢO Ban biên dịch First News. EXCEL toàn tập. Nhà Xuất Bản Trẻ-2001. II. Thực hành trên Eviews 5 1. Khởi động Eviews 5 a. Từ Start: Window XP: Start - >All Programs ->Eviews -> Eviews Window 98/2000: Start -> Programs -> Eviews -> Eviews b. Từ biểu tượng của Eviews Một số máy có biểu tượng của Eviews trên màn hình desktop như sau 5 / 24
  6. EViews 5.lnk Nhấp đúp chuột trái vào biểu tượng Eviews 5. 2. Các menu chính của Eviews 5 Anh (Chị) thử tìm hiểu các menu của Eviews bằng cách nhấp chuột vào menu chính để thấy các menu phụ. 3. Mở tập tin làm việc (workfile) đã được lưu trữ từ trước. Hộp thoại mở workfile như sau: 6 / 24
  7. 4. Đóng tập tin File ->Close hoặc nhấp vào biểu tượng Lưu tập tin thành một workfile khác: File -> Save as -> Chọn đường dẫn đặt tên mới. và 5. Mở một workfile mới : File -> New -> Workfile Hộp thoại mở workfile như sau: Cấu trúc của Workfile (workfile structure type) Unstructured/Undated: sử dụng cho loại dữ liệu chéo 7 / 24
  8. Observations: số quan sát của số liệu Dated-regular frequency: sử dụng cho loại dữ liệu chuỗi thời gian Annual: dữ liệu theo năm Semi-annual: dữ liệu theo 6 thng Quarterly: dữ liệu theo quý Monthly: dữ liệu thng Weekly: dữ liệu tuần Daily (5 day week): dữ liệu tuần nhưng chỉ tính ngày làm việc Daily (7 day week): dữ liệu tuần Dữ liệu chuỗi thời gian được nhập theo ngày của quan sát đầu tiên và ngày của quan sát cuối cùng. Balanced Panel: sử dụng cho loại dữ liệu bảng Start date: ngày bắt đầu End date: ngày kết thúc Number of cross sections: số lượng đơn vị kinh tế Names: đặt tên cho workfile 8 / 24
  9. Dữ liệu ở đây là dữ liệu năm nên chúng ta chọn Annual, bắt đầu là 1970, kết thúc là năm 1999. Workfile mới của chúng ta có tên BT1 như sau Workfile này có 2 biến được thiết kế sẵn Resid (residuals) : Phần dư. Khi chúng ta chưa hồi quy thì gi trị của nó là NA (Not available- Không có) C : Số ban đầu là 0. Workfile này đã sẵn sàng cho chúng ta nhập liệu. 6. Nhập số liệu vào Eviews a. Nhập bằng bàn phím Sử dụng workfile BT1 Đầu tiên chúng ta tạo biến. Tạo biến GDP Objects : hộp thoại new object như sau 9 / 24
  10. Chọn đối tượng mới là biến- Type of Object: Series Tên đối tượng là GDP – Name of Object: GDP Chúng ta cũng có thể tạo biến GDP bằng cách vào Generate Lúc này trên cửa sổ của workfile BT1 có biến GDP (gdp là chữ thường dù chúng ta đã viết chữ hoa trong phần đặt biến). Biến GDP chưa có giá trị và để kiểm chứng chúng ta nhấp đúp vào tên biến GDP. 10 / 24
  11. Để nhập số liệu cho biến GDP chúng ta nhấp vào Edit +/- và bắt đầu nhập. Sau khi nhập xong, chúng ta nhấp vào Edit +/- để kết thúc. Chúng ta có thể nhập số liệu cho Expenditure theo cách tương tự. Tuy nhiên, nhập dữ liệu bằng bàn phím trên Eviews là một quá trình bất tiện. Thông thường người ta nhập liệu bằng phần mềm khác, sau đó chuyển dữ liệu sang Eviews. b. Nhập bằng Copy và dán Chúng ta đã có số liệu file thuchanh trên EXCEL. Nhấp đúp biến NSLT -> Edit +/- để dán. Mở tập tin(workbook) thuchanh.XLS của EXCEL. Copy dãy số liệu của biến GDP : sheet1!B2:B31 Chuyển sang workfile BT1 -> Dán (Ctrl+V) vào GDP -> Edit +/- để kết thúc. Làm tương tự với biến Expenditure. c. Nhập dữ liệu từ phần mềm khác từ thủ tục Import Mở tập tin thuchanh.XLS. Ghi chú điểm khởi đầu của dữ liệu: B2. Số biến chúng muốn nhập l : 2 với thứ tự của biến là GDP và Expenditure. 11 / 24
  12. Đóng tập tin thuchanh.XLS vì Eviews chỉ đọc được dữ liệu từ một tập tin Excel đang đóng. Procs -> Import -> Read Text-Lotus-Excel… Hộp thoại tìm tập tin có dữ liệu nguồn như sau: Sau khi nhấp Open chúng ta có hộp thoại nhập liệu như sau 12 / 24
  13. By observations-series in column: Theo quan sát-biến xếp theo cột Điểm bắt đầu : B2 Tên trang dữ liệu: Excel 5+sheet name: sheet1 Tên biến: Name of series…. : GDP Expenditure hoặc đơn giản là nhập số 2 để chỉ 2 biến. Cỡ mẫu: Sample to import : Workfile range. 7. Trị thống kê mô tả Mở workfile BT1.wf1. Mở GDP. Trạng thái mặc định của biến là View/ Spreadsheet. Các tùy chọn khác như sau: View -> Line graph View -> Bar graph 13 / 24
  14. View -> Descriptive statistics -> Histogram and Stats 8. Quan hệ giữa các biến số Nhóm các biến số thành 1 Group. Giữ Ctrl và nhấp lần lượt vào GDP và Expenditure. Nhấp chuột phải, chọn as Group. 14 / 24
  15. Sau khi thành một group, dạng mặc định của group như sau. (View/spreadsheet) Ma trận tương quan: View -> Correlations-> Common Samples Ma trận hiệp phương sai: View -> Covariances -> Common Samples 9. Đồ thị Chúng ta đang làm việc với một group. Để lưu group gồm GDP và Expenditure vừa khảo sát ở trên, ta chọn Name và đặt tên group. Tên được đề nghị là GROUP01 nhưng bạn có thể đặt tên khác. 15 / 24
  16. Chúng ta đang làm việc với GROUP01. Đồ thị: View -> Scatter -> Simple Scatter: Đồ thị phân tán. View -> Scatter -> Simple Scatter: Đồ thị phân tán với đường hồi quy. Giả sử chúng ta chọn Scatter with regression, kết quả hiển thị như sau: Đồ thị này tự động thay đổi khi chúng ta cập nhật số liệu. 10. Lưu lại một bảng tính hay đồ thị : Freeze Lệnh này lưu giữ một bản đồ thị nguyên dạng như lúc chúng ta nhấp vào lệnh Freeze. Khi đó các thay đổi của dữ liệu không tác động lên đồ thị. Bản đồ thị gốc vẫn được giữ nguyên và vẫn cập nhật sự thay đổi của dữ liệu sau này. 16 / 24
  17. GROUP01: Biểu đồ gốc UNTITLED: Biểu đồ bị làm đông. 11. Hồi quy Từ menu Procs của chương trình chính hoặc từ menu Procs của GROUP01: Procs -> Make equation Từ chương trình chính: Quick -> Estimate equation Kết quả hồi quy như sau. 17 / 24
  18. 12. Tạo biến tương tác Để tạo biến tương tác (tích số giữa 1 biến định lượng và 1 biến giả) thì chúng ta vào Genn -> [tên biến tương tác] = [tên biến định lượng] *[tên biến giả] 13. Kiểm định đa cộng tuyến: không có phép kiểm định chính thức 14. Kiểm định phương sai thay đổi Dùng phương pháp đồ thị 18 / 24
  19. Kiểm định White Chúng ta đang làm việc trên Equation: View -> residual Tests -> White Heterokedasticity (cross terms hoặc no cross terms) Chúng ta thu được kết quả như sau: 19 / 24
  20. Dựa vào kết quả trên chúng ta chấp nhận H0 (H0: Phương sai của sai số không đổi). như vậy trong mô hình hồi quy này không tồn tại hiện tượng phương sai thay đổi. 15. Kiểm định tự tương quan: dựa vào giá trị d trong kết quả hồi quy 16. Kiểm định phân phối chuẩn View -> Residual Test -> Histogram-Normality Test Dựa vào kết quả trên chúng ta chấp nhận H0 (H0: ui có phân phối chuẩn) Nếu Anh(Chị) muốn tìm hiểu nhiều ứng dụng khác nữa của Eviews thì hãy nhấp vào: Help 20 / 24
Đồng bộ tài khoản