Kết hợp Flax và Flash trong việc tạo trang Web chủ P3

Chia sẻ: Mr Yo Ko | Ngày: | Loại File: PDF | Số trang:11

0
53
lượt xem
10
download

Kết hợp Flax và Flash trong việc tạo trang Web chủ P3

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tiếp tục, bạn sẽ bắt đầu công việc chính của mình là đưa ba tiêu chí đã tạo trước đó vào vùng trống phía bên phải vòng tròn chữ. Trước tiên, bạn hãy nhập tiêu chí một “Xem thao tác bằng hình ảnh” vào bằng cách chọn Insert New Symbol trên thanh trình đơn hoặc nhấn tổ hợp phím Ctrl + F8. Cửa sổ Symbol Properties xuất hiện. Nhấp chọn mục Movie Clip và tại mục Name hãy đặt tên cho Clip này ‘tieu chi 1’. Chọn xong nhấp nút OK. Bây giờ, cửa sổ làm việc hiện hành của bạn...

Chủ đề:
Lưu

Nội dung Text: Kết hợp Flax và Flash trong việc tạo trang Web chủ P3

  1. KẾT HỢP FLAX 1.5 VÀ FLASH 5 TRONG VIỆC TẠO TRANG WEB CHỦ Tiếp tục, bạn sẽ bắt đầu công việc chính của mình là đưa ba tiêu chí đã tạo trước đó vào vùng trống phía bên phải vòng tròn chữ. Trước tiên, bạn hãy nhập tiêu chí một “Xem thao tác bằng hình ảnh” vào bằng cách chọn Insert > New Symbol trên thanh trình đơn hoặc nhấn tổ hợp phím Ctrl + F8. Cửa sổ Symbol Properties xuất hiện. Nhấp chọn mục Movie Clip và tại mục Name hãy đặt tên cho Clip này ‘tieu chi 1’. Chọn xong nhấp nút OK. Bây giờ, cửa sổ làm việc hiện hành của bạn là trên Clip tieu chi 1. Trên thanh Timeline, bạn hãy đổi tên layer 1 thành tieu chi 1 bằng cách nhấp đúp chuột vào tên layer này. Sau đó nhập file tieu chi 1 đã tạo trong Flax vào bằng cách nhấp chọn File > Import hoặc nhấn tổ hợp phím Ctrl + R. Cửa sổ Import xuất hiện.
  2. Trong cửa sổ này, chọn thư mục lưu trữ file tieu chi 1.swf (file đã lưu trong cửa sổ Flax) trong mục Look in. Nhấp chọn file này (tên file sẽ xuất hiện trong mục File name). Chọn xong, nhấp nút Open. Tiêu chí một “Xem thao tác bằng hình ảnh” xuất hiện trong cửa sổ Clip tieu chi 1. Bạn nhấp chọn Control > Play hoặc nhấn Enter để xem kết quả.
  3. Tiếp tục, chèn thêm một layer vào bằng cách nhấp chọn Insert > Layer hoặc nhấp vào biểu tượng Insert Layer trên cửa sổ Timeline. Một layer mới được chèn vào với tên là Layer 2. Nhấp đúp chuột vào layer này và đổi tên thành tieu chi 11. Tiếp tục, trên layer tieu chi 11 bạn sẽ chèn file tieu chi 11.swf (đã được lưu từ Flax) vào bằng cách nhấp chọn File > Import hoặc nhấn tổ hợp phím Ctrl + R. Cửa sổ Import xuất hiện, bạn hãy chọn file tieu chi 11 sau đó nhấp Open.
  4. Sau khi nhấp chọn Open, trên thanh Timeline của Layer tieu chi 11 xuất hiện một loạt các keyframe. Nhấn phím Enter để xem kết quả diễn hoạt.
  5. Trong khi diễn hoạt Clip tieu chi 1, bạn thấy các keyframe trên hai Layer tieu chi 1 và tieu chi 11 diễn hoạt song song với nhau trông rất rối mắt. Đây không phải là điều mà bạn mong muốn. Tiến hành một số thao tác tiếp theo để nhận được kết quả: Khi diễn hoạt xong tất cả các keyframe trên Layer tieu chi 1 thì mới diễn hoạt đến các keyframe trên Layer tieu chi 11. Trước tiên, trên khung Timeline bạn nhấp chuột vào Layer tieu chi 11 để tiến hành tô đen toàn bộ Layer này. Sau đó nhấp giữ chuột và kéo thanh trượt cho đến khi nhìn thấy keyframe cuối cùng của Layer tieu chi 1. Tiếp tục, đưa chuột đến phần tô đen trên Layer tieu chi 11 cho đến khi con trỏ chuột có hình bàn tay với chữ Static bên dưới. Khi con trỏ chuột có hình bàn tay, bạn hãy nhấn giữ chuột và kéo rê toàn bộ các Frame trên Layer này về phía tay phải sao cho giáp với keyframe cuối cùng trên Layer tieu chi 1 (xem hình minh họa).
  6. Khi thực hiện xong, bạn thả chuột. Kết quả sẽ giống như hình minh họa dưới: Bây giờ, bạn nhấp trở lại keyframe đầu tiên của Layer tieu chi 1 và nhấn phím Enter hoặc nhấp chọn Control > Play từ thanh trình đơn. Lúc này, trong quá trình diễn hoạt, bạn không còn nhận thấy sự trùng lấp của hai Layer này nữa. Trên thanh Timeline, đoạn keyframe từ 1 cho đến 73 là diễn hoạt của Layer tieu chi 1. Và đoạn keyframe từ 74 cho đến 145 là diễn hoạt của Layer tieu chi 11.
  7. Như vậy là bạn đã hoàn tất Movie Clip tieu chi 1. Bước tiếp the, tạo Movie Clip tieu chi 2 để nhập hai file tieu chi 2.swf và tieu chi 21.swf với nội dung “Học nhanh chóng – dễ dàng” vào. Tương tự như với Movie Clip tieu chi 1, nhấp chọn Insert > New Symbol… hoặc nhấn tổ hợp phím Ctrl + F8. Hộp thoại Symbol Properties xuất hiện. Trong mục Name, nhập tên cho Clip này là tieu chi 2. Trong mục Behavior chọn Movie Clip sau đó nhấp OK. Sau khi nhấp chọn OK, trên Movie Clip tieu chi 2 bạn tiến hành các thao tác đổi tên Layer, thêm Layer sau đó nhập (import) file vào. Kết quả thực hiện như sau: Cũng như Movie Clip tieu chi 1, để tránh sự diễn hoạt trùng lấp giữa hai Layer tieu chi 2 và tieu chi 22, bạn hãy tô đen Layer tieu chi 22 sau đó đưa chuột đến vùng frame bị tô đen.
  8. Con trỏ chuột có hình bàn tay, nhấn giữ chuột và kéo rê cho đến khi Frame đầu tiên của Layer tieu chi 21 giáp với Frame cuối cùng của Layer tieu chi 2. Kết quả thực hiện như hình minh họa. Khi thực hiện xong thao tác di chuyển Frame, nhấp trở lại keyframe đầu tiên trên Layer tieu chi 2 và nhấn phím Enter để xem kết quả diễn hoạt. Trên thanh Timeline, đoạn keyframe từ 1 đến 82 là diễn hoạt của Layer tieu chi 2. Và đoạn keyframe từ 83 đến 118 là diễn hoạt của Layer tieu chi 21. Như vậy bạn thực hiện xong Movie Clip tieu chi 2. Bây giờ, hãy thực các bước tương tự như trên để tạo Movie Clip tieu chi 3 với nội dung “Ứng dụng ngay những gì đã học”. Movie Clip này cũng có hai Layer là tieu chi 3 (nhập file tieu chi 3.swf) và tieu chi 31 (nhập file tieu chi 31.swf).
  9. Tương tự như hai Movie Clip trước, hãy thực hiện các thao tác để loại bỏ sự trùng lấp hiệu ứng giữa hai Layer tieu chi 3 và tieu chi 31 trên Movie Clip tieu chi 3. Kết quả thực hiện giống như minh họa dưới: Cuối cùng, công việc quan trọng cần thực hiện là đưa 3 Movie Clip tương ứng với 3 tiêu chí vào bên phải của vòng tròn chữ. Bạn hãy thực hiện các thao tác sau: Trước tiên, để trở về màn hình chính, nhấp vào chữ Scene 1 (nằm bên trái chữ tieu chi 3) trên thanh Timeline.
  10. Trong cửa sổ của Scene 1, hãy thu nhỏ vùng làm việc lại bằng cách nhấp vào mũi tên hướng xuống trên thanh trạng thái và chọn 50%. Tiếp theo, nhấp chọn Grid > Show Grid để hiển thị lưới. Sau khi hiển thị lưới, trên bảng Timeline nhấp chọn biểu tượng Insert Layer để chèn vào một layer mới sau đó nhấp đúp vào tên layer này sau đó đổi tên nó thành tieu chi.
  11. Sau khi đổi tên layer, nhấp chọn frame đầu tiên của layer tieu chi sau đó nhấp kéo lần lượt các Symbol tieu chi 1, tieu chi 2 và tieu chi 3 từ vùng Preview của bảng Library vào vùng Stage như hình minh họa dưới (nhấn Ctrl+L để mở bảng Library). Bây giờ, hãy nhấn tổ hợp phím Ctrl + Enter để xem kết quả diễn hoạt. Để hiển thị file flash này trên trình duyệt Web bạn nhấn phím F12. Chúc bạn thành công!  

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản