Learning Flash

Chia sẻ: Thanh Cong | Ngày: | Loại File: PDF | Số trang:122

0
72
lượt xem
21
download

Learning Flash

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Life on the Web Add flavor effect, Afterburner, aftershocks, Andromedia, Allaire, Animation PowerPack, Aria, gain, Authorware, Authorware Star, Backstage, Bright Tiger, Clustercats, ColdFusion, Contribute, Design In Motion, Director, Dream templates, Dreamweaver, the drums in 2000, EDJE, EJIPT, Extreme 3D, Fireworks, Flash, Flash Lite, Flex, Fontographer, freedom, power, homesite, JFusion, JRun, Kawa, know your site, Kien object knowledge, knowledge Stream, Knowledge Track, LikeMinds, Lingo, Live Effects, MacRecorder Logo and Design, Macromedia...

Chủ đề:
Lưu

Nội dung Text: Learning Flash

  1. Learning Flash
  2. Trademarks Add Life to the Web, Afterburner, Aftershock, Andromedia, Allaire, Animation PowerPack, Aria, Attain, Authorware, Authorware Star, Backstage, Bright Tiger, Clustercats, ColdFusion, Contribute, Design In Motion, Director, Dream Templates, Dreamweaver, Drumbeat 2000, EDJE, EJIPT, Extreme 3D, Fireworks, Flash, Flash Lite, Flex, Fontographer, FreeHand, Generator, HomeSite, JFusion, JRun, Kawa, Know Your Site, Knowledge Objects, Knowledge Stream, Knowledge Track, LikeMinds, Lingo, Live Effects, MacRecorder Logo and Design, Macromedia, Macromedia Action!, Macromedia Breeze, Macromedia Flash, Macromedia M Logo and Design, Macromedia Spectra, Macromedia xRes Logo and Design, MacroModel, Made with Macromedia, Made with Macromedia Logo and Design, MAGIC Logo and Design, Mediamaker, Movie Critic, Open Sesame!, Roundtrip, Roundtrip HTML, Shockwave, Sitespring, SoundEdit, Titlemaker, UltraDev, Web Design 101, what the web can be, and Xtra are either registered trademarks or trademarks of Macromedia, Inc. and may be registered in the United States or in other jurisdictions including internationally. Other product names, logos, designs, titles, words, or phrases mentioned within this publication may be trademarks, service marks, or trade names of Macromedia, Inc. or other entities and may be registered in certain jurisdictions including internationally. Third-Party Information This guide contains links to third-party websites that are not under the control of Macromedia, and Macromedia is not responsible for the content on any linked site. If you access a third-party website mentioned in this guide, then you do so at your own risk. Macromedia provides these links only as a convenience, and the inclusion of the link does not imply that Macromedia endorses or accepts any responsibility for the content on those third-party sites. Speech compression and decompression technology licensed from Nellymoser, Inc. (www.nellymoser.com). Sorenson™ Spark™ video compression and decompression technology licensed from Sorenson Media, Inc. Opera ® browser Copyright © 1995-2002 Opera Software ASA and its suppliers. All rights reserved. Apple Disclaimer APPLE COMPUTER, INC. MAKES NO WARRANTIES, EITHER EXPRESS OR IMPLIED, REGARDING THE ENCLOSED COMPUTER SOFTWARE PACKAGE, ITS MERCHANTABILITY OR ITS FITNESS FOR ANY PARTICULAR PURPOSE. THE EXCLUSION OF IMPLIED WARRANTIES IS NOT PERMITTED BY SOME STATES. THE ABOVE EXCLUSION MAY NOT APPLY TO YOU. THIS WARRANTY PROVIDES YOU WITH SPECIFIC LEGAL RIGHTS. THERE MAY BE OTHER RIGHTS THAT YOU MAY HAVE WHICH VARY FROM STATE TO STATE. Copyright © 2004 Macromedia, Inc. All rights reserved. This manual may not be copied, photocopied, reproduced, translated, or converted to any electronic or machine-readable form in whole or in part without prior written approval of Macromedia, Inc. Acknowledgments Director: Erick Vera Project Management: Julee Burdekin, Erick Vera Writing: Jay Armstrong, Jody Bleyle, Mary Burger, Francis Cheng, Jen deHaan, Stephanie Gowin, Phillip Heinz, Shimul Rahim, Samuel R. Neff Managing Editor: Rosana Francescato Editing: Mary Ferguson, Mary Kraemer, Noreen Maher, Antonio Padial, Lisa Stanziano, Anne Szabla Production Management: Patrice O’Neill Media Design and Production: Adam Barnett, Christopher Basmajian, Aaron Begley, John Francis Second Edition: June 2004 Macromedia, Inc. 600 Townsend St. San Francisco, CA 94103
  3. CONTENTS INTRODUCTION: Learning Macromedia Flash MX 2004 . .................. 9 Additional resources for learning Flash . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 10 CHAPTER 1: Create a Document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 13 Take a tour of the user interface. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 14 Change background and Stage size . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16 Change your view of the Stage. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 16 View the Library panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17 Add graphics to the Stage . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17 Add video . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 17 View object properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18 Add video control behaviors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 18 Use the Movie Explorer to view the document structure . . . . . . . . . . . . . . . . . . . . 19 Test the document. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 19 Find help. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 20 CHAPTER 2: Create Accessible Flash Content . . . . . . . . . . . . . . . . . . . . . . . . . . 21 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 22 Specify that your document be accessible to screen readers . . . . . . . . . . . . . . . . . . 22 Provide a document title and description. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23 Provide a title and description for instances . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 23 Specify that screen readers ignore elements in your document . . . . . . . . . . . . . . . . 23 Change static text to dynamic text for accessibility . . . . . . . . . . . . . . . . . . . . . . . . 24 Control the tab order and reading order . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 24 About testing your document with screen readers . . . . . . . . . . . . . . . . . . . . . . . . . 26 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 26 3
  4. CHAPTER 3: Write Scripts with ActionScript . . . . . . . . . . . . . . . . . . . . . . . . . . . . 27 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28 Create an instance of a symbol . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 28 Name button instances . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 29 Initialize the document . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30 About ActionScript syntax. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 30 Locate ActionScript reference documentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31 Add comments to ActionScript . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31 Write a function for a button. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 31 Copy and modify a button function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 32 Check syntax and test your application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 33 CHAPTER 4: Create an Application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 35 Copy input and dynamic text fields. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36 Name text fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36 Add and name a Button component . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 36 Declare variables and values for the prices . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37 Specify values for input text fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 37 Write a function . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 38 Write an event handler for the component . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 39 Test your application . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 40 CHAPTER 5: Work with Layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 41 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 42 Select a layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43 Hide and show layers. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43 Lock a layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 43 Add and name a layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44 Change the order of layers . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44 Organize layers in a folder . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 44 Add a mask layer . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45 Add a guide layer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 45 Delete a layer. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 46 CHAPTER 6: Create a User Interface with Layout Tools . . . . . . . . . . . . . . . . . . . 47 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48 Use guides to align an object . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 48 Change the Stage size . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49 Resize objects to match the Stage size . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 49 Specify snap alignment settings . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50 Align an object using the alignment guides . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 50 Align objects using the Align panel . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51 Snap objects to each other . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 51 4 Contents
  5. Align objects using the Property inspector . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 52 Align objects using the grid and arrow keys . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 53 CHAPTER 7: Draw in Flash . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 55 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56 Select a shape tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 56 Select options to create a polygon . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57 Draw a polygon. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57 Rotate the shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 57 Use the cut-out feature . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58 Transform the shape of your drawing . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 58 Copy strokes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59 Draw with the Line tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59 Select and add a different fill color. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 59 Group the shape . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60 Create a logo with the Pen tool . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 60 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 61 CHAPTER 8: Create Symbols and Instances . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 63 About creating symbols . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64 Create a graphic symbol . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 64 Duplicate and modify an instance of a symbol . . . . . . . . . . . . . . . . . . . . . . . . . . . 65 Modify a symbol . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 65 Create a movie clip symbol . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66 Assign an instance name to the movie clip. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 66 Add an effect to the movie clip . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 67 CHAPTER 9: Add Animation and Navigation to Buttons . . . . . . . . . . . . . . . . . . . 69 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70 Create a button from grouped objects . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 70 Name a button instance. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71 View the hit area by enabling buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71 Change the hit area of a button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 71 Align buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 72 Create animation for a button state . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73 Add an action to a button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 73 Add navigation to a button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74 Test the SWF file. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 74 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 75 Contents 5
  6. CHAPTER 10: Add Static, Input, and Dynamic Text . . . . . . . . . . . . . . . . . . . . . . . 77 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 78 Create an expanding-width text block . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79 Create a fixed-width text block . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 79 Edit text and change font attributes. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80 Select device fonts . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 80 Add an input text field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81 Copy a text field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 81 Assign instance names to text fields . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82 Create a dynamic text field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 82 Specify format options. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83 View ActionScript for the dynamic text field . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83 Test the SWF file. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 83 Check spelling . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 84 CHAPTER 11: Create a Timeline Animation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 85 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86 Create a motion tween . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 86 Create a shape tween . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 87 Copy and paste keyframes in an animation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 88 Change the speed of the animation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 89 Test the SWF file. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 90 CHAPTER 12: Create a Presentation with Screens (Flash Professional Only) . . . 91 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 91 View the screen hierarchy and screen Timelines. . . . . . . . . . . . . . . . . . . . . . . . . . . 92 View screen properties . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93 Add content to a presentation slide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 93 Add screen navigation behaviors to buttons . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94 Add and name a slide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 94 Select and move slides . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95 Add content to a new slide . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95 Add transition behaviors . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 95 Test your presentation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 96 6 Contents
  7. CHAPTER 13: Add Interactivity with ActionScript . . . . . . . . . . . . . . . . . . . . . . . . 97 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 98 Name button instances . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99 Add a scene . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99 Move between scenes. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 99 Control the document with a stop() action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100 Link a button to a scene . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100 Add navigation to return to Scene 1 . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 100 Play a movie clip . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 101 Use a behavior to play an MP3 file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103 Test your document. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 103 CHAPTER 14: Create a Form with Conditional Logic and Send Data . . . . . . . . 105 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 105 Add an input text field to collect form data . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 106 Add a Submit button to the form . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107 Add an error message. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 107 Add a confirmation message . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108 Add a stop() action . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 108 Add frame labels for navigation . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109 Add conditional logic for the Submit button . . . . . . . . . . . . . . . . . . . . . . . . . . . . 109 Pass data out of a SWF file . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110 Write a function for the Try Again button . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 110 Test your SWF file. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 111 CHAPTER 15: Work with Objects and Classes Using ActionScript 2.0 . . . . . . . 113 Set up your workspace. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 113 About classes and object types . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114 Creating an object from a class . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 114 Creating a custom class . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 115 Create two objects from the Product class . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 118 About extending existing classes . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 119 Extend the MovieClip class to create a new class . . . . . . . . . . . . . . . . . . . . . . . . . 120 Summary. . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . 121 Contents 7
  8. 8 Contents
  9. INTRODUCTION Learning Macromedia Flash MX 2004 Learning Flash overview Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004 provide everything you need to create and deliver rich web content and powerful applications. Whether you’re designing motion graphics or building data-driven applications, Flash has the tools necessary to produce great results and deliver the best user experience across multiple platforms and devices. This lessons in this book are designed to introduce you to Flash. As you complete the lessons, you will learn many of the basic tasks of creating Flash applications. Note: This book is not a comprehensive manual detailing all the features of Macromedia Flash MX 2004. For in-depth information about using Flash, from within the Flash application, select Flash Help (Help > Help). About the lessons The book includes several step-by-step lessons, designed to teach you the fundamentals of Flash. We recommend that you go through the lessons using the sample files provided. The path to the sample file is provided in each lesson. By completing these hands-on lessons, you’ll learn how to use Flash to add text, graphics, and animation to your Flash applications. Additionally, you’ll learn how easy it is to customize your Flash application by using ActionsScript and behaviors. The lessons are targeted toward beginners to intermediate-level Flash designers and developers who want to get up to speed quickly. Each lesson focuses on a specific Flash design feature or topic and takes approximately 10–20 minutes to complete, depending on your experience. You can follow the lessons in this book in order, or you can start with a lesson or task that best suits your interests and experience. The Quick Start, Basic Flash, and Basic ActionScript lessons provide an opportunity to explore the Flash workspace. In these lessons, you learn how to create a Flash document, write ActionScript, work with video and video control behaviors, and add a Flash component. 9
  10. Where to start If you are new to Flash, start with the “Getting Started with Flash” chapter in Help (Help > Help > Using Flash > Getting Started with Flash) to help you become familiar with Flash before proceeding to the Flash lessons. To complete the Flash lessons, you can follow the lessons in this book or open the lessons in the How Do I panel in Flash Help (Help > How Do I). Although the lessons can be completed in any order, the best way to build your understanding of Flash is to take the lessons in the order they appear in the How Do I panel. Typographical conventions The following typographical conventions are used in this book: • Menu items are shown in this format: menu name > menu item name. Items in submenus are shown in this format: menu name > submenu name > menu item name. • Code font indicates HTML tag and attribute names as well as literal text used in examples. • Italic code font indicates replaceable items (sometimes called metasymbols) in code. • Bold roman text indicates text that you should enter verbatim. Additional resources for learning Flash Flash contains a variety of media to help you learn the program quickly and become proficient in creating your own Flash applications. About the electronic manuals and lessons The following electronic manuals are available through the Help panel (Help > Help): • Getting Started with Flash (or Getting Started Help) provides a hands-on introduction to Flash. • Using Flash (or Using Flash Help) contains complete information on working in the Flash authoring tool, including all commands, features, and user interface elements. • Using Components contains information on adding and configuring components in a Flash document, as well as information on creating components. • Using ActionScript in Flash (or Using ActionScript Help) provides a conceptual introduction to the ActionScript language • Flash ActionScript Language Reference (or Flash ActionScript Language Reference Help) documents all actions, methods, and properties in the ActionScript API. If you are a new user, you’ll find the following information useful: • Getting Started with Flash (or Getting Started Help) provides basic information about the Flash workspace and guides you in creating a simple document. • The lessons on the How Do I tab offer an introduction to using Flash. Refer to the Quick Start, Basic Flash, and Basic ActionScript lessons (Help > How Do I). 10 Introduction: Learning Macromedia Flash MX 2004
  11. Using the Help panel The updatable Help panel provides access to information on how to use Flash. For more information about the Help panel, see the following sections. Accessing help The tabs in the Help panel—Help and How Do I—contain the full set of user assistance information provided with the Flash application. • You can select the Help tab to display general help information. • You can select the How Do I tab to display a list of 10- to 20-minute lessons that guide you through many of the features in Flash. To access help and the table of contents: 1. Select Help > Help to open the Help panel. 2. If the table of contents is not visible, click the Table of Contents button to display it. A list of help books is displayed. The Help tab is selected by default. 3. Click a book to open it and display its topics. 4. Click a topic to select it. The How Do I tab contains brief lessons that introduce you to the main features of Flash, letting you practice on isolated examples. If you are new to Flash, or if you have used only a limited set of features, start with the How Do I tab. To start the lessons: 1. Select Help > How Do I to display the How Do I tab of the Help panel. In the table of contents, you’ll find a list of lessons. 2. Click a lesson topic to open it. To search for a word or phrase in the Help panel: 1. Click the Search icon in the Help panel toolbar. 2. Type a word or phrase in the text box, then click Search. A list of topics that contain the word or phrase is displayed. To close the help table of contents: • Click the X above the table of contents. Note: You can access the table of contents again by clicking the Table of Contents button. To print a help page: 1. Click the Print button in the Help panel toolbar. 2. In the Print dialog box, select the printer and other printing options, then click Print. Additional resources for learning Flash 11
  12. Updating the Help panel The Update feature allows you to update your help system with new and revised documentation, including procedures and lessons. You can click the Update button to see if new information is available. Additionally, if you see a topic in help with the text “For the latest information about this topic, click the Update button at the top of the Help tab,” you can click this button to update Flash Help. To update Flash Help: 1. Verify that you’re connected to the Internet. 2. Click the Update button in the Help panel toolbar and follow instructions to download the help system. 12 Introduction: Learning Macromedia Flash MX 2004
  13. CHAPTER 1 Create a Document You’re about to experience the power of Macromedia Flash MX 2004 and Macromedia Flash MX Professional 2004. You’ll see how, in a few minutes, you can create a compelling web experience that combines video, text, graphics, and media control behaviors. In the process, you’ll learn about the Flash authoring environment as you accomplish the following tasks: • Tour the user interface • Dock and undock panels • Change the background and Stage size • Change your view of the Stage • View your document library • Add graphics to the Stage • Add video • View object properties • Add video control behaviors • Use the Movie Explorer to view the document structure • Test the document • Find help Before taking this lesson, we recommend that you read Getting Started with Flash, to learn about the Flash workspace. To access this guide, select Help > Getting Started in Flash Help. 13
  14. Take a tour of the user interface First you’ll open the starting FLA file that you’ll use to complete this lesson. Each lesson includes one start file, and a finished file that demonstrates how the FLA file should appear upon completion of the lessons. 1. To open your start file, in Flash select File > Open and navigate to the file: ■ On Windows 2000 or XP, browse to boot drive\ Documents and Settings\All Users\Application Data\Macromedia\Flash MX 2004\language\Configuration\ HelpPanel\ HowDoI\ QuickTasks\start_files and double-click document_start.fla. Note: If the Application Data folder is hidden, you’ll need to change your Windows Explorer settings to see the folder. ■ On Windows 98, browse to boot drive\Windows\ Application Data\Macromedia\Flash MX 2004\language\Configuration\HelpPanel\ HowDoI\QuickTasks\start_files and double-click document_start.fla. ■ On Macintosh, browse to Macintosh HD/Users/Shared/Application Support/Macromedia/ Flash MX 2004/language/Configuration/HelpPanel/HowDoI/QuickTasks/start_files and double-click document_start.fla. Note: The QuickTasks\finished_files folder contains completed versions of lesson FLA files, for your reference. The document opens in the Flash authoring environment. The document already includes two layers in the Timeline. To learn more about layers, select Help > How Do I > Basic Flash > Work with Layers. One of the layers is a guide layer, which assists you in placing objects on the Stage. The other layer is a content layer in which to place the objects that will compose your document. Note: Guide layers do not appear in the Flash content that you test or publish. 2. Select File > Save As and save the document with a new name, in the same folder, to preserve the original start file. As you complete this lesson, remember to save your work frequently. Select panel sets and arrange panels The Training Layout panel set arranges your workspace in a way that facilitates taking lessons. You’ll use this layout for all lessons that you take in Flash. • Select Window > Panel Sets > Training Layout. You can move panels around, and resize them, as follows: ■ You can undock a panel by clicking the upper left corner of the panel, in the Title bar, and dragging the panel to another location in the work area. If the panel snaps against a border, it is docked in a new location (or docked in the same location, if you moved it back). Otherwise, the panel is undocked. ■ You can resize an undocked panel by dragging the lower right edge out to enlarge the panel. 14 Chapter 1: Create a Document
  15. Use tools to create Flash content The white rectangular Stage area is where you can arrange objects as you wish them to appear in your published file. Note: In Windows operating systems, you can open several documents at once and use document tabs, above the Stage, to navigate between them. The Tools panel, next to the Stage, offers a variety of controls that let you create text and vector art. To learn more about Tools panel tools, select Help > How Do I > Basic Flash > Draw in Flash and Help > How Do I > Basic Flash > Add Static, Input, and Dynamic Text. 1. Click the Pencil tool in the Tools panel. Click the Stroke color box, in the Tools panel Colors area, and select any color except white. 2. Click and drag around the Stage, without releasing the mouse, to draw a line. You’ve created Flash content. Your finished document will be much more impressive. Undo actions Flash can undo a series of changes to your document. You’ll undo the artwork that you just created. 1. To see the undo feature in action, first open the History panel (Window > Other Panels > History). The Pencil tool appears in the panel, because using the tool was your last action. 2. Do one of the following: ■ Select Edit > Undo Pencil Tool. ■ Press Control+Z (Windows) or Command+Z (Macintosh). Your scribbles disappear from the Stage. The History panel now shows a dimmed Pencil tool, which indicates the undo action was executed. Flash, by default, is set to undo 100 of your changes, in reverse order of execution. You can change the default setting in Preferences. To change your preferences, see Setting Preferences in Flash in the “Getting to Know the Workspace” chapter of Getting Started with Flash (Help > Getting Started. 3. To close the History panel, click the options menu in the upper right corner of the panel and select Close Panel. View the Timeline Just above the Stage, you see the Timeline and layers. You can create and name layers, then add content to frames on layers to organize how your Flash content plays as the playhead moves across the frames. Take a tour of the user interface 15
  16. • Move the mouse pointer over the area that separates the Stage from the Timeline. When the resizing handle appears, drag up or down slightly to resize the Timeline as necessary. Playhead Keyframe Resizing handle The playhead (the red indicator line) is on Frame 1 in the Timeline. The keyframes are designated by small circles in the frames, which are filled, indicating there’s content in those frames. You can add a keyframe to a document when you want the Flash content to change in some way in that frame. Change background and Stage size The Stage provides a preview of how your Flash content will appear in your published file. You’ll change the size of the Stage, to accommodate artwork designed for a larger Stage, and you’ll change the background color of the Stage. 1. In the Tools panel, click the Selection tool. 2. On the Stage, click anywhere in the gray work area that surrounds the Stage, or on the background area of the Stage, so that no objects are selected. The Property inspector, below the Stage, displays properties for the document when no objects are selected. 3. To change the Stage background color, click the Background color box and select a light shade of gray, such as gray with the hexadecimal value of #CCCCCC. 4. To change the Stage size, click the Size button in the Property inspector. In the Document Properties dialog box, enter 750 for the Stage width, then click OK. The Stage resizes to 750 pixels wide. Change your view of the Stage You can change your view of the Stage without affecting the actual Stage size of your document. 1. In the Stage View text box, above the right side of the Stage, type 500%. Then press Enter or Return. Your view of the Stage enlarges to 500%. 2. In the Stage View pop-up menu, which you access by clicking the control to the right of the text box, select 100% to view the Stage in dimensions that correspond to the size of the published Flash content. 16 Chapter 1: Create a Document
  17. View the Library panel Flash content that you import or that is a symbol is stored in your Library panel. To learn more about symbols and instances, select Help > How Do I > Basic Flash > Create Symbols and Instances. • To view the Library panel, select Window > Library. We’ve already imported library items and created symbols for objects that you’ll use in this lesson. Note: Flash also contains a library of buttons that you can use in your document. To view this library, after taking this lesson, select Window > Other Panels > Common Libraries and select the Buttons library. Add graphics to the Stage To add library items to your document, you verify that you’re adding the object to the correct layer, then drag the item from the Library panel to the Stage. 1. In the Timeline, click the Content layer name to select that layer. With the Selection tool selected, drag the Title movie clip, which contains a bitmap image and vector graphic, from the Library panel to the Stage and align it over the Title guide. In Flash, you can work with both bitmap images, which describe graphics using pixels, and vector art, which uses mathematical representation to describe art. For more information, see “About vector and bitmap graphics” in Using Flash. 2. With the Content layer still selected, drag the text symbol from the Library panel to Stage, and align it with the Trio ZX2004 text that’s already in place as a guide. You can use your keyboard arrow keys to nudge the text into place. The title text is actually a graphic created from text. Add video The Library panel includes an imported Flash video file (FLV). You’ll add the video to your document, and Flash will add the necessary frames to play the video. To learn more about using video in Flash, see “Working with Video” in Using Flash. 1. Verify that the Content layer is still selected in the Timeline. From the Library panel, drag the ggb_movie_for_trio_new video to the dark gray Video guide on the Stage. 2. A dialog box appears that indicates Flash will add 138 frames to the Timeline for the video. Click Yes. 3. Drag the playhead across the Timeline to view the video. Add video 17
  18. View object properties When you add an object to the Stage, you can select it, then view and change its properties in the Property inspector. The type of object selected determines which properties appear. For example, if you select a text object (not a text graphic, which we use in this lesson), the Property inspector displays settings such as font, type size, and paragraph formatting, which you can either view or change. If no object is selected, the Property inspector displays properties for the entire document. 1. On the Stage, with the Selection tool selected, click the Title graphic. The Property inspector (Window > Properties) shows specifications, such as height, width, and Stage coordinates, for the grouped object. 2. On the Stage, click the bounding box for the video movie clip that you dragged to the Stage and view its attributes in the Property inspector. 3. In the Instance Name text box of the Property inspector, enter video as the instance name. Note: Because ActionScript, the Flash scripting language, often refers to instance names, it is a good practice to name instances. To learn more about naming instances, select Help > How Do I > Quick Tasks > Write Scripts with ActionScript. Add video control behaviors Behaviors let you add complex functionality to your document easily, without having to know ActionScript, the Flash scripting language. You’ll now add behaviors for video control. 1. In the Timeline, click Frame 1 of the Content layer to select it, if it’s not already selected. 2. On the Stage, click the Play movie clip instance (which looks like a play button) to select it. In the Behaviors panel (Window > Development Panels > Behaviors), click the Add (+) button and select Embedded Video > Play. To learn more about symbols and instances, select Help > How Do I > Basic Flash > Create Symbols and Instances. 3. In the Play Video dialog box, verify that Relative is selected. Select video, which is the instance name that you gave to the video clip, then click OK. 4. On the Stage, click the Pause movie clip instance to select it. In the Behaviors panel, click the Add (+) button and select Embedded Video > Pause. 5. In the Pause Video dialog box, again select the video movie clip, then click OK. 6. On the Stage, click the Rewind movie clip instance to select it. In the Behaviors panel, click the Add (+) button and select Embedded Video > Rewind. 18 Chapter 1: Create a Document
  19. 7. In the Rewind Video dialog box, select video. 8. In the Number of Frames to Step Back text box, enter 20. The Number of Frames to Step Back text box indicates how many frames the playhead should move back when the user clicks the Rewind button. Note: Additional video control behaviors let you fast-forward, hide, and show a video. Use the Movie Explorer to view the document structure The Movie Explorer helps you arrange, locate, and edit media. With its hierarchical tree structure, the Movie Explorer provides information about the organization and flow of a document. 1. Select Window > Other Panels > Movie Explorer. If necessary, enlarge the Movie Explorer to view the tree structure within the pane. The Movie Explorer filtering buttons display or hide information. 2. Click the pop-up menu in the title bar of the Movie Explorer, and select Show Movie Elements and Show Symbol Definitions, if they’re not already selected. 3. Configure the filtering buttons, along the top of the Movie Explorer, so the only ones selected are Show Buttons, Movie Clips, and Graphics; Show Action Scripts; and Show Video, Sounds, and Bitmaps. If you move your mouse pointer over a button, a tooltip displays the name of the button. Examine the list to view some of the assets included in the document, and to see their relationship to other assets. 4. In the Movie Explorer pane, expand Actions for Play to view ActionScript that Flash created when you added the Play video control behavior. 5. To close the Movie Explorer, click its close box. Test the document As you author a document, you should save and test it frequently to ensure the Flash content plays as expected. When you test the SWF file, click the video control buttons to see if the video stops, plays, and rewinds as expected. 1. Save the document (File > Save) and select Control > Test Movie. The Flash content plays in a SWF file window. While FLA is the extension for documents in the authoring environment, SWF is the extension for tested, exported, and published Flash content. 2. When you finish viewing the SWF content, close the SWF file window to return to the authoring environment. Test the document 19
  20. Find help The lessons provide an introduction to Flash, and suggest ways that you can use features to create exactly the kind of document required. For comprehensive information about a feature, procedure, or process described in the lessons, see the Help tab of the Help panel (Help > Help). Summary Congratulations on creating a Flash document that includes graphics, a video, and video control behaviors. In a few minutes, you learned how to accomplish the following: • Tour the user interface • Dock and undock panels • Change the background and Stage size • Change your view of the Stage • View your document library • Add graphics to the Stage • Add video • View object properties • Add video control behaviors • Use the Movie Explorer to view the document structure • Test the document • Find help To learn more about Flash, take another lesson. 20 Chapter 1: Create a Document
Đồng bộ tài khoản