Macromedia Flash - Hiệu ứng với các khối lập phương

Chia sẻ: Hoang Nhan | Ngày: | Loại File: PDF | Số trang:5

0
94
lượt xem
51
download

Macromedia Flash - Hiệu ứng với các khối lập phương

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Trong bài này, tôi sẽ giải thích cho các bạn cách làm thế nào để tạo một hiệu ứng nâng cao với các khối hoặc các hình dựa trên Flash 8 và tất nhiên là có sử dụng Action Script.

Chủ đề:
Lưu

Nội dung Text: Macromedia Flash - Hiệu ứng với các khối lập phương

  1. Macromedia Flash - Hiệu ứng với các khối lập phương Nguồn : quantrimang.com  Trong bài này, tôi sẽ giải thích cho các bạn cách làm thế nào để tạo một hiệu ứng nâng cao với các khối hoặc các hình dựa trên Flash 8 và tất nhiên là có sử dụng Action Script. Hãy đi chuyển chuột lên trên các hình lập phương Bước 1 Mở một file Flash mới. Vào Modify > Document (Ctrl + J). Thiết lập độ rộng và chiều cao tương ứng là: Width: 400 pixels và Height: 250 pixel. Chọn màu nền là #72768, Frame rate: 42 fps và chọn OK. Bước 2 Chọn công cụ Rectangle (R). Bạn sẽ vẽ một hình chữ nhật không có màu viền. Để làm việc này, chọn màu cho Stroke là No color, màu Fill là màu trắng (white), và vẽ một hình lập phương 35 x 35px (Xem hình dưới) Bước 3 Chọn hình lập phương vừa vẽ, nhấn F8 (hoặc vào Modify > Convert to Symbol) để chuyển đổi hình lập phương đó sang Movie Clip.
  2. Bước 4 Kích đúp vào Movie clip trên với công cụ Selection (V). Bạn sẽ vào bên trong Mobie clip. Bước 5 Chọn hình lập phương và nhấn phím Ctrl + C (Copy), tạo một layer mới (layer2), chọn frame 2 và nhấn phím F6, sau đó nhấn Ctrl + Shift + V (Paste in Place). Bước 6 Trở lại layer 1, chọn nó và nhấn phím F8 (Convert to Symbol) để chuyển nó sang Button. Xem hình dưới. Bước 7 Sử dụng công cụ Selection Tool (V), click một lần vào hình lập phương để chọn nó và mở Properties Panel (Ctrl + F3). Ở bên phải bạn sẽ nhìn thấy menu Color. Hãy chọn Alpha với 17%. Bước 8 Chọn frame 8 và 13 rồi nhấn F6. Sau đó, trở lại frame 8, chọn công cụ Free Transform Tool (Q), nhấn và giữ phím Shift, dùng chuột kéo hình lập phương to ra một chút. Xem hình dưới.
  3. Sau đó, chọn công cụ Selection Tool (V), lại chọn hình lập phương và mở Properties Panel. Trên menu Color, lại chọn Alpha và giá trị là 100%. Bước 9 Kích chuột phải vào bất cứ đầu trong vùng màu giữa frame 1 với frame 8 và sau đó là giữa frame 8 với frame 13 cùng dòng, chọn Create Motion Tween từ menu xuất hiện. Bước 10 Trở lại frame 1, dùng công cụ Selection Tool (V) và lại chọn hình lập phương. Nhấn phím F9 hoặc vào Window > Actions để mở Actions panel. Bước 11 Nhập đoạn mã ActionScript bên dưới vào Actions Panel: on (rollOver) { play(); } Bước 12 Khóa layer1, chọn frame đầu tiên của layer 2, và trong Action Panel (F9) nhập vào mã sau: stop (); Bước 13
  4. Chọn frame 2 của layer 2, nhấn phím F8 (Convert to Symbol) để chuyển đổi hình lập phương này sang Graphic Symbol. Sau đó, dùng công cụ Selection Tool (V), chọn hình lập phương, vào Properties Panel. Trong phần menu Color chọn Alpha và 17%. Bước 14 Chọn frame 35 và 45 và nhấn phím F6. Bước 15 Trở lại frame 35, dùng công cụ Free Transform Tool (Q) để tăng hình lập phương lên như là chúng ta đã làm đối với hình lập phương đầu tiên (Bước 8) Bước 16 Kích chuột phải vào bất cứ đâu trong vùng giữa frame 2 với 35 và sau đó là frame 35 với 45, chọn Create Motion Tween từ menu xuất hiện. Bước 17 Trở lại Scene chính (Scene1) và nhân các hình lập phương lên nhiều bản.
  5.  
Đồng bộ tài khoản