Nhập chữ và tạo hiệu ứng với Flash MX phần 2

Chia sẻ: Lac Tran | Ngày: | Loại File: PDF | Số trang:12

0
94
lượt xem
40
download

Nhập chữ và tạo hiệu ứng với Flash MX phần 2

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Khi đã thiết đặt xong các thông số, trên thanh thước xuất hiện một mũi tên (đường motion tweening) từ frame 2 đến frame 39. Tương tự như ở frame 1, trên thanh thước Timeline nhấp chọn frame 40 sau đó chọn lệnh Motion ở mục Tween và thiết đặt các thông số đi kèm. Sau khi hoàn tất việc chọn lệnh Motion, bạn nhấp chọn frame 10 của Layer 2 và nhấn phím F6 để chèn thêm một keyframe vào vị trí này. Sau khi chèn thêm một keyframe, trên thanh Timeline nhấp chọn keyframe này sau đó nhấp chuột chọn chữ...

Chủ đề:
Lưu

Nội dung Text: Nhập chữ và tạo hiệu ứng với Flash MX phần 2

  1. NHẬP CHỮ VÀ TẠO HIỆU ỨNG VỚI FLASH MX Khi đã thiết đặt xong các thông số, trên thanh thước xuất hiện một mũi tên (đường motion tweening) từ frame 2 đến frame 39. Tương tự như ở frame 1, trên thanh thước Timeline nhấp chọn frame 40 sau đó chọn lệnh Motion ở mục Tween và thiết đặt các thông số đi kèm. Sau khi hoàn tất việc chọn lệnh Motion, bạn nhấp chọn frame 10 của Layer 2 và nhấn phím F6 để chèn thêm một keyframe vào vị trí này. Sau khi chèn thêm một keyframe, trên thanh Timeline nhấp chọn keyframe này sau đó nhấp chuột chọn chữ FLASH trong vùng Stage.
  2. Sau khi chọn chữ FLASH, bảng Properties có nội dung sau: Trên bảng này, nhấp chọn Tint ở mục Color, nhập giá trị 100 vào mục Tint Amout. Sau đó, nhấp chọn màu xanh Green (#00FF00) từ bảng màu cho chữ FLASH hoặc bằng cách nhập thông số RGB là 0, 255, 0. Khi đã xác định các thông số cần thiết, trên bảng Timeline bạn nhấp vào frame 1 và nhấn phím Enter trên bàn phím để xem kết quả diễn hoạt: Bạn sẽ thấy chữ FLASH chuyển từ màu đỏ sang màu xanh Green khi chuyển động từ frame 1 tới frame 10. Sau khi xem kết quả diễn hoạt, cho chữ này chuyển đổi qua một số màu khác nhau bằng cách thực hiện các bước sau: Trước tiên, trên thanh thước Timeline nhấp chọn frame 20 của Layer 2 và nhấn phím F6 trên bàn phím để chèn vào đó một keyframe. Tiếp theo, trên vùng Stage nhấp chọn chữ FLASH.
  3. Chọn xong, trên bảng Properties bạn nhấp chọn Tint từ danh sách ở mục Color và nhấp chọn màu xanh Blue (#0000FF) từ bảng màu hoặc nhập trực tiếp thông số RGB: 0, 0, 255. Trên thanh thước Timeline, tiếp tục nhấp chọn frame 30 của Layer 2 sau đó nhấn phím F6 trên bàn phím để chèn vào đó một keyframe. Sau khi chèn thêm một keyframe vào, dùng công cụ Arrow nhấp chọn chữ FLASH trong vùng Stage. Chọn xong, trên bảng Properties bạn thiết đặt một số thông số sau: Nhấp chọn Tint trong mục Color sau đó nhấp chọn màu vàng (#FFFF00) từ bảng màu hoặc nhập trực tiếp thông số RGB: 255, 255, 0.
  4. Cuối cùng, bạn nhấp chọn frame 40 của Layer 2 sau đó chọn chữ FLASH trong vùng Stage sau đó thiết đặt các thông số Properties như hình dưới: Như vậy là bạn đã hoàn tất công việc tạo hiệu ứng chuyển màu chữ, bây giờ bạn nhấp chọn frame đầu tiên (của bất kỳ layer nào trên bảng Timeline) sau đó nhấn phím Enter trên bàn phím để xem kết quả diễn hoạt: Thấy chữ FLASH đổi màu từ đỏ sang xanh Green sang xanh Blue sang vàng và cuối cùng là màu đen trong khi chuyển động từ frame 1 tới frame 40. Lưu lại kết quả bài tập bằng cách thực hiện các bước sau: Trước tiên nhấp chọn File > Save. Hộp thoại Save As xuất hiện, chọn thư mục lưu trữ ở mục Save in, nhập tên cho bài tập này là tao hieu ung chu ở mục File name tiếp đó nhấp vào nút Save.
  5. Cách lưu trữ trên sẽ lưu lại bài tập này với phần đuôi mở rộng là .fla. Tuy nhiên file này sẽ chỉ thực hiện được trong môi trường flash mà thôi. Để đưa file này vào trang web hoặc xem trong một môi trường khác thì bạn phải nhấp chọn lệnh File > Export Movie. Hộp thoại Export Movie xuất hiện, bạn cũng nhấp chọn lưu trữ ở mục Save in và nhập tên cho file là tao hieu ung chu ở mục File name và chọn kiểu lưu trữ ở mục Save as Type là .gif (Animated GIF). Cuối cùng nhấp vào nút Save để tiến hành lưu. Hộp thoại Export GIF xuất hiện, chấp nhận các thông số mặc định và nhấp OK.
  6. Bây giờ, bạn sẽ đưa file .gif vừa được lưu vào trang Web. Trước tiên hãy khởi động chương trình Frontpage bằng cách nhấp chọn Start > Programs > Microsoft Office > Microsoft FrontPage. Biểu tượng Microsoft FrontPage xuất hiện và tiếp theo đó là cửa sổ màn hình làm việc của chương trình này. Trên màn hình làm việc, nhấp chọn lệnh Insert > Picture > From File từ thanh trình đơn hoặc nhấp vào biểu tượng Insert Picture From File trên thanh công cụ chuẩn.
  7. Hai hộp thoại Picture và Select File xuất hiện đồng thời. Trên hộp thoại Select File, chọn thư mục lưu trữ file .gif đã lưu trước đó ở mục Look in. Tên file này sẽ xuất hiện trong mục File name và nhấp chọn OK. Sau khi nhấp nút OK, cả hai hộp thoại Picture và Select File đóng lại. Lúc này, trên cửa sổ màn hình FrontPage xuất hiện nội dung của file .gif mà bạn vừa chọn.
  8. Bây giờ, nhấp chọn File > Save từ trình đơn hoặc nhấn tổ hợp phím Ctrl+S để lưu lại trang Web vừa tạo. Hộp thoại Save As xuất hiện, chọn thư mục lưu trữ trang Web ở mục Save in, nhập tên cho trang này là trang chu ở mục File name sau đó nhấp nút Save.
  9. Sau khi lưu trữ trang Web xong, nhấp chọn File > Preview in Browser… từ thanh trình đơn hoặc nhấp chọn biểu tượng Preview in Browser trên thanh công cụ chuẩn để hiển thị trang Web này trên trình duyệt. Trình duyệt Microsoft Internet Explorer xuất hiện và hiển thị nội dung trang Web. Đường dẫn đến trang Web xuất hiện trên thanh Address. Tuy nhiên, trong Flash còn một cách khác cung cấp cho bạn một lệnh để xuất trực tiếp file Flash sang Web. Bây giờ, trở lại màn hình làm việc Flash, bạn chọn File > Publish Preview > Default – (HTML) hoặc nhấn tổ hợp phím Ctrl + F12.
  10. Khi thực hiện lệnh này, trình duyệt Web Microsoft Internet Explorer xuất hiện (bạn sẽ nhận được hai file .html và .swf cùng tên, cùng thư mục với file .fla). Bây giờ, bạn hãy thay file .gif trên trang web đã tạo từ Frontpage bằng file .swf. Do Microsoft FrontPage không hỗ trợ nhập file .swf nên muốn chèn file này vào bạn cần thực hiện các bước sau đây: Trước tiên, trở lại màn hình Flash và nhấn tổ hợp phím Ctrl + F12 để chạy lại file flash trên màn hình trình duyệt. Tiếp theo, trên màn hình trình duyệt bạn nhấp chọn View > Source. Màn hình Notepad xuất hiện với một đoạn mã lệnh. Bạn nhấp chọn Edit > Select All để tô đen đoạn mã lệnh.
  11. Sau khi toàn bộ vùng mã lệnh đã được tô đen, bạn nhấp chọn Edit > Copy để lưu nội dung vừa chọn vào Clipboard. Trở lại trang web trang chu, nhấp chọn tab HTML ở góc dưới trái của màn hình. Sau khi chuyển sang tab HTML, dùng chuột chọn toàn bộ đoạn mã lệnh hiện có trên màn hình và nhấp phải chuột chọn lệnh Paste từ menu để dán chồng phần nội dung vừa sao chép trước đó lên phần đang được tô đen.
  12. Lưu ý: Phải luôn để file .swf cùng thư mục với trang web chứa nó. Trong trường hợp này, nếu trang web đang tạo và file .swf không cùng thư mục, hãy chép file .swf vào cùng thư mục với file web. Sau khi sao chép đoạn mã lệnh xong, nhấp chọn tab Nomal và nhấn tổ hợp phím Ctrl + S để lưu lại, sau đó nhấp chọn File > Preview in Browser… để hiển thị xem lại nội dung trên trình duyệt. Hoặc bạn có thể nhấp vào tab Preview để xem ngay kết quả. Như vậy là bạn đã hoàn tất công việc tạo các định dạng file động khác nhau từ flash và nhập chúng vào trang web. Hãy tự tạo cho mình một giao diện web thật sinh động và hấp dẫn bằng cách kết hợp flash với các chương trình tạo web. Chúc bạn thành công!  
Đồng bộ tài khoản