Nhập và xuất các vỏ bao với Maya Cloth P5

Chia sẻ: Chau Duong | Ngày: | Loại File: PDF | Số trang:16

0
65
lượt xem
13
download

Nhập và xuất các vỏ bao với Maya Cloth P5

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tham khảo tài liệu 'nhập và xuất các vỏ bao với maya cloth p5', công nghệ thông tin, đồ họa - thiết kế - flash phục vụ nhu cầu học tập, nghiên cứu và làm việc hiệu quả

Chủ đề:
Lưu

Nội dung Text: Nhập và xuất các vỏ bao với Maya Cloth P5

  1. NHẬP VÀ XUẤT CÁC VỎ BAO VỚI MAYA CLOTH (PHẦN 5) ĐIỀU CHỈNH ÁO Từ Main Menubar, nhấp chọn quần. Từ Main Menubar, nhấp chọn Display > Object Component > Templates để tạo mẫu cho quần.
  2. Trong cửa sổ Oultiner, nhấp chọn shritExport:shirt. Từ Main Menubar, nhấp chọn Display > Show > Show Selection để cho áo được hiện ra.
  3. Rê chuột vào vùng của áo, nhấp chuột phải và chọn Vertex. Lúc này sẽ xuất hiện nhiều điểm màu hồng đó chính là Vertex. Nhấp rê chuột chung quanh từ phần lai áo lên gần eo (nhắm chừng ngang lưng quần) để chọn tất cả các Vertex trong vùng chọn này. Nhấn phím R để chọn Scale Tool, khi đó một hệ trục tọa độ xuất hiện, công cụ này dùng để hiệu chỉnh kích thước lớn hơn hoặc nhỏ hơn. Bạn dùng công cụ này để kéo áo cho rộng ra, lúc này các bạn có cảm giác áo đang phủ lên quần.
  4. Nhấn phím Spacebar để các bạn có thể quan sát ở cả bốn màn hình (top, persp, front, side). Bởi vì chỉ cần nới rộng phần thân trước vào sau áo cho nên bạn kéo trục Z là được. Để kéo riêng trục Z bạn nên quan sát bên màn hình side vì màn hình này chỉ có thể di chuyển được chủ yếu là trục Y và trục Z. Nhấp rê chuột vào trục Z về bên trái màn hình, bạn kéo một chút thôi. Bạn nhấn F8 hai lần để bỏ chọn Vertex. Nhấp chọn áo lúc này áo chiếu sáng màu lục và từ Main Menubar, nhấp chuột chọn Simulation > Update Cloth State để cập nhật vị trí mới của các vertex cho solver.
  5. 1. Đặt thuộc tính độ dày Với áo vẫn đang được chọn, từ Main Menubar, nhấp chọn Simulation > Properties > shirtExport:cpPropertyShirt. Bạn nhớ nhấp vào hình vuông để mở cửa sổ Attribute Editor. Trong cửa sổ Attribute Editor bạn thiết lập Thickness = 1.2; Thickness Force = 3.
  6. Lưu ý: Để xác định thuộc tính nào được gán cho vỏ bao của bạn, hãy chọn các panel. Bạn có thể làm điều này trong Outliner, hoặc hiển thị các panel và các đường bao lên và chọn panel bạn muốn trong chế độ view. Tên thuộc tính được hiển thị bên dưới Inputs trong Channel Box. Hiển thị jackie và khử Template cho quần: Trong cửa sổ Outliner bạn nhấp chọn jackie.
  7. Trong cửa sổ Outliner nhấp chọn pantsExportpants. Từ Main Menubar, nhấp chọn Display > Object Components.
  8. Nhấp chọn áo. Từ Main Menubar, nhấp chọn Simulation > StartSimulation để chạy simulation cục bộ để nới lỏng áo ở phần trên quần.
  9. ĐẶT VỊ TRÍ BẮT ĐẦU CỦA SỰ CHUYỂN ĐỘNG Cho trỏ chuột vào 2 ô đầu tiên của dòng Range Slider để nhập thời gian bắt đầu chuyển động là –20 và thời gian kết thúc chuyển động là 1. Từ Main Menubar, nhấp chọn Simulation > Solver > shirtExport:cpSolver1, bạn nhớ nhấp chọn hình vuông dùng để mở cửa sổ Attribute Editor. Trong cửa sổ Attribute Editor bạn thiết lập lại các thuộc tính sau: Start Frame = -20. Relax Frame Length = 0. Frame Samples = 2.
  10. Nhấp chọn áo và từ Main Menubar, nhấp chọn Simulation > Delete Cache. Từ Main Menubar, nhấp chọn Options > General Preferences.
  11. Trong cửa sổ General Preferences, chọn thẻ Animation. Trong khung chọn Playback: bạn chọn Looping = Once và Playback Speed = Free.
  12. Nhấp nút Play trên thanh trạng thái Status Line. Khi bạn đang ở frame 1, jackie đang ở vị trí bắt đầu chuyển động và quần áo của cô ta trông thật tự nhiên. Vào lúc này, bạn hãy lưu trạng thái bắt đầu mới cho cho các vỏ bao của bạn, điều này sẽ cho phép bạn mô phỏng (simulate) các chuyển động (animation) và sau đó trở lại frame 1 nếu bạn chọn simulate lần nữa. Bạn có thể thử với nhiều tính chất của vật liệu khác nhau cho đến khi bạn đạt được hình ảnh mong muốn. Nhấp chọn áo trong khung màn hình persp. Từ Main Menubar, nhấp chọn Simulation > Save as Initial Cloth State.
  13. Nhấp chọn quần trong khung màn hình persp. Từ Main Menubar, nhấp chọn Simulation > Save as Initial Cloth State. Trên thanh trạng thái Range Slider nhập frame khởi đầu là 1 và frame kết thúc là 118. Từ Main Menubar, nhấp chọn Simulation > Solver > shirtExport:cpSolver1, bạn nhớ nhấp chọn hình vuông dùng để mở cửa sổ Attribute Editor. Trong cửa sổ Attribute Editor thiết lập lại Start Frame = 1.
  14. Trong màn hình phối cảnh với áo đang được chọn, thì từ Main Menubar, nhấp chọn Simulation > Delete Cache. Nhấp nút Play để xem kết quả.
  15. HOÀN THÀNH Chúc mừng bạn đã hoàn thành việc mặc quần áo cho jackie và cho cô ta đang đi bộ với Maya Cloth. Lưu bài học Từ Main Menubar, nhấp chọn File > Save Scene. Để xem mẫu thiết kế sẵn cho bài học này. Từ Main Menubar, nhấp chọn File > Open Scene. Bạn chọn file importFinal.ma trong đường dẫn: C:AWmaya2.5extrascloth utorialsscenesimportFinal.ma
  16. KẾT LUẬN Vậy là bạn ghép áo và quần vào người jackie, bài học kế tiếp bạn sẽ tự mình tạo các đường bao, các đường bao này đòi hỏi cuối đường này sẽ trùng với đầu của đường kế tiếp, mong rằng bạn sẽ được tham khảo thêm nhiều chi tiết thú vị khác.  
Đồng bộ tài khoản