Nhập và xuất các vỏ bao với Maya phần 2

Chia sẻ: Vong Phat | Ngày: | Loại File: PDF | Số trang:10

0
69
lượt xem
21
download

Nhập và xuất các vỏ bao với Maya phần 2

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

IMPORT CÁC VỎ BAO File Import.ma chứa cùng 1 phiên bản của jackie mà bạn sẽ sử dụng trong bài học khác. Cô ta có cùng tỷ lệ và cùng tư thế mặc quần áo với các bài học khác. Điều này đòi hỏi các vỏ bao phải được import 1 cách thành công. Tuy nhiên, trong bài này, jackie không được định vị ở vị trí khởi đầu, cô ta đã bị di chuyển và xoay. Bạn sẽ được học cách di chuyển và xoay các vỏ bao mà bạn đã inport vào để cho chúng khít với cơ...

Chủ đề:
Lưu

Nội dung Text: Nhập và xuất các vỏ bao với Maya phần 2

  1. NHẬP VÀ XUẤT CÁC VỎ BAO VỚI MAYA CLOTH (PHẦN 2) IMPORT CÁC VỎ BAO File Import.ma chứa cùng 1 phiên bản của jackie mà bạn sẽ sử dụng trong bài học khác. Cô ta có cùng tỷ lệ và cùng tư thế mặc quần áo với các bài học khác. Điều này đòi hỏi các vỏ bao phải được import 1 cách thành công. Tuy nhiên, trong bài này, jackie không được định vị ở vị trí khởi đầu, cô ta đã bị di chuyển và xoay. Bạn sẽ được học cách di chuyển và xoay các vỏ bao mà bạn đã inport vào để cho chúng khít với cơ thể jackie. Trong cảnh này, jackie đã bị cho chuyển động, chuyển động cuối cùng là một vòng đi bộ (với 118 frame hình). Chúng tôi sẽ cho chuyển động từ frame -20 đến frame 1, quá trình này là quá trình chuyển động của jackie từ trạng thái mặc quần áo đến trạng thái bắt đầu chuyển động (đi bộ). Bây giờ bạn đã sẵn sàng cho việc inport áo sơ mi và làm cho nó khít vào cơ thể jackie. 1. Import áo Làm quen với sự chuyển động. Cho trỏ chuột vào 2 ô đầu tiên của dòng Range Slider để nhập thời gian chuyển động hiện hành là –20 (frame –20). Và nhập thời gian kết thúc chuyển động là 1 (frame 1). Lúc này jackie đang ở trạng thái mặc quần áo.
  2. Từ Main Menubar, nhấp chọn File > Import. Thao tác này mở cửa sổ Import Options. Trong cửa sổ Import Options hãy chắc là Use NameSpaces được bật (có dấu () Tùy chọn Name clash options được đặt là: Resolve: clashing nodes ; with: the file name. Chọn xong nhấp Import.
  3. Điều này bảo đảm là tất cả các mục chẳng hạn như solver có tên duy nhất. Xuất hiện cửa sổ Import cho bạn nhấp chọn shirtExport.ma từ project hiện hành của bạn. Chọn xong nhấp Import. Lưu ý: Là áo được đặt ở vị trí ban đầu trong bài học shirt, do đó bạn phải điều chỉnh lại cho hợp với tư thế hiện thời của jackie. Từ Main Menubar, nhấp chọn Window > Outliner. Lệnh này dùng để mở cửa sổ Outliner.
  4. Trong cửa sổ Outliner, nhấp chọn shirtExport:shirt. Trong hộp Channel, chú ý rằng mục shrit đã bị đổi tên do chúng ta đã sử dụng NameSpaces khi Import file. a. Định vị áo Ở phần này bạn có thể định vị áo lại theo hai cách: Cách 1: Bạn chọn công cụ di chuyển và xoay để định vị áo lên jackie cho càng khớp càng tốt. Trong khi áo đang được chọn nhấn phím W để chọn Move Tool. Bạn sẽ thấy xuất hiện một hệ trục tọa độ có 3 mũi tên hướng theo 3 chiều X, Y, Z. Từ Main Menubar nhấp chọn Modify > Center Pivot. Để đưa hệ trục tọa độ về giữa áo.
  5. Thật ra cách này bạn sẽ khó thấy 3 hệ trục tọa độ, nếu bạn nhấn nhanh phím Spacebar, lúc này trên màn hình sẽ chia thành bốn khu vực màn hình khác nhau, bên dưới mỗi màn hình có chữ đại diện hướng nhìn: top, side, front, persp.
  6. Lúc này, bạn nhấp rê vào 1 trong 3 mũi tên trên, bạn nhấp vào trục X di chuyển lên khoản 10 đơn vị và trục Z khoản –10 đơn vị, bạn hãy tập di chuyển sao cho gần giống như hình sau: Màu đang chiếu sáng màu lục là áo đang được chọn và bạn đang di chuyển. Bạn có thể nhấp chuột vào 1 trong 4 màn hình trên để chọn mũi tên có trục cần thiết để di chuyển áo. Trên màn hình top bạn thấy 2 tay áo dường như không để đúng vào 2 tay jackie. Bạn sẽ dùng công cụ xoay áo lại cho đúng.
  7. Tiếp tục nhấp phím E trên bàn phím để chọn Rotate Tool. Hoặc nhấp chọn trên thanh trạng thái Shelf. Khi bạn chọn Rotate Tool hệ trục tọa độ sẽ được đổi giống như quả cầu bao chung quanh áo, trong màn hình top nhấp chọn hình tròn bao quanh jackie và nhấp rê xoay cho đến khi 2 tay áo thẳng với 2 tay jackie. Hãy sử dụng 2 công cụ trên để di chuyển và xoay áo sao cho giống như hình dưới:
  8. Cách 2: Hoặc nhập trực tiếp các thông số vào hộp Channels, khi đó áo sẽ phủ lên người jackie. Trong hộp Channels bạn thiết lập Translate X = 10, Translate Z = -10 và Rotate Y = -25. Bạn có thể tắt Grid (đường lưới) để tập trung vào jackie, bằng cách từ Main Menubar nhấp chọn Display > Grid (nếu có dấu ( là Grid đang hiển thị). Nhấn phím số 5 để bật smoothshading lên xem áo có bị mất phần nào không (do tiếp xúc với cơ thể jackie).
  9. Nếu có một phần nhỏ áo bị mất thì bạn đã làm tốt lắm rồi, solver sẽ giải quyết cho bạn. Bây giờ bạn đã sẵn sàng cho cloth solver giải quyết công việc định vị chính xác hơn cho bạn. Khi áo vẫn đang được chọn, trong hộp Channels nhấp vào thẻ shirtExport:cpSolver1 để hiển thị thuộc tính, cuộn xuống dưới để thiết lập thuộc tính Start Frame = -20 để bật solver lên vào thời điểm khởi đầu chuyển động. Để hiển thị bộ menu Cloth, nhấp vào hộp chọn phía dưới Main Menubar tức là thanh trạng thái Status Line và chọn Cloth từ trình đơn xổ xuống.
  10. Từ Main Menubar, nhấp chọn Simulation > Save as Initial Cloth State. Lúc này, chúng ta hãy khai báo cho jackie là một đối tượng bị bao phủ để áo có thể phủ chính xác lên cô ta khi chạy simulation (mô phỏng quá trình chuyển động của sự bao phủ).  
Đồng bộ tài khoản