SolidWorks 2010- P14

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

lượt xem

SolidWorks 2010- P14

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

SolidWorks 2010- P14: Whether you are a new user of SolidWorks or a professional who wants to improve your skills, this book was written for you. Learning any software can be difficult at times. You launch the software for the first time, and you feel overwhelmed, not knowing how to even start a new document. In 3D CAD programs, it can be especially difficult. Many times a whole new vocabulary and a whole new creative environment are introduced.

Chủ đề:

Nội dung Text: SolidWorks 2010- P14

  1. Add Configurations to an Assembly 359 6. Select the cell that corresponds with the Shade – 20 Degrees configu- ration in the Modify Configurations window. Change the value from 10° to 20°, as shown in Figure 9.40. Click OK to accept the change. F I g u r e 9 . 4 0 Updating the value of the Angle mate in the Modify Configurations window Switch Between Configurations Switching between the available configurations allows you to see the differences between them. In this assembly, switching between the three configurations will give the illusion that the shade is moving between the three predefined locations. Switching between configurations will also allow you to make additional modifi- cations to the assembly. When you added the Angle mate to the second and third configurations, it also added the same mate to the Default configuration. As we mentioned earlier, this will cause a conflict and over-define the assembly. You can now switch back to the Default configuration to address the error. You can activate a configuration in a couple of ways. One way is to right- click the desired configuration and select Show Configuration in the menu (Figure 9.41). F I g u r e 9 . 4 1 Selecting Show Configuration in the right-click menu
  2. 360 Chapter 9 • Modeling Parts Within an Assembly The second, and in our opinion the easier, way to activate a configuration is to simply double-click the configuration in the ConfigurationManager. Using this technique, you will address the error created by adding the Angle mate. 1. Activate the Default configuration in the FeatureManager. 2. After activating the Default configuration, you will see that the FeatureManager design tree lights up like a Christmas tree with red and amber colors. That is because there is an error somewhere in the assembly. Oftentimes you will not know what the error actually is until you do a little detective work. The first place you should look is in the status bar below the graphics area. There you will see a mes- sage giving a hint as to what the issue is in the assembly, as shown in Figure 9.42. Click the error shown in the status bar. F I g u r e 9 . 4 2 Over-defined message in status bar 3. Clicking the error message in the status bar will display a window showing the mates that are causing the assembly to be over-defined, as shown in Figure 9.43. Since you already know that this configura- tion should not have the Angle mate active, you can select the mate to suppress it in the window. Select the mate, and click the Suppress button in the context bar. F I g u r e 9 . 4 3 View Mate Errors window 4. After suppressing the offending mate, the View Mate Errors win- dow will become empty, and the colored error messages in the FeatureManager will disappear as well. Click the red X in the upper- right corner of the View Mate Errors window to close it. After fixing the error, you will be able to switch between all the assembly con- figurations to see how the shade moves between its three predefined locations. Save the assembly, and you are ready to move to the next chapter.
  3. A r e Yo u E x p e r i e n c e d ? 361 Are You experienced? Now You Can… EECreate in-context models EE the Shell tool Use EESave virtual components externally EEModify appearances EE and show multiple configurations in an assembly Add EESuppress and edit mates in configurations
  4. Chapter 10 Making Modifications  Update Components in Isolation  Update the Drawing Document  Update Components Within Assemblies  Replace Components in Assemblies
  5. 364 C h a p te r 10 • M a k i n g M o d if ic at io n s C hanges to the model are to be expected. They are unavoidable and part of the design process. Before they are even prototyped, most parts and entire assemblies will often get redesigned and altered for many different reasons, such as to fit within size or weight restrictions, to reduce cost of manufacturing, to compensate for substitutions made because of lack of avail- ability or excessive cost of materials, or even to comply with laws and regula- tions of the particular region where the product will be manufactured, used, or disposed of. However, this doesn’t mean you’ll have to remodel the whole thing from scratch over and over again to incorporate these alterations; rather, you can make small modifications, also called revisions, to the original models. So far, you’ve learned how to use different features available in SolidWorks to create the parts for your model, and you’ve joined them together in assemblies and subassemblies. You’ve also learned how to generate a drawing from a part. In this chapter, you will now learn how to make modifications to your model and how to update those changes into your assembly and drawing documents. We will demonstrate how to make changes to sketches and features inside a part, how to make modifications to parts within an assembly, how to update the revi- sion table in your drawing to document the changes made to the model, and how to replace components in an assembly. Update Components in Isolation Continuing with the traditional bottom-up design approach that you’ve used so far, you will now make changes to a part in isolation. For this purpose, you’ll open and edit the part individually, in its own window. Changes made to the part will later propagate to other documents. This method is usually preferred when editing off-the-shelf parts and other standard components. The most basic and also the most common modifications that will usually need to be made to a model are changes to dimensions in sketches and features. Changes to dimensions can be made the “old-fashioned” way, by editing sketches and features separately as needed, or in a much faster and easier way, as long as Instant3D is enabled. In Chapter 3, “Creating Your First Part,” you used Instant3D to create an extruded boss in your part simply by selecting and dragging a sketch. Here we’ll demonstrate how, when Instant3D is enabled, you can resize features by editing sketch dimensions directly in the graphics area, without even having to go into Edit Sketch mode. This method is simple and can save you a few extra steps in the editing process, thus allowing you to make better use of your time.
  6. Update Components in Isolation 365 N O t e Remember, Instant3D is enabled by default, but it can be tog- gled on and off by clicking Instant3D on the Features tab. Parts and assem- blies support Instant3D. Inside an assembly, you can use Instant3D to edit components within the assembly, edit assembly-level sketches and features, and modify mate dimensions. You will learn how to edit a component within an assembly later in this chapter. Change Dimensions in Sketches with Instant3D We will first demonstrate the way to make changes to sketch dimensions while Instant3D is enabled. For this purpose, you’ll change the dimensions of one of the extrude features in the Base, Lamp part from Chapter 3. 1. Open the Base, Lamp model you created in Chapter 3. 2. Select Extrude6 in the FeatureManager. Notice that all dimensions asso- ciated with this feature will immediately show up in the graphics area. 3. In the graphics area, select the dimension for the diameter of 1.000 by clicking and releasing the left mouse button once. 4. After selecting the dimension, a small field will appear next to the dimension with the current value. In the field, change the value from 1.00 to 1.100, as shown in Figure 10.1. To apply the updated value, hit Enter on your keyboard, or click anywhere outside the field. F I g U r e 1 0 . 1 Applying the updated dimension value
  7. 366 C h a p te r 10 • M a k i n g M o d if ic at io n s Change Dimensions in Sketches Without Instant3D As we mentioned, it was only recently that Instant3D technology was introduced in SolidWorks. Some users still prefer to disable this option and make modifica- tions to features and sketches the way it was done in the past, before Instant3D was available. We will now demonstrate how it’s done by changing another dimension of the same Base, Lamp model with Instant3D disabled. As you will see, this method requires a few extra steps and takes just a little longer than the previous one, but it’s always a good idea to learn different ways to do the same in SolidWorks. There’s no particular “right” way to do things, although some methods could save you some time and effort. 1. On the Features tab of the CommandManager, deselect the Instant3D button to disable it (see Figure 10.2). F I g U r e 1 0 . 2 Disabling Instant3D 2. Select the Extrude7 feature in the FeatureManager, and notice that the dimensions of the sketch are no longer displayed in the graphics area. 3. Click the plus (+) next to the Extrude7 feature to display the child sketch. 4. Select the child sketch, Sketch7, and click the Edit Sketch button on the context toolbar (see Figure 10.3). Clicking this button will take you to Edit Sketch mode, or you can also double-click the sketch name in the FeatureManager design tree. F I g U r e 1 0 . 3 Edit Sketch button on context toolbar 5. Double-click the .700 diameter dimension in the graphics area to edit the dimension.
  8. Update Components in Isolation 367 6. In the small Modify window that is displayed next to the mouse pointer, change the value to .755, as in Figure 10.4. Click the green check mark or hit the Enter key on the keyboard to accept the change. F I g U r e 1 0 . 4 Modifying the dimension of the diameter 7. Click the Exit Sketch button in the confirmation corner to accept the change made to the sketch and to update the part geometry. 8. For future operations, click the Instant3D button on the Features tab once again to enable it. 9. Save the changes to the model, and click the X in the upper-right corner of the graphics to exit the file. Prevent Loss of Data At this point it is wise to observe that any changes made to the model will become permanent only once the document has been saved. If you fail to save and exit the document, all changes will be lost. It’s good practice to save your work often during the session to prevent loss of data in the unfortunate event of a computer crash or power outage. Save Notification If you are likely to become so engrossed in your work that you forget to save often, you can choose to have SolidWorks remind you to do it every certain amount of time that you specify in advance. If the active document hasn’t been saved within that interval, a transparent message will show up in the lower-right corner of the graphics area as an unsaved document notification, reminding you that you haven’t saved your document yet. Click the appropriate command in the message to save the document.
  9. 368 C h a p te r 10 • M a k i n g M o d if ic at io n s Follow these steps in order to enable this option: 1. Select Tools ➢ Options. 2. Select Backup/Recover on the System Options tab. 3. Under Save Notification, select the option to show a reminder. 4. Type in the proper field the number of minutes for the time interval between reminders. 5. Click OK to accept changes. Document recovery You can also have SolidWorks automatically save information about your active docu- ment every certain amount of time that you specify in advance. This option is known as Auto-Recovery, and its purpose is not to back up your active file but to save infor- mation of your model that you can retrieve in the event of an abnormal termination. Auto-Recover won’t save the information on top of your original file; it actually creates new files for the active document every time it saves changes. These files are always closed and deleted as soon as the original file is saved. If your computer crashes and you had this option enabled, the next time you start SolidWorks, the recovered files will appear on the task pane. You can choose to save any of these recovered files on top of your original file if it happens to include recent changes you made to the model and that are not present in the original file. Follow these steps in order to enable this option: 1. Select Tools ➢ Options. 2. Select Backup/Recovery on the System Options tab. 3. Under Auto-Recover, select Save Auto-Recover Info. 4. Type the number of minutes for the time interval between saves. 5. Either accept the default folder or browse to a different location of your choice where these temporary recovery files will be stored. 6. Click OK to accept the changes. Update the Drawing Document Once you save your Base, Lamp model, all modifications you’ve made to the part will propagate to all other documents associated with it, such as assemblies and drawings. This is because parts, assemblies, and drawings are all linked docu- ments in SolidWorks.
  10. Update the Drawing Document 369 In Chapter 4, “Creating Your First Drawing,” you created a drawing document from your Base, Lamp part. You will now see that the changes you’ve just made to the part document have been also included in the drawing document, and the modified dimensions will automatically update themselves the next time the drawing document is loaded. This certainly saves a lot of time and trouble, but you still need to document the changes you’ve made to the drawing for future reference. You’ll do this by updating the revision table and adding revision symbols to those entities and dimensions that have been altered. Update the revision Table Unlike the rest of the drawing, the revision table doesn’t automatically populate itself with fresh information every time a change in the model occurs. You need to update the revision table yourself in order to document all alterations made as they occur. It’s important to remember to do it as soon as changes in the model take place. The process is very simple and was already briefly introduced in Chapter 4. The following steps will show you how to update the revision table to account for the modifications made to the part and, therefore, to the drawing: 1. Open the drawing that was created in Chapter 4 named Base, Lamp. The changes that were made to the part model will automatically be updated in the drawing when it loads. 2. Zoom into the revision table in the upper-right corner of the drawing. 3. Right-click anywhere inside the table, and select Revisions ➢ Add Revision from the menu. Add Revision will add a new row to the table with the date of the revision and a letter assigned to it (see Figure 10.5). F I g U r e 1 0 . 5 Adding a new revision to the table
  11. 370 C h a p te r 10 • M a k i n g M o d if ic at io n s Place revision Symbols Depending on your organization’s standard operating procedures, you may be required to place revision symbols in your drawings. If that is not the case, you can skip the step of adding revision symbols by clicking Esc on your keyboard, but for the purpose of demonstration, you will be adding the symbols to this drawing. Here’s how: 1. In the graphics area, a circle will be displayed with the current revi- sion letter inside. Place the symbol next to the dimensions that were modified previously in the model by clicking and releasing the left mouse button, as shown in Figure 10.6. You can add the symbol to the drawing as many times as needed before clicking Esc. Notice also that if you ever need to add a symbol for an existing revision, even if it’s not the latest one, simply right-click with your mouse on the row that corresponds to the revision in the table, and select Revisions ➢ Add Symbol; then follow the same procedure described earlier to place the symbol in the drawing. F I g U r e 1 0 . 6 Adding revision symbols to the drawing N O t e You can find more information regarding revision symbols in ASME Y14.35M-1997. 2. In some organizations, the use of circular symbols may already be associated with other tasks. You can make changes to the appear- ances of selected symbols in the Revision Symbol PropertyManager. In the Border section of the PropertyManager, select the top field that currently displays Circular. In the flyout you can select an alternate symbol for the revision.
  12. Update the Drawing Document 371 N O t e Change the revision symbol only if your organization requires a different symbol. The ASME standards allow for the omission of the revision symbol if the circular symbol conflicts with other symbols in the drawing since the revision description in the revision table will suffice. 3. Once you have placed the symbols next to the two dimensions that were updated, you can exit the Revision Symbol command by press- ing Esc on your keyboard or clicking the green check mark in the PropertyManager. 4. Once the symbols have been added to the drawing area, the table should then be updated as well. Zoom in once again to the revision table in the upper-right corner of the drawing. 5. In the Description column, select the cell that corresponds to revi- sion B in the table by clicking it once. Prior to SolidWorks 2010, you were required to double-click a cell to edit its value. Now all that you need to do after selecting the cell is begin typing the description of change. In the cell, provide enough information to the print reader to be able to determine the changes made to the part, as shown in Figure 10.7. F I g U r e 1 0 . 7 Entering changes in the revision table 6. To accept the changes made to the revision table, click anywhere out- O side the table. When you create 7. Save the changes made to the drawing, and exit the document by a new revision in clicking the X in the upper-right corner of the graphics area. the revision table, the date is added The next step will be to modify a component that is part of an assembly but automatically. without opening the component in a separate window. Don’t worry! It’s not really difficult to do. In fact, once you get the hang of it, you’ll agree that it can actually be a very convenient approach.
  13. 372 C h a p te r 10 • M a k i n g M o d if ic at io n s Update Components Within Assemblies So far, all the modifications or revisions that you’ve made to your model have been taken care of using the approach known as bottom-up design, which was previously described in Chapter 2, “Learning the Basics.” As we mentioned, using this approach, you can create and modify a part in its own window, where only that part is visible and only the geometry inside that part can be used as reference. This way, changes made to that part will not propagate to other com- ponents in the assembly. Use In-Context editing As we also mentioned in Chapter 2, SolidWorks allows the user not only to create new parts in the context of an assembly but also to edit parts within the assem- bly, regardless of how they were created, either independently or while working in the assembly. This approach is known as top-down design, or in-context editing. The biggest advantages of editing the part using the top-down approach are being able to see the part in its correct location in the assembly while making modifications to it and that geometry from other components in the assembly will become available to you to copy, dimension to, or use as reference geometry for new or existing features in your part. Adjust Transparency During In- Context editing By default, when editing a part in-context, the component that is being edited will appear opaque, while all other components in the assembly that are not being edited are made transparent in order to improve visibility. Even though the components have been made transparent, their geometry is still available and can be easily selected from the graphics area. It is possible to adjust the default display settings that will be used for the components that are not being edited during in-context editing. The following steps will guide you in the process: 1. Click the Options button in the Standard toolbar, or select Tools ➢ Options. 2. On the Systems Options tab, select Display/Selection. 3. Under Assembly Transparency For In-Context Editing, you will be able to choose from three different options: Opaque Assembly This option will make all components not being edited appear opaque.
  14. Update Components Within Assemblies 373 Maintain Assembly Transparency This option will allow all com- ponents not being edited to retain any individual transparency set- tings they may already have. Force Assembly Transparency This is the option selected by default. When using this option, all components not being edited will use the same transparency level that you set here. Force Assembly Transparency is the best option for you at this moment. 4. Move the slider on the right side to the desired level of transparency. A level of 0 percent transparency will make the components opaque, and a level of 100 percent transparency will make them completely transparent. Click OK to accept the changes. Create external references If, while editing a component in the context of the assembly, you use a second component’s geometry to dimension to or as reference geometry in the defini- tion of a feature, an external reference to that second component’s geometry will be created. It is actually during in-context editing that most of the external references are created. The creation of this external reference means that one or more features in the document you just edited are now dependent on another document for their solu- tion. An example of this would be using a face in a component different from the one you’re editing as an end condition for an extruded boss feature. Your extruded boss would then become an in-context feature with an external reference to the face of the other component. Any changes made to the referenced component will propagate to the one that is referencing its geometry, as long as the update path is available. Since the update path is contained in the assembly where the reference was created, this simply means that you’ll need to open the assembly in order for updates made to the referenced component to propagate to the referencing one. In the FeatureManager design tree, a suffix will be added to all items that have an external reference. This suffix indicates not only that an external reference exists in that component but also the status of this external reference. Each suf- fix is explained here:  The suffix -> indicates that the external reference is up-to-date and a solution has been found for the in-context features in the referencing document.
  15. 374 C h a p te r 10 • M a k i n g M o d if ic at io n s  The suffix ->? indicates that the external reference is out-of-context and no solution has been found yet for the in-context features in the referencing document. You need to open the assembly that contains the update path.  The suffix ->* indicates that the external reference is locked, the existing in-context features will no longer update, and you can’t add any more external references to this component. Locked references can always be unlocked.  The suffix ->x indicates that the external reference is broken, the existing in-context features will no longer update, and the external references can never be restored. You can, however, add new refer- ences to the component. External references can be broken inten- tionally or as result of improper file management. N O t e You also have the option not to create external references while in-context editing. You can still make use of the geometry of other compo- nents, but no external references will be created. To specify that no exter- nal references are created, click the No External References button on the Assembly tab, or select Tools ➢ Options and select External References on the System Options tab, and then select Do Not Create References External To The Model. You can select or deselect this option as needed to create external references for some components but not for others. The modifications we’ll make to your components in this chapter, however, consist only of changes to dimensions. No reference to geometry from other components in the assembly will be needed. The result will be similar to updat- ing the part in isolation using the bottom-up approach, meaning that no changes will be propagated to any other components in the assembly and no references to outside geometry will be created. Technically, this is not considered top-down modeling, but it’s still a very convenient way to do updates to a component. Detect Interference Between Components Before you can proceed with any changes, you need to find out what compo- nents should be updated and how. You can use interference detection to help you with this task. It often happens that after updates are made to the individual parts that form an assembly, some of the components overlap or interfere with each other. In a small assembly, it may be easy to spot those interferences right away just by looking at it, but as assemblies grow larger and more complex, it also becomes more and more difficult to identify these areas of overlap between components.
  16. Update Components Within Assemblies 375 By using interference detection, not only can you find the interferences between components, but you can also display the true volume of the interfer- ence, distinguish between a coincidence and a true overlap between components, change the display settings to make the interference easier to visualize, ignore certain kinds of interferences such as press fits and threaded fasteners, and treat a subassembly as a single component in order to ignore all interferences inside the subassembly and concentrate only on those between the subassembly and the rest of the components in the top-level assembly. You can find the Interference Detection tool on the Evaluate tab in the CommandManager or listed in the Tools menu. The following steps will demonstrate how to use interference detection to locate interferences between the components in the shade subassembly. 1. Open the shade subassembly you created in the previous chapter. 2. Click the Evaluate tab in the CommandManager, and select the Interference Detection button, as shown in Figure 10.8. You can also access Interference Detection in the Tools menu in the Standard toolbar. F I g U r e 1 0 . 8 Interference Detection button 3. Look at the Selected Components section of the Interference Detection PropertyManager, and notice that the shade subassembly is already selected by default. This works for the purpose of this dem- onstration because you are interested in finding all existing interfer- ences in the assembly, but keep in mind that you could always clear this selection and select only a handful of components instead. Click the Calculate button. 4. The Results section of the Interference Detection PropertyManager will display a list containing all the areas of the assembly that were detected to contain interference. As you select an item listed in the window, the area will be highlighted in the graphics area. Select the first entry listed and the area where the washer cover and the mount- ing shaft overlap will be highlighted. For more clarity, you can see exactly which components are involved in the interference by clicking the plus (+) next to it (see Figure 10.9). It is obvious that the inner
  17. 376 C h a p te r 10 • M a k i n g M o d if ic at io n s diameter of the washer cover will have to be increased to eliminate the interference. At this point, you will only be making a mental note that the ID must be adjusted. F I g U r e 1 0 . 9 Interference between components 5. Moving on in the list, you will notice that the ID of the washer must also be updated. This makes sense because the washer and washer cover both have the same inner diameter. For the moment, you will disregard these two interferences and continue in the list until you reach the interference shown between the bulb subassembly and the mounting shaft. This is not a true interference since the tool does not take into account that the inter- ference is actually the threads interacting. Instead of having these instances pop up again, you can choose to ignore the interference. Below the results window, click the Ignore button. The interference will be removed from the results and the next item in the list will be highlighted. Continue to ignore any interference shown that is the result of threads. In other words, ignore two interferences between the shade mount and the bulb subassembly (Figure 10.10), one interfer- ence between the light bulb and the bulb receptacle (Figure 10.11), and one interference between the shade mount and the shade nut (Figure 10.12). That will leave you only with the interferences that were caused by the undersized washer and washer cover. Click the green check mark to exit the PropertyManager.
  18. Update Components Within Assemblies 377 Interference 1 Interference 2 F I g U r e 1 0 . 1 0 Two interferences between shade mount and bulb receptacle F I g U r e 1 0 . 1 1 Interference between shade mount and shade nut F I g U r e 1 0 . 1 2 Interference between light bulb and receptacle
  19. 378 C h a p te r 10 • M a k i n g M o d if ic at io n s Now that the problem areas have been located, you can make the necessary modifications to the dimensions in the features of the washer and washer cover. For convenience and for illustration purposes, you’ll do the editing of these two parts in the context of the assembly. Make Modifications to the Washer Cover Instead of opening the washer and washer cover separately in order to make the changes to the ID, you can make the changes while still in the assembly. Here’s how: 1. In the FeatureManager, click the plus (+) next to the washer subas- sembly to view its components. 2. Click the plus (+) next to the washer cover in the FeatureManager to view its features. 3. Select the Revolve-Thin1 feature, and click the Edit Sketch button on the context toolbar (see Figure 10.13). Revolve-Thin1 has only one internal sketch; that’s why you can access the Edit Sketch button by clicking the feature instead of the sketch. F I g U r e 1 0 . 1 3 Entering Edit Sketch mode from the context toolbar 4. Press Ctrl+8 or click the Normal To button in the Heads-up View toolbar, and zoom in closer to provide a better view of the sketch. 5. Select the .410 dimension in the graphics area. 6. You can also update the value of the dimension in the PropertyManager. In the Primary Value section, change the value to .450 (see Figure 10.14).
Đồng bộ tài khoản