SolidWorks 2010- P20

Chia sẻ: Cong Thanh | Ngày: | Loại File: PDF | Số trang:30

0
124
lượt xem
83
download

SolidWorks 2010- P20

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

SolidWorks 2010- P20: Whether you are a new user of SolidWorks or a professional who wants to improve your skills, this book was written for you. Learning any software can be difficult at times. You launch the software for the first time, and you feel overwhelmed, not knowing how to even start a new document. In 3D CAD programs, it can be especially difficult. Many times a whole new vocabulary and a whole new creative environment are introduced.

Chủ đề:
Lưu

Nội dung Text: SolidWorks 2010- P20

  1. L e a r n T i m e s a v i n g Fe a t u r e s f o r t h e D r a w i n g Te m p l a t e 539 7. Lastly, make sure the Use Document Settings option is enabled in the Border section. This will make it easier to adjust the appearance of the table in the Document Properties if the need arises. 8. With all the appropriate options enabled, click the green check mark and the revision table will be inserted in the drawing template. Saving Changes to the revision Table Template Just like with drawing templates, you can make modifications to any of the revi- sion table templates to meet your needs and save the template for future uses. For the drawings in this book we need to make a minor change to the revision table that we will be using. Rather than just have the change reflected in the drawing template, we will also save the change to the revision table template. The default template that we used does not have a table header designating it as Revision History. We will add this header to the table and save it in the draw- ing template and update the revision table template as well. 1. Select the top row of the revision table to edit the cell. 2. With Caps Lock on, type REVISION HISTORY into the cell. 3. Select the text you just typed, and deselect the Use Document Font but- ton on the Formatting toolbar. We always prefer to have text items in drawings use the document font because when you make a change in the document properties, all the text items will update as well. But for this case, you do not necessarily need to have the table header update.
  2. 540 C h a p t e r 1 6 • C r e a t i n g Yo u r O w n T e m p l a t e s : P a r t 2 4. After deselecting Use Document Font, an additional row will be added to the Formatting toolbar, allowing you to adjust the font for the selected text. Change the text height of the Revision Table header to 14, and click anywhere outside the table to accept the change. The change you just made to the table will be reflected only in the drawing template and is not automatically made to the actual Revision Table template. To update the Revision Table template, you need to overwrite the existing table temple or create a new one. Here’s how: 1. Right-click anywhere inside the revision table, and select Save As from the menu. 2. Browse to the folder where your revision templates are stored. 3. Select the file named No Zone Column.sldrevtbt, and click Save. 4. When prompted to replace the existing template, click Yes. The tem- plate has now been updated for future use. Save and Share the Sheet Format and Template Once you have made all the required modifications to the drawing template and sheet format, it is time to save the changes and make them available for use. You will need to save the drawing template and sheet format separately since they both have their own set of tasks. The sheet format can be saved and used in existing drawings to change sheet size or format. The drawing template will be used to create new drawings. Save the Sheet Format Saving the sheet format will allow you to be able to use it in existing drawings. This is helpful if you have a drawing that was created with a different template and you want to change the border and title block to meet your company standards.
  3. S a v e a n d S h a r e t h e S h e e t Fo r m a t a n d Te m p l a t e 541 You can also use saved sheet formats to change the size of a drawing sheet. For example, if you have a drawing that was originally created as a size A sheet and you decide that the sheet is too small, you can replace the sheet format with a larger size sheet without losing any other information you have already added to the drawing. 1. Once you complete all the modifications to the sheet format, hover over or click the SolidWorks logo on the menu bar. 2. Select Save Sheet Format from the File menu. 3. The Save Sheet Format window should already display the current sheet formats. If that is not the case, browse to the folder that con- tains the other sheet formats available for your system. 4. Instead of overwriting an existing sheet format, renaming the file will O allow you to maintain different sheet formats for differing tasks. For You can refer to the our purposes, name the file b - landscape - FDC.slddrt, as shown Sheet Format Folder in Figure 16.29. Location setting in the System Options window to deter- mine which folder SolidWorks is using. F I g u r e 1 6 . 2 9 Renaming a sheet to incorporate another sheet format 5. Click Save. The newly created sheet format is now available for use in existing drawings. Figure 16.30 shows the sheet format available in the Sheet Properties window. By right-clicking in an existing drawing and selecting Properties from the menu, you can change the sheet format to the one you just created.
  4. 542 C h a p t e r 1 6 • C r e a t i n g Yo u r O w n T e m p l a t e s : P a r t 2 F I g u r e 1 6 . 3 0 Selecting the sheet format in the Sheet Properties window Save the Draw Template It is now time to save the drawing template for later use. After the template is saved, it will be available for selection when creating a new drawing. All the changes made to the template including the options, custom properties, title block, revision table, and predefined views will be included when creating a new drawing. 1. Hover over or click the SolidWorks logo in the menu bar. Select Save As from the File menu. 2. In the Save As Type field of the Save As window, select Drawing Templates (*.drwdot). The folder location will automatically change based on the location for templates defined in the System Options window. 3. In the File Name field, enter the name for the template as FDC Size B. 4. Click Save. 5. With all the changes saved, you can now close the drawing. Click the X in the top-right corner of the graphics area.
  5. S a v e a n d S h a r e t h e S h e e t Fo r m a t a n d Te m p l a t e 543 Once the template is saved, it will become available for use and will be dis- played in the Advanced view of the New SolidWorks Document window, as shown in Figure 16.31. F I g u r e 1 6 . 3 1 New template available in New SolidWorks Document window Share Templates and Sheet Formats over a Network Some organizations prefer to have their templates and sheet formats stored on a network drive for all the users in the organization to share. This approach saves the CAD manager time by allowing him or her to update only one template with no need to distribute it companywide. The only difference in procedure described earlier is to add the network location to the File Locations section of the System Options window. t I p Of course, practice makes perfect, especially when making tem- plates, since they can be a huge time-saver if set up correctly. Instead of re- creating the same template from scratch, it is a good idea to build up your library of drawing templates and sheet formats for the other sizes of draw- ing sheets. Using the same steps described in this chapter, create drawing templates and sheet formats for the size A, C, D, and E drawing sheets.
  6. 544 C h a p t e r 1 6 • C r e a t i n g Yo u r O w n T e m p l a t e s : P a r t 2 are You experienced? Now You Can… EECreate a drawing template EE the Title Block Manager Use EE the difference between First Angle and Third Angle projections Tell EE a revision table Add EE predefined views Add EESave templates and sheet formats
  7. Chapter 17 Creating Simple, Stunning Renderings  Use the PhotoView 360 User Interface  Create Your First Rendering  Customize Your Rendering Even More  Create Renderings with Depth of Field
  8. 546 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s T hroughout the preceding chapters, you have learned many new skills in SolidWorks that will ensure your success in future designs. If you were to stop reading here, you would be able to create new designs, share them with other users, and even see your designs manufactured. But, you would be missing out one other skill that was previously considered too difficult and time-consuming to be a realistic option. Prior to SolidWorks 2008, photorealistic renderings needed to be created with software packages such as PhotoWorks, Maya, and others. PhotoWorks is a pow- erful rendering program that is fully integrated within the SolidWorks environ- ment. Although very powerful, many users have found the program too complex to be usable for even the simplest of renderings. Luckily, PhotoView 360 was introduced by SolidWorks to take the task of cre- ating photorealistic renderings from the hands of the elite and introduce it to the rest of the SolidWorks community. PhotoView 360 is a slicker, easier-to-use stand-alone application that is included with the SolidWorks Professional and SolidWorks Premium packages. Even though PhotoView 360 sports a simple, easy-to-use interface, it does not skimp on the quality of images that can be created. By the end of this chapter, you will have the skills needed to create some images that can rival those cre- ated with other, more complex rendering software packages. N O t e The 2011 release of PhotoView 360 will include even more tools that were previously available only in PhotoWorks. Subsequently, PhotoWorks will be discontinued after 2011. Use the PhotoView 360 User Interface The advantage of PhotoView 360 over PhotoWorks is its simplicity. Take one look at the user interface, as shown in Figure 17.1, and you will fall in love with its ease of use. Everything that you need in order to create stunning renderings is available in the drop-down menus at the top of the window and three separate toolbars. Without going into too much detail, we will cover what the menu and toolbars contain.
  9. U s e t he P hotoV iew 36 0 U s er Inter face 547 Menus Task Toolbar View Toolbar Selection Toolbar Preview Image F I g U R e 1 7 . 1 PhotoView 360 user interface Menus Just like with almost all Windows-based programs, the drop-down menus at the top of the window provide you with some basic commands, but the majority of operations you will be performing will be through the toolbars. The menu bar is broken down into the following five items: File The File menu contains the commands necessary for opening and closing scenes, as well as loading background images and environments. edit The Edit menu contains the commands to undo the last function and redo the last undo. View The View menu contains the commands to stop or rest the preview in the preview image. All elements that were hidden previously in the preview image can be shown with the Unhide All command. Render The Settings and Render windows can be called from the Render menu. You can also recall the last rendered image and save the current preview image.
  10. 548 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s Help In addition to the providing access to the help file and release notes, you can also view online video tutorials that will walk you through various render- ing tasks in detail. t I p If a keyboard shortcut is available for any of the menu items, it will be displayed to the far right of the menu next to the corresponding command. Tasks Toolbar The Tasks toolbar contains all that is needed to create a rendering. Even if you have never used PhotoView 360 before, you will be able to quickly determine the steps that you need to follow to create a rendering since the buttons in the Tasks toolbar are shown in order that you will use in most cases. We will be covering each one of the following buttons in the process of creating the various render- ings in this chapter: Open File The very first thing that you need to do to create a rendering is open a SolidWorks part or assembly model. The Open File button will display a stan- dard Windows file dialog box. Appearances Clicking the Appearances button will open a new window that contains the entire materials database for PhotoView 360. The Appearances win- dow is then broken down into logical sections based on the material type.
  11. U s e t he P hotoV iew 36 0 U s er Inter face 549 environments Clicking the Environments button will open a new window that contains 28 preset rendering environments that include background images, colors, flooring, and lighting. Settings This opens a new window that gives you access to environment, out- put, and camera settings. Final Render This begins the final rendering in a separate window based on the previously selected settings. gallery This opens the default web browser and takes you to the SolidWorks website where users have previously uploaded images created in PhotoView 360.
  12. 550 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s Help This opens the help file. Selection Toolbar The Selection toolbar allows you to specify how an appearance is applied to the active model in the preview image. Prior to adding an appearance, select how the appearance will be applied, using the following options: Face Selecting Face in the selection toolbar will only apply an appearance to the face directly under the mouse pointer once you release the left mouse button. Body Selecting Body in the Selection toolbar will apply an appearance to the entire solid body. Part Selecting Part in the Selection toolbar will apply an appearance to only one part at a time. Assembly Selecting Assembly in the Selection toolbar will apply one appear- ance to the entire assembly, overwriting any previously applied appearances at the part level. Appearances Selecting Appearances applies a new appearance to all items that share the same appearance. If an appearance was previously applied in SolidWorks, only the items that had their appearances applied in one operation will be selected. View Toolbar The View toolbar provides you with the tools necessary to manipulate the view of the model in the preview image. Even though you may ultimately be relying on your mouse for changing the view, it is sometimes helpful to be able to select the exact view tool you need. Select The Select tool in the View toolbar returns the selection mode. After clicking, the mouse pointer will return to the standard selection arrow.
  13. C r e a t e Yo u r F i r s t R e n d e r i n g 551 Pan This changes the mouse pointer to a group of four arrows pointing in the up, down, left, and right directions. To pan, click and hold the left mouse but- ton and drag the mouse pointer. The model in the preview image will move on a plane parallel to the viewing plane. t I p To pan without selecting the Pan tool in the View toolbar, press and hold the Ctrl button on your keyboard, and then press and hold the mouse wheel button while moving the mouse. Rotate This changes the mouse pointer to a circular arrow and rotates the model in the preview image around the center point of the entire model. To rotate, click and hold the left mouse button and move the mouse in any direction. Zoom This changes the mouse pointer to a magnifying glass and is used to O zoom in and out. The mouse pointer location in the preview image does not To rotate without affect the zoom. selecting the Rotate tool, press and hold the mouse wheel t I p There are a two different ways to zoom in and out without using button while moving the Zoom tool in the View toolbar. First, spinning the mouse wheel up and the mouse. down will zoom in and out. Second, holding the Shift key on the keyboard while pressing and holding the mouse wheel will zoom in and out when you move the mouse up and down. Zoom Window This changes the mouse pointer to a magnifying glass. Click once in the preview image to specify the center point of the zoom window, and when you move the mouse pointer out from the center, a yellow box will be dis- played. When the window is the size that you desire, click and release the left mouse button once again to zoom in on the box drawn. Fit To View Selecting this fits the entire model into the preview image. Create Your First Rendering O Pressing F on the Now that you have a feel for the layout of PhotoView 360, you can dive right into keyboard will also the first rendering. The first image you will be creating in this section is of the cause the model to top-level assembly of the desk lamp. This section will show the minimum num- fit entirely within the ber of steps that are required to create an amazing image. preview image. As we mentioned earlier, the buttons in the Task toolbar are ordered in such a way to mimic the order of operation when creating a rendering. Even the most
  14. 552 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s novice of users will have no problem creating stunning images. As you continue in the chapter, you will then explore more advanced techniques to make your renderings even more stunning. Open a Model Before you can create a rendering, you need to open a model. Since there are no modeling tools in PhotoView 360, the models must first be created in SolidWorks. That includes any additional parts or props that you want to include in the ren- dering. Since you do not need to do anything special at this time, you can open the desk lamp assembly as it is by doing the following: 1. You can open PhotoView 360 in a couple ways. First, you can locate and double-click the PhotoView desktop icon, or you can open the program through the Start menu. To open the program through the Start menu, click Start ➢ All Programs ➢ SolidWorks 2010 ➢ PhotoView 360, as shown in Figure 17.2. F I g U R e 1 7 . 2 Application icon in Start menu 2. Click the Open File button in the Task toolbar, as shown in Figure 17.3, and browse to the location where the assembly of the desk lamp is saved. Select the desk lamp assembly, and click Open. F I g U R e 1 7 . 3 Open File button on the Task toolbar t I p You can also open models in PhotoView 360 by dragging and drop- ping them onto the preview image from Windows Explorer.
  15. C r e a t e Yo u r F i r s t R e n d e r i n g 553 Add Appearances to a Model The term appearances in PhotoView 360 refers to the application of a material look to a face, solid body, part, or assembly. Just like how appearances are shown in RealView in SolidWorks, the appearances do not affect the model in any way other than how it is represented on the screen. PhotoView 360 comes with a fairly large database of material appearances, most of which can also be found in SolidWorks. In fact, an appearance added to a component in SolidWorks will carry over into PhotoView 360, which can be a huge time-saver. Since you already applied some material appearances to the assembly in SolidWorks, you will not need to do it all over again at this point. However, in order to illustrate the process for applying appearances, you will change how the brass components in the assembly will appear. The following steps describe the process for applying appearances: 1. Click the Appearances button in the Task toolbar to view the complete list of appearances available. 2. In the left pane of the Appearances window, click the arrows next to the material directory names to view additional directories in order to further define the material that will be used for the appearance. Click the arrow next to the Metal directory to expand the list, as shown in Figure 17.4. F I g U R e 1 7 . 4 Metal directory in Appearances window 3. Below the parent directory for Metal, select the Brass directory. In the right pane, a variety of brass material buttons will be shown. To change the size of the icons to better fit the available space, move the slider above the material list to the right to make the buttons bigger and to the left to make them smaller, as shown in Figure 17.5.
  16. 554 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s F I g U R e 1 7 . 5 Slider to change the size of the Appearances icons 4. Select the Part button in the Selection toolbar to specify that the material appearance will be applied to the selected part, as shown in Figure 17.6. F I g U R e 1 7 . 6 Part button in the Selection toolbar 5. Select the Brushed Brass button in the Appearances window by clicking and holding the left mouse button with the mouse pointer directly over the material, as shown in Figure 17.7. F I g U R e 1 7 . 7 Brushed Brass icon in Appearances window 6. While continuing to hold the left mouse button, drag the material appearance into the graphics window. Move the mouse pointer to directly above one of the brass components in the assembly. Release the left mouse button, and the parts appearance will update to show the new material.
  17. C r e a t e Yo u r F i r s t R e n d e r i n g 555 7. Continue to add the Brushed Brass material appearance to each of the brash components in the assembly. 8. You can choose to leave the Appearances window open, but to save space on the screen, you can close it by clicking the X in the upper- right corner of the window. You can also toggle the appearance of the window by clicking the Appearances button in the Task toolbar. Change the Scene environment An environment applies to the background, lighting, and floor of the rendering scene. The environment spherically wraps around the model in the preview image and moves relative to the model as it is being rotated. Environments are a great way to take your rendering to the next level with minimal effort. In fact, all that needs to be done to change the scene environment is just a simple drag and drop. Once you locate an environment that you like in the Environment window, just drag and drop it into the preview image, and instantly the scene is updated. The environments available range from a basic solid background with shad- owed or reflective floors to a sunny day in a public square. Each environment has a different effect on the final appearance of the model in a rendering. With some environments, such as the sunny public square, you will also be able to see a reflection of the environment in some of the shinier components. You can use a few options to customize the scene environment, and we will cover some of them later in this chapter. For now you will just select one of the environments and leave it as is. To add an environment to the scene, do the following. N O t e Predefined environments are based on high dynamic range (HDR) or HDRI images. 1. Click the Environments button on the Task toolbar. A new window, much like the Appearances window, will be displayed. 2. Locate the Abstract Studio Shadow environment button. Select the environment by pressing and holding the left mouse button with the mouse pointer on the button, as shown in Figure 17.8. 3. While still holding the left mouse button, drag the environment into the preview image. Once the mouse pointer is anywhere inside the preview image, release the left mouse button.
  18. 556 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s F I g U R e 1 7 . 8 Abstract Studio Shadow environment 4. The Environments window, just like with the Appearances window, can be left open and off the side of the main window. But if you do decide to close the window to save valuable desktop space, you can either click the X in the upper-right corner of the window or toggle the Environments button in the Task toolbar. Create the Final Rendering Now that the appearances have been applied and the environment has been set, you could make additional changes to the final output by adjusting various settings. But this time around, you will continue with the default settings and instead start the final rendering. After you see what the default rendering looks like, you can begin making fine adjustments to the settings to achieve the effect that you are looking for. Later in this chapter, we will cover how to make adjust- ments to the settings of the scene, but for now, the following steps will describe the process for creating the final rendering: 1. Click the Final Render button in the Task toolbar. A new window will be displayed and will immediately begin to create the final render- ing. Orange squares called buckets will jump around the image as the final rendering is built, as shown in Figure 17.9. The number of buckets will depend on the number of cores your processor has. More cores in your CPU means more buckets, which ultimately means faster renderings. 2. To save the new rendering, click the Save Image button near the upper- right area of the Final Render window, as shown in Figure 17.10. 3. Browse to the folder where you want to save the rendered image in the Save Image window.
  19. C r e a t e Yo u r F i r s t R e n d e r i n g 557 F I g U R e 1 7 . 9 Final rendering in process F I g U R e 1 7 . 1 0 Save Image button in the Final Render window 4. Name the new image file Desk Lamp Rendering 1 in the File Name field. Click the Save As Type field to display the list of supported image types, as shown in Figure 17.11. In the list, select the desired file type, and click Save. F I g U R e 1 7 . 1 1 Supported image types for saving renderings
  20. 558 C h a p t e r 17 • C r e a t i n g S i m p l e , S t u n n i n g R e n d e r i n g s 5. To close the Final Render window, click the X in the upper-right cor- ner of the window, or click the Close Window button on the right side of the top pane. N O t e Unlike with the Appearances and Environments windows, click- ing the Final Render button in the Task toolbar will not toggle the window close. Instead, clicking the Final Render button will begin the rendering pro- cess again with the previously selected settings. Customize Your Rendering even More In the previous exercise, we opted to have you generate the final rendering with the default settings. The first time we create a rendering, we always do it without making any adjustments. This allows the first rendering generated to act as a baseline, and after seeing the results, it is easier to determine what changes can be made to make the image created even more spectacular. After seeing the ini- tial result, you can now move on to make some additional changes in the scene. Adjust Appearance Properties After looking at the image created in the previous section, it may be determined that the shade can be made a little bit more transparent. Unfortunately, there is no material appearance that will work for the shade without some adjustments. The following steps will describe the process for adjusting a material appearance to come closer to the final look you need to achieve in the rendering: 1. If you closed the desk lamp assembly from the previous section, click Open File in the Tasks toolbar, and select the assembly in the Load File window. Click Open. 2. Click the Appearances button in the Tasks toolbar. 3. Locate the Thick Gloss directory in the Glass material directory. 4. Click the Part button in the Selection toolbar. 5. Drag and drop the Green Thick Glass button from the Appearances window onto the shade in the preview image.
Đồng bộ tài khoản