Tạo báo cáo tự động trong word từ bảng số liệu của Excel

Chia sẻ: Yukogaru | Ngày: | Loại File: PDF | Số trang:5

1
410
lượt xem
319
download

Tạo báo cáo tự động trong word từ bảng số liệu của Excel

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Khi làm báo cáo bằng Word có sử dụng số liệu từ bảng tính Excel, thường người ta thực hiện 2 công việc: - Công việc A: Nhập số liệu vào bảng Excel để tính. - Công việc B: Mở văn bản Word để cập nhật kết quả tính toán từ Excel (lời văn của báo cáo nói chung không thay đổi là mấy). Việc cập nhật thủ công văn bản Word dễ nhầm lẫn và tốn công khi có nhiều số liệu. Có một cách giúp liên kết tự động dữ liệu từ Excel với văn bản Word để...

Chủ đề:
Lưu

Nội dung Text: Tạo báo cáo tự động trong word từ bảng số liệu của Excel

  1. Thủ thuật Word 2003 Tạo báo cáo tự động trong word từ bảng số liệu của Excel Khi làm báo cáo bằng Word có sử dụng số liệu từ bảng tính Excel, thường người ta thực hiện 2 công việc: - Công việc A: Nhập số liệu vào bảng Excel để tính. - Công việc B: Mở văn bản Word để cập nhật kết quả tính toán từ Excel (lời văn của báo cáo nói chung không thay đổi là mấy). Việc cập nhật thủ công văn bản Word dễ nhầm lẫn và tốn công khi có nhiều số liệu. Có một cách giúp liên kết tự động dữ liệu từ Excel với văn bản Word để bạn chỉ cần làm công việc B một lần, sau đó mỗi khi bạn thực hiện công việc A xong thì Word tự động cập nhật những thay đổi và bạn chỉ việc in báo cáo ra mà không Hình 1: Excel, số liệu kỳ trước dùng phải thực hiện công việc B nữa. cho các báo cáo tháng 07/2005 Ví dụ, chúng ta xem xét báo cáo vận chuyển hành khách của 4 hãng xe HTX, TNHH, QD và CT. Báo cáo mỗi tháng bạn cần đưa vào số liệu của tháng hiện tại và tháng trước đó để so sánh sự tăng giảm. Hiện tại ta cần làm phân tích số liệu tháng 08/2005. Bước 1 (công việc A): Ở H.1 ta đã có sẵn bảng tính Excel với số liệu của kỳ trước (tháng 07/2005) với các công thức để tính tổng số hành khách, tỉ lệ hành khách tăng giảm so với tháng trước... ta chỉ cần nhập vào các số liệu của tháng cần báo cáo, Excel sẽ tự động tính ra các số còn lại. Sau khi nhập xong ta được bảng tính với các số liệu của kỳ hiện tại (tháng 08/2005) như H.2.
  2. Bước 2: Ở H.3 là phân tích số liệu có Hình 2: Excel, số liệu kỳ hiện tại dùng được trong H.1. Điều cần làm là phải sửa cho các báo cáo tháng 08/2005 số liệu của kỳ trước thành số liệu của kỳ này trong bảng phân tích đó (tức là sửa từ H.3 thành H.4). Bây giờ chúng ta sẽ liên kết dữ liệu từ Excel sang Word để các kỳ về sau chỉ cần sửa trong Excel rồi ra lệnh cho Word tự động cập nhật dữ liệu từ Excel sang. Đầu tiên bạn vào bảng tính Excel, copy ô số liệu cần là ô C2 ở H.2 (ô được tô đỏ ở H.2) rồi vào Word đặt con trỏ vào chỗ cần sửa dữ liệu thích hợp (ngay trước con số 272.601 ở H.3). Xóa giá trị 272.601 ở H.3 đi rồi nhấn vào menu Edit > Paste special, bảng Paste special xuất hiện. Bạn chọn Paste link > Unformated Text rồi OK (các thao tác này tạm gọi là Paste link), phần mới được paste vào có giá trị là 273.780 như trong H.4 nhưng phần nền của số 273.780 này có màu xám. Thực hiện giống như vậy ở những số liệu khác cần sửa đổi. (Chú ý khi copy từ Excel phải copy nguyên cả ô chứ không phải chỉ tô đen phần số rồi copy). Chú ý, nếu vùng được Paste link không có màu xám, bạn làm như sau: vào menu Tools > Options, chọn tab View, phần Field shadding chọn Always rồi OK. Riêng đối với những số liệu có thể có giá trị âm hoặc dương và giá trị này ảnh hưởng đến phần lời văn trong văn bản Word cần làm phức tạp hơn một chút. Như phần giảm 44,44% ở H.3: tháng trước giảm 44,44% vì giá trị trong Excel tương ứng là - 44,44 (ở H.1). Tháng này giá trị trong bảng tính Excel là 16,39 (ở H.2), ta phải hiển thị lời văn là Hình 3: Word, phân tích số tăng 16,39% trong Word. Cách làm như sau: đầu liệu của H.1 tiên bạn mở bảng tính Excel (H.2), đối với những cột nào thể hiện sự tăng giảm (ở ví dụ này là cột D và cột E) ta phải tạo thêm 2 cột phụ dùng để thể hiện lời văn cho mỗi cột. Ta làm cho cột D như sau (cột E làm tương tự):
  3. - Chè n thê m2 cột F và G để bổ sung cho cột D như H.5. Trong đó cột F thể hiện dấu của cột D và cột G thể hiện giá trị tuyệt đối của cột D. - Nhập vào ô F2 công thức: =IF(D2=0;"không tăng giảm";IF(D2>0;"tăng ";"giảm ")) Hình 4: Word, phân tích số liệu của H.2 Hàm này xét giá trị của ô D2, nếu =0 thì hiển thị "không tăng giảm", nếu >0 thì hiển thị "tăng ", nếu Select All rồi lại nhấn menu Edit > Links > Update
  4. Now, lập tức dữ liệu được cập nhật từ Excel vào Word. Chú ý, để Word không tự động cập nhật dữ liệu khi mở file: vào menu Tools > Options > General, bỏ chọn ở mục "Update automatic links at Open". Nếu không, mỗi khi bạn mở file Word nào có dữ liệu dạng liên kết thì Word sẽ luôn hỏi có cập nhật dữ liệu hay không rất phiền phức. Chèn nội dung của 1 file.doc đã có vào nội dung file đang mở MS Word: Đôi khi một tài liệu của bạn được nhiều người soạn thảo hoặc làm thành nhiều file khác nhau, và giờ bạn muốn tổng hợp thành 1 file tài liệu. QuanTriMang.com sẽ hướng dẫn bạn chèn nội dung một file văn bản đã có vào nội dung file đang mở. 1. Vào Insert / File… 2. Xuất hiện hộp thoại Insert File:
  5. Tại hộp thoại này bạn hãy chọn đường dẫn (path) và chọn file muốn chèn. 3. Chọn nút Insert (hoặc kích đúp vào file đã chọn) để chèn. Như vậy trong nội dung file văn bản đang mở sẽ có toàn bộ nội dung file văn bản mà bạn vừa chèn. Bạn cũng có thể dùng phương pháp copy và dán (paste) nội dung tài liệu vào những file.doc khác nhau.
Đồng bộ tài khoản