Tạo giao diện trang web với Flash P18

Chia sẻ: Mr Yo Ko | Ngày: | Loại File: PDF | Số trang:9

0
144
lượt xem
73
download

Tạo giao diện trang web với Flash P18

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tham khảo tài liệu 'tạo giao diện trang web với flash p18', công nghệ thông tin, đồ họa - thiết kế - flash phục vụ nhu cầu học tập, nghiên cứu và làm việc hiệu quả

Chủ đề:
Lưu

Nội dung Text: Tạo giao diện trang web với Flash P18

  1. TẠO GIAO DIỆN TRANG WEB VỚI FLASH 5 TẠO LIÊN KẾT ĐẾN CÁC TRANG Sau khi tạo các Scene trong các bài thực hành trước đó, bạn sẽ tạo liên kết các Scene đó lại với nhau để tạo thành một trang Web có liên kết. Trong bài thực hành này bạn sẽ tạo một số liên kết đến một trong các Scene đó và tạo thêm một số scene bổ sung nếu cần thiết. Tạo liên kết đến các trang khác phần 1: Trong các bài tập trước bạn đã tạo ra một số Scene, để thực hành tiếp trên các scene đó. Bạn hãy mở file Trang chu.fla lên để làm việc. Các nút trên một Scene hiện hành, bạn sẽ gán hành động cho nút đó liên kết đến một Scene khác tương ứng với nội dung của Scene đó. Sau đây là cách thực hiện công việc gán một số lệnh cho các nút đó. Bạn có thể tạo ra thêm nhiều nút và liên kết các nút đó đến các Scene và trong từng Scene đều có sự hiện diện của các nút khác. Nhấp vào trình đơn View > Goto, nhấp chọn vào mục TRANG 1 nếu bạn đang ở TRANG CHU. Nhấp nút GIỚI THIỆU và nhấp chọn trên trình đơn Window > Action để hiển thị bảng Object Actions. Nhấp đúp chuột vào lệnh Go To trong danh sách lệnh Basic Action. Các lệnh vừa chọn hiển thị trong khung bên phải của bảng Object Actions như sau: On release { gotoAndPlay (1) ; }
  2. Nhấp tiếp vào vùng Scene bên dưới bảng để chọn TRANG 1. Nhấp chọn tiếp vào vùng lệnh Go to and Play để bỏ chọn dấu kiểm này.
  3. Nhấp trở lại dòng lệnh on (release) { và nhấp chọn vào tùy chọn Press thay vì chọn Release bên dưới bảng Object Actions trong mục Event. Khi đó các dòng lệnh xuất hiện trong bảng này như sau: on (press) { gotoAndStop ("GIOI THIEU", 1); }
  4. Cách liên kết các nút khác làm tương tự như trên cho các nút còn lại. Sau đây là một số mã lệnh cho các nút đó. Mã lệnh cho nút THOÁT: on (press) { gotoAndStop ("THOAT", 1); } Mã lệnh cho nút SÁCH: on (press) { gotoAndStop ("SACH", 1); }
  5. Nếu bạn có nút câu hỏi, thì nút này có mã lệnh là: on (press) { gotoAndPlay ("CAU HOI", 1); } Bây giờ bạn hãy nhấp chọn vào từng Scene có tên tương ứng với các nút đó và gán lệnh Stop cho các frame trong Scene đó. Chẳng hạn như bạn hãy nhấp chuột vào Scene có tên là TRANG 1 và nhấp đúp chuột vào một Layer bất kỳ tại frame thứ nhất để xuất hiện bảng Frame Actions. Nhấp đúp chuột vào lệnh Stop có trong bảng Frame Actions. Khi đó biểu tượng chữ “a” sẽ xuất hiện trên frame của thanh thước Timeline.
  6. Nhấp tiếp vào các Scene khác và thực hiện tương tự như trên để tất cả các Scene đều có lệnh Stop. Bây giờ bạn cần tạo ra một số Scene mới có giao diện giống như Scene GIỚI THIỆU để khi nhấp chuột vào một trong các tên sách trên Scene SÁCH để liên kết đến đúng Scene của tên sách đó. Vào trình đơn Modify > Scene và nhấp chọn vào Scene GIOI THIEU trong bảng Scene. Nhấp nút Duplicate Scene để thêm vào một số Scene có tên như hình dưới:
  7. Bây giờ bạn hãy xóa nội dung trong từng Scene vừa tạo và nhập vào nội dung văn bản mới cho scene tương ứng đó. Dùng công cụ Text Tool để nhập nội dung văn bản cho Scene tương ứng:
  8. Bạn có thể đưa vào một chuỗi ký tự để phân biệt các Scene khác nhau khi bạn chọn đến. Nền “Hướng dẫn sử dụng Flash” xuất hiện bên dưới lớp ký tự Bạn hãy thực hiện tiếp cho các Scene khác cho đến khi hoàn thành.
  9.  
Đồng bộ tài khoản