Tạo giao diện với Flash 5 phần 1

Chia sẻ: Lac Tran | Ngày: | Loại File: PDF | Số trang:10

0
293
lượt xem
151
download

Tạo giao diện với Flash 5 phần 1

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

TẠO GIAO DIỆN CHO TRANG CHỦ Bài tập này hướng dẫn các bạn thiết kế giao diện của một trang Web với Flash 5 như hình. Từ ý tưởng bài tập này các bạn sẽ tự mình thiết kế một giao diện cho riêng mình với phần giao diện bắt mắt hơn cũng như thiết kế trên phiên bản Macromedia Flash mới hơn như Flash MX, Flash MX 2004, Flash 8 v.v. Bài tập được chia làm 7 phần, mỗi phần hướng dẫn tạo từng lớp và chuyển động, sau đó kết hợp lại thành một giao diện hoàn chỉnh....

Chủ đề:
Lưu

Nội dung Text: Tạo giao diện với Flash 5 phần 1

  1. TẠO GIAO DIỆN TRANG WEB VỚI FLASH 5 (PHẦN 1) TẠO GIAO DIỆN CHO TRANG CHỦ Bài tập này hướng dẫn các bạn thiết kế giao diện của một trang Web với Flash 5 như hình. Từ ý tưởng bài tập này các bạn sẽ tự mình thiết kế một giao diện cho riêng mình với phần giao diện bắt mắt hơn cũng như thiết kế trên phiên bản Macromedia Flash mới hơn như Flash MX, Flash MX 2004, Flash 8 v.v. Bài tập được chia làm 7 phần, mỗi phần hướng dẫn tạo từng lớp và chuyển động, sau đó kết hợp lại thành một giao diện hoàn chỉnh. Tạo giao diện cho trang chủ phần 1: Các bước thực hiện: Khởi động Flash 5, khi cửa sổ giao diện Flash 5 xuất hiện chọn Modify > Movie hoặc nhấn phím tổ hợp Ctrl + M xác định kích thước của đoạn phim để diễn hoạt. Trong hộp thoại Movie Properties, nhập giá trị 800 x 600 lần lượt vào trong mục Width và Height trong khung chọn Dimensions của hộp thoại.
  2. Nhấp vào Layer 1 và đặt tên lại là Layer Nen. Bây giờ bạn tiến hành việc vẽ khung màu nền cho giao diện bằng cách nhấp chọn công cụ Rectangle Tool. Chọn hộp màu Fill Color với ô màu chọn như hình dưới. Giá trị màu của vùng màu tô này là #3300CC. Vẽ vào vùng làm việc hình chữ nhật nằm bên trên của vùng làm việc.
  3. Dùng công cụ Zoom Tool để thu nhỏ vùng làm việc lại còn khoảng 60–70 %, khi đó bạn sẽ dễ quan sát vùng làm việc hơn. Vẽ tiếp khung hình chữ nhật đối diện với giao diện vừa thực hiện và có cùng màu Fill Color với màu trên. Khung hình chữ nhật này nằm bên dưới vùng làm việc. Vùng làm việc chính giữa còn lại bạn có thể để màu trắng như mặc định hoặc chọn một ảnh nền từ bên ngoài và chọn trên trình đơn File > Import để nhập ảnh vào.
  4. Nhấp vào nút dấu cộng (+) bên dưới thanh thước Timeline để tạo Layer mới và đặt tên là Layer Chu. Sau đó dùng công cụ Text Tool để nhập chuỗi văn bản như sau vào trong vùng làm việc. Tất cả các chuỗi ký tự đều có màu trắng ngoại trừ chuỗi “CHẾ BẢN VIDEO” là màu vàng và nằm trên các chuỗi độc lập với nhau, xếp thành hai hàng như trong hình.
  5. Chú ý: Bạn có thể nhập các chuỗi ký tự có ý nghĩ khác cũng được không nhất thiết là phải giống như trong hình. Bạn có thể nhập các thuộc tính như trong hình cho các chuỗi ký tự. Bước kế tiếp, bạn tạo một đoạn Movie clip cho vùng chữ hiển thị ở chính giữa giao diện. Nhấp chọn Insert > New Symbol. Hộp thoại Symbol Properties xuất hiện, chọn các thuộc tính như hình dưới: Chọn công cụ Text Tool và nhập vào trong vùng làm việc chuỗi ký tự trong chế độ Movie Clip.
  6. Bây giờ bạn làm chuỗi ký tự này chuyển động theo đường dẫn bằng cách nhấp phải chuột và chọn lệnh Create Motion Tween. Nhấp vào keyframe thứ 60 và nhấn phím F6 để chèn keyframe vào vị trí cuối cùng. Lúc này bạn sẽ thấy xuất hiện mũi tên cho biết đã tạo xong đường chuyển động. Tạo hiệu ứng màu cho chuỗi ký tự này bằng cách: Nhấp vào keyframe thứ 10 và nhấn phím F6.
  7. Sau đó chọn Window > Panels > Effect. Bảng Effect xuất hiện, nhấp chọn nút tam giác trong bảng Effect và chọn tùy chọn hiệu ứng màu Alpha và kéo con trượt trong mục Alpha đạt giá trị 0%. Khi đó bạn sẽ thấy chuỗi ký tự biến mất trên màn hình. Nhấp tiếp vào keyframe thứ 20 và nhấn phím F6. Chọn trong bảng Effect màu Tint và nhấp vào hộp màu Tint Color chọn một ô vuông màu đỏ như trong hình.
  8. Cứ cách nhau 10 keyframe sẽ có hiệu ứng cho chuỗi ký tự, bạn cứ lặp lại các bước trên để tạo hiệu ứng lên chuỗi chữ này cho đến khi kết thúc. Sau khi thực hiện xong, hãy nhấn phím Entrer để xem hiệu ứng xảy ra trên chuỗi ký tự. Nhấp nút Scence1 bên trái biểu tượng Movie Clip để trở về giao diện chính của đoạn phim trong Flash. Khi đó bạn chưa thấy đoạn phim vừa tạo xuất hiện trong vùng làm việc vì vậy hãy chọn trên trình đơn Window > Library để xuất hiện thư viện của file đang làm.
  9. Nhấp vào nút dấu cộng (+) bên dưới layer để tạo mới Layer hoặc bạn cũng có thể chọn trên trình đơn Insert > Layer và đặt tên là Giáo trình. Sau đó bạn kéo biểu tượng Movie clip có tên Giao Trinh vào trong vùng làm việc sao cho đoạn Movie clip này nằm giữa giao diện. Nhấn phím Ctrl + Enter để xem đoạn phim vừa tạo trong chế độ Flash Player.
  10. Đoạn phim đang diễn hoạt trong chế độ Flash Player  
Đồng bộ tài khoản