Tạo giao diện với Flash 5 phần 15

Chia sẻ: Lac Tran | Ngày: | Loại File: PDF | Số trang:9

0
121
lượt xem
54
download

Tạo giao diện với Flash 5 phần 15

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tạo liên kết đến các trang khác phần 2: Sau đó bạn gán một số lệnh liên kết các Scene vừa tạo ra ở trên với các nút trong Scene SACH. Khi đó nhấp chuột vào tên một trong các loại sách ngay Scene SACH, sẽ liên kết đến trang đó. Cách gán lệnh cho nút liên kết đến các Scene, bạn có thể xem lại các bước đã nói ở trên. Cứ mỗi một nút liên kết đến một Scene mang ý nghĩa của nút đó bất kể nút đó ở trong Scene nào. Ví dụ: Khi nhấp nút...

Chủ đề:
Lưu

Nội dung Text: Tạo giao diện với Flash 5 phần 15

  1. TẠO GIAO DIỆN TRANG WEB VỚI FLASH 5 (PHẦN 15) Tạo liên kết đến các trang khác phần 2: Sau đó bạn gán một số lệnh liên kết các Scene vừa tạo ra ở trên với các nút trong Scene SACH. Khi đó nhấp chuột vào tên một trong các loại sách ngay Scene SACH, sẽ liên kết đến trang đó. Cách gán lệnh cho nút liên kết đến các Scene, bạn có thể xem lại các bước đã nói ở trên. Cứ mỗi một nút liên kết đến một Scene mang ý nghĩa của nút đó bất kể nút đó ở trong Scene nào. Ví dụ: Khi nhấp nút sách ở bất kỳ Scene nào cũng sẽ liên kết đến Scene có tên sách. Sau đây là mã lệnh để liên kết giữa các nút đến Scene có tên SACH.
  2. Nhấp chọn trên trình đơn Control > Test Movie để xem đoạn phim diễn hoạt. Sau đó, vào trình đơn File > Save để lưu file.
  3. Trong khi diễn hoạt đoạn phim, bạn sẽ thấy thiếu một số chức năng của một số phần cần thiết. Chẳng hạn như nút thoát, khi người dùng không muốn xem tiếp tại bất kỳ Scene nào đó, họ có thể thoát khỏi chương trình. Vì vậy, lúc này bạn sẽ thêm vào nút thoát này tại mỗi Scene và thêm vào Scene THOAT. Nhấp chuột vào trình đơn Modify > Scene để tạo Scene mới có tên là THOAT. Sau đó bạn tạo vùng giao diện của Scene THOAT như hình sau: Các bước tạo đoạn phim trên cho Scene THOAT như sau: Vào trình đơn Insert > New Symbol và đặt tên cho đoạn phim như trong hình. Nhấp chọn công cụ Oval Tool để vẽ một vòng tròn có kích thước tương đối nhỏ, tô màu gradient cho vòng tròn này.
  4. Tạo đối tượng này chuyển động theo đường dẫn bằng cách nhấp phải chuột tại keyframe thứ nhất và chọn lệnh Create Motion Tween. Nhấp vào frame 60 và nhấn phím F6 để tạo chuỗi chuyển động. Bây giờ bạn hãy đặt tên cho Layer này là Layer Vong Tron và nhấp phải chuột tại vùng tên của Layer để chọn lệnh Add Motion Tween. Khi đó bạn sẽ thấy trên Layer xuất hiện như hình sau:
  5. Chọn công cụ cây viết chì (Pencil Tool) để vẽ vào đường dẫn hình xoắn ốc trên Guide Layer Vong Tron. Chọn công cụ Arrow Tool để hiệu chỉnh các đường vẽ này cho tương đối uyển chuyển. Nhấp vào đối tượng vòng tròn, kéo đối tượng này đến vị trí đầu tiên của đường cong vừa vẽ.
  6. Nhấn phím Enter để xem đoạn phim vừa diễn hoạt. Lúc này, bạn sẽ thấy đối tượng chuyển động bám theo đường dẫn vừa tạo. Nhấp vào keyframe cuối cùng, dùng công cụ Scale của công cụ Arrow Tool và kéo lớn đối tượng vòng tròn này. Nhấn phím Enter một lần nữa để xem đối tượng chuyển động.
  7. Tạo Layer mới có tên là Layer Duong Ke và nhấp phải chuột tại keyframe cuối cùng (keyframe 60) để chọn lệnh Insert Keyframe. Dùng công cụ Oval Tool để vẽ tiếp vòng tròn giống như vòng tròn vừa vẽ ở trên. Nhấp chọn vòng tròn vừa vẽ và di chuyển vào giữa tâm của vòng tròn trước đó.
  8. Dùng công cụ Line Tool để vẽ vào dấu cộng (+) bên trên đối tượng vòng tròn của Layer Duong Ke. Nhấp công cụ tô màu Fill Color và chọn một màu để tô vào trong góc một phần tư thứ nhất (¼) của vòng tròn. Sau đó chọn một màu tô khác để tô góc đối diện.
  9.  
Đồng bộ tài khoản