Tạo giao diện với Flash 5 phần 4

Chia sẻ: Lac Tran | Ngày: | Loại File: PDF | Số trang:13

0
118
lượt xem
75
download

Tạo giao diện với Flash 5 phần 4

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Tạo giao diện cho trang chủ phần 6: Bây giờ bạn hãy sắp xếp các đối tượng instance trong thư viện để dễ quan sát bằng cách tạo ra các thư mục và đặt từng loại instance vào thư mục đó. Chẳng hạn như bạn tạo ra thư mục Graphics để chứa tất cả các instance đều là graphic và tương tự cho Movie Clip và Button. Nhấp chọn biểu tượng thư mục New Folder bên dưới cửa sổ thư viện để tạo mới thư mục. Đặt tên cho thư mục rồi nhấn phím Enter. Nhấp chọn vào từng instance nào...

Chủ đề:
Lưu

Nội dung Text: Tạo giao diện với Flash 5 phần 4

  1. TẠO GIAO DIỆN TRANG WEB VỚI FLASH (PHẦN 6) Tạo giao diện cho trang chủ phần 6: Bây giờ bạn hãy sắp xếp các đối tượng instance trong thư viện để dễ quan sát bằng cách tạo ra các thư mục và đặt từng loại instance vào thư mục đó. Chẳng hạn như bạn tạo ra thư mục Graphics để chứa tất cả các instance đều là graphic và tương tự cho Movie Clip và Button. Nhấp chọn biểu tượng thư mục New Folder bên dưới cửa sổ thư viện để tạo mới thư mục. Đặt tên cho thư mục rồi nhấn phím Enter. Nhấp chọn vào từng instance nào bạn muốn đưa vào thư mục và kéo nó đến thư mục đó.
  2. Bây giờ đến phần khó nhất và cũng làm lâu nhất trong các phần của đoạn phim là cách tạo ra đoạn phim cho chuỗi ký tự “CHẾ BẢN VIDEO”. Chọn trình đơn Insert > New Symbol để tạo một Movie Clip mới có thuộc tính như sau: Chọn công cụ Text Tool để nhập vào chuỗi ký tự “CHẾ BẢN ĐIỆN TỬ”, các thuộc tính cho ký tự bạn có thể xem như hình. Chú ý: Bạn nên chọn màu cho ký tự trùng với màu nền để khi diễn hoạt không thấy được vùng màu nền. Để thực hiện được điều này, bạn hãy chọn màu nền là một màu khác, sau khi tô màu cho lớp ký tự xong, chọn lại màu khác. Hoặc bạn có thể chọn màu khác màu nền sau đó xóa lớp màu nền của lớp ký tự đi. Bây giờ bạn hãy chọn màu nền Background là màu đen bằng cách chọn trên trình đơn Modify > Movie.
  3. Trong hộp thoại Movie Properties, nhấp vào hộp màu bên cạnh mục Background Color và chọn màu xám hoặc đen. Sau khi chọn xong nhấp OK. Do nền màu xám hoặc đen vì vậy bạn dùng công cụ Text Tool nhập vào chuỗi ký tự màu trắng và chọn font chữ có kích thước lớn như font VNI-Bodon Poster với kích thước là 50. Ghi chú: Vì lý do kỹ thuật in ấn, nhằm muốn minh họa ảnh cho rõ ràng nên màu trong ví dụ trên ký tự minh họa có hơi khác, mong các bạn chú ý.
  4. Nhấp chọn trình đơn Modify > Break Apart để tách ký tự thành từng đối tượng riêng biệt. Nhấn phím F6 để thêm một keyframe, bây giờ trên thanh thước Timeline có hai keyframe. Nhấp chọn công cụ Brush Tool.
  5. Chọn tiếp vào công cụ Brush Size để chọn kích thước cọ vẽ. Và công cụ Brush Shape để chọn hình dáng cọ vẽ. Điều quan trọng là bạn hãy nhấp chọn nút Brush Mode để chọn chế độ cọ vẽ là Paint Inside nhằm xác định được màu tô chỉ nằm chọn trong vùng ký tự, không lan ra ngoài cho dù bạn tô lem ra ngoài. Nếu trong khi tô màu mà vùng màu tô lem ra bên ngoài ký tự đang tô, bạn phải thực hiện lại thao tác đó. Để bạn tô vùng màu không bị lem ra bên ngoài, bạn hãy tô từ trong ra ngoài trên vùng cần tô đó. Nhấp chọn vào nút Brush Mode để chọn kiểu cọ vẽ
  6. Nhấp chọn hộp màu Fill Color và chọn một màu để tô lên chuỗi ký tự như trong hình. Bây giờ bạn sẽ tiến hành tô ký tự đầu tiên, điều quan trong cần nhớ là khi bạn viết ký tự đó như thế nào thì trong khi tô màu cũng phải tô theo hướng như đã viết đó. Tô từ bên trong ký tự ra bên ngoài ký tự để vùng màu tô sẽ không bị tràn ra ngoài nếu không bạn phải thực hiện lại bước này vì màu tô tràn và lem ra ngoài vùng ký tự. Bạn có thể dùng công cụ Zoom Tool để phóng lớn chuỗi ký tự giúp cho việc tô màu dễ dàng hơn.
  7. Bây giờ đắt đầu tô màu cho ký tự đầu tiên trên keyframe thứ hai, bạn có thể chia một ký tự ra làm nhiều lần để tô (có thể là 2 hoặc 3 lần) của ký tự C. Nhấp chọn công cụ Arow Tool và nhấp vào vùng màu vừa tô, sau đó nhấn tổ hợp phím Ctrl + G để nhóm vùng màu vừa tô lại.
  8. Bây giờ, hãy nhấp vào keyframe thứ 5 và nhấn phím F6 để thêm keyframe vào. Do bạn muốn tô một ký tự làm hai lần nên chọn khoảng cách keyframe cách nhau 3 frame như vậy giúp cho công việc tô nhanh hơn. Nếu không bạn tô màu rất lâu nếu chọn từng frame và mỗi lần tô chỉ một chút màu trên ký tự đó.
  9. Nhấp chọn tại một vùng trống để bỏ chọn và chọn lại công cụ Brush Tool sau đó chọn lại màu tô như trong bước trước đó. Bây giờ tiến hành tô phần còn lại của ký tự C. Chọn lại công cụ Arrow Tool và nhấp vào vùng màu vừa tô, nhấn tổ hợp phím Ctrl + G để nhóm vùng màu tô lại. Nhấp chuột vào keyframe thứ 7 và nhấn phím F6. Chú ý không tô màu trên keyframe này do bạn bắt đầu tô màu sang ký tự mới. Mỗi khi tô màu sang một lớp ký tự khác, bạn phải bỏ trống 2 keyframe để lúc đó bạn có thể di chuyển ngòi bút đặt trên ký tự mới trước khi ký tự đó hiển thị.
  10. Nhấp chọn keyframe thứ 10 và nhấn phím F6 để thêm keyframe và bắt đầu tô ký tự H. Cũng chia ký tự H ra làm ba lần tô màu. Chú ý: Bạn có thể chia một ký tự ra làm nhiều đoạn để tô màu nhiều lần. Khi đó số frame bạn chọn sẽ nhỏ hơn (các vùng tô màu lúc đó chỉ cách nhau một frame) và khi diễn hoạt vùng màu tô sẽ di chuyển chậm hơn làm cho vùng ký tự chuyển động sắc nét hơn.
  11. Một phần ký tự sau khi tô màu Chú ý: Nếu bạn tô màu mà bị lem ra khỏi lớp ký tự, lúc đó bản phải chọn lệnh Undo (chọn trên trình đơn Edit) và tô lại phần màu đó. Chọn vào vùng màu tô bằng công cụ Arrow Tool sau đó nhấn tổ hợp phím Ctrl + G. Nhấp chuột vào keyframe thứ 13 và nhấn phím F6 sau đó tô phần nằm ngang của ký tự H, chọn và nhóm vùng màu vừa tô này lại. Nhấp chuột vào keyframe thứ 15 và nhấn phím F6 sau đóø tô phần còn lại của ký tự H, tiếp tục chọn và nhóm vùng màu tô.
  12. Nhấp chuột vào keyframe thứ 18 và nhấn phím F6, hai keyframe này bỏ (không cần tô màu do phải tô màu sang vùng ký tự mới). Nhấp chọn vào keyframe thứ 21 và nhấn phím F6, tô màu trên ký tự Ê và nhóm vùng màu vừa tô. Chú ý: Trong khi tô màu cho ký tự, bạn viết nhứ thế nào thì khi tô màu cũng theo hướng đó và tô màu từ trong ra ngoài nếu không vùng màu tô sẽ bị lem tràn ra ngoài ký tự. Nhấp chuột vào keyframe thứ 24 và nhấn phím F6, tô màu vùng trên của ký tự Ê và nhóm vùng màu tô.
  13. Bạn cứ lặp lại thứ tự theo các bước trên cho đến khi tô màu hết chuỗi ký tự. Sau khi bạn tô màu xong, số keyframe của bạn trên thanh thước Timeline nằmkhoảng keyframe 115 đến 120. Tùy thuộc vào số frame bạn chọn là nhiều hoặc ít.  
Đồng bộ tài khoản