THÍ NGHIỆM MÔ PHỎNG MẠCH ĐIỆN TỬ

Chia sẻ: Nguyen Van Minh | Ngày: | Loại File: DOC | Số trang:6

0
287
lượt xem
85
download

THÍ NGHIỆM MÔ PHỎNG MẠCH ĐIỆN TỬ

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Sử dụng Schematics kết hợp với PSpice và Probe trong phần mềm Design Center 5.4, bài thí nghiệm này giúp cho sinh viên có thể mô phỏng trên máy tính mạch khuếch đại CE. Dựa trên các kết quả phân tích và Probe xác định: 1. Tổng trở vào và ra. 2. Độ lợi điện áp, độ lợi công suất. 3. Quan hệ pha giữa tín hiệu vào và ra. 4. Đáp ứng tần số và băng thông.

Chủ đề:
Lưu

Nội dung Text: THÍ NGHIỆM MÔ PHỎNG MẠCH ĐIỆN TỬ

  1. PHẦN II: THÍ NGHIỆM MÔ PHỎNG MẠCH ĐIỆN TỬ Bài 1: MÔ PHỎNG MẠCH KHUẾCH ĐẠI E CHUNG A. MỤC ĐÍCH Sử dụng Schematics kết hợp với PSpice và Probe trong phần mềm Design Center 5.4, bài thí nghiệm này giúp cho sinh viên có thể mô phỏng trên máy tính mạch khuếch đại CE. Dựa trên các kết quả phân tích và Probe xác định: 1. Tổng trở vào và ra. 2. Độ lợi điện áp, độ lợi công suất. 3. Quan hệ pha giữa tín hiệu vào và ra. 4. Đáp ứng tần số và băng thông. B. TÓM TẮT LÝ THUYẾT - Xem tóm tắt lý thuyết bài Mạch Khuếch Đại E Chung (phần cứng). - Tìm hiểu phần mềm Design Center Eval 5.4 trong giáo trình Mạch Điện Tử 1 - Lê Tiến Thường, phần phụ lục D trang 230. - Các bước tiến hành mô phỏng mạch: I. Vẽ sơ đồ mạch trong Schematics Editor   1. Khởi động Shematics - tạo một sơ đồ mới   Mở phần mềm Design Center 5.4, khởi động Shematics bằng cách dùng chuột double-click vào icon Shematics ta sẽ có một trang trắng để vẽ sơ đồ. ồ Muốn tạo một sơ đồ mới vào menu File / chọn New. ọ Muốn mở một sơ đồ đã có sẵn vào menu File / chọn Open. 2. Lấy các linh kiện và đặt vào sơ đồ mạch   Để lấy các linh kiện ấn Ctrl-G hoặc mở menu Draw / chọn Get New Part, xuất hiện Add Part dialog box. Nếu biết tên linh kiện cần tìm đánh thẳng tên linh kiện vào, rồi chọn OK. Nếu không biết tên linh kiện chọn Browse, Get Part dialog box xuất hiện, chọn thư viện chứa linh kiện cần tìm ở phần danh sách thư viện (Library), chọn linh kiện cần tìm ở danh sách bên trái (chứa tên các linh kiện có trong thư viện tương ứng), rồi chọn OK hay đánh ENTER. Một số linh kiện thường dùng Part name Library Điện trở R analog.slb Biến trở R_var analog.slb Tụ điện C analog.slb Cuộn dây L analog.slb Transistor NPN Q2N2222 eval.slb Transistor PNP Q2N2907A eval.slb Diod D1N4148 eval.slb Diod Zenner D1N750 eval.slb Opamp UA741 eval.slb Nguồn áp SIN VSIN source.slb Nguồn áp DC VSRC source.slb Analog ground AGND port.slb Sau khi chọn linh kiện xong, cursor có hình linh kiện đã chọn. Di chuyển cursor đến vị trí cần đặt rồi click phím trái của chuột để đặt linh kiện. Muốn đặt thêm linh kiện 27
  2. vừa chọn vào một vị trí khác, ta chỉ việc di chuyển cursor đến vị trí cần đặt và click phím trái của chuột. Để kết thúc việc đặt click 1 lần phím phải của chuột. Để quay linh kiện 900 ấn Ctrl-R (Rotate) Để có ảnh đối xứng gương ấn Ctrl-F (Flip) Đặt tên, giá trị và các thuộc tính cho các linh kiện: muốn đặt tên cho linh kiện dùng chuột double-click vào nhãn của nó, xuất hiện dialog box là Edit Reference Designater, đánh tên linh kiện vào phần Package Reference Designator, xong chọn OK. Muốn đặt giá trị cho linh kiện ví dụ R, C, L double-click vào linh kiện, điền giá trị vào phần VALUE. - Biến trở R_var có giá trị R=VALUE*SET + 0.001, khi đặt giá trị cho biến trở phải đặt giá trị cho VALUE và SET. - Nguồn áp VSIN: đặt các giá trị cho các tham số sau DC=(để trống) AC=biên độ của tín hiệu được sử dung khi phân tích tần số(phân tích AC) voff=0 vampl=biên độ của tín hiệu được sử dụng khi phân tích quá độ freq=tần số của tín hiệu td=0 df=0 phase=0 - Nguồn áp một chiều VSRC: đặt giá trị cho các tham số sau DC=giá trị nguồn 1 chiều AC=(để trống) tran=(để trống) Một số lưu ý khi đặt giá trị: Cách kí hiệu đơn vị (cho điện trở, tụ điện, điện áp, dòng điện, tần số …) f(femto)=10-15 u(micro)=10-6 MEG(mega)=106 -12 -3 p(pico)=10 m(mili)=10 G(giga)=109 n(nano)=10-9 K(kilo)=103 T(tera)=1012 Các kí hiệu trên đều như nhau đối với chữ hoa và chữ thường. Ví dụ: R1 có giá trị 18k tức là18 kilo Ohm. C3 có giá trị 100u tức là 100 micro Fara. Nguồn V1 có giá trị 2 tức là 2 Volt. Nguồn I2 có giá trị 30m tức là 30mili Amper. Tần số f có giá trị 1 MEG tức là 1 mega Hz 28
  3. 3. Nối dây giữa chân các linh kiện ệ Để nối dây giữa các linh kiện ấn Ctrl-W hoặc mở menu Draw / chọn Wire ọ Cursor có hình bút chì, click phím trái để bắt đầu vẽ. ẽ Di chuyển chuột để kéo dài dây nối. ố Click phím trái của chuột để tạo một góc vuông, và tiếp tục vẽ. ẽ Double click phím trái để kết thúc nối dây đồng thời kết thúc luôn chế độ nối dây. * Để đánh dấu những điểm muốn xem trên mạch khi đã chạy PSpice và Probe vào menu Markers của Schematics / chọn Mark Voltage / level. 4. Cất sơ đồ ồ Chọn File / Chọn Save ọ Đánh tên sơ đồ vào phần tên file của dialog box. ủ Chọn OK II. Chạy PSpice để mô phỏng mạch   1.  Chọn chế độ phân tích (Analysis / Setup … ) Trước khi chạy PSpice và Probe trong Shematics, tùy thuộc vào yêu cầu bài thí nghiệm phải chọn chế độ phân tích thích hợp (DC, AC, Transient …), có nhiều chế độ phân tích nhưng các bài thí nghiệm chủ yếu sử dụng phân tích AC (AC Sweep) và phân tích quá độ (Transient). ộ Để xác định đáp ứng tần số của mạch vào menu Analysis của Shematics / chọn Setup, xuất hiện Analysis Setup dialog box, kích chuột vào AC Sweep để cài đặt như sau: + Trong AC Sweep Type chọn Decade. + Trong Sweep Parameters đặt giá trị cho các thông số : - Pts/Decade (số lượng điểm tính toán trong 1 Decade, giá trị mặc nhiên là 101) - Start Freq (tần số khởi đầu thường chọn là 1, chú ý phải khác 0) - End Freq (tần số kết thúc) Đáp ứng tần số được tính toán khi nguồn có tần số quét từ tần số khởi đầu đến tần số kết thúc. + Nhấn chuột vào nút OK để thoát về Analysis Setup dialog box. Trong Analysis Setup dialog box nhấn chuột vào ô vuông nhỏ bên trái mục AC Sweep. Nhấn OK để kết thúc cài đặt hoặc chọn những phân tích khác. ữ Để xác định đáp ứng quá độ của mạch (Xác định dòng điện, điện áp tại tất cả các điểm trong mạch theo thời gian) vào menu Analysis / chọn Setup, sau đó kích chuột vào Transient để cài đặt như sau: + Print Step: bước in các điểm của đáp ứng. + Final Time (thời gian kết thúc): chọn giá trị gấp 2-3 lần chu kỳ tín hiệu. + Nhấn chuột vào nút OK để thoát về Analysis Setup dialog box. Nhấn chuột vào ô vuông nhỏ bên trái mục Transient. Nhấn OK để kết thúc cài đặt hoặc chọn những phân tích khác. 2. Chạy PSpice và Probe Sau khi cài đặt các chế độ phân tích, để chạy PSpice nhấn phím F11 hoặc vào menu Analysis / chọn Run PSpice. Sau khi mô phỏng xong Probe sẽ được chạy tự động. Nếu không, có thể chạy Probe trong Shematics bằng cách vào menu Analysis / chọn Run Probe hoặc trước khi chạy PSpice vào menu Analysis / chọn Probe Setup, trong Auto-run Option / chọn Automaticcally Run Probe After Simulator. 29
  4. Dựa vào Probe để xem đáp ứng tần số hoặc quá độ tại tất cả các điểm trong mạch. Vào menu Plot / chọn AC để xem đáp ứng tần số hay chọn Transient để xem quá độ. Sau khi chạy Probe, sẽ xuất hiện đồ thị của những điểm đã được đánh dấu trên mạch (Đánh dấu bằng cách vào menu Markers của Schematics / chọn Mark Voltage/level). Để xem đồ thị tại những điểm khác vào menu Trace của Probe / chọn Add, xuất hiện 1 danh sách các điểm trong mạch, chọn các điểm cần xem, xong chọn OK. Để xác định giá trị tại một vị trí trên đồ thị vào menu Tools của Probe / chọn Cursor / chọn Display. Muốn xem các kết quả chi tiết khác vào menu Analysis của Schematics / chọn Examine Output hoặc vào menu File của PSpice / chọn Examine Output. 3. Sửa sai: Trong Shematics nếu vẽ sơ đồ bị sai, bị hở mạch hoặc cài đặt các giá trị, thuộc tính các linh kiện sai, không đầy đủ thì khi chạy PSpice sẽ báo error: “ ERC : Netlist / ERC errors - netlist not created ”. Sau khi nhấn OK sẽ xuất hiện Error list liệt kê các lỗi sai, sửa các lỗi sai này trong Shematics và chạy lại PSpice. Nếu cài đặt các chế độ phân tích sai hoặc mô phỏng sai ở linh kiện nào đó thì khi chạy PSpice sẽ báo sai trong Shematics là “ (Simulation error) Part: tên linh kiện bị sai” và trong PSpice báo " Circuit has errors … run aborted See output file for details " Vào output file xem các lỗi sai bằng cách: + Trong PSpice vào menu File / Chọn Examine Output. + Hoặc trong Shematics vào menu Analysis / Chọn Examine Output. Sửa các lỗi sai này và chạy lại PSpice. 30
  5. C.  TRÌNH TỰ THÍ NGHIỆM Hình 1 Tổng trở vào 1. Dùng Schematics vẽ sơ đồ mạch như hình 1, cài đặt giá trị cho các linh kiện   trong mạch, chỉnh biến trở VR ≥ 100KΩ . 2. Tín hiệu đầu vào Vin là tín hiệu sin tần số 1KHz, biên độ được chọn sao cho tín   hiệu ra không bị méo dạng (nên chọn cở mV). 3. Vào menu Analysis / chọn Setup / cài đặt 2 chế độ phân tích là AC Sweep và   Transient (như đã giới thiệu trong phần tóm tắt lý thuyết) Với AC Sweep đặt các tham số sau: + Trong AC Sweep Type chọn Decade. + Trong Sweep Parameters đặt giá trị cho các thông số : - Pts/Decade:101 - Start Freq: 1 - End Freq: 10MEG Với Transient đặt các tham số sau: + Print Step: 0.03m + FinalTime : 3m (vì tần số tín hiệu vào là 1KHz nên chu kì là 1ms, do đó chọn thời gian kết thúc gấp 2-3 lần chu kì tín hiệu ) Vào menu Analysis / chọn Run PSpice để mô phỏng mạch. 4. Sau khi Probe được khởi động / chọn Transient (hoặc vào menu Plot của   Probe / chọn Transient) để xác định giá trị điện áp đỉnh đỉnh của Vin, và giá trị dòng điện đỉnh đỉnh của iin (tức là dòng điện qua C1) V Rin = in 5. Tính   iin Tổng trở ra 31
  6. 6. Điều chỉnh biến trở VR ≥ 100KΩ, xác định Vout. Điều chỉnh biến trở VR thỏa:   100Ω ≤ VR ≤ 10KΩ, xác định iVR. V Z = out 7. Tính   i VR . Chứng minh rằng tổng trở ra R = Z - VR. out Độ lợi điện áp và độ lợi công suất. 8. Điều chỉnh biến trở VR ≥ 100KΩ, dựa vào Probe quan sát tín hiệu Vin, Vout, xác   định độ lợi điện áp và độ lợi công suất (decibel) của mạch. Quan hệ pha giữa tín hiệu vào và ra. 9. Dựa vào Probe quan sát tín hiệu Vin, Vout , xác định quan hệ pha của nó.   Đáp ứng tần số và băng thông. 10.  Vào menu Plot của Probe / chọn AC, vẽ đáp ứng tần số và xác định băng thông của mạch. 32

CÓ THỂ BẠN MUỐN DOWNLOAD

Đồng bộ tài khoản