Thiết kế flash với flash cs5 part 86

Chia sẻ: Mr Yukogaru | Ngày: | Loại File: PDF | Số trang:7

lượt xem

Thiết kế flash với flash cs5 part 86

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Quản lý tập tin dự án Một dự án là tập hợp các tập tin mà bạn có thể quản lý trực tiếp từ Flash. Dự án Bảng điều hiển thị tập tin bằng cách mở rộng tên tập tin. Theo mặc định, bảng dự án chỉ hiển thị văn bản dạng Flash (FLA, SWF, SWC, AS, JSFL, ASC, MXML). Nếu bạn muốn hiển thị các loại khác, bạn có thể thay đổi thiết lập trong Preferences Panel.

Chủ đề:

Nội dung Text: Thiết kế flash với flash cs5 part 86

  1. Managing Project A project is a collection of files that you can manage directly from Flash. The Project panel displays files by filename extension. By default, the Files Project panel only shows Flash documents type (FLA, SWF, SWC, AS, JSFL, ASC, MXML). If you want to display other types, you can change settings in Panel Preferences. You can also hide files or folder by pre- ceding the file or folder name with a special character, such as an underscore, and enabling the option in Panel Preferences. When you work with the same project, the Project Panel shows all recently opened files in the Recent Files folder for easy access. You can create files, including Flash and ActionScript, from the Project panel. Manage Project Files 1 1 Click the Window menu, point to Other Panels, and then click Project to open the Project panel. 2 Manage files using any of the Options menu following options: ◆ Create File. Select the folder where you want the file (no selection is the root), click the New File button, enter a name, select a file type, and then click Create File. ◆ Open File. Double-click the file in the Project panel. Delete button ◆ Delete File. Select the file, click New File button the Delete button, and then click Yes to delete a selected 3 project asset. ◆ Publish. Select or clear the file check box on the right to add or remove the file to/from the Options menu publishing list. ◆ Pin a Directory. Select a folder, and then click the Pin Directory button; click again to unpin. 3 Click the Close button on the Project panel. Panel Preferences Did You Know? You can clear the Recent Files list. In the Project panel, click the Options menu, and then click Clear Recent Files. 518 Chapter 21
  2. Change Project Properties 2 1 In the Project panel, click the Options menu, and then click Project Properties. 1 2 Click any of the following tabs: ◆ Classes. Specify the ActionScript version, and class file folder locations. ◆ Locations. Specify additional source folder locations. ◆ Paths. Specify the location Flex SDK files for use in Flash to create skins and other visual elements in Flex. 3 Click OK. 3 Change Panel Preferences 2 1 In the Project panel, click the Options menu, and then click Panel Preferences. 1 2 Click any of the following tabs: ◆ Classes. Specify the ActionScript version, and class file folder locations. ◆ Settings. Change defaults filters, hide files or folders based on the name, and show or hide classes folder, hidden files, or recent files. ◆ Locations. Specify additional source folder locations. 3 Click OK. 3 Chapter 21 Working with Projects and Other Programs 519
  3. Testing a Project A project is a collection of files that constitute a complex project. For example, you can create a Flash project that contains 5 Flash docu- ments, with interactive buttons on the pages to call the other pages. If all of the FLA files are located within the same project, it's an easy mat- ter to test the entire project. You must first select one of the files as the main file, and then simply click the Test Project button. Flash will auto- matically publish all of the Flash documents in the project, display the main file, and then allow you to test its operation. It's that simple. Test a Project 1 2 1 Click the Window menu, point to Other Panels, and then click Project to open the Project panel. 2 If the project you want to test is not open, click the Project list arrow, click Open Project in the Project panel, and then select the appropriate file. 3 Click Open. 5 IMPORTANT Since testing a project involves moving among different Flash movies, your published documents will have to 6 4 have interactive buttons linked to all the other pages within the project, or the test will not work. 4 Right-click (Win) or Control-click (Mac) one of the FLA or HTML files in the project. 5 Click Make Default Document from the available options. 6 Click Test Project. See Also See Chapter 17, “Debugging a Movie” on page 409 for more information on Project how to perform debugging operations comes up to test. on a running Flash movie. 520 Chapter 21
  4. After you finish making changes to a document, you can quickly send it Sending a Document to another person for review using e-mail. Flash allows you to send Using E-Mail documents out for review as an attachment using e-mail from within the program so that you do not have to open your e-mail program. An e-mail program needs to be installed on your computer before you begin. When you send your document out for review, reviewers can add comments and then send it back to you. Send an Office Document Using E-Mail 4 1 Click the File menu, and then click Send. ◆ If prompted, click Yes to save your Flash document. IMPORTANT To complete the 2 following steps, you need to have an e-mail program installed on your computer and an e-mail account set-up. 3 Your default e-mail program opens with your document attached. 2 Enter your recipients and subject (appears with document name by default). 3 Enter a message for your reviewer with instructions. 4 Click the Send button. Chapter 21 Working with Projects and Other Programs 521
  5. Exploring CS Live Adobe CS Live (New!) is an online service that allows you to set up or manage (sign in and out) an Adobe account, review CS5 documents Services (Illustrator, InDesign, and Photoshop) online, access the subscription-based Web site or the Adobe ConnectNow Web site where you can collaborate with others, display CS news and resources in a panel within CS5 programs, and access an Adobe Web site with information about CS Live Services. You can access these options directly from the CS Live menu on the right side of the menu bar next to the Search bar. When the CS Live menu icon includes a bulls eye, you are signed in to the online services. Explore CS Live Services 1 Signed in to CS Live online 1 Click the CS Live menu (New!), and then select any of the following commands: ◆ Set Up Your Access To Adobe CS Live Online Services, Sign In, or Sign Out. Select to set up, sign in, or sign out of the CS Live online service. ◆ Create New Review or Learn More. Creates a CS5 document review in Illustrator, InDesign, or Photoshop. ◆ Home. Opens the subscription-based Web site that allows you to work and collaborate with others. ◆ Share My Screen. Opens the Adobe ConnectNow Web site Sign In to Adobe CS Live where you can start an online meeting and collaborate on any design project across platforms and programs. ◆ CS News and Resources. Opens the CS News and Resources panel with news and resources from Adobe. ◆ Manage My Account. Opens a secure Web site with your Adobe account information after you sign in. ◆ Explore CS Live Services. Opens an Adobe Web site that describes CS Live Services. 522 Chapter 21
  6. Sharing My Screen The Share My Screen command on the File or CS Live (New!) menu allows you to connect to Adobe ConnectNow, which is a secure Web site where you can start an online meeting and collaborate on any design project across platforms and programs. You can share and annotate your computer screen or take control of an attendee’s com- puter. During the meeting, you can communicate by sending chat mes- sages, using live audio, or broadcasting live video. In addition, you can take meeting notes, and share files. Share My Screen 1 Click the File or CS Live menu, and then click Share my screen. 2 Enter your Adobe ID and password. ◆ If you don’t have an Adobe ID 2 and password, click the Create a Free Adobe ID link, and then follow the online instructions. 3 Click Sign In. ◆ If prompted, sign in to ConnectNow. 4 To share your computer screen, click the Share My Computer 3 Screen button. 5 Use the ConnectNow toolbar to do any of the following: 5 ◆ Meeting. Use to invite participants, share my computer screen, upload a file, share my webcam, set preferences, end a meeting, and exit Adobe ConnectNow. ◆ PODS. Use to show and hide pod panels. ◆ Help. Use to get help, troubleshoot problems, and set account and Flash Player settings. 6 Click the participant buttons at the bottom to specify roles, remove a user, or request control of a user’s computer. 6 Chapter 21 Working with Projects and Other Programs 523
  7. Using Adobe The Adobe Extension Manager is a program you can use to install and delete added program functionality, known as extensions, to many Extension Manager Adobe programs. The Extension Manager is automatically installed when you install Flash, Dreamweaver, InDesign, or Fireworks. You can use the Extension Manager to access the Adobe Exchange site, where you can locate, research, and download many different types of exten- sions. Some are free and some are not. After you download an exten- sion, you can use Extension Manager to install it. Extension Manager only displays extensions installed using the Extension Manager; other extensions installed using a third-party installer might not appear. After you install an extension, you can find and display information about it. Download and Install an Extensions for the Extension selected CS program 4 2 7 1 Start Adobe Extension Manager from the Start menu (Win) or the Applications folder (Mac). TIMESAVER In Flash, Dreamweaver, InDesign, or 6 Fireworks, click the Help menu, and then click Manage Extensions. 2 Click the Exchange button on the toolbar. 3 Select the extension you want to download, and then save it to your computer. 4 In Extension Manager, click the Install button on the toolbar. 5 Locate and select the extension Adobe CS programs (.mxp) you want to install, and then click Install. 6 You can perform any of the following: Downloaded ◆ Sort. Click a column heading. extension ◆ Enable or Disable. Select or clear the check in the Enabled check box next to the extension. ◆ Remove. Select the extension, and then click Remove. 7 When you’re done, click the Close button in the Extension Manager window. 524 Chapter 21
Đồng bộ tài khoản