Tổng quan về vi điều khiển, chương 15

Chia sẻ: Minh Anh | Ngày: | Loại File: PDF | Số trang:5

0
241
lượt xem
145
download

Tổng quan về vi điều khiển, chương 15

Mô tả tài liệu
  Download Vui lòng tải xuống để xem tài liệu đầy đủ

Chương trình chạy không cần cài đặt, khởi động chương trình IspPgm.exe với biểu tượng như bên dưới: . Chương trình hiện lên giao diện Trước hết bấm vào danh sách sổ (trên hình là ô có chữ "MEGA8"), chọn "89S52" .Bấm vào nút "Open File" để chọn file chương trình (có đuôi".hex"). Sau đó bấm vào "Write" để nạp chương trình cho vi điều khiển. Chú ý: Trước khi nạp cần đảm bảo mạch điện đã được kết nối chính xác đến vi điều khiển. Nếu đã kết nối đúng mà chưa nạp được thì nên rút các mạch giao tiếp...

Chủ đề:
Lưu

Nội dung Text: Tổng quan về vi điều khiển, chương 15

  1. Chương 15: CHƯƠNG TRÌNH NẠP ISP Chương trình chạy không cần cài đặt, khởi động chương trình IspPgm.exe với biểu tượng . Chương trình hiện lên giao diện như bên dưới: Trước hết bấm vào danh sách sổ (trên hình là ô có chữ "MEGA8"), chọn "89S52" .Bấm vào nút "Open File" để chọn file chương trình (có đuôi".hex"). Sau đó bấm vào "Write" để nạp chương trình cho vi điều khiển.
  2. Chú ý: Trước khi nạp cần đảm bảo mạch điện đã được kết nối chính xác đến vi điều khiển. Nếu đã kết nối đúng mà chưa nạp được thì nên rút các mạch giao tiếp ra khỏi P0, rồi thử nạp lại. 3.4 VIẾT CHƯƠNG TRÌNH VÀ BIÊN DỊCH với PINNACLE Nếu bạn chưa có một mạch vi điều khiển thực tế, bạn vẫn có thể thực hành và kiểm tra với sự hỗ trợ của phần mềm mô phỏng vi điều khiển. Phần mềm mô phỏng mô tả lại các trạng thái hoạt động của vi điều khiển khi chương trình được nạp vào vi điều khiển để thực thi. Có nhiều phần mềm mô phỏng vi điều khiển như Workbench, ISIS...Trong bài này, xin giới thiệu cùng các bạn phần mềm viết và mô phỏng PINNACLE. Phần mềm được cung cấp từ website http://www.vaultbbs.com/pinnacle , bạn có thể tải phần mềm tại địa chỉ http://www.codientu.info/soft/ Sau khi cài đặt chương trình đòi hỏi bạn phải đăng kí để sử dụng các tiện ích đầy đủ, thời hạn cho phép sử dụng chương trình là 30 ngày. Tuy nhiên sau 30 ngày đó nếu bạn không đăng kí, chương trình vẫn sử dụng được. Khi khởi động, chương trình hiện lên bảng giới thiệu và lựa chọn đăng kí sử dụng chương trình, chỉ cần bấm vào nút Register Later để bắt đầu sử dụng chương trình.Bạn có thể đăng kí để sử dụng hết tính năng của chương trình này, nếu không đăng kí để sử dụng chương trình, bạn chỉ có thể dịch chương trình dưới 2K. 3.4.1 Soạn thảo và biên dịch Soạn thảo: để soạn thảo chương trình mới, vào menu File/New hoặc tổ hợp phím Ctrl+N
  3. Lưu: sau khi soạn thảo chương trình, lưu chương trình bằng tổ hợp phím Ctrl+S hoặc menu File/Save. Lưu ý: tên của file không quá 8 kí tự và không có khoảng trắng. Biên dịch: sau khi đã lưu chương trình, để biên dịch chọn menu Project/Compile & Link File hoặc tổ hợp phím Ctrl+F2. Chương trình sẽ kiểm lỗi cú pháp, nếu có lỗi chương trình sẽ hiện lên các thông báo lỗi, để trở về sửa chữa các dòng lệnh bị lỗi double click vào dòng thông báo lỗi. Nếu chương trình không có lỗi, máy tính sẽ biên dịch chương trình vừa viết thành mã máy vi điều khiển, mã này được lưu trong file có đuôi là .hex, file này có tên cùng với tên của file soạn thảo và cùng nằm trong một thư mục (Folder). Sau khi biên dịch xong máy hiện thông báo với dòng cuối cùng là Build complete. 0 error(s), 0 warning(s) 3.4.2 Hướng dẫn mô phỏng các trạng thái của vi điều khiển Sau khi biên dịch thành công, nếu có phần cứng, các bạn đổ chương trình vào chip vi điều khiển, chương trình này chứa trong file có đuôi ".hex". Hoặc mô phỏng chương trình trên máy vi tính bằng phần mềm PINNACLE với các thao tác sau: Cách a: - Vào menu Simulator/Load Memory/Code Memory - Chương trình hiện lên hộp thoại: Ở ô Filename to Load chọn đường dẫn đến file có đuôi ".hex" chứa chương trình cần mô phỏng. Hoặc thực hiện các thao tác sau: Cách b: -Vào menu File\Open (hoặc Ctrl+O), chương trình xuất hiện một hộp thoại, trong trình đơn List file of type chọn Intel Hex (*.hex) để mở các file có đuôi *.hex. Tìm file có đuôi *.hex cần mở rồi nhấn nút OK.
  4. Sau khi đã thực hiện cách a hoặc b,vào menu Veiw\Ports (hoặc Ctrl+P) để xem trạng thái của các Port Cuối cùng, để xem các trạng thái của chương trình đã viết, vào menu Execute\Run (hoặc bấm F5 hoặc chọn biểu tượng ). Để ngừng vào menu Execute\Stop (hoặc chọn biểu tượng ) Còn nhiều công cụ khác để hỗ trợ cho quá trình viết chương trình và bảng trạng thái của những phần khác như trạng thái của các thanh ghi Rx, thanh ghi trạng thái .... bạn có thể tự tìm hiểu để biết thêm. Chú ý: vì tốc độ xử lí của phần mô phỏng nhanh hơn của vi điều khiển với thạch anh 12MHz rất nhiều nên các trạng thái xảy ra hơi nhanh không quan sát toàn bộ được, do đó để quan sát rõ các trạng thái của các Port bằng chương trình mô phỏng cần viết chương trình sao cho khoảng thời gian giữa các lần xuất tín hiệu ra Port kéo dài hơn.
Đồng bộ tài khoản